DB2 Query Management Facility
Version 12 Release 1

Installing and Managing DB2 QMF for Workstation and DB2 QMF for WebSphere

IBM
Installing and Managing DB2 QMF for Workstation and DB2 QMF for WebSphere
This edition applies to Version 12 Release 1 of IBM DB2 Query Management Facility (QMF) Enterprise Edition, which is a feature of IBM DB2 12 for z/OS (5650-DB2) and IBM DB2 11 for z/OS (5615-DB2). It also applies to Version 12 Release 1 of IBM DB2 QMF for z/OS (5697-QM2), which is a stand-alone IBM DB2 for z/OS tool. This information applies to all subsequent releases and modifications until otherwise indicated in new editions.

© Rocket Software Inc. 1995, 2017
Tables

1. Mapping between iSeries and SQL terminology ................................................. 4
2. Platforms, versions, and executable files supported by QMF for Workstation .... 5
3. QMF applications, components, and features .................................................. 7
4. Methods for uninstalling QMF for Workstation ............................................... 8
5. Java Virtual Machine parameters ..................................................................... 13
6. Binding preferences ......................................................................................... 20
7. The settings that you can import from QMF for Windows ................................. 20
8. Log category names and descriptions ............................................................... 41
9. Configuring repositories and connecting to a database task descriptions .......... 55
10. Property values and corresponding attributes for the serverBidiStringType and clientBidiStringType properties ....................................................... 59
11. Data source types ........................................................................................... 81
12. Conversion of folder objects into the Tables node ......................................... 96
13. Resource limits group schedules ...................................................................... 169
14. Determining resource limits ........................................................................... 188
15. AUDIT_VIEW ................................................................................................. 210
16. AUDIT_RECORDS ........................................................................................... 211
17. EVENT TYPES .............................................................................................. 212
18. EVENT_CATEGORIES .................................................................................... 212
19. EVENT_RESULTS ........................................................................................... 212
20. EVENT_OBJECT_TYPES table structure ....................................................... 212
21. QUERY TYPES ............................................................................................. 213
22. AUDIT_RECORDS_SQL table structure ......................................................... 213
About this information

This information contains details about the QMF™ for Workstation and QMF for WebSphere® Administrator applications. The information includes instructions for:

- Installing QMF for Workstation applications
- Installing QMF for WebSphere applications
- Using QMF for Workstation Administrator to configure a repository
- Using QMF for WebSphere Administrator to configure a repository
- Setting up resource limits to control resource usage

Specific changes since the previous edition of this book are indicated by a vertical bar (1) to the left of a change. Editorial changes that have no technical significance are not noted.

Always check the DB2® and IMS™ Tools Library page for the most current version of this publication:

www.ibm.com/software/data/db2imstools/db2tools-library.html

Who should read this information

This information is intended for the person that is responsible for configuring and maintaining the DB2 QMF query and reporting tool set, which consists of the following applications:

- QMF for Workstation
- QMF for Workstation Administrator
- QMF for WebSphere
- QMF for WebSphere Administrator

The administrator of the DB2 QMF query environment should have a working knowledge of:

- DB2
- QMF
- Workstation operating systems
- WebSphere

This information is not intended for users.

Service updates and support information

To find service updates and support information, including software fix packs, PTFs, Frequently Asked Questions (FAQs), technical notes, troubleshooting information, and downloads, refer to the following Web page:

IBM Software Support website

1. Throughout this information, the IBM® QMF client for WebSphere Application Server is referred to as QMF for WebSphere and the IBM QMF client for Workstation environment is referred to as QMF for Workstation.
Chapter 1. Planning to install

Before you install QMF, review the system requirements and understand the differences between QMF for Workstation and QMF for WebSphere.

Overview

QMF for Workstation Administrator and QMF for WebSphere Administrator are both part of the DB2 QMF query and reporting tool set for IBM’s DB2 relational database management system.

These two administrative applications are used to configure and manage the query environment for the following applications:

- **QMF for Workstation** which is an Eclipse-based, rich client desktop application, that provides querying, reporting and Business Intelligence (BI) solution development and execution capabilities.
- **QMF for WebSphere** which is a Java-based Web application that delivers a substantial subset of the QMF for Workstation capabilities using a pure HTML, thin-client deployment model. QMF for WebSphere is capable of running on a variety of operating systems, delivering this thin-client, HTML-based experience to users via a variety of web browsers across a number of platforms.

Managing the query environment

The QMF for Workstation Administrator and the QMF for WebSphere Administrator applications are used to perform the administrative tasks that enable the users of the QMF for Workstation and QMF for WebSphere applications to access data.

The tasks the administrator might perform are as follows:

- Configuring JDBC drivers
- Creating repositories
- Connecting to repositories
- Configuring data source information
- Setting up resource limits to control resource consumption and user actions
- Monitoring the performance of your query environment

In most instances, a single user is responsible for performing the necessary administrative tasks for QMF for Workstation and QMF for WebSphere users. The QMF administrator can choose to perform the administrative tasks using QMF for Workstation Administrator or QMF for WebSphere Administrator.

Administrators can configure every feature that is available in the application using QMF for Workstation Administrator. Administrators can configure the most

---

2. Eclipse is an open source community whose projects are focused on providing an extensible development platform and application frameworks for building software. Eclipse provides extensible tools and frameworks that span the software development lifecycle, including support for modeling, language development environments for Java™, C/C++, PHP and others, testing and performance, business intelligence, rich client applications and embedded development. A large, vibrant ecosystem of major technology vendors, innovative start-ups, universities and research institutions and individuals extend, complement and support the Eclipse Platform. The Eclipse Foundation is a not-for-profit, member supported corporation that hosts the Eclipse projects. Full details of Eclipse and the Eclipse Foundation are available at www.eclipse.org.
widely used feature set using QMF for WebSphere Administrator. There are some features that cannot be configured using QMF for WebSphere Administrator.

**QMF for Workstation system requirements**

Before installing QMF for Workstation ensure that your environment meets the following minimum requirements.

**Hardware requirements**

Each workstation on which QMF for Workstation runs should accommodate the following minimum requirements:

- Hardware configuration that supports Windows
- Minimum of 1 GB of disk space
- Minimum of 1 GB of RAM

**Software requirements**

QMF for Workstation can run on any of the following operating systems:

- Microsoft Windows 7
- Microsoft Windows 8
- Microsoft Windows 8.1
- Microsoft Windows 10
- Microsoft Windows Server 2008
- Microsoft Windows Server 2012

**Database servers**

QMF for Workstation supports the following database servers:

- IBM DB2 LUW
- IBM DB2 for z/OS
- IBM BigSQL
- Microsoft SQL Server
- MySQL
- IBM Netezza
- Oracle Database
- PostgreSQL
- Red Brick
- SolidDB
- Teradata

**Prerequisites**

The following QMF for Workstation functions have software dependencies:

- Database connectivity requires an appropriate JDBC driver for each type of RDBMS that is accessed.
- Exporting result sets to Microsoft Excel requires a minimum level of Excel 2003.
  
  If you are running a pre-2003 version of Microsoft Excel, the **Export to Excel** feature is not supported.
QMF for WebSphere system requirements

Before installing QMF for WebSphere, ensure that your environment meets the following minimum requirements.

Hardware requirements

- Hardware configuration that supports IBM WebSphere V8.5.5 or V9.0 or Apache Tomcat 7 or 8
- Minimum of 500 MB disk space
- Minimum of 1 GB of RAM on each server in which it is installed and an additional 50 MB of RAM for each concurrent user

Software requirements

QMF for WebSphere has the following software requirements:

- One of the following application servers:
  - WebSphere Application Server V8.5.5 or WebSphere Application Server V9.0 using Java 8.
  - Apache Tomcat V7.0 or V8.0 using Java 8.
- One of the following Web browsers (with JavaScript support enabled) on each client:
  - Google Chrome browser V50.0.2661.102 or later
  - Mozilla Firefox V47.0.1 or later
  - Microsoft Edge V25.10586.0.0 or later
  - Microsoft Internet Explorer V10 or later
  - Apple Safari browser V9.0.3 or later

Database servers

QMF for WebSphere supports the following database servers:

- IBM DB2 LUW
- IBM DB2 for z/OS
- IBM BigSQL
- Microsoft SQL Server
- MySQL
- IBM Netezza
- Oracle Database
- PostgreSQL
- Red Brick
- SolidDB
- Teradata

Prerequisites

The following QMF for WebSphere functions have software dependencies:

- Database connectivity requires an appropriate JDBC driver for each type of RDBMS that is accessed.
- Exporting result sets to Excel requires a minimum level of Excel 2003.
If you are running a pre-2003 version of Excel, the **Export to Excel** feature is not supported.

**iSeries terminology**

QMF for Workstation and QMF for WebSphere use SQL terminology, which, in some cases, is different than iSeries terminology.

The following table lists iSeries system terms and corresponding SQL relational database terms. For more information, refer to *DB2 for iSeries Database Programming*.

*Table 1. Mapping between iSeries and SQL terminology*

<table>
<thead>
<tr>
<th>iSeries term</th>
<th>SQL term</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Library</strong>: Groups related objects and allows you to find objects by name.</td>
<td><strong>Collection</strong>: Consists of a library, journal, journal receiver, SQL catalog, and, optionally, a data dictionary. A collection groups related objects and allows you to find the objects by name.</td>
</tr>
<tr>
<td><strong>Physical file</strong>: A set of records.</td>
<td><strong>Table</strong>: A set of columns and rows.</td>
</tr>
<tr>
<td><strong>Record</strong>: A set of fields.</td>
<td><strong>Row</strong>: The horizontal part of a table containing a serial set of columns.</td>
</tr>
<tr>
<td><strong>Field</strong>: One or more characters of related information of one data type.</td>
<td><strong>Column</strong>: The vertical part of a table of one data type.</td>
</tr>
<tr>
<td><strong>Logical file</strong>: A subset of fields and records of one or more physical files.</td>
<td><strong>Package</strong>: An object type that is used to run SQL statements.</td>
</tr>
<tr>
<td><strong>User profile</strong></td>
<td><strong>Authorization name or authorization ID</strong></td>
</tr>
</tbody>
</table>
Chapter 2. Installing QMF

Installing QMF involves running the setup executable file to install the QMF for Workstation and, optionally, deploying QMF for WebSphere to an application server.

Note: To check the installation results, see the installation log file in the temporary folder of the user home directory.

Setup executable

QMF for Workstation is implemented as a high performance, Eclipse-based desktop application, combining the portability of Java with the performance of native applications.

The following table lists the QMF for Workstation setup executable file and supported operating systems:

A self-contained installation package is available for each of the following supported platforms:

| Table 2. Platforms, versions, and executable files supported by QMF for Workstation |
|---------------------------------|---------------------------------|-----------------------------|
| Operating system | Version | Setup executable file |
| Windows | Server 2008, Server 2012, Vista, 7, 8, 8.1, 10 | setupwin32.exe or setupwin64.exe |

Installing QMF for Workstation

To install QMF for Workstation, run the appropriate setup executable on the target operating system and follow the installation prompts. Upon completion of the installation, it is recommended that you apply the latest available fix packs.

About this task

QMF installation package includes 3 .iso files:

CD1 Contains the setupwin32.exe file, readme files, and the Notices and Information file.

CD2 Contains the setupwin64.exe file, readme files, and the Notices and Information file.

CD3 Contains the installation files for QMF for WebSphere, QMF Data Server Administrative Console, and QMF Vision and the Notices and Information file.

This topic describes how to run the setup process to install QMF. It assumes you have downloaded the QMF setup executable file to your computer. It provides information about the properties and values you can set during the installation process.
During installation you will specify license information and where to install the product. You will also select which the feature set (Administrator, User or both) to install.

You can stop the installation at time by clicking Cancel.

**Procedure**

1. Go to the directory where you have downloaded setup executable file.
2. Run the setup executable file to begin the installation. The installer program prepares the product for installation.
3. On the Introduction panel, read the recommendations and description of the installation process and click Next.
4. On the License Agreement panel, read the licensing terms and select I accept the terms of the License Agreement to proceed with the installation. Click Next.

   **Note:** If you select I do not accept the terms in the license agreement, the installation process stops.

5. On the Choose Install Folder panel, select Choose to specify the directory where QMF will be installed or accept the default destination. Click Next.

   - Select Typical if you want to install the workstation application, all of its components and features and download the QMF for WebSphere application files.

     For a description of the applications, components, and features, see QMF applications, components, and features.

   - If you want to install particular components, select Custom and choose from the applications, components, and features listed in the panel beneath the Install Set field.

   If you selected specific applications and components to install and you then want to revert to the options of typical installation, select Typical from the Install Set drop-down list.
Table 3. QMF applications, components, and features

<table>
<thead>
<tr>
<th>Application</th>
<th>Components and features</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QMF for Workstation</td>
<td>• QMF for Workstation User.</td>
<td>QMF for Workstation includes a User component and an Administrator component.</td>
</tr>
<tr>
<td></td>
<td>• QMF for Workstation Administrator</td>
<td>Select the component that suits your role and the manner in which you will</td>
</tr>
<tr>
<td></td>
<td>• Support for OLAP and XMLA data sources</td>
<td>use the application. For example,</td>
</tr>
<tr>
<td></td>
<td>Select this feature to download the files that will allow users to create and edit</td>
<td>• Select the QMF for Workstation</td>
</tr>
<tr>
<td></td>
<td>multidimensional queries.</td>
<td>User component if your intention is use the application on your own</td>
</tr>
<tr>
<td></td>
<td>• Support for Virtual Data Sources</td>
<td>personal workstation.</td>
</tr>
<tr>
<td></td>
<td>Select this feature to download the files that will allow administrators to create and edit</td>
<td>• Select the QMF for Workstation</td>
</tr>
<tr>
<td></td>
<td>virtual data sources.</td>
<td>Administrator component if your intention is to create product</td>
</tr>
<tr>
<td></td>
<td>• Support for Data Source Environments</td>
<td>configuration that will be made available to multiple users across the</td>
</tr>
<tr>
<td></td>
<td>Select this feature to download the files that will allow administrators to create and</td>
<td>enterprise and to administer that configuration on behalf of the enterprise</td>
</tr>
<tr>
<td></td>
<td>edit Data Source Environments.</td>
<td>users. Administrators use this component to grant user access to</td>
</tr>
<tr>
<td></td>
<td>• Translated Help Systems</td>
<td>repositories and define resource limits. It should be installed only for</td>
</tr>
<tr>
<td></td>
<td>Select the help systems that you want to install in addition to the English help system</td>
<td>those users who will be allowed to perform these tasks.</td>
</tr>
</tbody>
</table>

QMF Data Service Studio | A Typical installation includes QMF Data Service Studio. You can choose not to install it. | QMF for Workstation and QMF for WebSphere allow you to work with tables     |
|                       |                                                                                          | provided by QMF Data Service. QMF Data Service Studio is installed as a     |
|                       |                                                                                          | separate application for configuring QMF Data Service.                      |

6. Select where to create product icons and click **Next**.
7. On the Pre-Installation Summary panel, review the summary information.
   • If you want to make changes, click **Previous** until you reach the panel that contains values that you want to change.
   • If you are satisfied with your selections, click **Install** and complete the installation.

**Results**

You have successfully installed QMF
If you selected QMF Data Service Studio from the installation wizard, the application is installed into a separate directory inside the QMF for Workstation root directory.

After completing the installation successfully, you are ready to configure the product for use.

**Installing a fix pack**

This topic describes how install a fix pack of the QMF for Workstation application.

**About this task**

You use the same steps to install a fix pack as you do to install the original application. The application must not be uninstalled before the new fix pack can be introduced. When the fix pack executable file is run, the existing installation of QMF for Workstation is automatically updated. For specific steps, see “Installing QMF for Workstation” on page 5.

**Important**: For Arabic and Hebrew languages, to avoid problems with the application installation, remove previous fix pack and install the current fix pack over QMF for Workstation Version 12.1.

**Note**: For every fix pack that you install, if you implement repository or QMF catalog protection using static SQL packages, you must rebind them. When you download the fix pack executable, check the accompanying readme file for steps on how to rebind your existing static SQL packages.

**Uninstalling QMF for Workstation**

The following table lists ways to uninstall QMF for Workstation.

<table>
<thead>
<tr>
<th>Table 4. Methods for uninstalling QMF for Workstation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Method</td>
</tr>
<tr>
<td>Run the uninstaller manually</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Uninstall from the Start menu</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Uninstall from the Control Panel</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Reverting to an earlier fix pack**

This topic describes how to revert to a previous fix pack of the QMF for Workstation application.
**About this task**

If it is necessary to revert back to a previous fix pack, the same steps that you use to install a new fix pack apply. The existing installation does not have to be uninstalled. When the fix pack executable is run, the existing installation of QMF for Workstation is automatically updated. For specific steps, see “Installing QMF for Workstation” on page 3.

**Note:** As with installing a new fix pack, if you implement repository or QMF catalog protection using static SQL packages, it might be necessary to rebind them. When you download the fix pack executable, check the accompanying readme file for steps on how to rebind your existing static SQL packages.

---

**Deploying QMF for WebSphere to the application server**

The installation media includes an Enterprise Archive (EAR) file and a Web Archive (WAR) file that can be immediately deployed to your web application server using your server’s administration console.

**Obtaining the QMF for WebSphere installation file**

The QMF for Workstation installation media includes the files that are used to install QMF for WebSphere.

The files are the QMF for WebSphere Enterprise Archive (EAR) file and the QMF for WebSphere Web Archive (WAR) file. You can obtain these files from the C03 folder of the QMF installation package. You can keep the files local or copy them to a WAS server machine.

**Opening the WebSphere Administrative Console**

Start the WebSphere Administrative Console by opening a web browser on a client machine, and entering the appropriate URL.

By default, the URL is http://host:port/ibm/console, where host is the host name of the WAS server and port is the port on which the Administrative Console is configured to listen (9060, by default).

**Installing the new application**

Follow this procedure to install the new application.

**About this task**

In the navigation tree on the left side of the Administrative Console window:

**Procedure**

1. Expand **Applications**.
2. Click **Install New Application**. The Preparing for the application installation page displays on the right side of the Administrative Console window.
3. On the first Preparing for the application installation page, specify the location of the QMF for WebSphere EAR file that you want to install.
   - If the QMF for WebSphere EAR file is on the local machine, click **Local file system**. Use the **Browse** button to search for and locate the file.
   - If the file is on the WAS server machine, click **Remote file system**. Use the **Browse** button to search for and locate the file.
4. When you install using the QMF for WebSphere EAR file, the default context root for the application is always QMFWebSphere121. If for some reason you need to specify an alternate context root for the application, you must use the QMF for WebSphere WAR file for installation, enter the alternate context root in the Context root field, and follow the prompts to complete the installation.

5. Click Next. The second Preparing for the application installation page opens.

6. Click Generate Default Bindings.

7. Click Next. The Step 1: Select Installation options page opens.

8. Verify that the Deploy Web Services check box is clear and click Next. The Step 2: Map modules to servers page opens.

9. Accept the default values and click Next. The Step 3: Map virtual hosts for Web modules page opens.

10. Note the name of the application server listed for the QMF for WebSphere module and click Next. The Step 4: Map security roles to users/groups page opens.

11. Specify whether you will map a security role named qmfadmin for the QMF for WebSphere application. If you have WebSphere security enabled, you must map at least one user ID to this role. The qmfadmin role is used to authenticate a user before performing various administrative tasks in QMF for WebSphere, such as binding packages. Use this page to specify whether the role should be mapped to all users (effectively eliminating authentication for the role), to all authenticated users (allowing any authenticated user to perform QMF administration functions), or only to users or groups that you specify.

12. Click Next.

13. Review the summary page that lists the options that you have chosen and click Finish.

14. After WAS has finished installing the application, save the configuration. You will receive a message dialog informing you of the progress of the installation and that the installation of the application is complete. The Enterprise Applications page opens.

15. Click Save to Master Configuration and click Save.

Configuring access to JDBC drivers

The last element of configuration that you must perform using the WebSphere Administrative Console is to provide access to any JDBC drivers that will be used by QMF for WebSphere.

About this task

In the navigation tree on the left side of the Administrative Console window:

Procedure

1. Expand Servers.

2. Click Application Servers. The Application Servers page displays on the right side of the Administrative Console window.

3. In the displayed list of application servers, click the application server where you installed the QMF for WebSphere application. The properties of the application server are displayed.

5. For z/OS®️, in the **ProcessType** list, click **Servant**. The Process Definition page displays.

6. In the **Additional Properties** list, click **Java Virtual Machine**. The Java Virtual Machine page displays.

7. In the **Classpath** list, add all of the *.zip or *.jar files that are required by the JDBC drivers that will be used by QMF for WebSphere. For example, for the DB2 Universal Database™️ V8 Type 4 driver on Microsoft Windows, you might enter:

   C:\Program Files\ibm\SQLLib\Java\db2jcc.jar
   C:\Program Files\ibm\SQLLib\Java\db2java.zip
   C:\Program Files\ibm\SQLLib\Java\sqlj.zip

   For the Type 4 driver on z/OS you might enter:

   /usr/lpp/db2810/jcc/classes/db2jcc.jar
   /usr/lpp/db2810/jcc/classes/db2jcc_license_cisuz.jar
   /usr/lpp/db2810/jcc/classes/db2jcc javax.jar
   /usr/lpp/db2810/jcc/classes/sqlj.zip

8. For non-z/OS platforms, you can skip to Step 11. For z/OS, you must specify a list of directories that contain the native code libraries used by the JDBC driver. Return to **Servers** and select **Custom Properties** from the **Additional Properties** list. The Custom Properties page displays.

9. Click the **New** button. The Configuration page opens.

10. In the **General Properties** list, specify the library path name in the **Name** field as **LIBPATH** and specify the directories list in the **Value** field. For example, in the **Value** field you might specify:

    /usr/lpp/db2810/jlib
    /usr/lpp/db2810/jcc/jlib

11. When you have finished adding the required files, click **OK** and save the configuration. After the configuration is saved, you must restart the server for the changes to take effect.

### Starting the application

Follow this procedure to start the new application.

**About this task**

In the navigation tree on the left side of the Administrative Console window:

**Procedure**

1. Expand **Applications**.
2. Click **Enterprise Applications**. The Enterprise Applications page displays on the right side of the Administrative Console window.
3. In the displayed list of installed applications, select the check box next to QMF for WebSphere.
4. Click **Start**. The application is now available.

**Accessing the application**

Upon completion, you should be able to access QMF for WebSphere using one of the following URLs (assuming the use of the suggested context root of QMFWebSphere121)

URL to launch QMF for WebSphere application:

http(s)://[server]:[port]/[ContextRoot]/user
For example: http://www.ibm.com:9080/QMFWebSphere121/user

URL to launch QMF for WebSphere Administrator application:

http(s)://[server]:[port]/[ContextRoot]/admin

For example: http://www.ibm.com:9080/QMFWebSphere121/admin

Completing the installation

The final steps to installing QMF for WebSphere are to set up JDBC driver library information, configure repositories, and set up repository connection information.

About this task

The QMF for WebSphere administrator is virtually identical to the QMF for Workstation administrator. However, if you have installed QMF for WebSphere on the same system as QMF for Workstation, the two applications have different configuration files (located in the user's Application Data folder). You must take direct action to register JDBC drivers and define repositories for both QMF for Workstation and QMF for WebSphere.

You can configure your new installation of QMF for WebSphere in two ways:

Procedure

1. Use the QMF for WebSphere application to configure drivers and repositories. (See Chapter 3, “Configuring the environment,” on page 15 for more information).
2. Configure the drivers and repositories using QMF for Workstation and then copy the .bi.jdbc.drivers and repositories.xml files from the application data location on the workstation to the equivalent application data location on the web server.

Customizing Java Virtual Machine system properties and files

You can specify Java Virtual Machine system properties and files for saving the QMF for Workstation/WebSphere system properties and files, especially when you configure a cluster to share application settings and other folders among cluster nodes and to set a timeout for a user session.

About this task

By default, all QMF for Workstation/WebSphere system properties and files are stored in the user home directory, the path to which is in the user.home Java Virtual Machine system property. But you can use qmf.instance.area.global, qmf.instance.area.shared, or qmf.instance.area Java Virtual Machine system properties to customize the directories for storing files.

If you want to specify a timeout for a user session to close the session when a user do not work with application, use the qmf.use.session.timeout parameter.

The following table describes the available parameters.
Table 5. Java Virtual Machine parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Stored files</th>
</tr>
</thead>
</table>
| qmf.instance.area.global      | This property is responsible for the folder that is distributed among several cluster nodes. It is used to store server configuration files, scheduled tasks, and personal repositories. If this parameter is not set, the settings from the qmf.instance.area are applied. | • Repository connections data (repositories.xml)  
• JDBC drivers properties (.bi.jdbc.drivers)  
• License files  
• Cache files |
| qmf.instance.area.shared      | This property is responsible for the application folder that is shared among several cluster nodes. If this parameter is not set, the settings from the qmf.instance.area are applied.            | • Log files  
• Session data:  
  – User settings  
  – User global variables  
  – Logins and passwords |
| qmf.instance.area             | This property is responsible for storing temporary files. If this parameter is not set, the settings from the java.io.tmpdir Java Virtual Machine system property are applied.                     | • Temporary files                                                                                   |
| qmf.use.session.timeout       | This property is responsible for the timeout of a user session. If it is set to true, the user session is closed after the HTTP session timeout that is specified on the server. If this parameter is set to false or not defined, the session is active until the user closes the application. | -                                                                                                 |

To specify particular paths for saving system properties and files:

**Procedure**

1. For QMF for Workstation
   a. In the application installation directory, open the eclipse.ini file.
   b. Add the parameters the value of that you want to customize with the -D prefix and specify the path for the new storage. For example, 
      -Dqmf.instance.area=C:\work\ 
   c. Save the eclipse.ini file.
2. For QMF for WebSphere:
   a. Start the WebSphere Administrative Console by opening a web browser on a client machine, and entering the appropriate URL.
   b. Navigate to the **Process definition** and, in the **Custom properties** for Java Virtual Machine, add the required properties qmf.instance.area.global, qmf.instance.area.shared, qmf.instance.area, or qmf.use.session.timeout depending on the parameters that you want to modify.
   c. Save the added parameters.
Chapter 3. Configuring the environment

Configuring the environment for QMF for Workstation and QMF for WebSphere involves a number of administrative steps.

This chapter provides an overview of the administrative tasks. It is intended to provide you with an understanding of the broad concepts before you configure the environment. The administrative tasks include:

1. Setting up the connection data needed to access the relational data sources in your enterprise:
   - Providing the location of the JDBC driver files that will be used to access the relational data sources in your enterprise
   - Creating a direct connection using DRDA®

2. Creating a repository within which data source definitions and authored content will reside

3. Defining the means by which users will connect to your repository, thereby gaining access to your configured data sources and QMF content.

Configuring JDBC Drivers

QMF for Workstation and QMF for WebSphere use JDBC drivers to connect to relational data sources. The product is already preloaded with the configuration information for each of the popular JDBC drivers (DB2, Informix®, Oracle, MySQL, SQL Server, Derby). However, the product does not include the actual JDBC driver files. Administrators must define the location of the JDBC driver files in order for QMF for Workstation and QMF for WebSphere to load and use the driver. You only need to define the location of the driver files for those database types that you intend to access using the QMF products.

Using DRDA to connect to relational data sources: Depending on your environment, you can use DRDA to connect directly to relational data sources.

Defining a repository

Prior versions of QMF for Workstation and QMF for WebSphere used a Server Definitions File (SDF) to store the location of data sources accessible within the QMF products. In recent releases, the SDF has been replaced by a content repository. The repository offers the following key improvements over the older SDF approach:

- The repository is not limited to storing data source (server) definitions. It is capable of storing all content created within the QMF products, including queries, forms, reports, dashboards, result sets and scheduled tasks. This is particularly useful when creating content that executes against non-DB2 data sources, where storage within a QMF catalog is not appropriate.
- The repository has the ability to tailor the environment of a given QMF user. For example, queries, reports and dashboards can be routed to use US-based data sources for North American users and European data sources for European users. This mapping of data sources is done dynamically, without the need to change the underlying QMF objects.
• Similarly, the repository has the ability to tailor the presentation of QMF objects on a per user or regional basis. Business users can be presented with a set of folders arranged in business terms whereas technical users may retain a database-centric tree of available objects.

Repositories are stored within a relational database of your choosing. Similar to a QMF catalog, they consist of a set of tables, accessible via stored procedures or static SQL packages. You may choose to place the repository tables in the same database as your production data or within a stand alone database created specifically for repository use. The repository is essentially a structured form of the SDF file, with additional capabilities. As such, it can be adequately served by a distributed database such as DB2 on LUW, Informix, Oracle, SQL Server or MySQL.

Repositories can also be given an optional security model. If you elect to use repository security, you have the additional ability to control the repository content on a per user and group basis. For example, users in group A may see data sources A, B and C whereas users in group B see data sources A, D and E. Permissions can be applied to all QMF objects, including queries, forms, procedures, dashboards and individual workspace folders.

If you elect to use repository security, you may use one of the following methods:
• LDAP/Active Directory: QMF uses an external Active Directory or LDAP-based service to authenticate the user and obtain the user and group listings.
• Database security: QMF uses the user's database logon as the basis of the security model. This approach is equivalent to the QMF catalog security model.
• Internal security: Users and groups can be defined directly within QMF itself.

QMF also supports personal repositories. A personal repository is stored within the QMF built-in database engine. This type of repository is intended for individual use, providing a means of storing content on a local workstation without the need for a relational database.

**Defining the means by which users connect to your repository**

Once your repository has been created, your final step involves creating the connection information that QMF for Workstation and QMF for WebSphere will use to connect to the repository. Once this connection has been defined, you are ready to distribute the configuration information with the installation of QMF for Workstation. Users that install the product will then be immediately connected to your repository when they open the software.

**Distributing your configuration settings with the installation program**

Once you have finished configuring your environment, you are ready to make it available to your users. Your final steps include:
1. Defining the data sources in the repository that will be accessible to QMF users.
2. Distributing the configuration information with the setup program.
3. Copying the configuration information to QMF for WebSphere.

If you are using JDBC to connect to the database repositories and data sources, you must specify where QMF will find the JDBC driver files for each type of database that will host a repository or be accessed as a data source.
“Using DRDA to connect to database repositories and data sources” on page 60
You can use the Direct DRDA Connection to establish a connection to DB2 database repositories and data sources.

Chapter 10, “Creating a shared repository storage,” on page 63
A shared repository storage is a set of database tables. You must create a shared repository storage for storing database connection and resource limit information, as well as the database objects that users will use for reporting and querying actions.

“Adding repositories to the repository storage tables” on page 70
You can add repositories to the repository storage tables. Repositories serve as a centralized place in which an aggregation of data, such as queries, procedures, forms, dashboards, and, reports are developed for a specific set of data sources. Each repository that you create can have its own independent objects, security models, and users.

Chapter 12, “Data sources,” on page 81
As an administrator, you create data sources to store database connection information.

Chapter 16, “Creating the repository connection for QMF,” on page 129
QMF needs to know how to access the application data (as grouped by the repository name) so that users will have access to this data. The way to provide this connection data to QMF is to create it using the QMF connection wizard.

Chapter 18, “Exporting the configuration data to users,” on page 147
QMF administrators are responsible for ensuring that the application executable, the JDBC JAR files, a populated JDBC driver information file, and a populated repository connection information file are available to each machine that is running QMF for Workstation and to each server (or workstation) that is running QMF for WebSphere.
Chapter 4. Importing relational data source information from QMF for Windows

You can add relational data source information to a repository from an existing server definition file by using the Import QMF for Windows Configuration Settings wizard.

**About this task**

The Import QMF for Windows Configuration Settings wizard opens automatically the first time you launch QMF for Workstation. Also you can open the wizard by selecting File > Import > QMF for Windows Configuration Settings.

**Note:** Data sources in QMF for Windows Version 8.1 and QMF for WebSphere Version 8.1 and prior were referred to as servers in the SDF.

To import the related data source information from QMF for Windows:

**Procedure**

1. Select the settings and preferences that you want to import on the first page of the Import QMF for Windows Configuration Settings wizard.

2. Select **Import the content of the last used server definition file**, and then select whether to add the related data source information to a new personal repository or to the current repository. Click Next.

   **Note:** If you are running QMF for Workstation for the first time, the current repository option is not available. If you select the new personal repository option, the repository created will have the same name as the server definition file from which you are importing content. If a repository with this name already exists or if the name contains restricted symbols, you are prompted to enter a unique and valid name.

3. To add user authentication information and search filter settings, select **Import server-related information** check box.

4. Specify the server definition file on the second page of the Import QMF for Windows Configuration Settings wizard. The default path to the server definition file is specified automatically. If the server definition file is not located in the default path, specify the correct path in the File path field.

5. Select encoding type from the **Encoding** list. If encoding is correct, you can view the contents of the specified file in the preview area.

6. If required, prepare configuration packages by selecting **Bind Packages**, and then click Next.

7. Select the server whose settings you want to edit from the **Servers Found** list. Each of the servers that are defined in the server definition file are displayed in the list.

8. To modify the connection parameters to the selected server, edit the **Alias**, **URL** and **Driver** fields. If you selected **Bind Packages**, click Next to proceed. Otherwise, click **Finish** to complete the import process.

9. Review the list of data sources for which you want to bind packages in the QMF Catalog table.
10. Specify the settings for package binding. Some settings are specified by default. The following table lists the default values:

Table 6. Binding preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Default value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collection ID for Packages</td>
<td>QMF11</td>
</tr>
<tr>
<td>Grant permission on packages</td>
<td>PUBLIC</td>
</tr>
<tr>
<td>Database username and Database password</td>
<td>Authorization parameters are imported from the selected server definition file. Note: Selecting several data sources with different authorization information can cause problems.</td>
</tr>
</tbody>
</table>

11. Click Finish and wait until the import process is complete.

QMF for Windows settings

QMF for Windows settings can be imported to QMF for Workstation.

The following table lists the QMF for Windows settings that you can import by using the Import QMF for Windows Configuration Settings wizard.

Table 7. The settings that you can import from QMF for Windows

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>To view in QMF for Windows</th>
<th>To view in QMF for Workstation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Favorites</td>
<td>The contents of the Favorites folder</td>
<td>Open Database Explorer tree</td>
<td>Open Personal view</td>
</tr>
<tr>
<td>Recently used objects</td>
<td>The list of recently used objects</td>
<td>Open Database Explorer tree</td>
<td>Open Personal view and Repository Explorer view</td>
</tr>
<tr>
<td>Global variables</td>
<td>The list of global variables</td>
<td>Select View &gt; Global Variables</td>
<td>Select View &gt; Preferences &gt; Global variables</td>
</tr>
<tr>
<td>Saved join definitions</td>
<td>The list of joins that are added automatically on the basis of information about the tables that you have ever joined in Prompted or Query Builder editors.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export preferences</td>
<td>The settings for exporting query result and export report type to a file or database.</td>
<td>Select Results &gt; Save to File or Results &gt; Save to Database</td>
<td>Select File &gt; Export</td>
</tr>
<tr>
<td>LOB options</td>
<td>LOB object settings</td>
<td>Select View &gt; Options &gt; LOBs</td>
<td>Select View &gt; Preferences &gt; LOBs</td>
</tr>
<tr>
<td>Grid options</td>
<td>The default font properties, formatting options, cell colors and other grid settings</td>
<td>Select Results &gt; Font and Results &gt; Format</td>
<td>Select Results &gt; Font and Results &gt; Format</td>
</tr>
<tr>
<td>Page setup settings</td>
<td>The page settings that are used for printing</td>
<td>Select File &gt; Page Setup</td>
<td>Select File &gt; Page Setup</td>
</tr>
<tr>
<td>User interface settings</td>
<td>The user interface settings such as language, default font and null values display options</td>
<td>Select View &gt; Options &gt; General and View &gt; Options &gt; Appearance</td>
<td>Select View &gt; Preferences &gt; General and View &gt; Preferences &gt; Appearance</td>
</tr>
<tr>
<td>Command bar history</td>
<td>The history of commands entered in command bar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setting</td>
<td>Description</td>
<td>To view in QMF for Windows</td>
<td>To view in QMF for Workstation</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
<td>---------------------------</td>
<td>-------------------------------</td>
</tr>
</tbody>
</table>
| Server - related settings | User authentication information and search filter settings  
**Note:** Availability depends on the Import the content of the last used server definition file option. | | |

Table 7. The settings that you can import from QMF for Windows (continued)
Chapter 5. Considerations for configuring the product and environment

There are several things to consider before configuring the product.

This section provides an overview of the administrative tasks to help you understand of the broad concepts prior to starting the configuration process.

1. Setting up the connection data needed to access the relational data sources in your enterprise:
   • Providing the location of the JDBC driver files that will be used to access the relational data sources in your enterprise
   • Creating a direct connection using DRDA

2. Creating a repository within which data source definitions and authored content will reside

3. Defining the means by which users will connect to your repository, thereby gaining access to your configured data sources and QMF content.

Connecting to relational data sources

Using JDBC to connect to relational data sources: You can use JDBC drivers to connect to relational data sources. The product is already preloaded with the configuration information for each of the popular JDBC drivers (DB2, Informix, Oracle, MySQL, SQL Server, Derby and so on). However, the product does not include the actual JDBC driver files. Administrators must define the location of the JDBC driver files in order for QMF for Workstation and QMF for WebSphere to load and use the driver. You must define the location of the driver files for those database types that you intend to access using the QMF products.

Using DRDA to connect to relational data sources: Depending on your environment, you can use DRDA to connect directly to relational data sources.

Defining a repository

Prior versions of QMF for Workstation and QMF for WebSphere used a Server Definitions File (SDF) to store the location of data sources accessible within the QMF products. In recent releases, the SDF has been replaced by a content repository. The repository offers the following key improvements over the older SDF approach:

• The repository is not limited to storing data source (server) definitions. It is capable of storing all content created within the QMF products, including queries, forms, reports, dashboards, result sets and scheduled tasks. This is particularly useful when creating content that executes against non-DB2 data sources, where storage within a QMF catalog is not appropriate.

• The repository has the ability to tailor the environment of a given QMF user. For example, queries, reports and dashboards can be routed to use US-based data sources for North American users and European data sources for European users. This mapping of data sources is done dynamically, without the need to change the underlying QMF objects.
• Similarly, the repository has the ability to tailor the presentation of QMF objects on a per user or regional basis. Business users can be presented with a set of folders arranged in business terms whereas technical users can retain a database-centric tree of available objects.

Repositories are stored within a relational database of your choosing. Similar to a QMF catalog, they consist of a set of tables, accessible via stored procedures or static SQL packages. You can choose to place the repository tables in the same database as your production data or within a stand alone database created specifically for repository use. The repository is essentially a structured form of the SDF file, with additional capabilities. As such, it can be adequately served by a distributed database such as DB2 on LUW, Informix, Oracle, SQL Server or MySQL.

Repositories can also be given an optional security model. If you elect to use repository security, you have the additional ability to control the repository content on a per user and group basis. For example, users in group A can see data sources A, B and C whereas users in group B see data sources A, D and E. Permissions can be applied to all QMF objects, including queries, forms, procedures, dashboards and individual workspace folders.

If you elect to use repository security, you can use one of the following methods:
• LDAP/Active Directory: QMF uses an external Active Directory or LDAP-based service to authenticate the user and obtain the user and group listings.
• Database security: QMF uses the user’s database logon as the basis of the security model. This approach is equivalent to the QMF catalog security model.
• Internal security: Users and groups can be defined directly within QMF itself.

QMF also supports personal repositories. A personal repository is stored within the QMF built-in database engine. This type of repository is intended for individual use, providing a means of storing content on a local workstation without the need for a relational database.

**Defining the means by which users connect to your repository**

Once your repository has been created, your final step involves creating the connection information that QMF for Workstation and QMF for WebSphere will use to connect to the repository. Once this connection has been defined, you are ready to distribute the configuration information with the installation of QMF for Workstation. Users that install the product will then be immediately connected to your repository when they open the software.

**Distributing your configuration settings with the installation program**

Once you have completed the above administration steps, your QMF environment is ready for use. Your final steps include:
1. Defining the data sources in the repository that will be accessible to QMF users.
2. Distributing the configuration information with the setup program.
3. Copying the configuration information to QMF for WebSphere.
Using the Quick Start wizard to configure repositories and connect to the database

You can use the Quick Start wizard to configure the QMF for Workstation for first time use or personal use and perform the following tasks:

1. Define JDBC driver libraries;
2. Define and establish repository connections;
3. Add data sources.

For information about using the Quick Start wizard, see Using the Quick Start wizard to configure repositories and connect to the database.
Chapter 6. Overview

Administrators configure QMF so users can access the data sources needed to create queries, reports, and visual dashboards.

Generally, configuration tasks are performed by the Administrator from QMF Administrator component. The Administrator component consists of a variety of views, perspectives, and editors to facilitate the process. For description of the views, perspectives, and editors, see Perspectives, Views, and Editors in the Product overview help.

Configuring QMF can be divided into the following tasks:

- Setting up repositories and connecting to the database
  This involves the following sub-tasks:
  - Defining the JDBC driver library
  - Configuring the repository storage
  - Creating the repository
  - Defining the connection to the database
- Populating repositories with the data sources, workspaces, and environments that define how users interact with data and determine what is exposed to the users in the QMF User component.
  This involves the following sub-tasks:
  - Creating virtual data sources
  - Setting up workspaces
  - Creating entity relationship (ER) diagrams
  - Setting up environments
- Setting permissions for accessing data
  This activity involves the following sub-task:
  - Assigning users and groups permission to use repository objects
- Managing resources and usage
  QMF provides administrators with the capability to optimize usage by setting up and managing resource limits.
  Managing resources and usage involves the following tasks:
  - Setting up data source resource limits
  - Creating resource limits groups
  - Setting up group schedules
  - Assigning users to resource limits groups

After configuring QMF, the administrator creates a repository connection, which provides users with access to the data.

Using QMF for Workstation versus QMF for WebSphere to create the configuration

You can configure QMF for multiple users by using either the QMF for WebSphere Administrator component or the QMF for Workstation Administrator component.
The method you choose to configure QMF is a matter of preference. The following diagrams illustrate both methods.

**Application Server**

1. Start QMF for WebSphere in your web browser.
2. Using the Administrator component, complete the configuration steps for a shared configuration.
3. Provide users with URL.

**File Server**

1. Using the Administrator component, configure QMF for Workstation on your workstation.
   
   The result of completing the configuration steps is an updated `repositories.xml` file and an updated `.bi.jdbc.drivers` file.

2. Put the installer executable (or silent installation options file) on a shared file server and use the QMF for Workstation **File** > **Export** feature to export a `settings.xml` file with the repository connection and JDBC driver information to the shared file server.
   
   For information about creating a `response file` for a silent installation, see Creating a silent installation options file.

3. Users access the shared directory in the file server and install QMF for Workstation by running the installer GUI or the silent installation.
   
   When users run the installer, the configuration data in the `settings.xml` file is applied to the installed application. As a result, when users start QMF, they are connected to a repository and have access to the data sources as determined by the Administrator’s configuration.

---

**Figure 1. Using QMF for WebSphere to configure QMF for multiple users**

1. Start QMF for WebSphere in your web browser.
2. Using the Administrator component, complete the configuration steps for a shared configuration.
3. Provide users with URL.

**Figure 2. Using QMF for Workstation to configure QMF for multiple users**

1. Using the Administrator component, configure QMF for Workstation on your workstation.
   
   The result of completing the configuration steps is an updated `repositories.xml` file and an updated `.bi.jdbc.drivers` file.

2. Put the installer executable (or silent installation options file) on a shared file server and use the QMF for Workstation **File** > **Export** feature to export a `settings.xml` file with the repository connection and JDBC driver information to the shared file server.
   
   For information about creating a `response file` for a silent installation, see Creating a silent installation options file.

3. Users access the shared directory in the file server and install QMF for Workstation by running the installer GUI or the silent installation.
   
   When users run the installer, the configuration data in the `settings.xml` file is applied to the installed application. As a result, when users start QMF, they are connected to a repository and have access to the data sources as determined by the Administrator’s configuration.
Chapter 7. Setting preferences

The Preferences dialog is used to set user preferences that will apply to specific QMF objects and functions.

The Preferences window consists of two panes. The left pane displays the list of preferences groups and the right pane displays the page for the selected group. The following groups of preferences are displayed in the Preferences window.

Setting general preferences

You use the General page of the Preferences window to specify the language, orientation direction, locale settings, and object default actions.

About this task

To specify the general user preferences for the current QMF application interface session:

Procedure

1. Select View > Preferences. The Preferences window opens. Select General from the tree.
2. Conditional: If available as an option on the Preferences window, select from the Language drop-down list of supported languages the language that will be used for the current application interface session. Select the value Auto to use the local language of the current machine.
3. Select from the Locale setting for numbers, currencies, times, and dates drop-down list the language that will be used to display numbers, currencies, times and dates in the current QMF application interface session. Select the value Auto to use the local language of the current machine.
4. Click one of the Default Action for Objects radio buttons to specify the action that QMF will perform when you double-click an object that is included in an explorer tree. Select Run object to run the object that is selected. Select Display object to display the SQL content of the object.
5. In the Default Tab for the Query Editor area, you can specify the tab on which the Visual Query Editor is opened by default for a new query.
6. Click the Line width ellipsis (...) or enter the value of the maximum line width.
   The available values for line width are from 10 to 1000. The default value is 79.
   This value is used in the Query menu item Reformat Text for SQL text. Additionally, the value specified in the Line width field:
   • Controls the maximal line length in the DDL scripts, which are displayed when you create or update repository storage or QMF catalogs.
   • Controls the maximal line length in the DDL scripts that are produced when you run the Export Update Scripts wizard.

Note: The Export Update Scripts wizard provides users with the capability to upload the DDL to a mainframe data set and run it in the z/OS.
environment. Using the **Line width** field you can ensure the data sets meet the limitation requirement of 72 characters per line.

7. Select the **Convert rollover time** check box if you want QMF to allow Java to convert and express 24 hour rollover time as the next day. For example, if you select the check box, Java converts `2012-01-01:24:00:00` to `2012-01-02:00:00:00`. The converted format is displayed by QMF in the result sets and visual projects.

Clear the **Convert rollover time** check box if you want QMF to preclude Java from converting and expressing the 24 hour rollover time as the next day. If you clear the check box, QMF uses the timestamp value saved in the database.

**Note:** The **Convert rollover time** feature applies only if you are using a DRDA connection with a DB2 database.

8. Select the **Always run in background** check box to perform long running operations displayed in the **Progress** dialog in the background without blocking you from doing other work.

9. Select the **Always run objects by clicking the Results tab** check box to run QMF objects automatically when you click the Results tab in the editor for the first time.

10. Click **Apply** to save your preferences choices.

11. Click **Restore Defaults** to restore the default preference values.

12. Click **OK** to close the Preferences window.

### Setting Acceleration preferences

Use the Acceleration page of the Preferences window to specify the query acceleration settings.

**About this task**

To set the acceleration preferences, complete the following procedure:

**Procedure**

1. From the main menu, select **View > Preferences**. The Preferences window opens.
2. On the left side of the window, click **Acceleration**.
3. To be able to override the acceleration options that were specified for your resource limits group by the administrator, select the **Override acceleration options if possible** check box on the right side of the screen.

**Note:** The settings from this page are applied only if the following conditions are met:

- The **Acceleration options can be overridden** check box is selected in the resource limits for the current data source.
- The object that you are running does not have specified resource limits or if the **Acceleration options can be overridden** check box is selected in the object resource limits.

4. Click the **Enable acceleration** check box and specify the acceleration type:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NONE</td>
<td>Specifies that no queries are sent to an accelerator server.</td>
</tr>
</tbody>
</table>
### Setting appearance preferences

You use the Appearance page of the Preferences window to specify default fonts, color scheme, and strings for displaying and entering special values. On the page, you can also select saving custom window size.

#### About this task

To set the appearance preferences:

#### Procedure

1. Select **View > Preferences**. The Preferences window opens. Select **Appearance** from the tree.
2. In the **Default Fonts** area, define the font type for headings and columns of query results, classic reports.
3. Specify a string in the **Display null values as** field that QMF will use to display null values that are retrieved from a database data source.
4. Specify a string in the **Enter null values as** field that you will use when you enter null values in the query results or in database tables using the table editor.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENABLE</td>
<td>Specifies that queries are accelerated only if the database determines that it is advantageous to do so. If an accelerator failure occurs while a query is running or if the accelerator returns an error, database returns a negative SQLCODE to the application.</td>
</tr>
<tr>
<td>ENABLE WITH FAILBACK</td>
<td>Specifies that queries are accelerated only if the database determines that it is advantageous to do so. If the accelerator returns an error during the PREPARE or first OPEN command for the query, the database executes the query without the accelerator. If the accelerator returns an error during a FETCH or a subsequent OPEN command, the database returns the error to the user and does not execute the query.</td>
</tr>
<tr>
<td>ELIGIBLE</td>
<td>Specifies that queries are accelerated if they are eligible for acceleration. Queries that are not eligible for acceleration are executed by the database. If an accelerator failure occurs while a query is running or if the accelerator returns an error, the database returns a negative SQLCODE to the application.</td>
</tr>
<tr>
<td>ALL</td>
<td>Specifies that queries are accelerated if they are eligible for acceleration. Queries that are not eligible for acceleration are not executed by the database, and an SQL error is returned. If an accelerator failure occurs while a query is running or if the accelerator returns an error, the database returns a negative SQLCODE to the application.</td>
</tr>
</tbody>
</table>
5. Specify a string in the **Enter default values as** field that you will use when you enter default values in the query results or in database tables using the table editor.

6. Select from the **Color scheme in text editors** drop-down list what type of color scheme will be supported in the text editors. In most instances you will choose QMF to specify that the default color schemes used by the text editors are acceptable. If you will be working in high contrast mode, you will have to select **system default**.

7. If you use a high definition display, select the **Display large icons** check box in the **Icon Size** area to double the size of all the icons.

8. If you customize the size and position of the windows in the application and want to save these changes, in the **Window Size** area, select **Save custom window size and position** check box. To revert your changes, clear the check box.

9. Click **Apply** to save your preferences choices.

10. Click **Restore Defaults** to restore the default preference values.

11. Click **OK** to close the Preferences dialog box.

### Setting the audit system

Use the Audit page of the Preferences window to enable and configure the audit system for QMF.

**About this task**

To enable and configure the audit system:

**Procedure**

1. From the main menu, select **View > Preferences**.
2. On the left side of the window, select **Audit**.
3. Select the **Enable audit** check box.
4. To set the audit system to record only failed events, select the **Record failed events only** check box.
5. In the **Backup interval (days)** field, specify a time interval to define how often database backup files are created.

   **Note:** After backup files are created, the original database is cleared.

6. In the **Delete all backup files older than (days)** field, specify an age for database backup files to be deleted.

7. Select the **Record SQL statements for users** check box to set the audit system to record SQL statements made by users for queries against the database.
   - Select **All Users** to record SQL statements made by all users.
   - Click the **Specify Users...** button to open the Data Source Users dialog and specify particular users. Click **OK** to accept the changes or **Cancel** to leave the dialog without saving the changes.

8. Click **Apply** to apply the settings and remain on the page or click **OK** to apply the settings and close the window.

**Results**

After audit is enabled, all information that is gathered by the audit system is saved to the tables under the **AUDIT** schema in an H2 database. This database is created in
the application data folder. The summarized information from all the tables is presented in the AUDIT_VIEW table. For information about reading audit records, see Chapter 27, “Using the audit system,” on page 209.

Setting dashboard runtime preferences

You use the Dashboard Runtime page of the Preferences dialog to specify the Google Map API key.

About this task

To specify the dashboard runtime user preferences for the current QMF application interface session:

Procedure

1. Select View > Preferences. The Preferences window opens. Select Dashboard Runtime from the tree.
2. Set values for the Dashboard Runtime: You can obtain the Google Map APIs from the Google Code web site.
   - In the Google Maps JavaScript API key field, specify the Google Maps JavaScript API key to enable the usage of the Google Map layout object in visual dashboards in the HTML5 rendering mode.
   - You can obtain the Google Maps JavaScript APIs from the Google Developers web site.
   - Set the Display null values as to specify how null values are displayed in the dashboards.
3. Click Apply to save your preferences choices.
4. Click Restore Defaults to restore the default preference values.
5. Click OK to close the Preferences window.

Setting SMTP and email preferences

You use the Email page of the Preferences window to specify the list of available SMTP servers and email notifications from the application.

About this task

The following topics describe how to specify SMTP server preferences and to set email notifications from scheduled tasks:

Setting SMTP server preferences

You use the SMTP area of the Preferences window to specify the list of available SMTP servers.

About this task

Defining parameters for commonly used SMTP servers in the SMTP area saves users from having to specify these parameters every time they need to send an email message by using these servers. For example, if the SMTP server password is expired, you just need to change it once in the SMTP area instead of updating authorisation information for every object that uses this SMTP server.

The servers listed in the SMTP area can be used in the following procedures:
- Adding a Send Mail action to a Visual Project
- Sending email messages by using the File > Send to command
- Sending email messages by using the MAIL TO procedure command.

To specify SMTP server preferences:

**Procedure**
1. Select View > Preferences to open the Preferences window. Select Email from the tree and navigate to the SMTP area.
2. Add a new server to the list by clicking Add Server.
3. In the SMTP window specify SMTP server parameters including its name, address and port number.
4. Optional: If the SMTP server requires authentication, select Use SMTP authentication, and then specify user name and password in the User and Password fields.
5. Optional: If it is necessary to specify additional access preferences, click Advanced to open the Advanced SMTP Settings window where you can add required keywords supported by javamail1. Click OK.
6. Click OK to close the SMTP window and then click Apply to save your preferences choices.

   **Tip:** Select or clear the Enabled check box to control the SMTP settings globally.

7. Optional: If you need to restore default preferences, click Restore Defaults.
8. Click OK to close the Preferences window.

**Specifying email notification preferences**

You can globally configure a list of email notifications with debug information, which are sent for failed scheduled tasks. This information can be useful for fast fixing the problems with scheduled tasks.

**Before you begin**

**Note:** For remote tasks the preferences must be specified on the web server.

**About this task**

To configure an email notification:

**Procedure**
1. Select View > Preferences to open the Preferences window. Select Email from the tree.
2. In the Email Notifications area, click Add Notification to add a configuration for sending notifications.
3. In the Email Notification Settings window, type the name for the notification in the Name field.
4. In the Message Properties area, specify the following settings:
   - Select the format of the body text from the Format list. The available formats are Text and HTML.
   - The address to that the email must be sent in the To field.
   - The address to that a carbon copy of the email must be sent in the Cc field.
• The address from that the email must be sent in the From field.

5. To specify SMTP server parameters, click SMTP Settings. In the SMTP Settings window, specify whether to use the server that is predefined by administrator or a custom one.
   a. If you decide to use a predefined SMTP server, select the server from the list of predefined servers or click Add Server to create one.
   b. If you decide to use a custom server, specify server parameters: its address and port number. If the SMTP server requires authentication, select Use SMTP authentication, and then specify user name and password. If it is necessary to specify extra access preferences, click Advanced to open the Advanced SMTP Settings window where you can add keywords that are supported by javamail. Click OK.

Click OK to close the SMTP Settings window.

6. Click OK to save the specified notification settings. The specified notification appears in the Email Notifications area. You can select it for a particular task in the Task List window.

Tip: Select or clear the Enabled check box to control the notifications globally.

---

## Working with global variables

Global variables are variables that stay active while the current session of QMF is active. This is in contrast to substitution variables that are active only during the execution of an object (query, form, procedure).

For objects that use substitution variables, values are entered via a window when the object is run. After the object runs, the variable and the value that you used no longer exists. For objects that use global variables, the value currently defined for the global variable is used.

There are two types of global variables:

- **System global variables** are pre-loaded with the QMF application. That means their values are re-initialized each time you open the QMF application. System global variables begin with the letters DSQQW, DSQAO, DSQEC, DSQDC, and DSQCP. You cannot add or delete system global variables. However, you can edit the default values for the system global variables.

- **User global variables** are defined by the user. User global variables can be specified with any unique name that does not begin with the letters DSQQW, DSQAO, DSQEC, DSQDC, and DSQCP. User global variables values can be available during the current session or permanently.

Using the Global Variables page of the Preferences window you can view, add, delete and edit your user global variables. You can also edit the values of the system global variables.

## Specifying user variables

You use the Global Variables page of the Preferences window to view, add, delete, and edit user global variables.

## About this task

To view, add, edit and delete user defined global variables:
Procedure


2. The system and user global variables that are defined for your session are listed in the Variables list box. The name of the global variable is listed in the Name field. The current value for the global variable is listed in the Value field. The lifetime setting is listed in the Variable Lifetime field.

3. To add a user-defined variable, click the Add button. The New Variable window opens.
   a. In the Name field, type the name of the new user variable
      
      Note: You can type any combination of unique characters that are not used. Do not begin a user variable with the system global variable prefixes of DSQQW, DSQAO, DSQEC, DSQDC, and DSQCP.
   b. Optional: In the Description field, type the text describing the user variable that is displayed in the Description column on the Global Variables page.
   c. In the Value field, type the initial value of the user variable.
   d. In the Variable Lifetime area, select the lifetime for the created variable:
      • If you want the variable to be available for use during the current QMF session, select Current session.
      • If you want the variable to be available persistently, select Permanent. This option is useful when you use the variable in different objects and distribute them among other users.
   e. Click OK.

4. To edit the value of a user variable, click the Value field for the variable that you want to change and type the new value for the variable.

5. To edit the description of the permanent user variables, click the Description field for the variable that you want to change and type the text.

      Note: The description of the current session variable is read-only.

6. To edit the lifetime of a user variable, click the Variable Lifetime field for the variable that you want to change and select the lifetime that you want to apply to this variable.

7. To delete a user variable, select an existing user variable from the Variables list and click the Remove button. The user variable is deleted.

8. Click Apply to save your preferences choices.

9. Click Restore Defaults to restore the default preference values.

10. Click OK to close the Preferences dialog.

Editing system global variable values

You use the Global Variables page of the Preferences dialog to edit any system global variable values.

About this task

To edit system global variable values:

Procedure

2. The system global variables are listed in the Variables list by name. System global variable start with the prefix of DSQQW, DSQAO, DSQEC, DSQDC, or DSQCP.

3. The current system global variable values are listed in the Value field. To edit the value of a global variable, click in the Value field for the system global variable that you want to change. Type the new value for the system global variable in the Value field.

4. Click Restore Defaults to restore the default values for all the system global variables.

5. Click Apply to save your preferences choices.

6. Click OK to close the Preferences window.

---

**Setting help preferences**

If you are using QMF for Workstation, you use the Help page of the Preferences window to specify the default values for how help information is displayed and to change the interface and port specification for the internal server that the help system uses.

**About this task**

To change the web browser adapter setting:

**Procedure**

1. Select View > Preferences. The Preferences window opens. Select Help from the tree.

2. The help system can display information in either the Help view or in a browser. If the help is displayed in a browser, the browser can be an embedded browser or a full external browser. If the embedded browser is supported on your system, help will use it by default to display help. If you prefer to always use a full external browser, select Use external browser from the drop-down list.

3. By default, context-sensitive help for workstation windows is displayed in the Help view. If you prefer to display workstation window context-sensitive help in infopops, select Open window context help in an infopop from the drop-down list.

4. By default, context-sensitive help for dialogs is displayed in the dialog’s tray, which is similar to the Help view. If you prefer to display dialog context-sensitive help in infopops, select Open dialog context help in an infopop from the drop-down list.

5. Click Apply to save your preferences choices.

6. Click Restore Defaults to restore the default preference values.

7. Click OK to close the Preferences window.

---

**Including help content from a remote server**

The help system includes an internal server that serves the help contents to the browser. You use this preference page to change the interface and port that the internal server uses.

**About this task**

You should only change these settings if you experience problems and cannot view help with the default preferences.
To change the interface and port that the help server uses:

**Procedure**

1. Select View > Preferences. The Preferences dialog opens. Expand the Help branch by clicking the plus sign. Select Content from the tree.
2. Select the Include help content from a remote infocenter check box. The Remote Infocenter window becomes available.
3. Click Add. The Add new infocenter window opens.
4. Specify the name of a local IP interface to be used by the server in the Name field.
5. Specify the host of a local IP interface to be used by the server in the Host field.
6. Specify the URL of a local IP interface to be used by the server in the Path field.
7. Select Use port and specify the number of a specific port the server will listen to.
8. Click OK. The Add new infocenter window closes and control returns to the Preferences window. The new infocenter is displayed in the Remote Infocenters window.
10. To delete and infocenter, click Delete. The selected infocenter is removed from the list.
11. To view the properties of a specific infocenter, click View Properties. The Properties for [infocenter name] window opens with the name, host, path, port, and URL displayed.
12. To test an infocenter’s connection to the local IP interface, click Test Connection. The Test Connection window opens displaying the test results.
13. To disable an infocenter without deleting it, click Disable. The infocenter is now disabled, and its status in the Enabled column is changed to disabled.
14. Click Apply to save your preferences choices.
15. Click Restore Defaults to restore the default preference values.
16. Click OK to close the Preferences window.

**Setting JDBC preferences**

You can use the Preferences window to set up the JDBC driver information.

**About this task**

QMF administrators are responsible for distributing the JDBC driver information that users will need in order to access any data source. In most cases, administrators distribute this information by deploying a pre-configured JDBC library settings file when the application interface that you are using is installed.

Advanced users can define or change JDBC driver location information using the JDBC Libraries page of the Preferences window to specify the JDBC driver information for each type of database (such as DB2, Informix, Oracle) that will be accessed. The JDBC driver locations must be accessible to QMF. QMF will retain the JDBC driver information. You would only repeat this specification process to add new drivers or make changes to the properties of an existing driver.
To define JDBC driver information:

**Procedure**

1. Select View > Preferences to open the Preferences window. Select JDBC Libraries. The JDBC Libraries page opens. All of the JDBC drivers and their associated JAR files that you have already set up are listed. They are organized by library.

2. To add new JDBC driver information for a type of database that is not listed, select Add Driver. The Add New Driver Library window opens.

3. The JDBC driver information for each type of database is organized by libraries. Enter a name for the library in the Enter new library name field. It is recommended that the name that you specify describes the JDBC information that will be included in the library. For example, if you are adding JDBC driver information for accessing DB2 databases, you might call the library DB2. However, this is a descriptive field and can include any text.

4. Specify the actual name of the driver class that will be used in the Driver class name field. This can be found in your JDBC driver documentation. For example: com.ibm.db2.jcc.DB2Driver.

5. Optional: Specify a generic example of a correctly formatted URL that could be used to connect to the database in the URL templates field. For example, if you are adding JDBC driver information for accessing DB2 databases, you might specify the following JDBC URL template: jdbc:db2://host:50000/database. The generic information as specified in the template is presented when you are adding data sources to the repository and when you are creating repository connections. You will replace the generic information with the specific database information.

6. If you are using QMF for Workstation, add the location information for the JDBC driver files to the library. Click Add JARS. The Add JARS to libraryname window opens. Search for and select the JDBC driver files that you want to add. Click Open. The location of the JDBC driver files is saved in the JDBC library that you have selected.

7. Click Apply. The JDBC library information that you have specified is saved.

8. You can make the following changes to the JDBC driver information:
   - To edit the JDBC driver library information, select an existing JDBC driver library from the list and click Edit. The Edit Driver Library window opens where you can make changes to the Library name, Driver class name, and JDBC URL template fields.
   - If you are using QMF for Workstation, to edit the name and location of the files that contain the JDBC drivers, select a file from the list of files that have been added to the JDBC library, and click Edit. The Edit JAR URL window opens. Specify the name and location in the Edit JAR location field.
   - To remove a JDBC driver library, select an existing JDBC driver library from the list and click Remove. The library, including all the JAR files that it contains, is removed.
   - If you are using QMF for Workstation, to remove a JAR file from a JDBC driver library, select an existing file from the list and click Remove. The file is removed.

9. Click OK. The JDBC library information is saved. The Preferences window closes. You must repeat this process for each type of JDBC driver that will be used to access various database data sources such as Informix or SQL Server.
Setting LOB preferences

You use the LOBs page of the Preferences dialog to specify options that will control retrieving and saving LOB data.

About this task

LOB data (Large Object data) is large text or binary objects in a database. LOBs can be large strings of text, images, and so on. If a query result set contains a large amount of LOB data, processing resources could be severely strained. The LOB preferences page contains a number of LOB data retrieval restrictions that you can use to manage repository resources. To specify LOB data preferences:

Procedure

1. Select View > Preferences. The Preferences window opens. Select LOBs from the tree.

2. Check Override LOB options if possible to grant yourself the ability to override the LOB options that have been specified by your QMF administrator for your resource limits group. Your administrator must have given your resource limits group permission to override the LOB options. If you do not have permission to override LOB options, this check box is not available.

3. Use the LOB Retrieval Option radio buttons to specify how large object data (LOB) will be retrieved. There are four choices:
   - Select Disable LOB columns to disable LOB data retrieval. By selecting this option, you will not be able to query any table that contains LOB data.
   - Select Disable LOB data retrieval to disable LOB data retrieval but allow access to the other columns in the tables that contain LOB data. By selecting this option, you can query tables that contain LOB data and result data for all columns except those that contain LOBs will be returned.
   - Select Retrieve LOB data on demand to specify that you want to retrieve all LOB data from a table but only display selected columns of the LOB data in the query results. By selecting this option, you can query tables that contain LOB data and your result data will be returned for all columns that contain LOB objects. To conserve resources, however, the retrieved LOB data is stored in a file. Pointers (<LOB LOCATOR>) to the LOB data objects are displayed in the query results. You click the pointer to view the LOB data. You can also pull the data from the database by double-clicking on the pointer.
   - Select Retrieve LOB data automatically to specify that you want to retrieve all LOB data from a table and immediately display the retrieved LOB data in the query results. This option pulls ALL of the LOB data for ALL of the LOB columns from the database to the local computer. The actual LOB data is not displayed in grids and reports. Instead, pointers to the LOB data are displayed. This option can potentially consume a large amount of resources on the local computer.

4. Use the LOB Saving Option radio buttons to specify whether you can save large object data (LOB). There are two choices:
   - Select Disable LOB data to disable saving LOB data on a database data source.
   - Select Enable LOB data to allow saving LOB data on a database data source.
5. Specify the maximum size of a LOB column in the **Maximum LOB column size** field. You specify the size in kilobytes, up to 2G (the maximum LOB size). The default is 0, which specifies there is no maximum size. If you query a table with LOB data that is larger than the maximum, the LOB data will not be returned for display.

6. Click **Apply** to save your preferences choices.
7. Click **Restore Defaults** to restore the default preference values.
8. Click **OK** to close the Preferences window.

### Setting log preferences

You use the Log page of the Preferences window to activate a log file that will track QMF processing information.

#### About this task

The log file information can be useful in debugging.

To specify the log file preferences for the QMF session:

**Procedure**

1. Select **View > Preferences**. The Preferences window opens. Select **Log** from the tree.
2. Check **Enable log** to activate the log file for debugging purposes. If this check box is selected, the log file option fields are enabled. Check one or more of the log file options to indicate what information should be gathered. It is recommended that all options remain checked. The available log file options are as follows:
   - Print stack trace for log exceptions
   - Print report to log file
   - Print log class and method
3. Click **Apply** to save your preferences choices.
4. Click **Restore Defaults** to restore the default preference values.
5. Click **OK** to close the Preferences window.

### Example

**Table 8. Log category names and descriptions.**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>log</td>
<td>This is a root category.</td>
</tr>
<tr>
<td>log.api</td>
<td>This category logs messages or exceptions related to API calls. The information from Java Class API is added to this category.</td>
</tr>
<tr>
<td>log.api.qmfwin</td>
<td>This category logs messages or exceptions related to QMF API calls.</td>
</tr>
<tr>
<td>log.cache</td>
<td>This category logs exceptions and messages of query results cache.</td>
</tr>
<tr>
<td>log.calculator</td>
<td>This category logs the work of the calculator which is used in visual projects.</td>
</tr>
<tr>
<td>log.canvas</td>
<td>This category logs messages and exceptions related to canvas.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>log.config</td>
<td>This category logs the reading or writing configuration information.</td>
</tr>
<tr>
<td>log.context_service</td>
<td>This category logs the service of repository contexts.</td>
</tr>
<tr>
<td>log.database</td>
<td>This category logs the database access operations and the work with a database.</td>
</tr>
<tr>
<td>log.database.common_errors</td>
<td>This category logs miscellaneous errors that occur on the database access layer.</td>
</tr>
<tr>
<td>log.database.connection_pool_ex</td>
<td>This category logs the work of database connection pool.</td>
</tr>
<tr>
<td>log.database.connections</td>
<td>This category logs the information on the connection management.</td>
</tr>
<tr>
<td>log.database.descriptors</td>
<td>This category logs the server descriptors information.</td>
</tr>
<tr>
<td>log.database.drda</td>
<td>This category logs the work of DB2 DRDA driver.</td>
</tr>
<tr>
<td>log.database.driver</td>
<td>This category logs JDBC drivers messages and records the JDBC library loader.</td>
</tr>
<tr>
<td>log.database.driverloader</td>
<td>This category logs the information from JDBC driver libraries class loader. It is used together with log.database.driver.</td>
</tr>
<tr>
<td>log.database.edit</td>
<td>This category logs the table editing operations.</td>
</tr>
<tr>
<td>log.database.jdbc</td>
<td>This category logs the execution of dynamic SQL queries.</td>
</tr>
<tr>
<td>log.database.sqlj</td>
<td>This category logs the execution of static SQL packages and stored procedures.</td>
</tr>
<tr>
<td>log.design_view</td>
<td>This category logs messages and exceptions related to design view.</td>
</tr>
<tr>
<td>log.displayMode</td>
<td>This category logs messages and exceptions related to display modes in analytical queries.</td>
</tr>
<tr>
<td>log.displayMode.chart</td>
<td>This category logs messages and exceptions related to the chart display mode.</td>
</tr>
<tr>
<td>log.displayMode.scenario</td>
<td>This category logs messages and exceptions related to drill-down paths.</td>
</tr>
<tr>
<td>log.environment</td>
<td>This category logs environment information of the application.</td>
</tr>
<tr>
<td>log.exception</td>
<td>This category logs the appearing exceptions.</td>
</tr>
<tr>
<td>log.export</td>
<td>This category logs messages and exceptions related to export to Excel.</td>
</tr>
<tr>
<td>log.forecast</td>
<td>This category logs messages and exceptions related to forecasts.</td>
</tr>
<tr>
<td>log.formula</td>
<td>This category logs messages and exceptions related to formulas used in calculated columns.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>log.grid</td>
<td>This category logs the runtime exceptions and messages related to query results grid.</td>
</tr>
<tr>
<td>log.importer</td>
<td>This category logs the information of the import operations.</td>
</tr>
<tr>
<td>log.install</td>
<td>This category logs the installation process of stored procedures.</td>
</tr>
<tr>
<td>log.install.customizer</td>
<td>This category logs package customization. It is proper for DB2 systems only, as it logs the work of the external SQL profiles in the process of the customization.</td>
</tr>
<tr>
<td>log.job_scheduler</td>
<td></td>
</tr>
<tr>
<td>log.js</td>
<td>This category logs messages and exceptions related to all JavaScript features.</td>
</tr>
<tr>
<td>log.js.js Metadatalayer</td>
<td>This category logs messages and exceptions related to JavaScript tables.</td>
</tr>
<tr>
<td>log.js.js Modules</td>
<td>This category logs messages and exceptions related to JavaScript modules.</td>
</tr>
<tr>
<td>log.js.js Procedures</td>
<td>This category logs messages and exceptions related to JavaScript procedures.</td>
</tr>
<tr>
<td>log.legacy converter</td>
<td>This category logs runtime exceptions and messages for utilities that convert legacy objects into visual projects when they are imported.</td>
</tr>
<tr>
<td>log.license</td>
<td>This category logs product licenses related runtime exceptions and messages.</td>
</tr>
<tr>
<td>log.limits</td>
<td>This category logs the runtime exceptions and messages related to resource limits.</td>
</tr>
<tr>
<td>log.limits.editor</td>
<td>This category logs the runtime exceptions and messages related to resource limits editor.</td>
</tr>
<tr>
<td>log.mailer</td>
<td>This category logs messages and exceptions that are related to sending the data from the application by email.</td>
</tr>
<tr>
<td>log.messages</td>
<td>This category logs messages displayed to users.</td>
</tr>
<tr>
<td>log.metadatalayer</td>
<td>This category logs the general functionality of Virtual data sources.</td>
</tr>
<tr>
<td>log.metadatalayer.optimize</td>
<td>This category logs the optimization system of Virtual data sources.</td>
</tr>
<tr>
<td>log.metadatalayer.scheduling</td>
<td>This category logs the work of a scheduler for Virtual data sources.</td>
</tr>
<tr>
<td>log.olap_core_logger_category</td>
<td>This category logs the work of XMLA queries and XMLA editor.</td>
</tr>
<tr>
<td>log.procedureDesigner</td>
<td>This category logs messages and exceptions that are related to the work with procedures in design mode.</td>
</tr>
<tr>
<td>log.prompt_hierarchy</td>
<td>This category logs messages and exceptions related to prompt hierarchies.</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>log.prompts</td>
<td>This category logs messages and exceptions related to prompts.</td>
</tr>
<tr>
<td>log.qmf</td>
<td>This category logs QMF objects issues.</td>
</tr>
<tr>
<td>log.qmf.command_processor</td>
<td>This category logs procedure information.</td>
</tr>
<tr>
<td>log.queryEngine</td>
<td>This category logs runtime exceptions and messages related to the query.</td>
</tr>
<tr>
<td>log.queryEngine.localQueryEngine</td>
<td>This category logs runtime exceptions and messages for the local part of query.</td>
</tr>
<tr>
<td>log.queryEngine.localQueryEngine.localQEWarnings</td>
<td>This category logs runtime exceptions and messages related to the warnings in resource limits.</td>
</tr>
<tr>
<td>log.queryEngine.localQueryEngine.storedProcedures</td>
<td>This category is not used.</td>
</tr>
<tr>
<td>log.queryEngine.remoteQEServer</td>
<td>This category logs server related runtime exceptions and messages for the remote part of query.</td>
</tr>
<tr>
<td>log.queryEngine.remoteQEServer.QERequestResponseServer</td>
<td>This category logs requests and responses between remote and local parts of a query in case of network or web-service connection.</td>
</tr>
<tr>
<td>log.quick_report</td>
<td>This category logs messages and exceptions related to quick reports.</td>
</tr>
<tr>
<td>log.report designer</td>
<td>This category logs the events of visual projects in design mode.</td>
</tr>
<tr>
<td>log.reporter</td>
<td>This category logs the exceptions and messages appearing in the visual projects module.</td>
</tr>
<tr>
<td>log.reporter.reporter_data_cache</td>
<td>This category logs the cache work of query results in visual projects.</td>
</tr>
<tr>
<td>log.reporter.reporter_flash_viewer</td>
<td>This category logs the module that processes the connections from mobile devices (for example, iPad).</td>
</tr>
<tr>
<td>log.reporter.reporter_maps</td>
<td>This category logs the map data in Visual Projects.</td>
</tr>
<tr>
<td>log.reporter.reporter_queries</td>
<td>This category logs the work with queries in visual projects.</td>
</tr>
<tr>
<td>log.reporter.reporter_runtime</td>
<td>This category logs runtimes evaluation in visual projects.</td>
</tr>
<tr>
<td>log.reporter.reporter_runtime.reporter_canvas</td>
<td>This category logs the runtimes evaluation of canvas.</td>
</tr>
<tr>
<td>log.reporter.scene_views</td>
<td>This category logs messages and exceptions related to the scene views feature.</td>
</tr>
<tr>
<td>log.repository</td>
<td>This category logs repository runtime exceptions and messages and covers both repository and functions that use this repository.</td>
</tr>
</tbody>
</table>
Table 8. Log category names and descriptions. (continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>log.rsbi</td>
<td>It logs all operations, in case a particular category cannot be determined, log data is written to this category.</td>
</tr>
<tr>
<td>log.runtime</td>
<td>This category logs the exceptions caused by work with UI and user messages.</td>
</tr>
<tr>
<td>log.scheduler</td>
<td>This category logs messages and exceptions related to Scheduler.</td>
</tr>
<tr>
<td>log.security</td>
<td>This category logs messages and exceptions related to secured repository providers.</td>
</tr>
<tr>
<td>log.service</td>
<td>This category logs internal application services and utility issues.</td>
</tr>
<tr>
<td>log.show_message</td>
<td>This category logs messages from Show Message action in visual projects.</td>
</tr>
<tr>
<td>log.statistics</td>
<td>This category is used only as a container.</td>
</tr>
<tr>
<td>log.statistics.queryEngine</td>
<td>This category logs statistics of the time spent on separate blocks of a query execution process.</td>
</tr>
<tr>
<td>log.tracking</td>
<td>This category logs exceptions and messages related to object tracking.</td>
</tr>
<tr>
<td>log.transformation</td>
<td>This category logs messages and exceptions related to query transformations.</td>
</tr>
<tr>
<td>log.transformation.complex</td>
<td>This category logs messages and exceptions related to complex transformations.</td>
</tr>
<tr>
<td>log.transformation.simple</td>
<td>This category logs messages and exceptions related to simple transformations.</td>
</tr>
<tr>
<td>log.ui</td>
<td>This category logs user interface operations.</td>
</tr>
<tr>
<td>log.value</td>
<td>This category logs only the value runtime exceptions and messages in visual projects.</td>
</tr>
<tr>
<td>log.web.ide</td>
<td>This category logs the messages and exceptions that are related to the launch of QMF for WebSphere and its work.</td>
</tr>
</tbody>
</table>

Setting output preferences

You can use the Output page of the Preferences window to activate the Output view that tracks the information about errors, queries, procedures, and connections in QMF.

About this task

The information from the Output view can be useful for debugging. It can be delivered as a report in the Output view and automatically added to the log file.

To specify the output file preferences for the QMF session:

Procedure

1. Select View > Preferences. The Preferences window opens. Select Output from the tree.
2. On the Output page, you can specify the following options:
   
   **Show errors**
   This option displays all error texts in the Output view.
   
   **Show query text**
   This option displays all texts of the run queries in the Output view.
   
   **Show procedure text**
   This option displays all texts of the run procedures in the Output view.
   
   **Show connection status**
   This option displays the statuses of connections to data sources in the Output view.
   
   **Show debug messages for JavaScript features**
   This option displays debug messages for all JavaScript features: JavaScript procedures, JavaScript modules, and JavaScript tables.
   
   **Automatically activate Output view**
   When an error occurs or a message appears, this option automatically opens the Output view.

3. Click **Apply** to save your preferences choices.
4. Click **Restore Defaults** to restore the default preference values.
5. Click **OK** to close the Preferences window.

---

### Setting QMF Data Service preferences

Use the QMF Data Service page of the Preferences window to specify the general settings for QMF Data Service data sources.

**About this task**

To set the general settings for QMF Data Service data sources, complete the following procedure:

**Procedure**

1. From the main menu, select **View > Preferences**. The Preferences window opens.
2. On the left side of the window, click **QMF Data Service**.
3. In the **Connection timeout (secs)** field, specify the time interval to wait for the connection with the server to be established.
4. In the **Operation timeout (secs)** field, specify the time interval to wait for operations to run.
5. To shift the password symbols to upper case for the connection to the server, select the **Shift password to upper case** check box.
6. Click **OK**.

**Results**

You set the general preferences for QMF Data Service data sources.

### Setting driver preferences

Use the Driver page of the Preferences window to specify the driver settings for QMF Data Service data sources.
About this task

To set the driver preferences, complete the following procedure:

Procedure

1. From the main menu, select View > Preferences. The Preferences window opens.
2. On the left side of the window, expand QMF Data Service and click Driver.
3. In the Connection overrides field, type one or more parameters and their values that you want to insert into the JDBC URL that the application uses to connect to the server. The specified values override the default values of the parameters. Consider the following example: HOST=<host_name>; PORT=<port_number>. Here, you specify that you want to connect to the <host_name> server and use the <port_number> port. If you leave the field blank, the JDBC URL is generated automatically.
4. Click OK.

Results

You set the driver preferences for QMF Data Service data sources.

Setting SSL preferences

Use the SSL page of the Preferences window to specify the SSL certificates settings for QMF Data Service data sources.

About this task

To set the SSL certificates settings for QMF Data Service data sources, complete the following procedure:

Procedure

1. From the main menu, select View > Preferences. The Preferences window opens.
2. On the left side of the window, expand QMF Data Service and click SSL.
3. To enable the use of SSL certificates, select the Enable the use of SSL certificates for QMF Data Service check box.
4. In the Communication with Server area, select the protocol that you want to use for communication between the application and the server.
5. In the Server Authentication area, select the authentication strategy that you want to use.
   - If you want all server certificates to be authenticated, select Require server validation.
   - If you want to allow the use of self-signed server certificates, select Allow self-signed certificate.
   - If you want to allow the use of all certificates, select Trust all certificates.
6. If you choose the Require server validation or the Allow self-signed certificate strategy, you must specify the necessary information in the fields in the Server Authentication area.
   a. In the Truststore field, specify the path to the file that contains the server certificate signed by the certification authority or a self-signed server certificate.
   b. In the Password field, type the password for the truststore file.
c. From the Type list, select the type of your truststore file.

7. To enable the client authentication by the server, click Enable client authentication and type the necessary information in the fields in the Client Authentication area.
   a. In the Keystore field, specify the path to the file that contains the client certificate signed by the certification authority or a self-signed client certificate.
   b. In the Password field, type the password for the keystore file.
   c. From the Type list, select the type of your keystore file.
   d. Click Refresh and select the appropriate item from the Alias list.

8. Click OK.

Results

You set the SSL preferences for QMF Data Service data sources.

---

Setting the directory location preference for objects generated by Export actions

You can set preferences in QMF so that objects generated from various QMF actions are exported to a specific location on either the local file system or the server file system.

Before you begin

If you are using QMF for Workstation, create a folder on the local file system.

If you are using QMF for WebSphere, create a folder on application server file system.

When you set the Server-Side File System preference, you will point to one of these folders.

About this task

This task describes how to specify (through preference settings) the location to which generated objects will be exported.

To set the export directory preference:

Procedure

1. Select View > Preferences and select Server-side File System from the tree.
2. Select the Enable access to the server file system check box.
3. Type the path in the Root output directory field to indicate where generated objects will be exported.
   When data and objects are generated by the EXPORT procedure, scheduled tasks (Copy or Execute object) or by event actions such as Export to PDF and Export to Excel, they will be exported to path you specify.
   The directory you specify must exist on either the local file system or on the server file system.
4. Type the path in the Root input directory field to indicate the path of the root directory for dynamart source files.
Note: You need to specify a Root input directory path, otherwise the settings are incorrect, and the EXPORT using server-side file system will yield an error.

5. Click Apply to save your preferences.
6. To restore preferences to the default values, click Restore Defaults.
7. Click OK to close the Preferences window.

---

### Setting third party library preferences

You use the Third-Party Libraries page of the Preferences window to specify the location of any third-party software that is required by QMF.

#### About this task

To specify the third party library preferences:

#### Procedure

2. The third-party software whose location has been defined to QMF is listed by name, package name and location. In most instances, the location information for third party libraries is specified when QMF is installed.
3. To add additional location information for third party software, click Add. The New Third-Party Library window opens. Specify the path to the software in the Path field. If applicable, specify the packages name in the Packages (optional) field. Click OK. The path to the software is added to the Third party library list. Control returns to the Preferences window.
4. To edit the location information for defined third party software, select Edit. The Edit Library dialog opens. You can change the path to the selected software in the Path field. You can change the packages name in the Packages (optional) field. Click OK. The changes that you have made are applied. Control returns to the Preferences window.
5. To remove third party library information, click the third party library in the Third party libraries list and click Remove. The third party library information is removed from the list.
6. Click Apply to save your preferences choices.
7. Click Restore Defaults to restore the default preference values.
8. Click OK to close the Preferences window.

---

### Specifying virtual data source preferences

You use the Virtual Data Source page of the Preferences window to enable the automatic cache refresh option for virtual data sources.

#### About this task

For detailed information on how to enable automatic cache refresh for virtual data sources, see the Enabling automatic refresh for virtual data source cache topic of Administrator Help.
Specifying Visual Designer preferences

If you are using QMF for Workstation, you use the Visual Designer page of the Preferences window to specify preferences that will effect the creation of visual projects.

About this task

To specify the preferences that will effect the creation of visual projects:

Procedure


2. Click one of the Visual Designer Ruler Unit radio buttons to specify the default units that will be used for the ruler that spans the editor window in the Visual Designer perspective. Your choices are pixels, inches, or centimeters.

3. Select a formatting schema for date values of a classic report in the Formatting for &DATE values drop-down list.

4. Select a formatting schema for time values of a classic report in the Formatting for &TIME values drop-down list.

5. Select the Reset global variables when entering runtime mode check box to reset the global variable values back to default values each time a visual project is run.


7. To make a different set of fonts available for visual dashboards, specify the path to a custom set of fonts in the Search directory field and click Refresh Associations.

8. Select Project Explorer from the tree.

9. Specify a specific number of times that you can undo an action in the design editor in the Undo limit field. A value of ‘0’ indicates that there is no limit to the number of times that you can undo an action.

10. In the Rename preferences radio group, specify whether you will be prompted to confirm when you attempt to rename an object in the design editor. The available options include:

   • Always prompt - You will always be prompted when you attempt to rename an object.
   • Prompt when referenced - You will only be prompted when the object has references to other objects.
   • Never prompt - You will never be prompted when you attempt to rename an object.

11. In the Delete preferences radio group, specify whether you will be prompted to confirm when you attempt to delete an object in the design editor. The available options include:

   • Always prompt - You will always be prompted when you attempt to delete an object.
   • Prompt when referenced - You will only be prompted when the object has references to other objects.
   • Never prompt - You will never be prompted when you attempt to delete an object.

12. Click Apply to save your preferences choices.
13. Click **Restore Defaults** to restore the default preference values.
14. Click **OK** to close the Preferences window.
Chapter 8. Switching QMF to the FIPS-140 security standard

You can switch QMF to the FIPS-140 computer security standard by configuring a security provider definition.

About this task

To switch to the FIPS-140 standard:

Procedure

1. In the QMF installation directory, open the java.security file in edit mode.
2. Find a list of security provider definitions by looking for the following:
   security.provider.N=, where N represents a number.
3. Insert the following line to the first position of this list:
   security.provider.1=com.ibm.crypto.fips.provider.IBMJCEFIPS
4. Modify the numbers for the other security provider definitions in the list. When you open QMF, the application will work in FIPS-140 mode.
Chapter 9. Configuring repositories and connecting to the database

You need to configure the repositories and define the QMF connection to the database.

**About this task**

Repositories provide a logical grouping of QMF objects (queries, procedures, visual reports, and visual dashboards) and contain the database connection information and resource limits. Generally speaking, only administrators work with repositories.

The tasks required to configure repositories and connect to a database vary, depending on whether you are configuring QMF for yourself or for multiple users.

If you are configuring QMF for multiple users, you perform the following tasks:
1. Define the JDBC driver library
2. Configure the repository storage
3. Create a shared repository
4. Define the connection to the database
5. Create the repository connection
6. Export the configuration to the users

The tasks for configuring repositories and connecting to a database are described in the following table:

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
<th>Information</th>
</tr>
</thead>
</table>
| Defining JDBC Driver Library| Define the location of the driver files for the database that you intend to access with QMF. | You can connect to database repositories and data sources by defining the JDBC driver library or by using DRDA.  
JDBC driver files are not included with QMF, but QMF does include the configuration data for the most commonly used JDBC drivers.  
You need to define the JDBC driver files so that QMF for Workstation and QMF for WebSphere can load and use the driver.  
See Defining the JDBC driver library for detailed steps.  
See Using DRDA to connect to database repositories and data sources for detailed steps. |
<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
<th>Information</th>
</tr>
</thead>
</table>
| Configuring repository storage| Configure the storage that is used to hold database connection and resource limit information, as well as the database objects to be used by developers. | Configuring shared repository storage involves the following tasks:  
  • Specifying connection parameters and user login information  
  • Creating and updating tables  
  • Protecting repository storage tables and granting user permissions  
  • Setting maximum number of simultaneous database connections |
| Creating a repository         | Create repository into which users can save queries, reports, and other data objects. | See Creating repositories for detailed steps. |
| Defining a connection to the database | Add a relational data source or multidimensional data source to define the QMF connection to the database.  
  The connection information is stored in the Repository. | See Defining a connection to the database for detailed steps. |
| Creating the repository connection | Provide QMF for Workstation and QMF for WebSphere with information needed to connect the repository | See Creating the repository connection for QMF for detailed steps. |
| Providing access to the configured product | Allow multiple users to install and access QMF for Workstation or access QMF for WebSphere configuration from their web browser. | See Exporting the configuration data to users for detailed steps. |

### Creating the JDBC driver configuration file

If you are using JDBC to connect to the database repositories and data sources, you must specify where QMF will find the JDBC driver files for each type of database that will host a repository or be accessed as a data source.

**Before you begin**

Open the Administrator perspective if you have not already done so. To open the Administrative perspective go to the menu pane and select Window > Open perspective > Other > Administrator.

The JDBC driver files that are required to connect to a specific database must be installed on or accessible to the machine that you are currently using to configure repositories and data sources. QMF does not ship with these drivers.
About this task

The procedure in this task describes how to add the required JDBC driver files to your QMF environment configuration.

To specify the JDBC driver information for each type of database that will host a repository or be accessed as a data source, perform the following procedure:

Procedure

1. Select Preferences from the View menu to open the Preferences window. Select JDBC Libraries. The JDBC Libraries page opens. QMF supplies pre-populated libraries named for specific databases. For example, you will see libraries named IBM solidDB®, DB2, Derby, Informix, MS SQL, Oracle, SUN ODBC, and Netezza. Expanding a database library reveals that each is pre-populated with one or more driver libraries. The driver libraries are named for the most commonly used drivers for each type of database. Expanding the driver libraries reveals the class name for each type of driver.

2. If a JDBC driver is not listed in the pre-populated libraries, you can add a user defined JDBC driver library and driver class name:
   a. Select Add Driver. The Add New Driver Library window opens.
   b. The JDBC driver information is organized by libraries. Enter a name for the driver library in the Enter new library name field. It is recommended that the name that you specify describes the JDBC driver that will be included in the library. For example, if you are adding information for a DB2 Type 2 UDB driver, you might call the library DB2 Type 2 UDB driver. However, this is a descriptive field and can include any text.
   c. Specify the actual name of the driver class that will be used in the Driver class name field. This can be found in your JDBC driver documentation. For example, for a DB2 Type 2 UDB driver you might specify: com.ibm.db2.jdbc.app.DB2Driver.
   d. Optionally, you can specify a generic example of a correctly formatted URL that could be used to connect to the database in the URL templates field. To add a URL template, select the Add URL template icon. The text New template displays in the Template field. Replace the text New template with a sample of how the URL should be formatted. For example, if you are adding JDBC driver information for DB2 Type 2 UDB driver, you might specify the following JDBC URL template: jdbc:db2://host:50000/database. The generic information as specified in the template is presented when you are adding data sources to the repository and when you are creating repository connections. You will replace the generic information with the specific database information.
   e. Optionally, you can add additional JDBC driver properties to the URL template. Click JDBC driver properties. The Advanced JDBC Settings window opens. Select the properties that will be supported or can be used when connecting to a database using JDBC. They will be reflected in the URL template.

3. If you are using QMF for Workstation, for each driver class entry in a library, both pre-populated and user defined, you must specify where to find the associated JDBC driver JAR files. To specify where to find the associated JAR files:
   a. Expand the library that contains the JDBC driver class name to which you want to add JAR file location information.
   b. Select Add JARS. The Add JARS to [libraryname] window opens.
c. Search for and select the JDBC driver files that you want to add.

d. Select Open. The location of the JDBC driver JAR files is saved in the JDBC library that you have selected.

4. Select Apply. The JDBC library information that you have specified is saved in the .bi.jdbc.drivers file for the current machine. You must repeat the previous step for each pre-populated and user defined driver that will be used to access various database repositories or data sources.

5. You can make the following changes to the JDBC driver information:
- To edit user defined JDBC driver library information, select an existing JDBC driver library from the list and click Edit. The Edit Driver Library window opens where you can make changes to the Edit library name, Driver class name, and URL templates fields.
- If you are using QMF for Workstation, to edit the location of the JAR files, select a JAR file from the list of files that have been added to the JDBC library, and click Edit. The Edit JAR URL window opens. Specify the name and location in the Edit JAR location field.
- To remove a JDBC driver library, select an existing JDBC driver library from the list and click Remove. The library, including all the JAR files that it contains, is removed. You can not remove any pre-populated libraries.
- If you are using QMF for Workstation, to remove a JAR file from a JDBC driver library, select an existing JAR file from the list and click Remove. The JAR file is removed.

6. Click OK. The Preferences window closes.

Results

The JDBC driver information is saved and QMF can connect to your database.

Note: The information that you entered in the wizard is written to a file named .bi.jdbc.drivers. This file is saved in the personal settings directory of the machine/server that you are using to configure QMF repositories.

What to do next

Now you are ready to create the shared repository storage tables on your database.

Note: For more information on configuring JDBC libraries, refer to the Creating and Connecting to a repository cheat sheet. This cheat sheet details how to configure JDBC libraries and describes how you can copy the JDBC settings file for distribution across multiple systems. The cheat sheet is accessible from the QMF for Workstation Help menu. To open the cheat sheet, select Help > Cheat Sheets. Select Creating and connecting to a repository from the Cheat Sheet window.

Enabling bidirectional text layout transformations for DB2 Type 4 UDB JDBC driver

Enabling bidirectional (BiDi) text layout transformations allows the driver to correctly handle the data entered in a language with the right-to-left writing system when retrieving it from the database.
About this task

To enable BiDi text layout transformations for a data source, complete the following steps:

Procedure

1. **Procedure**
   
   In the Repository Explorer view, right-click the data source that you want to work with and select Properties from the menu.

2. **Procedure**
   
   In the upper-left corner of the Properties window, click **Connection Parameters**.

3. **Procedure**
   
   In the **Connection Parameters** area, click **Advanced**.

4. **Procedure**
   
   Enable the following properties: `enableBidiLayoutTransformation`, `serverBidiStringType`, and `clientBidiStringType`.

5. **Procedure**
   
   Set the value of the `enableBidiLayoutTransformation` property to true.

6. **Procedure**
   
   For the `serverBidiStringType` and `clientBidiStringType` properties, select integer values that match the way the data is stored on the server machine and represented on the client machine that you work with. Use the following table as a reference.

   **Table 10. Property values and corresponding attributes for the serverBidiStringType and clientBidiStringType properties**

<table>
<thead>
<tr>
<th>Value</th>
<th>Type of text</th>
<th>Text Orientation</th>
<th>Symmetric swapping</th>
<th>Numeral shape</th>
<th>Text shapes</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Visual</td>
<td>Left-to-right</td>
<td>No</td>
<td>Nominal</td>
<td>Shaped</td>
</tr>
<tr>
<td>5</td>
<td>Logical</td>
<td>Left-to-right</td>
<td>Yes</td>
<td>Nominal</td>
<td>Nominal</td>
</tr>
<tr>
<td>6</td>
<td>Logical</td>
<td>Right-to-left</td>
<td>Yes</td>
<td>Nominal</td>
<td>Nominal</td>
</tr>
<tr>
<td>7</td>
<td>Visual</td>
<td>Right-to-left</td>
<td>No</td>
<td>Nominal</td>
<td>Shaped</td>
</tr>
<tr>
<td>8</td>
<td>Visual</td>
<td>Right-to-left</td>
<td>No</td>
<td>Nominal</td>
<td>Shaped</td>
</tr>
<tr>
<td>9</td>
<td>Logical</td>
<td>Right-to-left</td>
<td>Yes</td>
<td>Nominal</td>
<td>Shaped</td>
</tr>
<tr>
<td>10</td>
<td>Logical</td>
<td>Contextual</td>
<td>Yes</td>
<td>Nominal</td>
<td>Nominal</td>
</tr>
<tr>
<td>11</td>
<td>Logical</td>
<td>Contextual</td>
<td>Yes</td>
<td>Nominal</td>
<td>Nominal</td>
</tr>
</tbody>
</table>

Consider the following descriptions of the attributes listed in Table 1:

**Type of text**

Specifies the relationship between the order of text as stored in memory or on external media and its order for correct display. Possible values are:

- **Visual** – text is stored in the same order as it is displayed
- **Logical** – text is stored in the order it is intended to be read

**Text orientation**

Specifies the direction in which the text is stored. Possible values are:

- **Left-to-right** – marks the text as left-to-right
- **Right-to-left** – marks the text as right-to-left
- **Contextual left-to-right** – the direction of the text is determined by analyzing the text itself. If the first strong character belongs to the left-to-right script or there are no strong characters in the text, it is marked as left-to-right. If the first strong character belongs to a right-to-left script, the text is marked as right-to-left.
• Contextual right-to-left – the direction of the text is determined by analyzing the text itself. If the first strong character belongs to the left-to-right script, the text is marked as left-to-right. If the first strong character belongs to a right-to-left script or there are no strong characters in the text, it is marked as right-to-left.

Symmetric swapping
Specifies whether characters that have an implied directional meaning, such as <, >, ( ), and so on, are replaced with their mirror images. This option is meant for texts that are written in right-to-left writing systems and are stored in Visual order. Symmetric swapping is not performed for texts that are stored in logical order. Possible values are:
• Yes – symmetric swapping is enabled
• No – symmetric swapping is disabled

Numeral shape
Specifies whether numbers are presented by using the European digit shapes or the Arabic-Indic digit shapes. Possible values are:
• Nominal – numbers are presented by using the European digit shapes
• National – numbers are presented by using the Arabic-Indic digit shapes

Text shapes
Specifies the encoding for Arabic symbols. Possible values are:
• Nominal – Arabic letters are encoded with intrinsic code points, in the "06xx" range for Unicode
• Shaped – Arabic letters are encoded as presentation forms which can be Initial, Middle, Final, or Isolated

Using DRDA to connect to database repositories and data sources

You can use the Direct DRDA Connection to establish a connection to DB2 database repositories and data sources.

Before you begin

The Direct DRDA Connection is supported only for DB2 for z/OS Version 9, Version 10, and Version 11. Do not use it for DB2 LUW or DB2 for iSeries.

About this task

In contrast to JDBC driver libraries, the Direct DRDA Connection is included with QMF and does not require additional driver installation.

You can specify the Direct DRDA Connection when creating a relational data source, shared repository storage, or shared repository connection.

You can enable the use of SSL certificates for the Direct DRDA Connection to make the connection secure.

To specify the Direct DRDA Connection:

Procedure

1. From the JDBC Driver drop-down list of the connection parameters section, select Direct DRDA Connection. The connection will be used to access the database that hosts the repository storage.
2. In the **JDBC URL** list specify the URL that points to the database that hosts the repository storage.

The templates for the URL can be displayed in the list:

```
jdbc:rsbi:db2://(server):(port)/(database)
```

You must specify the **server**, **port**, and **database** information.

**Note:** You can also use the Build URL by URL Template window to form the correct string. To do so, click **Build URL** to open the Build URL by URL Template window. From the JDBC URL drop-down list, select the template. In the table, specify the server, port, and database information and click OK. The result URL string is added to the JDBC URL list.

3. Click **Advanced** to specify Direct DRDA Connection string properties and their values to be used for the database that hosts the repository storage tables.

See [Direct DRDA Connection properties](#) for more information.

4. To bind the direct DRDA package click **Bind Packages**. The Bind Packages dialog opens.

In order for Direct DRDA Connection to properly work you must bind Direct DRDA packages when you are connecting to a database for the first time. When the binding operation completes, users can connect to the database by using Direct DRDA Connection. They do not have to bind packages again.

a. In the **Owner ID** field you can enter a privileged SQLID with the necessary rights for the binding process, in case a user who establishes a server connection has no administrator privileges for the database. If the value of this field is not specified, the CURRENT SQLID, the user name set in the Set User Information dialog, will be used to perform the installation process.

b. Click **Install** to start the installation process.

5. Continue specifying the relational data source, shared repository storage, or shared repository connection parameters.

**Direct DRDA Connection properties**

Direct DRDA Connection properties define how the connection to a particular data source is established. You can specify Direct DRDA Connection properties in the **Advanced JDBC Settings** window.

The Direct DRDA Connection has the following property:

**Parameters**

**securityMechanism**

This property specifies the Direct DRDA Connection security mechanism. The data type of this property is integer. Possible values are:

- **SECMEC.I_USRIDPWD = 3**
  Neither user ID nor password is encrypted.
- **SECMEC.I_EUSRIDPWD = 9**
  Both user ID and password are encrypted.
- **SECMEC.I_EUSRPWDDTA = 13**
  The user ID, Password, and Data are encrypted.

If you do not specify a value for **securityMechanism**, the requester attempts to connect using the security mechanism without any encryption.
If the server accepts only encrypted login information, the requester attempts to switch to the corresponding security mechanism.

If a connection cannot be established because the server does not support that security mechanism, an exception is thrown.

**sslConnection**
This property specifies whether the use of SSL certificates is enabled for the current connection. The data type of this property is string. Possible values are:

- **true** Specifies that the use of SSL certificates is enabled.
- **false** Specifies that the use of SSL certificates is disabled.

**sslTrustStoreLocation**
This property specifies the path to the truststore file that is used for the connection. The data type of this property is string. The value must contain a path to the truststore file.

**sslTrustStorePassword**
This property specifies the password to the truststore file that is used for the connection. The data type of this property is string. The value must contain a password to the truststore file.

**enableBidiLayoutTransformation**
This property specifies the way the Direct DRDA Connection processes bidirectional data. Enabling this property allows QMF DRDA driver to correctly handle the data entered in a language with the right-to-left writing system (such as Arabic) that is stored in visual order. If the data is stored in logical order, enabling this option will result in incorrect data output.

- **true** The enableBidiLayoutTransformation property is enabled.
- **false** The enableBidiLayoutTransformation property is disabled.

**Note:** If the enableBidiLayoutTransformation option is enabled, users cannot insert, edit, or delete any data in the database. Also, with the enableBidiLayoutTransformation option enabled, the driver is configured to handle BiDi data on the server machine and on the client machine differently. See the table in the Enabling bidirectional text layout transformations for DB2 Type 4 UDB JDBC driver topic for details.
Chapter 10. Creating a shared repository storage

A shared repository storage is a set of database tables. You must create a shared repository storage for storing database connection and resource limit information, as well as the database objects that users will use for reporting and querying actions.

Before you begin

Before you begin this task, make sure you have:

- Installed and configured your database management system (DBMS).
- Installed the JDBC driver JAR files and license files so that QMF can connect to the database.

Open the Administrator perspective if you have not already done so. To open the Administrative perspective go to the menu pane and select Window > Open perspective > Other > Administrator.

Make sure the Repository view is open in the workbench. To open the Repository view select Window > Show view > Repositories. The Repositories tab opens in the workbench.

About this task

Creating the repository storage tables is a multistep process with multiple options presented in each step. The options you select in one step will determine the next step in the process.

The steps in this topic provide an overview of the process for creating the shared repository storage on your database, so that the data in the repositories can be obtained for further relocation or distribution in a network. See the subsequent topics in this section for detailed descriptions of the wizards employed.

The maximal line length of the DDL scripts displayed when creating shared repository storage is determined by the value set in the Line width field on the General Preferences page. See Setting general preferences in the User help for more information.

To create the repository storage on your database:

Procedure

2. On the Enter connection parameters for new shared repository storage page, specify the JDBC connection information and user login information that will be used to connect to the database that will host the repository storage.
3. Click Next. The Create or upgrade repository storage tables page of the wizard opens.
4. On the Create or upgrade repository storage tables page, specify that the database objects that are required by the QMF applications in order to access the repository storage will be created or upgraded.

5. Click Next. If necessary, the Upgrade repository storage tables page opens listing the SQL statements that will be used to create or update the required repository storage tables. If this page opens, click Next. The Protect repository storage tables page of the wizard opens.

6. On the Protect repository storage tables page of the wizard specify whether the database repository storage tables will be protected from unauthorized users.

7. Click Finish.

Results

You have created the shared repository storage on your database.

What to do next

The next step is to add repositories to the repository storage tables.

Specifying connection parameters and user login information

The first step to creating shared repository storage is to specify the connection parameters and the user login information that will be used when accessing the database that hosts the repository storage.

About this task

To specify the connection and user login information for the database that hosts the repository storage:

Procedure

1. Open the Create New Shared Repository Storage wizard and navigate to the Enter connection parameters for new shared repository storage page.

2. In the JDBC Driver field specify the library for the JDBC driver that will be used to access the database that is hosting the repository storage. You can select from a drop down list of libraries that you defined when you set up the JDBC driver information. You can use the ellipsis (...) to the right of the field to open the JDBC Libraries dialog where you can create additional JDBC driver libraries.

   Note: If you work with a DB2 for z/OS database, you can use the Direct DRDA Connection. In contrast to JDBC libraries, the Direct DRDA Connection comes with QMF and does not require additional driver installation.

   You can enable the use of SSL certificates for the Direct DRDA Connection to make the connection secure.

   Note: The Direct DRDA Connection is supported only for DB2 for z/OS Version 9, Version 10, and Version 11. Do not use it for DB2 LUW or DB2 for iSeries.

   See Using DRDA to connect to database repositories and data sources for more information.
3. In the JDBC URL list, specify the URL that points to the database that hosts the repository storage within which the repository to which you want to connect resides.

The format for the URL can be displayed in the list.

**Note:** You can also use the **Build URL by URL Template** dialog box to form the correct string.

Click **Build URL** to open the Build URL by URL Template dialog box. From the JDBC URL drop-down list, select the template. In the table, specify the server, port, and database information and click **OK**. The result URL string is added to the JDBC URL list.

4. Click **Advanced** to specify any driver-specific connection string keywords and their values that will be used for the database that is hosting the repository storage tables. The list of available advanced properties will change depending on both the type of driver being used, and the version of the driver. For information on any keywords that are required by a selected database driver, consult the specific driver’s documentation.

**Note:** For the DB2 Type 4 UDB driver and the DB2 Universal JDBC Driver, to receive extended SQL exception error messages, check the `retrieveMessagesFromServerOnGetMessage` option in the Advanced JDBC Settings window.

5. If you use the Direct DRDA Connection, bind packages by clicking the **Bind Packages** button.

6. Specify the user information. Click the **Set User Information** button to open User Information dialog.

7. In the User Information dialog, select **User ID and password are required** to require the use of a user ID and password when accessing the database that is hosting the repository storage. If the database that is hosting the repository storage allows access without a user ID and password, selecting this option will override that allowance, and a user ID and password will be required to access the repository storage tables.

8. Specify the user ID and password that will be used to access the database in the **User ID** and **Password** fields. The user ID and password that you specify when connecting to the host repository are used to authorize the user in that repository. The user ID and password that you specify must have administrative privileges on the host database in order to create the repository storage tables. This mode is only available on DB2.

9. To remember this password every time you use the specified user ID to connect to the database, select the **Remember password** check box.

10. Click **Test Connection** to test the connection to the database. If you have specified any information incorrectly you will not be able to connect.

11. Click **Next**. The Create or update the repository storage tables page of the wizard opens.

---

**Creating and updating tables**

The second step to creating shared repository storage is to specify whether the database objects that are required by the QMF applications in order to access the repository storage will be created or updated.
About this task

Several database tables are required to support the shared repository storage that is being created on the database. You must specify whether QMF should check to see if the tables exist or need updating.

To create or update the repository storage tables:

Procedure

1. Open the Create New Shared Repository Storage wizard and navigate to the Create or update repository storage tables page.
2. Select one of the following options:
   • Click Repository storage tables have already been created to bypass this step. You might select this option if all the repository storage tables already exist and you are certain that the tables have not changed. An example of this situation might be if you are editing the repository storage options and your intent is to re-bind packages or re-run stored procedures for the repository storage tables. Click Next. The Protect repository storage tables page of the wizard opens.
   • Click Create or upgrade repository storage tables to check if the tables have been created or have to be updated.
3. Optionally you can type the owner name in the Owner ID field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.

Tip: (for DB2 for z/OS databases)

When the user without administrator privileges creates or updates the shared repository storage tables and enters the owner name in the Owner ID field, the user login and Owner ID are automatically inserted to the RSBI.AUTHID_TABLE as the PRIMARY_ID and SECONDARY_ID correspondingly. This allows the user to create shared repositories with database-based security provider and automatically work with the repositories as an administrator.

4. If repository storage tables have not been created, you can select the Enable customization of database object names check box to open a window where you can customize how database objects are named.
5. Click Next. Depending on the status of the tables you will proceed as follows:
   • If all the tables have been created and have not changed, a message is issued. Click OK in the message window. The Protect repository storage tables page of the wizard opens.
   • If the tables have to be created or updated and you did not select the Enable customization of database object names check box, then the Update repository storage tables page of the wizard opens listing the SQL statements that will be used to create or update the required repository storage tables. You can make changes to the SQL statements as described on the page. Click Next. The Protect repository storage tables page opens.
   • If the tables have to be created and you selected the Enable customization of database object names check box, then the Enter Substitution Variable Values window opens. Enter your customized database object names in the Value column and click OK.

Note: The Value column of the window displays the default name of each database object. This gives you an opportunity to review and/or rename the
objects that will be created. For example, one could preface all index names with the prefix "IX".
The Enter Substitution Variable Values window closes and the Protect repository storage tables page of the wizard opens.

Protecting repository storage tables and granting user permissions

The last step to creating shared repository storage is to specify whether the shared repository storage tables will be protected from unauthorized users.

About this task

Several tables in repository storage are used by QMF to store processing information. Some of these tables store sensitive information, for example the permissions table. By default all users can access these repository storage tables and make changes to the tables. You can choose to protect the repository storage tables. In protection mode the repository storage tables are accessed using a collection of stored procedures or static SQL packages depending on what the database that is hosting the repository storage supports. Users of the repository storage must then be granted permission to run the stored procedures or static SQL packages.

To protect the repository storage tables:

Procedure

1. Open the New Shared Repository Storage wizard and navigate to the Protect repository storage tables page.
2. Specify whether the shared repository storage tables will be protected from unauthorized users. By default the Protection method check box is not selected. This means that all users will have access to the repository storage tables and can make changes to any of those tables. To specify that you will protect the repository storage tables, select the Protection method check box. The fields that you will use to specify the protection method become available.
3. Select one of the following protection methods:
   - Select Stored procedures to specify that you will use stored procedures to protect the repository storage tables. You can select this option if the repository storage tables are located on one of the following databases:
     - Informix
     - DB2 UDB LUW V9 and above
     - DB2 z/OS V9 and above in NFM
     - DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
     - Microsoft SQL Server
     - Oracle
     - PostgreSQL
   - Select Static SQL packages to specify that you will use static SQL packages to protect the repository storage tables. You can select this option if the repository storage tables are located on a DB2 database that you will connect to using the IBM DB2 Universal driver for JDBC or the Direct DRDA connectivity provided by the product (the latter option is available for DB2 for z/OS connectivity only).
4. Type, or select from the drop-down list, the name that you want to use to identify the collection of stored procedures or static SQL packages in the Collection ID field.
5. Optionally you can type the owner name in the Owner ID field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.

6. Click Create. The stored procedures are created or the static SQL packages are bound. A message is issued that informs you of the success of the either process. You can also use the Delete button to remove a collection of stored procedures or packages.

7. Specify which users will have permission to run the stored procedures or static SQL packages for the repository storage tables on this database. To grant permission to all users, enter PUBLIC in the User IDs field and click Grant. To grant permission to specific users, type their user IDs in the field and click Grant. A message is issued that informs you that the selected user IDs have been granted permission to run the stored procedures or packages. Optionally, you can revoke permission to run the stored procedures or static SQL packages from any user that is listed in the User IDs list box. To revoke permission from one or more users, highlight one or more of the user IDs and click Revoke. A message is issued informing you that permission to run the stored procedures or static SQL packages has been revoked from the selected user IDs.

8. Click Finish. The repository storage tables are created. The location of the new repository storage tables is listed in the Repositories view. After you have created the shared repository storage in the database, you can add one or more repositories that will share the storage. Each repository that you create can have its own independent objects, security models, and users.

---

Setting maximum number of simultaneous database connections

An advanced feature in creating repository storage tables allows you to specify the maximum number of simultaneous database connections.

About this task

This advanced feature exists in both Workstation and WebSphere, and contains the concurrent access to repository storage database limit.

To set the maximum number of simultaneous database connections:

Procedure

1. In the Repositories view right-click the repository storage to which you want to specify simultaneous database connections. Select Edit from the pop-up menu. The Edit Repository Storage window opens.

2. Click the Advanced tab.

3. Specify the number of database connections in the Maximum number of simultaneous database connections field. The default value is 10.

4. Click OK. The maximum number of simultaneous database connections is set in the repository storage tables.
Chapter 11. Repositories

Repository is a storage of QMF objects and database connection information.

QMF supports personal and shared repositories. The Administrator component provides the tools to create, manage, and maintain repositories.

Main features of repositories:
- Repositories organize all accessible data sources and objects in a tree structure.
- Repositories use security models to control user access to their content.
- Repositories can be stored in most commonly used databases. You can choose to place repository tables in the same database as your production data or within a stand-alone database that is created specifically for work with repositories.
- Repositories can be served by a distributed database such as DB2 on LUW, Informix, Oracle, SQL Server, or MySQL.

Repository security

To control access to the repository for different individual users and groups of users, administrators assign shared repositories a security model. For example, users in group A can see data sources A, B and C, whereas users in group B see data sources A, D, and E. Permissions can be applied to all QMF objects, including queries, dashboards, and individual workspace folders.

You can use the following security models:
- LDAP/Active Directory:
  QMF uses an LDAP-based service, such as Active Directory, to authenticate the user and obtain the user and group lists.
- Database security:
  QMF uses the user database login as the basis of the security model. This security model is available only if the repository storage for the repository is located on a DB2 or Oracle database.
- Internal security:
  Using this method, users and groups can be defined within QMF itself and saved directly in repositories.

Personal repositories

Personal repositories serve a single user and provide the ability to store content on a local workstation without a relational database.

If you are configuring QMF for personal use, see the detailed information on how to create a personal repository in the Creating personal repositories topic of User Help.

QMF includes a pre-configured personal repository named Samples. The Samples repository includes a relational data source for connecting to sample content.

The personal repositories that you create are stored in the home directory of the machine that is running QMF.
Personal repositories do not support security models.

**Shared repositories**

If a shared repository is assigned a security model, it can be administered by a limited number of users. Otherwise, all the users have the administrator rights. Shared repositories support the security and workspace features that allow the administrator to control the view of enterprise resources on an individual or group basis. They also support the login mapping feature, and network or Web service repository connections that allow users to access databases through a connection that is set on another system.

If you are configuring QMF for multiple users, you can create a shared repository.

**Note:** In QMF for Workstation and QMF for WebSphere V9.1 Fix Pack 6 and later, the following changes have occurred:

- Database-based repositories are now referred to as shared repositories.
- Personal repositories have replaced file-based repositories. You can no longer create file-based repositories. However, you can still connect to any file-based repositories that were created prior to V9.1 Fix Pack 6.

---

**Adding repositories to the repository storage tables**

You can add repositories to the repository storage tables. Repositories serve as a centralized place in which an aggregation of data, such as queries, procedures, forms, dashboards, and, reports are developed for a specific set of data sources. Each repository that you create can have its own independent objects, security models, and users.

**Before you begin**

Make sure the **Repository** view is open in the workbench. To open the Repository view select **Window > Show view > Repositories**. The **Repositories** tab opens in the workbench.

**About this task**

The information in this topic describes how to add a repository within the repository storage tables on a database.

As part of the procedure for adding repositories, you define the permissions for accessing the repositories. These permissions determine which users or user groups have access to the repositories.

To add a repository to the repository storage table, perform the following steps:

**Procedure**

1. In the **Repositories** view right-click the repository storage to which you want to add a repository. Select **New > Shared Repository** from the pop-up menu. The Create New Shared Repository wizard opens.
2. Specify the name that will be used to identify the repository in the **Name** field.
3. Optionally, type a comment that describes the repository in the **Comment** field. This comment will display with the properties for the repository.
4. Select the type of security that will be applied to the repository. From the Security provider drop-down list select one of the following:

- **None**: Specifies that no additional security beyond what is provided by the database that is hosting the repository will be applied. All users will have full access to the contents of the repository.
- **Internal**: Specifies that a layer of security beyond what is provided at the database level will be applied. This level of security allows you to define users and groups, and then assign them permission to access the repository. This level of security also allows you to control which objects a user or group can access or view when they are connected to the repository. User and group definitions, and their assignments, are stored within the repository. Users will log on to QMF for Workstation or QMF for WebSphere using their defined user IDs and passwords. They will be granted access to a repository or to repository objects based on the permissions that they are assigned by the QMF administrator.
- **LDAP**: Specifies that a layer of security beyond what is provided at the database level will be applied. This level of security allows you to control the users and groups who are permitted access to the repository. This level of security also allows you to control which objects a user or group can access or view when connected to the repository. If you choose the LDAP security option, the user identities and group affiliations are obtained from an existing LDAP server. Users will log on to QMF for Workstation or QMF for WebSphere using their LDAP user names and passwords. They will be granted access to a repository or to repository objects based on the permissions that they are assigned by the QMF administrator.
- **Database-based**: Specifies that the security settings of the host database will be used to protect the shared repository.

5. If you selected either Internal or LDAP security, click Next. One of the following wizard pages opens:

- If you selected Internal security, the Internal security provider options page opens. Specify the user name and password that will identify the QMF administrator account. The QMF administrator account is the account that is used to create additional administrative accounts, as well as apply security permission levels to different users and groups.
- If you selected LDAP security, the LDAP security provider options page opens. Specify one or more values for the LDAP fields. These fields are used to obtain all LDAP users and groups. You will be asked to specify an existing LDAP group in your directory that represents the QMF administrator account. All LDAP accounts that belong to this group will have QMF administrator privileges and can create additional administrative accounts, as well as apply security permission levels to different users and groups.

6. Click Finish.

**Results**

You have created and added to the list of available repositories that are contained within the shared repository storage.

**What to do next**

The next step is to configure data source information in the repository.

If you have applied Internal security to the repository you can choose to create the users and groups that can access the repository at this point, or after you have
configured data source information. If you assigned LDAP security to the repository, all the users and groups that were obtained from your LDAP server can access the repository. For both types of secured repositories, Internal and LDAP, you assign users and groups permission to access repository objects on an ongoing basis as the needs of your environment dictate or change.

If you are just creating the repository, you must populate the repository with data source information before you can specify the level of access a user or group will have to the objects that are in the repository.

**Specifying internal security fields**

For repositories with Internal security, you must specify the user name and password that will identify the QMF administrator account.

**Administrator login**

Use this field to specify a user name that will identify the QMF administrator. The QMF administrator account is the account that is used to create additional administrative accounts as well as create new user and group accounts. In addition, only administrator accounts can be used to apply security permissions to user and groups.

**Administrator password**

Use this field to specify the password that will be used in conjunction with the user ID that is specified in the Administrator login field.

**Confirm Administrator password**

Use this field to confirm the password that you specified in the Administrator password field.

**Days for password expiration (0 - without limit)**

Use this field to specify the number of days until the password will expire. A value of zero (0) indicates that the password will not expire.

**Warning before password expiration date (days)**

Use this field to specify the number of days prior to the expiration day that a warning to change the password will be issued.

**Specifying users and groups for Internal security option**

The Internal security option requires that you identify the users and groups that will be able to access the repository.

**About this task**

Each repository that you create can have a different set of users and groups that are allowed access. After you identify the users and groups that are allowed to access the repository, you can then assign them permission to access specific objects within the repository.

To set up the users and groups that can access a repository that has Internal security:

**Procedure**

1. Open the Users and Groups view by selecting Window > Show View > Users and Groups.
2. To add a new user that will be able to access this repository, right-click the Users node and select New > User from the pop-up menu. The New Repository User window opens. Specify the new user information.
3. To add a new group that will be able to access this repository, right-click the Groups node and select New > Group from the pop-up menu. The New Repository Group window opens. Specify the new group information.

4. To edit a user’s password, right-click the user name in the tree and select Set Password from the pop-up menu. The Set Password For User window opens. Specify the new password in the Password field.

5. To delete a user or group, right-click a user or group name in the tree and select Delete from the pop-up menu. The selected user or group is deleted.

6. To refresh the list of user and groups names, right-click anywhere in the view or on any element in the tree and select Refresh from the pop-up menu. The list is refreshed.

7. To edit a user’s or group’s properties, right-click a user or group name in the tree and select Properties from the pop-up menu. The Properties for [User] window opens if you have selected a user or the Properties for [Group] window opens if you have selected a group. Edit the fields that you want to change and click OK.

8. You can choose to either leave the Users and Groups view open or close the view by clicking the close icon. The next step to setting up users and groups for repositories with Internal security is to assign permission to use repository objects.

Creating a user
You must define each user that will be allowed to access a repository that has been assigned the Internal security option.

About this task
To create a new user that will be allowed to access a repository with Internal security:

Procedure
1. Open the New Repository User window, by expanding the repository tree to the Users and Groups branch, then right-click Users, select New > User
2. Specify the ID that the user will use to connect to the repository in the User name field.
3. Specify the user’s full name in the Full name field.
4. Specify the password for the user name in the Password field.
5. Retype the password for the user name in the Confirm password field.
6. Optionally, you can type a description of the user in the Description field. This description is displayed with the user’s properties.
7. To automatically create a default home workspace for the user, select the Has a home workspace check box.
8. Add the new user to a group by using the Group Membership check boxes. Each group that you have created is listed. You can select one or more group check boxes. The user will be added to each group whose check box is selected. If the group that you want to add the user to is not listed, you must define the group.
9. Click Finish. The user identity is created and will be allowed to access the repository. You will repeat this process for each new user that will have access to the repository. After specifying the users and groups that can access the repository, the next step is to assign them permission to use repository objects.
Creating new group
You must define each group that will be allowed to access a repository that has been assigned the Internal security option.

About this task
To create a new group that will be allowed to access a repository with Internal security:

Procedure
1. Open the New Repository Group window, by expanding the repository tree to the Users and Groups branch, then right-click Groups, select New > Group
2. Specify the name of the group in the Group Name field.
3. Add users to the new group by using the Members check boxes. Each user that you have created is listed. You can select one or more user's check boxes.
4. Specify the parent folder for the new group by using the Parent field. The current group hierarchy is displayed. From the tree, select the group that will be the parent for the new group.
5. Optionally, you can type a description of the group in the Description field. This description is displayed with the group's properties.
6. Click Finish to create the new group.

Editing user properties
You can edit the properties that you have specified for each user that will be allowed to access a repository that has been assigned the Internal security option.

About this task
To edit a user's properties:

Procedure
1. Open the Users and Groups view by selecting Window > Show View > Users & Groups > Other. Expand the QMF Workbench and select Users and Groups. Right-click a user name in the tree and select Properties from the pop-up menu. The Properties for [User] window opens.
2. On the User General page of the Properties for [User] window, the User name field displays the name of the selected user. You can edit the following user fields on this page:
   - Type any changes to the user's user name in the User name field.
   - Type any changes to the user's full name in the Full Name field.
   - Type any changes to the description in the Description field.
   - Specify a new password for the user by clicking the Set Password button. The Set Password for [User] window opens where you can specify the new password.
3. On the User Membership page of the Properties for [User] window, you can add and remove the user to and from groups. All of the groups that have been created for the repository are listed in the Member of list box. Each group has a corresponding check box. The check box is selected if the user belongs to that group and cleared if the user does not belong to the group. To add the user to a group, select the group's corresponding check box. To remove the user from a group, clear the group's corresponding check box.
4. Click OK. The changes that you have made to the user's properties are saved.
Editing group properties
You can edit the properties for each group that can access an internally secured repository.

About this task
To edit a group’s properties:

Procedure
1. Open the Users and Groups view by selecting Window > Show View > Users & Groups > Other. Expand the QMF Workbench and select Users and Groups. Right-click a group name in the tree and select Properties from the pop-up menu. The Properties for [Group] window opens.
2. The Group name field in the Group General page of the Properties window displays the name of the selected group. You can make changes to the name of the group in this field.
3. The parent group for the selected group displays in the Parent group field. To change the parent group of the selected group, click Change. The Edit Parent Group window opens. Expand the branches of the Groups tree until you expose the group to which you want to add the selected group. Click Set As Parent. The selected group will be moved to the new parent group.
4. The description for the group is displayed in the Description field. You can edit the description text by typing new text directly in the field.
5. Click Apply to apply the Group General properties that you have changed.
6. You can add and remove users to and from the selected group using the Group Membership page of the Properties for [Group] window. All of the users that have been defined for the repository are listed in the Members list box. The corresponding check box for each user is selected if the user belongs to the group and clear if the user does not belong to the group. To add the user to a group, select the group’s corresponding check box. To remove the user from a group, clear the group’s corresponding check box.
7. Click Apply to apply the Group Membership properties that you have changed.
8. Click OK. The changes that you have made to the group’s properties are saved.

Specifying LDAP security fields
If you specified the LDAP security option for a repository, you must specify the LDAP security parameters in order to obtain the user identities and group affiliations from your LDAP server.

About this task
Note: All users and groups that are defined in your LDAP server are obtained and granted permission to access the repository. To specify what type of access the users and groups can have to the repository, you edit the repository’s security properties assigning permission levels to each user or group.

Specifying LDAP Main fields
You must specify the LDAP Main fields if you have selected LDAP security for the database repository.

Host Use this field to specify the IP address of the LDAP server.
Port Use this field to specify the contact port that is used by your LDAP server.
For example, the LDAP protocol specifies the use of TCP/IP port number 389 for LDAP. However, this value can vary based on what has been specified in your environment.

To use the Secure Sockets Layer (SSL) protocol to communicate with the LDAP server, select the Use SSL check box and specify the appropriate SSL port number in the Port field.

**Note:** The LDAP server that you use must be configured to use SSL.

**Auth type**

Use this field to specify what type of LDAP authentication should occur for this repository. Select None to allow a user to authenticate to an LDAP server as an anonymous user. Select Simple to require that a user authenticates to the LDAP server with a distinguished name (DN) and a password.

**User DN**

Use this field to specify the user-distinguished name that can be used to access your LDAP directory. This field is available only if your LDAP directory requires authentication in order to access, and you specified Simple in the Auth Type field.

**Password**

Use this field to specify the password that is associated with the user’s distinguished name that you specified in the User DN field.

**Base DN**

Use this field to specify (or select from the drop-down list) the distinguished name or names that will lead to the entry in the LDAP directory under which all users and groups will be retrieved. A distinguished name is a unique name for an entry in your LDAP directory. For example: ou=people, o=eastcoast.

**Account required**

Select this check box to specify that a master account can be used to edit the LDAP repository settings.

**Login**  
Specifies the login that will be used as the master account.

**Password**  
Specifies the password that will be used for the master account.

**Specifying LDAP Group fields**

You must specify the LDAP Group fields if you have selected LDAP security for the database repository.

**Base RDN**

Use this field to specify the relative distinguished name for a group. For example: o=Sales.

**Search scope**

Specifies the possible scopes for the directory search. You can specify:

- **One level:** To search the one level below the Base RDN level, excluding the base object.
- **Subtree:** To search the whole subtree rooted at the Base RDN level, including the base object and all its child objects.
Object class
Specify the object class to which the group belongs. For example: objectclass:posixGroup indicates that all entries under Base RDN belong to the posixGroup class.

Name attribute
Specify the name of an attribute whose value specifies the group name.

Description attribute
Specify the name of an attribute whose value specifies the description of the group.

Name filter
This field specifies the standard search string that will be used to search groups by name. This field is generated based on the values that you specify in the Name attribute and Object class fields.

All groups filter
This field specifies the standard search string that will return all the groups under the Base RDN. This field is generated based on the values that you specify in the Name attribute and Object class fields.

User's group
Use this field to specify the group to which the member belongs.

Administrator's group
Use this field to specify the group whose members will be granted administrator permissions within the content of the QMF products.

Member attribute
Specifies the name of a groups entry's attribute whose value specifies membership in the group. You can specify an RDN that will refer to a user entry or a user's name.

Member type
Specifies the member type based on what was specified in the Member attribute field. If you specified an RDN in the Member attribute field, the member type is DN. If you specified a user name in the Member attribute field, the member type is Value.

Identity type
Specifies the attribute that is used to identify the group and the type of access the group has to the repository. Using the identity attribute ensures retaining the granted permissions to the repository for the group, if the group is renamed or moved to another folder in the LDAP directory. The possible values are the following:
• DN is the default value. It means that the distinguished name for the group is used for identification.
• Custom attribute means that the name of the attribute specified in the Custom Attribute field is used for identification.

Custom attribute
This field is available only if you selected Custom attribute identity type. Specify the name of an attribute which value will be used for identification of the group.

Specifying LDAP User fields
You must specify the LDAP User fields if you have selected LDAP security for the database repository.
Base RDN
Use this field to specify the relative distinguished name for a user. For example: uid=Mike.

Search Scope
Specifies the possible scopes for the directory search. You can specify:

- **Onelevel**: To search the one level below the Base RDN level, excluding the base object.
- **Subtree**: To search the whole subtree rooted at the Base RDN level, including the base object and all its child objects.

Object class
Specify the object class to which the user belongs. For example:
objectclass:sales indicates that all entries under Base RDN belong to the sales class.

Name attribute
Specify the name of an attribute whose value specifies the user name.

Description attribute
Specify the name of an attribute whose value specifies the description of the user.

Name filter
This field specifies the standard search string that will be used to search users by name. This field is generated based on the values that you specify in the Name attribute and Object class fields.

All users filter
This field specifies the standard search string that will return all the users under the Base RDN. This field is generated based on the values that you specify in the Name attribute and Object class fields.

Full name attribute
Use this field to specify the name of the attribute that contains a user's full name.

Login attribute
Specify the name of an attribute whose value specifies the login of the user.

Identity type
Specifies the attribute that is used to identify the user and the type of access the user has to the repository. Using the identity attribute ensures retaining the granted permissions to the repository for the user, if the user is renamed or moved to another folder in the LDAP directory. The possible values are the following:

- **DN** is the default value. It means that the distinguished name for the user is used for identification.
- **Login attribute** means that the name of the attribute specified in the Login attribute field is used for identification.
- **Custom attribute** means that the name of the attribute specified in the Custom attribute field is used for identification.

Custom attribute
This field is available only if you selected Custom attribute identity type. Specify the name of an attribute which value will be used for identification of the user.
Note: If a user and a group have the same value of identity attribute, they are determined as different security objects in the repository.

Specifying LDAP Authenticator fields
You must specify the LDAP Authentication fields if you have selected LDAP security for the database repository.

Authenticator type
Use this field to specify the type of authentication that will occur. You can choose:
- **Bind**: to use an LDAP bind operation.
- **Compare**: to use a string compare with the value of the **Password attribute** and that of a user's entry.

User's password attribute
Use this field to specify the attribute that will be retrieved in a user's entry as a password. This field is used only if you specified **Compare** in the Authenticator type field.

Append base DN
Select this check box to specify that when authenticating a user, the base DN will be appended to a user's RDN. This field is used only if you specified **Bind** in the Authenticator type field.

Allow empty password
Select this check box to allow an empty password.
Chapter 12. Data sources

As an administrator, you create data sources to store database connection information.

Data sources are classified by the types of databases that they represent.

<table>
<thead>
<tr>
<th>Data source</th>
<th>Database</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relational</td>
<td>Data is stored in relational databases.</td>
</tr>
<tr>
<td>Multidimensional</td>
<td>Data is stored in multidimensional databases.</td>
</tr>
<tr>
<td>Hive</td>
<td>Data is stored in Apache Hive™ data warehouses.</td>
</tr>
<tr>
<td>Folder</td>
<td>Data is stored on the local file system.</td>
</tr>
<tr>
<td>Virtual</td>
<td>Data is stored in virtual and JavaScript tables.</td>
</tr>
<tr>
<td>JavaScript</td>
<td>Data is provided by online services. Data is stored in JavaScript tables.</td>
</tr>
<tr>
<td>QMF Data Service</td>
<td>Data is stored in tables on the QMF Data Service server.</td>
</tr>
</tbody>
</table>

Except for folder data sources, when creating a data source, the first step is to select an availability type. If you create a shared data source, it will be stored in the repository to which you are currently created and available to all users. If you select to create a personal data source, it will be stored on your local file system. Personal data sources are available only to users who create them.

In most configuration scenarios, the person creating the connection to the database has an understanding of the authentication requirements for the data source.

Enabling QMF catalog functionality

You can configure a relational data source in the repository so that it can use a QMF catalog. By enabling access to the QMF catalog users can access any objects that are saved in the QMF catalog and, if they choose, they can save any new objects to the QMF catalog.

About this task

The QMF catalog is a set of database tables that contain saved objects (queries, procedures and forms); user resource limits and profiles; reports; and other miscellaneous settings and information. QMF catalogs reside on database servers that host a DB2 database.

The maximal line length of the DDL scripts displayed when creating or updating QMF catalogs is determined by the value set in the Line width field on the General Preferences page. See Setting general preferences in the User help for more information.

By configuring a data source to access a QMF catalog, you can retrieve any QMF objects that have been saved in an existing QMF catalog. You can also save any
QMF objects that you might create to a QMF catalog. This allows you to share and use objects regardless of the application version or platform that was used to create the QMF object.

In addition, if you configure a data source to access a QMF catalog, you can control resource usage with the resource limits that have been set for the data source and the user and saved in the QMF catalog.

To configure a data source so that it can access a QMF catalog:

**Procedure**
1. Open the QMF catalog wizard.
2. Specify what type of catalog objects you will create using the Create or update catalog objects page of the QMF catalog wizard.
3. Click Next.
4. If it was decided that a set of QMF catalog tables has never been created on the data source, the Create Objects page of the wizard opens. The SQL to create the catalog tables is displayed. You can make changes to the SQL. If it was decided that a set of QMF catalog tables has already been created for this data source and there are no required updates, then this step is bypassed.
5. Click Next.
6. The Protect QMF catalog tables page of the wizard opens. From the Protect QMF catalog tables page you will specify whether the QMF catalog tables will be protected from unauthorized users. You will also specify user permission to use those stored procedures or SQL packages.
7. Click Next.
8. The Select QMF Catalog page of the wizard opens. From the Select QMF Catalog page you will select the QMF catalog that the data source will use.

**Creating or updating QMF catalog objects**
The first step to enabling QMF catalog functionality is to choose whether the QMF catalog objects will be created or updated on the current data source.

**About this task**

To create or update QMF catalog database objects:

**Procedure**
1. On the Enable data source plug-ins page of the New Relational Data Source wizard, select QMF Catalog Plug-in Enable plug-in check box. The Create or update catalog objects page of the QMF catalog wizard opens.
2. On the Create or update catalog objects page, you will specify whether a set of QMF catalog tables has ever been created on the data source and what kind of object names (long or short) are or will be supported by the QMF catalog that exists or will be created. Select one of the following:
   - Select Catalog tables have already been created if the QMF catalog tables already exist on this data source. A set of catalog tables would have been created for the data source when it was originally configured in either a repository or by a prior version of the application. You would select this
option if you know the tables have already been created and you only want to rerun stored procedures or rebind the catalog packages.

- Select **Create or update catalog tables to support short names** if you are configuring a new data source that has never had the QMF catalog tables installed and you will only use short names for objects, or you are upgrading from a previous version of the application and the existing QMF catalog tables will continue to support only short names for objects. If no QMF catalog tables exist on the data source, then they will be created. If you are upgrading to a new version, and a set of tables exist on the data source, they will be checked and updated or added as necessary. You are given the opportunity to confirm and modify the SQL statements used to create the tables. Any data that is in the existing catalog tables is maintained.

- Select **Create or update catalog tables to support long names** if you are configuring a data source for the first time and want to create a set of QMF catalog tables that use long names; you are upgrading from a previous version of the application and the existing QMF catalog tables will continue to support only long names for objects; or you want to convert the existing catalog tables that support short names to catalog tables that support long names. To select this option, the data source that you are configuring must support long names. If you choose to create the QMF catalog tables so that they support long names, QMF applications prior to Version 8.1 will not be able to use the long names QMF catalog tables.

If no QMF catalog tables exist on the data source, then they will be created and they will support long names. If a set of QMF catalog tables that support long names are detected on the data source, they will be updated or added to as necessary. If an existing set of QMF catalog tables that use short names are detected on the data source, they will be converted to support long names. The data source will be checked to ensure that the support for long names is available. There is no requirement to use long names in the QMF catalog tables. If the data source uses long names, the QMF catalog tables can still use short names. Once converted, only 8.1 or later of QMF applications can use these QMF catalog tables.

You are given the opportunity to confirm and modify the SQL statements used to create or update the tables. Any data that is in the existing catalog tables is maintained.

- If you do not want to create a set of QMF catalog tables for this data source, select **Do not create catalog tables**. You would select this option if the data source you are configuring will not host a QMF catalog; will use a set of QMF catalog tables that reside on a different data source; or a set of QMF catalog tables has already been created for this data source and you are just selecting a different QMF catalog.

3. If catalog tables have not been created, you can select the **Enable customization of database object names** check box to open a window where you can customize how database objects are named.

4. Click **Next** to open the next page of the wizard. If you selected:

- **Catalog tables have already been created** option, the Protect QMF Catalog tables page of the wizard opens.

- **Create or update catalog tables to support short names** or **Create or update catalog tables to support long names** option and you did not check the **Enable customization of database object names** check box, the Choose object listing option page of the wizard opens.

- **Create or update catalog tables to support short names** or **Create or update catalog tables to support long names** option and you did check the **Enable
customization of database object names check box, the Enter Substitution Variable Values window opens. Enter your customized database object names in the Value column and click OK.

Note: The Value column of the dialog displays the default name of each database object. This gives you an opportunity to review and/or rename the objects that will be created. For example, one could preface all index names with the IX.
The Choose object listing option page of the wizard opens.

- Do not create catalog tables option, the Select QMF Catalog page of the wizard opens.

Creating database objects for the QMF catalog

The second step to enabling QMF catalog functionality is to review and run the SQL that is used to create the database objects for the QMF catalog.

About this task

This step of the process is necessary only if catalog objects were created on the data source or the existing catalog objects need to be updated.

To modify the SQL statements that will be used to create or update the required database objects:

Procedure

1. If you chose to create or update catalog tables, the Choose object listing option page of the QMF catalog wizard opens.
2. Select an object listing option from the radio group:
   - Include all objects - This option includes all objects that are saved in the data source, regardless of a user's ability to access them.
   - Include only objects accessible by either the user's primary or current authorization ID
   - Include only objects accessible by any of the user's primary or current authorization ID
3. Click Next. The Create objects page of the QMF Catalog wizard opens.
4. The SQL that will be used to create or update the tables is displayed in the field. Type any changes that you want to make to the SQL statements directly in the field. You can modify any of the SQL statements to customize any parameters. You can not change the name of any of the objects. You must use a semi-colon(;) to separate multiple statements. Unless absolutely necessary, it is recommended that you run the SQL as it is displayed.

Note: You can switch the RDBI.PROFILE_VIEW to use RDBI.PROFILES or Q.PROFILES tables by specifying them in SQL. When you switch the table, you must specify correct values for the ENVIRONMENT column for each CREATOR.

- In the existing table row for a particular CREATOR, specify <NULL> to make the creator available for both QMF for TSO and CICS and QMF for Workstation or QMF for WebSphere.
- Copy the existing table row for a particular creator and replace TSO or CICS with WINDOWS. The creator is available for both QMF for TSO and CICS and QMF for Workstation or QMF for WebSphere.
5. Click Next. A QMF catalog named Default will be created when this step is run. The Protect QMF Catalog tables page of the wizard opens.
Protecting catalog tables and granting user permissions

The third step to configuring a relational data source to use a QMF catalog is to specify whether the QMF catalog tables will be protected from unauthorized users and to specify the users that will have permission to access the tables.

About this task

Several tables in the QMF catalog store sensitive information that should not be available to the public. You can choose to protect the QMF catalog tables. In protection mode, the QMF catalog tables are accessed using a collection of stored procedures or SQL packages depending on what the database that is hosting the QMF catalog supports. Users of the QMF catalog must then be granted permission to run the stored procedures or static SQL packages.

To protect the QMF catalog tables:

Procedure

1. Open the Protect QMF Catalog tables page of the wizard.
2. To specify the type of protection that will be applied to the QMF catalog tables, select one of the following from the Connect using Protected Mode radio group:
   • **Never**: You select this option to specify that no protection will be placed on the QMF catalog tables. This method will expose the QMF catalog tables to unauthorized use. With no protection the QMF catalog tables can be accessed by any user using dynamic queries. When the database administrator grants permissions to a user to access the QMF catalog that resides on the database, that permission will extend to the whole QMF catalog including the tables in the QMF catalog that store sensitive information.
   • **If possible**: You select this option to specify that the QMF catalog tables will be protected using either stored procedures or static SQL packages if they are available on the data source. You will specify the users that can run the stored procedures or static SQL packages. If a set of stored procedures or static SQL packages is not available, access to the QMF catalog tables will be as if they are unprotected.
   • **Always**: You select this option to specify that the QMF catalog tables will always be protected using either stored procedures or static SQL packages. You will specify the users that can run the stored procedures or static SQL packages. If a set of stored procedures or static SQL packages is not available, the query to access the QMF catalog tables will fail.
3. If you selected **If possible** or **Always** from the Connect using Protected Mode radio group, the Protect check box becomes available.
4. Select the Protect check box. The protection method options become available.
5. Select one of the following protection methods:
   • Select **Stored procedures** to specify that you will use stored procedures to protect the QMF catalog tables. You can select this option if the repository storage tables are located on one of the following databases:
     – DB2 UDB LUW V9 and above
     – DB2 z/OS V9 and above
     – DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
   • Select **Static SQL packages** to specify that you will use static SQL packages to protect the QMF catalog tables. You can select this option if the...
repository storage tables are located on a DB2 database that you will connect to using the IBM DB2 Universal driver for JDBC or the Direct DRDA connectivity provided by the product (the latter option is available for DB2 for z/OS connectivity only).

6. Type, or select from the drop-down list, the name that you want to use to identify the collection of stored procedures or static SQL packages in the Collection ID field.

7. Optionally you can type the owner name in the Owner ID field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.

8. Click Create. The stored procedures are created or the static SQL packages are bound. A message is issued that informs you of the success of either process. You can also use Delete to remove a collection of stored procedures or static packages.

9. You must specify which users will have permission to run the stored procedures or static SQL packages for the QMF catalog tables on this database. To grant permission to all users, highlight PUBLIC in the User IDs list and click Grant. To grant permission to specific users, type their user IDs in the field, highlight one or more of the user ID(s) and click Grant. A message is issued that informs you that the selected user IDs have been granted permission to run the stored procedures or static SQL packages. Optionally, you can revoke permission to run the stored procedures or SQL packages from any user that is listed in the User IDs list box. To revoke permission from one or more users, highlight one or more of the user IDs and click Revoke. A message is issued informing you that permission to run the stored procedures or static SQL packages has been revoked from the selected user IDs.

10. Click Next. The Select QMF Catalog page of the QMF Catalog wizard opens.

Selecting the QMF catalog

The last step to configuring a data source so that it can access a QMF catalog is to select a QMF catalog.

About this task

To select the QMF catalog for the data source:

Procedure

1. Open the Select QMF Catalog page of the QMF Catalog wizard.

2. From the Data source name list, select the data source that hosts the QMF catalog that you want the data source that you are configuring to use. This could be the same data source as the one you are currently configuring or a different data source that has already been configured in your repository.

3. From the Catalog list, select the catalog that you want the current data source that you are configuring to use. You can choose one of the following types of catalogs:

   • **Default**: This is the main QMF catalog. It is created automatically as a result of running the SQL statements to create objects on the data source. All objects saved to a default catalog are saved together. The Default catalog is the only catalog that can be used by QMF for TSO/CICS and versions of QMF prior to 7.2.

   • **Extended**: Extended catalogs are extensions of the default catalog. While a data source can only host a single default QMF catalog, it can host multiple
extended catalogs. Extended catalogs are useful when several data sources share one QMF catalog. Without extended catalogs, all objects would be saved into the default QMF catalog. With extended catalogs, each data source can isolate their saved objects in a particular catalog extension.

4. Optional: To create a new extended catalog that will reside on the current data source, select the Add catalog icon. The Add Catalog window opens.

5. Optional: To edit the name or the CCSID of an existing extended QMF catalog, select the Edit catalog icon. The Edit Catalog window opens. You can also use this window to edit the CCSID for the Default QMF catalog.

6. Optional: To delete an existing extended catalog from the current data source select the Remove catalog icon. You should use caution when deleting extended catalogs as QMF for Workstation removes the extended catalog and all of its contents regardless of whether other data sources might be configured to use the extended catalog.

7. Optional: Select Refresh List to refresh the list of available extended catalogs in the list box.

8. Click Finish. The QMF Catalog wizard closes. This is the last step to configuring a data source to use a QMF catalog. Control returns to the Enable data source plug-ins page of the New Relational Data Source wizard.

Creating an extended catalog

You can create extended QMF catalogs to organize user access to objects within the overall default QMF catalog.

About this task

Instead of all objects being in the main default catalog, they can be isolated in smaller extended catalogs. There are many reasons to use extended catalogs. You can use them to control a user's view of objects. You can use them to isolate objects from one data source that is sharing a QMF catalog on another data source. An extended catalog can contain only the selected objects from a specific data source. You can also set up extended catalogs that have different CCSID settings from the main Default catalog.

Note: Performance, a user's views of objects, and the overall maintenance of your query environment can be adversely impacted when a data source uses an extended catalog (or a Default catalog) that resides on a different data source.

To create an extended catalog:

Procedure
1. Open the Add catalog window.
2. Specify a unique name for the extended catalog in the Name field.
3. Select a CCSID code page for the extended catalog from the CCSID list.
4. Click OK. The new extended catalog is created.

Editing an extended catalog's properties

You can change the name or CCSID properties of an extended QMF catalog. You can also change the CCSID property of the default QMF catalog.

About this task

To edit the properties of an extended or default QMF catalog:
Procedure
1. Open the Edit catalog window.
2. Specify a new name for the extended catalog in the Name field. You can not change the name of the Default QMF catalog.
3. Select a new CCSID code page for the extended catalog from the CCSID list. You can change the CCSID of the Default QMF catalog.
4. Click OK. The changes to the QMF catalog: property values are saved.

Creating personal data sources

When creating a data source, you can select to make it personal. It allows you to store this data source on the local file system and access it via any repository connection. A personal data source is not accessible only when you establish a connection to a repository that has another data source under the same name.

About this task

Personal data sources are available only to users who create them.

To create a personal data source, complete the following steps:

Procedure
1. In the Repository Explorer, right-click the category of data sources to which you want to add a personal data source.
2. Click New > Data Source Type. The wizard for creating data sources opens.
3. On the page of availability type selection, select Personal.

Note: This step is skipped when:
• You create a folder data source, because folder data sources can only be personal.
• You are only authorized to create personal data sources in the repository.
4. Complete the procedure of creating the data source as instructed in the topic for this particular type of data sources.
5. Click Finish. You created a personal data source. It is now located under the node of the respective data source type. The created personal data source will be displayed in all of the repositories to which you are connected.
6. To delete the personal data source, right-click it and select Delete. The deleted data source will not be displayed in any of the repositories to which you are connected.

Exporting personal data sources

You can export personal data sources.

About this task

To export personal data sources, complete the following steps:

Procedure
1. From the main menu, select File > Export... The Export wizard opens.
2. Select Personal data sources and click Next. The Export personal data sources page of the wizard opens.
3. When specifying the .wso file for export, you can:
• Leave the path and the name of the default .wso file unchanged.
• Type a path to another .wso file and its name or click Browse to navigate to the file.
4. From the list, select the personal data source that you want to export. To filter the list, type a filter text in the field above the list.

   **Restriction:** Folder data sources cannot be exported.
5. Click Finish. The selected personal data source is exported to the specified file in the local file system.

### Importing personal data sources

You can import personal data sources from your local file system.

**About this task**

To import personal data sources, complete the following steps:

**Procedure**

1. From the main menu, select File > Import... The Import wizard opens.
2. Select Personal data sources and click Next. The Import personal data sources page of the wizard opens.
3. In the File name field, specify a path to a .wso file and the .wso file name, or click Browse to navigate to a .wso file that you want to import and double-click it.
4. From the list, select the personal data source that you want to import. To filter the list, type a filter text in the field above the list.

   **Restriction:** Folder data sources cannot be imported.
5. Click Finish. The imported personal data source is added to the category where the other data sources of the same type are stored.

### Creating a new relational data source

You must add configuration information to your repositories for all relational data sources.

**About this task**

Relational data sources are accessed using JDBC. A relational data source stores data in database tables. Each database table comprises a number of columns, and one or more rows. Queries for relational data sources are written in SQL.

To create a new relational data source:

**Procedure**

1. From the Repositories view, right-click the repository to which you want to add the relational data source configuration information. Select New > Relational Data Source. The Create New Relational Data Source wizard opens.
2. On the page of availability type selection, select Personal or Shared.

   **Note:** For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.
3. Click **Next** to open the Add new relational data source name and connection parameters page of the wizard.

4. In the **JDBC Driver** field specify the library for the JDBC driver that will be used to access the database that is hosting the repository storage. You can select from a drop down list of libraries that you defined when you set up the JDBC driver information. You can use the ellipsis (...) to the right of the field to open the JDBC Libraries dialog where you can create additional JDBC driver libraries.

   **Note:** If you work with a DB2 for z/OS database, you can use the Direct DRDA Connection. In contrast to JDBC libraries, the Direct DRDA Connection comes with QMF and does not require additional driver installation.

   You can enable the use of SSL certificates for the Direct DRDA Connection to make the connection secure.

   **Note:** The Direct DRDA Connection is supported only for DB2 for z/OS Version 9, Version 10, Version 11, and Version 12. Do not use it for DB2 LUW or DB2 for iSeries.

   See [Using DRDA to connect to database repositories and data sources](#) for more information.

5. In the **JDBC URL** list, specify the URL that points to the database that hosts the repository storage within which the repository to which you want to connect resides.

   The format for the URL can be displayed in the list.

   **Note:** You can also use the **Build URL by URL Template** dialog box to form the correct string.

   Click **Build URL** to open the Build URL by URL Template dialog box. From the JDBC URL drop-down list, select the template. In the table, specify the **server**, **port**, and database information and click **OK**. The result URL string is added to the JDBC URL list.

6. Click **Advanced** to specify any driver-specific connection string keywords and their values that will be used when connecting to this shared repository. For information on any keywords that are required by a selected database driver, consult the specific driver’s documentation.

   **Note:** For the DB2® Type 4 UDB driver, to receive extended SQL exception error messages, check the **retrievemessagessFromServerOnGetMessage** option in the Advanced JDBC Settings window.

7. If you use the Direct DRDA Connection, bind packages by clicking the **Bind Packages** button.

8. Click **Set User Information**. The User Information window opens.

9. Select the **User ID and password are required** check box to specify that user information will be requested each time this data source is accessed. This check box can be left clear if the data source does not require logon information, or if the logon information is obtained using some other means, such as Kerberos or Windows authentication.

10. Select the **Try to use repository login and password to connect to this data source** check box to specify that before requesting logon information from the user, the current repository login and password will be used to try and connect to the data source (such as the case in Kerberos security).
11. Specify the user ID and password that will be used to access the data source in the **User name** and **Password** fields. Click **OK**. The User Information window closes and control returns to the Create New Relational Data Source wizard.

12. To test the connection, click **Test Connection**.

13. Click **Next**. The second page of the Create New Relational Data Source wizard opens where you will enable the Database and QMF catalog plug-ins for the data source.

### Enabling data source plug-ins

The second step in configuring a relational data source is to enable one or more of the available plug-ins that provide additional functionality for the data source.

#### About this task

For each relational data source that you configure in the repository you can enable additional functionality that applies specifically to that data source. QMF Catalog Plug-in is an example of such functionality. When you enable the QMF Catalog plug-in for a relational data source, users can access the QMF catalog that you specify whenever they are connected to the data source. They will be able to view and access any objects that are saved in the QMF catalog and, if they choose, they can save any new objects to the QMF catalog. With the QMF Catalog plug-in enabled, accelerator tables are displayed only in the **Accelerator** node of the data source tree of objects. With the plug-in disabled, accelerator tables are displayed both in the **Accelerator** node and the **Database** node of the tree.

If the database that you are using supports IDAA, **Acceleration Database Plug-in** becomes available on the **Properties** page of your data source. Click **Parameters** to configure protection options for Accelerator tables. The procedure is identical to configuring protection options for QMF catalog tables. For more information, see the **Protecting catalog tables and granting user permissions** topic of Administrator Help.

To enable plug-ins for a relational data source:

#### Procedure

1. Open the Enable data source plug-ins page of the Create New Relational Data Source wizard.

2. To configure this data source to use a QMF catalog, select the **QMF Catalog Plug-in Enable Plug-in** check box. The QMF Catalog Wizard opens. Upon completion of the wizard’s processing, control returns to the Enable data source plug-ins page of the Create New Relational Data Source wizard.

3. The QMF catalog will be available to this relational data source. By default, the node label for the QMF catalog as it will appear in the repository will be QMF Catalog. You can specify a unique name. Type the name that you want to use to identify this QMF catalog in the **Catalog Label** field. Optionally, you can type a comment that describes the QMF catalog in the **Comment** field.

4. To change any of the QMF catalog plug-in parameters, click **Parameters**. The QMF Catalog Plug-in Parameters window opens. Upon completion of modifying the parameters, control returns to the Enable data source plug-ins page of the Create New Relational Data Source wizard. You can also open the QMF Catalog Plug-in Parameters window from the **Repository Explorer** view by right-clicking a data source, selecting **Properties** from the pop-up menu, and selecting **Plug-ins** from the **Properties** list.
5. By default, the node label for all of the native database objects for this relational data source as it appears in the repository will be **Database**. You can specify a unique name. Type the name that you want to use to identify these database objects in the **Label** field. You can also choose to type a comment that describes the native database objects in the **Comment** field.

6. Click **Next**. The third page of the Create New Relational Data Source wizard opens where you will select the resource limits provider for the data source.

### Selecting the resource limits provider

The third step in configuring a relational data source is to specify whether the resource limits that will govern access to the data source will be provided from the repository or from the QMF catalog.

#### About this task

To specify the resource limits provider for a relational data source:

#### Procedure

1. Open the Select resource limits provider page of the Create New Relational Data Source wizard.

2. From the **Resource limits provider** drop-down list, select where the resource limits for this data source are defined. Your choices are:
   - **Repository** if the resource limits are defined in the repository.
   - **QMF Catalog** if the resource limits are defined in a QMF catalog. This option is only available if you have enabled the QMF Catalog plug-in for the data source.

3. Click **Finish**. The **Repositories** view lists the data source configuration information under a folder named **Relational Data Sources**. The objects for each data source will be organized in two folders that will include database objects and QMF catalog objects if the QMF catalog was enabled. You have completed the process of configuring a relational data source in the repository. You would now customize the feature set of the data source.

   **Note:** From the **Repositories** view of the data source, you can view and move the listed objects. However, if you want to run any objects you must be connected to the repository. To connect to the repository you must set up repository connection information if it has not been created. Click the repository connection information for the repository that is listed in the **Repository Connections** view. When you are connected to the repository select the object to run from the **Repository Explorer** view.

4. To add, edit, or delete resource limits, right-click the data source in the **Repository Explorer** view (after it has been created) and click **Properties** from the pop-up menu. Select **Resource Limits** from the **Properties** tree. You can add, edit, and delete resource limits groups, schedules and user assignments.

5. You can selectively perform any of the following to customize the feature set of the data source:
   - Set up login mapping for the data source.
   - Add data source information to a workspace.
   - Set up customized workspaces and assign the users and groups that will be allowed to use them.
   - Assign the users and groups permission to access any repository object.
Create, edit, or delete resource limits groups, schedules, and resource limit values.
Set up repository connections.

Specifying additional parameters
You can specify additional data source parameters on the Information page of the data source Properties window.

About this task
You must specify the settings for additional data source parameters that determine how the data source retrieves data. To specify these additional parameters:

Procedure
1. From the Repository Explorer view, right-click the data source that you want to edit and select Properties from the pop-up menu. The Properties window opens.
2. Select Information. The Information page opens.
3. Specify the settings in the Additional parameters table. Valid additional parameters include:

   **Emulate Host QMF Column Naming (DB2 Only)**
   Specifies whether the data source emulates the column naming conventions of the host QMF catalog. This option is only valid for DB2 data sources.

   **Enable Spatial Extensions**
   Specifies whether extensions are enabled for spatial data that is stored in the data source.

   **Schema Retrieval Method**
   Specifies how schemas are retrieved from the database. If you select getTables, the schemas are organized by their table names. If you select getSchemas, the schemas are organized by their owners.

   **Do Not Access Database to Retrieve Query Metadata**
   Specifies whether query metadata is retrieved from the host database. Use this parameter to reduce the time of running the query and display the result set faster. It is FALSE by default. When this parameter is set to TRUE, the application does not refer to database and does not retrieve the metadata. So the result set is displayed faster, but the amount of R/W (read and write) queries is smaller than when the metadata are retrieved and this parameter is set to FALSE.

4. When you finished specifying the additional parameters, click Apply. The changes are saved to the data source.
5. Click OK. The Properties window closes.

Creating a new multidimensional data source
You must add configuration information to your repositories for all multidimensional data sources.
About this task

Multidimensional data sources are accessed using XMLA. Multidimensional data is organized by one or more dimensions. Multidimensional data structures are often referred to as cubes. Queries for multidimensional data sources accessed using XMLA are written in MDX.

To configure multidimensional data source information in a repository:

Procedure

1. Open the New Multidimensional Data Source wizard in one of the following ways:
   - Right-click the Multidimensional Data Sources node in the Repositories view. Select New. Select Multidimensional Data Source from the pop-up menu. The New Multidimensional Data Source wizard opens.
   - From the File menu, select New. Select Other from the pop-up menu. The New window opens. Expand the Repository folder. Select Multidimensional Data Source. The Create New Multidimensional Data Source wizard opens.
2. On the page of availability type selection, select Personal or Shared. Click Next.

   Note: For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.
3. In the Data Source Name field, type a name that will be used to identify the data source in the repository. This can be any name.
4. QMF will use XML for Analysis (XMLA) via HTTP protocol to connect to a multidimensional data source. You specify the URL that will point to the data source in the HTTP URL field.
5. Select User ID and password are required to require the use of a user ID and password when accessing this multidimensional data source. If the data source allows access without a user ID and password, selecting this option will override that allowance, and a user ID and password will be required to access the data source.
6. Specify the user ID and password that will be used to access the data source in the User name and Password fields. To test the connection, click the Test Connection button.
7. Select the multidimensional data source that you want to add to the repository from the Data Source list box. All the data sources that are located at the specified URL address are listed in the Data Source list box. You can refresh the list using the refresh button.
8. Optional: Type a comment that describes the data source in the Description field. This comment will display with the properties for the data source.
9. Click Finish. The multidimensional data source is listed in the Repositories view under the Multidimensional Data Sources node. You would repeat this process for all multidimensional data sources that you want to be accessible from the repository.

Results

Note: Support for resource limits or login mapping is not available for multidimensional data sources.
Creating a Hive data source

You can create Hive data sources to work with Apache Hadoop, which is the open source software framework, used to reliably managing large volumes of structured and unstructured data.

Before you begin

Make sure you have defined the Hive driver library JAR files so that QMF can connect to Hive data sources.

About this task

Hive data source is a data warehouse infrastructure that provides data summarization and ad hoc querying. Hive data sources are accessed using special drivers for JDBC. The current JDBC interface for Hive only supports running queries and fetching results.

To create a Hive data source:

Procedure

1. Select File > New > Other > Repository > Hive Data Source. The Create New Hive Data Source wizard opens.
2. On the page of availability type selection, select Personal or Shared. Click Next.

   Note: For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.
3. Type the data source name in the Data Source Name field.
4. Specify the necessary parameters in the Connection Parameters area. You must set the Host name, Port number, and Database name.
5. Click Set User Information button to specify the necessary user parameters.
6. Click Advanced button to select the advanced parameters supported by the installed Hive driver.
7. In the Description field, you can enter the description of the created data source.
8. Click Finish to create the Hive data source and close the Create New Hive Data Source wizard.

Working with folder data sources

Create folder data sources to access data files on your file system as tables.

Folder data sources provide users with a convenient way to work with data files in separate data sources. When creating a folder data source, you select a folder on your file system, and all the data files of supported types that are located there are converted by the application into tables.

In the Repository Explorer tree, the Tables node structure is based on conversion of the folder and its content.
Table 12. Conversion of folder objects into the Tables node

<table>
<thead>
<tr>
<th>File system object</th>
<th>Folder data source object</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root folder</td>
<td>Root schema</td>
</tr>
<tr>
<td>· Subfolder (if included)</td>
<td>Schema</td>
</tr>
<tr>
<td>· .xls file</td>
<td></td>
</tr>
<tr>
<td>· .xlsx file</td>
<td></td>
</tr>
<tr>
<td>· Data file of a supported type (except .xls, .xlsx files)</td>
<td>Table</td>
</tr>
<tr>
<td>· Spreadsheet in a .xls or .xlsx file</td>
<td></td>
</tr>
</tbody>
</table>

You work with such tables in the standard query editor. You can also configure the display of content of data files.

Folder data sources can be accessed locally, only by users who created them, regardless of the repository connection they are using.

Creating folder data sources

Create folder data sources to access data files from your file system as tables. You can work with the following file formats: xls, xlsx, csv, txt, xml, ixf, dbf, tab, ctab.

About this task

Each created folder data source represents a folder selected from your file system so that all data files of supported types in this folder are converted into tables. By default, all folder data sources are personal.

To create a folder data source, perform the following steps:

Procedure

1. Open the Create Folder Data Source wizard in one of the following ways:
   - Right-click the Folder Data Sources node in the Repositories view. Select New > Folder Data Source from the context menu. The Create Folder Data Source wizard opens.
   - Select File > New > Other. The New window opens. Expand the Repository folder. Select Folder Data Source. The Create Folder Data Source wizard opens.
2. Enter a name for the new folder data source in the Data Source Name field.
3. Specify the folder data source parameters in the Parameters area:
   - In the Directory field, specify the path to the source folder, or browse for it by clicking the ellipsis (...) button.
   - To include the subfolders in the selected source folder, select the Include subfolders check box.
   - To include the hidden files in the selected source folder, select the Include hidden files check box.
4. In the Comment field, type a comment to describe the created folder data source. The comment will be displayed in the properties of this data source.
5. Click Finish.
Results

You created a folder data source. It is now located under the Folder Data Sources node.

Editing folder data sources

You can configure the display of content of data files in folder data sources.

About this task

Depending on the format of data files, you can configure different parameters of data display in folder data sources. To configure data display in folder data source:

Procedure

1. Right-click a table that you want to edit.
2. Select Properties > Import Parameters.
3. If available, from the Encoding list, select the encoding type.
4. In Settings, specify how content of the data file is converted into the table. The steps to perform in Settings depend on the type of the data files and correspond to the analogous procedure for imported files. For more information, see topics on importing data files in “Specifying conversion options for Excel files in folder data sources” on page 98 and “Specifying conversion options for CSV and TXT files in folder data sources” on page 98.
5. Click Metadata to configure the table fields.
6. Select what columns to include in the result set by checking the check boxes to the left of the Field name column.
7. To edit a column name, click a cell in the Field name column and enter a new name.
8. To specify a different data type, click a cell in the Type column and select a data type from the list. Available options are the following:
   • INTEGER can be used to store signed whole numbers between -2 147 483 648 and 2 147 483 647.
   • BIGINT can be used to store large signed whole numbers between -9 223 372 036 854 775 808 and 9 223 372 036 854 775 807.
   • DOUBLE can be used to store large numbers with a floating decimal point.
   • CHAR is used to store fixed-length string of characters. For example, you can use it to store employee phone number which is generally fixed in length.
   • VARCHAR is used to store variable-length string of characters like employee name.
   • DECIMAL is used to store the fixed precision and scale numbers. This data type should be used for precise values, such as currency.
   • DATE is used to store a date only.
   • TIME is used to store a time only.
   • TIMESTAMP is used to store both a date and a time.

Note: DATE, TIME, and TIMESTAMP data types support different format options that define how the values are displayed in the result set.

Note: The supported ranges and the precision of values might vary depending on the database you use.
9. In the **Length** field, specify a maximum number of characters for the VARCHAR type.
10. In the **Precision** field, specify a maximum total number of digits for the DECIMAL type.
11. In the **Scale** field, specify a maximum number of:
   - fractional digits for the DECIMAL type
   - digits in the fractional seconds part for the TIMESTAMP or TIMESTAMP WITH TIMEZONE type
12. In the **Preview** pane, you can track how each selection changes the layout of the result set.
13. To save the changes and close the dialog, click **OK**.
14. To save the changes without closing the dialog, click **Apply**.
15. To restore the original metadata configuration, click **Restore Defaults**.
16. To cancel the changes to the fields, click **Cancel**.

**Specifying conversion options for Excel files in folder data sources**

You use the **Settings** tab of the Import Parameters wizard to specify how QMF will convert the data of the Excel file into a table in the folder data source.

**About this task**

To specify conversion options in **Settings** for the Excel file:

**Procedure**
1. Click the **Settings** tab of the Import Parameters wizard.
2. In the **First row number** field, type the row number of the Excel sheet that you want to be the first row in the result set.
3. In the **First column number** field, type the column number of the Excel sheet that you want to be the first column in the result set.
4. To limit the number of rows in the result set, select the **Row limit** check box and type the number of rows.
5. To limit the number of columns in the result set, select the **Column limit** check box and type the number of columns.
6. If you want to turn the first row of the Excel document into the column names of the result set, select the **First row contains column names** check box.
7. In the **Preview** pane, you can track how each selection changes the layout of the result set.

**Specifying conversion options for CSV and TXT files in folder data sources**

You use the **Settings** tab of the Import Parameters wizard to specify how QMF will convert the data of the CSV or TXT file into a table in the folder data source.

**About this task**

To specify conversion options in **Settings** for the CSV or TXT file:

**Procedure**
1. Click the **Settings** tab of the Import Parameters wizard.
2. Select the **Skip rows starting with** check box and specify a string in the text field to exclude certain rows from the result set.
3. Select what symbol is used to display decimal points in the file in the Decimal separator drop-down list.

4. Select the First row contains column names check box to specify that the first line of the file contains the names of columns to be created.

5. To specify that the columns will be created based on a fixed set of character lengths, click Fixed width and then specify the specific widths of the columns by entering the character lengths in the Specify columns width field. When each character length is reached in the text, the characters after that point are placed in a separate column, regardless of the content of the text.

6. To specify that the columns will be created automatically by breaking at certain symbols, click Separated by and then selecting the symbols check boxes below. When the result set is made, each time these symbols are encountered in the text, the characters after the symbol are placed in a separate column.

7. Select the Merge separators check box to consolidate columns that are created by multiple adjacent separators into one column. For example, if Comma and Space are selected and the text includes the string NAME, DEPT, three columns will be created. The first column contains NAME, and was created when the comma was encountered. The second column is empty, and was created when the space was encountered. The third column contains DEPT, and was created when the remaining text was encountered. By selecting the Merge separators check box, only one column is created when the comma and the space are encountered.

8. Select whether a single or double quotation marks are used to delineate text in the Text qualifier drop-down list. Text that is contained in the specified quotes is always displayed as is, whether it contains a separator symbol or not.

9. In the Preview pane, you can track how each selection changes the layout of the result set.

Creating a virtual data source

Create a virtual data source to tailor the way users view enterprise data. Virtual data sources introduce a database metadata layer that allows you to optionally hide the complexities of your underlying database structures.

About this task

To create a new virtual data source:

Procedure

1. Open the New Virtual Source wizard in one of the following ways:
   - Right-click the Virtual Data Sources node in the Repositories view. Select New > New Virtual Data Source from the pop-up menu. The New Virtual Source wizard opens.

   The Create New Virtual Source wizard opens.

2. On the page of availability type selection, select Personal or Shared. Click Next.

   Note: For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.

3. Enter a name for the new virtual data source in the Data Source Name field.
4. Specify the virtual data source parameters in the **Parameters** area:
   a. Select **In-memory** check box to create an inner in-memory database for the work of the virtual data source.
   b. If you want to save the inner database in to the file system, select **Back up server on shutdown** check box. Then when you shut down the application in normal mode the database will be saved to the file system and retrieved at the next launch of the application.

5. Click **Finish**. The new virtual data source is listed under the **Virtual Data Sources** node.

**Results**

You have added a new virtual data source.

The new virtual data source is displayed under the **Virtual Data Sources** node.

**What to do next**

You can now add tables to the virtual data source.

**Editing virtual data sources**

Use the virtual data source editor to manage the content and structure of virtual data sources and to administer user and user group authorization to a data source.

To edit a virtual data source, locate it in the **Repository Explorer** view and double-click it. The [DataSourceName] editor opens.

The [DataSourceName] editor consists of two sections:

- The **Structure** section, from which you can modify the structure of a virtual data source.
- The **Security** section, from which you can administer users and user groups authorization to the data source stored in the secured repository.

**Modifying the structure of virtual data sources**

Use the Structure tab of the virtual data source editor to modify the structure of virtual data sources.

**About this task**

To modify the structure of your virtual data source, complete the following steps:

**Procedure**

1. In the **Repository Explorer** pane, select the table or query that you want to add to your virtual data source and click **Copy Selected**. You added an object to your virtual data source. You can also add tables to your virtual data source by using the Virtual Table wizard. For more information, see the **Creating virtual tables** topic of the User Help.

2. In the **Tables** pane, edit the tables that are stored in your virtual data source.
   a. To add a column to your table, select the table and click **Add Column**.
   b. To edit the expression of a calculated column, select a column with an expression and click **Edit**.
c. To delete a column from your table, expand the table, select the column that you want to remove, and click **Delete**.

d. To change the position of a column, expand your table, select the column that you want to reposition and click **Move Up** or **Move Down**.

e. To specify cache expiration schedules for your table, select it and click **Assign Expiration Schedules**.

f. To edit the source query of your table, right-click the table and select **Edit Table SQL** or **Edit Table Link...**, depending on the type of your source query.

**Administering virtual data sources**

Use the Security tab of the virtual data source editor to set user roles and permissions for your virtual data source that is stored in a secured repository.

**About this task**

Complete the following steps to administer your virtual data source:

**Procedure**

1. To apply user permissions to a table or a column, expand **Tables** in the **Tables** pane and select the table that you want to administer.

2. See the list of users and user groups in the **Groups or users names** pane.
   
   a. To filter the list, select or clear the **Show users** and **Show groups** check boxes.
   
   b. To edit the permissions of each user or user group, select it and drag it to the **Permissions** pane.

3. Edit the permissions that are currently authorized for each owner in the **Permissions** pane. For more information about the permissions, see [Assigning users and groups permission to use repository objects](#).

4. Apply user permissions to specific table rows in the **Row level security conditions** pane.
   
   a. To apply user permissions on a row level, select the user that you want to grant permissions to in the **Permissions** pane.
   
   b. In the **Row level security conditions** pane, select the **Override parent’s conditions** check box.
   
   c. In the editor area, type the column name, the values of which you want to use as a filter, and type the condition. For example, if you work with the Q.STAFF table and only want to display managers to a particular user, type `Job='MGR'`.

   **Note:** The **Row level security conditions** pane is only available for virtual tables based on relational tables.

5. Click **Apply** to save the settings.

**Specifying settings of cache expiration schedules in virtual and JavaScript data sources**

You can enable caching for virtual data sources and tables that they store on the **Cache Settings** page of virtual data source properties window.
About this task

When you enabled caching for a virtual data source, records from the tables stored in this virtual data source are cached. If you open one of these tables, its records will be retrieved from cache rather than from the data source. You can also enable caching for individual tables within a virtual data source.

To enable caching for virtual data sources:

Procedure

1. Select File > New > Other > Virtual Data Source Schedule to open the Create New Expiration Schedule wizard.
2. From the Data source list, select the data source to which you want to specify the cache expiration scheduler.
3. In the Schedule name field, enter the name you want to use for this schedule.
4. In the Data Expires area, specify the period of the cache expiration. The available options are:
   a. Hourly: Select this option to specify that the same cache data will be used for one hour period.
   b. Daily: Select this option to specify that the same cache data will be used for a 24 hour period.
   c. Weekly: Select this option to specify that the same cache data will be used for a period of 7 days.
   d. Monthly: Select this option to specify that the same cache data will be used for a month.
   e. At specific date: Select this option to specify that the same cache data will be used until a specific date is reached. If you select this option, the cache will be updated on the specific date.
   f. Never expires: Select this option to specify that the same cache data will always be used. If you select this option, the cache will never be updated.
   g. Always expired: Select this option to specify that the data will always be updated every time a query is run against this data source.
5. If you selected Hourly, Daily, Weekly, Monthly, or At specific date, click Next.
6. Depending on the type of schedule that you are creating one of the following variations of the Set schedule properties page of the wizard opens:
   a. If you selected Hourly, specify the date and time that the hour period will start in the Begin date and the Begin time fields. In the Expiration Interval area, specify expiration interval in Hours and Minutes fields.
   b. If you selected Daily, specify the date and time that the 24 hour period will start in the Begin date and the Begin time fields. You specify when the 24 hour period will occur in the Data Expires area:
      • Select Daily to specify that the 24 period will occur every day.
      • Select Each to specify that the 24 hour period will occur every number of days and select the number from the list.
      • Select Days of week to specify that the 24 hour period will occur on one or more specific days. You must select the check boxes for the proper days.
   c. If you selected Weekly, specify the date and time that the week will start in the Begin date and the Begin time fields. You can select a number from the
Each week list to specify that the 7 day period will occur every number of weeks. In the Days of Week area, specify particular days on which the cache will be updated.

d. If you selected Monthly, specify the date and time that the month will start in the Begin date and the Begin time fields. You can enter a specific day in the Day field or to specify that data retrieval will occur on a specific day of the week in the month in the Or field. In the Select Months area, specify the required months.

e. If you selected At specific date, specify the date and time that will trigger data retrieval in the Date and time list. Click the cell, the ellipsis (...) appears. Then click the ellipsis (...) to open a calendar where you will select the date and time.

7. Click Finish. The schedule is created and listed in the Schedules node of the particular virtual data source in the Repository Explorer view.

Scheduling cache expiration for virtual and JavaScript data sources

You can use expiration schedules for virtual data sources and tables that they store on the Cache Settings page of virtual data source Properties window.

About this task

When the Use expiration schedules check box is clear the caching expiration mode equals Always Expired for a virtual data source. Records from the tables stored in this data source are updated each time on-demand.

To specify particular cache schedule for virtual data sources or their tables, complete the following procedure:

Procedure

1. From the Repositories or Repository Explorer view, right-click a virtual data source and select Properties.


3. On the Cache Settings page, select the Use expiration schedules check box. The schedule expiration settings become available.

4. From the Default expiration schedule list, select the schedule that you want to use as the default one for the whole data source.

Note: A created data source has Always Expired default settings. To add more schedules create them in the data source wizard.

5. To assign a particular cache expiration schedule to a particular table click the Schedule name column of the table the settings of which you want to modify and select the required scheduler from the list of available ones.

Note: If tables contain any substitution variables, only Always Expired expiration schedule is applied to such tables.

6. If you have any tables that require authorization for accessing them, you must specify the authorization settings for the data source. Click the Manage Authorization button. The Manage Authorization dialog opens.

7. All the data sources that require authorization are listed there. This authorization data will be used for updating the cache. Click Login column for the required data source. The Edit Data Source Login dialog opens.
8. Enter the proper values in the Login and Password fields and click OK.

9. When you finish specifying authorization data for all required data sources, click OK in the Manage Authorization dialog.

10. Click Apply and then click OK to close the Properties for [data source] window.

**Enabling automatic refresh for virtual data source cache**

Enabling the application to automatically refresh the virtual data source cache allows users to run queries against the virtual data source faster.

**Before you begin**

Before you can enable the automatic cache refresh option for a virtual data source, make sure to schedule cache expiration for that data source. For more information, see the Scheduling cache expiration for virtual and JavaScript data sources topic of Administrator Help.

**About this task**

To enable the automatic cache refresh option for a virtual data source, complete the following steps:

**Procedure**

1. From the main menu, select View > Preferences.
2. On the left side of the Preferences window, click Virtual Data Source.
3. Select the Enable automatic cache refresh check box.
4. Click Apply, then click OK.

**Invalidating virtual data source and JavaScript data source cache manually**

You can manually invalidate the cache of a virtual or JavaScript data source and the tables that it contains to make sure that you work with the most current data.

**About this task**

To manually invalidate the cache of a virtual or JavaScript data source, complete the following steps:

**Procedure**

1. From the Repositories or Repository Explorer view, right-click the virtual or JavaScript data source whose cache you want to invalidate and select Properties from the menu.
2. In the Properties window, select Cache Settings.
3. Click to invalidate the data source cache manually.

**Note:** Make sure that the virtual or JavaScript data source that you work with contains at least one cached table. Otherwise, the button is not available.
Working with JavaScript data sources

You can collect data from network resources and store it inside the application in the form of JavaScript data sources.

The following topics include reference information about JavaScript data sources:

Creating a JavaScript data source

Create a JavaScript data source to collect data from a web service as a data source and process it in the form of relational tables.

About this task

To create a JavaScript data source, perform the following steps:

Procedure

1. From the main menu, select File > New > Other.
2. In the New window, expand the Repository folder and select JavaScript Data Source. The Create JavaScript Data Source wizard opens.
3. On the page of availability type selection, select Personal or Shared. Click Next.

Note: For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.

4. Enter a name for the data source in the Data Source Name field.
5. In the Connection Parameters area:
   a. In the URL field, enter the URL of the web resource to that you want to connect and get data.
   b. Select the User ID and password are required check box to request user information each time when the web resource is accessed. If the web resource does not require logon information, leave the check box clear.
   c. Select the Allow users to save password check box if you want to allow the application to remember the password for the entered user ID.
6. Click Next. On the JavaScript Parameters page of the wizard, specify the global parameters for the data source that you can address by using the dataSource.parameters object in JavaScript modules. You can easily modify these parameters if you need to connect to other web resource or with other user credentials.
   a. Click Add Parameter, enter the parameter name and value in the corresponding columns.
   b. To delete parameters from the data source, select them and click Remove Parameter.
7. Click Finish.

Results

You created a JavaScript data source. The editors for the Authenticate, Common Functions, and Disconnect JavaScript modules open. Now, populate the data source with JavaScript tables.
Objects and methods in JavaScript data sources

Use the dataSource object to address the parameters and the sendHTTPRequest() method to create RSBIHttpRequest objects in JavaScript data source.

<table>
<thead>
<tr>
<th>Object Properties</th>
<th>Possible Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>dataSource.parameters</td>
<td>Object</td>
<td>The parameters that are specified for the JavaScript data source on the second page of the Create JavaScript Data Source wizard. For example, if the supportTeamEmail parameters was specified in the wizard, you can address it by using dataSource.parameters.supportTeamEmail in the code.</td>
</tr>
<tr>
<td>dataSource.url</td>
<td>String</td>
<td>The URL that was specified for the JavaScript data source.</td>
</tr>
<tr>
<td>dataSource.userinfo.login</td>
<td>String</td>
<td>The user name that was specified for the network resource in JavaScript data source.</td>
</tr>
<tr>
<td>dataSource.userinfo.password</td>
<td>String</td>
<td>The password that was specified for the network resource in JavaScript data source.</td>
</tr>
</tbody>
</table>

sendHTTPRequest() method

You can use the sendHTTPRequest() method to create RSBIHttpRequest objects in JavaScript data sources only.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>method</td>
<td>Specifies the HTTP method to use, such as &quot;GET&quot;, &quot;POST&quot;, &quot;PUT&quot;, &quot;DELETE&quot;, and so on.</td>
</tr>
<tr>
<td>url</td>
<td>Specifies the URL to send the request to.</td>
</tr>
<tr>
<td>headers</td>
<td>Specifies the list of header field definitions as a JavaScript object. (Optional)</td>
</tr>
<tr>
<td>body</td>
<td>Specifies the data that is sent in the request to the server. It is relevant for the &quot;PUT&quot;, &quot;PATCH&quot;, and &quot;POST&quot; methods. (Optional)</td>
</tr>
</tbody>
</table>

Note:
- When you use the sendHTTPRequest() method, SSL certificates are ignored.
- If the url parameter does not contain the http prefix, the url is relative to the one that is specified in the dataSource.url property. For example, dataSource.url = www.example.com and url = page1, the final url is www.example.com/page1.

Examples

var request = dataSource.sendHTTPRequest("GET",url);

RSBIHttpRequest class:

The class that is used to make HTTP requests. It has the same functions as the standard JavaScript object XMLHttpRequest 1.0. The latter is also supported but it is recommended to use RSBIHttpRequest.

NTLM authentication

You can specify the additional parameters in the open() method of RSBIHttpRequest class to use NTLM authentication. See Example 2.
## Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>method</strong></td>
<td>Specifies the HTTP method to use, such as &quot;GET&quot;, &quot;POST&quot;, &quot;PUT&quot;, &quot;DELETE&quot; and so on.</td>
</tr>
<tr>
<td><strong>url</strong></td>
<td>Specifies the URL to send the request to.</td>
</tr>
<tr>
<td><strong>async</strong></td>
<td>Supplies a Boolean value indicating whether or not to perform the operation asynchronously.</td>
</tr>
<tr>
<td><strong>username</strong></td>
<td>Required for NTLM authentication. This parameter specifies the name of the user.</td>
</tr>
<tr>
<td><strong>password</strong></td>
<td>Required for NTLM authentication. This parameter specifies the password of the user.</td>
</tr>
<tr>
<td><strong>domain</strong></td>
<td>Required for NTLM authentication. This parameter specifies the name of the domain.</td>
</tr>
<tr>
<td><strong>workstation</strong></td>
<td>Optional for NTLM authentication. This parameter specifies the name of the workstation.</td>
</tr>
</tbody>
</table>

## Using HTTPS

If you want to use the HTTPS protocol to send the HTTP requests, you must first configure your Java virtual machine to handle the SSL certificates properly. If you do not want to do the configuration, use the `RSBIHttpRequest.ignoreCertificates()` method. In this case, your JVM is set to ignore the SSL certificates and the connection that is established is not secure.

## Examples

### Example 1

```javascript
var request = new RSBIHttpRequest();
request.open('GET','http://example.com', false);
```

### Example 2

```javascript
var req = new RSBIHttpRequest();
req.open("GET", 'http://example.com', false, "username", "password", "domain", "workstation");
```

or

```javascript
req.open("GET", 'http://example.com', false, "username", "password", "domain");
```

## Methods

**getAllResponseHeaders()**

The `getAllResponseHeaders()` method returns a string with a list of header field definitions, which are separated by "\r\n".

**getResponseHeader()**

The `getResponseHeader()` method returns a header field definition with the specified name.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>name</strong></td>
<td>Specifies the name of the HTTP header field definition that you want to get.</td>
</tr>
</tbody>
</table>
Parameter | Description
---|---
method | Specifies the HTTP method to use, such as "GET", "POST", "PUT", "DELETE" and so on.
url | Specifies the URL to send the request to.
async | Supplies a Boolean value indicating whether or not to perform the operation asynchronously.
username | Required for NTLM authentication. This parameter specifies the name of the user.
password | Required for NTLM authentication. This parameter specifies the password of the user.
domain | Required for NTLM authentication. This parameter specifies the name of the domain.
workstation | Optional for NTLM authentication. This parameter specifies the name of the workstation.

**Note:** You can specify additional parameters in the open() method of RSBIHttpRequest class to use NTLM authentication. See Example 2.

**Examples**

1. var request = new RSBIHttpRequest();
   request.open('GET','http://example.com', false);
2. var req = new RSBIHttpRequest();
   req.open('GET', 'http://example.com', false, 'username', 'password', 'domain', 'workstation');
3. req.open('GET', 'http://example.com', false, 'username', 'password', 'domain');

**send()** The send() method sends a JavaScript object to the web service.

Parameter | Description
---|---
data | Specifies the object that you want to sent in the HTTP request.

**setRequestHeader()**

The setRequestHeader() method allows setting the name and value of a header field definition.

Parameter | Description
---|---
name | Specifies the name of the HTTP header field definition that you want to send.
value | Specifies the value of the HTTP header field definition that you want to send.

**Example**

```javascript
request.setRequestHeader("Content-Type","application/x-www-form-urlencoded");
```

**RSBIHttpRequest constants**

Use the following states instead of constants to specify the state of the RSBIHttpRequest object.

<table>
<thead>
<tr>
<th>Constant</th>
<th>RSBIHttpRequest Object State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Uninitialized</td>
</tr>
<tr>
<td>Constant</td>
<td>RSBIHttpRequest Object State</td>
</tr>
<tr>
<td>----------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>1</td>
<td>Loading</td>
</tr>
<tr>
<td>2</td>
<td>Loaded</td>
</tr>
<tr>
<td>3</td>
<td>Interactive</td>
</tr>
<tr>
<td>4</td>
<td>Complete</td>
</tr>
</tbody>
</table>

**Example**

See the example of retrieving the required data from the Internet.

```javascript
if(request.readyState === request.Complete) is used instead of
if(request.readyState === 4).

function getStockData(url) {
  var request = new RSBIHttpRequest();
  request.open('GET', url, false);
  var response = '';
  request.onreadystatechange = function() {
    if(request.readyState === request.Complete) {
      response = request.responseText;
    }
  }
  request.send(null);
  return response;
}
```

**Modules in JavaScript data sources**

The following topics include reference information about preset and user modules in JavaScript data sources.

Users can work with the following preset modules in JavaScript data sources:

- *Authenticate* can contain the script for connecting to a web service and authorizing at it.
- *Common Functions* can contain the common script with global functions that you want to use in other modules. For example, functions for getting data from a web service or caching.
- *Disconnect* can contain the script for disconnecting from a web service and logging out from it.

Users can also create additional modules to expand the functionality of a JavaScript data source according to their needs.

The preset and user modules are always initialized in the following order:

1. *Common Functions* module
2. User modules
3. *Authenticate* module
4. *Load Data* modules of the JavaScript tables that are stored in the data source. *Load Data* modules are used to process the data from a network resource in a relational table.
5. *Disconnect* module

**Working with JavaScript Tables**

You can use JavaScript Tables to collect the data from network resources and process it in the form of relational tables.
For example, you need to collect the stock exchange information from a financial portal for a certain period of time and save this information so that you can use it in QMF as a typical relational table.

For this, you create a JavaScript Table, specify its structure, and save it to a JavaScript data source or a virtual data source. In the JavaScript Table editor, you write a script that populates the table with the required data retrieved over HTTP or HTTPS. When you run a query based on the created JavaScript Table, the script retrieves the data and saves it in a table that is used by the query.

If it is necessary, you can use external functions and objects from different modules that are either saved in a repository or located on a web server.

You can run queries based on a JavaScript Table and use them to create quick reports, forecasts, or add them to visual dashboards.

**Creating JavaScript Tables**

You use the Create JavaScript Table wizard to add a new JavaScript Table and specify its structure.

**About this task**

To create a JavaScript Table:

**Procedure**

1. Select File > New > Other. In the opened window select JavaScript Tables and click Next. The Create New JavaScript Table wizard opens.
2. On the Add New JavaScript Table page, specify the name for the table you create and select a JavaScript data source or a virtual data source where you want to save it. Click Next.

   **Note:** The Data Source list contains only virtual data sources from the current repository connection.
3. On the JavaScript Table Structure page, define the table structure including the list of columns, their order, value types and required parameters. You can also add comments to any column.
4. Click Finish to close the wizard. The JavaScript Table with the specified name and structure is added to the selected JavaScript data source or virtual data source. After closing the wizard, JavaScript Table editor opens.
5. In the JavaScript Table editor, you create scripts to populate the JavaScript Table with the required data.
6. When you finish working with script, save the changes and close the editor.

**Results**

Now you can use the created JavaScript Table as a typical relational table. For example, you can run queries based on the created JavaScript Table, use them to create quick reports, forecasts, or add to visual dashboards.

**Writing scripts to populate JavaScript Table:**

Once you created a JavaScript Table and specified its structure, you need to write a script that will populate the table with the required data.
About this task

You write the script in the JavaScript Table editor according to general JavaScript syntax rules. The editor opens automatically after you close the Create New JavaScript Table wizard.

To manage the content of a JavaScript Table, you can also use the following special functions of the table global object:

appendData()
  Inserts the data specified by a two-dimensional array to the end of the JavaScript Table.

replaceData()
  Completely replaces the content of a JavaScript Table with the data specified by a two-dimensional array of the following form: [[<row 1 column1>, <row 1 column 2>,...], [<row 2 column 1>, <row 2 column 2>,...],...].

eraseData()
  Removes JavaScript Table records that satisfy the specified SQL condition. If you call eraseData() function without arguments or with null argument, all table records are removed.

setTag()
  Links the JavaScript Table with some additional information specified by a string. This information can be retrieved by the getTag() method. To clear the information, use setTag() with null argument or without arguments.

getTag()
  Returns the additional information related to the JavaScript Table.

include()
  You can include external code in your JavaScript Table script by using the include() method.

To trace HTTP request, response, and record logs, use the log() function.

You can also use prompted variables in the script. A user will be prompted to enter variable values when running a query based on the created JavaScript Table. If you use a prompted variable in the script, note the following peculiarities:

- The JavaScript Table cache is ignored.
- When a user works with a JavaScript Table in QMF for WebSphere, all the retrieved data will be available to that user only.

You can work with the preset modules or create custom ones.

When you finish working with the script, save the changes and close the editor.

Procedure

1. If you want to work with the preset modules, add JavaScript to them. For more information about modules, see "Modules in JavaScript data sources" on page 109.

2. To add a user module:
   a. In the Repository Explorer view, right-click the Modules node of the data source and select New > JavaScript Module.
b. In the New JavaScript Module wizard, specify the name for the JavaScript Module in the Name field and click Finish to open the JavaScript Module editor.

3. Type script in the modules and save them.

   **Important:** If you work with preset modules, do not duplicate names of variables in different modules to avoid conflicts during their execution.

**JavaScript Table Example:**

The following example demonstrates how to use JavaScript Tables.

**Purpose**

You need to collect stock exchange information from a financial portal for a certain period of time and save this information so that you can use it in QMF as a typical relational table. The table must not be updated too often and store information longer than 30 days.

**Preparing table structure**

Before you begin writing the script, you need to make sure that the specified table structure corresponds to the data that you need to retrieve.

**Planning the script structure**

According to the purpose the script must retrieve information from server, parse the data to fill the table, save and check the last modification time, and remove outdated information.

```javascript
var lastModificationDate = getTableModificationTime();
if (needUpdate(lastModificationDate))
{
    var raw_data = retrieveRawData(url);
    var data = parseData(raw_data);
    table.appendData(data);
    eraseOutdated();
    setTableModificationTime();
}
else
{
    log("Data is already up to date ");
}
```

The following functions are used:

- `setTableModificationTime()` to attach the last modification time to the table.
- `getTableModificationTime()` to get the last table modification time.
- `needUpdate()` to check if update is required depending on the last modification time.
- `retrieveRawData()` to get the required data from the portal.
- `parseData()` to split the received string according to the table structure.
- `eraseOutdated()` to remove old records.
- `log()` to trace the response status and write information to the Output view.
Retrieving data from the Internet

First of all, you need to retrieve the required data from the Internet. For this, 

**RSBIHttpRequest** class is used:

```javascript
function getStockData(url)
{
    var request = new RSBIHttpRequest();
    request.open('GET',url, false);
    var response = '';
    request.onreadystatechange = function()
    {
        if(request.readyState === request.Complete)
        {
            response = request.responseText;
        }
    }
    request.send(null);
    return response;
}
```

**Tip:** If you want to use the HTTPS protocol to send HTTP requests for your JavaScript table, you must first configure your Java virtual machine to handle the SSL certificates properly. If you do not want to do the configuration, use the **RSBIHttpRequest.ignoreCertificates()** method. In this case, your JVM is set to ignore the SSL certificates and the connection that is established is not secure.

The **getStockData()** function returns the response string with all required data from the portal.

It is called from the **retrieveRawData()** function that forms an HTTP request and uses **log()** function to trace response information. You can also use prompted variables (the **symbols** variable) in script – user will be prompted to specify the values when running the query. The **_DSQQW_DQ** global variable is used for substitution of double quotes.

```javascript
function retrieveRawData()
{
    var symbols = _DSQQW_DQ&symbols&DSQQW_DQ;
    var url = "http://finance.yahoo.com/d/quotes.csv?s="+symbols+'&f=snl1d1t1ohgdr';
    var raw_data = getStockData(url);
    log(raw_data);
    return raw_data;
}
```

### Parsing received data

Secondly, you need to parse the retrieved data according to your purposes so that you can fill the table with the help of **appendData() or replaceData()** functions. The easiest way is to split the response string:

```javascript
function parseData(raw_data)
{
    var data = [];
    var rows = raw_data.split('\n');
    for (var i=0; i < rows.length; i++)
    {
        var row = rows[i].trim();
        if (row !== '')
        {
            var cells = row.split(',');
            data.push(cells);
        }
    }
    return data;
}
```
Specifying data update interval

You can attach modification time (as any additional information in string format) to the table with the help of setTag() function. The getTag() function is used to retrieve this information.

1. Setting the current time (last modification) as a table tag:
   
   ```javascript
   function setTableModificationTime()
   {
   var currentDate = new Date();
   table.setTag(currentDate.getTime());
   }
   ```

2. Retrieving the last modification time:
   
   ```javascript
   function getTableModificationTime()
   {
   var tag = table.getTag();
   if (tag === null)
   {
   var d = new Date();
   d.setDate(-2); // to force update for the first time use
   tag = d.getTime();
   }
   else
   {
   tag = parseInt(tag);
   }
   return tag;
   }
   ```

3. Checking whether update is required:
   
   ```javascript
   function needUpdate(lastModificationDate)
   {
   var yesterday = new Date();
   yesterday.setDate(-1);
   return lastModificationDate <= yesterday.getTime();
   }
   ```

Removing outdated information

You can use the eraseData() function to remove outdated information from the table:

```javascript
function eraseOutdated()
{
var expirationDate = new Date();
expirationDate.setDate(-30);
var day = expirationDate.getDay();
var month = expirationDate.getMonth() + 1;
var year = expirationDate.getFullYear() + 1900;
var strDate = year + '-' + month + '-' + day;

table.eraseData("Last Trade Date"+ '+' + strDate + '"");
}
```  

Displaying results

When you finish working with the script, save the changes and close the editor.
To run the query, navigate to the saved JavaScript Table in the Repository Explorer view and double-click it. Run the opened query.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Name</th>
<th>Last Trade (Price Only)</th>
<th>Last Trade Date</th>
<th>Last Trade Time</th>
<th>Open</th>
<th>Day’s High</th>
<th>Day’s Low</th>
<th>Dividend/Share</th>
<th>P/E Ratio</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Coke</td>
<td>91.98</td>
<td>2012-04-02</td>
<td>18:11</td>
<td>63.96</td>
<td>68.92</td>
<td>91.28</td>
<td>2.28</td>
<td>9.35</td>
</tr>
<tr>
<td>2</td>
<td>General Electric</td>
<td>23.94</td>
<td>2012-04-02</td>
<td>18:11</td>
<td>23.20</td>
<td>23.17</td>
<td>23.09</td>
<td>0.20</td>
<td>17.88</td>
</tr>
<tr>
<td>3</td>
<td>Microsoft Corp</td>
<td>28.80</td>
<td>2012-04-02</td>
<td>18:11</td>
<td>28.80</td>
<td>28.80</td>
<td>28.52</td>
<td>0.86</td>
<td>23.72</td>
</tr>
</tbody>
</table>

**Editing JavaScript Tables**

You can edit the structure and the script of already created JavaScript Table.

**About this task**

To edit JavaScript table:

**Procedure**

1. In the Repositories or Repository Explorer view, navigate to the required JavaScript Table.
2. To edit the structure of the JavaScript Table, right-click this table and select Properties from the popup menu.
   a. Open the Structure page in the Properties window.
   b. Change the table structure including the list of columns, their order, value types and required parameters. You can also add comments to any column.
   c. To cancel unsaved changes, click Restore Defaults.
   d. To save the updated structure of the JavaScript Table, click Apply, and then OK.

   **Note:** All the data will be removed from the table.
3. To edit the script of the JavaScript Table, right-click this table and select Edit Source Script from the popup menu. In the opened JavaScript Table editor, rewrite the script according to your purposes. Once you finished editing the source script, save the JavaScript Table.

**Scheduling cache expiration for virtual and JavaScript data sources**

You can use expiration schedules for virtual data sources and tables that they store on the Cache Settings page of virtual data source Properties window.

**About this task**

When the Use expiration schedules check box is clear the caching expiration mode equals Always Expired for a virtual data source. Records from the tables stored in this data source are updated each time on-demand.

To specify particular cache schedule for virtual data sources or their tables, complete the following procedure:

**Procedure**

1. From the Repositories or Repository Explorer view, right-click a virtual data source and select Properties.
3. On the Cache Settings page, select the Use expiration schedules check box. The schedule expiration settings become available.

4. From the Default expiration schedule list, select the schedule that you want to use as the default one for the whole data source.

   **Note:** A created data source has Always Expired default settings. To add more schedules create them in the data source wizard.

5. To assign a particular cache expiration schedule to a particular table click the Schedule name column of the table the settings of which you want to modify and select the required scheduler from the list of available ones.

   **Note:** If tables contain any substitution variables, only Always Expired expiration schedule is applied to such tables.

6. If you have any tables that require authorization for accessing them, you must specify the authorization settings for the data source. Click the Manage Authorization button. The Manage Authorization dialog opens.

7. All the data sources that require authorization are listed there. This authorization data will be used for updating the cache. Click Login column for the required data source. The Edit Data Source Login dialog opens.

8. Enter the proper values in the Login and Password fields and click OK.

9. When you finish specifying authorization data for all required data sources, click OK in the Manage Authorization dialog.

10. Click Apply and then click OK to close the Properties for [data source] window.

**Specifying settings of cache expiration schedules in virtual and JavaScript data sources**

You can enable caching for virtual data sources and tables that they store on the Cache Settings page of virtual data source properties window.

**About this task**

When you enabled caching for a virtual data source, records from the tables stored in this virtual data source are cached. If you open one of these tables, its records will be retrieved from cache rather than from the data source. You can also enable caching for individual tables within a virtual data source.

To enable caching for virtual data sources:

**Procedure**

1. Select File > New > Other > Virtual Data Source Schedule to open the Create New Expiration Schedule wizard.

2. From the Data source list, select the data source to which you want to specify the cache expiration scheduler.

3. In the Schedule name field, enter the name you want to use for this schedule.

4. In the Data Expires area, specify the period of the cache expiration. The available options are:
   a. Hourly: Select this option to specify that the same cache data will be used for one hour period.
   b. Daily: Select this option to specify that the same cache data will be used for a 24 hour period.
c. **Weekly**: Select this option to specify that the same cache data will be used for a period of 7 days.

d. **Monthly**: Select this option to specify that the same cache data will be used for a month.

e. **At specific date**: Select this option to specify that the same cache data will be used until a specific date is reached. If you select this option, the cache will be updated on the specific date.

f. **Never expires**: Select this option to specify that the same cache data will always be used. If you select this option, the cache will never be updated.

g. **Always expired**: Select this option to specify that the data will always be updated every time a query is run against this data source.

5. If you selected **Hourly, Daily, Weekly, Monthly, or At specific date**, click Next.

6. Depending on the type of schedule that you are creating one of the following variations of the **Set schedule properties** page of the wizard opens:

   a. If you selected **Hourly**, specify the date and time that the hour period will start in the **Begin date** and the **Begin time** fields. In the **Expiration Interval** area, specify expiration interval in **Hours** and **Minutes** fields.

   b. If you selected **Daily**, specify the date and time that the 24 hour period will start in the **Begin date** and the **Begin time** fields. You specify when the 24 hour period will occur in the **Data Expires** area:
      - Select **Daily** to specify that the 24 period will occur every day.
      - Select **Each** to specify that the 24 hour period will occur every number of days and select the number from the list.
      - Select **Days of week** to specify that the 24 hour period will occur on one or more specific days. You must select the check boxes for the proper days.

   c. If you selected **Weekly**, specify the date and time that the week will start in the **Begin date** and the **Begin time** fields. You can select a number from the **Each week** list to specify that the 7 day period will occur every number of weeks. In the **Days of Week** area, specify particular days on which the cache will be updated.

   d. If you selected **Monthly**, specify the date and time that the month will start in the **Begin date** and the **Begin time** fields. You can enter a specific day in the **Day** field or to specify that data retrieval will occur on a specific day of the week in the month in the **Or** field. In the **Select Months** area, specify the required months.

   e. If you selected **At specific date**, specify the date and time that will trigger data retrieval in the **Date and time** list. Click the cell, the ellipsis (...) appears. Then click the ellipsis (...) to open a calendar where you will select the date and time.

7. Click **Finish**. The schedule is created and listed in the **Schedules** node of the particular virtual data source in the Repository Explorer view.

**Modifying connection parameters in JavaScript data sources**

You can edit the URL and logon information of the existing JavaScript data source.

**About this task**

To edit modify connection parameters of JavaScript data sources:
**Procedure**

1. In the Repositories or Repository Explorer view, right-click the JavaScript data sources the parameters of that you want to modify and select **Properties**.

2. In the **Connection Parameters** area:
   a. In the URL field, enter the URL of the web resource to that you want to connect and get data.
   b. Select the **User ID and password are required** check box to request user information each time when the web resource is accessed. If the web resource does not require logon information, leave the check box clear.
   c. Select the **Allow users to save password** check box if you want to allow the application to remember the password for the entered user ID.

3. In the JavaScript parameters table, you can add or remove parameters:
   a. Click **Add Parameter**, enter the parameter name and value in the corresponding columns.
   b. To delete parameters from the data source, select them and click **Remove Parameter**.

4. To cancel unsaved changes, click **Restore Defaults**.

5. To save the updated structure of the JavaScript Table, click **Apply**, and then **OK**.

---

**Creating a QMF Data Service data source**

QMF Data Service data sources allow users to work with tables provided by QMF Data Service.

**About this task**

To create a QMF Data Service data source, perform the following steps:

**Procedure**

1. From the main menu, select **File > New > Other > Repository > QMF Data Service Data Source**. The Create QMF Data Service Data Source wizard opens.

2. On the page of availability type selection, select **Personal** or **Shared**. Click **Next**.

   **Note:** For more information about types of data source availability, see Chapter 12, “Data sources,” on page 81.

3. In the **Data Source Name** area, specify the name for the data source.

4. In the **Connection Parameters** area, specify host server name, port number, and encoding.

   **Note:** If the encoding that you want to specify for the data source is not present in the **Encoding** list, you can type it manually.

5. Click **Set User Information**.

6. In the User Information window, you can specify user information for accessing the data source and allow users to save password.

7. If you want to access tables that are provided by one of the server subsystems, select the **Subsystem** check box. From the list, select the subsystem that you want to work with.

   If you want to access virtual tables, leave the check box clear.

8. To test the connection, click **Test Connection**.
9. Click Finish.

Results

You created a QMF Data Service data source.
Chapter 13. Setting up workspaces

Use the workbench to create workspaces for QMF for Workstation users.

In Eclipse, workspaces are used to organize a collection of projects. In QMF for Workstation, users can create a workspace to house projects that hold the artifacts (data sources and repository objects) needed to build interactive visual tools, such as visual dashboards and reports.

As the administrator you can choose to have your QMF for Workstation users work with repository objects from a workspace, or directly from the repository. Every repository that you create has one default workspace that is created automatically. Initially, all users have access to the default workspace.

The first step to setting up a workspace is to specify the contents of the workspace. You can then assign users and groups permission to use the workspace and the workspace objects.

Advantages of using workspaces

There are advantages to having your users access repository objects from a workspace. If you have chosen the Internal or LDAP security option for the repository, you can create one or more workspaces and assign specific users and groups varying levels of access to the entire workspace or to specific objects within the workspace. If you have chosen no additional security for the repository, then one or more workspaces can help organize repository objects.

If you choose not to use workspaces and have your QMF for Workstation users access repository objects directly from the repository, you should recommend they alter the views that are opened by default with the User perspective. Instead of opening the Workspaces view by default, change the perspective so that the Repository Explorer view opens by default.

Adding content to the workspace

You can populated the workspaces you create by adding data source and repository objects that will be available to the users of the workspace.

About this task

Initially, every workspace, including the default workspace created automatically when you created the repository, is empty.

This task describes how to add content to a workspace.

To add content to a workspace, perform the following procedure:

Procedure

1. From the Repositories or Repository Explorer view select an object (such as a data source, folder, query, dashboard, report) that you want to add to the workspace. The object that you select must be available to you in the repository to which you are currently connected.
2. With the mouse button pressed drag the object to the workspace folder. Release the mouse button. You can also right-click the object and select Copy from the pop-up menu, then right-click the workspace folder to which you want to add the object.

3. Depending on the type of object that you selected a pop-up menu opens. One or more of the following options become available:
   - **Copy Here** to make a copy of the object in the workspace.
   - **Move here** to move the object from the repository to the workspace.
   - **Create link here** to create a link to the object. Each time a user or group accesses the object they will actually link to the resource.
   - **Create offline entry** to create an offline entry to the object. The Create Offline entries window opens. Check each of the entries that you want to copy (in their entirety). Offline entries allow you to work with an object from a data source without actually accessing the data source. Users are responsible for keeping offline entries in the workspace synchronized with the actual contents of the repository.
   - **Paste as Offline** is the same as Create offline entry except the object was copied to the clipboard rather than dragged to the workspace.

---

### Adding a workspace as a user

You can optionally choose to set up additional workspaces for your users and groups.

**About this task**

To add a workspace as a user, perform the following procedure:

**Procedure**

2. Specify the name for the new workspace in the Name field.
3. Specify a comment that describes the workspace in the Comment field.
4. Click Finish. After you have created a workspace, you specify what data source information and objects will be available in the workspace, and specify the user and groups that will have permission to use the workspace.
Chapter 14. Working with ER diagrams

Use ER diagrams to specify relationships among columns of related tables and store these relations.

For example, a table stores the staff data for everyone in a company. This table includes a column that is named DEPT that stores the identifier of the department in which an employee works. Another table stores the organization data of each department in the company. This table includes a column that is named DEPTNAME that stores the name of each department in the company. These two tables are related, as they have columns that can be easily joined. But when a user opens either one of these tables, this relationship is not readily apparent. By creating an ER diagram that includes these two tables and all of their possible joins, you can make this relationship much easier to see. Now when users open these tables, the ER Diagrams editor displays all of the relationships that you saved, and users can make more effective and dynamic reports.

Creating ER diagrams

Use ER diagrams to create abstract and conceptual representations of relational databases that can be used for building conceptual connections among table columns.

About this task

To create an ER diagram:

Procedure
1. From the main menu, select File > New > Other. The New window opens.
2. Expand the QMF Objects folder, select ER Diagram, and click Next. The Create New ER Diagram wizard opens.
3. Enter a name for the ER diagram in the Name field.
4. Enter the data source that you want to associate with the ER diagram in the Data source list. The Data source list is populated with all data sources in the repository.
5. Click Finish. The new ER diagram is added to the data source and the ER Diagram editor with this diagram opens.

Editing ER diagrams

When you created an ER diagram manually, you must specify the tables and column joins that you want to include in the entity relationship.

About this task

When you include tables that have possible column connections in your ER diagram, you make the process of building queries and reports much easier for your users.

To edit an ER diagram:
Procedure

1. Double-click the ER diagram that you want to edit. The ER Diagram editor opens. The associated data source is displayed in the left pane of the editor.

2. Expand the Tables node of the Database folder.

3. Drag each of the tables that you want to include in the diagram to the right pane of the editor. A visual representation of each table that you add is displayed.

   **Restriction:** Accelerator tables cannot be added to an ER diagram.

4. To set up join conditions between tables, select a column from one table and drag it to a column in another table. A connecting line is drawn between the joined columns. You can set up multiple join conditions.

5. To edit a join condition, right-click a connection line and select **Edit.** The Join Tables window opens.

6. Select the type of join for linking two tables. The available join types are:
   - **Inner join** includes only those rows with matching values in both tables in the query results.
   - **Left outer join** includes all the rows from the left table and only the rows from the right table that match with rows from the left table in the query results.
   - **Right outer join** includes all the rows from the right table and only the rows from the left table that match with rows from the right table in the query results.
   - **Full outer join** includes all rows from both tables in the query result.

7. Click **Change.** The new join conditions are saved.

8. To delete a join condition, right-click a connection line and select **Delete.**

   **Note:** All the join modifications (adding, editing, and deleting) that you specify for two tables in an ER diagram are automatically applied to these tables in other ER diagrams in this data source. If you add only one of the joined tables to an ER diagram, you can add the other table automatically by right-clicking the ER diagram and selecting **Add Linked Tables.**

9. To add a textual note to the ER diagram, right-click in the ER diagram editor and select **Add Text.** A text box is displayed. You can add text, resize the text box, and move the text box from one point in the diagram to another. Use text notes allow to convey additional information about the tables and joins in the ER diagram to your users.

10. To delete a text box, right-click it and select **Delete.**

11. To show or hide a column of a table, right-click the column name in the table diagram and select **Hide/Show columns.** The Hide/Show Columns window opens and contains all of the available table columns.

12. Select a column's associated check box to show the column, clear it to hide the column, and click **OK.** The Hide/Show Columns window closes and the changes to the table diagram are displayed.

13. When you are finished adding tables and configuring join conditions, click the **Save** icon. The edited ER diagram is saved to the ER Diagrams folder of the data source. Now, when a user builds a query that includes one or more of these tables, the join conditions that you configured are automatically added to the query and displayed in the Query Builder editor.
Creating ER diagram folders

You can create entity relationship diagram folders to add a folder for ER diagrams to the data source.

About this task

To create an ER diagram folder:

Procedure

1. From the main menu, select File > New > Other. The New window opens.
2. Expand the QMF Objects folder, select ER Diagrams folder, and click Next. The Create New ER Diagrams Folder wizard opens.
3. Specify attributes for an ER Diagrams Folder:
   a. Enter a name for the ER diagram folder in the Name field.
   b. Enter a parent folder for the new ER diagram folder in the Parent folder field.
   c. Optional: If you want to add a comment to describe the new folder with ER Diagrams, type it in the Comment field. This comment is displayed in the properties of the created ER diagram folder.
4. Click Finish. The Create New ER Diagrams Folder wizard closes and the new ER diagram folder is displayed under the parent folder in the data source.

Results

You can create new ER diagrams, copy the existing ones, or move them to ER diagram folders for grouping. You can also populate ER diagram folders with ER diagrams automatically.

Populating ER diagrams automatically

You can specify the tables to which you want to create joins automatically and QMF populates existing ER diagram folders with ER diagrams for these tables.

Before you begin

You must have an ER diagram folder to populate it.

About this task

To populate ER diagrams:

Procedure

1. In the Repository Explorer view, right-click the ER diagram folder that you want to populate and select Populate.
2. In the Set Name Filter window, you can specify the following criteria:
   a. In the Object owner field, specify the identifier that owns the tables that you want to join in ER diagrams. You must specify the owner in the correct format for identifiers. You can use a pattern with a wildcard character in this field to match multiple owners.
b. In the **Object name** field, specify the identifier that names the tables join in ER diagrams. You must specify the name in the correct format for identifiers. You can specify a matching pattern with a wildcard character to match multiple names.

3. Click **OK** to close the Set Name Filter window and start the populating process.

**Results**

When the ER diagram is built, it is displayed in the ER Diagram editor. For detailed information about editing the created ER diagrams, see the [Editing ER diagrams](#) topic.
Chapter 15. Setting up environments

An environment is a collection of data source definitions.

Environments allow you to point a repository object to a different data source without making any changes to the objects themselves. This can be useful for testing purposes when it is not recommended to test objects against production data. You can define a test environment that points to a test data source and use it for development. Users can use a production environment once all objects have been tested.

One default environment always exists and cannot be deleted.

When you create a new environment, it reads data source definitions from the default environment. You can then change those definitions so they point to different locations.

If you have more than one environment available, you can switch between them.

Creating a new environment

You can create a new environment using the Create New Environment wizard.

About this task

To create a new environment:

Procedure

1. From the Administrator perspective, select File > New > Other. The New window opens.
2. Expand the Environments folder, select Environment and click Next. The Create New Environment wizard opens.
3. Specify a name for the environment in the Environment Name field and click Next.
4. Use the check box to select the data sources that you want to include in the environment from the Environments Contents table. Clear items use original data source definitions (as defined in the default environment).
5. Select the connection string you want to specify and click Test Connection. The Log on to Data Source window opens. The Connection Settings wizard opens.
6. Specify a user name in the User name field and a password in the Password field and click OK. The system displays The connection to the data source was established.
7. To change the connection string of the data source, select the connection string that you want to edit and click the ellipsis (...). The Connection Settings wizard opens.
8. Either specify a new JDBC URL in the JDBC URL field or use the Build JDBC URL field to build the JDBC URL.
9. Click Advanced to specify additional JDBC settings. The Advanced JDBC Settings wizard opens.
10. Enter any required driver-specific connection string keywords for this data source and click OK.

   **Note:** For more information on any keywords that might be required or supported by the selected driver, consult the driver's documentation.

11. Click OK. The Connection Settings window closes and control returns to the Create New Environment wizard.

12. Click **Finish**. The Create New Environment wizard closes and the new environment is listed under the **Environments** node.

### Editing environment connection settings

You can edit connection settings and add data sources to an environment by using the Edit Environment dialog.

**About this task**

To edit the connection settings from an existing environment:

**Procedure**

1. From the **Repositories** view, expand the **Environments** folder, right-click the environment that you want to edit and select **Edit**. The Edit Environment window opens.

2. Use the check box to select the data sources that you want to include in the environment from the **Environments Contents** table. Clear items use original data source definitions (as defined in the *default* environment).

3. Select the connection string you want to specify and click **Test Connection**. The Log on to Data Source window opens. The Connection Settings wizard opens.

4. Specify a user name in the **User name** field and a password in the **Password** field and click **OK**. The system displays **The connection to the data source was established**.

5. To change the connection string of the data source, select the connection string that you want to edit and click the ellipsis (...). The Connection Settings wizard opens.

6. Either specify a new JDBC URL in the **JDBC URL** field or use the **Build JDBC URL** field to build the JDBC URL.

7. Click **Advanced** to specify additional JDBC settings. The Advanced JDBC Settings wizard opens.

8. Enter any required driver-specific connection string keywords for this data source and click **OK**.

   **Note:** For more information on any keywords that can be required or supported by the selected driver, consult the driver’s documentation.

9. Click **OK**. The Connection Settings window closes and control returns to the Edit Environment window.

10. Click **OK**. The Edit Environment window closes and the changes to the environment are saved.
Chapter 16. Creating the repository connection for QMF

QMF needs to know how to access the application data (as grouped by the repository name) so that users will have access to this data. The way to provide this connection data to QMF is to create it using the QMF connection wizard.

About this task

You must create connection information for each repository. The repository connection information specifies how a shared repository will be accessed. You decide the type of connection to create depending on how you want to set up your environment.

The repository connection information is saved in a file called settings.xml. This file is saved in the personal settings directory of the machine that is running the application interface. You can use this file to streamline the process of setting up the environment for all users of QMF.

To create repository connection information:

Procedure

1. Open the Create New Repository Connection wizard by right-clicking anywhere in the Repository Connections view and selecting New > Repository Connection.

2. Select the type of connection that you will create from one of the following radio buttons:
   - **Shared repository** to create a repository connection to a shared repository using a client/server JDBC connection. With client/server access, the user's workstation establishes a direct connection to the repository database using its locally installed JDBC driver. For this type of connection each workstation that runs QMF for Workstation and the server (workstation) that runs QMF for WebSphere must have JDBC drivers installed.
   - **File-based repository** to create a repository connection to a file-based repository stored at a given location. (QMF for Workstation only)
   - **Network repository** to create a repository connection to a shared repository using direct network access. Network connectivity permits users to access a shared repository without the need for direct database connectivity from the workstation. Connecting to repositories using a network connection allows for consolidation of data access at a central server and removes the need to distribute JDBC drivers across each desktop running QMF for Workstation.
   - **Web service repository** to create a repository connection to a shared repository through the QMF for WebSphere web services API using a HTTP or HTTPS connection. Web service connectivity permits users to access a shared repository without the need for direct database connectivity from the workstation. Connecting to repositories using a web service connection allows for consolidation of data access at a central server and removes the need to distribute JDBC drivers across each desktop running QMF for Workstation.

3. Click Next. The second page of the Create New Repository Connection wizard opens. The second page of the wizard differs depending on the type of the repository connection that you are defining.
Creating shared repository connections

You create a shared repository connection to set up the information that will enable you to connect to a shared repository that resides in a database using a client/server JDBC connection.

About this task

The steps in this task describe how to create a shared repository connection.

Note: The connection mode for the shared repository connection is determined by settings on the Protection tab of the Edit Repository Storage window.

To complete the process of creating a shared repository connection:

Procedure

1. Open the second page of the Create New Repository Connection wizard.
2. Specify a name for the repository connection in the Connection name field. This name will be used to identify the connection as it appears in the Repository Connections view. You can enter any name but it is recommended that the name identifies the repository for which this connection information applies.
3. Select the Connect immediately check box to connect to the shared repository immediately. If this check box is clear, the connection information will be created, saved and displayed in the Repository Connections view, but you will not be immediately connected to the repository.
4. In the JDBC Driver field specify the library for the JDBC driver that will be used to access the database that is hosting the repository storage. You can select from a drop down list of libraries that you defined when you set up the JDBC driver information. You can use the ellipsis (...) to the right of the field to open the JDBC Libraries dialog where you can create additional JDBC driver libraries.

Note: If you work with a DB2 for z/OS database, you can use the Direct DRDA Connection. In contrast to JDBC libraries, the Direct DRDA Connection comes with QMF and does not require additional driver installation.

Note: The Direct DRDA Connection is supported only for DB2 for z/OS Version 9, Version 10, and Version 11. Do not use it for DB2 LUW or DB2 for iSeries.

See Using DRDA to connect to database repositories and data sources for more information.
5. In the JDBC URL list, specify the URL that points to the database that hosts the repository storage within which the repository to which you want to connect resides.

The format for the URL can be displayed in the list.

Note: You can also use the Build URL by URL Template dialog box to form the correct string.

Click Build URL to open the Build URL by URL Template dialog box. From the JDBC URL drop-down list, select the template. In the table, specify the server, port, and database information and click OK. The result URL string is added to the JDBC URL list.
6. Click **Advanced** to specify any driver-specific connection string keywords and their values that will be used when connecting to this shared repository. For information on any keywords that are required by a selected database driver, consult the specific driver's documentation.

**Note:** For the DB2® Type 4 UDB driver, to receive extended SQL exception error messages, check the `retrieveMessagesFromServerOnGetMessage` option in the Advanced JDBC Settings window.

7. In the **JDBC Driver** field specify the library for the JDBC driver that will be used to access the database that hosts the repository. Select from a drop-down list of libraries that you defined when you set up the JDBC driver information. Click the ellipsis (…) to open the JDBC Libraries window where you can create additional JDBC driver libraries.

8. In the **JDBC URL** field specify the URL that points to the database that hosts the repository storage within which the repository to which you want to connect resides. The format for the URL can be displayed in the field if you specified an example when setting up the JDBC libraries.

9. Click **Set User Information** to specify the user information that will be used to connect to the repository. The Set User Information window opens.
   
a. Select the **User ID and password are required** check box to specify that user information will be requested each time a connection is made to this shared repository. In some cases, leaving this check box clear will enable users to access the repository without overtly specifying their user information.
   
b. Enter the user ID and password that will be used to access the specified repository database in the **User name** and **Password** fields.
   
c. To remember the password, select the **Remember password** check box.
   
d. To enable the **Single-Use Password Mode**, click **Advanced** and select **Enabled**.

   In the **Repository storage connections timeout** field, enter the time in minutes that the Single-Use Password Mode feature will remain enabled (while not being used) without being closed by application.

   **Note:** A value of zero 0 sets unlimited idle state for the connection timeout, meaning that connection will close only when the session ends.

   Enabling the **Single-Use Password Mode** feature provides users with the ability to log into the repository for the entire session without having to reenter his or her user ID and password.

   Using this feature assumes that you selected **User ID and password are required** and that you have selected **Remember password** check box.

   If you do not select the **Remember password** check box, the system will prompt you for a user ID and password whenever you open the Edit Repository Connection wizard.

10. Click **OK** to close the User Information window.

11. Select **Hide from web service clients** to exclude this connection from the list of available connections in the **Repository connection name** field in QMF for WebSphere.

   This check box is displayed in QMF for WebSphere user interface only. If you are working in the QMF for Workstation user interface, **Hide from web service clients** is not an option.

   If you select this check box, the user cannot establish a web service connection to this repository connection.
12. In the **Repository name** field, select the repository to connect to. If no repositories are listed, click Refresh.

13. Click **Finish**. The repository connection is listed in the **Repository Connections** view. If you selected **Connect immediately**, you are connected to the repository that you selected. This repository connection information is entered in the connections settings file. The next step to creating repository connection information is to distribute this information to each user that will be running QMF for Workstation or to the server (workstation) that is running QMF for WebSphere.

### Creating file-based repository connections

If you are using QMF for Workstation, you can create a file repository connection to set up the information that will enable you to connect to a file-based repository that is stored on a local or network drive.

**About this task**

File connections can only be created for legacy, file-based repositories. The later versions of QMF for Workstation and QMF for WebSphere have replaced file-based repositories with personal repositories.

To complete the creation of a file-based repository connection:

**Procedure**

1. Open the second page of the Create New Repository Connection wizard.
2. Specify a name for the repository connection in the **Connection name** field.
   This name will be used to identify the connection as it appears in the **Repository Connections** view. You can enter any name but it is recommended that the name identifies the repository for which this connection information applies.
3. Select the **Connect immediately** check box to connect to the file-based repository immediately. If this box is clear, the connection information will be created, saved and displayed in the **Repository Connections** view, but you will not be immediately connected to the repository.
4. Click **Finish**. The repository connection is listed in the **Repository Connections** view. If you selected the **Connect immediately**, you are connected to the repository that you selected. This repository connection information is entered in the connections settings file.

### Configuring repository caching

You can configure a caching functionality on your repositories. When caching is enabled on a repository, the system saves the content of the repository (dashboards, queries, visual reports, and other objects) to the memory on the workstation client or on the web server if you are using QMF for WebSphere.

**About this task**

This task describes how to configure repository caching.

**Considerations:**
• Caching happens in local memory on your machine if you are using QMF for Workstation and in memory on the web server if you are using QMF for WebSphere.

Subsequently, the next time you access the repository objects, information is retrieved from memory (without sending a request to the repository), hence retrieval time is reduced.

The following content is cached:
– Content of objects
– Path to objects
– Metadata to tables

• When you make changes to cached repository objects, the cache is refreshed to reflect the changes.

• For QMF for Workstation, the repository cache is cleared whenever you shut down your machine or close the application.

• For QMF for Workstation, users can set repository caching parameters for the version of the application running on their machine.

• For QMF for WebSphere, repository caching is shared between all connections made with the same Repository Connection login.

• For QMF for WebSphere, you must have administrator authorization in order to change repository connection settings.

To configure repository caching:

**Procedure**

1. Open the second page of the Creating New Repository Connection wizard or of the Edit Repository Connection wizard.

2. In the **Repository cache** area, select the **Enable** check box to activate cache configuration options.

   The radio buttons for predefined cache validation are enabled in the **Predefined modes** section.

   To implement a predefined cache validation mode, select the associated radio button. The cache validation processing for each predefined mode are as follows:

   • **Low relevance-High performance**
     If selected, cache validation is not performed.

   • **Balanced relevance/performance**
     If selected cache validation is performed every 5 minutes. This is the default setting for cache validation.

   • **High relevance-Low performance**
     If selected cache validation is performed every 60 seconds (1 minute).

3. To implement custom cache validation, select the **Use custom cache settings** check box.

   When you select the **Use custom cache settings** check box, the options for predefined cache validation modes are disabled.

   Click **Custom. . .** to launch the Repository Cache Settings wizard.

   Use this wizard to specify cache size information and to set validation intervals.

   The wizard consists of two panes:

   • The Repository Caches pane on the left
This pane lists the specific types of repository-related data to cache.

- The Repository Caches Settings pane on the right
  
  This pane is where you set the caching parameters.

  You can set parameter values for general caching, which are applied to each type of repository-related data.

  You can also set parameter values for the different types of repository-related data. These types include:

  - Content Cache
  - Server Metadata Cache
  - Structure Cache
  - Table Metadata Cache

  a. To set general cache settings, click Repository Caches in the list pane and set a value in the Cache validation time (minutes) field.

     The value you enter represents how often (in minutes) that cache validation occurs.

     The value you enter determines how often the cache validates that the objects in it haven’t changed. The system checks the last updated date for every cached object stored in the repository.

     The default value is 5 minutes.

     Any object that has been changed gets removed from the cache.

     Any object that has not been accessed within the time specified, are not removed from the cache.

     Enter 0 (zero) if you never want to refresh the cache. This is useful for repositories with static content.

  b. To set parameter values for the different types of repository-related data, expand Repository Caches and select the type of data to configure. The types of repository-related data and their configuration parameters are as follows:

     - Content Cache

        Includes the following parameter:

        - Content size (megabytes) specifies the maximum size allowed (in megabytes) for cached content.

        The value entered represents the total combined size of all objects stored in the cache and saved to memory on your machine if you are using QMF for Workstation and on the web server if you are using QMF for WebSphere.

        When a new object is added to the cache whose size has reached the maximum allowed size, the system removes objects until it has enough space to accommodate the new object.

        Those objects that have not been accessed for the longest period of time are removed first.

     - Server Metadata Cache

        Includes the following parameters:

        - Lifetime limit (minutes)

        Parameter sets maximum time (in minutes) for records to be kept in cache. Lifetime is calculated for each record starting from the moment of its creation. Upon expiration of specified lifetime record is forced out of cache.

        - Inactivity (minutes)
Parameter sets maximum time (in minutes) for records to be kept in cache without being referenced. Inactivity period is calculated for each record starting from the moment of its last use. Upon expiration of specified inactivity period record is forced out of cache.

- **Structure Cache**
  Includes the following parameters:
  - **Lifetime limit (minutes)**
    Parameter sets maximum time (in minutes) for records to be kept in cache. Lifetime is calculated for each record starting from the moment of its creation. Upon expiration of specified lifetime record is forced out of cache.
  - **Inactivity (minutes)**
    Parameter sets maximum time (in minutes) for records to be kept in cache without being referenced. Inactivity period is calculated for each record starting from the moment of its last use. Upon expiration of specified inactivity period record is forced out of cache.

- **Table Metadata Cache**
  Includes the following parameters:
  - **Lifetime limit (minutes)**
    Parameter sets maximum time (in minutes) for records to be kept in cache. Lifetime is calculated for each record starting from the moment of its creation. Upon expiration of specified lifetime record is forced out of cache.
  - **Inactivity (minutes)**
    Parameter sets maximum time (in minutes) for records to be kept in cache without being referenced. Inactivity period is calculated for each record starting from the moment of its last use. Upon expiration of specified inactivity period record is forced out of cache.

4. Click **Finish** to exit the wizard.

**Results**

You have enabled repository caching and have set the parameters by which caching occurs. The settings are saved to the product configuration.

The system allows you to read and write (save) file Cache settings and uses it to set the current settings directly to the Caches. All settings are grouped by services in the set of configuration records.

---

**Creating network repository connections**

You create a network repository connection to set up the information that will enable you to connect to a shared repository using direct network access.

**About this task**

Network connectivity permits users to access a shared repository without the need for direct database connectivity from the workstation. Connecting to repositories using a network connection allows for consolidation of data access at a central server and removes the need to distribute JDBC drivers across each desktop running QMF for Workstation.
QMF for Workstation users can connect to repositories via a centralized machine running the QMF network repository service. Network connectivity provides similar capabilities to the web-based approach but does not require a web application server in order to operate. In order to use network connectivity you must set up and start the network repository service.

Note: When you create a network repository connection in QMF for Workstation (client) the version of network repository service (server) must be at the same release levels. If the release levels (between the client and server) do not match, network repository connections will not work.

To complete the creation of a network repository connection:

Procedure
1. Set up and start network repository service.
2. Open the second page of the Create New Repository Connection wizard.
3. Specify a name for the repository connection in the Connection name field. This name will be used to identify the connection as it appears in the Repository Connections view. You can enter any name but it is recommended that the name identifies the repository for which this connection information applies.
4. Select the Connect immediately check box to connect to the repository immediately. If this check box is clear, the connection information will be created, saved and displayed in the Repository Connections view, but you will not be immediately connected to the repository.
5. Specify the name or the IP address of the server (or workstation) that is running your network service in the Server host field.
6. Specify the contact port for the network server in the Port field.
7. Click Refresh.
   The available repository connections for the specified network repository service are retrieved. Select the repository connection that you want to use from the list of available repository connections.
8. Click Finish.
   The repository connection is listed in the Repository Connections view. If you selected Connect immediately, you are connected to the repository that you selected. This repository connection information is entered in the connections settings file.

Setting up network repository services
QMF for Workstation users can connect to shared repositories by using a centralized machine that runs the QMF network repository service.

About this task

To set up the QMF network repository service:

Procedure
1. During the installation of QMF for Workstation, all *.jar files are placed in the API installation directory. Copy them to a required directory on the server machine.
2. Copy the product license files to the directory on the server machine referred to in [1 on page 136]. The product license files are located under WEB-INF/config in QMF for WebSphere or in the QMF for Workstation installation directory.

3. Copy the repositories.xml and .bi.jdbc.drivers files to the directory on the server machine referred to in [1 on page 136]. These files are created at installation and populated when you configure repositories with repository connection information and set up JDBC drivers. If you use the QMF for Workstation administrator component, you find the files in the QMF for Workstation installation directory. If you use the QMF for WebSphere Administrator application you find the files in the QMF for WebSphere installation WEB-INF/config directory.

4. To start the network repository service, run the following lines as one command:

   ```java
   java -cp CLASSPATH com.ibm.bi.qmf.core.repository.RepositoryService
   PORT_NUMBER PATH_TO_REPOSITORIES.XML
   ```

   Where:
   - CLASSPATH: Contains the location of the files that were copied to the directory on the server in step one.
   - PORT_NUMBER: The port on which the network repository service must operate. It can be any free TCP/IP port of your choosing.
   - PATH_TO_REPOSITORIES.XML: Provides the path containing the repositories.xml and .bi.jdbc.drivers files. If omitted, the files are assumed to be in the current directory.

   Sample command line (issue the following lines as one command):

   ```java
   java -cp "$qmf_jar_file_name.jar"
   com.ibm.bi.qmf.core.repository.RepositoryService
   8889
   ```

5. QMF for Workstation users connect to the network repository service by using the machine name and designated port as defined in the Network Repository connection information.

---

**Creating web service repository connections**

You create a Web service repository connection to set up the information that will enable you to connect to a shared repository through the QMF for WebSphere web services API using a HTTP or HTTPS connection.

**About this task**

You can used web-based connectivity to access a shared repository without the need for direct database connectivity from the workstation. By using this method to connect to repositories you consolidate data access at a central server, thus removing the need to distribute JDBC drivers across each desktop running QMF for Workstation.

Web-based connectivity is provided by the QMF for WebSphere built-in repository web service. To enable this facility, you must have QMF for WebSphere deployed to a WebSphere Application Server (WAS) instance. In addition, you must have repository connection information available to this version of QMF for WebSphere. QMF for Workstation users connect to the repository using the URL and port to the QMF for WebSphere server.
Note: When you create a web service repository connection in QMF for Workstation (client) the version of web repository service (server) must be at the same release levels. If the release levels (between the client and server) do not match, web service repository connections will not work.

To complete the creation of a web service repository connection:

Procedure
1. Deploy QMF for WebSphere to a WebSphere Application Server (WAS) instance; configure one or more shared repositories, and set up shared repository connection information for each repository.
2. Open the second page of the Create New repository Connection wizard.
3. Specify a name for the repository connection in the Connection name field. This name will be used to identify the connection as it appears in the Repository Connections view. You can enter any name but it is recommended that the name identifies the repository for which this connection information applies.
4. Select the Connect immediately check box to connect to the web service repository immediately. If this box is clear, the connection information will be created, saved and displayed in the Repository Connections view, but you will not be immediately connected to the repository.
5. In the Web Server URL field, specify the URL to launch the instance of QMF for WebSphere whose web services API will be used for this connection. This is the URL address that was created when the instance of QMF for WebSphere was deployed.
6. Click Refresh. The available repository connections that have been defined for the instance of QMF for WebSphere that you specified in the Web Server URL field are retrieved. Select the repository connection that you want to use from the list of available connections.
7. Click Finish. The repository connection is listed in the Repository Connections view. If you selected Connect immediately, you are connected to the repository that you selected. This repository connection information is entered in the connections settings file. The next step to creating repository connection information is to distribute this information to each user that will be running QMF for Workstation.

Results
Currently, when the QMF for WebSphere client opens, it connects to the last accessed repository. An additional connection URL parameter has been added to control which repository connection should be used when the QMF for WebSphere client opens.

For example:
http://host:port/QMF/user?repository=MyConnection

If the connection parameter points to an invalid connection, then the system opens open the Switch Repository window. You can pass logon information for secured repository connections using the user and password parameters.

For example:
http://host:port/QMF/
user?repository=MyConnection&user=userLogin&password=userPassword
Setting up login mapping for a data source

Login mapping enables a user to login to a repository and gain access to one or more of the database data sources that have been configured in that repository using a single user ID and password.

About this task

With login mapping, administrators can set up users so that they can login to a repository and access any data source without specifying another user ID and password that is specific to the database data source. By setting up login mapping, users do not have to continually reenter login information every time they access a database data source, and they do not have to know the login information for each database data source.

You set up login mapping for each data source that you include in the repository. Login mapping can only be set up for data sources that reside in protected repositories. Protected repositories are those that were created with the security option Internal or LDAP. When setting up login mapping for a DB2 database users, you can use a trusted connection if a trusted context is enabled for the managed data source. In this case, the specified connection to the application is recognized as trusted and the database does not require individual user credentials.

When users are assigned several login, it is required to specify priority for each of them. To better understand how it works, consider the following:

- User X is a member of two groups, Group A and Group B. You have assigned a login mapping ID and password for Group A that gives all users assigned to Group A a certain level of access to the data source. You have assigned a login mapping ID and password for Group B that gives all users assigned group B a lesser level of access to the database data source. As a member of both groups, when User X accesses the data source, it is unclear what login information that should be used. Should it be the based on the user as a member of Group A or Group B. The Priority field resolves this issue. You would assign a priority value to the login information. For example, Group A is assigned a priority of 10 and Group B is assigned a priority of 5. When a user that is a member of both groups accesses the data source, access is granted based on the login information of the group, to which the user is a member, with the highest priority. In this example that would be Group A. It is important to note that in this scenario, you can not assign the same priority value to more than one group.

- User X is a member of two groups, Group A and Group B. However, User X must have a distinct level of access to a data source that is different than any other member of either group. You will use the Priority field to resolve this issue. You will assign a login mapping user ID and password to Group B and assign a priority value of 5 to the mapping information. You will assign a login mapping user ID and password to Group A and assign a priority value of 10 to the mapping information. You will assign a login mapping user ID and password for User X and assign a priority value of 25 to mapping information. When User X accesses the data source, the mapping information with the highest priority value will be used. It is important to note that in this scenario, you can not assign the same priority value to a group and individual user that is a member of the group.
The topics below describe how to set up login mapping with and without trusted context.

**Login mapping without trusted connections**

This topic describes the procedure of setting up login mapping without trusted connections.

**About this task**

To set up login mapping for a data source without trusted context:

**Procedure**

1. Right-click a data source in the **Repositories** or the **Repository Explorer** view. Select **Properties** from the menu. The Properties window opens. Select **Login Mapping** from the tree. The Login Mapping page of the window opens. All users and groups that have been defined for the repository are listed in the **Data source login list**. This list is empty if you have not defined any users or groups.

2. If you set up login mapping for a DB2 database, make sure the **Use trusted connections** check box is deselected.

3. To set up mapping for a user or group, select a user or group and click the **Edit data source login** button above the list box. The Edit Data Source Login window opens.

4. Specify the user ID that will be used to login to the database data source in the **Login** field.

5. Specify the password that will be used to login to the database data source in the **Password** field.

6. Verify the password by retyping it in the **Verify password** field.

7. Specify the priority that will be placed on this login information in the **Priority** field. You can enter any numerical value in this field with the value of 1 having the lowest priority. The **Priority** value is used to determine what login mapping ID and password will be invoked for a user that is a member of multiple groups. To find more information about priority, see “Setting up login mapping for a data source” on page 139.

8. Click **OK**. The data source login information for the selected user or group is listed in the **Data source login** list as follows:
   
   - **Login mapping owner** lists the name of the user or group that will use this login to access the data source. This is the same name that appears in the **Users and groups** list box.

   - **Auth ID** specifies the login user ID that will be used to access the data source for the user or group.

   - **Priority** specifies the priority that is assigned to the login information. This priority value determines which login information will be invoked for users that are members of multiple groups.

You will repeat this process for each user or group for which you want to set up login mapping information.

9. To edit existing data source login information, select the data source login information from the **Data source login** list and click the **Edit data source login** button located above the list box. The Edit data source login window opens. You can make changes to any of the fields. Click **OK** to close the Edit data source login window.
10. To delete existing data source login information, select the data source login from the Data source login list and click the Remove data source login button located above the list box.

11. Click OK. The login mapping parameters that you have specified for each user or group are in effect for the data source. You must set up login mapping information individually for each data source in the repository.

**Login mapping for DB2 databases with trusted connections**

This topic describes the procedure of setting up login mapping by means of trusted connections.

**About this task**

When you set up login mapping for users who connect to DB2 data sources, you may use a trusted context. Trusted context is an entity created by a database administrator that determines whether a connection to the database can be used as a trusted connection. The database does not require individual credentials to authenticate users of such trusted connection. It is very practical when an administrator has a lot of user credentials to manage. To use a trusted context, you specify system authorization credentials that were used when creating the trusted context for the current connection to be recognized as trusted. For users who work over a trusted connection, you can assign Auth ID attributes that are specified in the trusted context to define their privileges when connected to the database.

**Note:** You can only use this option if there is a trusted context created for the data source.

To set up login mapping for a data source using a trusted connection:

**Procedure**

1. Right-click a data source in the Repositories or the Repository Explorer view. Select Properties from the menu. The Properties window opens. Select Login Mapping from the tree. The Login Mapping page of the window opens. All users and groups that have been defined for the repository are listed in the Data source login list. This list is empty if you have not defined any users or groups.

2. Select the Use trusted connections check box. The System Authorization Credentials dialog opens. The Edit system authorization credentials button is enabled.

3. Enter the system authorization credentials for the connection to be recognized as trusted. In the ID field, enter the SYSTEM AUTHID specified in the trusted context.

4. Click OK to close the System Authorization Credentials dialog.

**Note:** If the entered information is incorrect, an error message is shown to prompt you to try again.

5. To edit the system authorization credentials, click the Edit system authorization credentials button.

6. Select the Use repository login if Auth ID is not specified check box if you want a repository login to be used when an Auth ID is not assigned.

**Note:** If the repository login is not found in the trusted context, a connection error is registered and the user is returned to the log on dialog.
7. To assign an Auth ID or edit an assigned Auth ID, select a user or a group of users and click the **Edit user account information** button above the list box. The User Account Information window opens.

8. In the **Auth ID** field, specify an Auth ID from the list provided by the trusted context.

9. In the **Priority** field, specify the priority that will be placed on this login information. You can enter any numerical value in this field with the value of 1 having the lowest priority. The **Priority** value is used to determine which Auth ID will be invoked for a user that is a member of multiple groups. To find more information about priority, see “Setting up login mapping for a data source” on page 139.

10. Click **OK**. The data source login information for the selected user or group is listed in the **Data source login** list as follows:

    - **Login mapping owner** lists the name of the user or group that will use this login to access the data source. This is the same name that appears in the **Users and groups** list box.
    - **Auth ID** specifies the login that is used when a trusted connection is established.

    **Note:** If the Auth ID is not specified, the repository login will be used. If the login is not found in the trusted context, a connection error is registered and the user is returned to the log on dialog.

    - **Priority** specifies the priority that is assigned to the login information. This priority value determines which Auth ID will be invoked for users that are members of multiple groups.

    You will repeat this process for each user or group for which you want to set up login mapping information using the trusted context.

11. To delete existing data source login information, select the data source login from the **Data source login** list and click the **Remove data source login** button located above the list box.

12. Click **OK**. The login mapping parameters that you have specified for each user or group are in effect for the data source. You must set up login mapping information individually for each data source in the repository.

---

**Creating web links to data objects**

Use the Web Link wizard to create web links to QMF objects. You can use these links to open the objects directly in web browsers.

**Before you begin**

If you are using QMF for Workstation, the Web Link wizard is available only when you have an available web service repository connection.

**About this task**

To create a web link to data objects:

**Procedure**

1. From the main menu, select **File > New > Other > Web Link** to open the Web Link wizard.
Note: You can also access this wizard from the repository tree pop-up menu option Create Web Link. If you access the wizard by using this method, the Repository object field and User-Defined Parameters are pre-filled automatically.

2. From the Repository object field, select the object to which you want to create a web link.

3. Specify settings for the following Predefined Parameters:
   - The Toolbar check box indicates whether to show or hide the toolbar.
   - The Run check box indicates whether to run the object when it is opened.
   - The Environment check box indicates whether to use the default environment to run the object.
     If you want to use an environment other than the default one, select the check box and choose from the list of environments.
   - The Renderer mode check box is available for visual reports. It determines the mode in which visual report is rendered.

4. Specify User-Defined Parameters to represent the selected parameters of repository objects.
   You can add parameters into the generated URL by selecting Include in URL check box.
   When the Toolbar check box is selected, the URL formula is:
   \[http://\{host\}:{port}/\{app_context\}/g?object_name&param1=value1\]
   When the Toolbar check box is clear, for visual dashboards the URL formula is:
   \[http://\{host\}:{port}/\{app_context\}/go?object_name&param1=value1\]

5. Click Next to display the second page of the Web Link wizard.
   On the page, you can add data sources. Use the Add Data Source and Remove Data Source buttons to edit the list of data sources. In the Login and Password fields, you can enter logins and passwords for added data sources.
   In the Web link name field, enter the name for the current object, that you want to use in the URL and in the tab title in your browser.
   For example, if you specify NEW_OBJECT_NAME in the Web link name field and check the Toolbar check box, the following URL is generated:
   \[http://\{host\}:{port}/\{app_context\}/g?NEW_OBJECT_NAME\]
   When the Toolbar check box is clear, the URL is:
   \[http://\{host\}:{port}/\{app_context\}/go?NEW_OBJECT_NAME\]
   You can change the link name by using the Web link name field.
   If you leave the Web link name field empty, a new name is created automatically.

6. Click Create to generate a web link.
   If the specified link name exists, you must either rename it, or leave the Web link name field empty to create the name automatically.

7. Click Open Web Link to open the created web link in the browser.

8. Click Finish to close the Web Link wizard.

Note:
Chapter 17. Distributing the configured application

The administrator is responsible for distributing a fully configured and operational application to the users.

To do this, the administrator needs to ensure that the application executable, the JDBC JAR files, a populated JDBC driver information file, and a populated repository connection information file are available to each machine that is running QMF for Workstation and to each server (or workstation) that is running QMF for WebSphere.
Chapter 18. Exporting the configuration data to users

QMF administrators are responsible for ensuring that the application executable, the JDBC JAR files, a populated JDBC driver information file, and a populated repository connection information file are available to each machine that is running QMF for Workstation and to each server (or workstation) that is running QMF for WebSphere.

About this task

The following steps describe the most streamlined process for making the QMF configuration available to your users.

Procedure

1. Ensure that the JDBC JAR files are available (assuming that the location of the JDBC driver files is identical for each machine) as follows:
   - to each machine running QMF for Workstation that will connect directly to repositories and data sources using direct database connections.
   - to each server (workstation) running QMF for WebSphere that will connect directly to repositories and data sources using direct database connections.

2. Place the QMF for Workstation installation executable in a directory that is available to all users.

3. Using QMF for Workstation administrative perspective, specify the JDBC driver location information for each type of JDBC driver that will be used to connect to shared repositories and database data sources. The .bi.jdbc.drivers file is automatically updated. Place the JDBC driver information file (.bi.jdbc.drivers) alongside the QMF for Workstation installation executable.

4. Using QMF for Workstation administrative perspective, specify the information required to connect to one or more shared repositories. The repositories.xml file is automatically updated. Place the connection settings file (repositories.xml) alongside the QMF for Workstation installation executable.

5. You can set up a silent installation of QMF for Workstation. A silent installation runs on its own without user intervention. There is no need for users to monitor the installation and provide input via dialog boxes. Using a silent installation, you as the administrator can control what features are installed on the users machine. To set up a silent installation, create the silent installation options file, modify the executable name to include the silent installation parameters, and place the file alongside the QMF for Workstation installation executable.

6. QMF for Workstation users can now install the application by running the executable. The repository connection information and JDBC driver information will automatically be set up on their machine. If the application executable has the silent installation parameter specified, the user will not have to respond to any dialog messages. In lieu of users running the executable, administrators can also use distribution software to complete the installation of QMF for Workstation on each user machine.

7. To update each instance of QMF for WebSphere with the latest repository connection and JDBC driver information. You can do one of the following:
   - Drop the repository connections file (repositories.xml) and the JDBC driver information file (.bi.jdbc.drivers) in the home directory of the workstation
or server that is running QMF for WebSphere. This makes the repository connection and JDBC driver information available to each user of that QMF for WebSphere application.

- Using QMF for Workstation export the repository connections settings file (repositories.xml) and the JDBC driver information file (.bi.jdbc.drivers) to a general location. The exported file is called settings.xml. Using QMF for WebSphere Administrator import the settings.xml file. The repository connection and JDBC driver information is updated on the server (or workstation) that is running QMF for WebSphere.

**Results**

You have exported the QMF configuration data to your users. Users can now begin using the product.

**What to do next**

Each time the repository connections or JDBC information files are updated, they must be distributed again to all the users of QMF for Workstation and to all the servers (or workstations) that are running QMF for WebSphere.

---

**Installing the product silently**

A silent installation runs on its own without user intervention. Users must not monitor the installation and provide input via dialog boxes. Using a silent installation, you as the administrator can control what features are installed on the user machine. To set up a silent installation, you must create a silent installation options file and place the file in the same directory as the QMF for Workstation installation executable.

**About this task**

To install the product silently, see the following topics:

**Creating a response file**

To run a silent installation of QMF for Workstation, you must create a response file that specifies all installation options. This file must specify all the features that you want to install and installation paths.

**About this task**

To create a response file:

**Procedure**

1. In the command line, run the installation command.
   - See the examples for a Windows installation to the current directory:
     setupwin32.exe -r installer.properties
     or
     setupwin64.exe -r installer.properties
     where: -r specifies that the installation software runs in record mode.
   - See the example for a Windows installation to the custom directory:
     setupwin32.exe -r C:\drive_path\response_file.properties
     or
setupwin64.exe -r C:\drive_path\response_file.properties

where:
- `-r` specifies that the installation software is run in the record mode.
- `C:\drive_path\response_file.properties` specifies the path to the response file that you want to create.

2. As the installation proceeds, you select the features that each user that runs this executable installs on their machine.
3. Upon completion of the installation, the application is installed in the directory that you specified during the installation.

Results

The response file is created and saved in the current directory or the directory that you specified in the path.

What to do next

Distribute the files to the user machines to that you want to install the software and run the silent installation.

Running the silent installation

To run a silent installation of QMF for Workstation, you distribute the response file among the user machines to that you want to install the application.

Before you begin

You must have the response file.

About this task

To run the silent installation:

Procedure

1. Optional: If you want the JDBC, repository storage, repository connection, and license information to be included in the user installation, copy the repositories connections file (`repositories.xml`), the JDBC driver file (`.bi.jdbc.drivers`), license file (`*.lic`), and storage file (`.storage`) from the application home directory to the directory where the installation executable is stored.

2. To prepare for the silent mode, rename the response file to `installer.properties` and place it in the same directory with `setupwin32.exe` or `setupwin64.exe`. Use the command line to pass the following arguments for the Windows OS:
   `setupwin32.exe -i silent`
   or
   `setupwin64.exe -i silent`

   where:
   - `-i silent`: specifies that the installation software runs in silent mode.

Note: If you want to use the response file that is stored in the directory that is different from the one where the installation executable is stored, specify the absolute path to the response file in the argument:

   `setupwin32.exe -i silent -f C:\drive_path\response_file.properties`
or

```
setupwin64.exe -i silent -f C:\drive_path\response_file.properties
```

**Results**

The installation is silent; the product directories are created without notification to the user.

---

**Exporting and importing the JDBC driver and connection information**

QMF administrators can distribute repository connection and JDBC driver information by exporting the repositories.xml file and the .bi.jdbc.drivers file; and importing the settings.xml file.

**About this task**

To export and then import the repository connection and JDBC driver information:

**Procedure**

1. Populate the repository connection repositories.xml and the JDBC driver information .bi.jdbc.drivers files.

2. Open the Export window by selecting File > Export. Select Connection and JDBC library settings from the list of available export destinations.

3. Click Next. The Export Connection and JDBC Library Settings page of the wizard opens.

4. A single file called settings.xml will be exported. If you are using QMF for Workstation, specify where to save the settings.xml file in the **Settings file** field. You can use **Browse** to locate a directory that is accessible to all users.

5. Select the connection information that you want to include in the exported settings file. All of the repository connections that are currently defined are listed in the **Repository connections** list box. Select the check box for each connection that you want to include in the settings.xml file.

6. All of the JDBC driver libraries that you have defined are listed in the **JDBC libraries** list box. Select the check box for each JDBC driver library that you want to include in the settings.xml file.

7. Click Finish. If you are using QMF for WebSphere, the Save file window opens which lists the settings.xml file. Click the **Link to file** hyperlink to download the file to your local workstation and click OK. If you are using QMF for Workstation, the Export Connection and JDBC Library Settings page of the wizard closes. The files are exported to the location that you specified in the **Settings file** field.

8. For each instance of QMF that is installed on another machine or server, import the repository connections and JDBC driver information settings.xml file by selecting File > Import. Select Connection and JDBC library settings from the Import window. The Import Connection and JDBC Library Settings page of the wizard opens.

9. Specify where to find the settings.xml file in the **Settings file** field. You can use **Browse** to locate the file.

10. Select the **Repository connections** check box to import the repository connections that have been included in the settings.xml file.

11. Select the **JDBC library settings** check box to import the JDBC driver information that has been included in the settings.xml file.
12. Specify how you want conflicts with previous settings files to be resolved using the Conflict resolving radio buttons. Select Override existing settings to replace all conflicting information with new information. Select Keep existing settings to not update any existing information with new information. Select Manually resolve conflicts to open the Conflicts window where you will manually resolve conflicts between existing and new setting information.

13. Click Finish. The Import Connections and JDBC Library Settings window closes. The repository connection settings and JDBC driver information files are updated for the current machine running QMF for Workstation and the current server (or workstation) running QMF for WebSphere. You can repeat this process each time the JDBC driver information or repository connection information is updated.

Exporting update scripts

Use the Export Update Script feature to apply product updates to all your repository storages and QMF catalogs when you installed a product update.

About this task

The scripts that are generated by the Export Update Script feature automate the process for updating table structures, rebinding packages, and re-creating stored procedures.

The maximal line length of the DDL scripts that are generated by this feature is determined by the value set in the Line width field on the General Preferences page. For more information, see Setting general preferences in the user help.

To generate the update scripts in the newly installed product version, perform the following procedure:

Procedure

1. From the main menu, select File > Export, select Export Update Script, and click Next.
   The Export Storage Update Scripts wizard opens.
2. In the Repository Storages table, select the repository storages that you want to update. Use Select All and Deselect All buttons for more convenient selection.
3. In the Settings pane, specify the following settings for the repository storages:
   (Use the same settings for all selected storages.)
   - Protect using: Stored procedures or Static SQL Packages to set the protection method for the newly installed version of the product.
   - Collection ID for packages to set the collection ID for the packages to update.
   - Owner ID for packages to set the owner ID for the packages to update if it is necessary to change a default.
   - Grant permission on packages to specify particular users and groups for which you are granting permissions. Users and groups must be separated by commas.
   - Database username to set the username that is used to access the databases.
   - Database password to set the password that is used to access the databases.
4. Click Next
5. In the QMF Catalogs table, select the QMF catalogs to update. Use Select All and Deselect All buttons for more convenient selection.

   All settings on the Repository Storages wizard page by default are duplicated on the QMF Catalogs page.
   - **Protect using:** Stored procedures or Static SQL Packages to set the protection method for the newly installed version of the product.
   - **Collection ID for packages** to set the collection ID for the packages to update.
   - **Owner ID for packages** to set the owner ID for the packages to update if it is necessary to change a default.
   - **Grant permission on packages to** to specify particular users and groups for which you are granting permissions. Users and groups must be separated by commas.
   - **Database username** to set the username that is used to access the databases.
   - **Database password** to set the password that is used to access the databases.

6. Click Finish to generate the files to update repository storages and QMF catalogs.

   The following files are generated and stored in a directory of your choosing:
   - Database update SQL (.ddl files)
   - Package installation properties (.bndtask) files
   - Package installation scripts (bind.bat and bind.sh)
   - Repository connections configuration file (repositories.xml)
     This file updates configuration of existing and updated installations of the product.

   **Note:** The .ddl scripts must be run first to avoid errors. The names of the .ddl and .bndtask files are generated in the following format:
   - <host>_<port>_<database>_repository.ddl
   - <host>_<port>_<database>_repository.bndtask
Chapter 19. Assigning users and groups permission to use repository objects

You can assign security permission levels for users and groups and control their access to repositories and any object in the repository.

About this task

Security permission levels for users and groups can only be assigned for secured repositories (those created with Internal or LDAP security). You can apply permission levels to any object that is listed in the repository including for example, directories, folders, workspaces and individual query and reporting objects.

Only users who have been identified as QMF administrators can assign security permission levels to users and groups. In addition, users that have been granted full permission privileges can modify permissions that have been applied to objects.

To assign users and groups different levels of permission to use repository objects:

Procedure

1. Right-click any repository object that is listed in the Repositories, Repository Explorer or Workspaces views. Select Properties from the pop-up menu. The Properties window opens. Select Security from the sidebar. The Security page of the window opens.

2. Each user or group that has been granted permission to use this repository is listed in the Group or user names list. To add additional users and groups, click the Add button. The Select Users or Groups window opens.

3. Each user and group can be assigned different levels of permissions for the selected repository object. The levels of permission that are available are listed in the Permissions for list. To assign a level of permission, select a group or user and check the corresponding check box for the level of permissions that you want to assign. Your choices are:
   - **Full**: grants the user or group permission to perform all functions (edit, view, browse and delete) on the repository object. In addition, full permission allows users to modify permissions that have been assigned to the repository object.
   - **Edit**: grants the user or group permission to make changes to, as well as view and browse, the repository object.
   - **Browse**: grants the user or group permission to see the contents of the repository object. For example, browse privileges on a directory in the repository allows a user to see what is inside that directory. Browse privileges on a query object allows a user to open and run the query object.
   - **View**: grants the user or group permission to see the repository object listed in the repository. For example, view privileges on a directory in the repository allows the user only to see the directory. The user cannot open the directory or see the contents of the directory. View privileges on a query object allow a user only to see the object. They cannot open or run the object.
• **None**: denies the user or group permission to see that the repository object is included in the repository.

4. Click **Apply permissions to child folders and objects** to apply the selected level of permission to all of the folders and objects that are under the object to which the permission is being applied.

5. To remove permission from a user or group, select the user or group from the **Group or user names** list. Click **Remove**. The user or group will be removed from the list.

6. Click **Apply**.

7. Click **OK**.

---

**Selecting the users and groups that are allowed repository object access**

You must select the users and groups that will be allowed to access a repository object.

**About this task**

To select the users and groups that will be allowed access to a repository object:

**Procedure**

1. Right-click any repository object that is listed in the **Repositories**, **Repository Explorer** or **Workspace** views. Select **Properties** from the pop-up menu. The Properties window opens. Select **Security** from the tree. The Security page of the window opens. Click **Add**. The Select Users or Groups window opens.

2. The users and groups that are available for assignment are listed in the **Group or user names** list box. These are the users and groups that you either specified using the **Users and Groups** view if you selected **Internal** repository security, or obtained from your LDAP server if you selected **LDAP** repository security.

3. To filter the users and groups that are listed you can:
   - Use the **Name filter** field.
   - Clear the **Show users** check box. Only Groups will be listed.
   - Clear the **Show groups** check box. Only Users will be listed.

4. To select a user or group and grant them permission to use this repository object, select the user or group from the **Group or user names** list box and click the move right (>>) icon. The user or group is now listed in the **Selected objects** list box.

5. To remove a user or group from the **Selected objects** list box, click the move left (<<) icon.

6. Click **OK**. The Select Users or Groups window closes. The users or groups that you have moved to the **Selected objects** list box are added as users and groups that can access the repository object. They are listed in the **Group or user names** list box of the Properties dialog.
Chapter 20. Assigning users and groups administrative permission for database-based security

Database-based security takes the security settings of the host database and uses these settings to protect the shared repository.

Before you begin

Make sure you are operating on the RSBI objects.

About this task

To determine if a user has administrator authorization, QMF calls for the contents of RSBI.ADMIN_VIEW and runs the following SQL statement:

```
SELECT COUNT(*) FROM RSBI.ADMIN_VIEW WHERE AUTHID=:OWNER
```

Where OWNER is the user login. If this statement returns the value that is greater than zero, the user is the repository administrator.

The database-based security for shared repositories requires SYSADM authority on DB2 and DBA authority on Oracle. Without this authority users cannot administer the repository.

For DB2 databases you can populate the RSBI.AUTHID_TABLE with PRIMARY_IDs and SECONDARY_IDs pairs of users and groups, where the group does have SYSADM authority.

Results

The ADMIN_VIEW will have the list from SYSIBM.SYSUSERAUTH with the addition of the PRIMARY_IDs from the AUTHID_TABLE, whose SECONDARY_IDs are also in the list from SYSIBM.SYSUSERAUTH.

Example

The following examples illustrate the QMF authorization processes on different server types:

**DB2 for z/OS**

```
CREATE VIEW "RSBI"."ADMIN_VIEW" ( "AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYSIBM"."SYSUSERAUTH" A
WHERE A."SYSADMAUTH" IN ('G', 'Y')
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SYSIBM"."SYSUSERAUTH" B ON
B."GRANTEE" = A."SECONDARY_ID"
```
DB2 for iSeries
CREATE VIEW "RSBI"."ADMIN_VIEW" ("AUTHID")
AS
SELECT "AUTHID"
FROM "RSBI"."ADMIN_TABLE"

DB2 LUW
CREATE VIEW "RSBI"."ADMIN_VIEW" ("AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYSIBM"."SYSDBAUTH" A
WHERE A."DBADMAUTH" = 'Y'
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SYSIBM"."SYSDBAUTH" B ON
B."GRANTEE" = A."SECONDARY_ID"

DB2 for z/VM®
CREATE VIEW "RSBI"."ADMIN_VIEW" ("AUTHID")
AS
SELECT A."NAME" AS "AUTHID"
FROM "SQLDBA"."SYSUSERLIST" A
WHERE A."AUTHOR" = ''
AND A."DBAAUTH" = 'Y'
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SQLDBA"."SYSUSERLIST" B ON
B."NAME" = A."SECONDARY_ID"

Oracle
CREATE VIEW "RSBI"."ADMIN_VIEW" ("AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYS"."DBA_ROLE_PRIVS" A
WHERE A."GRANTED_ROLE" = 'DBA'
Chapter 21. Running the QMF Data Server

QMF Data Server can be used to access QMF entities with third-party applications.

About this task

To run the QMF Data Server, complete the following steps:

Procedure

1. Create a directory in the file system of a machine that you want to use as server.
2. Copy the repositories.xml file and the .bi.jdbc.drivers file to the directory that you created in step 1. If you are using the Microsoft Windows operating system, you can find these files here:
   - C:\Users\[user_name]\AppData\Roaming\IBM\QMF for Workstation - for the Workstation version
   - QMF for WebSphere subfolder of the Application Data folder - for the WebSphere version
3. Copy the license file to the folder that you created in step 1. The product license files are located in the QMF for WebSphere subfolder of the Application Data folder for QMF for WebSphere or in the QMF for Workstation installation directory.
4. In the command line, type the following command: java -cp "[path to QMF installation directory]\API\QMFLib.jar" com.ibm.rsbi.drda.NetworkService start -h [host] -p [portnumber] -ssl [sslmode] -confpath "[data_server_folder]" -sessionTimeout [time inactive] -noSecurityManager, where [path to QMF installation directory] is the path to the QMF installation directory, [host] is the name of the server that you want to use to run the Data Service, [portnumber] is the port on that server, [sslmode] is the SSL encryption mode that you want to use to protect your connection to QMF, [data_server_folder] is the path to the folder that you created in step 1, and [time inactive] is the session timeout time in milliseconds.
5. Press Enter to run the QMF Data Server.

QMF Data Server is running. You can use the QMF Data Server Objects node of the repository tree of objects to view the QMF entities that are available on the QMF Data Server.

6. Optional: To end the current session on the QMF Data Server, type the following command: java -cp "[path to QMF installation directory]\API\QMFLib.jar" com.ibm.rsbi.drda.NetworkService shutdown -h [host] -p [portnumber], where [host] is the name of the server that runs the Data Service and [portnumber] is the port that is used for the current session.

Publishing objects to QMF Data Server Objects node

Objects that are available on the QMF Data Server can be viewed inside QMF from the QMF Data Server Objects node of the repository tree of objects. You can add (publish) objects to the QMF Data Server Objects node by using the Publish to QMF Data Server wizard.
About this task

To publish one or several objects to the QMF Data Server Objects node of the repository tree of objects, complete the following steps:

Procedure

1. In the Repository Explorer view, select the objects that you want to publish, right-click the selection, and select Publish to QMF Data Server from the menu.

   **Restriction:** Currently, the following objects can be published:
   - Analytical queries
   - Compound dynamarts
   - Dynamarts
   - Forecasts
   - Tables
   - Virtual tables
   - Visual queries

   Note that objects with prompts cannot be published to QMF Data Server Objects node.

   The Publish to QMF Data Server wizard opens.

2. In the wizard, make sure that the objects that you want to publish are selected from the Current table list.

3. In the New name field, specify the name that the object acquires when it is published.

4. In the Field definitions area, you can edit the result set structure for the object that you want to publish:
   - To add a column or a calculated column to the result set, click **Add Column** and select a column from the list or type an expression.
   - To remove a column from the result set, click **Remove Column**.
   - To reorder the result set rows, select the row that you want to reposition and click **Move Up** or **Move Down**.

5. Click Next.

6. On the Specify user names and passwords for data sources page of the wizard, specify data sources that the objects use:
   - To add a data source to the list, click **Add Data Source**.
   - To remove a data source from the list, click **Remove Data Source**.
   - In the **Login** and **Password** fields, specify user credentials for the data sources that you add.

7. Click Finish.

---

**SSL modes available for QMF Data Server**

The following SSL modes are available for the QMF Data Server.

<table>
<thead>
<tr>
<th>SSL mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>off</td>
<td>No SSL encryption is enabled. This is the default option.</td>
</tr>
<tr>
<td>basic</td>
<td>SSL encryption is enabled with no peer authentication.</td>
</tr>
<tr>
<td>SSL mode</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>peerAuthentication</td>
<td>SSL encryption and peer authentication are enabled.</td>
</tr>
</tbody>
</table>

The term *peer* is used for the other part of the server-client communication. The server's peer is the client, and the client's peer is the server.

Peer authentication may be set on the server side, on the client side, or on both. With peer authentication enabled, one of the sides of the SSL connection (server or client machine) is authenticated based on a trusted certificate installed locally on the other side.
Chapter 22. Using the Quick Start wizard to configure JDBC drivers and connect to repositories

You can run the QMF Quick Start wizard to configure repositories and connect to the database.

About this task

The QMF Quick Start wizard configures QMF to connect to data by defining the JDBC libraries, connecting to a repository and adding data sources.

Running the Quick Start wizard is appropriate if you want to minimize the amount of time required to achieve a functional QMF environment for personal use.

The Quick Start wizard is ideal for users that have little experience working with JDBC drivers and Data Sources to create working production configuration.

Procedure

1. From the menu bar, select Help > Quick Start.
   The Welcome to the Quick Start Wizard page opens. Click Next.
2. On the Define JDBC libraries page,
   - If you do not want to add JDBC drivers to the list that is provided, click Next.
   - If you want to add JAR files for a particular driver, click Select directory with driver's JAR files icon, select a directory with associated files, and click OK.

   The JDBC library provides information about a particular JDBC driver. It defines the path to the driver, its JDBC URLs, and list of supported properties. For more information, see "Setting JDBC preferences" on page 38.
3. On the Repository Connections page,
   - Right-click the repository that you want to connect to, establish the connection, and click Next.
   - Click the Create new connection to Repository icon to add a new repository connection as described in Chapter 16, "Creating the repository connection for QMF," on page 129. Click Next.
4. On the Data Sources page,
   - If you do not want to add any data source to the list that is provided, click Finish.
   - To add a data source, use one of the icons above the provided list depending on the type of the data source that you want to add. Complete the procedure as described in Chapter 12, "Data sources," on page 81. Click Finish.

Results

You have configured JDBC libraries and connected to a repository with data sources.
What to do next

As an administrator, you can generate and export the settings.xml file to users so that users can begin using the product. For more information, see “Exporting and importing the JDBC driver and connection information” on page 150.
Chapter 23. Managing resource limits

Resource limits help you manage resource consumption on a database data source. By specifying resource limits you can control the actions a user can perform and implement limits on the resources a user can consume when they access the data source using QMF.

Resource limits can be applied globally to data sources or they can be applied to individual queries that access any data source. Data source and query resource limits allow you to control resource consumption on a per user, group, day of the week, or time of day basis.

Caching

In QMF, caching is a feature that allows you to accelerate the application performance, but affects the relevance of the data.

You can configure the caching functionality for the following entities:

- Repositories
- Queries
- Data sources
- Virtual data sources
- Visual dashboards and visual reports

**Repository cache**

When caching is configured for a repository, the application saves the contents of that repository, including all the objects and metadata, in the local memory of your computer or on the web server. Repository cache is cleared when the time limit is exceeded.

Repository cache is also cleared when you exit the application. Caches of other QMF entities are not cleared when you exit the application.

**Query cache**

When caching is configured for a query, the results of that query are saved in cache after its first run. Later, if the query is run again unchanged, the results are retrieved from cache. Query cache is cleared when the time limit is exceeded.

**Data source cache**

When caching is configured for a data source, data from the tables in that data source is saved in cache, so that users can work with it without directly accessing the database. Data source cache is available for relational data sources only. It is cleared when the time limit is exceeded.

**Virtual data source cache**

When caching is configured for a virtual data source, records from the tables in that data source are saved in cache, so that users can work with the contents of the tables without directly accessing the database. Virtual data source cache is cleared when the time limit is exceeded and can be updated regularly. You can configure the application to update the cache of virtual data sources automatically in two distinct ways.
- Expired virtual data source cache can be updated when the user tries to run a query against the outdated data. This is the default option for QMF for Workstation, although it can be re-configured.
- Expired cache of virtual data sources can be updated regularly, according to the schedule. This is the default option for QMF for WebSphere, although it can be re-configured.

**Visual dashboard cache and visual report cache**
When caching is configured for a visual dashboard or a visual report, cache stores the results of the queries that provide data for that visual dashboard or visual report. This allows the dashboard or report to function faster, but affects the relevance of the data. Visual dashboards and visual reports cache is cleared when the time limit is exceeded.

QMF allows users to automate the update and expiration of virtual data source cache and visual dashboard cache by using schedules.

### Assigning administrative privileges

QMF administrative privileges should be given only to those users who will be responsible for creating and managing repositories.

If your repository will be stored in a database and you want to protect your resources, only users familiar with administering databases should be given QMF administrative privileges. In many environments having a single user responsible for managing repositories centralizes and streamlines control over database resources.

Those users without QMF administrative privileges do not have the QMF for Workstation Administrator component installed and must be given the information necessary to connect to a repository that is created by the QMF administrator. Users without the Administrator component can create personal repositories.

### About collection IDs

Collection IDs identify a group of static SQL packages or stored procedures that serve a particular purpose or function.

QMF includes a set of embedded SQL statements for working with databases. These statements are installed as queries on the database server during the QMF configuration, through a process commonly referred to as *binding*.

The database type determines whether the queries are bound as packages of static SQL statements (for DB2 UDB and DB2 for z/OS databases) or as a set of stored procedures (for all supported databases, but this option is not recommended for DB2 UDB and DB2 for z/OS). This group of installed packages or stored procedures is called a *collection*.

Each version of QMF has its own collection. When QMF connects to database server, it automatically detects proper installed collection and uses it. However, it is useful practice to incorporate the application version in the collection ID name to help users differentiate collections from one version of QMF to another.

Depending on the database type, the length of the collection ID can have some restrictions.
In the case of stored procedures, the notion of a collection is usually synonymous with owner ID or schema. The maximum length for collection ID field is determined by database restriction on the maximum schema length. For more details on schema length limits see the database documentation.

The collections of packages are supported by DB2 databases only. DB2 databases can function in either short names or long names mode, depending on their configuration. In short names mode the maximum number of characters allowed in collection ID field is 8.

The following DB2 databases can be set up to support long names:
- iSeries V5R1 or later
- DB2 for z/OS V8 or later
- DB2 UDB V8 or later

For these DB2 databases the maximum length of the collection ID is 128 characters.

**Servers that support long names**

Long names apply to the names of objects that reside in the QMF catalog.

The following servers support long names:
- iSeries V5R1 or later
- zOS V8 or later

**Long names for objects**

Long names apply to the names of objects that reside in the QMF catalog.

Long names for QMF objects that can be saved in the QMF catalog tables that support long names can be up to 128 characters for the owner and name fields.

**Short names for objects**

Long names apply to the names of objects that reside in the QMF catalog.

Short names for QMF objects that can be saved in the QMF catalog tables can be up to eight (8) characters for the owner and up to eighteen (18) characters for the name.

---

**Setting up data source resource limits**

You can set up one or more unique sets of resource limits that can be applied to individual users or to groups of users when they access a data source.

**About this task**

For every data source that you add to a repository, the Add New Data Source wizard creates a default set of resource limits. Based on your resource limits provider selection, the default resource limits for the data source are stored in the repository or the QMF catalog. The resource consumption at the data source for every user of QMF for Workstation and QMF for WebSphere is automatically controlled by that default set of resource limits. The default resource limits are non-restrictive and are always active.
To modify the default resource limits or set up new, unique resource limits for a data source:

**Procedure**

1. From the **Repository Explorer** view, right-click a relational data source. Select **Properties** from the pop-up menu. The Properties for [data source] window opens. Click the **Resource Limits** folder. The Resource Limits window opens.

2. All resource limits groups that exist for a data source are listed in the **Resource limits groups** list box. Every data source has a resource limits group called **Default**. The **Default** resource limits group includes all users and has no resource limitations. Use the **Show resource limits groups whose names match** field and the **Refresh List** button to search for specific resource limits groups that exist on the data source. Use a percent (%) sign in the **Show resource limits groups whose names match** field to list all resource limits groups that exist on the data source.

3. Create a new resource limits group for the data source by clicking the **Add** icon. The New Resource Limits Group window opens. Specify field values and click **OK**.

4. Create a schedule and specify resource limit values for the resource limits group by selecting the resource limits group from **Resource limits groups** list box and clicking the **Edit** icon. The Edit Resource Limits Group window opens. Specify field values and click **OK**.

5. Assign users to a resource limits group by selecting the resource limits group from the **Resource limits groups** list box and clicking **Assign**. If you are using a repository as your resource limits provider, the Assignment for [resource limits group name] window opens. If you are using a QMF catalog as your resource limits provider, the Assign User Profiles to [resource limits group name] window opens. Specify field values and click **OK**.

6. To delete a resource limits group, select the group from **Resource limits groups** list box and click the **Delete** icon. The resource limits group is removed from **Resource limits groups** list box.

7. Click **OK** to close the Resource Limits page of the Properties window.

**Note:** If a resource limit has been set at the query level and the data source level, QMF will apply the most restrictive limit of the two. For example, if the **Maximum Rows to Fetch** limit is set to 150,000 rows at the query level, but set to 100,000 rows at the data source level, then QMF will apply the data source limit of 100,000 rows when the query is run, since the lower number constitutes a more restrictive limit. This selection process is repeated for every resource limit that is set at both the query and data source levels.

---

**Setting up query resource limits**

You can set up one or more unique sets of resource limits that can be applied to an individual query.

**About this task**

Each time a user runs the query at any data source, the resource limits assigned to the user will control their resource consumption at that data source. Each set of resource limits can place specific restrictions that can be implemented based on the time of day or day of week that the query is run. You can apply resource limits to any query that has been saved in a repository. The resource limits that you can apply to a query are the **Timeouts**, **LOBs**, and **Cache** resource limits.
To set up resource limits for a query:

**Procedure**

1. From the Repository Explorer or Repositories view, right-click a query that has been saved in the repository. Select Properties from the pop-up menu. The Properties for [query name] window opens. Click the Resource Limits folder. The Resource Limits window opens.

2. All resource limits groups that exist for a query are listed in the Resource limits groups list box. Every data source has a resource limits group called Default. The Default resource limits group includes all users and has no resource limitations. Use the Show resource limits groups whose names match field and the Refresh List button to search for specific resource limits groups that exist on the data source. Use a percent (%) sign in the Show resource limits groups whose names match field to list all resource limits groups that exist on the data source.

3. Create a new resource limits group for the data source by clicking the Add icon. The New Resource Limits Group window opens. Specify field values and click OK.

4. Create a schedule and specify resource limit values for the resource limits group by selecting the resource limits group from Resource limits groups list box and clicking the Edit icon. The Edit Resource Limits Group Schedule window opens. Specify field values and click OK.

5. Assign users to a resource limits group by selecting the resource limits group from the Resource limits groups list box and clicking Assign. If you are using a repository as your resource limits provider, the Assignment for [resource limits group name] window opens. If you are using a QMF catalog as your resource limits provider, the Assign User Profiles to [resource limits group name] window opens. Specify field values and click OK.

6. To delete a resource limits group, select the group from Resource limits groups list box and click the Delete icon. The resource limits group is removed from Resource limits groups list box.

7. Click OK to close the Resource Limits page of the Properties window.

**Note:** If a resource limit has been set at the query level and the data source level, QMF will apply the most restrictive limit of the two. For example, if the Maximum Rows to Fetch limit is set to 150,000 rows at the query level, but set to 100,000 rows at the data source level, then QMF will apply the data source limit of 100,000 rows when the query is run, since the lower number constitutes a more restrictive limit. This selection process is repeated for every resource limit that is set at both the query and data source levels.

**Definition of a resource limits group**

A resource limits group is a set of resource limits that are implemented collectively, for each user that is assigned to the group, according to a specified schedule. You can create as many resource limits groups as you want, with each group having a different set of resource limits implemented according to different schedules.

There are many permutations available to you for setting up resource limits groups. The most common ways to set up resource limits groups and control resource usage are by:

- data source
- user
day of the week
• time of day

For example, a resource limits group can contain one set of limits that is in effect weekdays between 8 AM and 6 PM and another that is in effect on weekends and off-hours. In addition, each resource limits group can have different users assigned allowing them to perform only certain functions on specific database data sources or when running specific queries.

Default resource limits group

Initially, all users are assigned to the default resource limits group. Users who are not assigned to any other resource limits group are governed by the limits defined in the default resource limits group.

The default resource limits group is assigned a set of default resource limits and a default schedule. The default resource limits are not restrictive and the default schedule implements the resource limits 24 hours a day, every day of the week. You can edit the default resource limits group and change the resource limits and the schedule.

Note: Resource limits are always active. Governing based on default resource limits is performed even if you do not set up resource limits groups. You should review the limits specified for the default resource limits group to ensure that unassigned users that are governed by the default group are not granted limits that are more extensive or restrictive than you intend.

Ensuring resource limits groups security

In order to protect the limits that have been specified for each user, QMF catalog-based resource limits groups are securely stored in the table RDBI.RESOURCE_TABLE that is part of the QMF catalog and resides on a database server.

You must have the authority to execute the QMF application package on the database server in order to make any changes to a resource limits group. This prevents unauthorized users from changing the resource limits.

A view named RDBI.RESOURCE_VIEW is defined for the resource limits table. QMF applications access the resource limits information using the view so the table remains intact.

Note: The Default resource limits group resource limit information is stored in the repository and not in the RDBI.RESOURCE_TABLE on the database server. That means any user who can access the repository can make changes to the resource limits of the default resource limits group.

Creating resource limits groups

A resource limits group is a set of resource limits that are implemented collectively, for each user that is assigned to the group.

About this task

You can create one or more resource limits groups for each data source that you add to the repository.

To create a resource limits groups:
Procedure


2. Type a name for the group in the Group name field. There are no restrictions on the name.

3. Optional: In the Comments field you can specify up to 80 characters of comments describing the resource limits group.

4. You can select the Create this group using schedules from the Default group check box to create the resource limits group with the same schedules as the default group. If this check box is cleared, the new resource limits group has no schedules. You create or modify a resource limits group's schedule using the Edit Resource Limits Group Schedule window.

5. Click OK. The New Resource Limits Group window closes. The new resource limits group is created. Control returns to the Resource Limits window. The next step to setting up resource limits is to create or edit the resource limits group schedules.

Setting up resource limits group schedules

The resource limits group schedule determines when the resource limits specified for the group are in effect. You can create as many schedules for a resource limits group as you need. Each schedule can be set up to implement a unique set of resource limits.

Specifying multiple schedules for one resource limits group

Specify resource limits during different time periods using multiple schedules for one resource limits groups.

When a user accesses a data source the resource limits groups to which the user has been assigned are identified. The schedules of the identified groups are verified to determine which resource limits are currently in effect. Because users can be assigned to multiple resource limits groups, each with multiple schedules, there can easily be overlapping spans of time when technically multiple sets of resource limits could be in effect.

In the cases of overlapping schedules, a unique schedule number is used to determine which schedule is in effect. The schedule with the lowest number takes precedence.

For example, suppose that a resource limits group has the following four schedules:

<table>
<thead>
<tr>
<th>Schedule #</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>From Day</td>
<td>Wednesday</td>
<td>Monday</td>
<td>Monday</td>
<td>Sunday</td>
</tr>
<tr>
<td>To Day</td>
<td>Wednesday</td>
<td>Friday</td>
<td>Friday</td>
<td>Saturday</td>
</tr>
<tr>
<td>From Time</td>
<td>10:30</td>
<td>9:00</td>
<td>17:00</td>
<td>00:00</td>
</tr>
<tr>
<td>To Time</td>
<td>11:30</td>
<td>17:00</td>
<td>9:00</td>
<td>24:00</td>
</tr>
</tbody>
</table>

Table 13. Resource limits group schedules
You will notice that schedule #1 is embedded in schedule #2 and schedules #1, #2, and #3 are embedded in schedule #4. If a user accessed this data source on Wednesday at 11:00, schedules #1, #2, and #4 could be in effect. The schedule with the lowest number is used.

When you create your resource limits group schedules, it is recommended that you stagger your numbering so additional schedules can be inserted where appropriate or deleted without impact. Keep in mind that schedules do not have to be numbered sequentially but once a schedule is assigned a number it cannot be changed.

All time and day ranges of the schedules are inclusive. That means if the From time is 08:00, the schedule is in effect exactly at 08:00. If the To time is 17:00 the schedule is in effect until 16:59:59. The from and to times can wrap around midnight, and the from and to days can wrap around weekends.

When users are accessing data sources in different time zones, the clock used to determine time resides on the data source being accessed. For example, a user in New York is accessing a data source in California and it is 9:00 AM Monday in New York. Based on the example schedules, schedule 3 is in effect because according to the data source it is 6:00 California time.

**Determining the resource limits schedule in effect**

Each resource limits group schedule has a unique number that specifies the priority of the schedule.

The resource limits group schedule specifies the limits that have been set up for a group of users. For each resource limits group, there can be more than one schedule. Usually each schedule has different limits specified and is effective at different times. However, some schedules can have different limits but overlapping times where they are effective. In the cases of overlapping times, QMF uses the unique schedule number to determine which schedule is in effect. The schedule with the lowest number takes precedence.

For example; if a resource group has following four schedules:

<table>
<thead>
<tr>
<th>Schedule #</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>From Day</td>
<td>Sunday</td>
<td>Monday</td>
<td>Wednesday</td>
<td>Monday</td>
</tr>
<tr>
<td>To Day</td>
<td>Saturday</td>
<td>Friday</td>
<td>Wednesday</td>
<td>Friday</td>
</tr>
<tr>
<td>From Time</td>
<td>00:00</td>
<td>09:00</td>
<td>10:30</td>
<td>17:00</td>
</tr>
<tr>
<td>To Time</td>
<td>24:00</td>
<td>17:00</td>
<td>11:30</td>
<td>09:00</td>
</tr>
</tbody>
</table>

Schedule 1, because it has the lowest number, is always in effect. The numbering of these schedules as presented above does not make sense. As defined, schedule 3 will never be in effect because the time frame it spans always falls within schedule 1, and schedule 1 will always take precedence. This is a major consideration when assigning numbers to the schedules.

When you create a schedule, you as the administrator can choose to assign any number from 1 to 99 to that schedule. It is recommended that for the schedule with the most selective time constraints, you assign the lowest number, and for the schedule with the broadest time expanse, you assign the higher number.
Following this logic, the more appropriate way of numbering the above schedules would be:

<table>
<thead>
<tr>
<th>Schedule #</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>From Day</td>
<td>Wednesday</td>
<td>Monday</td>
<td>Monday</td>
<td>Sunday</td>
</tr>
<tr>
<td>To Day</td>
<td>Wednesday</td>
<td>Friday</td>
<td>Friday</td>
<td>Saturday</td>
</tr>
<tr>
<td>From Time</td>
<td>10:30</td>
<td>09:00</td>
<td>17:00</td>
<td>00:00</td>
</tr>
<tr>
<td>To Time</td>
<td>11:30</td>
<td>17:00</td>
<td>09:00</td>
<td>24:00</td>
</tr>
</tbody>
</table>

Now, on Wednesday at 10:30 AM, schedule 1 is in effect. On Monday at 10:30 AM, schedule 2 is in effect, all other times on Monday through Friday from 9:00 AM to 5:00 PM schedule 2 is in effect, and from 5:00 PM to 9:00 AM schedule 3 is in effect. On Friday evening schedule 3 is in effect until midnight. At midnight Saturday morning, schedule 4 takes over. On Sunday at 10:30 AM schedule 4 is in effect.

Additional considerations when creating schedules:

- Schedules do not have to be numbered sequentially. Once a schedule is assigned a number it cannot be changed, so it is recommended that you stagger your numbering so additional schedules can be inserted where appropriate or deleted without impact.
- All time and day ranges of the schedules are inclusive. That means if the From time is 08:00, the schedule is in effect exactly at 08:00:00. If the To time is 17:00, the schedule is in effect until 16:59:59.
- The from and to times can wrap around midnight, and the from and to days can wrap around weeks.
- When users are accessing servers in different time zones, the clock used to determine time resides on the server being accessed. For example, a user in New York is accessing a server in California and it is 9:00 am Monday in New York. Based on the example schedules, schedule 3 is in effect because according to the server it is 6:00 California time.

**Creating a resource limits group schedule**

A resource limits group can have one or more schedules, each with a different set of resource limits. The schedule defines when the associated set of resource limits is in effect.

**About this task**

The set of resource limits specify what actions and resource usage is allowed while the schedule is in effect.

To create or edit a resource limits group schedule:

**Procedure**

2. The Resource limits group that you selected is identified in the Group name field.
3. Comments that were specified when the group was created are displayed in the Comments field. You can make changes to the comment text by typing new text directly in the field.

4. All of the schedules that have been defined for this resource limits group are listed in the Schedule List list box.

5. The Status radio buttons indicate whether all of the schedules that are listed in the Schedule List are collectively active or inactive. To activate all the schedules listed in the Schedule List, select Active. All of the schedules are active. To deactivate all the schedules listed in the Schedule List, click the Inactive. None of the schedules are in effect except the default schedule. The schedules are saved and can be activated at any time.

6. To create a new resource limits group schedule, click Add. The Main page of the Edit Resource Limits Group Schedule window opens. Use the pages of the Edit Resource Limits Group Schedule window to specify the individual resource limits for the schedule.

7. To edit a resource limits group schedule, select the schedule from the Schedule List and click Edit. The Timeouts page of the Edit Resource Limits Group Schedule window opens. Use the pages of the Edit Resource Limits Group Schedule window to specify the individual resource limits for the schedule.

8. To delete a resource limits group schedule, select the schedule from the Schedule List and click Delete. The selected resource limits group schedule is deleted.

9. Click OK. The Edit Resource Limits Group window closes. The new resource limits group schedule is created and any changes that you have made to the resource limits parameters are saved. Control returns to the Resource Limits window. The next step to setting up resource limits is to assign users to the resource limits groups.

Specifying values for the resource limits

From the Edit Resource Limits Group Schedule window you enter the resource limits that you want to be in effect for the schedule.

About this task

To specify the individual resource limits:

Procedure


2. Using the following pages of the Edit Resource Limits Group Schedule window specify the parameters that will set up the resource limits for the selected resource limits group schedule:

   • Select the Main page to assign the schedule a priority and specify the time of day and day of the week the schedule is in effect. You must specify these parameters when you are creating a new schedule.

   • Select the Timeouts page to specify warning and cancellation limits for idle queries, idle connections, and server response time.
Select the **Limits** page to specify warning and cancellation limits for the maximum number of rows and bytes of data that can be retrieved. In addition, select this page to specify the maximum number of simultaneous connections that can be established to the database server.

Select the **SQL Verbs** page to limit the SQL verbs that users assigned to this resource limits group are allowed to use when this schedule is in effect.

Select the **Options** page to specify access options including: database data source access using either the QMF for Workstation or QMF for WebSphere user interface and programming interface; database update confirmation; isolation levels for user queries; mandatory account information; and the ability to fetch all rows automatically, export data, edit tables, and only run saved queries.

Select the **Save Data** page to allow users assigned to this resource limits group and using this schedule to save data at the database server.

Select the **Binding** page to allow users assigned to this resource limits group and using this schedule to bind or drop static packages for their queries.

Select the **Object Tracking** page to turn on QMF for Workstation or QMF for WebSphere object tracking. You must turn on object tracking in order to have meaningful object tracking reports.

Select the **LOB Options** page to allow users, assigned to this resource limits group and using this schedule, to access tables containing large object data (LOB).

Select the **Cache** page to control caching options for each user.

Select the **Object List** page to define the default owner name that will be used to filter data source objects and specify a specific list of owner names that can be used to filter data source objects aside from the default name.

Select the **Acceleration** page to specify the acceleration options.

**Note:** Acceleration is available only for DB2 z/OS databases that support IDAA.

3. Click **OK**. The Edit Resource Limits Group Schedule window closes. All the changes that you have made to the resource limits parameters are saved. The Edit Resource Limits Group window stays open. From the Resource Limits Group window, the next step to setting up resource limits is to assign users to the resource limits groups.

### Specifying Main resource limits

On the Main page of the Edit Resource Limits Group Schedule window you specify the priority schedule number, and the day and time when the schedule will be in effect.

The **Main** resource limits are as follows:

**Number**

Populate this text field with a number from 1 to 99. This number is used to identify the schedule and represent the schedule’s priority. A number is assigned to the schedule only when it is created. The schedule number must be unique. Once assigned, you cannot change the schedule number and its assigned priority.

The schedule’s priority number is used to decide which schedule is in effect when schedules overlap. If two schedules for the resource limits group cover the same time period, the schedule with the lower number takes precedence.
Day Range
Select from the drop down lists a day of the week that will be the starting
day and a day of the week that will be the ending day for the schedule.
The schedule is in effect from the starting day to the ending day, inclusive.
You can specify a day range that wraps around the end of the week. For
example, selecting Friday through Monday activates the schedule Friday,
Saturday, Sunday, and Monday. In reverse, selecting Monday through
Friday activates the schedule Monday, Tuesday, Wednesday, Thursday, and
Friday.

Time Range
Select from the drop down lists a time to start and a time to end the
schedule. The schedule is in effect from the start time to the end time,
inclusive. Time is specified using a 24 hour clock. You can specify a time
range that wraps around midnight. For example, selecting 23:00 through
7:00 will activate the schedule from 11:00 at night until 7:00 in the morning.
In reverse, selecting 7:00 through 23:00 will activate the schedule from 7:00
in the morning till 11:00 at night.

Status
Use these radio buttons to set the status of the individual schedule. The
status of the whole Resource Limits group, set using Status on the Edit
Resource Limits Group window, takes precedence over the individual
schedule status. There are two choices of status:
• Active to activate this schedule.
• Inactive to deactivate this schedule. An inactive schedule remains as it
  was defined until you activate it or delete the schedule from the
  resource limits group. You can activate the schedule at any time.

Specifying Timeouts resource limits
On the Timeouts page of the Edit Resource Limits Group Schedule window you
set the timeout warning and cancellation limits for idle queries, idle connections,
and data source response time.

Idle Query Timeouts and Server Response Timeouts resource limits can be set for
both data sources and for individual queries. The Idle Connection Timeouts
resource limit can only be set for data sources and not for individual queries. The
Timeouts resource limits are as follows:

Idle Query Timeouts
These fields specify the amount of time that a query can remain idle. The
Warning limit field displays the number of seconds that a query can
remain idle before the user is informed and asked if the query should be
canceled. The Cancel limit field displays the number of seconds that a
query can remain idle before the query is automatically canceled.

Server Response Timeouts
These fields specify the amount of time that can be spent waiting for a
response from the database. The Warning limit field specifies the number
of seconds that can elapse before the user is informed and asked if the
database request should be canceled. The Cancel limit field specifies the
number of seconds that can elapse before the database request is
automatically canceled.

Note: A lower timeout limit prevents long running, runaway queries. A
higher timeout limit allows database requests to complete when the
database server is slow due to resource contention or other reasons.
Idle Connection Timeouts
This field specifies the amount of time that an idle connection to a database data source is retained. The Cancel limit field specifies the number of seconds that an idle connection is retained before it is automatically closed.

Note: A lower timeout limit minimizes the resources consumed at the database by idle connections. A higher timeout limit minimizes the overhead of establishing connections.

Specifying Limits resource limits
On the Limits page of the Edit Resource Limits Group Schedule window you set the warning and cancellation limits for the maximum number of rows and bytes of data that can be retrieved from the database data source. In addition, you can specify the maximum number of simultaneous connections that can be established to the data source.

Limits resource limits can be set for data sources. The Limits resource limits are as follows:

Maximum Rows to Fetch
These fields specify the limits for the number of rows of data that can be retrieved from a database data source when running a query. The Warning limit field specifies the number of rows that can be retrieved from the data source before you are notified that a row limit has been reached. The user is prompted to select whether more data should be fetched or should the query be canceled. The Cancel limit field displays the number of rows that can be retrieved from the data source before the row limit is reached. The query is then automatically cancelled.

Maximum Bytes to Fetch
These fields specify the limits for the number of bytes of data that can be retrieved from a database data source when running a query. The Warning limit specifies the number of bytes that can be retrieved from the data source before the user is notified that the byte limit has been reached. The user is then prompted to specify whether more data should be fetched or should the query be canceled. The Cancel limit displays the number of bytes that can be retrieved from the data source before the byte limit is reached. The query is then automatically cancelled.

Maximum Connections
This field specifies the limit for the number of simultaneous connections that can be established to a database data source. The Cancel limit specifies the number of simultaneous connections that can be established to a data source before the query requesting the next connection is automatically canceled. Setting the limit to zero (0) indicates that there is no limit to the number of connections.

Generally, connections to database data sources are reused. If you run one query at a data source, then run another query at the same data source, only one connection is required. However, if you run those two queries simultaneously, then two connections are required. If another connection to a data source is required and this limit is reached, an error is returned and the operation is not performed.

Note: To enable table editing, you must specify that two or more simultaneous connections are allowed.
Specifying SQL Verbs resource limits

On the SQL Verbs page of the Edit Resource Limits Group Schedule window you specify the SQL verbs that users assigned to this resource limits group are allowed to use when this schedule is in effect.

If a user tries to run a query that contains a disallowed verb, the query is canceled without sending the SQL to the data source. SQL Verbs resource limits can be set for data sources.

The use of the following SQL verbs can be controlled:
- ACQUIRE
- ALTER
- CALL
- COMMENT
- CREATE
- DELETE
- DROP
- EXPLAIN
- GRANT
- INSERT
- LABEL
- LOCK
- REFRESH
- RENAME
- REVOKE
- SET
- SELECT
- UPDATE

Specifying Options resource limits

On the Options page of the Edit Resource Limits Group Schedule window you specify the levels of access users have to a data source and the data source objects.

Options resource limits can be set for data sources. The Options resource limits are as follows:

Allow access to data source from user interface
This field specifies whether you have permission to access a data source from the QMF for Workstation user interface when the current resource limits group schedule is in effect.

Allow access to data source from programming interface
This field specifies whether you have permission to access a data source from the QMF for Workstation application programming interface (API) when the current resource limits group schedule is in effect.

Fetch all rows automatically
This field specifies how the data source will send query results data to the application. By default, data is requested from the data source only as required to display query results. For example, if 20 rows fill up the query results window, only 20 rows are requested from the data source. When you scroll down to make the 21st row visible, more data is requested. If
you run a query and then wait before scrolling down, the query remains active for that wait time, consuming resources at the data source. If this parameter is enabled, data is requested repeatedly until all data is received, independent of your scrolling requests.

Confirm database updates
This field specifies whether or not you must confirm all data source changes resulting from the queries that you run or the actions that you perform when editing tables. If this check box is selected, you will be prompted for confirmation before any data source changes can occur. If this check box is cleared, data source changes can occur without confirmation.

You can override this resource limit setting using the Confirm parameter in a Procedure command. The following table shows the correlation of the parameters, depending on the specified values.

<table>
<thead>
<tr>
<th>Confirm database updates value</th>
<th>Procedure parameter value</th>
<th>The confirmation dialog behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected</td>
<td>confirm=yes</td>
<td>appears</td>
</tr>
<tr>
<td>Selected</td>
<td>confirm=no</td>
<td>does not appear</td>
</tr>
<tr>
<td>Selected</td>
<td>not specified</td>
<td>appears</td>
</tr>
<tr>
<td>Cleared</td>
<td>confirm=yes</td>
<td>appears</td>
</tr>
<tr>
<td>Cleared</td>
<td>confirm=no</td>
<td>does not appear</td>
</tr>
<tr>
<td>Cleared</td>
<td>not specified</td>
<td>does not appear</td>
</tr>
</tbody>
</table>

Enable exporting of data
This field specifies whether a user can export query result data to a file using the Export command from the File menu or the EXPORT DATA procedure command.

Enable table editing
This field specifies whether or not you can edit a table using the table editor feature.

Allow running saved queries only
This field specifies whether or not you can create and save new queries at the database data source. If checked, you can only run queries that are saved at the database data source. If clear, you can run queries, as well as create and save new queries at the database data source.

Isolation level for queries
The Isolation level for queries parameter only applies to databases that support transactions.

This field specifies the level of transaction isolation to be applied to a user’s queries. There are varying levels of isolation, each with a differing degree of impact on transaction processing in the database.

Consult with your database administrator or the database server documentation to determine if the database server being used is configured to support transaction processing.

Valid values include:
• Default specifies that the isolation level for a query will be the default specified for all applications.
• **Repeatable Read** specifies that the isolation level for a query will be Repeatable Read (RR). The RR isolation level provides the most protection from other applications.

• **All (RS)** specifies that the isolation level for a query will be Read Stability (RS).

• **Cursor Stability (CS)** specifies that the isolation level for your query will be Cursor Stability (CS). The CS isolation level provides the maximum concurrency with data integrity.

• **Change (UR)** specifies that the isolation level for your query will be Uncommitted Read (RS) which allows an application to read uncommitted data.

• **No Commit (NC)** specifies that the isolation level for your query will be No Commit (NC). An application running with an isolation level of NC can not make permanent database changes.

**Account**

This field specifies the default account information that will be sent to a data source when you connect to that data source.

**Account can be overridden**

This field specifies whether you are allowed to override the default accounting information specified in the Account field when connecting to a data source. If selected, you can enter a new accounting string using the Set User Information window. If clear, you cannot enter new accounting information and you are prevented in some cases from accessing data source objects that are not owned by your resource limits group.

**Require account information**

This field specifies whether you must specify a valid accounting string in the Set User Information window before connecting to a database when this schedule is in effect.

**Allow printing**

This check box must be selected in order for you to print objects that are stored on the data source.

**Specifying Save Data resource limits**

On the Save Data page of the Edit Resource Limits Group Schedule window you specify whether users assigned to this resource limits group and using this schedule can save data at the database data source.

**Save Data** resource limits can be set for data sources. The Save Data resource limits are as follows:

**Allow save data command**

This field specifies whether you can save data at the database data source. Saving data can be extremely resource-intensive. As a result it can have a significant impact on your database and network.

**Default table space**

This field specifies the default table space name that will be used for tables created with the save data command. This field is only available if the Allow save data command has been selected. The syntax of the table space name that you specify must conform to the database rules for table space names. Any value that you specify is used as part of the CREATE TABLE SQL statement that runs when you save data to a new table. Entering an asterisk (*) specifies that the default table space will be taken from a user's
profile in the RDBI.PROFILE_TABLE or Q.PROFILES that are specified by the administrator when your profile was created.

**Default table space can be overridden**
This field specifies whether you can override the default table space. If selected, you can specify any table space name subject to database security authorizations. If this check box is not selected, you must use the table space name specified in the **Default table space** field.

**Allow to replace any existing data**
This field specifies whether a user can override the existing data when the objects are exported or imported to the database. If this option is selected, a user can replace the existing data with the new one in the database. If this check box is clear, a user can only append new data to the existing one.

**Specifying Binding resource limits**
On the Binding page of the Edit Resource Limits Group Schedule window you specify whether users assigned to this resource limits group and using this schedule can bind or drop static packages for their queries to or from the data source.

**Binding** resource limits can only be set for data sources. The **Binding** resource limits are as follows:

**Allow binding of packages**
This field specifies whether or not you can bind static packages for your queries on the database data source.

**Allow dropping of packages**
This field specifies whether or not you can drop static packages from the database data source.

**Default collection ID**
This field specifies the default collection ID for the static packages that you bind.

**Default collection ID can be overridden**
This field specifies whether you must use the default collection ID. If this check box is selected, you can specify any collection ID subject to database security authorizations. If this check box is clear, you must use the default collection ID that is specified in the **Default collection ID** field.

**Default isolation level**
This field specifies the default isolation level for the static packages that you bind. You can select one of the isolation levels:

- **Repeatable Read** specifies that the default isolation level for the static packages will be Repeatable Read (RR). The RR isolation level isolates the SQL statements in the static package from the actions of concurrent users for rows the requester reads and changes, including phantom rows. RR isolation provides the most protection.

- **All (RS)** specifies that the default isolation level for the static packages will be Read Stability (RS). The RS isolation level isolates the SQL statements in the static package from the actions of concurrent users for rows the requester reads and changes.

- **Cursor Stability (CS)** specifies that the default isolation level for the static packages will be Cursor Stability (CS). The CS isolation level isolates the SQL statements in the static package and the current row to
which the database cursor is positioned from the actions of concurrent users for changes the requester makes.

- **Change (UR)** specifies that the default isolation level for the static packages will be Uncommitted Read (UR). The UR isolation level isolates the SQL statements in the static package from the actions of concurrent users for changes the requester makes.

- **No Commit (NC)** specifies that the default isolation level for the static packages will be No Commit (NC). The NC isolation level does not isolate the SQL statements in the static package from the actions of concurrent users for changes the requester makes.

**Default isolation level can be overridden**
This field specifies whether you can override the isolation level specified in the Default isolation level field. If this check box is selected, you can specify any isolation level when binding packages. If this check is not selected, you must use the default isolation level specified in the Default Isolation Level field to bind static packages.

**Specifying Object Tracking resource limits**
On the Object Tracking page of the Edit Resource Limits Group Schedule window you activate object tracking.

Object tracking must be enabled in order to collect the tracking data that is used to populate object tracking reports. Object tracking reports can help you locate unused objects, locate frequently accessed data sources such as tables or columns and spot potential problem areas. Object Tracking resource limits can be set for data sources.

The Object Tracking resource limits are as follows:

**Enable summary object tracking**
This field specifies whether summary object tracking is activated for your resource limits group. Summary tracking records the number of times an object is run, and the most recent times it was run and modified.

**Enable detailed object tracking**
This field specifies whether detailed object tracking is activated for your resource limits group. Detailed tracking records each time the object is run, who ran it, and the results. A large amount of data can be collected if this option is selected.

*Note:* This option must be enabled to use ad hoc object tracking or SQL text tracking.

**Enable ad-hoc object tracking**
This field specifies whether a record of each ad-hoc query is kept in the summary or detail object tracking tables. An ad-hoc query is a query that has not been named or saved at the database data source.

*Note:* The Enable detailed object tracking option must be enabled in order to enable this option.

**Enable SQL text tracking**
This field specifies whether a record of the SQL text of each query is kept in the detail tracking table.
Note: The Enable detailed object tracking option must be enabled in order to enable this option.

Last Used timestamp option
This field specifies when and by which commands data objects are updated.

Note: In cases when the object is saved to the QMF Catalog, the data is kept in the column LAST_USED of the table Q_OBJECT_DIRECTORY. If the object is saved to the repository, then the data is kept in the column LAST_USED of the RSBI.OBJECTS table.

The following options are available:

- **Update when object is accessed (legacy mode)**
  Data is updated when you run any of the following commands against the object:
  - CONVERT
  - DISPLAY
  - EXPORT
  - IMPORT
  - PRINT
  - RUN
  - SAVE

- **Update when object is run, saved or imported**
  Data is updated after performing RUN, SAVE or IMPORT commands.

- **Update only when object is run**
  Data is updated only after performing RUN command.

Last Used timestamp options can be overridden
Indicates whether the DSQEC_LAST_RUN variable value is ignored.

This check box is cleared by default.

Select this check box to change the variable value and override the resource limit.

Specifying LOB Options resource limits
On the LOB Options page of the Edit Resource Limits Group Schedule window you control a users ability to access, retrieve, and save data to and from tables containing large objects (LOBs).

A Large Object (LOB) is aDB2 for z/OS and DB2 for Linux, UNIX, and Windows data type that houses non-traditional data such as text, multimedia, image, video, photograph, sound, or any very large data file inside a database table. Retrieving or saving LOB data can consume a substantial amount of resources. Even just accessing a table that contains LOB data can be resource consumptive. Using the LOB Options resource limits, you can control access to tables on the database data source that include LOB data. LOB Options resource limits can be applied to both data sources and individual queries.

The LOB Options resource limits are as follows:

LOB Retrieval Option
This field specifies whether a user can retrieve large object (LOB) data when this schedule is in effect. You can select one of the following:
• **Disable LOB columns** specifies that users can not retrieve LOB data and can not query or access any table that contains LOB data.

• **Disable LOB data retrieval** specifies that users can not retrieve LOB data but can query tables that contain LOB data. Query result data will be returned for all columns in the table except those that contain LOB data.

• **Retrieve LOB data on demand** specifies that users can query tables that contain LOB data and result data will be returned for all columns including those columns that contain LOB objects. However, the results data for the LOB columns will not actually be displayed in the column. A pointer is displayed. When the user selects the pointer, the LOB data will be displayed in the query results.

    You can also pull the data from the database by double-clicking on the pointer.

• **Retrieve LOB data automatically** specifies that users can query tables that contain LOB data and the result data will be returned for all columns, including those columns that contain LOB objects.

    This option pulls ALL of the LOB data for ALL of the LOB columns from the database to the local computer.

    This option can potentially consume a large amount of resources and time. The actual LOB data is not displayed in grids and reports. Instead, pointers to the LOB data are displayed.

**Enable saving LOB data**

This field specifies whether users can save LOB data on the database data source.

**Maximum LOB column size**

This field specifies the maximum size of a LOB column, in kilobytes, up to 2G (the maximum LOB size). The default is 0, no maximum. If a user queries a table with LOB data that is larger than the maximum, the LOB data will not be returned for display.

**LOB options can be overridden**

This field specifies whether a user can override the default LOB Options resource limits that have been specified for their group.

### Specifying Report Center resource limits

You can control the level of QMF Report Center functionality allowed for members of a resource limits group.

With QMF Report Center you can generate custom reports using shared queries, forms, procedures and tables that are stored on the database server. The custom reports can then be viewed and manipulated in a variety of applications.

To control which Report Center functions are authorized for a resource limit group, you specify settings on the **Report Center** page of the Edit Resource Limits Group window.

**The Report Center resource limits are as follows:**

**Allow display of all object types**

Select this check box to allow members of this resource limits group to access the objects that are used for their QMF Report Center reports.
Users do not need special permission to use the QMF Report Center application or run reports. However, in order to create new reports they need access to the stored objects. Some users might not have permission to access these objects. By selecting this check box you are authorizing members of this resource limits group to access the objects that are stored on the database server and create new reports.

**Note:** The Allow display of all object types check box is selected by default.

**Allow administration of root node**
Select this check box to allow the members of this resource limits group to add folders to the root folder, Public Favorites, used by the QMF Report Center application. The Public Favorites folder is stored on the database server.

QMF Report Center uses two top-level folders, Personal Favorites and Public Favorites, to store user's reports. Each folder contains reports that point to objects that reside on the database server. The objects are not contained within the folders.

The Personal Favorites folder resides locally on the user's machine. This folder and the reports contained in it can only be accessed by the user who created it.

The Public Favorites folder resides on the database server. It can be accessed (potentially) by all QMF Report Center users. However, in order to add a first-level sub folder to the Public Favorites folder, users must have permission. This option gives the members of this resource limits group that permission.

If granted permission to create a first-level sub folder, the member of the resource limit group is authorized to use the QMF Report Center security options to control who can run or amend the reports residing in the folder. The Public Favorites folder can have up to 50 first-level sub folders.

**Note:** The Allow administration of root node check box is cleared by default.

**Allow taking ownership of node**
Select this check box to allow all members of this resource limits group authorization to take ownership of a folder or a report in the Public Favorites folder.

If this check box is selected, users can access any report or folder in the Public Favorites folder regardless of whether they have been granted that access by QMF Report Center security.

**Note:** The Allow taking ownership of node check box is cleared by default.

**Specifying Cache resource limits**
On the Cache page of the Edit Resource Limits Group Schedule window you activate caching for query results.

With this resource limit enabled, when a query is run, the results will be cached. If the query is run again, and nothing has changed, the results will be taken from the cached results rather than run again at the data source. Cache resource limits can be applied to both data sources and individual queries.
The **Cache** resource limits are as follows:

**Cache is enabled**
This field specifies whether the caching of result set data is enabled. Caching is disabled by default. If caching is enabled, result data from a query is cached (stored) and is available for use by other users that have the same privileges to access this data on the data source. Caching result set data can significantly decrease resource consumption and improve performance. The cached result set data is not automatically refreshed.

**Auto data fetching enabled**
This field specifies how the cached rows of data will be retrieved. This resource limit becomes available if **Cache is enabled** is selected. When selected, this option specifies that if the query result set is taken from the cache, the entire result set will be presented. When this option is not selected, 100 rows (the default) of the query result set is presented.

**Data expiration interval**
This field specifies the time period the query result set data will remain in cache. You can set the time period by specifying the number of days, hours, and minutes. After this period, the cached query result set data will be updated.

**Cache options can be overridden**
This field specifies whether the cache options can be overridden.

---

**Specifying Object List resource limits**

On the Object List page of the Edit Resource Limits Group Schedule window you specify default and allowed owner names for data sources.

With **Object List** resource limits, you can define the default owner name that will be used to filter data source objects. You can also specify a specific list of owner names that can be used to filter data source objects aside from the default name.

The **Object List** resource limits are as follows:

**Default Owner Name**
This field specifies the default owner name that will be used to filter the data source object list.

**Default Owner Name can be overridden**
This check box allows the user to override the current default owner name.

**Allowed Owner Names**
This field specifies the list of additional owner names that can be used to filter the data source object list. Owner names should be separated by a comma.

**Allow <USERNAME>**
This check box allows the current user’s owner name to be used to filter the data source object list.

**Allow <SQLID>**
This check box allows the current user’s SQLID to be used to filter the data source object list.

---

**Specifying Acceleration resource limits**

Use the Acceleration page of the Edit Resource Limits Group Schedule window to activate query acceleration.
With this resource limit enabled, you are able to save your data to the accelerator server that is associated with the database that you are currently using, and run accelerated queries. With this resource limit disabled, you cannot run accelerated queries.

The **Acceleration** page includes the following settings:

**Enable acceleration**
This check box specifies whether the acceleration is enabled. Acceleration is available only for DB2 z/OS databases that support IDAA.

**Acceleration type**
This field specifies the conditions that determine whether the queries are run by the database or by the accelerator. The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NONE</td>
<td>Specifies that no queries are sent to an accelerator server.</td>
</tr>
<tr>
<td>ENABLE</td>
<td>Specifies that queries are accelerated only if the database determines that it is advantageous to do so. If an accelerator failure occurs while a query is running or if the accelerator returns an error, database returns a negative SQLCODE to the application.</td>
</tr>
<tr>
<td>ENABLE WITH FAILBACK</td>
<td>Specifies that queries are accelerated only if the database determines that it is advantageous to do so. If the accelerator returns an error during the PREPARE or first OPEN command for the query, the database executes the query without the accelerator. If the accelerator returns an error during a FETCH or a subsequent OPEN command, the database returns the error to the user and does not execute the query.</td>
</tr>
<tr>
<td>ELIGIBLE</td>
<td>Specifies that queries are accelerated if they are eligible for acceleration. Queries that are not eligible for acceleration are executed by the database. If an accelerator failure occurs while a query is running or if the accelerator returns an error, the database returns a negative SQLCODE to the application.</td>
</tr>
<tr>
<td>ALL</td>
<td>Specifies that queries are accelerated if they are eligible for acceleration. Queries that are not eligible for acceleration are not executed by the database, and an SQL error is returned. If an accelerator failure occurs while a query is running or if the accelerator returns an error, the database returns a negative SQLCODE to the application.</td>
</tr>
</tbody>
</table>

**Acceleration options can be overridden**
This check box specifies whether acceleration options can be overridden.
Assigning users to resource limits groups

You must specifically assign users to a resource limits group.

About this task

Once assigned, what each user can do using QMF for Workstation and QMF for WebSphere is dictated by the resource limits group schedule. All users who are not assigned to a resource limits group are automatically included in the default resource limits group Default. The Default resource limits group schedule has no restrictions.

In order to assign a user to a resource limits group, you must first specify information that defines the user to QMF for Workstation and QMF for WebSphere. The process of defining users to the applications and then assigning them to a resource limits group varies slightly depending on the resource limits provider that was selected for the data source.

Assigning users to repository resource limits groups

To assign a user to a repository-based resource limits group, you select directly from the list of available users and groups that were given access to the secured repository when it was created.

About this task

The users and groups that are available for selection were defined based on the type of security that was selected for the repository. If LDAP security was selected, the users and groups were obtained from the LDAP server. If Internal security was selected, you define the user and group information using the Users and Groups view. If no security has been specified for the repository, and resource limits are repository based, you do not have the ability to create resource limits groups and make assignments.

The order in which you create user information or resource limits groups does not matter. You can create user information first, then create resource limits groups. You can create resource limits groups first, then user information. This flexibility is intended as creating and editing user information and resource limits group assignments is an ongoing process as the needs of your organizations change.

To assign a user to a repository-based resource limits group:

Procedure


2. The users that have been defined for the data source and are available for assignment, but have not been assigned to the selected resource limits group, are listed in the Not assigned list box. The users that have been assigned to the selected resource limits group are listed in the Assigned list box. To filter the users that are listed in the Not assigned list specify the user ID of a specific user or a wildcard character in the Name filter field. A percent (%) sign will
generate a list of all users that have been defined for the data source. If not listed, the user or group has not been defined. You can define a new user or group, and then refilter the list.

3. Select the user that you want to assign to the resource limits group from the Not assigned list. Click Assign. The user is moved to the Assigned list.

4. To remove a user from the resource limits group, select the user from the Assigned list. Click Unassign. The user is moved to the Not assigned list. To remove all the users from the Assigned list and move them to the Not assigned list, click Unassign All.

5. Click OK. Your additions or changes to the resource limits group user assignments are saved.

Results

Note: You can also make user assignments to resource limits groups on the Assignment page of the Resource Limits window.

Managing user assignments for all repository resource limits groups

Each user and group that is defined for a data source can be assigned to one or more repository resource limits groups.

About this task

The Assignment page of the Resource Limits window lists each user or group that is defined for a data source and each resource limits group that is defined for the data source. From this window, you can assign a user to one or more resource limits groups from a single dialog.

To make user assignments for all resource limits groups from one dialog:

Procedure

1. From the Repository Explorer view, right-click a data source. Select Properties from the pop-up menu. The Properties for [data source] window opens. Click the Resource Limits folder. The Resource Limits window opens. There are two pages. Click the Assignment tab.

2. The users and groups that have been defined for the data source are listed in the Users and Groups field. Expand the Groups folder to see all groups. Expand the Users folder to see all users.

3. Each Users and Groups cell has a corresponding Resource groups drop-down list box. The Resource groups list displays all the resource limits groups that have been defined for the data source. To select a resource limits group, click the Resource groups cell for the user or group, click the downward arrow, and select a new resource limits group from the list of available resource limits groups.

4. Click Save or OK. The new assignment is made.

Assigning users to QMF catalog-based resource limits groups

To assign a user to a QMF catalog-based resource limits group you must first define a user profile for the user, and then you assign the user profile to the resource limits group.
The order in which you create user profiles or resource limits groups does not matter. You can create user information first, then create resource limits groups. You can create resource limits groups first, then user information. This flexibility is intended as creating and editing user information and resource limits group assignments is an ongoing process as the needs of your organizations change.

**Granting QMF catalog user profile enrollment**

When a user connects to a data source the correct user profile for their user ID is located and their enrollment status is verified to determine which resource limits group to use.

Access to a data source will be granted to a user based on the following types of user ID enrollment:

- *Restricted enrollment*, where each user ID must have a matching user profile to gain access to the data source.
- *Open enrollment*, where each user ID can either have a matching user profile to gain access to a data source or automatically fall into a default user profile called SYSTEM.

With open enrollment, every user has access to the SYSTEM user profile, giving every user potential access to the data source. You can create unique profiles for some users and allow other users to use the SYSTEM default profile.

With restricted enrollment, every user must have a unique user profile in order to access the data source. When setting up restricted enrollment, you delete the SYSTEM profile, which prevents users without unique profiles from accessing the data source.

**Determining which QMF catalog user profile to use**

When QMF for Workstation or QMF for WebSphere connects to a data source on behalf of a user, the user ID and password they provide are validated first by the data source. If the user information is valid, then the user ID is looked up in the user profile table, RDBI.PROFILE_TABLE.

The RDBI.PROFILE_TABLE is created at installation. All user IDs that are included in the Q.PROFILES table at the time of installation are included in the RDBI.PROFILE_TABLE.

**Note**: After the initial copy of Q.PROFILES, any user ID added directly to Q.PROFILES is not automatically added to the RDBI.PROFILE_TABLE. You must add those new user IDs using a QMF Administrator product (Workstation or WebSphere).

The RDBI.PROFILE_TABLE includes the following columns:

<table>
<thead>
<tr>
<th>CREATOR</th>
<th>ENVIRONMENT</th>
<th>TRANSLATION</th>
<th>RESOURCE GROUP</th>
</tr>
</thead>
<tbody>
<tr>
<td>userID</td>
<td>WINDOWS</td>
<td>English</td>
<td>TECH</td>
</tr>
<tr>
<td>userID</td>
<td>NULL</td>
<td>English</td>
<td>SALES</td>
</tr>
<tr>
<td>SYSTEM</td>
<td>WINDOWS</td>
<td>English</td>
<td>BASIC</td>
</tr>
<tr>
<td>SYSTEM</td>
<td>NULL</td>
<td>English</td>
<td>SYSTEM</td>
</tr>
</tbody>
</table>
When you create a new user profile, an entry is made in the table for the user ID that you enter. The Creator column is the user ID that you enter, the Environment and Translation columns are filled for you based on the environment and language of the host system. The Resource Group column contains the resource limits group to which this user is assigned.

**Determining database access with QMF catalog user profiles**

QMF for Workstation and QMF for WebSphere determine which resource limits group to use by locating the user's profile from the RDBI.PROFILE_TABLE, finding the resource limits group name in the Resource Group column of the table, then finding that resource limits group in the RDBI.RESOURCE_TABLE, where the resource limits and schedule are retrieved.

When you are setting up your user profiles for your environment, there are many permutations that can be used to control data source access. The following summarizes some of the different combinations that you might use:

For restricted enrollment:
- User ID matches a user profile. User profile names a resource limits group. Resource limits group exists. Access to data source is based on the resource limits and schedule for the group.
- User ID does not match a user profile. There is no default user profile called SYSTEM. User is denied access to the data source.

For open enrollment:
- User ID matches a user profile. User profile names a resource limits group. Resource limits group exists. Access to data source is based on the resource limits and schedule for the group.
- User ID does not match a user profile. There is a default user profile called SYSTEM. The default user profile SYSTEM names a resource limits group. The resource limits group exists. Access to data source is based on the resource limits and schedule for the group.
- User ID matches a user profile. No resource limits group is assigned. Access to the data source is based on the limits set for the default resource limits group.
- User ID does not match a user profile. There is a default user profile called SYSTEM. There is no resource limits group that has been defined for the SYSTEM user profile. User has access to the data source based on the limits set for the default resource limits group.

**Assigning users to QMF catalog resource limits groups**

To assign a user to a QMF catalog-based resource limits group you must first define a user profile for the user, and then you assign the user profile to the resource limits group.

**About this task**

The order in which you create user profiles or resource limits groups does not matter. You can create user information first, then create resource limits groups. You can create resource limits groups first, then user information. This flexibility is intended as creating and editing user information and resource limits group assignments is an ongoing process as the needs of your organizations change.
Note: The users with the specified <NULL> or <WINDOWS> value in the ENVIRONMENT column and the users with values that match Language User Interface of the Preferences in the TRANSLATION column are available for assigning the resource limits group.

To assign users to a QMF catalog resource limits group:

**Procedure**


2. The user profiles that have been created for the data source and are available for assignment are listed in the User Profiles Not Assigned list box including the SYSTEM user profile. You can modify the user profiles that are listed using the Show User Profiles with creator matching field. In this field you can specify the user ID of a specific user profile or a wildcard character. A percent (%) sign will generate a list of all user profiles that have been created for the data source. Click the Refresh List button to initiate the search. All the user profiles are stored in RDB1.PROFILE_VIEW that match the value you entered are retrieved. It can be populated from RDB1.PROFILE_TABLE or Q.PROFILES. For more information about the RDB1.PROFILE_TABLE or Q.PROFILES tables, see “Creating database objects for the QMF catalog” on page 84. The users that have been assigned to the selected resource limits group are listed in the Assigned list box.

3. If the user ID that you want to assign to a resource limits group is not listed in the Not Assigned list, click Create New to create a new user profile. The New Profile window opens. In the Creator field, specify a valid user ID for a user. Click OK. The New Profile window closes. The new user profile is created and assigned to the resource limits group. Control returns to the Assign User Profiles to [resource limits group name] window.

4. Select the user that you want to assign to the resource limits group from the Not Assigned list. Click Assign. The user is moved to the Assigned list. To move all the users from the Not Assigned list to the Assign list, click Assign All.

5. To remove a user from the resource limits group, select the user from the Assigned list. Click Unassign. The user is moved to the Not Assigned list. To remove all the users from the Assigned list and move them to the Not Assigned list, click Unassign All.

6. Click OK. Your additions or changes to the resource limits group user assignments are saved.

**Results**

*Note:* You can also make user assignments to resource limits groups, and create, edit and delete user profiles, from the User Profiles page of the Resource Limits window.

**Managing user profiles**

All users that will be assigned to a QMF catalog based resource limits group must have a user profile.
About this task

You can use the User Profiles page of the Resource Limits window to create, edit or delete user profiles, and assign new user profiles that you create to QMF catalog resource limits groups.

To create, edit or delete user profiles:

Procedure

1. From the Repository Explorer view, right-click a data source. Select Properties from the pop-up menu. The Properties for [data source] window opens. Click the Resource Limits folder. The Resource Limits window opens. There are two pages. Click the User Profiles tab.

2. The user profiles that have been created for the data source and meet the most recent search criteria are listed in the User Profiles list box including the SYSTEM user profile. You can modify the user profiles that are listed using the Show User Profiles whose names match field. In this field you can specify the user ID of a specific user profile or a wildcard character. A percent (%) sign will generate a list of all user profiles that have been created for the data source. Click the Refresh List button to initiate the search.

3. To add a new user profile, click Add. The User Profile window opens. Specify the field values and click OK. The user profile is created and assigned to a resource group that you specify. Control returns to the User Profiles page.

4. To edit a user profile, select the user profile that you want to change from the User Profiles list. Click Edit. The User Profile window opens. Make the changes to the field values and click OK. The changes are saved and control returns to the User Profiles page.

5. To delete a user profile, select the user profile that you want to delete from the User Profiles list. Click Delete. The user profile is deleted from the profile table.

   Note: If you are choosing to use restricted enrollment, you must delete the SYSTEM user profile.

6. Click Apply or OK. The changes that you have made to the user profiles are saved.

Creating user profiles

You can create a new user profile or edit an existing user profile using the User Profile dialog.

About this task

If you are creating a new user profile, you can assign the new user profile to a resource limits group from the same window. If you are editing a user profile you can change the resource limits group assignment to a different group. In either case, the resource limits group you select must already have been created.

To create a new or edit an existing user profile:

Procedure

1. From the Repository Explorer view, using QMF for Workstation, right-click a data source. Select Properties from the pop-up menu. The Properties for [data
source] dialog opens. Click the **Resource Limits** folder. The Resource Limits window opens. There are two pages. Click the **User Profiles** tab. Click **Add**. The User Profile window opens.

2. Specify a valid user ID for the user profile in the **Creator** field.

3. Specify a resource limits group to which the user profile will become a member in the **Resource Group** field. Unless otherwise specified all new user profiles are automatically assigned to the default resource limits group SYSTEM. To see a list of the resource limits groups defined for this data source, click the button with three dots to the right of the field. The Resource Limits Groups at [data source] window opens. From the Resource Limits Groups at [data source] window, select a resource limits group for the user profile. Click **OK**. The user profile is assigned to the selected resource limits group. Control returns to the User Profile window.

4. Specify a table space name that will be used when this user saves data using the **SAVE DATA** command in the **Space** field. This field is only applicable if the **Default table space can be overridden** resource limit setting in the **Save Data** tab has been checked, allowing users to override the default table space name with a unique name. Click **OK**. The user profile is created.

**Selecting a resource limits group for a user profile**

Use the Resource Limits Group at window to view a list of the resource limits groups that have been defined for the data source.

**About this task**

You can select from the list of available groups, the resource limits group to which you will assign the user profile that you are creating or editing.

To select a resource limits group for a user profile:

**Procedure**

1. From the **Repository Explorer** view, using QMF for Workstation, right-click a data source. Select **Properties** from the pop-up menu. The Properties for [data source] window opens. Click the **Resource Limits** folder. The Resource Limits window opens. There are two pages. Click the **User Profiles** tab. Click **Add**. The User Profile window opens. Click the button with three dots. The Resource Limits Group at window opens.

2. From the **Resource limits group** list, select the resource limits group to which you want to assign the user profile.

3. Click **OK**. The user profile is assigned to the resource limits group that you selected. The Resource Limits Groups at window closes. Control returns to the User Profile window.
Chapter 24. Managing repositories

Administrators are responsible for the ongoing maintenance of shared repositories, and the query and reporting environment.

The following tasks describe maintaining repositories:

Deleting a repository

You can delete a repository from shared repository storage.

About this task

To delete a repository:

Procedure

1. The Repositories view is usually open and docked to the left, next to the Repository Explorer view. If closed, you can open the Repositories view by selecting Repositories from the View menu.
2. From the Repositories view, right-click the repository that you want to delete.
3. From the pop-up menu, select Delete Repository. A confirmation message is issued. If you are sure that you want to delete the repository, click OK.

Editing shared repository storage properties

You can edit the properties of shared repository storage.

About this task

To edit shared repository storage properties:

Procedure

1. The Repositories view is usually open and docked to the left, next to the Repository Explorer view. If closed, you can open the Repositories view by selecting Repositories from the View menu.
2. From the Repositories view, right-click the shared repository storage whose properties you want to modify. From the pop-up menu, select Edit. A multiple page Edit Repository Storage window opens displaying the properties that you can change.
3. Select Connection to change the JDBC connection or user login information. The Connection page opens. You can make any of the JDBC connection or user login information changes from this page.
4. Select Objects to update the repository storage database objects. The Objects page opens. You can update the repository storage database objects from this page.
5. Select Protection to change the protection status of the repository storage tables. The Protection page opens. You can make any changes to the protection status of the repository storage tables and grant or revoke users access to the tables from this page.
• **Unprotected**: Specifies that you will connect to the repository in unprotected mode. In this mode, dynamic query access to the repository storage tables, within which the repository resides, will be allowed. If the repository storage tables are restricted to the connecting user ID, the connection will fail. If the repository storage tables are unrestricted to the connecting user ID, the connection will be made and the dynamic query will process.

• **Auto**: Specifies that the protection mode will be selected automatically depending on whether a collection of stored procedures or static SQL packages are available. If available, the repository storage tables within which the repository resides will be accessed using the specified stored procedures or static SQL packages. If the stored procedures or static SQL packages are unavailable, dynamic query access (unprotected mode) will be used.

• **Protected**: Specifies that you will connect to the repository in protected mode using the specified stored procedures or static SQL packages to access the repository storage tables within which the repository resides. If the specified set of stored procedures or static SQL packages are not available, the connection will fail.

6. Click OK. The Edit Repository Storage window closes. The changes that you have made are applied.

**Editing connection parameters and user login information**

You use the Connection page of the Edit Repository Storage window to edit the connection information and the user login information that will be used to connect to the shared repository storage.

**About this task**

To edit the connection parameters and login user information for shared repository storage:

**Procedure**

1. Open the Connection page of the Edit Shared Repository Storage window.
2. In the **JDBC Driver** field specify the library for the JDBC driver that will be used to access the database that is hosting the repository storage. You can select from a drop down list of libraries that you defined when you set up the JDBC driver information. You can use the ellipsis (...) to the right of the field to open the JDBC Libraries dialog where you can create additional JDBC driver libraries.

   **Note:** If you work with a DB2 for z/OS database, you can use the Direct DRDA Connection. In contrast to JDBC libraries, the Direct DRDA Connection comes with QMF and does not require additional driver installation.

   You can enable the use of SSL certificates for the Direct DRDA Connection to make the connection secure.

   **Note:** The Direct DRDA Connection is supported only for DB2 for z/OS Version 9, Version 10, and Version 11. Do not use it for DB2 LUW or DB2 for iSeries.

   **See** [Using DRDA to connect to database repositories and data sources](#) for more information.
3. In the **JDBC URL** list, specify the URL that points to the database that hosts the repository storage within which the repository to which you want to connect resides.

   The format for the URL can be displayed in the list.

   **Note:** You can also use the *Build URL by URL Template* dialog box to form the correct string.

   Click *Build URL* to open the Build URL by URL Template dialog box. From the JDBC URL drop-down list, select the template. In the table, specify the *server*, *port*, and database information and click *OK*. The result URL string is added to the JDBC URL list.

4. Click *Advanced* to specify any driver-specific connection string keywords and their values that will be used for the database that is hosting the repository storage tables. The list of available advanced properties will change depending on both the type of driver being used, and the version of the driver. For information on any keywords that are required by a selected database driver, consult the specific driver's documentation.

   **Note:** For the DB2 Type 4 UDB driver and the DB2 Universal JDBC Driver, to receive extended SQL exception error messages, check the *retrieveMessagesFromServerOnGetMessage* option in the Advanced JDBC Settings window.

5. If you use the Direct DRDA Connection, bind packages by clicking the *Bind Packages* button.

6. In the User Information dialog, select *User ID and password are required* to require the use of a user ID and password when accessing the database that is hosting the repository storage. If the database that is hosting the repository storage allows access without a user ID and password, selecting this option will override that allowance, and a user ID and password will be required to access the repository storage tables.

7. To remember this password every time you use the specified user ID to connect to the database, select the *Remember password* check box.

8. Click *Test Connection* to test the connection to the database. If you have specified any information incorrectly you will not be able to connect.

9. If you have completed making changes to the repository storage properties, click *OK*. If you will be making additional changes, click the *Objects* or *Protection* tab, depending on the changes that you are making.

**Updating database objects**

You use the Objects page of the Edit Shared Repository Storage dialog to update the database objects that are required for the repository storage.

**About this task**

To update the repository storage objects that reside on the database:

**Procedure**

1. Open the Objects page of the Edit Repository Storage window.

2. Optionally you can type the owner name in the *Owner ID* field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.
Tip: (for DB2 for z/OS databases)

When the user without administrator privileges creates or updates the shared repository storage tables and enters the owner name in the Owner ID field, the user login and Owner ID are automatically inserted to the RSBI.AUTHID_TABLE as the PRIMARY_ID and SECONDARY_ID correspondingly. This allows the user to create shared repositories with database-based security provider and automatically work with the repositories as an administrator.

3. Click Update to check if the repository storage objects have been created or have to be updated. Depending on the status of the objects you will proceed as follows:
   • If all the objects have not changed, a message is issued. Click OK in the message window.
   • If the objects have to be updated, then the Update repository storage tables page opens listing the SQL statements that will be used to update the required repository storage tables. You can make changes to the SQL statements as described on the page.

4. If you have completed making changes to the repository storage properties, click OK. If you will be making additional changes, click the Connection or Protection tab, depending on the changes that you are making.

Editing protection options

You use the Protection page of the Edit Shared Repository Storage window to update the protection options for the repository storage tables.

About this task

To update the protection options for the repository storage tables:

Procedure

1. Open the Protection page of the Edit Shared repository Storage window.
2. Depending on the current status of the Protection method check box, you can change the protection status of the repository storage table in one of the following ways:
   • Clear the Protection method check box to remove the protected status of the repository storage tables. This means that all users will have access to the repository storage tables and can make changes to any of those tables.
   • Select the Protection method check box to specify that you will protect the repository storage tables. The fields that you will use to specify the protection method become available.
3. Select one of the following protection methods:
   • Select Stored procedures to specify that you will use stored procedures to protect the repository storage tables. You can select this option if the repository storage tables are located on one of the following databases:
     – Informix
     – DB2 UDB LUW V9 and above
     – DB2 z/OS V9 and above in NFM
     – DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
     – Microsoft SQL Server
     – Oracle
     – PostgreSQL
• Select Static SQL packages to specify that you will use static SQL packages to protect the repository storage tables. You can select this option if the repository storage tables are located on a DB2 database that you will connect to using the IBM DB2 Universal driver for JDBC or the Direct DRDA connectivity provided by the product (the latter option is available for DB2 for z/OS connectivity only).

4. Type, or select from the drop-down list, the name that you want to use to identify the collection of stored procedures or static SQL packages in the Collection ID field.

5. Optionally you can type the owner name in the Owner ID field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.

6. Click Create. The stored procedures are created or the static SQL packages are bound. A message is issued that informs you of the success of the either process. You can also use the Delete button to remove a collection of stored procedures or packages.

7. Specify which users will have permission to run the stored procedures or static SQL packages from the repository storage tables on this database. To grant permission to all users, enter PUBLIC in the User IDs field and click Grant. To grant permission to specific users, type their user IDs in the field and click Grant. A message is issued that informs you that the selected user IDs have been granted permission to run the stored procedures or packages. Optionally, you can revoke permission to run the stored procedures or static SQL packages from any user that is listed in the User IDs list box. To revoke permission from one or more users, highlight one or more of the user IDs and click Revoke. A message is issued informing you that permission to run the stored procedures or static SQL packages has been revoked from the selected user IDs.

8. If you have completed making changes to the repository storage properties, click OK. If you will be making additional changes, click the Objects or Connection tab, depending on the changes that you are making.

---

**Editing QMF catalog plug-in properties**

You use the QMF Catalog Plug-in Parameters dialog to change or update the QMF catalog plug-in parameters for a data source.

**About this task**

To edit the QMF catalog plug-in properties:

**Procedure**

1. The Repositories view is usually open and docked to the left, next to the Repository Explorer view. If closed, you can open the Repositories view by selecting Repositories from the View menu.

2. From the Repositories view, right-click the data source whose QMF catalog plug-in properties you want to modify. From the pop-up menu, select Properties. The Properties window opens. Select Plug-ins. The Plug-ins window opens. If the QMF Catalog Plug-in has been enabled for this data source (the Enable plug-in check box is selected), the Parameters button is available. Click Parameters. The QMF Catalog Plug-in Parameters window opens.
Note: If the database that you are using supports IDAA and QMF Catalog Plug-in is disabled for the data source, Accelerator-only tables are displayed in the Database node and the Accelerator node of the data source tree of objects. If the plug-in is enabled, Accelerator-only tables are displayed only in the Accelerator node.

3. Select **Catalog Tables** to update the QMF catalog tables. The Catalog Tables page opens. You can update the QMF catalog tables from this page.

4. Select **Protection** to change the protection status of the QMF catalog tables. The Protection page opens. You can make any changes to the protection status of the QMF catalog tables and grant or revoke users access to the tables from this page.

5. Select **Catalog** to change the QMF catalog that the current data source will use. The Catalog page opens. You can make any changes to the QMF catalog selected for this data source.

6. Select **Sample Tables** to create a set of sample tables for the current data source. The Sample Tables page opens. You can create the sample tables from this page.

7. Click **OK**. The Edit QMF Catalog Plug-in Parameters window closes. The changes that you have made are applied.

### Updating QMF catalog tables

Use the Catalog Tables page of the QMF Catalog Plug-in Parameters window to update the QMF Catalog tables for a data source.

#### About this task

You would update the QMF Catalog tables if a new version of QMF has been installed or if you want to change from a QMF catalog that supports short names to one that supports long names.

#### Procedure

1. Open the Catalog Tables page of the QMF Catalog Plug-in Parameters window.

2. To update a set of QMF catalog tables that supports short names for objects, select **Update catalog tables to support short names**. QMF will check the existing QMF catalog tables on the data source, and update or add to the existing tables as necessary. You are given the opportunity to confirm and modify the SQL statements used to create the tables. Any data that is in the existing catalog tables is maintained.

   Select this option if you are upgrading from a previous version of QMF and the existing QMF catalog tables will continue to support only short names for objects.

3. To update a set of QMF catalog tables that supports long names for objects, select **Update catalog tables to support long names**. QMF will check the existing QMF catalog tables on the data source, and update or add to the existing tables as necessary. You are given the opportunity to confirm and modify the SQL statements used to create the tables. Any data that is in the existing catalog tables is maintained.

   Select this option if you are upgrading from a previous version of QMF and the existing QMF catalog tables will continue to support long names for objects.

   You would also select this option if you want to update the QMF catalog tables from supporting short names to supporting long names. If an existing set of QMF catalog tables that use short names is detected on the data source, those tables will be converted to support long names.
**Note:** In order to select this option, the data source must support long names. QMF will check to ensure that the data source supports long names.

**Tip:** When the QMF Catalog tables are updated, QMF checks whether the required QMF objects exist and restores the objects that are dropped to the appropriate locations in a database.

The names of the QMF objects that are generated in a database when you create the QMF Catalog and their property values are stored in the RDBI.SERVER_INFO table. If a database administrator renames some objects in a database, the information in the RDBI.SERVER_INFO becomes invalid. During the update process, QMF detects the QMF objects that were renamed and saves their actual names to the RDBI.SERVER_INFO table. The changes that are made to the RDBI.SERVER_INFO table during the update process are displayed in a log file.

4. Click **OK** to close the QMF Catalog Plug-in Parameters window. Any changes that you have made to the QMF Catalog Plug-in parameters are saved.

---

**Updating the protection status of QMF catalog tables**

Use the Protection page of the QMF Catalog Plug-in Parameters window to update the QMF catalog tables protection options.

**About this task**

You would update the QMF catalog table protection if you are updating your version of QMF; changing the type of protection that has been specified for the tables; or changing the stored procedures or static SQL packages that you originally specified. You can also change user permissions to use the QMF catalog packages at any time.

**Procedure**

1. Open the Protection page of the QMF Catalog Plug-in Parameters window.
2. To change the type of protection that will be applied to the QMF catalog tables, select one of the following from the **Connect using Protected Mode** radio group:
   - **Never:** You select this option to specify that no protection will be placed on the QMF catalog tables. This method will expose the QMF catalog tables to unauthorized use. With no protection the QMF catalog tables can be accessed by any user using dynamic queries. When the database administrator grants permissions to a user to access the QMF catalog that resides on the database, that permission will extend to the whole QMF catalog including the tables in the QMF catalog that store sensitive information.
   - **If possible:** You select this option to specify that the QMF catalog tables will be protected using either stored procedures or static SQL packages if they are available on the data source. You will specify the users that can run the stored procedures or static SQL packages. If a set of stored procedures or static SQL packages is not available, access to the QMF catalog tables will be as if they are unprotected.
   - **Always:** You select this option to specify that the QMF catalog tables will always be protected using either stored procedures or static SQL packages. You will specify the users that can run the stored procedures or static SQL packages. If a set of stored procedures or static SQL packages is not available, the query to access the QMF catalog tables will fail.
3. If you selected **If possible** or **Always** from the **Connect using Protected Mode** radio group, the **Protect** check box becomes available.

4. Select one of the following protection methods:
   - Select **Stored procedures** to specify that you will use stored procedures to protect the QMF catalog tables. You can select this option if the repository storage tables are located on one of the following databases:
     - DB2 UDB LUW V9 and above
     - DB2 z/OS V9 and above
     - DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
   - Select **Static SQL packages** to specify that you will use static SQL packages to protect the QMF catalog tables. You can select this option if the repository storage tables are located on a DB2 database that you will connect to using the IBM DB2 Universal driver for JDBC or the Direct DRDA connectivity provided by the product (the latter option is available for DB2 for z/OS connectivity only).

5. Type, or select from the drop-down list, the name that you want to use to identify the collection of stored procedures or static SQL packages in the **Collection ID** field.

6. Optionally you can type the owner name in the **Owner ID** field, if you work with DB2 databases. The Owner ID provides the administrator privileges to the user who operates under the login without SYSADM authority.

7. Click **Create**. The stored procedures are created or the static SQL packages are bound. A message is issued that informs you of the success of either process. You can also use **Delete** to remove a collection of stored procedures or static packages.

8. You must specify which users will have permission to run the stored procedures or static SQL packages for the QMF catalog tables on this database. To grant permission to all users, highlight **PUBLIC** in the User IDs list and click **Grant**. To grant permission to specific users, type their user IDs in the field, highlight one or more of the user ID(s) and click **Grant**. A message is issued that informs you that the selected user IDs have been granted permission to run the stored procedures or static SQL packages. Optionally, you can revoke permission to run the stored procedures or SQL packages from any user that is listed in the **User IDs** list box. To revoke permission from one or more users, highlight one or more of the user IDs and click **Revoke**. A message is issued informing you that permission to run the stored procedures or static SQL packages has been revoked from the selected user IDs.

9. Click **OK** to close the QMF Catalog Plug-in Parameters window. Any changes that you have made to the QMF Catalog Plug-in parameters are saved.

**Selecting a different QMF catalog for the data source**

Use the Catalog page of the QMF Catalog Plug-in Parameters dialog to select a different QMF catalog for the data source.

**About this task**

To select a different catalog for the data source:

**Procedure**

1. Open the Catalog page of the QMF Catalog Plug-in Parameters window.
2. From the **Data source name** drop-down list of available data sources in the currently connected to repository, select the data source that hosts the QMF catalog that you want to use.

3. From the list of available QMF catalogs available on the data source that you selected in **Data source name**, select the QMF catalog that you want the data source to use. If the QMF catalog is not listed, you can add a new extended QMF catalog using the **Add** icon. You can also edit an existing extended QMF catalog's properties using the **Edit** icon or delete an existing extended QMF catalog using the **Delete** icon.

4. Click **OK** to close the QMF Catalog Plug-in Parameters window. Any changes that you have made to the QMF Catalog Plug-in parameters are saved.
Chapter 25. Using sample tables

Nine sample tables are supplied with the QMF for Workstation and QMF for WebSphere applications.

These tables contain information about a fictitious electrical parts manufacturing company. They can be useful while you are learning how to use QMF for Workstation or QMF for WebSphere. Sample tables are only available if you have enabled a QMF catalog for a data source.

Activating sample tables

You must activate the sample tables.

About this task

To activate the sample tables:

Procedure

1. From the Repository Explorer view, right-click a data source that has been configured to access a QMF catalog. Select Properties from the pop-up menu. The Properties for [data source] dialog opens. Click the Plug-ins folder. The Plug-ins dialog box opens. Select Plug-ins from the properties tree. Verify that the Enable plug-in check box is selected. Click the Parameters button. The QMF Catalog Plug-in Parameters dialog box opens. Click the Sample Tables tab. The Sample Tables dialog box opens.

2. From the Sample Tables dialog box, click Create.

3. If you are prompted with the message that says existing sample tables will be overwritten if new tables are created, respond to the confirmation message by clicking Yes.

4. The status bar at the bottom of the dialog window lists the sample tables that are being created.

5. Click OK to close the QMF Catalog Plug-in Parameters dialog box.

Sample table names and descriptions

This list includes the name of each sample table that is included with the QMF application.

The following sample tables are available:

Q.APPLICANT
The company's prospective employees

Q.INTERVIEW
The interview schedule for the company's prospective employees

Q.ORG
Organization of the company by department, within division

Q.PARTS
Materials supplied by the company
Q.PRODUCTS
Products produced by the company

Q.PROJECT
The company’s projects

Q.STAFF
The company’s employees

Q.SALES
Sales information for the company

Q.SUPPLIER
Vendors that supply materials to the company
Chapter 26. Using object tracking reports

Object tracking reports show you detailed and summary information on object usage by QMF for Workstation or QMF for WebSphere users.

With this information, you can spot potential problem areas and see where changes to resource limits group schedules are needed. Object tracking reporting is available for data sources with repository based or QMF catalog based resource limits. In order to report on object usage you must activate object tracking for a data source.

Activating object tracking

To track a user’s object usage on a data source, you must activate object tracking for their resource limits group.

About this task

You can activate object tracking for a resource limits group on a data source when you define or update the schedules for the resource limits group.

Note: If your user ID has the required authority, you can query the detail and summary tracking tables directly using QMF for Workstation or QMF for WebSphere and see any tracking information contained within those tables.

To activate object tracking for a data source:

Procedure

1. Right-click a data source from either the Repositories or Repository Explorer views. Select Properties from the pop-up menu. The Properties for [data source] window opens. Click the Resource Limits folder. The Resource Limits window opens. There are two pages. Click the Resource Limits tab.
2. Select a resource limits group from the list of available resource limits groups. Click Edit. The Edit Resource Limits Group window opens.
3. All of the schedules that have been defined for this resource limits group are listed in the Schedule List list box. To edit the resource limits group schedule, select the schedule from the Schedule List list box and click Edit. The Edit Resource Limits Group Schedule window opens.
4. Select the Object Tracking tab.
5. Check the type of object tracking that you want to activate. Your choices are:
   - **Enable summary object tracking:** Select this check box to activate summary object tracking. Summary object checking tracks an object and keeps a summarized record of actions that pertain to the record.
   - **Enable detailed object tracking:** Select this check box to activate detailed object tracking. Detailed object checking keeps a detailed record of each action taken using an object.
   - **Enable ad hoc object tracking:** Select this check box to keep a record of each *ad hoc* SQL query and the SQL text of that query. Detailed object tracking must be activated in order to use *ad hoc* object tracking.
• **Enable SQL text tracking:** Select this check box to specify that a record of the SQL text of each SQL query is kept. Detailed object tracking must be activated in order to use SQL text tracking.

6. Click **OK**.

## Running the object tracking reports

After activating object tracking you can run any of the existing reports or you can create your own report.

### About this task

To run an object tracking report:

### Procedure

1. Right-click a data source from either the **Repositories** or **Repository Explorer** views. Select **Object Tracking Reports** from the pop-up menu. The Object Tracking Reports window opens.

2. Select a report from the list of available reports and click **Run**. The list of available report includes both standard object tracking reports that come with the application and customized object tracking reports that you might have added. The following standard object tracking reports are available:
   • **Cancellation Summary By User:** This report shows which users most frequently have their queries cancelled. High rates of cancellation can indicate that the user needs more training or greater resource privileges.
   • **Cancellation Details For Single User:** This report provides details about the queries that were cancelled for a specific user, including the query name, SQL text, and reason for cancellation.
   • **Performance Summary (Maximum) by Query:** This report shows performance data for queries, including their maximum elapsed time and number of times run. The report is sorted in descending order to highlight the queries with the most resource consumption.
   • **Performance Summary (Average) By Query:** This report shows performance data for queries, including their average elapsed time and number of times run. It is sorted in descending order to highlight the queries with the most resource consumption.
   • **Performance Summary (Cumulative) For Single Query:** This report shows which users most often run a specific query and the elapsed time of the query. Use this report once a problem query is identified to determine the users who run the query most frequently.
   • **Performance Details For Single Query:** This report shows detail statistics for each run of a query. It provides performance information, such as elapsed time and bytes fetched for each run.
   • **Performance Profile For Single User:** This report shows which queries have been run by a user and the resources consumed by the queries. The report is sorted in descending order to highlight the queries with the most resource consumption.
   • **Performance Summary (Cumulative) By User:** This report shows which users are most actively using QMF and consuming the most resources.
   • **Time Period Performance Summary (Cumulative) By User:** This report shows, within a time period, which users most actively used QMF and consumed the most resources.
• **Cancellation Summary By Repository User:** This report shows which users most frequently have their queries that are stored in the repository cancelled. High rates of cancellation can indicate that the user needs more training or greater resource privileges.

• **Performance Summary (Maximum) by Repository Query:** This report shows performance data for queries that are stored in a repository, including their maximum elapsed time and number of times run. The report is sorted in descending order to highlight the queries with the most resource consumption.

• **Performance Summary (Average) by Repository Query:** This report shows performance data for queries that are stored in a repository, including their average elapsed time and number of times run. It is sorted in descending order to highlight the queries with the most resource consumption.

• **Performance Summary (Cumulative) by Repository User:** This report shows which users are most actively using a repository and consuming the most resources.

• **Time Period Performance Summary (Cumulative) By Repository User:** This report shows, within a time period, which users most actively used a repository and consumed the most resources.

3. A customized object tracking report is a visual report that you have created and saved to a file. After you create the report, you can add the customized report to the list of available object tracking reports, by clicking the **Add** button in the Object Tracking Reports window. The Add Object Tracking Report window opens. Specify the name of the report as it will appear in the list of available object tracking reports in the **Report title** field. Optionally, you can enter a description of the report in the **Report description** field. Specify the name of the file where the visual report was saved in the **Report file name** field. Specify where the query that was used for the visual report resides in the **Query for report** field. If the visual report includes a query that runs against an extended QMF catalog, specify the name and where the query resides in the **Extended query for the report** field. Click **OK**. The report is added to the list.

---

**Maintaining object tracking tables**

Detail and summary object tracking tables should be maintained on a regular basis.

Detail and summary object tracking tables should be maintained on a regular basis. Detailed object tracking data about repository based objects is stored in the RSBLOBJ_ACTIVITY_DTL table and detailed object tracking data about QMF catalog based objects is stored in the Q.OBJ_ACTIVITY_DTL table. Summarized object tracking data about repository based objects is stored in the RSBLOBJ_ACTIVITY_SUMM table and summarized object tracking data about QMF catalog based objects is stored in the Q.OBJ_ACTIVITY_SUMM table.

A row is added to the Q.OBJ_ACTIVITY_DTL table and the RSBLOBJ_ACTIVITY_DTL for each use of an object. For example, if a user executes a query (object) 20 times, 20 rows are added to the table.

Only one row is added to the summary tables Q.OBJ_ACTIVITY_SUMM and RSBLOBJ_ACTIVITY_SUMM for each object regardless of the amount of times the object is used. So in this example, the object usage count, a field in the table, would increase by 20, but no new rows are added. Rows are added to the summary table only when a new object is created and rows are automatically deleted when an object is deleted.
Since the summary tables will not grow without boundaries and the detail tables will, it is more important to perform maintenance on the detail tables with greater frequency than the summary tables. The following are recommendations for optimum performance of the Q.OBJ_ACTIVITY_DTL table and RSBI.OBJ_ACTIVITY_DTL detail tables:

- Run RUNSTATS for the table space and index.
- Delete old data periodically.

For example, for a DB2 database, you can run this query to delete all rows older than 30 days from the QMF catalog object detail table (if your user ID has permission to access the summary and detail tables):

```
DELETE FROM Q.OBJ_ACTIVITY_DTL WHERE "DATE" (CURRENT DATE - 30 DAYS)
```

For a DB2 database, you can run the following query to delete all rows older than 30 days from the repository object detail table (if your user ID has permission to access the summary and detail tables).

If you are using DB2 for LUW:

```
DELETE FROM RSBI.OBJ_ACTIVITY_DTL WHERE
( DAYS ( CURRENT DATE ) - DAYS ( DATE ('1970001')) - ETIME/3600/24/1000 ) >30
```

If you are using DB2 for z/OS:

```
DELETE FROM RSBI.OBJ_ACTIVITY_DTL WHERE
CAST((DAYS ( CURRENT DATE ) - DAYS ( DATE ('1970001')) AS BIGINT ) *86400000 - ETIME > 2592000000
```

- For DB2 for z/OS, perform maintenance on the repository object detail table and its associated auxiliary table (RSBL.ACTIVITY_LOB_DATA) and index (RSBL.ACTIVITY_LOB_DATA). For DB2 for z/OS, perform maintenance on the QMF catalog object detail table and its associated table space (RAADB.RAAIX2) and index (Q.RAAIX2). Q.RAAIX2 is a default name that can be changed by the database administrator when the QMF catalog is created.

**Note:** The first-used, last-used and last-modified summary statistics stored in the summary table are not affected when you delete detailed data.
Chapter 27. Using the audit system

QMF provides an audit system to collect detailed information on user actions.

The audit system covers the following categories of user actions:
- Connecting to and disconnecting from various type of repositories
- Working with Repository Explorer objects
- Working with QMF objects
- Using Web API
- Using the task scheduler

Accessing audit records

The topic describes how you can access the audit system records for QMF.

About this task

Before you access the audit records, make the audit system is configured. For more information about setting the audit system, see “Setting the audit system” on page 32.

To access the audit records:

Procedure

1. Create a relational data source using the following URL:
   - jdbc:h2:/{user.home}\AppData\Roaming\IBM\QMF for Workstation\Audit\audit;AUTO_SERVER=TRUE for QMF for Workstation
   - jdbc:h2:{user.home}\Application Data\IBM\QMF for WebSphere\Audit\audit;AUTO_SERVER=TRUE for QMF for WebSphere
   where {user.home} depends on the user account under which the application is run.
2. In the JDBC Driver field, specify the library for the JDBC driver that will be used to access the H2 database.
3. When configuring the data source, clear the User ID and password are required check box in the User Information dialog.
4. In the created data source, go to the AUDIT schema and double-click the AUDIT_VIEW table.

Note: For more information about creating relational data sources, see “Creating a new relational data source” on page 89.

Reading the audit record table

This topic describes the AUDIT_VIEW table that presents all information gathered by the audit system.

To find information about how to access the AUDIT_VIEW table, see “Accessing audit records.” The AUDIT_VIEW has the following content.
<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVENT TIME</td>
<td>Indicates the time of the event.</td>
</tr>
<tr>
<td>USER IP</td>
<td>Indicates the IP address of the system on which the action was performed.</td>
</tr>
<tr>
<td>USER LOGIN</td>
<td>Indicates the name of the user who connects to the repository indicated in the REPOSITORY NAME column.</td>
</tr>
<tr>
<td>REPOSITORY STORAGE</td>
<td>Indicates the URL of the repository storage where the specified event occurred.</td>
</tr>
<tr>
<td>REPOSITORY NAME</td>
<td>Indicates the name of the repository in the indicated repository storage where the specified event occurred.</td>
</tr>
<tr>
<td>OBJECT NAME</td>
<td>Indicates the name of the event object.</td>
</tr>
<tr>
<td>OBJECT PATH</td>
<td>Indicates the path to the event object.</td>
</tr>
<tr>
<td>OBJECT TYPE</td>
<td>Indicates the type of the event object.</td>
</tr>
<tr>
<td>DATABASE</td>
<td>Indicates the data source that is used by the event object.</td>
</tr>
<tr>
<td>EXECUTION CONTEXT</td>
<td>Indicates the path to the object that runs the event object. For example, a path to a procedure or visual dashboard.</td>
</tr>
<tr>
<td>DURATION</td>
<td>Indicates the time to process the specified event.</td>
</tr>
<tr>
<td>CATEGORY</td>
<td>Indicates the subsystem where the specified event occurred.</td>
</tr>
<tr>
<td>EVENT TYPE</td>
<td>Indicates the event type.</td>
</tr>
<tr>
<td>ERROR CODE</td>
<td>Indicates the code of the error that occurred during the specified event. The complete list of error messages is provided in the Messages section of the Installing and managing DB2 QMF for Workstation and DB2 QMF for WebSphere publication.</td>
</tr>
<tr>
<td>ROWS FETCHED</td>
<td>Indicates the number of rows retrieved by an SQL query against the database.</td>
</tr>
<tr>
<td>ROWS UPDATED</td>
<td>Indicates the number of rows affected by an UPDATE or INSERT SQL query against the database.</td>
</tr>
<tr>
<td>DATABASE LOGIN</td>
<td>Indicates the login of the user who connects to the data source indicated in the DATABASE column.</td>
</tr>
<tr>
<td>SQL TEXT</td>
<td>Provides access to the text of an executed SQL query. Double-click the &lt;LOB locator&gt; to view the SQL text.</td>
</tr>
<tr>
<td>QUERY TYPE</td>
<td>Indicates the type of an executed query.</td>
</tr>
<tr>
<td>RESULT</td>
<td>Indicates whether the specified event was successful or failed.</td>
</tr>
</tbody>
</table>

To find the descriptions of the tables that contribute to the AUDIT_VIEW table, see “Auxiliary audit record tables” on page 211.
Auxiliary audit record tables

This topic describes the structure of the auxiliary audit record tables that contribute to the formation of the AUDIT_VIEW table.

To find information about how to access the tables that store data gathered by the audit system, see “Accessing audit records” on page 209. Under the AUDIT schema, you can find the following auxiliary audit record tables:

- The AUDIT_RECORDS is the basic table that provides information for the AUDIT_VIEW table. It has the following content:

  **Table 16. AUDIT_RECORDS**

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Record ID</td>
</tr>
<tr>
<td>EVENT TIME</td>
<td>Indicates the time of the event.</td>
</tr>
<tr>
<td>USER IP</td>
<td>Indicates the IP address of the system on which the action was performed.</td>
</tr>
<tr>
<td>USER LOGIN</td>
<td>Indicates the name of the user who connects to the repository indicated in the REPOSITORY NAME column.</td>
</tr>
<tr>
<td>REPOSITORY STORAGE</td>
<td>Indicates the URL of the repository storage where the specified event occurred.</td>
</tr>
<tr>
<td>REPOSITORY NAME</td>
<td>Indicates the name of the repository in the indicated repository storage where the specified event occurred.</td>
</tr>
<tr>
<td>OBJECT NAME</td>
<td>Indicates the name of the event object.</td>
</tr>
<tr>
<td>OBJECT PATH</td>
<td>Indicates the path to the event object.</td>
</tr>
<tr>
<td>OBJECT TYPE</td>
<td>Indicates the type of the event object.</td>
</tr>
<tr>
<td>DATABASE</td>
<td>Indicates the data source that is used by the event object.</td>
</tr>
<tr>
<td>EXECUTION CONTEXT</td>
<td>Indicates the path to the object that runs the event object. For example, a path to a procedure or visual dashboard.</td>
</tr>
<tr>
<td>DURATION</td>
<td>Indicates the time to process the specified event.</td>
</tr>
<tr>
<td>CATEGORY</td>
<td>Indicates the ID of the subsystem where the specified event occurred according to the EVENT_CATEGORY table.</td>
</tr>
<tr>
<td>EVENT TYPE</td>
<td>Indicates the event type ID according to the EVENT_TYPES table.</td>
</tr>
<tr>
<td>ERROR CODE</td>
<td>Indicates the code of the error that occurred during the specified event.</td>
</tr>
<tr>
<td>ROWS Fetched</td>
<td>Indicates the number of rows retrieved by an SQL query against the database.</td>
</tr>
<tr>
<td>ROWS UPDATED</td>
<td>Indicates the number of rows affected by an UPDATE or INSERT SQL query against the database.</td>
</tr>
</tbody>
</table>

The complete list of error messages is provided in Appendix D. Messages in the Installing and managing DB2 QMF for Workstation and DB2 QMF for WebSphere publication.
**Table 16. AUDIT_RECORDS (continued)**

<table>
<thead>
<tr>
<th>DATABASE LOGIN</th>
<th>Indicates the login of the user who connects to the data source indicated in the DATABASE column.</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQLTEXTID</td>
<td>Indicates the ID of the row with the text of the executed SQL query according to the AUDIT_RECORDS_SQL table.</td>
</tr>
<tr>
<td>QUERY TYPE</td>
<td>Indicates the ID of the executed query type according to the QUERY_TYPE table.</td>
</tr>
<tr>
<td>RESULT</td>
<td>Indicates the ID of the specified event result according to the EVENT_RESULTS tables.</td>
</tr>
</tbody>
</table>

- The EVENT_TYPES table that provides data for the EVENT_TYPE column of the AUDIT_RECORDS table and contains the following content:

**Table 17. EVENT_TYPES**

<table>
<thead>
<tr>
<th>ID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>READ</td>
</tr>
<tr>
<td>2</td>
<td>LOGOUT</td>
</tr>
<tr>
<td>3</td>
<td>DELETE</td>
</tr>
<tr>
<td>4</td>
<td>ENUMERATE</td>
</tr>
<tr>
<td>5</td>
<td>CREATE</td>
</tr>
<tr>
<td>6</td>
<td>UPDATE</td>
</tr>
<tr>
<td>7</td>
<td>RUN</td>
</tr>
<tr>
<td>8</td>
<td>LOGIN</td>
</tr>
</tbody>
</table>

- The EVENT_CATEGORIES table that provides data for the CATEGORY column of the AUDIT_RECORDS table contains the following content:

**Table 18. EVENT_CATEGORIES**

<table>
<thead>
<tr>
<th>ID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>REPOSITORY</td>
</tr>
<tr>
<td>2</td>
<td>SECURITY</td>
</tr>
</tbody>
</table>

- The EVENT_RESULTS table that provides data for the RESULT column of the AUDIT_RECORDS table and contains the following content:

**Table 19. EVENT_RESULTS**

<table>
<thead>
<tr>
<th>ID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>SUCCESS</td>
</tr>
<tr>
<td>2</td>
<td>FAILED</td>
</tr>
<tr>
<td>3</td>
<td>ACCESS DENIED</td>
</tr>
<tr>
<td>4</td>
<td>CANCELED</td>
</tr>
</tbody>
</table>

- The EVENT_OBJECT_TYPES table provides data for the OBJECT TYPE column of the AUDIT_RECORDS table and has the following structure:

**Table 20. EVENT_OBJECT_TYPES table structure**

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
</table>
Table 20. EVENT_OBJECT_TYPES table structure (continued)

<table>
<thead>
<tr>
<th>ID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Object type ID</td>
</tr>
<tr>
<td>NAME</td>
<td>Object type name</td>
</tr>
</tbody>
</table>

- The QUERY_TYPES table provides data for the QUERY_TYPE column of the AUDIT_RECORDS table and contains the following content:

Table 21. QUERY TYPES

<table>
<thead>
<tr>
<th>ID</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RENAME</td>
</tr>
<tr>
<td>2</td>
<td>ALTER</td>
</tr>
<tr>
<td>3</td>
<td>CALL</td>
</tr>
<tr>
<td>4</td>
<td>SET</td>
</tr>
<tr>
<td>5</td>
<td>CREATE</td>
</tr>
<tr>
<td>6</td>
<td>REVOKE</td>
</tr>
<tr>
<td>7</td>
<td>REFRESH</td>
</tr>
<tr>
<td>8</td>
<td>LOCK</td>
</tr>
<tr>
<td>9</td>
<td>SELECT</td>
</tr>
<tr>
<td>10</td>
<td>COMMENT</td>
</tr>
<tr>
<td>11</td>
<td>DROP</td>
</tr>
<tr>
<td>12</td>
<td>ACQUIRE</td>
</tr>
<tr>
<td>13</td>
<td>DELETE</td>
</tr>
<tr>
<td>14</td>
<td>GRANT</td>
</tr>
<tr>
<td>15</td>
<td>EXPLAIN</td>
</tr>
<tr>
<td>16</td>
<td>LABEL</td>
</tr>
<tr>
<td>17</td>
<td>INSERT</td>
</tr>
<tr>
<td>18</td>
<td>UPDATE</td>
</tr>
<tr>
<td>19</td>
<td>UNKNOWN</td>
</tr>
</tbody>
</table>

- The AUDIT_RECORDS_SQL table provides data for the SQLTEXTID column of the AUDIT_RECORDS table and has the following structure:

Table 22. AUDIT_RECORDS_SQL table structure

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>SQL statement ID</td>
</tr>
<tr>
<td>SQLTEXT</td>
<td>SQL statement text presented as LOB</td>
</tr>
</tbody>
</table>
Chapter 28. Using the QMF Data Server Administrative Console

QMF Data Server Administrative Console allows you to administer the QMF Data Server.

The following topics describe how to use the QMF Data Server Administrative Console:

Deploying QMF Data Server Administrative Console on the application server

The installation package includes an Enterprise Archive (EAR) file and a Web Archive (WAR) file that can be immediately deployed to your web application server using the server administrative console.

About this task

To deploy QMF Data Server Administrative Console to your application server, complete the following steps:

Procedure

1. To install QMF Data Server Administrative Console, follow the standard installation procedure for IBM web-based applications. For more information about the procedure, see IBM online help.

2. When the installation is complete, open your web browser and type the following URL: http://host:port/QMFDataServer121, where host is the name of your host server and port is the number of the port that you want to use.

   **Note:** The repositories.xml, .bi.jdbc.drivers, and .lic configuration files from QMF for WebSphere are required to start QMF Data Server via web console. QMF Data Server Administrative Console is displayed.

Working with QMF Data Server Administrative Console

Use the QMF Data Server Administrative Console to administer the QMF Data Server.

On the QMF Data Server Administrative Console web page, you can perform the following actions:

- **Click START** to start a new QMF Data Server session.
- **Click STOP** to end the current QMF Data Server session.
- **To configure QMF Data Service to work with a QMF Data Server session,** view the **CONNECTION INFORMATION FOR QMF DATA SERVICE** area. The following connection information is available in the area:

  **Database Type**
  
  Shows the database type that the service works with.
Domain
Shows the web address of the server that runs the QMF Data Server Administrative Console.

Port
Shows the number of the currently used QMF Data Server port.

Available Locations
Shows the list of available repository connections.
For more detailed information, see the QMF Data Service documentation.

- Click AVAILABLE JDBC DRIVERS to view the list of JDBC drivers that are specified in QMF for WebSphere.
- Click RUNTIME INFORMATION to display the runtime information for QMF Data Server. The following runtime information is available:

  **Session Number**
  Shows the ordinal number of the current session.

  **Connection Threads**
  Shows the amount of data streams that are used for user connections to the server.

  **Active Sessions**
  Shows the number of active sessions.

  **Waiting Sessions**
  Shows the number of suspended sessions.

  **Total Memory**
  Shows the amount of memory that is available for the JVM.

  **Free Memory**
  Shows the amount of free memory that is available for the JVM.

- Click to display the CONFIGURATION dialog. In the CONFIGURATION dialog of the QMF Data Server Administrative Console, you can perform the following actions:
  - In the Port field, specify the port that you want to work with. The default value is 1527. If the Port field is left blank, the default value is used.
  - In the VM arguments field, specify the changes that you want to make to the Java Virtual Machine that runs QMF Data Server. For more information about VM arguments, consult the Oracle documentation.
  - From the QMF Log Level list, select the type of QMF messages that you want to save in the log.
  - In the Classpath field, specify the path to the JDBC driver files.
  - In the Path to Logs field, specify the location where you want to save the log files.
  - From the DRDA Protocol Log Level list, select the type of QMF Data Server messages that you want to save in the log.
Appendix A. Accessibility

Software accessibility features help those with physical disabilities, such as restricted mobility or limited vision, use their computers.

Note: The QMF for Workstation application provides the best accessibility functionality. Users with physical disabilities who must make use of the QMF accessibility features should install and run QMF for Workstation, as opposed to QMF for WebSphere.

Standard keyboard equivalents in QMF for Workstation

Keyboard equivalents use keyboard keys to perform mouse actions instead of using a mouse.

The keyboard is the most frequently used alternative for performing mouse functions. QMF supports the standard keyboard equivalents that include:

- Shortcut, or accelerator keys, to perform the most frequently used functions in pull-down menus without going to the menu. For example:
  - Ctrl+S to save
  - Ctrl+P to print
  - Ctrl+R to run a query
  Shortcuts display in the pull-down menu next to its function.

- Mnemonics, or access keys, are available to perform each function on a menu or window. A mnemonic for a function is the underlined character in the function name. For example:
  - Press F to open the File menu
  - Press O to open the Open window
  Use ALT to activate the mnemonic and move the keyboard focus.

For more information, refer to the documentation for your operating system for a complete list of standard keyboard equivalents.

Standard keyboard navigation

Keyboard navigation refers to using keys instead of a mouse to move from item to item on your screen.

The movement is usually in the order specified by the operating system or your application. QMF applications follow the standards with regard to the typical keys used for keyboard navigation such as using TAB and SHIFT+TAB to move between controls, and arrow keys to move up, down, and sideways between items.

Operating system accessibility

Most operating systems have a set of accessibility options that enable individuals with disabilities to customize system-wide settings.

QMF applications:

- Inherit their settings from the operating system
• Do not interfere with keyboard accessibility features built into the operating system

Assistive technology products

QMF applications support assistive technology products, such as screen readers and voice synthesizers.

Each QMF application interface requires special navigation when using a screen reader with query results. See “Navigation in QMF for Workstation” or “Navigation in QMF for WebSphere” on page 220 for more information.

Navigation in QMF for Workstation

The following table shows how to accomplish various tasks using keystrokes.

<table>
<thead>
<tr>
<th>To:</th>
<th>Process:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate mnemonics in menus</td>
<td>Press the Alt key. Mnemonics in each menu are activated.</td>
</tr>
<tr>
<td>Obtain online help</td>
<td>Press F1 to open a specific help task or Alt+H to open the Help menu. Use the arrow keys to move through the menu selections. Press Enter to open a menu command.</td>
</tr>
<tr>
<td>Display keyboard shortcuts</td>
<td>Press Ctrl+Shift+L.</td>
</tr>
<tr>
<td>Display the Draw Query wizard</td>
<td>Press Ctrl+D.</td>
</tr>
<tr>
<td>Display the switch list of the editors of the opened QMF objects and switch between the editors</td>
<td>Press Ctrl+F6 to move forward in the switch list and Ctrl+Shift+F6 to move in the opposite direction.</td>
</tr>
<tr>
<td>Left to right switch between the tabs of the opened QMF objects</td>
<td>Press Ctrl+Page Up</td>
</tr>
<tr>
<td>Right to left switch between the tabs of the opened QMF objects</td>
<td>Press Ctrl+Page Down</td>
</tr>
<tr>
<td>Move focus through each element</td>
<td>Press TAB to move forward or SHIFT+TAB to move in the opposite direction.</td>
</tr>
<tr>
<td>Emulate clicks on a link</td>
<td>Use the TAB key to jump from link to link, then press the Enter key to open the link.</td>
</tr>
<tr>
<td>Emulate clicks on a button</td>
<td>Use the TAB key to jump from button to button, then press Space key to activate the button.</td>
</tr>
<tr>
<td>Within a window, activate the default action</td>
<td>Press the Enter key.</td>
</tr>
<tr>
<td>Within a window, cancel the action</td>
<td>Press the ESC key.</td>
</tr>
<tr>
<td>Left to right switch between views</td>
<td>Press Ctrl+F7</td>
</tr>
<tr>
<td>Right to left switch between views</td>
<td>Press Ctrl+Shift+F7</td>
</tr>
<tr>
<td>Left to right switch between perspectives</td>
<td>Press Ctrl+F8</td>
</tr>
<tr>
<td>To:</td>
<td>Process:</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Right to left switch between perspectives</td>
<td>Press Ctrl+Shift+F8</td>
</tr>
<tr>
<td>Left to right switch between tabs in the active editor</td>
<td>Press Alt+Page Up</td>
</tr>
<tr>
<td>Right to left switch between tabs in the active editor</td>
<td>Press Alt+Page Down</td>
</tr>
<tr>
<td>Activate command bar</td>
<td>Press Ctrl+Shift+C</td>
</tr>
<tr>
<td>Use screen reader for query results</td>
<td>1. Run the query.</td>
</tr>
<tr>
<td>or</td>
<td>2. Press Alt+R to open the <strong>Results</strong> menu.</td>
</tr>
<tr>
<td>Use browser to display query results in high contrast mode for the</td>
<td>3. Select <strong>Export</strong> to open the Export Query Results wizard.</td>
</tr>
<tr>
<td>visually impaired</td>
<td>4. Use the <strong>TAB</strong> key to move through controls. Use arrow keys to</td>
</tr>
<tr>
<td></td>
<td>move through selection items in the control. Select <strong>HTML</strong></td>
</tr>
<tr>
<td></td>
<td>from the <strong>Export Type</strong> list. Specify where to save the file in the</td>
</tr>
<tr>
<td></td>
<td><strong>File name</strong> field.</td>
</tr>
<tr>
<td></td>
<td>5. Press <strong>Finish</strong>.</td>
</tr>
<tr>
<td></td>
<td>6. Open the *.htm file in a browser.</td>
</tr>
<tr>
<td>or</td>
<td>1. Run the query.</td>
</tr>
<tr>
<td></td>
<td>2. Press Alt+R to open the <strong>Results</strong> menu.</td>
</tr>
<tr>
<td></td>
<td>3. Select <strong>Export</strong> to open the Export Query Results wizard.</td>
</tr>
<tr>
<td></td>
<td>4. Use the <strong>TAB</strong> key to move through controls. Use arrow keys to</td>
</tr>
<tr>
<td></td>
<td>move through selection items in the control. Select <strong>CSV</strong></td>
</tr>
<tr>
<td></td>
<td>from the <strong>Export Type</strong> list. Specify where to save the file in the</td>
</tr>
<tr>
<td></td>
<td><strong>File name</strong> field.</td>
</tr>
<tr>
<td></td>
<td>5. Press <strong>Finish</strong>.</td>
</tr>
<tr>
<td></td>
<td>6. Open the *.csv file in supportive software such as Microsoft Excel.</td>
</tr>
<tr>
<td>Add object or condition</td>
<td>Use <strong>TAB</strong> to switch between different sections of the <strong>Query Builder</strong></td>
</tr>
<tr>
<td></td>
<td>editor, and then press <strong>Spacebar</strong> to expand the sections.</td>
</tr>
<tr>
<td>Select multiple objects</td>
<td>1. Tab to the list box.</td>
</tr>
<tr>
<td></td>
<td>2. Press Shift+<strong>Arrow</strong> to select additional, consecutive rows.</td>
</tr>
<tr>
<td></td>
<td>3. Press Shift+<strong>Enter</strong> to add the objects.</td>
</tr>
<tr>
<td>Edit rows in list boxes (only for rows that can be edited)</td>
<td>1. <strong>TAB</strong> to the list box, such as the Global Variables window.</td>
</tr>
<tr>
<td></td>
<td>2. Press the spacebar or use the up and down arrow keys to select the</td>
</tr>
<tr>
<td></td>
<td>row.</td>
</tr>
<tr>
<td></td>
<td>3. Press <strong>F2</strong> to activate edit mode.</td>
</tr>
<tr>
<td></td>
<td>4. Use <strong>TAB</strong> to move between columns and rows.</td>
</tr>
<tr>
<td></td>
<td>5. Press <strong>Enter</strong> to accept edits.</td>
</tr>
<tr>
<td></td>
<td>6. Press <strong>TAB</strong> to exit the list box and move to the next control in</td>
</tr>
<tr>
<td></td>
<td>the dialog.</td>
</tr>
</tbody>
</table>
## Navigation in QMF for WebSphere

The following table shows how to accomplish various tasks using keystrokes.

<table>
<thead>
<tr>
<th>To:</th>
<th>Process:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit query results</strong></td>
<td>1. Press CTRL+F7 or CTRL+SHIFT+F7 until either the</td>
</tr>
<tr>
<td></td>
<td>Workspaces or Repository Explorer view is highlighted.</td>
</tr>
<tr>
<td></td>
<td>2. Use the down or up arrow keys to select the folder that</td>
</tr>
<tr>
<td></td>
<td>contains a table.</td>
</tr>
<tr>
<td></td>
<td>3. Use the right arrow key to expand folders and the left arrow</td>
</tr>
<tr>
<td></td>
<td>key to collapse folders.</td>
</tr>
<tr>
<td></td>
<td>4. Use the arrow keys to expose and select the table that you</td>
</tr>
<tr>
<td></td>
<td>want to edit.</td>
</tr>
<tr>
<td></td>
<td>5. Press the Menu key (the key to the left of the right-side of</td>
</tr>
<tr>
<td></td>
<td>the CTRL key).</td>
</tr>
<tr>
<td></td>
<td>6. Press the mnemonic key for Open With (the h key).</td>
</tr>
<tr>
<td></td>
<td>7. Use the down arrow key to highlight Table Editor.</td>
</tr>
<tr>
<td></td>
<td>8. Press the ENTER key. The table opens in Table Editor.</td>
</tr>
<tr>
<td><strong>Change font for query</strong></td>
<td>1. Run the query.</td>
</tr>
<tr>
<td><strong>results</strong></td>
<td>2. Press Alt+A to select all.</td>
</tr>
<tr>
<td></td>
<td>3. Press Alt+R to open the Results menu.</td>
</tr>
<tr>
<td></td>
<td>4. Press F to open the Font window.</td>
</tr>
</tbody>
</table>

### Tables

<table>
<thead>
<tr>
<th>To:</th>
<th>Process:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move focus through each</td>
<td>Press TAB to move forward or SHIFT+TAB to move in the opposite direction.</td>
</tr>
<tr>
<td>element</td>
<td></td>
</tr>
<tr>
<td>Emulate clicks on a link</td>
<td>Use the TAB key to jump from link to link, then press the Enter key to</td>
</tr>
<tr>
<td></td>
<td>open the link.</td>
</tr>
<tr>
<td>Emulate clicks on a button</td>
<td>Use the TAB key to jump from button to button, then press Space key to</td>
</tr>
<tr>
<td></td>
<td>activate the button.</td>
</tr>
<tr>
<td>Within a dialog, activate</td>
<td>Press the Enter key.</td>
</tr>
<tr>
<td>the default action</td>
<td></td>
</tr>
<tr>
<td>Within a dialog, cancel the</td>
<td>Press the ESC key.</td>
</tr>
<tr>
<td>action</td>
<td></td>
</tr>
<tr>
<td>Move focus to the command</td>
<td>Press ALT+C.</td>
</tr>
<tr>
<td>line</td>
<td></td>
</tr>
<tr>
<td>Move focus to the main</td>
<td>Press the left ALT key. Navigate through the menu commands using the</td>
</tr>
<tr>
<td>menu</td>
<td>arrow keys.</td>
</tr>
<tr>
<td>Open context menus</td>
<td>Press the pop-up menu key if you have an extended keyboard. Press the</td>
</tr>
<tr>
<td></td>
<td>right Ctrl key. Navigate through the menu commands using the arrow keys.</td>
</tr>
<tr>
<td>Activate top-level menu</td>
<td>Press Shift+Ctrl+1 (Shift+Ctrl+2, Shift+Ctrl+3, and so on)</td>
</tr>
<tr>
<td>Switch between open editors</td>
<td>Press Shift+Ctrl+F6</td>
</tr>
<tr>
<td>Switch between open views</td>
<td>Press Shift+Ctrl+F7</td>
</tr>
</tbody>
</table>
Appendix B. Customizing QMF objects

This topic gives examples of the SQL that is used to create the QMF objects. It also describes some modifications that you might make to the SQL.

Sample generated SQL

This example shows the SQL that can be generated to create required database objects; this SQL is proposed and it can be modified.

You can edit the SQL. For example:

CREATE NODEGROUP RDBING1 ON NODE (0);
CREATE NODEGROUP RDBING2 ON NODE (0);
CREATE REGULAR TABLESPACE RDBITSSC
    IN NODEGROUP RDBING1
    MANAGED BY SYSTEM USING('RDBITSSC');
CREATE TABLE RDBI.AUTHID_TABLE
    ( PRIMARY_ID CHAR(8) NOT NULL,
      SECONDARY_ID CHAR(8) NOT NULL
    )
    IN RDBITSSC
    PARTITIONING KEY (SECONDARY_ID) USING HASHING
    ;
COMMENT ON TABLE RDBI.AUTHID_TABLE
    IS 'Secondary authorization ID table FOR RDBI';

Listing physical and logical files for iSeries

You can list physical and logical files for iSeries from the Create Objects.

Follow these steps to list iSeries physical and logical files:
1. On the Create Objects page, scroll down to the following statement:
   CREATE VIEW RDBI.TABLE_VIEW2
2. In the 'CREATE' statement, modify the "WHERE" clause by adding a 'P' for physical files and an 'L' for logical files. For example:
   WHERE A.TABLE_TYPE IN ('T','V','P','L')
3. Click OK to create the object.

Granting EXECUTE privilege for iSeries

You can use the built-in stored procedure QSYS.QCMDEXC() to grant the EXECUTE privilege for iSeries libraries.

If the built-in stored procedure QSYS.QCMDEXC() is registered on the target server, QMF finds it at runtime and invokes it either explicitly when QMF generates SQL DDL scripts during installation, or implicitly when binding static packages or creating stored procedures depending upon the selected protection method, stored procedures or static SQL packages.
If the built-in stored procedure `QSYS.QCMDEXC()` is not registered on the target server, then QMF does not invoke it at all. However, the libraries RSBI, Q, RDBI, and the library where QMF stored procedures or static SQL packages are created may not be granted the proper privileges. In this case, the database administrator must perform the following grant privilege operations for iSeries libraries:

- `GRTOBJ[AUT OBJ(RSBI) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE)];`
- `GRTOBJ[AUT OBJ(Q) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE)];`
- `GRTOBJ[AUT OBJ(RDBI) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE)];`
- `GRTOBJ[AUT OBJ(QFWPKG) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE)];`

where QFWPKG is the library of QMF stored procedures or static SQL packages.

**Object views**

Object views determine how lists are built.

The following views are created when objects are created:

- `RDBTABLE_VIEW`
- `Q.RAA_OBJECT_VIEW`

You can alter these views when you install QMF to tailor the list building. These views differ based on the DB2 platform.

Lists for the extended catalog are built by the views that are created when you select the Create Objects option. For queries, forms, and procedures, the view `Q.RAA_OBJECT_VIEW_X` is the key and it interacts with other views and tables.

**Q.RAA_OBJ_DIR_X**

Look at the catalog_ids and owner names in Q.RAA_OBJ_DIR_X and display or fail to display each object based on the conditions below.

"Yes" to any of the following questions causes the query, procedure or form to be displayed in the list:

1. Does the object owner match the current user ID?
2. Does the object owner match the current SQLID?
3. Does the object owner match the secondary authorization ID of the current user ID having the same catalog ID?
4. Is the object SHARED? (Restricted = N)
5. Is the user a SYSADM having the same catalog_ID?

**RDBI.USER_ADMIN_VIEW_X**

This view determines whether the user or a secondary authorization ID of the user is a SYSADM.

It checks RDBI.ADMIN_VIEW and RDBI.CATALOG_DIR_X for:

- The current user ID or SQLID
- Secondary authorization ID of the current user having the same catalog ID in RDBI.CATALOG_DIR_X
RDBLUSER.USER_AUTHID_VIEW_X

This view retrieves all rows from the base table RDBI.AUTHID_VIEW_X, where the primary ID is that of the current user. It will list all secondary authorization IDs for the current user.

RDBLADMIN_VIEW

This view obtains a list of GRANTEEes from the base table SYSIBM.SYSUSERAUTH. It takes GRANTEEes who have been granted G or Y for SYSADMAUTH.

RDBI.CATALOG_DIR_X

This table contains all rows of internal identifier of the distinct catalog and name of the distinct catalog.

RDBI.AUTHID_VIEW_X

This table copies all rows from the base table RDBI.AUTHID_TABLE_X.

SYSIBM.SYSUSERAUTH

This table contains the SYSUSERAUTH information.

RDBI_AUTH_TABLE_X

A base table listing primary and secondary authorization IDs. This table must be populated by the system or database administrator. QMF for Workstation does not have access to the preexisting RACF/DB2 relationships during or after installation, unless they are stored in a custom DB2 table of the administrator's design.

Q.RAA_OBJECT_VIEW_X

For queries, forms, and procedures, the view Q.RAA_OBJECT_VIEW_X is the key and it interacts with the other views and tables, as shown below.

Note: This view is for the Object Listing Option:

''Include only those objects that any of the user's primary or secondary authorization IDs are authorized to access. This option requires the most database resources when producing lists.''

The following SQL statements create this view:

CREATE VIEW Q.RAA_OBJECT_VIEW_X

( CATALOG_ID,  
  OWNER, NAME, TYPE, SUBTYPE, OBJECTLEVEL, RESTRICTED, MODEL,  
  REMARKS  
  DELETED_BY_USER, DELETED_BY_SQLID, DELETED_TIMESTAMP  
) AS  
SELECT A.CATALOG_ID,  
  A.OWNER, A.NAME, A.TYPE, A.SUBTYPE,  
  A.OBJECTLEVEL, A.RESTRICTED, A.MODEL,  
  B.REMARKS,  
  A.DELETED_BY_USER, A.DELETED_BY_SQLID, A.DELETED_TIMESTAMP  
FROM Q.RAA_OBJ_DIR_X A, Q.RAA_OBJ_REM_X B  
WHERE (A.CATALOG_ID = B.CATALOG_ID AND  
  A.OWNER = B.OWNER AND  
  A.NAME = B.NAME AND  
  A.DELETED_TIMESTAMP IS NULL AND B.DELETED_TIMESTAMP IS NULL)  
  AND (A.RESTRICTED = 'N'  
    OR A.OWNER IN (USER, CURRENT SQLID)  
)
OR A.OWNER IN (SELECT C.SECONDARY_ID
   FROM RDBI_USER_AUTHID_VIEW_X C
   WHERE C.CATALOG_ID = A.CATALOG_ID)
OR EXISTS (SELECT D.AUTHID
            FROM RDBI.USER_ADMIN_VIEW_X D
            WHERE D.CATALOG_ID = A.CATALOG_ID))

RDBI.USER_ADMIN_VIEW_X
These SQL statements create the RDBI.USER_ADMIN_VIEW_X table.
CREATE VIEW RDBI.USER_ADMIN_VIEW_X
(  CATALOG_ID,
  "AUTHID"
) AS
SELECT B.ID, A."AUTHID"
FROM RDBI.ADMIN_VIEW A., RDBI.CATALOG_DIR_X B
WHERE A."AUTHID" IN (USER, CURRENT SQLID)
  OR A."AUTHID" IN (SELECT C.SECONDARY_ID
                      FROM RDBI.USER_AUTHID_VIEW_X C
                      WHERE B.ID = C.CATALOG_ID)

RDBI.USER_AUTHID_VIEW_X
These SQL statements create the RDBI.USER_AUTHID_VIEW_X table.
CREATE VIEW RDBI.USER_AUTHID_VIEW_X
(  CATALOG_ID,
  PRIMARY_ID,
  SECONDARY_ID
) AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_VIEW_X A
WHERE A.PRIMARY_ID = USER

RDBI.ADMIN_VIEW
These SQL statements create the RDBI.ADMIN_VIEW table.
CREATE VIEW RDBI.ADMIN_VIEW
(  "AUTHID"
) AS
SELECT A.GRANTEE
FROM SYSIBM.SYSUSERAUTH A
WHERE A.SYSADMAUTH IN ('Y', 'G')

RDBI.CATALOG_DIR_X
These SQL statements create the RDBI.CATALOG_DIR_X table.
CREATE TABLE RDBI.CATALOG_DIR_X
(   ID SMALLINT NOT NULL
   NAME VARCHAR (128) NOT NULL
) IN RDBIDB.X.RDBITSX1
   CCSID EBCDIC

RDBI.AUTHID_VIEW_X
These SQL statements create the RDBI.AUTHID_VIEW_X table.
CREATE VIEW RDBI.AUTHID_VIEW_X
(
  CATALOG_ID,
  PRIMARY_ID,
  SECONDARY_ID
);

AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_TABLE_X A

RDBI.AUTHID_TABLE_X

These SQL statements create the RDBI.AUTHID_TABLE_X table.

CREATE TABLE RDBI.AUTHID_TABLE_X
(
  CATALOG_ID SMALL INIT NOT NULL,
  PRIMARY_ID CHAR (8) NOT NULL,
  SECONDARY_ID CHAR (8) NOT NULL
)
IN RDBIDBX.RDBITSX
CCSID EBCDIC

Note: This table must be populated by the system or database administrator. QMF for Workstation does not have access to the pre-existing RACF/DB2 relationships during or after installation.

For other tables, the view RDBI.TABLE_VIEW2_X is the key and interacts with the other views and tables, as shown below.

RDBI.TABLE_VIEW2_X

RDBI.TABLE_VIEW2_X constructs a list of tables. First, it checks for tables listed in the base table SYSIBM.SYSTABAUTH. All tables in SYSIBM.SYSTABAUTH have, by definition, already had some type of authority granted to at least one user.

SYSIBM.SYSTABAUTH must answer "Yes" to one of the following questions:
1. Is the GRANTEE = the current user?
2. Is the GRANTEE = the current SQLID?
3. Is the GRANTEE = PUBLIC?
4. Is the GRANTEE = PUBLIC*?
5. Is the GRANTEE = a secondary authorization ID of the current USER having the same catalog_ID?
6. Is the user a SYSADM having the same catalog_ID?

The table must have one of the following GRANTEE types:
- U
- G

The GRANTEE of the table must have Y or G authority on one of the following four categories:
- DELETEAUTH
- INSERTAUTH
- SELECTAUTH
- UPDATEAUTH
RDBI.USER_ADMIN_VIEW_X
This view determines whether the user or a secondary user ID of the user is a SYSADM.

It checks the RDBI.ADMIN_VIEW and RDBI.CATALOG_DIR_X for:
• The current user ID
• Secondary user ID of the current user having the same catalog ID

RDBI.USER_AUTHID_VIEW_X
This view retrieves all rows from the base table RDBI.AUTHID_VIEW_X where the primary ID is that of the current user. It will list all secondary authorization IDs for the current user.

RDBI.ADMIN_VIEW
This view retrieves a list of GRANTEEs from the base table SYSIBM.SYSUSERAUTH. It takes GRANTEEs who have been granted G or Y for SYSADMAUTH.

Note: If you are setting up under an iSeries database, the RDBI.ADMIN_VIEW refers to the RDBI.ADMIN_TABLE.

RDBI.AUTHID_VIEW_X
This view copies all rows from the base table RDBI.AUTHID_TABLE_X.

RDBI.AUTHID_TABLE_X
A base table listing catalogued, and primary and secondary authorization IDs.

Note: This table must be populated by the system or database administrator. QMF for Workstation does not have access to the pre-existing RACF/DB2 relationships during or after installation, unless they are stored in a custom DB2 table of the administrator's design.

Also, for tables, the view RDBI.TABLE_VIEW2_X is the key and interacts with the other views and tables, as shown below.

RDBI.ADMIN_TABLE
A base table used exclusively by iSeries databases that lists user IDs with administrative privileges.

Note: This table must be populated by the system or database administrator. This table takes the place of the base RDBI.AUTHID_TABLE for DB2 databases.

Also, for tables, the view RDBI.USER_ADMIN_VIEW and RDBI.USER_ADMIN_VIEW_X are the keys and interact with the other views and tables, as shown below.

RDBI.USER_ADMIN_VIEW_X
The following SQL statements create the RDBI.USER_ADMIN_VIEW_X table.
CREATE VIEW RDBI.USER_ADMIN_VIEW_X
(CATALOG_ID,
"AUTHID"

AS
SELECT B.ID, A."AUTHID"
FROM RDBI.ADMIN_VIEW A, RDBI.CATALOG_DIR_X B
WHERE A."AUTHID" IN (USER, CURRENT SQLID)
  OR A."AUTHID" IN (SELECT C.SECONDARY_ID
                      FROM RDBI.USER_AUTHID_VIEW_X C
                      WHERE B.ID = C.CATALOG_ID)

RDBI.USER_AUTHID_VIEW_X
These SQL statements create the RDBI.USER_AUTHID_VIEW_X table.
CREATE VIEW RDBI.USER_AUTHID_VIEW_X
(
    CATALOG_ID,
    PRIMARY_ID,
    SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_VIEW_X A
WHERE A.PRIMARY_ID = USER

RDBL.ADMIN_VIEW
These SQL statements create the RDBL.ADMIN_VIEW table.
CREATE VIEW RDBL.ADMIN_VIEW
(
    "AUTHID"
)
AS
SELECT A.GRANTEE
FROM SYSIBM.SYSUSERAUTH A
WHERE A.SYSADMAUTH IN('Y', 'G')

RDBI.AUTHID_VIEW_X
These SQL statements create the RDBI.AUTHID_VIEW_X table.
CREATE VIEW RDBI.AUTHID_VIEW_X
(
    CATALOG_ID,
    PRIMARY_ID,
    SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_TABLE_X A

RDBI.AUTHID_TABLE_X
These SQL statements create the RDBI.AUTHID_TABLE_X table.
CREATE TABLE RDBI.AUTHID_TABLE_X
(
    CATALOG_ID SMALLINT NOT NULL,
    PRIMARY_ID CHAR (8) NOT NULL,
    SECONDARY_ID CHAR (8) NOT NULL
)
IN RDBIDBX.RDBITSX2
CCSID EBCDIC

Note: This table must be populated by the system or the database administrator.
QMF for Workstation does not have access to the pre-existing RACF/DB2
relationships during or after installation.
RDBI.ADMIN_TABLE

These SQL statements create the RDBI.ADMIN_TABLE table for iSeries support.

QMF long name catalog support:
CREATE TABLE "RDBI"."ADMIN_TABLE"
{
   "AUTHID" VARCHAR(128) NOT NULL
} ;
COMMENT ON TABLE "RDBI"."ADMIN_TABLE"
   IS 'Administrator authorization ID table for RDBI';
COMMENT ON COLUMN "RDBI"."ADMIN_TABLE"."AUTHID"
   IS 'Authorization ID (user ID)';

QMF short name catalog support: The only difference is that VARCHAR(128) changes to VARCHAR(8):
CREATE TABLE "RDBI"."ADMIN_TABLE"
{
   "AUTHID" VARCHAR(8) NOT NULL
} ;
COMMENT ON TABLE "RDBI"."ADMIN_TABLE"
   IS 'Administrator authorization ID table for RDBI';
COMMENT ON COLUMN "RDBI"."ADMIN_TABLE"."AUTHID"
   IS 'Authorization ID (user ID)';

Note: This table must be populated by the iSeries system or database administrator.
Appendix C. Troubleshooting

Use these topics to diagnose and correct problems that you experience with QMF.

QMF for Workstation Win32 API reverts to previous version of QMF for Windows

Symptoms
If an earlier version of QMF for Windows that is installed alongside QMF for Workstation Version 12 is opened, API instances automatically revert to QMF for Windows, even after Version 12 has been reopened.

Causes
When QMF for Workstation Version 12 is installed, the application version number is updated in the system registry. When a preexisting version of QMF for Windows is opened, it automatically reverts the application’s version number in the system registry. When Version 12 is opened, this automatic rename does not take place.

Resolving the problem
Any time that the QMF for Windows application is opened, you must manually reset the version number in the system registry if you want API instances to point to QMF for Workstation Version 12.

User response: To reset the application version number in the system registry:
1. Go to the following location in your workstation directory:
   "C:\Program Files\IBM\DB2 Query Management Facility\API"
2. Double-click the file named qmfwin.exe

Note: Win32 API uses active repository connections. If there is not an active repository connection, the system brings up a dialog box that lists all available connections where you must select the connection you want to use.
Appendix D. Messages

This topic lists and describes the messages and return codes issued by the program components of QMF for Workstation and QMF for WebSphere.

QMF for Workstation and QMF for WebSphere messages are numbered as follows:

\textit{CPTprefixMESSnumber}

\textit{CPTprefix}

The abbreviation of the component of the application that threw the error. This can be an indication of the first place to look in order to resolve the error.

\textit{MESSnumber}

The specific number of the error message.

For example: \textit{ABC0001}

All of the error messages of each component are listed in alphabetical order. To look up more information about a specific error message and how to resolve it, search for the component prefix and number of the message in this publication.

\textbf{Note:} Since QMF supports DB2 databases, DB2 error messages are included in the application. DB2 error messages have a component prefix of DB2. (for example, DB20001) If you encounter a message with this component prefix, refer to the DB2 online documentation at \url{www.ibm.com}. If you are using the DB2 Type 4 UDB driver or the DB2 Universal JDBC Driver, to receive extended SQL exception error messages, check the \texttt{retrieveMessagesFromServerOnGetMessage} option in the Advanced JDBC Settings window of the Edit Repository Connection wizard.

\begin{tabular}{ll}
\textsc{API1001} & {0} \\
\textbf{Explanation:} & This is a container for other messages. \\
\textbf{User response:} & No action is required. \\
\hline
\textsc{API1002} & The API has not been initialized. \\
\textbf{Explanation:} & The API instance has not been initialized. This could mean that the QMFwin API was not initialized, or a repository connection was not established. \\
\textbf{User response:} & Check the QMFwin API logs to determine the error that caused the API instance to fail, or establish a repository connection. \\
\hline
\textsc{API1003} & No data found. \\
\textbf{Explanation:} & There was an attempt to obtain a row that does not exist in a result set. \\
\textbf{User response:} & No action required. \\
\hline
\textsc{API1006} & The specified source {0} is not valid. \\
\textbf{Explanation:} & An invalid value was specified for the SourceType parameter of an initializeProc() or initializeQuery() function. \\
\textbf{User response:} & Specify a valid value for the SourceType parameter of any initializeProc() or initializeQuery() function. \\
\hline
\textsc{API1007} & The specified source name is not valid. \\
\textbf{Explanation:} & An invalid value was specified for the Source, CollectionName, PackageName, or ConsistencyToken parameter of an initializeProc(), initializeQuery(), or initializeStaticQuery() function. \\
\textbf{User response:} & Specify a valid value for the Source, CollectionName, PackageName, or ConsistencyToken parameter of any initializeProc(), initializeQuery(), or initializeStaticQuery() function. \\
\hline
\textsc{API1008} & The specified database server {0} is not valid. \\
\textbf{Explanation:} & An unknown data source alias was specified in a getServerAttributes(), getServerType() or initializeServer() function. \\
\end{tabular}
<table>
<thead>
<tr>
<th>API1009</th>
<th>No database server has been specified.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The initializeServer() function was not invoked before other functions were invoked that require an initialized data source.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that the initializeServer() function is invoked before other data source dependent functions are called.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1010</th>
<th>The specified row limit (0) is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the RowLimit parameter of an open() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a positive value for the RowLimit parameter of any open() function.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1011</th>
<th>The specified query ID (0) is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the QueryID parameter of an API function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the QueryID parameter of all relevant functions.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1012</th>
<th>The SQL verb (0) cannot be used with open().</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An open() function was called for a query that does not contain the SELECT, VALUES, WITH, or CALL SQL verbs.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any open() function calls a query that contains one of the SQL verbs that was mentioned above.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1013</th>
<th>The SQL verb (0) cannot be used with execute().</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An execute() function was called for a query that contains the SELECT, VALUES, WITH, or CALL SQL verbs.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any execute() function does not call a query that contains one of the SQL verbs that was mentioned above.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1015</th>
<th>A new procedure could not be created. There may be too many documents already open, or there may be insufficient memory.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unexpected error occurred while creating a procedure using the initializeProc() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check the QMFwin API logs to find the root error.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1016</th>
<th>A new query could not be created. There may be too many documents already open, or there may be insufficient memory.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unexpected error occurred while creating a query using the initializeQuery() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check the QMFwin API logs to find the root error.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1024</th>
<th>The specified column delimiter (0) is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the ColumnDelimiter parameter of an export() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the ColumnDelimiter parameter of any export() function.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1026</th>
<th>The specified file name is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid or empty value was specified for the FileName parameter of an export() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the FileName parameter of any export() function.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1027</th>
<th>The specified format (0) is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the Format parameter of an export() function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the Format parameter of any export() function.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1028</th>
<th>The specified form name is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid or empty value was specified for the Form parameter of a report related function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the Form parameter of any report related functions.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1029</th>
<th>The specified form source (0) is not valid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the SourceType parameter of a report related function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the SourceType parameter of any report related function.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>API1030</th>
<th>The global variable name is invalid.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was specified for the GlobalVariableName parameter of a global variables related function.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid value for the GlobalVariableName parameter of any global variables related function.</td>
</tr>
</tbody>
</table>
API1031  The specified host variable is not valid.
Explanation: An invalid value was specified for the Value parameter of a setHostVariable() function.
User response: Specify a valid value for the Value parameter of any setHostVariable() function.

API1033  The specified owner and name (0) are not valid.
Explanation: An invalid value was specified for the OwnerAndName parameter of an API function.
User response: Specify a valid value for the OwnerAndName parameter of any relevant API function.

API1034  The specified page length (0) is not valid.
Explanation: An invalid value was specified for the PageLength parameter of an exportReport() or exportVisualReport() function.

API1035  The specified page width (0) is not valid.
Explanation: An invalid value was specified for the PageWidth parameter of an exportReport() or exportVisualReport() function.

API1037  The specified procedure ID (0) is not valid.
Explanation: An invalid value was specified for the ProcID parameter or a procedure related function.
User response: Specify a valid value for the ProcID parameter of any procedure related functions.

API1038  The specified resource (0) is not valid.
Explanation: An invalid value was specified for the Resource parameter of a getResourceLimit() function.

API1039  The specified range of rows and columns is not valid.
Explanation: Invalid values were specified for the FirstRow, FirstCol, LastRow, and LastCol parameters of an exporting result set function.

User response: Specify valid values for the FirstRow, FirstCol, LastRow, and LastCol parameters of any exporting result set function.

API1040  The specified string delimiter (0) is not valid.
Explanation: An invalid value was specified for the StringDelimiter parameter of an export() function.
User response: Specify a valid value for the StringDelimiter parameter of any export() function.

API1041  The specified table name is not valid.
Explanation: An invalid value was specified for the TableName parameter of an export() function.
User response: Specify a valid value for the TableName parameter of any export() function.

API1042  The specified target server is invalid.
Explanation: An invalid value was specified for the Server parameter of a saveData() or copyQMFOBJECT() function.
User response: Specify a valid value for the Server parameter of any saveData() or copyQMFOBJECT() function.

API1044  The specified time (0) is not valid.
Explanation: An invalid value was specified for the Time parameter of a getQMFOBJECTINFO() function.
User response: Specify a valid value for the Time parameter of any getQMFOBJECTINFO() function.

API1045  The specified type (0) is not valid.
Explanation: An invalid value was specified for the Type parameter of a getQMFOBJECTINFO() function.
User response: Specify a valid value for the Type parameter of any getQMFOBJECTINFO() function.

API1046  The specified variable (0) is not valid.
Explanation: An invalid value was specified for the VariableName parameter of a setVariable() function.
User response: Specify a valid value for the VariableName parameter of any setVariable() function.

API1053  The SQL verb (0) cannot be used with ExecuteStoredProcedure() function.
Explanation: A query that does not contain the CALL SQL verb was specified for an executeStoredProcedure() function.
User response: Specify a CALL query for any executeStoredProcedure() function.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>API1054</td>
<td>Can't prepare a static section.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> A static query was specified for a prepare() function; only dynamic queries can be specified.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Specify a dynamic query for any prepare() function.</td>
</tr>
<tr>
<td>API10004</td>
<td>The values specified for ForceDialog and SuppressDialog are mutually exclusive.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The initializeServer() function was called and the values that were specified for ForceDialog and SuppressDialog parameters were mutually exclusive.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Check the code that invokes the initializeServer() function.</td>
</tr>
<tr>
<td>BIC00000</td>
<td>Internal Error</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> There was an internal error.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>BIC00001</td>
<td>Illegal Argument</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The specified argument is not valid.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>BIC00002</td>
<td>Null Pointer</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> A null pointer exception occurred.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>BIC00004</td>
<td>{0}</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The specified exception occurred.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Correct the specified exception and try again.</td>
</tr>
<tr>
<td>BIC00005</td>
<td>Unknown exception</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> An error occurred while retrieving a resource string.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>BIC00006</td>
<td>This feature is not supported by QMF</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The specified feature is not supported by QMF</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> No action is required.</td>
</tr>
<tr>
<td>BIC00007</td>
<td>Object is not supported by QMF</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The specified object is not supported by QMF</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> No action is required.</td>
</tr>
<tr>
<td>BIC00009</td>
<td>Fetching of children is cancelled by user.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The operation was cancelled by the user.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Retry to fetch the specified objects.</td>
</tr>
<tr>
<td>CLC00001</td>
<td>Cannot convert {0} to number.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The specified element can not be converted into a numeral.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Specify valid element to convert into a numeral.</td>
</tr>
<tr>
<td>CLC00002</td>
<td>Unable to evaluate linReg: data series have different numbers of elements.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The data series specified for the x and y variables contain different numbers of data points.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Specify data series that contain the same number of data points.</td>
</tr>
<tr>
<td>CLC00003</td>
<td>Unable to evaluate linReg: not enough data.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The data series specified do not contain enough rows to calculate the linear regression.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Specify a query result set that contains more than one row of data points.</td>
</tr>
<tr>
<td>CLC00004</td>
<td>Unable to evaluate linReg: coefficient is out of range.</td>
</tr>
<tr>
<td></td>
<td><strong>Explanation:</strong> The value that you specified for the nParam parameter of the linreg() function is invalid.</td>
</tr>
<tr>
<td></td>
<td><strong>User response:</strong> Specify either a 0 or a 1 for the nParam parameter. A 0 returns the slope of the linear regression.</td>
</tr>
</tbody>
</table>
regression. A 1 returns the intercept of the linear regression.

**CLC00005** Illegal data row range specified: from [0] to [1]

**Explanation:** The range of data rows specified for the nFirstRow and nLastRow parameters is invalid.

**User response:** Specify a valid range of data rows. The nFirstRow value must specify a row before the nLastRow value in the query result set.

**CLC00006** Unable to calculate gammaIP: domain error.

**Explanation:** Invalid arguments were specified in the gammaIP function.

**User response:** Specify a valid argument in the gammaIP function.

**CLC00009** "[0]" function is not found in Lib class, but supported in expressions.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00010** "[0]" function has wrong arguments description.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00011** Type conversion error. Object of [0] type cannot be converted to [1] type.

**Explanation:** The indicated object cannot be converted to the indicated type.

**User response:** Specify a valid object to be converted to the indicated type.

**CLC00012** Evaluation of expression failed: [0]

**Explanation:** The evaluation of the indicated expression failed.

**User response:** Specify a valid expression for evaluation.

**CLC00014** Evaluation of expression has failed.

**Explanation:** The evaluation of the specified expression has failed.

**User response:** Check the syntax of the expression for errors and try again.

**CLC00016** Cannot parse an expression: [0]

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00018** Unknown function name: [0].

**Explanation:** The indicated function name is not valid.

**User response:** Specify a valid function name.

**CLC00030** Unable to process URL: "[0]"

**Explanation:** The indicated URL is invalid.

**User response:** Specify a valid URL.

**CLC00034** "[0]" function description is missing.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00038** Multiple declarations of "[0]" library in LibraryFactory class.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00039** Multiple declarations of "[0]" library in LibraryFactory class.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00040** Cannot load "[0]" library in LibraryFactory class.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

**CLC00041** Types "[0]" and "[1]" are not acceptable for "[2]" function.

**Explanation:** The arguments that were passed to the function are of invalid types.

**User response:** Check the syntax of the expression for errors and try again.
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
</table>
| CLC00042   | Type 
"[0]" is not acceptable for 
"[1]" function. |
| CLC00043   | Information service is undefined. |
| CLC00044   | Aggregation service is undefined. |
| CLC00045   | Hierarchy service is undefined. |
| CLC00046   | Color service is undefined. |
| CLC00047   | PPI service is undefined. |
| CLC00048   | Value provider is undefined. |
| CLC00049   | Function 
"[0]" is defined for 
{1} argument(s). |
| CLC00050   | Function 
"[0]" is undefined for argument 
{1}. |
| CLC00051   | One of the operands does not have 
measurement units. |
| CLC00052   | Cannot multiply two measured values. |
| CLC00053   | Cannot create list from elements of 
"[0]" type. |
| CLC00054   | List cannot contain elements of different types. |
| CLC00055   | Types 
"[0]", 
"[1]" and 
"[2]" are not 
acceptable for 
"[3]" function. |
| CLC00056   | Argument(s) with measurement units are 
not acceptable for 
"[0]" function. |
Incorrect index given.

Explanation: An error occurred in the LineText function.

User response: Check the arguments that are specified for the LineText function for errors.

Types "{0}", "{1}", "{2}" and "{3}" are not acceptable for "{4}" function.

Explanation: The indicated function is not compatible with the given types.

User response: Check the expression syntax for errors and try again.

Calculator exception cause: {0}

Explanation: A generic error occurred.

User response: Check the syntax of the expression for errors and try again.

Value for variable "{0}" is not defined.

Explanation: The value for the indicated variable is not defined.

User response: Define the value for the indicated variable.

Function "{0}" caused error: {1}

Explanation: The indicated function caused the indicated error.

User response: Correct the indicated error and rerun the function.

Property "{0}" contains error: {1}

Explanation: The indicated property caused the indicated error.

User response: Correct the indicated error and rerun the function.

List sizes are not comparable.

Explanation: Invalid parameters with type List were specified for add, multiply, divide, or subtract functions.

User response: Specify a valid value for the List parameter of any add, multiply, divide, or subtract functions.

Cannot be evaluated for empty list.

Explanation: No value was specified for the List parameter of a function.

User response: Specify a valid value for the List parameter of any relevant function.

Function @if has odd number of parameters: @if(cond1, exp1, cond2, exp2, ..., expn). expn is used when there aren't true conditions.

Explanation: The syntax of an @if function is invalid.

User response: Check the syntax of any @if functions for errors and try again.

The feature is not supported.

Explanation: The specified feature is not supported by the database.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

No column named "{0}" was found.

Explanation: The indicated column was not found.

User response: Check the column name for errors or specify a different column name.

The current row is unsuitable for get/set operations.

Explanation: The specified row can not be retrieved or set.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

The database cursor has been closed.

Explanation: The requested operation could not be completed because the cursor is closed.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

An error occurred while accessing the file. {0}

Explanation: An input/output error occurred while accessing the file.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Character encoding {0} is not supported.

Explanation: The indicated character encoding is not supported.

User response: Use a character set that is supported by your current JVM.
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
<th>Explanation</th>
<th>User Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAL01008</td>
<td>An error occurred while accessing the database. (0)</td>
<td>An error occurred while accessing the indicated database.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>DAL01009</td>
<td>An internal error occurred. (0)</td>
<td>The indicated internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>DAL01011</td>
<td>Class [0] is not suitable for server description</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>DAL01012</td>
<td>Requested operation is not available in offline mode</td>
<td>The specified operation is not available in offline mode.</td>
<td>Specify a different operation to apply to the active object, or switch to online mode and try again.</td>
</tr>
<tr>
<td>DAL01013</td>
<td>Cannot create connection to server &quot;{0}&quot; due to the following: (1)</td>
<td>A connection to the indicated server could not be established due to the indicated error.</td>
<td>Resolve the indicated error and retry to connect to the server.</td>
</tr>
<tr>
<td>DAL01014</td>
<td>Invalid set of connection parameters used,</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>DAL01016</td>
<td>Cannot parse data (base64 encoding rules violation)</td>
<td>The XML file is corrupted.</td>
<td>Fix any errors in the XML file and try again.</td>
</tr>
<tr>
<td>DAL01017</td>
<td>Duplicate query with name &quot;{0}&quot; is detected in package &quot;{1}&quot;.</td>
<td>An internal error occurred; the indicated package contains several queries with the same specified name.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>
| DAL01018   | The source data is not compatible with the target table. | The attempt to save data in the database table failed because of the following:  
- Number of columns does not match.  
- Columns have incompatible types. | Select compatible target table and try again. |
| DAL01019   | Operation is not supported. | An internal error occurred; the requested operation can not be performed due to internal limitations. | Collect support data by selecting Help > Collect Support Data and forward it to customer support. |
| DAL01020   | Invalid SQL type definition: "{0}" | An internal error occurred; the indicated SQL type definition is invalid (it can be mapped to more than one known data types). | Collect support data by selecting Help > Collect Support Data and forward it to customer support. |
| DAL01021   | This product does not contain SQLj support module | QMF does not support or can not initialize the SQLj support module. | Collect support data by selecting Help > Collect Support Data and forward it to customer support. |
| DAL01022   | Cannot have two different driver libraries with the same driver name. | The driver with the specified driver name is already defined in another library definition. | Use (edit) the already defined driver library instead of creating a new one. |
An error has occurred while saving driver libraries list: {0}

**Explanation:** The indicated error occurred while the driver libraries list was being saved.

**User response:** Resolve the indicated error and try again.

An error has occurred while loading the driver libraries list: {0}

**Explanation:** The indicated error occurred while trying to load the driver libraries list.

**User response:** Resolve the indicated error and try again.

Operation cannot be performed due to resource limits restriction: {0}

**Explanation:** The operation could not be performed due to the indicated resource limits restriction.

**User response:** Check your current resource limits by selecting Resource Limits from the View menu. Specify an operation within your resource limits or contact your administrator for specific permissions.

User name is missing.

**Explanation:** The user name is missing from the User Information dialog name field.

**User response:** Specify a user name.

Password is missing.

**Explanation:** The password is missing from the User Information dialog.

**User response:** Specify a password.

Wrong JDBC URL: {0}.

**Explanation:** The indicated JDBC URL cannot be processed by QMF. The URL may be incorrect.

**User response:** Check the JDBC URL for errors or specify a different URL.

Query parameter [0] is of wrong Java type. Data type "[1]" is required.

**Explanation:** An internal error occurred while running the query. The query parameters have invalid types.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

The current row is unsuitable for editing.

**Explanation:** An internal error occurred; the current row cannot be edited.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

The database server does not support table renaming.

**Explanation:** Tables in this database server can not be renamed by QMF.

**User response:** No action is required.
DAL01038  The edit operation was cancelled.
Explanation:  The table editing operation was cancelled by the user.
User response:  No action is required.

DAL01039  The record could not be updated (possibly concurrent edit/delete operations).
Explanation:  The record could not be updated. This is most likely because it is locked due to a concurrent edit/delete operation.
User response:  Refresh the result set and try again.

DAL01040  The record could not be deleted (possibly concurrent edit/delete operations).
Explanation:  The record could not be deleted. This is most likely because it is locked due to a concurrent edit/delete operation.
User response:  Refresh the result set and try again.

DAL01041  The value of a calculated column is longer than specified in the metadata
Explanation:  The data could not be exported because one or more of the calculated columns in the result set contains data that is longer than what is allowed in the column's definition.
User response:  Increase the maximum column length or modify the data in the calculated column.

DAL01042  Invalid type conversion detected.
Explanation:  An internal error occurred; a type conversion in the specified operation is invalid.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

DAL01043  An attempt was made to modify a deleted record.
Explanation:  An internal error occurred; records that have already been deleted can not be modified or restored.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

DAL01044  Connection is blocked due to the following: {0}
Explanation:  The attempted connection was blocked due to the indicated error or restriction.
User response:  Depending on the indicated problem, either resolve the specified error or contact your administrator to remove the restriction.

DAL01046  This product does not contain static mode support module for selected database.
Explanation:  This product does not contain static mode support module for selected database.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

DAL01048  Driver class name "[0]" is not loaded. This may be caused by an incorrect driver class name or missing JDBC driver libraries.
Explanation:  The indicated driver class name can not be loaded. This may be caused by an incorrect driver class name or missing JDBC driver libraries.
User response:  Check that there is a proper definition for the JDBC driver library that refers to the indicated driver class.

DAL01049  Selected protection mode is not supported by database.
Explanation:  The selected protection mode is not supported by the specified database.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

DAL01050  Driver specific functionality is not available due to: {0}
Explanation:  Driver specific functionality is not available due to the indicated error.
User response:  Resolve the indicated error and retry. Verify that the JDBC driver library for the driver is properly configured and that it contains all of the necessary JAR files. If the problem persists, collect support data by selecting Help > Collect Support Data and forward it to customer support.

DAL01020  Generic data access error has occurred. {0}
Explanation:  An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error
conditions depending on product versions.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

<table>
<thead>
<tr>
<th>DAL01201</th>
<th>Generic data access error has occurred. {0}, {1}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01202</th>
<th>Generic data access error has occurred. {0}, {1}, {2}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01203</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01204</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}, {4}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01205</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}, {4}, {5}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01206</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01207</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DAL01208</th>
<th>Generic data access error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An error with no textual description occurred. Additional information may follow the message. This error code may refer to different error conditions depending on product versions.</td>
</tr>
<tr>
<td>User response:</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DDM0001</th>
<th>Unexpected error occurred.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An internal error in the driver code was detected.</td>
</tr>
<tr>
<td>User response:</td>
<td>Send an error report to the developers.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DDM0002</th>
<th>Object {0} have no fields with codepoint {1}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>An internal error in the driver code was detected.</td>
</tr>
<tr>
<td>User response:</td>
<td>Send an error report to the developers.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DDM0003</th>
<th>Socket open exception. {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explanation:</td>
<td>Unable to establish TCP/IP connection.</td>
</tr>
<tr>
<td>User response:</td>
<td>Check the host and port details in the JDBC URL; ping the server to check that the network connection works.</td>
</tr>
</tbody>
</table>
DDM0004  •  DDM0019

DDM0004  •  Socket write exception. {0}
Explanation: There was a network connection failure or an internal error in the driver code was detected.
User response: Check you network connection. If the connection works fine, send an error report to the developers.

DDM0005  •  Data format exception detected.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0006  •  Invalid JDBC URL {0}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0007  •  DSS header format error detected.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0008  •  Unsupported CCSID {0}
Explanation: An internal error was detected in the driver code.
User response: Send an error report to the developers.

DDM0009  •  Cipher error {0}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0010  •  Object {0} does not contain required field {1}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0011  •  Object {0} does not support value {1}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0012  •  Syntax error detected: {0}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0013  •  Syntax error detected: {0}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0014  •  Object {0} can hold no more repeated fields {1}
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DDM0015  •  Illegal port number value: {0}
Explanation: The JDBC URL contains an invalid value in the Port field.
User response: Specify a correct port number in the JDBC URL.

DDM0016  •  {0} is invalid length for the field {1} of object {2}
Explanation: An internal error was detected in the driver code.
User response: Send an error report to the developers.

DDM0017  •  Unknown FD:OCA descriptor type id {0}
Explanation: An internal error was detected in the driver code.
User response: Send an error report to the developers.

DDM0018  •  Null value for non nullable data detected.
Explanation: An internal error was detected in the driver code.
User response: Send an error report to the developers.

DDM0019  •  Whole number of FD:OCA {0} triplet repeating groups cannot be placed in {1} bytes
Explanation: An internal error was detected in the driver code.
User response: Send an error report to the developers.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>DDM0020</td>
<td>Illegal CPT triplet detected.</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0021</td>
<td>Illegal duplicated field ([1]) in object ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0022</td>
<td>Referenced FD:OCA triplet ([0]) not found</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0023</td>
<td>FD:OCA ([0]) triplets cannot be referenced from RLO triplet</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0024</td>
<td>Replication factor ([0]) is detected in RLO triplet while only 1 and 0 is allowed by DRDA</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0025</td>
<td>FD:OCA ([0]) triplets cannot be referenced from GDA triplet</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0026</td>
<td>Unknown DRDA type ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0027</td>
<td>Infinite element count is not allowed for RLO handler of ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0028</td>
<td>An error occurred while parsing triplet handler for DRDA type ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0029</td>
<td>Unspecified value for JDBC statement variable ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0030</td>
<td>Illegal type conversion.</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0031</td>
<td>Illegal date or time format detected: ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0032</td>
<td>Prepared statement parameter type ([0]) (from java.sql.Type set) is not supported.</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0033</td>
<td>Unknown DB2 type ([0])</td>
<td>An internal error was detected in the driver code.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0034</td>
<td>Statement is closed.</td>
<td>An attempt to work with a closed Statement object was detected.</td>
<td>Fix your program code.</td>
</tr>
<tr>
<td>DDM0035</td>
<td>ResultSet is closed.</td>
<td>An attempt to work with a closed ResultSet object was detected.</td>
<td>Fix your program code.</td>
</tr>
<tr>
<td>Code</td>
<td>Description</td>
<td>Explanation</td>
<td>User response</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>DDM0037</td>
<td>Object is closed.</td>
<td>An attempt to work with a closed object was detected.</td>
<td>Fix your program code.</td>
</tr>
<tr>
<td>DDM0038</td>
<td>Operation cannot be performed in current ResultSet state.</td>
<td>An attempt to work with a ResultSet column of a result set that is not positioned on any valid record was detected.</td>
<td>Fix your program code.</td>
</tr>
<tr>
<td>DDM0039</td>
<td>Error reply is received.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0040</td>
<td>Error reply is received for [0] command.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DDM0041</td>
<td>Error detected while processing [0] object.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DRL00001</td>
<td>The maximum number of connections to the server has been reached.</td>
<td>The maximum number of connections to the server has been reached.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0003</td>
<td>An array description is required, and this is not one (too many or too few Row Lay Out (RLO) triplets).</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0004</td>
<td>A row description is required, and this is not one (too many or too few RLO triplets).</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0005</td>
<td>晚的环境描述符收到，不支持。</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0006</td>
<td>Malformed triplet; required parameter is missing.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0007</td>
<td>Parameter value is not acceptable.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0008</td>
<td>Meta-Data Descriptor (MDD) present is not recognized as a Structured Query Language (SQL) descriptor.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0017</td>
<td>FD:OCA triplet is not used in DRDA descriptors, or the type code is invalid.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0018</td>
<td>FD:OCA triplet sequence error.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>DSCERRCD0019</td>
<td>FD:OCA triplet sequence error.</td>
<td>An internal error in the driver code was detected.</td>
<td>Send an error report to the developers.</td>
</tr>
</tbody>
</table>
User response: Send an error report to the developers.

DSCERRCD0033  Representation is incompatible with SQL type (in prior MDD).
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0034  CCSID is not supported.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0050  Group Data Array (GDA) references a local identifier (LID) which is not a Scalar Data Array (SDA) or GDA.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0051  GDA length override exceeds limits.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0052  GDA precision exceeds limits.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0053  GDA scale greater than precision or scale negative.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0054  GDA length override missing or incompatible with data type.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

DSCERRCD0065  RLO references a LID which is not an RLO or GDA.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.
ERM0009  Resource Limits Reached.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0010  Data Stream Syntax Error.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0011  Target Not Supported.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0012  Parameter Value Not Supported.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0013  Conversational Protocol Error.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0014  RDB Currently Accessed.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0015  RDB Access Failed Reply Message.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0016  Not Authorized To RDB.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0017  RDB Not Found.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0018  Resource Limits Reached.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0019  Data Stream Syntax Error.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0020  Invalid Request.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0021  Abnormal End Unit of Work Condition.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0022  RDB Package Binding Process Active.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0023  Query Not Open.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0024  RDB Not Accessed.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0025  Data Descriptor Mismatch.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0026  Object Not Supported.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.
ERM0027  RDB Package Binding Not Active.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0028  RDB Update Reply Message.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0029  SQL Error Condition.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0030  End of Data.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0031  End of Query.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0032  Commitment Request.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0033  End Unit of Work Condition.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0034  Invalid Descriptor.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0035  Open Query Complete.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0036  Open Query Failure.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0037  Query Previously Opened.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM0038  Command Violation.
Explanation: An internal error in the driver code was detected.
User response: Send an error report to the developers.

ERM1200  Generic DRDA error has occurred. {0}
Explanation: The indicated generic DRDA error has occurred.
User response: Resolve the indicated generic DRDA error and try again.

ERM1201  Generic DRDA error has occurred. {0}, {1}
Explanation: The two indicated generic DRDA error have occurred.
User response: Resolve the two indicated errors and try again.

ERM1202  Generic DRDA error has occurred. {0}, {1}, {2}
Explanation: The three indicated generic DRDA errors have occurred.
User response: Resolve the three indicated errors and try again.

ERM1203  Generic DRDA error has occurred. {0}, {1}, {2}, {3}
Explanation: The four indicated generic DRDA errors have occurred.
User response: Resolve the four indicated errors and try again.

ERM1204  Generic DRDA error has occurred. {0}, {1}, {2}, {3}, {4}
Explanation: The five indicated generic DRDA errors have occurred.
User response: Resolve the five indicated errors and try again.
ERM1205  Generic DRDA error has occurred. {0}, {1}, {2}, {3}, {4}, {5}

Explanation:  The six indicated generic DRDA errors have occurred.
User response:  Resolve the six indicated errors and try again.

ERM1206  Generic DRDA error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}

Explanation:  The seven indicated generic DRDA errors have occurred.
User response:  Resolve the seven indicated errors and try again.

ERM1207  Generic DRDA error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}

Explanation:  The eight indicated generic DRDA errors have occurred.
User response:  Resolve the eight indicated errors and try again.

ERM1208  Generic DRDA error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}

Explanation:  The nine indicated generic DRDA errors have occurred.
User response:  Resolve the nine indicated errors and try again.

EXPT1000  Cannot perform export command: {0}

Explanation:  The indicated export command can not be performed.
User response:  Resolve the first indicated error and try again.

EXPT1001  An unsupported data type {0} was encountered.

Explanation:  The result set contains columns with the types that are not supported by the IXF370 format.
User response:  Make sure that the result set does not contain columns with any of the following types: BINARY, VARBINARY, ROWID, LONGVARBINARY, CLOB, DBCLOB, BLOB, GRAPHIC, VARGRAPHIC, or LONGVARGRAPHIC.

EXPT1002  The length of column {0} must be less than {1}.

Explanation:  The length of the indicated column must be less than the indicated length due to restrictions of the IXF format.
User response:  Make sure that the indicated data column is less than the indicated length. Try to export using another format (for example, XML).

EXPT1003  The precision of column {0} must be an odd number between {1} and {2}, inclusive.

Explanation:  The precision of the indicated column must be an odd number between the two indicated values due to restrictions of the IXF format.
User response:  Make sure the precision of the indicated data column is an odd number between the two indicated values. Try to export using another format (for example, XML).

EXPT1004  The data could not be exported due to an unsupported CCSID {0}.

Explanation:  The indicated CCSID is not supported for export.
User response:  Specify a valid CCSID for export. A list of supported CCSIDs can be obtained from the CCSID drop down menu in the Export dialog.

EXPT1005  The data could not be exported because the single-byte code page is not specified.

Explanation:  A result set containing CLOB, CHAR, VARCHAR, or LONGVARCHAR columns was exported in IXF format but a CCSID that contains a single-byte code page was not specified.
User response:  Select a CCSID that contains a single-byte code page.

EXPT1006  The data could not be exported because the double-byte code page is not specified.

Explanation:  A result set containing DBCLOB, GRAPHIC, VARGRAPHIC, or LONGVARGRAPHIC columns was exported in IXF format but a CCSID that contains a double-byte code page was not specified.
User response:  Select a CCSID that contains a double-byte code page.

EXPT1007  The value in column {0} exceeds the maximum length supported by the dBASE file format.

Explanation:  The value in the indicated column exceeds the character limit that is supported by the dBASE file format.
User response:  Shorten the value in the indicated column or specify a different file format for export.
| EXPT1008 | The data type of column {0} is not supported in dBASE files. |
| Explanation: | The data type of the indicated column is not supported by the dBASE file format. |
| User response: | Specify a different data type for the indicated column or select a different file format for export. Supported types: CHAR, VARCHAR, SMALLINT, INTEGER, DECIMAL, BIGINT, DOUBLE, FLOAT, DATE, and TIME. |

| EXPT1009 | The row length in a dBASE file cannot exceed 4000 characters. |
| Explanation: | The summary length of all of the result set's columns exceeds 4,000 characters, which is not supported by the dBASE file format. |
| User response: | Make sure that the length is shorter than 4,000 characters, or select a different file format for export. |

| EXPT1010 | The specified data source does not exist. |
| Explanation: | There was an attempt to export a result set to a data source that does not exist |
| User response: | Specify a valid data source. |

| EXPT1011 | The operation cancelled. |
| Explanation: | The user cancelled the export command when prompted for a user name and password. |
| User response: | Specify a valid user name and password for the export command. |

| EXPT1012 | Name must be specified. |
| Explanation: | There was an attempt to export a result set to a table that does not exist. |
| User response: | Specify a valid export table. |

| EXPT1013 | Invalid storage entry. |
| Explanation: | The storage file contains corrupted data. |
| User response: | Setup fonts and font mapping for PDF export. |

| EXPT1014 | Cannot create font {0} for PDF |
| Explanation: | The indicated font cannot be created for the PDF file format. |
| User response: | Specify a different font for conversion, specify a different file format for export, or set up fonts and font mapping for PDF file export. |

| EXPT1015 | {0} font is not mapped |
| Explanation: | The indicated font name is not mapped to the physical font file. |
| User response: | Set up fonts and font mapping for PDF file export. |

| FRM1001 | The input line type is invalid. |
| Explanation: | Corrupted form: The form loader is hanging on a line with a certain first character, because every line in a form file, according to the form file format, starts with certain character (T, V, R, H, E, *) that define the line type. The current line's first character has an unknown type. |
| User response: | Try to open and save again with exact same version of QMF that was used to create the form. |

| FRM1002 | The input line is too short. |
| Explanation: | Corrupted form: The form loader is hanging on a line with a certain character count, because each line type must have a character count greater than a certain number (T > 15, V > 11, R > 3, or H > 44). The current line is too short. |
| User response: | Try to open and save again with exact same version of QMF that was used to create the form. |

| FRM1003 | The boolean value is invalid. Valid values are YES or NO. |
| Explanation: | Corrupted form: A boolean value in the form file has a string other than YES or NO. |
| User response: | Try to open and save again with exact same version of QMF that was used to create the form. |

| FRM1004 | The numeric value is invalid. Valid values are NONE, COLUMNS, DEFAULT, or an integer value. |
| Explanation: | Corrupted form: The form loader waits for a valid Integer value or predefined word (NONE, COLUMNS, or DEFAULT). |
| User response: | Try to open and save again with exact same version of QMF that was used to create the form. |

<p>| FRM1005 | An invalid code was encountered. |
| Explanation: | Corrupted form: Every table structure in a form file has its own column types. The form loader waits for certain column types depending on the table type. |
| User response: | Try to open and save again with exact same version of QMF that was used to create the form. |</p>
<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>FRM1006</td>
<td>The object header is too short.</td>
<td>The form loader is hanging on a line with a certain character count, because each line type must have a character count greater than a certain number (T &gt; 15, V &gt; 11, R &gt; 3, or H &gt; 44). The current line is too short.</td>
<td>Try to open and save again with exact same version of QMF that was used to create the form.</td>
</tr>
<tr>
<td>FRM1007</td>
<td>The object header is invalid.</td>
<td>Corrupted form: The object header contains unexpected fields or data.</td>
<td>Try to open and save again with exact same version of QMF that was used to create the form.</td>
</tr>
<tr>
<td>FRM1008</td>
<td>Invalid usage code.</td>
<td>The “new column” of the form dialog contains an invalid usage code.</td>
<td>Leave the usage code field empty or select one from the combo box.</td>
</tr>
<tr>
<td>FRM1009</td>
<td>The value specified for (0) is invalid. Valid values are {1}.</td>
<td>In the form dialog page, there are several places where you can type or choose a listed value. An invalid listed value was entered.</td>
<td>Enter a valid value from the list.</td>
</tr>
<tr>
<td>FRM1010</td>
<td>The column heading &quot;(0)&quot; is too long.</td>
<td>The length of the column heading must be less than 40 characters.</td>
<td>Ensure that the column heading is less than 40 characters.</td>
</tr>
<tr>
<td>FRM1011</td>
<td>There is no condition expression with ID (0).</td>
<td>A form has a few detail blocks in the “detail” branch (by default – one) and each detail can use a condition that defines the detail as enabled or disabled. The condition typed in the C1, C2, .. C999 format and the condition with the according index should exist in the “conditions” branch.</td>
<td>Specify YES, NO, or Ci where Ci is the existing condition.</td>
</tr>
<tr>
<td>FRM1012</td>
<td>Line Wrapping Width must be NONE when Number of Fixed Columns is not NONE.</td>
<td>In the Options page of the form designer, when any number is defined in the Number of Fixed Columns field, the Line Wrapping Width field must be set to NONE.</td>
<td>Specify NONE in either the Line Wrapping Width field or the Number of Fixed Columns field.</td>
</tr>
<tr>
<td>FRM1013</td>
<td>The ID for calculation (0) is already being used by a different calculation.</td>
<td>In the Calculations page of the form designer, two or more calculations with the same ID were specified.</td>
<td>Ensure that each calculation ID is unique.</td>
</tr>
<tr>
<td>FRM1014</td>
<td>The ID for condition (0) is already being used by a different condition.</td>
<td>In the Conditions page of the form designer, two or more conditions with the same ID were specified.</td>
<td>Ensure that each of the conditions are unique.</td>
</tr>
<tr>
<td>FRM1015</td>
<td>Line Wrapping Width must be 0 if any column uses a column wrapping edit code.</td>
<td>If a column uses the wrapping edit code, then in the Options page of the form designer, the Line Wrapping Width field must be set to NONE.</td>
<td>Either set the Line Wrapping Width field to NONE, or do not use the line wrapping edit code.</td>
</tr>
<tr>
<td>FRM1016</td>
<td>Automatically Reorder Report Columns must be TRUE when using the ACROSS usage code.</td>
<td>If any columns have the ACROSS usage code, then in the Options page of the form designer, the Automatically Reorder Report Columns field must be set to TRUE.</td>
<td>Either set the Automatically Reorder Report Columns field to TRUE or do not use the ACROSS usage code.</td>
</tr>
<tr>
<td>FRM1017</td>
<td>The ACROSS usage code requires other columns to use the GROUP and aggregate usage codes.</td>
<td>If any columns use the ACROSS usage code, then all other columns must use either the OMIT, GROUP, or AGGREGATION usage code.</td>
<td>Set the OMIT, GROUP, or AGGREGATION usage codes for all other columns.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1018</td>
<td>Only one column can use the ACROSS usage code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>Only one column can use the ACROSS usage code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Ensure that only one column uses the ACROSS usage code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1019</td>
<td>The GROUP usage code requires other columns to use aggregate usage codes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>When one column uses the GROUP usage code, all of the other columns must use the OMIT, GROUP, BREAK, or AGGREGATION usage codes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Ensure that all of the other columns use the OMIT, GROUP, BREAK, or AGGREGATION usage codes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1020</td>
<td>The GROUP usage code requires all other columns to use a non-blank usage code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>When a column uses the GROUP usage code, all of the other columns must use the OMIT, GROUP, BREAK, or AGGREGATION usage codes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Ensure that all of the other columns use the OMIT, GROUP, BREAK, or AGGREGATION usage codes.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1021</td>
<td>The aggregate usage code can only be used when the column has a numeric data type.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The SUM, CSUM, AVERAGE, STDEV, PCT, TPCT, CPCT, and TCPCT usage codes can only be used with numeric columns.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify a different usage code than SUM, CSUM, AVERAGE, STDEV, PCT, TPCT, CPCT, or TCPCT for non-numeric columns.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1022</td>
<td>There is no calculation expression with ID {0}.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>In the Calculations page of the form designer, the calculation usage code ID must be specified.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify a calculation ID for the calculation usage code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1023</td>
<td>&quot;{0}&quot; is not a valid edit code for a calculation.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The specified edit code is not a valid calculation edit code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify another calculation edit code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1024</td>
<td>Invalid edit code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The specified edit code is invalid.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Check the reference section of the User help to find a valid edit code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1025</td>
<td>Invalid string &quot;(0)&quot; is encountered. Parsing failed.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The form is corrupted or needs to be opened with another locale because a string that represents a number value cannot be parsed in the current locale.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Try to open and save the form with the same version of QMF that was used to create the form or try to change the locale and reopen.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1026</td>
<td>The variable &quot;{0}&quot; is invalid in this context.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The specified variable name is invalid when used in the expression.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify a valid variable name for the expression.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1027</td>
<td>There is no column {0}.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The expression contains a variable that refers to a column that does not exist.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify a valid column number in the expression variable.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1028</td>
<td>The suffix '_B' is invalid in this context.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The suffix '_B' can not be used in predefined variables, and as such is invalid for the current variable.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Remove the suffix '_B' from all predefined variables.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1029</td>
<td>Unable to open linked data source.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Explanation:</td>
<td>The form attempted to open a linked data source and an error occurred during this process.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Specify a valid data source object for the form.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRM1030</td>
<td>An error occurred while registering user edit code.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>User response:</td>
<td>Review the FormCustomEditCode implementation documentation and check for errors.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The user-defined edit routine class could not be found. {0}

Explanation: The user implementation class FormCustomEditCode cannot be loaded by the Classloader.

User response: Check the className.jar CLASSPATH.

An error occurred while initializing user-defined edit routine class. {0}

Explanation: An error occurred.

User response: See additional information in the wrapped exception.

Generic driver error has occurred. {0}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

Generic driver error has occurred. {0}, {1}, {2}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

Generic driver error has occurred. {0}, {1}, {2}, {3}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

Generic driver error has occurred. {0}, {1}, {2}, {3}, {4}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

Generic driver error has occurred. {0}, {1}, {2}, {3}, {4}, {5}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

Generic driver error has occurred. {0}, {1}, {2}, {3}, {4}, {5}, {6}

Explanation: An internal error in the driver code was detected.

User response: Send an error report to the developers.

The LOB column index is invalid.

Explanation: The file contains an invalid index of a LOB column.

User response: The imported IXF file is corrupted or has an unknown format.

The LOB column length is invalid.

Explanation: The IXF file contains a LOB column that has an invalid length.

User response: The imported IXF file is corrupted or has an unknown format.

The end of the file was encountered prematurely.

Explanation: A premature end of file was encountered while importing data from the IXF file.

User response: The imported IXF file is corrupted or has an unknown format.

The length of record {0} is invalid.

Explanation: A corrupted record was encountered while importing data from the IXF file.

User response: The imported IXF file is corrupted or has an unknown format.

An invalid record length was encountered in record {0}.

Explanation: An invalid record length was encountered while importing data from the IXF file.

User response: The imported IXF file is corrupted or has an unknown format.

An invalid name length was encountered in record {0}.

Explanation: An invalid column name length was encountered while importing data from the IXF file.
IXF01008  An unrecognized record type was encountered in record [0].
Explanation: An unknown record type was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

IXF01009  An invalid value was encountered in record [0].
Explanation: An unexpected data value was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

IXF01010  An unsupported data type was encountered in record [0].
Explanation: An unsupported data type was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

IXF01011  An unsupported CCSID was encountered in record [0].
Explanation: The IXF file contains character data which is encoded using a CCSID that is not supported by QMF.
User response: Create an IXF file using another CCSID to import to QMF.

IXF01012  The column length is invalid.
Explanation: An invalid column name was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

IXF01013  The data record ID in record [0] is negative.
Explanation: An invalid data identifier was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

IXF01014  The position for a column is negative in record [0].
Explanation: An invalid column position was encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or has an unknown format.

JOB1000  {0}
Explanation: This is a wrapped message.
User response: Resolve the indicated error and try again.

JOB1001  Unknown JDF file format.
Explanation: An incorrect job file was selected while importing a job file in the old format (.jdf) to the new format (.jdfx).
User response: Select a correct job file in the old format to import.
JOB1002  Unexpected end of file.
Explanation: A corrupted job file was selected while importing a job file in the old format (.jdf) to the new format (.jdfx).
User response: Resave the job file in QMF version 8 and retry to import the file.

LIC1000  License field "[0]" has invalid date format: [1].
Explanation: The format of the date at the specified field is incorrect.
User response: Ensure that the license file contains a date in dd/mm/yyyy format.

LIC1001  Required field "[0]" missed.
Explanation: No value was specified for the indicated field.
User response: Ensure that a value is specified for the indicated field.

LIC1002  Field "[0]" has invalid value "[1]". Valid value is [2].
Explanation: An incorrect value was specified for the indicated field.
User response: Ensure that a valid license file is being used.

LIC1003  License file could not be found [0].
Explanation: The license file could not be found.
User response: Use the Manage License dialog to import a valid license.

MAIL1000  {0}
Explanation: The indicated error occurred.
User response: Resolve the error and try again.

MAIL1001  SMTP server must be specified.
Explanation: The email server that will send the message containing the object has not been specified in the procedure command.
User response: Specify the email server that will send the message in the MAIL TO procedure command. Check the MAIL TO procedure command topic in the user help for more information.

MAIL1002  Unknown type of attachment specified.
Explanation: The file specified in the MAIL TO command is of an unknown file format, or was entered incorrectly.
User response: Check the ATTACHMENT parameter of the MAIL TO command for errors or specify a different attachment. Check the MAIL TO procedure command topic in the user help for more information.

NLS00001  Generic error #[0] has occurred in module [1].
Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00002  Generic error #[0] has occurred in module (1) ([2]).
Explanation: The indicated error occurred.
User response: Send an error report to the developers.
NLS00003 Generic error #0 has occurred in module {1}; {2}; {3}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00004 Generic error #0 has occurred in module {1}; {2}; {3}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00005 Generic error #0 has occurred in module {1}; {2}; {3}; {4}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00006 Generic error #0 has occurred in module {1}; {2}; {3}; {4}; {5}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00007 Generic error #0 has occurred in module {1}; {2}; {3}; {4}; {5}; {6}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00008 Generic error #0 has occurred in module {1}; {2}; {3}; {4}; {5}; {6}; {7}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

NLS00009 Generic error #0 has occurred in module {1}; {2}; {3}; {4}; {5}; {6}; {7}; {8}; {9}.

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

OLCQ1002 You must select at least one value for each level.

Explanation: At least one value must be selected in every level of a slicer control.
User response: Select a value and try again.

OLCQ1005 Cannot find needed data source.

Explanation: A nonexistent data source was specified for the OLAP query.
User response: Specify a valid data source for the OLAP query.

OLP1000 {0}

Explanation: This is a wrapped message.
User response: Resolve the indicated error and try again.

OLP1002 The database does not support OLAP feature.

Explanation: The specified database does not support OLAP functionality.
User response: Specify a database with OLAP functionality.

OLP1003 Unable to locate cube measure {0}.

Explanation: The indicated cube measure could not be found on the database.
User response: Select a different database to search for the cube measure.

OLP1004 Unable to locate cube dimension {0}.

Explanation: The indicated cube dimension could not be found on the database.
User response: Select a different database to search for the cube dimension.

OLP1005 Unable to locate {0}.

Explanation: The indicated OLAP cube could not be found on database.
User response: Select a different database to search for the OLAP cube.

OLP1006 Cannot retrieve values for {0}.

Explanation: An error occurred while reading the dimension information.
User response: Ensure that the indicated dimension exists.

OLCQ1001 Query was cancelled.

Explanation: The current query was cancelled.
User response: Rerun the query.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>OLP1007</td>
<td>Measure or dimension cannot be added because it is not related to any table currently used in the layout.</td>
<td>An error occurred while building the SQL query to retrieve OLAP data from CubeViews; the table that stores information about the selected measure or dimension could not be found.</td>
<td>Check the integrity of the CubeView metadata.</td>
</tr>
<tr>
<td>OLP1008</td>
<td>There is not enough information to link specified measure or dimension: {0}.</td>
<td>An error occurred while building the SQL query to retrieve OLAP data from CubeViews; the tables that store information about the selected measures or dimensions could not be joined.</td>
<td>Check the integrity of the CubeView metadata.</td>
</tr>
<tr>
<td>OLP1009</td>
<td>Cannot connect to database: {0}.</td>
<td>Can not connect to the database.</td>
<td>Check if connection to a database is available or ask your administrator for more information.</td>
</tr>
<tr>
<td>OLP1010</td>
<td>Cube definition is not suitable for layout of the current query.</td>
<td>The cube structure as it is defined in the OLAP query does not match the current cube structure.</td>
<td>Check to make sure that the cube structure that is defined in the OLAP query matches the current cube structure.</td>
</tr>
<tr>
<td>OLQ1000</td>
<td>{0}</td>
<td>This is a wrapped message.</td>
<td>Resolve the indicated error and try again.</td>
</tr>
<tr>
<td>OLQ1003</td>
<td>You must select at least one value for each level.</td>
<td>At least one value must be selected in a slicer control.</td>
<td>Select a value and try again.</td>
</tr>
<tr>
<td>OLQ1004</td>
<td>Invalid type for saving the query.</td>
<td>An invalid object type was selected in which to save the query. OLAP queries can only be saved in the *.oq file format.</td>
<td>Save the OLAP query to a file with the *.oq file extension.</td>
</tr>
<tr>
<td>OLQ1005</td>
<td>No data source was specified for the query.</td>
<td>A nonexistent data source was specified for the OLAP query.</td>
<td>Specify a valid data source for the OLAP query.</td>
</tr>
<tr>
<td>OLQ1006</td>
<td>Only one reference to dimension hierarchy {0} can appear in the slicer.</td>
<td>MDX DB2 DWE supports only one dimension per slicer.</td>
<td>Select only one dimension.</td>
</tr>
<tr>
<td>PE00001</td>
<td>Encountered &quot;[0]&quot; at column [1]. Was expecting one of: {2}.</td>
<td>An invalid character was encountered at the indicated column.</td>
<td>Replace the invalid character with one of the indicated characters.</td>
</tr>
<tr>
<td>PE00002</td>
<td>Encountered &quot;[0]&quot; at column [1]. Was expecting: {2}.</td>
<td>An invalid character was encountered at the indicated column.</td>
<td>Replace the invalid character with the indicated character.</td>
</tr>
<tr>
<td>PE00003</td>
<td>Expression needs a calculator to get a value.</td>
<td>The expression does not return a value.</td>
<td>No action is required.</td>
</tr>
</tbody>
</table>
Parse exception occurred.

Explanation: An error occurred while parsing the expression.

User response: Check the expression syntax for errors and try again.

---

An unexpected error occurred while parsing the command.

Explanation: An internal error occurred.

User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

---

An error occurred while parsing the command: unexpected token "[0]".

Explanation: An unexpected token was encountered while parsing the procedure.

User response: Check the procedure's text for syntax errors (using the documentation or Content Assist via Ctrl+Space)

---

An error occurred while parsing the command: unexpected character "[0]".

Explanation: An unexpected character was encountered while parsing the procedure.

User response: Check the procedure's text for syntax errors or invalid characters (using the documentation or Content Assist via Ctrl+Space)

---

The parameter "[0]" is invalid in this context.

Explanation: An unsupported parameter token was encountered while parsing the procedure.

User response: Check the procedure's text for syntax errors (using the documentation or Content Assist via Ctrl+Space)

---

The parameter "[0]" cannot be specified twice.

Explanation: The indicated parameter was specified twice in the same procedure command.

User response: Only specify one instance of the indicated parameter.

---

"[1]" is not a valid value for parameter "[0]".

Explanation: The indicated value is not valid for the indicated parameter.

User response: Specify a valid value for the indicated parameter. See the Procedure Commands section of the user help for more information.

---

You cannot set variable "[0]".

Explanation: The indicated variable can not be set manually.

User response: Specify a valid variable and try again.

---

An error occurred while parsing the command: unexpected end of line.

Explanation: An unexpected end of line was encountered while parsing the procedure.

User response: Check the procedure's text for syntax errors (using the documentation or Content Assist via Ctrl+Space)

---

An error occurred while parsing the command: unrecognized command "[0]".

Explanation: The indicated command is not valid.

User response: Check the procedure text for errors or specify a different command.

---

Parsing error at lines [0]-[1] (command #[2]).

Explanation: a syntax error was encountered while parsing procedure.

User response: Check the procedure's text for syntax errors (using the documentation or Content Assist via Ctrl+Space)

---

An error occurred while parsing the command: invalid object name "[0]".

Explanation: The indicated object name is invalid.

User response: Check the procedure text for errors and specify a valid object name. See the Procedure Commands section of the user help for more information.

---

You must specify object type or object name.

Explanation: A required object type or name was not specified.

User response: Specify a valid object type or name where needed in the procedure command text. See the Procedure Commands section of the user help for more information.
PRC1013  

''{0}'' is an invalid variable name.  

Explanation: The indicated variable name is invalid.  

User response: Check the variable name for syntax errors or specify another valid variable. Check the Procedure Commands section of the user help for more information.

PRC1014  

Close bracket reached before end.  

Explanation: An unexpected close bracket was encountered while parsing the procedure.  

User response: Check the procedure’s text for syntax errors (using the documentation or Content Assist via Ctrl+Space).

PRC2001  

An error occurred while retrieving {0}.  

Explanation: The indicated error occurred while retrieving the indicated object.  

User response: Resolve the error and rerun the procedure.

PRC2002  

{0} does not exist.  

Explanation: The indicated object does not exist.  

User response: Specify a valid object in the procedure command.

PRC2003  

{0} exists but is of the wrong type.  

Explanation: The indicated object exists in an open window of the editor, but the object type that was specified in the procedure command does not match the type of the object.  

User response: Make sure the object type that is specified in the procedure command matches the type of the object in the open window of the editor.

PRC2004  

{0} does not exist or is of the wrong type.  

Explanation: There is no object of the specified object type open in an open window of the editor, or the object type is incorrect.  

User response: Make sure that the object type that is specified in the procedure command matches the type of the object that is in the open window.

PRC2005  

The procedure issued a command against a current object, but no current object of the correct type exists.  

Explanation: The procedure does not specify a specific object name, only an object type. In this instance, if an object of this type is open in another window of the editor, the procedure will run correctly. Since an object of the type specified is not open in another window, the procedure failed to run.  

User response: Make sure an object of the specified type is open in another window, or specify a specific object name.

PRC2006  

{0}  

Explanation: This is a wrapped message.  

User response: Resolve the indicated error and try again.

PRC2007  

The CONVERT command can only be issued against queries; it cannot be applied to {0}.  

Explanation: The indicated object can not be converted using the CONVERT command.  

User response: Specify a query to be converted using the CONVERT command. For more information, see the CONVERT topic in the Procedure Commands section of the user help.

PRC2008  

The operation was cancelled.  

Explanation: The operation was cancelled by the user.  

User response: Rerun the operation.

PRC2011  

Saving in {0} format is not supported.  

Explanation: The selected format is not supported when exporting an object. Reports may only be exported in TEXT, HTML and PDF formats.  

User response: Change the export data format in the procedure command.

PRC2017  

The maximum nesting depth of procedures was exceeded.  

Explanation: More than 50 nested procedure levels are not support.  

User response: Redesign the procedure to decrease its depth.

PRC2018  

The specified query did not return a result set.  

Explanation: The SAVE DATA command was issued against a query that does not contain a result set.  

User response: Ensure that the query you are trying to save contains a result set.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC2020</td>
<td>An error occurred while saving the object at the server. (0)</td>
<td>The indicated error occurred while the object was being saved at the server.</td>
<td>Resolve the indicated error and rerun the procedure.</td>
</tr>
<tr>
<td>PRC2022</td>
<td>The operation cannot be performed because no data is available.</td>
<td>The EXPORT DATA command was issued against an object that does not contain data.</td>
<td>Ensure that the object that you are trying to export contains data.</td>
</tr>
<tr>
<td>PRC2025</td>
<td>The procedure was terminated because it recursively invokes itself.</td>
<td>The procedure recursively invoked itself. Recursion is not supported in procedures.</td>
<td>Rewrite the procedure and remove the recursion.</td>
</tr>
<tr>
<td>PRC2026</td>
<td>An error occurred while running the procedure. (0)</td>
<td>The indicated error occurred while the procedure was being run.</td>
<td>Resolve the indicated error and rerun the procedure.</td>
</tr>
<tr>
<td>PRC2028</td>
<td>An error occurred while importing the (0) file.</td>
<td>An error occurred while the file was being imported.</td>
<td>Ensure that object that is being imported is of a supported format.</td>
</tr>
<tr>
<td>PRC2029</td>
<td>Could not connect to a server (1): (0)</td>
<td>The data source alias that was specified in the CONNECT TO command is undefined.</td>
<td>Ensure that the command refers to a valid data source in the repository.</td>
</tr>
<tr>
<td>PRC2030</td>
<td>Specified object (0) for import has incompatible type.</td>
<td>The IMPORT or DISPLAY command was issued against an object with an unsupported type.</td>
<td>Ensure that the object to be imported or displayed is of a valid type.</td>
</tr>
<tr>
<td>PRC2031</td>
<td>Specified command, or some of its parameters unsupported.</td>
<td>The procedure contains commands or parameters that are not supported.</td>
<td>Check the procedure's text for syntax errors (using the documentation or Content Assist via Ctrl+Space)</td>
</tr>
<tr>
<td>PRC2032</td>
<td>Cannot save non-QMF object into QMF Catalog.</td>
<td>The specified object is a non-QMF object and can not be saved into the QMF Catalog.</td>
<td>Specify a different location in which to save the object or specify a different object to be saved.</td>
</tr>
<tr>
<td>PRC2033</td>
<td>You cannot set the value of (0).</td>
<td>The indicated parameter's value can not be manually set with the SET GLOBAL command.</td>
<td>Values for some DSQ variables cannot be set manually (for example DSQAO_NUM_FETCHED, etc). Rewite the procedure to exclude these variable values.</td>
</tr>
<tr>
<td>PRC2035</td>
<td>The printer name &quot;(0)&quot; is invalid.</td>
<td>The indicated printer name is invalid.</td>
<td>Check the spelling of the printer name, or specify a different printer to use for the PRINT command.</td>
</tr>
<tr>
<td>PRC2036</td>
<td>You are not authorized to use the table editor at this data source.</td>
<td>The Enable Table Editing resource limit for the data source is turned off; you can not open Table Editor of the data source</td>
<td>Ask your administrator to enable this resource limit.</td>
</tr>
<tr>
<td>PRC2037</td>
<td>You are not authorized to edit tables at this data source.</td>
<td>The Enable Table Editing resource limit for the data source is turned off; you cannot edit values in a query's grid cells.</td>
<td>Ask your administrator to enable this resource limit.</td>
</tr>
<tr>
<td>PROC1000</td>
<td>REXX procedure references cannot be determined.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Explanation:</strong></td>
<td>References for the procedure cannot be built for REXX procedures.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>You can view references at the Repository or Workspaces views for generic procedures only.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PROC1001</th>
<th>Some substitution variables are not defined.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>Some of the substitution variables of the procedure are not defined.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that all of the substitution variables are defined for the procedure, or run this procedure without the /batch parameter in the command line. In this case QMF will ask for all of the necessary variables values.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0001</th>
<th>You are not allowed to run queries returning LOB data.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>You are not allowed to run queries that contain large object data.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check your LOB Options resource limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0002</th>
<th>The Maximum Rows to Fetch limit has been exceeded. [0] rows were retrieved so far.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The Maximum Rows to Fetch limit has been reached. The indicated number of rows have been retrieved so far.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check your Maximum Rows to Fetch resource limit by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0003</th>
<th>The Maximum Bytes to Fetch limit has been exceeded. [0] bytes were retrieved so far.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The Maximum Bytes to Fetch limit has been reached. The indicated number of bytes have been retrieved so far.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check your Maximum Bytes to Fetch resource limit by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0004</th>
<th>The length of a LOB column exceeds the maximum allowable length.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The length of a LOB column in the query results exceeds the maximum allowable length.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check your Maximum LOB column size by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0005</th>
<th>You are not allowed to use the &quot;[0]&quot; SQL verb.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>You are not allowed to use the indicated SQL verb.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check your SQL Verbs limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEL0006</th>
<th>You are not allowed to save data to database.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>You are not allowed to save data to the database.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check you Save Data resource limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEN0001</th>
<th>Query was cancelled.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The active query was cancelled.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Rerun the query.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEN0003</th>
<th>Unexpected token: [0]</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unexpected token was encountered while parsing the query that calls the stored procedure.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check the query’s syntax for errors.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEN0004</th>
<th>Unexpected token: [0] is expected but [1] was found.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unexpected closed bracket was encountered while parsing the query that calls the stored procedure.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check the query’s syntax for errors.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>QEN0005</th>
<th>Unexpected end of statement.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unexpected end of statement was encountered while parsing the query that calls the stored procedure.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Check the query’s syntax for errors.</td>
</tr>
</tbody>
</table>
QEN00006 Expression [0] is not a stored procedure.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QEN00007 End of statement is expected but [0] was found
Explanation: Tokens were encountered after the end of statement while parsing the query that calls the stored procedure.
User response: Check the query’s syntax for errors.

QEN00008 Unsupported parameter data type: [0]
Explanation: An unsupported parameter was encountered while parsing the query that calls the stored procedure.
User response: Check the query’s syntax for errors.

QEN00009 [0] is invalid value for this type: [1]
Explanation: When prompted for a value for a stored procedure parameter, the user entered a value that is not valid for that parameter’s type.
User response: Specify a valid value for the parameter.

QRL00001 You are not authorized to print objects from ''{0}'' data source in user interface mode.
Explanation: You are not authorized to print objects from this data source in user interface mode.
User response: Check your Options limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRL00002 You are not authorized to print objects from ''{0}'' data source in automation mode.
Explanation: You are not authorized to print objects from this data source in automation mode.
User response: Check your Options limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRL00003 You are not authorized to run unsaved queries.
Explanation: You are not authorized to run unsaved queries.
User response: Check your Options limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRL00004 You are not authorized to save data from this data source to a file.
Explanation: You are not authorized to save data from this data source to a file.
User response: Check your Save Data limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRL00005 You are not authorized to save data from this data source to the database.
Explanation: You are not authorized to save data from this data source to the database.
User response: Check your Save Data limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRL00006 You are not authorized to retrieve LOB data.
Explanation: You are not authorized to retrieve LOB data.
User response: Check your LOB Options limits by selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for more information.

QRL00008  No resource group for user [0] was found.
Explanation: No resource group for the indicated user was found.
User response: Specify a valid resource group for the user.

QRL00009  The operation cannot be performed because the processing of LOB data is disabled.
Explanation: The operation cannot be performed because the processing of LOB data is disabled.
User response: Check your LOB options limits by selecting Resource Limits from the View menu to see your specific allowances or ask your administrator for more information.

QRY0999  [0]
Explanation: This is a wrapped message.
User response: Resolve the indicated error and try again.

QRY1001  Query was cancelled.
Explanation: The query was cancelled.
User response: Rerun the query.

QRY1002  An invalid header record was encountered.
Explanation: The query was loaded with errors.
User response: Try to reload the query; otherwise the query is corrupted.

QRY1003  No data source was specified for the query.
Explanation: No data source was specified for the query.
User response: Specify a data source for the query.

QRY1004  An unexpected "R" record was encountered: [0].
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1005  An unexpected "T" record was encountered: [0].
Explanation: An error was encountered while loading a type T record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1006  An invalid "T" record was encountered: [0].
Explanation: An error was encountered while loading a type T record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1007  A "T" record with invalid column information was encountered: [0].
Explanation: An error was encountered while loading a type T record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1008  An unrecognized table type was encountered: [0].
Explanation: An error was encountered while loading a record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1009  An invalid value in an "R" record for table 1110 was encountered: [0].
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1010  An invalid value in an "R" record for table 1150 was encountered: [0].
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer support.

QRY1011 An invalid value in an "R" record for table 1210 was encountered: {0}.
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1012 An invalid value in an "R" record for table 1310 was encountered: {0}.
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1013 An invalid value in an "R" record for table 1410 was encountered: {0}.
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1014 An out of sequence 'R' record for table 1310 was encountered.
Explanation: An error was encountered while loading a type R record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1015 An invalid "V" record was encountered: {0}.
Explanation: An error was encountered while loading a type V record from the prompted query file during storage of info in the prompted query structure.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1016 There must be less than 16 tables in Prompted Query.
Explanation: There must be less than sixteen tables called from the Prompted Query editor.
User response: Ensure that there are less than sixteen tables called from the Prompted Query editor and rerun the query.

QRY1017 The same correlation ID was encountered for two or more tables.
Explanation: The PqTable object for the specified correlation ID already exists.
User response: Select another table for the Prompted Query editor.

QRY1018 An invalid table correlation ID was encountered.
Explanation: An error was encountered while retrieving a valid correlation ID.
User response: Try to add the query to the Prompted Query editor again, or collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1019 A column on which to join tables is in more than one of the tables in the query.
Explanation: A join column can only exist in one table when multiple tables are joined in a single query.
User response: Ensure that any join columns in the query exist in only one table.

QRY1020 A column on which to join tables is not in any of the tables in the query.
Explanation: A specified join column is not present in any of the tables in the query.
User response: Check the join column name for errors, or specify a different join column.

QRY1021 Type of join columns for joined tables mismatch.
Explanation: A columns that join two or more tables must all be of the same column type.
User response: Ensure that all of the columns that make up a single join are of the same column type.
The expression contains a syntax error: {0}

Explanation: The indicated expression contains a syntax error.

User response: Correct the syntax error and rerun the query.

An invalid connector for a row condition was encountered.

Explanation: An invalid connector for a row condition was encountered.

User response: Check all row conditions for errors and rerun the query.

An invalid expression type in a row condition was encountered.

Explanation: An invalid expression type in a row condition was encountered.

User response: Check all expression types in the row conditions for errors and rerun the query.

An invalid operator in a row condition was encountered.

Explanation: An invalid operator in a row condition was encountered.

User response: Check all operators in the row conditions for errors and rerun the query.

The selected relational operator is not valid for numeric data.

Explanation: An invalid operator in a row condition was encountered for numeric data.

User response: Check all of the operators in the row conditions for errors and rerun the query.

An invalid sort direction was encountered.

Explanation: An invalid sort direction was encountered. Valid directions are Ascending or Descending.

User response: Check all instances where sort directions are applied and change them to either ascending or descending.

The prompted query format is an earlier version, and contains join conditions that cannot be migrated to the current version. These join conditions have been deleted.

Explanation: A join condition can only appear with the higher of the two tables involved in the join. Also, a table cannot be joined with a preceding table if there is a third table between them with no join conditions.

User response: Reordered elements of the array of joins to match the current order of the tables.

The table {0} does not exist.

Explanation: The indicated table is called in the SQL code, but does not exist in the data source.

User response: Check the table name for errors, or enter a different table to be called.

The prompted query cannot be saved because a table name exceeds the maximum length allowed in the prompted query export format.

Explanation: The prompted query cannot be saved because a table name exceeds the maximum length allowed in the prompted query export format.

User response: Decrease the length of the table name.

The prompted query cannot be saved because a column name used in a join condition exceeds the maximum length allowed in the prompted query export format.

Explanation: The prompted query cannot be saved because a column name used in a join condition exceeds the maximum length allowed in the prompted query export format.

User response: Decrease the length of the join column name.

The prompted query cannot be saved because a column expression exceeds the maximum length allowed in the prompted query export format.

Explanation: The prompted query cannot be saved because a column expression exceeds the maximum length allowed in the prompted query export format.

User response: Decrease the length of the column expression name.

The prompted query cannot be saved because an expression in a row condition exceeds the maximum length allowed in the prompted query export format.

Explanation: The prompted query cannot be saved because an expression in a row condition exceeds the maximum length allowed in the prompted query export format.
User response: Decrease the length of the row condition.

QRY1034  An invalid record was encountered.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

QRY1035  Only a SELECT query can be shown in the prompted view.
Explanation: Only a SELECT query can be shown in the Prompted Query editor.
User response: Make sure that the specified query contains a SELECT statement.

QRY1036  Only simple SELECT statements are supported.
Explanation: Only simple SELECT statements are supported.
User response: Ensure that the specified query only contains simple SELECT statements.

QRY1037  Unrecognized table reference.
Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

QRY1038  You cannot view a query that has subselects in the prompted view.
Explanation: Subselects are not supported for queries that are viewed in the Prompted Query editor.
User response: Ensure that specified query does not contain subselects if it is to be viewed in the Prompted Query editor.

QRY1039  Table locator references are not supported.
Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

QRY1040  Table functions are not supported.
Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

QRY1041  Only AND conditions are supported for joins in the prompted view.
Explanation: Only AND conditions are supported for joins in queries that are viewed in the Prompted Query editor.
User response: Ensure that the specified query only contains AND conditions for joins if it is to be viewed in the Prompted Query editor.

QRY1042  Quantified predicates are not supported.
Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

QRY1043  'Exists' predicates are not supported.
Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

QRY1044  Only simple LIKE statements are supported.
Explanation: Only simple LIKE statements are supported.
User response: Ensure that the specified query only contains simple LIKE statements.

QRY1045  Only simple row conditions are supported.
Explanation: Only simple row conditions are supported.
User response: Ensure that the specified query only contains simple row conditions.

QRY1046  Expression cannot be empty.
Explanation: An error occurred while constructing the query.
User response: Check the query’s syntax for errors and try again.

QRY1047  Invalid type for saving the query.
Explanation: The type that was set for the query is invalid.
User response: Specify a valid type for the query or collect support data by selecting Help > Collect Support Data and forward it to customer support.
You cannot run an empty query.

Explanation: The specified query did not contain any SQL code.
User response: Populate the query with at least a SELECT statement and rerun.

Some substitution variables are not defined.

Explanation: Some of the substitution variables in the query were not given values when the query was run.
User response: Ensure that all of the substitution variables in the query are defined.

You cannot view a query that uses row values in the predicate.

Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

'XMLExists' predicates are not supported.

Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

An invalid value: {0}.

Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

Only SELECT statements are supported in compound queries.

Explanation: Only SELECT statements are supported in compound queries.
User response: Ensure that only SELECT statements are called in the specified compound query.

Query content is not compatible with Prompted Query format.

Explanation: The query can not be saved in the prompted format.
User response: Save the query in another format.

Host variable predicates are not supported.

Explanation: An error occurred while parsing the SQL text to construct the prompted query.
User response: Check the SQL text for errors and try again.

Internal error

Explanation: An internal processor error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Type mismatch

Explanation: An unexpected error occurred while processing the *.rco file.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Function {0} is not implemented yet

Explanation: An unexpected error occurred while processing the *.rco file.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Undefined variable {0}

Explanation: An unexpected error occurred while processing the *.rco file.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Missing variable name

Explanation: An unexpected error occurred while processing the *.rco file.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

Syntax error in "{0}"

Explanation: An unexpected error occurred while processing the *.rco file.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.
<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCO0006</td>
<td>Unknown function {0}</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RCO0007</td>
<td>Unknown object type {0}</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RCO0008</td>
<td>Wrong parameters in &quot;{0}&quot;</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RCO0009</td>
<td>Database object {0} not found</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RCO0010</td>
<td>Database error {0}</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RCO0011</td>
<td>Unknown database server type {0}</td>
<td>An unexpected error occurred while processing the *.rco file.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>REP01001</td>
<td>An input/output error occurred: {0}</td>
<td>The indicated error occurred in the repository.</td>
<td>Resolve the indicated error and try again.</td>
</tr>
<tr>
<td>REP01002</td>
<td>Character encoding is not supported: {0}</td>
<td>The indicated encoding error occurred while the data was being processed.</td>
<td>Ensure that UTF-8 encoding is used in the repository storage database.</td>
</tr>
<tr>
<td>REP01003</td>
<td>Internal error has occurred: {0}</td>
<td>The indicated error occurred.</td>
<td>Resolve the indicated error and try again.</td>
</tr>
<tr>
<td>REP01004</td>
<td>The following error has occurred while accessing database: {0}</td>
<td>The indicated error occurred while the database was being accessed.</td>
<td>Resolve the indicated error and retry to connect to the database.</td>
</tr>
<tr>
<td>REP01005</td>
<td>Operation is not supported.</td>
<td>The specified operation is not supported by the repository.</td>
<td>Specify a different operation and try again.</td>
</tr>
<tr>
<td>REP01006</td>
<td>Object with such identifier not found.</td>
<td>An error occurred while searching for the object.</td>
<td>Ensure that the specified object identifier is correct.</td>
</tr>
<tr>
<td>REP01007</td>
<td>Object or file with URL &quot;{0}&quot; not found.</td>
<td>There are no objects or files with the indicated URL.</td>
<td>Check the URL for errors or specify a different URL.</td>
</tr>
<tr>
<td>REP01008</td>
<td>Not enough permissions to perform operation.</td>
<td>Your user ID does not have permission to perform the specified operation.</td>
<td>Contact your administrator to check</td>
</tr>
</tbody>
</table>
your specific permissions or specify a different operation to perform.

REP01009 Operation cancelled due to invalid object identifier: {0}
Explanation: The operation was cancelled because the indicated object identifier is invalid.
User response: Specify a different object identifier and retry the specified operation.

REP01010 Cannot open connection: {0}
Explanation: The indicated error occurred while establishing a connection to the repository database.
User response: Ensure that the repository database is accessible.

REP01011 At least one line of the document is longer than 79 characters, which is the maximum supported length when saving objects in the database.
Explanation: The maximum character length allowed for documents saved to the database is seventy-nine characters. The document contains at least one line that is longer than seventy-nine characters.
User response: Ensure that all of the lines of the document are less than seventy-nine characters and retry to save the document.

REP01012 {0} already exists and has a different type.
Explanation: The indicated object name already exists as a different type of object. Each object in the database must have a different name.
User response: Specify a different name for the object and retry to save the object.

REP01013 {0} does not exist.
Explanation: The indicated object could not be found because it does not exist in the database.
User response: Specify a different object name to search for in the database.

REP01014 {0} already exists.
Explanation: The indicated object could not be saved because it already exists in the database.
User response: Specify a different name for the object and retry to save the object.

REP01015 {0} has unsupported type and cannot be accessed.
Explanation: The indicated object is of an unsupported type.
User response: Ensure that all of the necessary plug-ins are installed and available.

REP01016 Operation is impossible because object is too large.
Explanation: The specified operation could not be performed because the specified object is too large.
User response: Specify a different object or a different operation and try again.

REP01017 Illegal state or illegal operation error.
Explanation: An internal error occurred in the repository.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

REP01018 User is not logged on repository.
Explanation: You cannot perform the specified operation, because you are not connected to the repository.
User response: Connect to the repository and try again.

REP01019 Not implemented.
Explanation: The indicated error occurred while attempting to access a non-implemented functionality.
User response: Ensure that you are using the latest version of the product.

REP01020 Unexpected error occurred.
Explanation: An internal error occurred in the repository.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

REP01021 Initialization error occurred "{0}".
Explanation: An error occurred while the repository was being initialized.
User response: Check the repository initialization parameters and try again.
<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
</table>
| REP01022 | Invalid initialization parameters were specified "[0]".  
**Explanation:** An error occurred while the repository was being initialized.  
**User response:** Check the repository initialization parameters and try again. |
| REP01027 | A repository instance hasn't been initialized.  
**Explanation:** An error occurred while trying to access a non-initialized repository.  
**User response:** Initialize the repository and try again. |
| REP01028 | Repository "[0]" could not be found.  
**Explanation:** The indicated repository could not be found.  
**User response:** Check the repository name for errors or specify a different repository and try again. |
| REP01029 | Object type [0] cannot be added to this folder.  
**Explanation:** Objects of the indicated type cannot be added to the specified folder.  
**User response:** Specify a different folder in which to add the indicated object. |
| REP01030 | More authentication information for [0] required.  
**Explanation:** Not enough authentication information was provided for the indicated object.  
**User response:** Provide more authentication information to the indicated object and try again. |
| REP01031 | Repository storage table structure is obsolete. Contact repository storage administrator.  
**Explanation:** An error occurred while trying to access a repository that has an obsolete structure.  
**User response:** Contact your administrator to upgrade the repository database structure. |
| REP01032 | CCSID information could not be found for current QMF catalog.  
**Explanation:** An error occurred while trying to read CCSID information from the QMF Catalog.  
**User response:** Specify valid CCSID information and try again. |
| REP01034 | A repository with name [0] already exists.  
**Explanation:** The repository could not be created, because a repository of the same name already exists.  
**User response:** Specify a different name for the new repository and try again. |
| REP01035 | Unknown object type.  
**Explanation:** An error occurred while trying to access an unsupported object.  
**User response:** Ensure that all of the required plug-ins are installed and available. |
| REP01036 | Object [0] cannot be added to this folder.  
**Explanation:** The indicated object cannot be added to the specified folder.  
**User response:** Specify a different folder in which to add the indicated object. |
| REP01037 | Repository could not be found.  
**Explanation:** The specified repository could not be found.  
**User response:** Check the repository name for errors or specify a different repository name and try again. |
| REP01038 | Undefined or wrong repository identifier  
**Explanation:** An error occurred while trying to initialize a repository with deprecated initialization parameters.  
**User response:** Change the repository connection properties through the Edit Repository Connection dialog and try again. |
| REP01039 | There are no catalogs on the server  
**Explanation:** No QMF catalogs exist on the specified server.  
**User response:** Specify a different server and try again. |
| REP01042 | You are not authorized to use objects with Owner = [0].  
**Explanation:** Your user ID is not authorized to use objects with the indicated owner.  
**User response:** Specify an object that has a different owner or contact your administrator for more information. |
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>REP01043</td>
<td>This data source cannot be accessed by QMF</td>
<td>The application can not access this data source.</td>
<td>Check your user license and try again.</td>
</tr>
<tr>
<td>REP01044</td>
<td>Access to data source &quot;(0)&quot; blocked due to QMF catalog restriction violation.</td>
<td>Access to the indicated data source is blocked due to a restriction imposed by the QMF catalog protection limits.</td>
<td>Specify a different data source to access or contact your administrator for more information.</td>
</tr>
<tr>
<td>REP01045</td>
<td>Associated QMF catalog data source could not be found: (0)</td>
<td>The indicated QMF catalog data source could not be found.</td>
<td>Check the data source name for errors or specify a different data source and try again.</td>
</tr>
<tr>
<td>REP01046</td>
<td>Cannot find connection: (0)</td>
<td>The indicated repository connection could not be found.</td>
<td>Specify a different repository connection and try again.</td>
</tr>
<tr>
<td>REP01047</td>
<td>Cannot find data source: (0)</td>
<td>The indicated data source could not be found.</td>
<td>Specify a different data source and try again.</td>
</tr>
<tr>
<td>REP01049</td>
<td>Object name cannot exceed (0) characters.</td>
<td>The indicated object name exceeds the maximum character limit.</td>
<td>Shorten the indicated object name and try again.</td>
</tr>
<tr>
<td>REP01050</td>
<td>Object path cannot exceed (0) characters.</td>
<td>The indicated object path exceeds the character limit.</td>
<td>Shorten the indicated object path and try again.</td>
</tr>
<tr>
<td>REP01051</td>
<td>Cannot connect to repository &quot;(0)&quot; because it is used by another instance of QMF.</td>
<td>You can not connect to the indicated repository because it is being used by another instance of the application.</td>
<td>Select a different repository connection and try again.</td>
</tr>
<tr>
<td>REP01052</td>
<td>Data Source plug-in &quot;(0)&quot; was not properly initialized.</td>
<td>The indicated plug-in was not properly initialized.</td>
<td>Change the plug-in parameters.</td>
</tr>
<tr>
<td>RGEN1000</td>
<td>An error has occurred while generating the report: (0)</td>
<td>The indicated error occurred while the report was being generated.</td>
<td>Resolve the indicated error and retry to generate the report.</td>
</tr>
<tr>
<td>RGEN1001</td>
<td>The action was cancelled.</td>
<td>The specified action was cancelled</td>
<td>Rerun the specified action.</td>
</tr>
<tr>
<td>RGEN1002</td>
<td>The number of columns in the form does not match the number of columns in the query.</td>
<td>The number of columns in the form does not match the number of columns in its associated query.</td>
<td>Edit the number of columns in the form to match the number of columns its associated query.</td>
</tr>
<tr>
<td>RGEN1003</td>
<td>Internal error.</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RGEN1004</td>
<td>The number of columns in the form does not match the number of columns in the query.</td>
<td>The number of columns in the form does not match the number of columns in its associated query.</td>
<td>Edit the number of columns in the form to match the number of columns its associated query.</td>
</tr>
</tbody>
</table>
form to match the number of columns its associated query.

RGEN1005 The data source object is not specified.
Explanation: The data source object for the report is not specified.
User response: Specify a data source object for the report and try again.

RLE00002 Cannot retrieve resource limits of type {0}.
Explanation: The resources of the indicated type cannot be retrieved.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RLE00003 An error has occurred while retrieving resource limits from remote site: {0}
Explanation: The indicated error occurred while resource limits were being obtained from a remote site.
User response: Resolve the indicated error and try again.

RLE00004 Unknown resource limits key is used to retrieve limits.
Explanation: An error occurred while retrieving resource limits.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RLE00005 An error has occurred while obtaining resource limits: {0}
Explanation: The indicated error occurred while resource limits were being obtained.
User response: Resolve the indicated error and try again.

RLE00006 Cannot retrieve resource limits because resource limits key content is corrupted. {0}
Explanation: The indicated error occurred while attempting to retrieve resources limits.
User response: Resolve the indicated error and try again.

RLE00007 The following error has occurred while retrieving resource limits: {0}
Explanation: The indicated error occurred while resource limits were being retrieved.
User response: Resolve the indicated error and try again.

RLE00008 Data source cannot be accessed.
Explanation: Your user ID does not have permission to access the data source.
User response: Check your resource limits by selecting Resource Limits from the View menu or contact your administrator for more information.

RLE00009 LOB data saving is denied.
Explanation: Your user ID does not have permission to save objects that contain LOB data.
User response: Check your LOB Options resource limits by selecting Resource Limits from the View menu or contact your administrator for more information.

RLE00010 You are only authorized to run saved queries at this server.
Explanation: You are only allowed to run saved queries while you are connected to the current server.
User response: Check you Save Data resource limits by selecting Resource Limits from the View menu or contact your administrator for more information.

RLE00011 You are not authorized to save objects at this server.
Explanation: You are not authorized to save objects while you are connected to the current server.
User response: Check you Save Data resource limits by selecting Resource Limits from the View menu or contact your administrator for more information.

RLE00012 You are not authorized to access data source {0}.
Explanation: Your user ID is not authorized to access the indicated data source.
User response: Try to connect to another data source, or contact your administrator for information regarding specific allowances.

RLE00013 You are not authorized to access data source {0}.
Explanation: Your user ID is not authorized to access the indicated data source.
User response: Try to connect to another data source,
or contact your administrator for information regarding specific allowances.

---

RLW00001  [0] rows were retrieved. The Maximum Rows to Fetch warning limit has been exceeded.

**Explanation:** The indicated number of rows were retrieved and the warning limit for the Maximum Rows to Fetch limit has been reached.

**User response:** Click OK to continue running the query. Click Abort to abort the query. Click Ignore to ignore the warning.

---

RLW00002  [0] bytes were retrieved. The Maximum Bytes to Fetch warning limit has been exceeded.

**Explanation:** The indicated number of bytes were retrieved and the warning limit for the Maximum Bytes to Fetch limit has been reached.

**User response:** Click OK to continue running the query. Click Abort to abort the query. Click Ignore to ignore the warning.

---

RLW00003  There has been no response from [0],[1] for (2) seconds.

**Explanation:** The query was cancelled because the Server Response Timeout limit has been reached. There was no response from the indicated server after a wait time of the indicated length.

**User response:** Check your Server Response Timeouts resource limit by selecting Resource Limits from the View menu or try to connect to the server during a time of lighter server traffic.

---

RLW00004  The query has been idle for (0) seconds.

**Explanation:** The query has been idle for the indicated number of seconds and the Idle QueryTimeouts warning limit has been reached.

**User response:** Click OK to continue running the query. Click Abort to abort the query. Click Ignore to ignore the warning.

---

RLW00005  The query was cancelled because the Idle Query Timeout limit was exceeded.

**Explanation:** The query was cancelled because the Idle Query Timeout limit was exceeded.

**User response:** Attempt to rerun the query at a time when there is less server traffic.

---

RLW00006  The operation cannot be performed because the processing of LOB data is disabled.

**Explanation:** The operation can not be performed because the LOB Retrieval Option resource limits is disabled.

**User response:** Check your LOB Retrieval Option resource limit by selecting Resource Limits from the View menu or contact your administrator for more information.

---

RPT00001  Unable to process a Level component.

**Explanation:** An internal error occurred.

**User response:** Collect support data by selecting Help > Collect Support Data and forward it to customer support.

---

RPT00002  Report does not contain a main page.

**Explanation:** The visual report does not contain a main page.

**User response:** Make sure that the report contains a main page.

---

RPT00003  A group expression "[0]" is not correct.

**Explanation:** The indicated expression refers to a nonexistent column.

**User response:** Ensure that the expression refers to a valid column.

---

RPT00014  BLOB locator was not initialized.

**Explanation:** An error occurred while retrieving a BLOB locator.

**User response:** Reconnect to the repository and try again.

---

RPT00015  Query results were not initialized.

**Explanation:** The query results were not initialized.

**User response:** Reconnect to the repository and try again.

---

RPT00033  Internal swing renderer error: too early completion.

**Explanation:** The line object is incorrect.

**User response:** Delete the line object and recreate it in the designer.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPT00034</td>
<td>Internal swing renderer error: incorrect segment type.</td>
<td>The line object is incorrect.</td>
<td>Delete the line object and recreate it in the designer.</td>
</tr>
<tr>
<td>RPT00035</td>
<td>Internal error in reporter engine.</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RPT00037</td>
<td>Invalid arguments was used: row and column should be positive or zero.</td>
<td>A row or column in the grid is of a length that is less than zero when viewed in the HTML or SWF rendering mode.</td>
<td>Reload the visual project.</td>
</tr>
<tr>
<td>RPT00038</td>
<td>Parameter {0} already exists.</td>
<td>The specified parameter already exists.</td>
<td>Specify a new name for the new parameter.</td>
</tr>
<tr>
<td>RPT00039</td>
<td>Unable to process one or more expressions in the visual dashboard to render its runtime content.</td>
<td>The renderer attempted to render a scene that is undefined.</td>
<td>Reload the visual project.</td>
</tr>
<tr>
<td>RPT00040</td>
<td>A renderer for the selected report format has generated an error. No output contents has been produced.</td>
<td>A renderer for the selected report format has generated an error. No output contents have been produced.</td>
<td>Try to view the visual project in another rendering mode, or reload the visual project.</td>
</tr>
<tr>
<td>RPT00041</td>
<td>Internal error: unable to create reporter engine.</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RPT00042</td>
<td>Unable to parse previously stored visual project data.</td>
<td>The visual project’s data is corrupted.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RPT00043</td>
<td>Unable to locate visual dashboard format file.</td>
<td>{CONFIG_DIR}/converter/repository/world.xml can not be found or read.</td>
<td>Reinstall QMF.</td>
</tr>
<tr>
<td>RPT00044</td>
<td>Unable to read visual dashboard format file.</td>
<td>{CONFIG_DIR}/converter/repository/world.xml can not be found or read.</td>
<td>Reinstall QMF.</td>
</tr>
<tr>
<td>RPT00045</td>
<td>Unable to read visual dashboard scene.</td>
<td>The visual project’s data is corrupted.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RPT00048</td>
<td>Unable to serialize object {0}.</td>
<td>An internal error occurred.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RPT00049</td>
<td>Internal serialization error: no tag for {0} object class.</td>
<td>The tag description for the indicated class could not be found during the serialization process.</td>
<td>Reinstall QMF.</td>
</tr>
<tr>
<td>RPT00050</td>
<td>Unknown parameter type.</td>
<td>An unknown parameter type was encountered during the serialization process.</td>
<td>Reload the visual project.</td>
</tr>
<tr>
<td>RPT00051</td>
<td>Invalid action type.</td>
<td>An unknown action type was encountered while loading the visual project.</td>
<td>Reload the visual project.</td>
</tr>
</tbody>
</table>
RPT00052 Embedded visual dashboard picture is corrupted.
Explanation: An embedded image in the visual dashboard is corrupted and can not be opened.
User response: Check all of the embedded images in the visual dashboard and delete any that are corrupted.

RPT00053 Invalid color value.
Explanation: Corrupted tags were encountered while loading a ColorMap or a ColorSequence.
User response: Reload the visual project.

RPT00054 Invalid threshold value for color map.
Explanation: Corrupted tags were encountered while loading a ColorMap or a ColorSequence.
User response: Reload the visual project.

RPT00055 Invalid event type.
Explanation: An unknown event type was encountered.
User response: Reload the visual project.

RPT00056 Missing image alias.
Explanation: An unknown image was found.
User response: Reload the visual project.

RPT00057 Invalid number value.
Explanation: While loading the visual project, a string that was supposed to contain a number value was encountered without digit characters.
User response: Reload the visual project or try using a different locale.

RPT00058 Invalid date value.
Explanation: While loading the visual project, a string that was supposed to contain a date value was encountered with characters that could not be parsed into a date value.
User response: Reload the visual project or try using a different locale.

RPT00059 Invalid point value.
Explanation: While loading the visual project, a string that was supposed to contain a point value was encountered with characters that could not be parsed into a point value.
User response: Reload the visual project.

RPT00060 Unable to read visual dashboard.
Explanation: An error occurred while loading the visual dashboard.
User response: Reload the visual dashboard.

RPT00061 (Multiple possible messages; see Explanation)
Explanation:
1. Missing query alias. - A query with no query name tag was encountered while loading the visual project.
2. The offline visual report cannot be saved in file. - Offline visual reports can not be saved to a file.
User response:
1. Reload the visual project.
2. Convert the visual report to an online report before saving to a file.

RPT10001 Source Visionary World file has not been specified.
Explanation: The Visionary World file can not be found.
User response: Ensure that the Visionary World file exists and that it can be read.

RPT10002 Configuration directory has not been specified.
Explanation: The configuration directory for the converter can not be found.
User response: Reinstall QMF.

RPT10003 Source Visionary World file has not been found.
Explanation: The Visionary World file can not be found.
User response: Ensure that the Visionary World file exists.

RPT10004 Configuration directory has not been found.
Explanation: The configuration directory for the converter can not be found.
User response: Reinstall QMF.

RPT10005 Configuration file {0} has not been found.
Explanation: The configuration file for the converter can not be found.
User response: Reinstall QMF.
Unable to locate Visionary Connection file(s) in the folder {0}.
Explanation: The Visionary Connection files do not exist in the proper locations.
User response: Check that all Visionary World files are saved in the correct locations.

Unable to read Visionary Query file {0}.
Explanation: The Visionary World file that is specified in the query cannot be found.
User response: Check that all Visionary World files are saved in the correct locations.

Unable to locate Visionary Scene file {0}.
Explanation: The indicated scene file is not saved in the correct location.
User response: Check that all Visionary World files are saved in the correct locations.

Unable to read an image file {0}.
Explanation: The image file that is specified by the indicated name cannot be found.
User response: Check that all Visionary World files are saved in the correct locations.

Picture file {0} is too large.
Explanation: The indicated picture file is too long.
User response: Specify a smaller picture file to be used in the visual project.

XML parsing error.
Explanation: An XML parsing error occurred while attempting to convert the Visionary World.
User response: Save the Visionary World file in Visionary and try again.

XML reading error.
Explanation: An input/output error occurred while attempting to read the XML data.
User response: Try to convert the XML data again.

Unable to create Visual Dashboard object.
Explanation: An error occurred while attempting to convert the Visionary World file.
User response: Try to convert the Visionary World file again.

Cannot parse configuration file {0}.
Explanation: An error occurred while attempting to parse the converter configuration files.
User response: Reinstall QMF.

Visual Dashboard for a connection is not specified.
Explanation: The Visionary World file was not loaded properly.
User response: Reload the Visionary World file.

Invalid color description has been found.
Explanation: Corrupted tags were encountered while loading a ColorMap or ColorSequence.
User response: Reload the Visionary World file.

Invalid color map description has been found.
Explanation: Corrupted tags were encountered while loading a ColorMap.
User response: Reload the Visionary World file.

Unknown tag: {0}
Explanation: Unknown tags were encountered while attempting to convert the Visionary World file.
User response: Try to convert the Visionary World file again.

Invalid scene template description.
Explanation: An error occurred while loading the Visionary World scene file.
User response: Reload the Visionary World scene file.

Corrupted property value has been found.
Explanation: An incorrect format or a corrupted value was specified in a property tag.
User response: Reload the Visionary World file.

Invalid URL or path format: "{0}"
Explanation: The indicated URL or path format is invalid.
User response: Check the URL for errors or specify a different URL.
<table>
<thead>
<tr>
<th>RPT10022</th>
<th>Unknown or unsupported event type</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>A corrupted or unknown event type was encountered.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10023</th>
<th>Function name in expression is missing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>A function name in an expression is missing.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10024</th>
<th>Cannot parse function argument</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The function argument could not be parsed while loading the Visionary World file.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10025</th>
<th>Invalid scene template description.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An error occurred while loading the Visionary World scene file.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10026</th>
<th>Unable to parse a number: {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>While loading the Visionary World file, a string that was supposed to contain a number value was encountered without digit characters.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10027</th>
<th>PointSet component XML is corrupted.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>While loading the Visionary World file, a string that was supposed to contain a point value was encountered with characters that could not be parsed into PointSet value.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10028</th>
<th>Unknown expression type {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An unknown expression type was encountered while loading the Visionary World file.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10029</th>
<th>One or more queries do not have alias.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>A query alias tag that does not contain a name property was encountered while converting the Visionary World file.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10031</th>
<th>Unable to parse a point value.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>While loading the Visionary World file, a string that was supposed to contain a point value was encountered with characters that could not be parsed into PointSet value.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10032</th>
<th>Visionary World XML has been corrupted.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An error occurred while attempting to load the Visionary World file.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the Visionary World file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10033</th>
<th>Internal error: unable to access Visionary World.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT10034</th>
<th>Unable to add parameter {0} to a Visual Dashboard</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT20001</th>
<th>Unable to access repository during Visual Report conversion.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The repository could not be accessed while the Visual Report was being converted.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>This could possibly be because you were not connected to the repository. Make sure you are connected and try again.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT20002</th>
<th>Source visual report file has not been specified.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The source visual report file has not been specified.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the source visual report file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT20003</th>
<th>Source visual report file has not been found.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The source visual report file could not be found.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify a valid source visual report file.</td>
</tr>
<tr>
<td>Code</td>
<td>Message</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>RPT20004</td>
<td>Visual Report name has not been specified.</td>
</tr>
<tr>
<td>RPT20005</td>
<td>Unable to create visual report.</td>
</tr>
<tr>
<td>RPT20006</td>
<td>Unable to open an embedded image.</td>
</tr>
<tr>
<td>RPT20007</td>
<td>Unknown section type: {0}</td>
</tr>
<tr>
<td>RPT20008</td>
<td>Unable to create Visual Report page component.</td>
</tr>
<tr>
<td>RPT20009</td>
<td>Internal error: unable to access Visual Report.</td>
</tr>
<tr>
<td>RPT20011</td>
<td>Unable to set a line style for a line control.</td>
</tr>
<tr>
<td>RPT20012</td>
<td>Invalid linked picture alias has been found in Visual Report.</td>
</tr>
<tr>
<td>RPT20013</td>
<td>Unable to create Visual Report control.</td>
</tr>
<tr>
<td>RPT20015</td>
<td>Invalid parameter name &quot;{0}&quot; has been found.</td>
</tr>
<tr>
<td>RPT20016</td>
<td>Invalid parameter value &quot;{0}&quot; has been found.</td>
</tr>
<tr>
<td>RPT30001</td>
<td>Navigate to Embedded Scene: Embedded Scene not found for name &quot;{0}&quot;.</td>
</tr>
<tr>
<td>RPT30002</td>
<td>Navigate back: can’t execute exit action (maybe history is empty).</td>
</tr>
<tr>
<td>RPT30021</td>
<td>DesignReporter: LevelTemplate is null.</td>
</tr>
<tr>
<td>RPT30022</td>
<td>DesignReporter: unknown component {0}.</td>
</tr>
<tr>
<td>Code</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>RPT30024</td>
<td>The template is invalid. FillStyle or LineStyle property is null!</td>
</tr>
<tr>
<td>RPT30025</td>
<td>The template is invalid. Height == 0!</td>
</tr>
<tr>
<td>RPT30026</td>
<td>The template is invalid. Width == 0!</td>
</tr>
<tr>
<td>RPT30028</td>
<td>Cannot load resources for package 0 and locale 1.</td>
</tr>
<tr>
<td>RPT30029</td>
<td>Request for resource string &quot;(0)&quot; from package 1 failed.</td>
</tr>
<tr>
<td>RPT30035</td>
<td>No OutputComponentCreator in map for 0.</td>
</tr>
<tr>
<td>RPT30038</td>
<td>Could not find 0.</td>
</tr>
<tr>
<td>RPT30040</td>
<td>Chart cannot read query result set.</td>
</tr>
<tr>
<td>RPT30042</td>
<td>Error - axisLength is infinite. totalPercentages:(0) m_sceneRuntimePanel.getZoomFactor() (1)</td>
</tr>
<tr>
<td>RPT30044</td>
<td>Unknown checkbox value: 0.</td>
</tr>
<tr>
<td>RPT30045</td>
<td>Unknown m_style: 0.</td>
</tr>
<tr>
<td>RPT30047</td>
<td>Line is not horizontal or vertical.</td>
</tr>
<tr>
<td>RPT30048</td>
<td>Unsupported segment type: 0.</td>
</tr>
<tr>
<td>RPT30049</td>
<td>Could not get corner type last: 0 start: 1 end: 2.</td>
</tr>
<tr>
<td>RPT30050</td>
<td>Should not have gotten here.</td>
</tr>
</tbody>
</table>

278 Installing and Managing QMF for Workstation and QMF for WebSphere
RPT30052  Unknown horizontal align: [0].
Explanation: A value other than LEFT, RIGHT, or CENTER was encountered in the HorizontalAlign property of an object.
User response: Ensure that any action that sets the value of the HorizontalAlign property of an object sets it as LEFT, RIGHT, or CENTER.

RPT30053  Unknown vertical align: [0].
Explanation: A value other than TOP, BOTTOM, or CENTER was encountered in the VerticalAlign property of an object.
User response: Ensure that any action that sets the value of the VerticalAlign property of an object sets it as TOP, BOTTOM, or CENTER.

RPT30054  Unknown location anchor: [0].
Explanation: A value other than BOTTOMLEFT, LEFTCENTER, TOPLEFT, BASELINELEFT, BOTTOMCENTER, CENTER, TOPCENTER, BASELINECENTER, BOTTOMRIGHT, CENTER TOPRIGHT, or BASELINERIGHT was encountered in the LocationAnchor property of an object.
User response: Ensure that any action that sets the value of the LocationAnchor property of an object sets it as BOTTOMLEFT, LEFTCENTER, TOPLEFT, BASELINELEFT, BOTTOMCENTER, CENTER, TOPCENTER, BASELINECENTER, BOTTOMRIGHT, CENTER TOPRIGHT, or BASELINERIGHT.

RPT30055  Unknown arrowheadStyle: [0].
Explanation: A value other than NONE, TRIANGLE, CIRCLE, DIAMOND, or SWEPTPOINTER was encountered in the MarkerShape property of an arrow object.
User response: Ensure that any action that sets the value of the MarkerShape property of an arrow object sets it as NONE, TRIANGLE, CIRCLE, DIAMOND, or SWEPTPOINTER.

RPT30056  Unknown marker shape: [0].
Explanation: A value other than HOLLOWCIRCLE, HOLLOWDIAMOND, HOLLOWCROSS, HOLLOWTRIANGLE, HOLLOWDIAMOND2, HOLLOWCROSS2, HOLLOWTRIANGLE2, HOLLOWSTAR, HOLLOWPLUS, SOLIDCIRCLE, SOLIDDIAMOND, SOLIDCROSS, SOLIDTRIANGLE, SOLIDTRIANGLE2, SOLIDSTAR, SOLIDPLUS, CROSS, PLUS, BOXCROSS, or BOXPLUS was encountered in the MarkerShape property of a data point object.
User response: Ensure that any action that sets the value of the MarkerShape property of a data point object sets it as HOLLOWCIRCLE, HOLLOWDIAMOND, HOLLOWCROSS, HOLLOWTRIANGLE, HOLLOWDIAMOND2, HOLLOWCROSS2, HOLLOWTRIANGLE2, HOLLOWSTAR, HOLLOWPLUS, SOLIDCIRCLE, SOLIDDIAMOND, SOLIDCROSS, SOLIDTRIANGLE, SOLIDTRIANGLE2, SOLIDSTAR, SOLIDPLUS, CROSS, PLUS, BOXCROSS, or BOXPLUS.

RPT30060  Unknown attachmentStyle: [0].
Explanation: A value other than TOLEFT, TOPCENTER, TOP, TOPRIGHT, CENTERLEFT, CENTER, CENTERRIGHT, BOTTOMLEFT, BOTTOMCENTER, BOTTOM, or BOTTOMRIGHT was encountered in the AttachmentStyle property of a connector object.
User response: Ensure that any action that sets the value of the AttachmentStyle property of a connector object sets it as TOLEFT, TOPCENTER, TOP, TOPRIGHT, CENTERLEFT, CENTER, CENTERRIGHT, BOTTOMLEFT, BOTTOMCENTER, BOTTOM, or BOTTOMRIGHT.

RPT30061  Unknown border type for table: [0].
Explanation: An invalid value was encountered in the BorderType property of an object.
User response: Ensure that any action that sets the BorderType property of an object sets a valid value.

RPT30062  Unknown m_horizontalAlign: [0].
Explanation: An invalid value was encountered in the HorizontalAlign property of a table cell.
User response: Ensure that any action that sets the HorizontalAlign property of a table cell sets a valid value.

RPT30063  Unknown m_verticalAlign: [0].
Explanation: An invalid value was encountered in the VerticalAlign property of a table cell.
User response: Ensure that any action that sets the VerticalAlign property of a table cell sets a valid value.

RPT30064  Unknown border type for table: [0].
Explanation: An invalid value was encountered in the Border property of a table.
User response: Ensure that any action that sets the Border property of a table sets a valid value.

RPT30065  Unknown scrollBarStyle: [0].
Explanation: An invalid value was encountered in the ScrollBarStyle property of an object.
User response: Ensure that any action that sets the ScrollBarStyle property of an object sets a valid value.

RPT30066  Unknown AlignmentStyle: [0].
Explanation: An invalid value was encountered in the AlignmentStyle property of a textbox object.
User response: Ensure that any action that sets the AlignmentStyle property of a textbox object sets a valid value.
<table>
<thead>
<tr>
<th>RPT30068</th>
<th>Unknown lineStylePattern: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was encountered in the LineStylePattern property of an object.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any action that sets the LineStylePattern property of an object sets a valid value.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30069</th>
<th>Unknown gradient type: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was encountered in the GradientType property of an object.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any action that sets the GradientType property of an object sets a valid value.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30070</th>
<th>Unknown borderType: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was encountered in the BorderType property of a textbox or embedded scene object.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any action that sets the BorderType property of a textbox or embedded scene object sets a valid value.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30071</th>
<th>Unknown imageAnchor: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was encountered in the ImageAnchor property of an object.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any action that sets the ImageAnchor property of an object sets a valid value.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30072</th>
<th>Embedded Scene: Unknown scrollBarStyle.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An invalid value was encountered in the ScrollBarStyle property of an embedded scene object.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that any action that sets the ScrollBarStyle property of an embedded scene object sets a valid value.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30073</th>
<th>Embedded Scene: unknown typeOfFind: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30074</th>
<th>The cell chosen by client not found.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The action can not be performed when using the HTML rendering mode.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the visual project.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30077</th>
<th>Grid cell's click event could not be dispatched.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The action can not be performed when using the HTML rendering mode.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Reload the visual project.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30079</th>
<th>Unknown page type - {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer service.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30082</th>
<th>Parameters group cloning problem {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30083</th>
<th>No class in map for {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30088</th>
<th>Unable to serialize an object: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>An internal error occurred.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30089</th>
<th>Value must be positive: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The indicated value must be a positive number.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that the indicated value is a positive number.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30090</th>
<th>Level was null when zoom was {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>No level is specified for the indicated zoom percentage.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that a level is specified for the indicated zoom percentage.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RPT30091</th>
<th>Chart can't find parent column: {0}.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The indicated parent column could not be found in the result set.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Ensure that a valid column named is specified in the DataLocator property of the group.</td>
</tr>
</tbody>
</table>
RPT30092  Chart can't find child column: {0}.
Explanation: The indicated child column could not be found in the result set.
User response: Ensure that a valid column named is specified in the DataLocator property of the group.

RPT30095  Hierarchy chart must have one DataTemplate child.
Explanation: A hierarchy chart must have one DataTemplate child.
User response: Check the Project Explorer and ensure that the hierarchy chart only has one DataTemplate child.

RPT30096  CurrentRowIndex < 0.
Explanation: The specified row index is less than zero. The row index must be an integer that is equal to or greater than zero.
User response: Ensure the specified row index is an integer that is equal to or greater than zero.

RPT30097  Unknown interval: {0}.
Explanation: An invalid value was specified for the DateAxis property of an object.
User response: Ensure that any action that sets the value of the DateAxis property of an object sets a valid value.

RPT30098  Unhandled interval: {0}.
Explanation: An invalid value was specified for the DateAxis property of an object.
User response: Ensure that any action that sets the value of the DateAxis property of an object sets a valid value.

RPT30099  Unknown dateInterval: {0}.
Explanation: An invalid value was specified for the DateAxis property of an object.
User response: Ensure that any action that sets the value of the DateAxis property of an object sets a valid value.

RPT30104  Shouldn't get here - roundIncrement: {0} power: {1}.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30105  Group name is undefined for group header.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30106  Group name is undefined for group footer.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30107  m_templateRows contained a {0}.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30109  Embedded Scene: Linked not found for name {0}.
Explanation: The value of the LinkedScene property of an embedded scene is invalid.
User response: Ensure that the scene that the embedded scene is linked to exists and that the link text is correct.

RPT30111  Unable to clone component {0}.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30112  Property {0} of component {1} doesn't appear to be of type {2}.
Explanation: The property of the indicated object is of an invalid type.
User response: Ensure that any action or expression that sets the value of the property sets it to a valid type.

RPT30114  Swing output cannot be created for component {0}.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.
RPT3017  Component {0} does not support action {1}.
Explanation: The indicated component does not support the indicated action.
User response: Specify a different action for the component and try again.

RPT3018  Component {0} does not support property {1}.
Explanation: The indicated component does not support the indicated property.
User response: Specify a different property and try again.

RPT30120  *(Multiple possible messages; see Explanation)*
Explanation: 1. The global parameter "{0}" does not exist - The indicated global parameter does not exist.
2. Query "{0}" does not contain column named "{1}" - The indicated column does not exist in the indicated query.
User response: 1. Check the global parameter name for errors or specify a different global parameter.
2. Check the column name for errors or specify a different column name.

RPT30121  Result set index "{0}" for query "{1}" is out of bounds.
Explanation: An invalid value was set for the ResultSetIndex of a layout object.
User response: Ensure that any action that sets the ResultSetIndex property of a layout object sets a valid value.

RPT30122  Query with key "{0}" does not exist.
Explanation: A query with the indicated key does not exist in the repository.
User response: Select the query in the Repository Explorer or Workspaces view and copy and paste the key value from the Properties view, or specify a different query’s key.

RPT30123  Component "{0}" cannot be created due to the following problem: {1}
Explanation: The indicated component cannot be created due to the indicated error.
User response: Resolve the indicated error and try again.

RPT30124  Result set index cannot be defined.
Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

RPT30126  Security list "{0}" cannot be found.
Explanation: The indicated security list cannot be found.
User response: Check the security list name for errors or specify a different security list.

RPT30127  Visual project "{0}" cannot be loaded because of missing project descriptor.
Explanation: The indicated visual project cannot be loaded because it is missing a project descriptor.
User response: Ensure that the visual project has a project descriptor and retry to load the project.

RSE01000  {0}
Explanation: The indicated error occurred while accessing the repository security provider.
User response: Resolve the indicated error and try again.

RSE04000  System internal error occurred, please check the error log.
Explanation: A system internal error occurred.
User response: Check the error log by selecting Output from the context menu of the Window menu.

RSE04001  Cannot find User {0}
Explanation: The indicated user cannot be found.
User response: Check the name of the user for errors and try again.

RSE04002  User {0} already exists;
Explanation: The indicated user already exists.
User response: Specify a different user.

RSE04003  Group {0} already exists;
Explanation: The indicated group already exists.
User response: Specify a different group.
### RSE04004
**Cannot find group** {0}

**Explanation:** The indicated group cannot be found.

**User response:** Specify a different group.

### RSE04005
**Not logged in with security provider.**

**Explanation:** You attempted to access the repository without logging in.

**User response:** Login to the repository and try again.

### RSE04006
**The user ID and password are invalid**

**Explanation:** The user ID and password that were entered are invalid.

**User response:** Check the user ID and password for errors and try again.

### RSE04007
**Name** "{0}" **is in conflict with the existing name.**

**Explanation:** The new name that was entered already exists.

**User response:** Select a different name.

### RSE04008
**Object access denied**

**Explanation:** Access to the specified object is denied.

**User response:** Select a different object to access or contact your administrator for more information.

### RSE04011
**Cannot remove User** {0} **from Group** {1}

**Explanation:** The indicated user cannot be removed from the indicated group.

**User response:** Select another user to be removed from the group.

### RSE04012
**Cannot delete User** {0}

**Explanation:** The indicated user cannot be deleted.

**User response:** Select another user to be deleted.

### RSE04013
**Cannot delete Group** {0}

**Explanation:** The indicated group cannot be deleted.

**User response:** Select another group to be deleted.

### RSE04014
**Cannot initialize security provider,** {0}

**Explanation:** The indicated error occurred while initializing the repository.

**User response:** Resolve the indicated error and try again.

### RSE04015
**This security provider is a read-only one.**

**Explanation:** You cannot change the principals of a read-only security provider.

**User response:** Choose another security provider to modify.

### RSE04016
**Cannot find any name associates with UID** {0} **in Repository**

**Explanation:** The indicated repository identifier is invalid.

**User response:** Specify a valid repository identifier and try again.

### RSE04017
**AuthType is not anonymous("none"), please specify principal and credentials**

**Explanation:** An error occurred while initializing the LDAP security provider.

**User response:** Change the repository initialization parameters and try again.

### RSE04018
**LDAP Configuration contains illegal values or some required values are missing, please check the preferences({0})**

**Explanation:** An error occurred while initializing the LDAP security provider.

**User response:** Change the repository initialization parameters and try again.

### RSE04019
**Cannot connect to the LDAP server. Communication broken or Directory Service is not available.**

**Explanation:** An error occurred while connecting to the LDAP directory.

**User response:** Check the network connection and try again.

### RSE04020
**Cannot read User's password attribute (Make sure you have enough permission or PasswordAttribute in configuration is correct.)**

**Explanation:** An error occurred while reading data from the LDAP directory.

**User response:** Ensure that the LDAP service is accessible.
<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation</th>
<th>User response</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSE04021</td>
<td>Invalid search filter in LDAP configuration</td>
<td>The specified search filter in the LDAP configuration is invalid.</td>
<td>Specify a valid search filter for the LDAP configuration.</td>
</tr>
<tr>
<td>RSE04022</td>
<td>LDAP server returned error</td>
<td>An error occurred while reading data from the LDAP directory.</td>
<td>Ensure that the LDAP service is accessible.</td>
</tr>
<tr>
<td>RSE04023</td>
<td>Cannot find the specified name {0}</td>
<td>The indicated user name can not be found.</td>
<td>Specify a different user name.</td>
</tr>
<tr>
<td>RSE04024</td>
<td>Not enough permission to perform the LDAP operations.</td>
<td>You user ID does not have permission to perform LDAP operations.</td>
<td>Contact your administrator for more information concerning specific permissions and allowances.</td>
</tr>
<tr>
<td>RSE04025</td>
<td>Cannot find a attribute of entry {0} specified in LDAP configurations</td>
<td>An error occurred while reading attribute data from the LDAP configuration.</td>
<td>Correct the configuration parameters and try again.</td>
</tr>
<tr>
<td>RSE04026</td>
<td>UUID {0} mapping to an invalid distinguished name {1}.{(2)}</td>
<td>The indicated distinguished name is invalid.</td>
<td>Specify a valid distinguished name and try again.</td>
</tr>
<tr>
<td>RSE04028</td>
<td>Incorrect operation.</td>
<td>An error occurred while editing the principals of the security provider.</td>
<td>Collect support data by selecting Help &gt; Collect Support Data and forward it to customer support.</td>
</tr>
<tr>
<td>RSE04029</td>
<td>Cannot register security provider.</td>
<td>An error occurred while registering the security provider in the provider registry.</td>
<td>Ensure that the registered name of the provider is unique.</td>
</tr>
<tr>
<td>RSE04030</td>
<td>Security provider not initialized.</td>
<td>An error occurred while accessing the security provider service because the service is not initialized.</td>
<td>Initialize the security provider and try again.</td>
</tr>
<tr>
<td>RSE04031</td>
<td>Security provider not registered.</td>
<td>An error occurred while accessing the security provider because the security provider is not registered.</td>
<td>Register the security provider and try again.</td>
</tr>
<tr>
<td>RSE04032</td>
<td>You can not remove default Administrator.</td>
<td>The default administrator can not be deleted.</td>
<td>Specify a different administrator to be deleted.</td>
</tr>
<tr>
<td>RSE04033</td>
<td>You can not change the default Administrator's membership.</td>
<td>The membership of the default administrator can not be changed.</td>
<td>Specify the membership of a different administrator to change.</td>
</tr>
<tr>
<td>RSE04035</td>
<td>You can not rename the Administrators group.</td>
<td>The group of the default administrator can not be renamed.</td>
<td>Specify the group of a different administrator to be renamed.</td>
</tr>
<tr>
<td>RSE04036</td>
<td>Password has expired and is no longer valid.</td>
<td>The specified password has expired and is no longer valid.</td>
<td>Specify an updated password and try again.</td>
</tr>
<tr>
<td>SPL01001</td>
<td>Cannot find objectClass attribute of {0}</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---------</td>
<td>-------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Explanation:</strong></td>
<td>The indicated object does not have an objectClass attribute. Every object in the LDAP directory must contain this attribute.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify an objectClass attribute for the indicated object.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01002</th>
<th>The returned entry {0} is not acceptable for LDAP Security Provider, its objectClass is not {1} or {2}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The indicated object is defined as neither a user or group in the LDAP security provider.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Edit the objectClass attribute of the indicated object to specify whether it is a user or group.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01003</th>
<th>Cannot read the Group's name (attribute: {0})</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The LDAP directory does not contain an object that has the required attribute.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Edit the groupName attribute so that it will point to an existing object in the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01004</th>
<th>Cannot read the User's name (attribute: {0})</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The LDAP directory does not contain an object that has the required attribute.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Edit the userName attribute so that it will point to an existing object in the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01005</th>
<th>LDAP server host or port was not specified.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The LDAP server host or port was not specified.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the LDAP server and host.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01006</th>
<th>The base distinguished name of the LDAP server must be present.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The base distinguished name of the LDAP server was not specified.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the base distinguished name of the LDAP server.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01007</th>
<th>The distinguish name of user principal must be present.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The distinguished name of the principal user was not specified.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the distinguished name of the principal user or use anonymous authentication.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01008</th>
<th>The credentials of user entry must be specified.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The credentials of the entry user were not specified.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the credentials of the entry user or use anonymous authentication.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01009</th>
<th>Cannot create LDAP entry for administrator user: {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The user who is associated with the administrative account could not be found in the LDAP directory.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the administrative user of the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01010</th>
<th>Cannot create LDAP entry for administrators group: {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The group that is associated with the administrative account could not be found in the LDAP directory.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the administrative group of the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01011</th>
<th>Cannot create LDAP entry for everyone group: {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The group that is associated with the everyone account could not be found in the LDAP directory.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the everyone group of the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01012</th>
<th>Cannot create LDAP entry for root group: {0}</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The object that is associated with the Base DN could not be found in the LDAP directory.</td>
</tr>
<tr>
<td><strong>User response:</strong></td>
<td>Specify the Base DN object in the LDAP directory.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPL01013</th>
<th>Cannot find the JNDI extension package or Sun's LDAP Service Provider.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explanation:</strong></td>
<td>The JNDI extension package or Sun's LDAP Service Provider was not located in the CLASSPATH.</td>
</tr>
</tbody>
</table>
User response: Ensure that the CLASSPATH includes both the JNDI extension package and Sun's LDAP Service Provider.

**SPL01014**  The catalog object is missing.
Explanation: The catalog object is not set.
User response: Specify the catalog object and try again.

**SPL01015**  Empty name is not allowed.
Explanation: No name was specified as an RDN.
User response: Specify a name as an RDN.

**SPL01016**  Illegal RDN of security object (offending string: "[0]")
Explanation: The RDN is invalid. The RDN must be one or more LDAP components that are separated by commas.
User response: Specify valid components for the RDN.

**SPL01017**  Unknown attribute name "[0]" in RDN.
Explanation: An unknown attribute name was encountered while parsing the RDN.
User response: Check the attributes of the RDN for errors.

**SPL01101**  Currently Client Authentication is not supported.
Explanation: Client Authentication is not supported.
User response: Use anonymous authentication.

**SPL01103**  SSL is not correctly initialized.
Explanation: The secure socket protocol factory is not initialized.
User response: Restart the application and try again.

**SPL01104**  Attribute [0] is absent.
Explanation: The indicated attribute was not found while reading the LDAP object.
User response: Specify a valid value for the indicated attribute.

**SPL01105**  Object class name "[0]" is unknown.
Explanation: The object name has an invalid class name; it must be either qmfUser or qmfGroup.
User response: Specify either qmfUser or qmfGroup for the indicated object name.

**SQM02001**  An input/output error occurred while processing package "[0]". [1]
Explanation: The indicated error occurred while processing the indicated package.
User response: Resolve the indicated error and try again.

**SQM02002**  Error in SQLJ customization: [0]
Explanation: The indicated error occurred while processing the SQLJ customization.
User response: Resolve the indicated error and try again.

**SQM02003**  No SQLJ installed
Explanation: The SQLJ library could not be loaded.
User response: Add sqlj.zip to the driver definition.

**SQM02004**  An error occurred while retrieving profile data for package "[0]". [1]
Explanation: The indicated error occurred while the profile data for the indicated package was being loaded.
User response: Resolve the indicated error and try again.

**SQM02005**  An error occurred while loading the profile for package "[0]".
Explanation: The indicated error occurred while the profile for the indicated package was being loaded.
User response: Resolve the indicated error and try again.

**SQM02006**  While loading the class with the implementation of package "[0]" the following error has occurred: "[1]."
Explanation: The indicated error occurred while class with the implementation of the indicated package was being loaded.
User response: Reinstall the application and try again.

**SQM02007**  A database access error occurred while processing package "[0]". [1]
Explanation: The indicated database access error occurred while the package was being processed.
User response: Resolve the indicated database access error and try again.
SQM0208 A database access error occurred: {1}
Explanation: The indicated database access error occurred.
User response: Resolve the indicated error and try again.

SQM0209 User has no rights to execute queries of package "{0}". Original error follows: {1}
Explanation: The user does not have permission to access the package because of the indicated reason.
User response: Contact your database administrator.

SQM0210 An error occurred while deleting profile for package "{0}". {1}
Explanation: The indicated error occurred while the profile for the indicated package was being deleted.
User response: Resolve the indicated error and try again.

SQM0211 Empty customizer call pattern
Explanation: Package customization failed because of an unexpected error.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM0213 An error occurred while loading data for package "{0}".
Explanation: An error occurred while the data for the indicated package was being loaded.
User response: Resolve the indicated error and try again.

SQM0214 Wrong customizer call pattern: {0}
Explanation: Package customization failed because of an unexpected error.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM0216 Cannot create collection "{0}" due to the following: {1}
Explanation: The indicated collection could not be created due to the indicated error.
User response: Resolve the indicated error and try again.

SQM0217 Profile for package "{0}" is too long to be stored at database
Explanation: The profile for the indicated package is too long to be stored at the database.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM0218 No collection ID (profile owner) is specified. Cannot proceed in static mode.
Explanation: The SQLJ package can not be loaded if no collection ID is specified.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM0219 Cannot prepare statement "{0}" of package "{1}" due to the following error: "{2}"
Explanation: The indicated statement of the package can not be prepared due to the indicated error.
User response: Resolve the indicated error and try again.

SQM0220 While checking user rights on package "{0}" the following error has occurred: "{1}"
Explanation: The indicated error occurred while the user rights on the indicated package were checked.
User response: Resolve the indicated error and try again.

SQM0221 Inconsistent profile data for queries package "{0}" were detected. Rebind package.
Explanation: Inconsistent profile data for the indicated queries package was detected.
User response: Rebind the package.

SQM02100 The required parameter "{0}" is missing.
Explanation: The indicated required parameter is missing.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.
SQM02101  An error occurred while initializing the connection. [0]
Explanation: The indicated error occurred while the connection was initialized.
User response: Resolve the indicated error and try again.

SQM02102  [0]
Explanation: The indicated database access error occurred.
User response: Resolve the indicated error and try again.

SQM02103  An error occurred while loading package description class "[0]". [1]
Explanation: The indicated error occurred while the package description class was loaded.
User response: Resolve the indicated error and try again.

SQM02104  An error occurred while loading the profile for package "[0]". [1]
Explanation: The indicated error occurred while the profile for the indicated package was loaded.
User response: Resolve the indicated error and try again.

SQM02105  Static mode profile for package "[0]" is not found.
Explanation: The static mode for the indicated package was not found.
User response: Reinstall the application and try again.

SQM02106  An error occurred while creating directory "[0]".
Explanation: The temporary directory for the customization process could not be created.
User response: Ensure that the application has permissions to create the directory and try again.

SQM02107  An error occurred while creating profiles directory "[0]".
Explanation: An error occurred while the indicated profile's directory was created.
User response: Ensure that the application has permissions to create the directory and try again.

SQM02108  An error occurred while saving the profile for package "[0]". [1]
Explanation: The indicated error occurred while the profile for the indicated package was saved.
User response: Resolve the error and try again.

SQM02109  An error occurred while saving the packages description file. [0]
Explanation: The indicated error occurred while the package description file was saved.
User response: Resolve the error and try again.

SQM02110  An error occurred while starting customization. [0]
Explanation: The indicated error occurred while customization was started.
User response: Resolve the error and try again.

SQM02111  An error occurred while customizing package "[0]". [1]
Explanation: The indicated error occurred while the indicated package was customized.
User response: Resolve the indicated error and try again.

SQM02112  An error occurred while creating the profiles data table. [0]
Explanation: The indicated error occurred while the data table of the profile was created.
User response: Resolve the indicated error and try again.

SQM02113  No user ID list for GRANT/REVOKE operation was specified.
Explanation: No user ID list for GRANT/REVOKE operation was specified.
User response: Specify a user ID list for the GRANT/REVOKE operation.

SQM02115  An error occurred while uninstalling the packages. [0]
Explanation: The indicated error occurred while the packages were uninstalled.
User response: Resolve the indicated error and try again.
SQM02116  File with packages description was not found. [0]
Explanation:  The indicated error occurred while preparing the packages descriptions based on the previously build packages description file.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM02117  An error occurred while reading the packages description file. [0]
Explanation:  The indicated error occurred while the packages description file was being read.
User response:  Collect support data by selecting Help > Collect Support Data and forward it to customer support.

SQM02119  An error occurred while installing the package [0]. [1]
Explanation:  The indicated error occurred when the indicated package was being installed.
User response:  Resolve the indicated error and try again.

SQM02120  An error occurred while uninstalling the package [0]. [1]
Explanation:  The indicated error occurred when the indicated package was being uninstalled.
User response:  Resolve the indicated error and try again.

SYNERRCD0001  DSS header length less than 6.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0002  DSS header length does not match the number of bytes of data found.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0003  DSS header C-byte not D0.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0004  DSS header f-bytes either not recognized or not supported.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0005  DSS continuation specified but not found.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0006  DSS chaining specified but no DSS found.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0007  Object length less than four.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0008  Object length does not match the number of bytes of data found.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0009  Object length greater than maximum allowed.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0010  Object length less than minimum required.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.

SYNERRCD0011  Object length not allowed.
Explanation:  An internal error in the driver code occurred.
User response:  Send an error report to the developers.
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
<th>Explanation</th>
<th>User Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYNERRCD0012</td>
<td>Incorrect large object extended length field.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0013</td>
<td>Object codepoint index not supported.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0014</td>
<td>Required object not found.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0015</td>
<td>Too many command data objects sent.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0016</td>
<td>Mutually-exclusive objects present.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0017</td>
<td>Too few command data objects sent.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0018</td>
<td>Duplicate object present.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0019</td>
<td>Invalid request correlator specified.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0020</td>
<td>Required value not found.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0021</td>
<td>Reserved value not allowed.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0022</td>
<td>DSS continuation less than or equal to two.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0023</td>
<td>Objects not in required order.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0024</td>
<td>DSS chaining bit not 1, but DSSFMT bit 3 set to 1.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0025</td>
<td>Previous DSS indicated current DSS has the same request correlator, but the request correlators are not the same.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0026</td>
<td>Previous DSS indicated current DSS has the same request correlator, but the request correlators are not the same.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
<tr>
<td>SYNERRCD0027</td>
<td>DSS chaining bit not 1, but error continuation requested.</td>
<td>An internal error in the driver code occurred.</td>
<td>Send an error report to the developers.</td>
</tr>
</tbody>
</table>

290 Installing and Managing QMF for Workstation and QMF for WebSphere
SYNERRCD0028  Mutually-exclusive parameter values specified.
Explanation: An internal error in the driver code occurred.
User response: Send an error report to the developers.

SYNERRCD0029  Codepoint not valid command.
Explanation: An internal error in the driver code occurred.
User response: Send an error report to the developers.

SYNERRCD0030  The atmind instance variable is not set to its default value of 0x00 on an EXCSQLSTT command within an atomic EXCSQLSTT chain.
Explanation: An internal error in the driver code occurred.
User response: Send an error report to the developers.

THM1001  Cannot copy CSS file.
Explanation: The CSS file could not be copied to the server.
User response: Ensure that the CSS file name is correct and try again.

THM1002  Cannot extract main theme CSS file from the archive.
Explanation: The specified archive does not contain the main CSS file.
User response: Ensure that the main CSS file is saved to the archive and try again.

THM1003  Already registered. Try another theme name.
Explanation: A theme with the same name already exists.
User response: Specify a different name for the theme.

THM1004  Theme root folder already exists. Try another theme name.
Explanation: A theme with the same name already exists.
User response: Specify a different name for the theme.

UIM12001  Internal error has occurred: {0}
Explanation: The indicated internal error occurred.
User response: Resolve the indicated error and try again.

UIM12004  An input/output error occurred: {0}
Explanation: The indicated input/output error occurred.
User response: Resolve the indicated error and try again.

UIM12005  The file does not exist: {0}
Explanation: The indicated file does not exist.
User response: Specify a valid file and try again.

VAL00001  Variable {0} not found.
Explanation: The indicated variable was not found.
User response: Specify a valid variable.

VAL00003  Type conversion error. Object of {0} type cannot be converted to {1} type.
Explanation: The indicated object can not be converted to the indicated type.
User response: Specify an object of a different type to be converted, or convert the object to a different type.

VAL00004  Unit conversion error. Unit {0} cannot be converted to {1}.
Explanation: The indicated unit can not be converted to the indicated type.
User response: Specify a different unit to be converted, or convert the unit to a different type.

VAL00005  An expression contains a syntax error.
Explanation: An expression that you entered contains a syntax error.
User response: Check the expressions that you typed for syntax errors.

VAL00006  Wrong expression has been used.
Explanation: An incorrect expression has been used.
User response: Specify a valid expression.

VAL00007  Name "(0)" has invalid character at {1}. The name must start with a letter and should not contain special characters. See the help for a list of invalid characters.
Explanation: The indicated name contains an invalid character at the indicated column.
User response: Check the help for syntax rules and retype the invalid character.
VAL00008 Name cannot be empty. The name must start with a letter and should not contain special characters. See the help for a list of invalid characters.

Explanation: The name of a control can not be empty.
User response: Specify a correct name for the control.

VAL00009 Unable to process URL "\{0\}".

Explanation: The indicated URL could not be processed.
User response: Check the URL for errors and try again.

VAL00010 Unable to process URI "\{0\}".

Explanation: The indicated URI could not be processed.
User response: Check the URI for errors and try again.

VAL00019 Cycle has been found in definition of following properties: \{0\}.

Explanation: The expression contains a cyclic reference.
User response: Edit the expression to remove the cyclic reference and try again.

VAL00021 Cannot evaluate properties: \{0\}.

Explanation: The expression could not be evaluated.
User response: Check the expression for syntax errors and try again.

VAL00022 Validation failed: Cannot set \{0\} to \{1\}. Value must be \{2\} \{3\}.

Explanation: The property can not have the indicated value. Possible values are listed in the error message.
User response: Edit the property’s expression and try again.

VDS1000 \{0\}

Explanation: The indicated error occurred while processing the virtual data source.
User response: Resolve the indicated error and try again.

VDS1001 Internal Error.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help > Collect Support Data and forward it to customer support.

VDS1002 No data source was specified for the query.

Explanation: No data source was specified for the query.
User response: Specify a data source for the query.

VDS1003 Configuration directory is not defined.

Explanation: The configuration directory is not defined.
User response: Define the configuration directory.

VDS1004 Source data source not found for virtual table "\{0\}".

Explanation: The source data source for the indicated virtual table was not found. It is possible that the source data source has been moved or deleted.
User response: Check the location of the source data source and copy the source table to the virtual data source again if necessary.

VDS1005 Table is not defined in the query.

Explanation: The table is not defined in the query.
User response: Define the table in the query.

VDS1006 Source table column not found for virtual column "\{0\}" in the table "\{1\}".

Explanation: The indicated virtual column does not match any of the source table columns.
User response: Ensure that every column in the virtual table has a corresponding column in the source table.

VDS1007 Only tables and queries can be added to the virtual data source.

Explanation: You attempted to move an object that was not a table or a query to the virtual data source. Only tables and queries may be added to the virtual data source.
User response: Specify a table or query to be moved to the virtual data source.

VDS1008 Cannot find specified tables in data source.

Explanation: The tables that are referenced in the virtual data source can not be found in the source data source. This may be because the source tables were moved or deleted.
User response: Check the location of the source tables in the data source and copy them to the virtual data source again if necessary.

VDS1009 Cannot remove the last column from virtual table.

Explanation: You attempted to remove the last column from the virtual table. A virtual table must have at least one column.

User response: Ensure that the virtual table has at least one column.

VDS1010 Only queries for relational data sources can be added.

Explanation: You attempted to add a query from a multidimensional data source. Only queries for relational data sources can be added to virtual data sources.

User response: Specify queries for relational data sources to be added to the virtual data source.

VDS1011 Source table not found ":(0)".

Explanation: The indicated source table was not found. This may be because the source table was moved or deleted.

User response: Check the location of the source table and copy it to the virtual data source again if necessary.

VDS1012 Source query not found ":(0)".

Explanation: The indicated source query was not found. This may be because the source query was moved or deleted.

User response: Check the location of the source query and copy it to the virtual data source again if necessary.

VDS1013 Only SQL queries with SELECT statement can be used to create virtual tables.

Explanation: You attempted to create a virtual table using a source query that does not contain a SELECT statement. Only queries with SELECT statements can be used as source queries.

User response: Specify a query that contains a SELECT statement as a source query.

VDS1014 Virtual table cannot be created because source query returns columns with ambiguous names.

Explanation: The virtual table sources a query that returns a result set that has columns with identical names.

User response: Change the result set column names in the source query and try again.
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not give you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in any manner serve as an endorsement of those websites. The materials at those websites are not part of the materials for this IBM product and use of those websites is at your own risk.
IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement, or any equivalent agreement between us.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both. These and other IBM trademarked terms are marked on their first occurrence in this information with the appropriate symbol (® or ™), indicating US registered or common law trademarks owned by IBM at the time this information was published. Such trademarks may also be registered or common law trademarks in other countries. A complete and current list of IBM trademarks is available on the Web at [http://www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.
Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, and service names may be trademarks or service marks of others.

Terms and conditions for product documentation

Permissions for the use of these publications are granted subject to the following terms and conditions:

Applicability: These terms and conditions are in addition to any terms of use for the IBM website.

Personal use: You may reproduce these publications for your personal, noncommercial use provided that all proprietary notices are preserved. You may not distribute, display or make derivative work of these publications, or any portion thereof, without the express consent of IBM.

Commercial use: You may reproduce, distribute and display these publications solely within your enterprise provided that all proprietary notices are preserved. You may not make derivative works of these publications, or reproduce, distribute or display these publications or any portion thereof outside your enterprise, without the express consent of IBM.

Rights: Except as expressly granted in this permission, no other permissions, licenses or rights are granted, either express or implied, to the publications or any information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its discretion, the use of the publications is detrimental to its interest or, as determined by IBM, the above instructions are not being properly followed.

You may not download, export or re-export this information except in full compliance with all applicable laws and regulations, including all United States export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.

Privacy policy considerations

IBM Software products, including software as a service solutions, ("Software Offerings") may use cookies or other technologies to collect product usage information, to help improve the end user experience, to tailor interactions with the end user, or for other purposes. In many cases no personally identifiable information is collected by the Software Offerings. Some of our Software Offerings
can help enable you to collect personally identifiable information. If this Software Offering uses cookies to collect personally identifiable information, specific information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

If the configurations deployed for this Software Offering provide you as customer the ability to collect personally identifiable information from end users via cookies and other technologies, you should seek your own legal advice about any laws applicable to such data collection, including any requirements for notice and consent.

Glossary

The glossary provides brief descriptions of product terms.

accessibility. Features that help those with physical disabilities, such as restricted mobility or limited vision, use their computer.

breakpoints. Color maps that specify the value at which the color changes.

calculated columns. Columns of data that you add to the query results.

classic reports. Text-based, tabular reports that are generated using query results as the data source and a form template.

color map. A color map can be used to vary the color of a visual project object depending on a value associated with the object.

color sequence. A color sequence can be used to modify the color properties of a visual project object based on an index value.

command bar. An interface that allows you to run procedure commands directly from the QMF for Workstation interface.

connectivity tool. An interface that allows you to define dependencies between non-query driven objects such as text box objects and label objects. The Connectivity tool is only available when creating visual dashboards.

cube structure tree. In the layout format, the Cube Structure tree lists the dimensions and measures that are contained in the cube.

data sources. Data sources allow you to create virtual tables that can be edited and manipulated by users without altering the original tables' content. Virtual data sources work by introducing a metadata layer which mediates between an administrator-defined, virtual data source and the underlying data sources that contain the physical tables and views.

data templates. Data templates are used to create and control the visual representation of query result set data within layout objects.

Diagram Query Editor. When building queries using the Diagram Query editor, you supply table, join, column, sort, and row information and the Diagram Query editor constructs the Structured Query Language (SQL) statements. The Diagram Query editor is not available in QMF for WebSphere.

Draw Query Editor. Use the Draw Query editor to create a query object automatically based on the query type and tables that you specify.

drilldown. A navigation feature that enables your users to click an object and jump to another scene that contains more information that relates specifically to the original object's value. The Drilldown wizard is available for all layout objects that can display query result data.
edit codes. Edit codes specify how to format character, date, graphic, numeric, time and timestamp data that will appear in a specific column of a report. You can also create user-defined edit codes.

embedded scene. An embedded scene object is a container through which you can view all or a portion of another scene and then navigate to that scene. The scene where you place the embedded scene object is considered the source scene. The destination scene is the embedded scene.

event actions. You define event actions to objects to provide scene interactivity and navigation. As a user navigates your dashboard, mouse actions trigger predefined events, such as jumps between scenes, executing of SQL statements, or the launching of other applications.

Expression Designer. The Expression Designer is used to specify any property value that is associated with a selected object. The Expression Designer is an alternative way of specifying an object's properties. For each property that can be specified for an object, you are given templates that can help you format the value of that property. In addition, you have more space available to work and view your property value (which can grow quite large if expressions are used).

fast save. When saving your query results data using a "fast save" method, all the processing occurs at the database. There is no further passing of data between the QMF for Workstation/WebSphere interface and the database. The QMF for Workstation/WebSphere interface adds SQL to the original query, the query is rerun and the data is saved directly into the specified table(s). Saving query results data using the "fast save" process significantly improves performance when a large amount of data is to be saved.

file-based repositories. If you are using QMF for Workstation, you can create a file repository connection to set up the information that enables you to connect to
a file-based repository that is stored on a local or network drive. File connections can only be created for legacy, file-based repositories.

**formatting options.** You can customize how the query results will appear in the editor window. You can specify different fonts, colors and text alignments for each column heading and each cell of the column. You can also specify that column and cell formatting be applied based on the results of a conditional expression. You can apply formatting options to entire columns, individual cells, column headings, and summary cells.

**forms.** Forms are considered objects and they can be saved in your repository, in the QMF catalog, or in a file. When you open a form object that has been saved, you are actually running the form object to generate the report. When opened, forms automatically use the currently active query results as the data source.

**form variables.** Form variables are codes that you can insert into text fields to produce information on the report. For example, you can insert a date variable to produce the current date whenever the report is printed.

**global parameter.** A global parameter is available to your entire visual project and to the user of your visual dashboard. You can pass global parameters when you specify object properties or when you create event actions. You also have the option of making global parameters public at runtime so they are accessible to the user.

**global resources.** Global resources can be used by all the pages of a visual report or all the scenes of a visual dashboard. You can use global resources for computing object properties.

**global variables.** Global variables are variables that stay active while the current session of QMF for Workstation/WebSphere is active. This is in contrast to substitution variables that are active only during the execution of an object (query, procedure, form). For objects that use global variables, the value currently defined for the global variable is used.

**grouping and aggregation.** Grouping and aggregation options can be applied to query result columns to organize the result data into logical or summarized groupings. By adding grouping and aggregation you can automatically obtain summary information about your data and display the data more logically. For example you can roll up data in a report by department or average departmental commissions.

**information zooming.** Information zooming is a navigation feature that presents a more detailed view of data as your user zooms in on a scene or a data point in a layout. Every layout object and scene has a default zoom level (100% zoom). You can set up information zooming navigation for whole scenes and for individual layout objects. Information zooming on the layout object allows you to provide more query information on each data point as the user zooms in on a layout object. You use the same query results data for each zoom level. Information zooming on the scene level allows you to display an entirely different layout and query results data for each zoom level.

**JDBC drivers.** QMF for Workstation/WebSphere uses JDBC to connect to all database repositories and data sources. QMF for Workstation/WebSphere does not include JDBC drivers. The location of the JDBC drivers that QMF for Workstation/WebSphere uses to connect to repositories and data sources must be defined. QMF for Workstation/WebSphere administrators are responsible for identifying where each instance of the application interface will find the JDBC drivers.

**job definition files.** Job definition files (.jdfx) are legacy QMF files that can be imported to set up scheduled jobs.

**layout objects.** In a visual dashboard scene, layout objects are used to display query results in visual formats, such as charts, graphs, maps, tables and grids. For most layout objects, you display the results of multiple queries in a single layout. For example, you could create a single XY chart that displays sales figures derived from one query and spending figures derived from another query. You can nest multiple layout objects. When you nest layout objects, you can pass query result information from a higher level layout object to a lower level layout object. Because you have the ability to pass this information, you can use nested layout objects to display more detailed information that relates to a specific data value.

**Layout Properties dialog.** An interface that allows you to set all the options that are available for formatting query results. The Layout Properties dialog uses a tree structure to represent the columns in the query results. Depending on what you have selected in the query results, the Layout Properties tree displays branches for all columns in the query results or for a single column in the query results. You can apply formatting options to entire columns, individual cells, column headings, and summary cells.

**Legacy Visionary world.** You can create a new dashboard from an existing Visionary world that was created using a previous version of QMF Visionary. The Visionary world that you import must have been exported as an XML file using QMF for Visionary Version 8.1, Fix Pack 13 or later.

**LOB data.** A large object (LOB) is a DB2 for z/OS and DB2 for Linux, UNIX®, and Windows data type that houses nontraditional data such as text, multimedia, image, video, photograph, sound, or any very large
data file inside a database table. Retrieving or saving LOB data can consume a substantial amount of resources.

**network repositories.** A connection to a shared repository using direct network access. Network connectivity permits users to access a shared repository without the need for direct database connectivity from the workstation. Connecting to repositories using a network connection allows for consolidation of data access at a central server and removes the need to distribute JDBC drivers across each desktop running QMF for Workstation. This type of connection is not applicable to QMF for WebSphere users.

**OLAP queries.** OLAP queries enable users to dynamically access different dimensions of multidimensional data. Using QMF for Workstation and QMF for WebSphere you can create an OLAP query for multidimensional data sources that is queried using MDX and accessed using XMLA.

**palette objects.** From the Palette view, you can insert any graphical object that is listed into your visual project. All objects from the Palette view can be inserted in a visual dashboard. Not all objects available from the Palette view can be inserted in a visual report. The objects that cannot be inserted in a visual report have interactive properties, and visual reports are not interactive.

**personal repositories.** Personal repositories serve a single user and are stored in the personnel settings directory of the workstation (server) that is running the QMF for Workstation/WebSphere application interface.

**perspectives.** An interface used for querying data and formatting results.

**procedures.** A set of commands that enable you to run queries, print reports, import and export data, as well as perform other functions.

**Project Explorer view.** The Project Explorer view details in a tree structural all the elements and objects of each visual report and each dashboard.

**Prompted Query editor.** An interface that allows you to build simple to complex queries. The Prompted Query editor prompts you for the information it needs to build the SQL statement. You can also set sort and row conditions using the Prompted Query editor. (QMF for Workstation only)

**QMF catalogs.** A set of database tables that contain saved objects (queries, procedures and forms); user resource limits and profiles; reports; and other miscellaneous settings and information. QMF catalogs reside on database servers that host a DB2 database.

**Query Editor.** An interface that allows you to open any database table that is accessible to you in your workspace.

**query parameters.** Query parameters contain the value that will be sent to the query and used at runtime.

**regular save.** When saving your query results data using a "regular save" method, the interface that you are using (QMF for Workstation or QMF for WebSphere) saves the retrieved query results to the database using an individual SQL INSERT statement for each row of data. This type of save can be expensive in terms of performance due to the overhead of passing large amounts of data back to the database.

**relational query.** A query is a request for information from a data source. To request information from a relational data source your query is constructed using SQL statements.

**resource limits.** QMF for Workstation/WebSphere resource limits control your data source access and resource consumption. You must be connected to the data source in order to view the resource limits that are in effect for your user ID when you access that data source.

**scene parameters.** A parameter that is available only to a specific scene in a visual dashboard. You can pass scene parameters when you create embedded scenes and event actions.

**scheduled tasks.** You can schedule your procedure, query, quick report, or visual report to run at any given time using your local scheduler or the QMF for WebSphere scheduler. Objects that have been scheduled to run at another time are referred to as scheduled tasks.

**shared repositories.** Shared repositories are located on a database and can be shared by many users. Only QMF for Workstation/WebSphere administrators can create shared repositories.

**SQL Query editor.** For those with SQL experience, one way of creating a query is to type their own SQL statements in the SQL Query editor. You can write a single SQL statement that will return a single result set or multiple SQL statements that will return multiple result sets. The editor does coloring support for your SQL statements.

**static SQL packages.** Several tables in repository storage are used by QMF to store processing information. Some of these tables store sensitive information, for example the permissions table. By default all users can access these repository storage tables and make changes to the tables. You can choose to protect the repository storage tables. In protection mode, the repository storage tables are accessed using a collection of stored procedures or static SQL packages depending on what the database that is hosting the repository storage supports. Users of the repository storage must then be granted permission to run the stored procedures or static SQL packages.
**substitution variables.** Substitution variables are used to enter changing values to a SQL query at run time. This feature enables you to substitute a part of an SQL statement and make it more generic. Substitution variables are active only while the object (query, procedure or form) is running. As a result, only one object can access the substitution variable. The variable will not exist after the object is executed.

**Table Editor.** An interface that allows you to open any database table that is accessible to you in your workspace.

**Table Viewer.** An interface that allows you to open any database table that is accessible to you in your workspace.

**task scheduler.** QMF for Workstation/WebSphere has the ability to schedule procedures, queries, quick reports, and visual reports to be executed on a periodic, recurring basis or at a specific date and time. You can schedule your object to run at any given time using your local scheduler or the QMF for WebSphere scheduler.

**translation tables.** Translation tables enable dashboard designers to publish a single visual dashboard that may be viewed in multiple languages. When content developers create a dashboard, button captions, labels, tool tips and other embedded text is entered directly into the property values of the dashboard objects. Using translation tables, content developers can supply alternate versions of this entered text, to be displayed when the user is in a different locale. For example, a Japanese developer may elect to author a new dashboard in Japanese but then also include translation tables for German and French, each of which will be used when the dashboard is viewed under German and French locales.

**usage codes.** Usage codes provide summary information about the data in a column. For example, usage codes can provide total summary information at the end of a column, or partial summaries at control breaks in a table. The usage codes available depend on the data in the column and the type of summary.

**user preferences.** The Preferences dialog is used to set user preferences that will apply to specific functions in the current QMF for Workstation/WebSphere application interface session. The Preferences dialog consists of two panes. The left pane displays a hierarchical tree to organize the preferences and the right pane displays the pages of actual preference values.

**variables bar.** You can use the Variables bar to specify a property value. The Variables bar is located in the menu bar. From the Variables bar you can choose a global or local parameter that has been defined for the visual project and a column name from a set of query results.

**views.** QMF for Workstation/WebSphere views support editors and provide alternative presentations as well as ways to navigate the information in your window. Each view displays as a pane in the main workstation window. Each perspective of QMF for Workstation/WebSphere initially displays the views that are most commonly used to perform specific functions.

**visual dashboards.** Visual dashboards present interactive or persistent data obtained from querying multiple heterogeneous data sources across the enterprise. Visual dashboards present data in a scene format using a wide variety of graphics including charts, graphs, maps and user interface widgets. Data driven graphical objects can be easily linked so that user selections will trigger unique data displays. Content developers can create a visual dashboard that can be viewed by multiple users with either QMF for Workstation or QMF for WebSphere.

**visual designer.** You can quickly design visual reports and dashboards using the intuitive Visual Designer perspective that includes an editor that presents both design and runtime views of the project; the Project Explorer view which details the structural content of each visual report and each dashboard; and the Palette, Properties, Events and Output views which support the Visual Designer editor and assist in creating visual reports and dashboards.

**visual reports.** Visual reports are page-based, printable reports that include both formatted text and graphics to display persistent data to a wide variety of users. Visual reports can also contain data driven graphics (such as maps and charts) inserted in different sections (such as the headers or footers) of the report. Each of the data driven graphics can present data from multiple queries that are run across the enterprise.

**web service repositories.** You create a Web service repository connection to set up the information that enables you to connect to a shared repository through QMF for WebSphere web services API using a HTTP or HTTPS connection. Web-based connectivity permits users to access a shared repository without the need for direct database connectivity from the workstation. Connecting to repositories using a web-based connection allows for consolidation of data access at a central server and removes the need to distribute JDBC drivers across each desktop running QMF for Workstation. This type of connection does not apply to QMF for WebSphere.

**workspaces.** All of the data sources and objects that you can access are contained in one or more workspaces that have been pre-populated for you by the QMF for Workstation/WebSphere administrator. Each workspace to which you have access is listed in the Workspaces view. From the Workspaces view, you can perform the majority of query and reporting functions.
**zoom.** If you are using QMF for Workstation, you can use the Zoom option to view in hexadecimal or binary number the contents of a cell in the query results.
preferences (continued)
user 29
virtual data source 49
Visual Designer 29, 50

repositories (continued)
data sources (continued)
JavaScript 105
multidimensional 94
relational 89
virtual 96, 99, 100, 101
deleting 193
QMF catalog properties 197
data sources 200
protection status 199
tables 198
shared properties 193
database objects 195
JDBC connections 194
protection options 196
virtual data sources 100
repository connections
network
setting up 136
repository objects caching 132
repository storage 69
shared 63
adding repositories 70
internal security fields 72
JDBC connections 64
LDAP security fields 75
resource limits 163
acceleration 185
binding 179
cache 183
data source 165
group schedule values 172
main 173
group schedules 169, 171
groups 168
assigning users 186
limits 175
LOB options 181
object list 184
object tracking 180
options 176
QMF catalogs 189
creating user profiles 191
managing user profiles 191
user profiles 192
query 166
Report Center 182
repositories 186
managing user assignments 187
save data 178
SQL verbs 176
timeouts 174
resource limits group 167
determining the schedule 170
-specifying multiple schedules 169
resource limits groups
assigning users 188
reverting 9
RSBIHttpRequest class 106
running setup process 5

S
sample tables 203
activating 203
names and descriptions 203
save data resource limits 178

P
path 37
personal data sources 88, 89
populating ER diagrams 125
port 37
preferences
Appearance 29, 31
Dashboard Runtime 29
driver 47
e-mail 33
General 29
Global Variables 29
Help 29, 37
JDBC 38
JDBC Libraries 29
LOBs 29, 40
Log 29, 41
Output 45
QMF Data Service 46
Server-Side File System 48
SMTP 33
SSL 47
Third Party Libraries 49
Third-Party Libraries 29
refresh 104
relational data sources 89
additional parameters 93
enabling plug-ins 91
QMF catalogs 81
database objects 84
extended 87
objects 82
properties 197
data sources 200
protection status 199
tables 198
protecting and granting
permissions 85
resource limits security 168
selecting a catalog 86
user profiles 188
enrollment 188
QMF Data Service data source 118
creating 118
QMF Data Service preferences 46
QMF for WebSphere system requirements 3
QMF for Workstation system requirements 2
qmf.instance.area 12
qmf.instance.area.global 12
qmf.instance.area.shared 12
qmf.use.session.timeout 12
query environment
setting up 15
query resource limits 166

Q
QMF catalogs 81
database access 189
database objects 84
extended 87
objects 82
properties 197
data sources 200
protection status 199
tables 198
protecting and granting
permissions 85
resource limits security 168
selecting a catalog 86
user profiles 188
enrollment 188
QMF Data Service data source 118
creating 118
QMF Data Service preferences 46
QMF for WebSphere system requirements 3
QMF for Workstation system requirements 2
qmf.instance.area 12
qmf.instance.area.global 12
qmf.instance.area.shared 12
qmf.use.session.timeout 12
query environment
setting up 15
query resource limits 166

O
object list resource limits 184
object tracking reports 205
activating 205
maintaining tables 207
running 206
object tracking resource limits 180
object views 222
Q. RAA_OBJ_DIR_X 222
Q. RAA_OBJECT_VIEW_X 223
RDBI_AUTH_TABLE_X 223
RDBI_AUTHID_VIEW_X 223
RDBIADMIN_VIEW 224, 226
RDBIAUTH_TABLE_X 225, 226, 227
RDBIAUTHID_VIEW_X 225, 226, 227
RDBICATALOG_DIR_X 223, 224
RDBITABLE_VIEW2_X 225
RDBIUSER_ADMIN_VIEW_X 222, 224, 226
RDBIUSER_VIEW_X 226, 227
RDBIADMIN_VIEW 227
RDBIADMINVIEW 223
RDBIUSERAUTHID_VIEW_X 223
SYSIBM.SYSUSERAUTH 223
objects
customizing 221
options resource limits 176
Output preferences 45
overview 1, 145

N
network connections 135
network repositories 129
notices
legal 295
SDF 19
security
  database-based 155
  FIPS-140 53
selecting setup executable 5
server definition files
  importing data sources 19
Server-Side File System 29
preferences 48
service information ix
setting 30
shared repositories 129, 130, 132
short name objects 165
silent installation 148, 149
simultaneous database connections 68
  setting maximum number 68
SMTP preferences 33
SQL
  generated sample 221
SQL verbs resource limits 176
SSL preferences 47
static SQL packages 67, 130
stored procedures 67, 130
support information ix
system requirements
  QMF for WebSphere 3
  QMF for Workstation 2

T
tables 66
  protecting and granting
    permissions 67
Third Party Libraries preferences 49
timeouts resource limits 174

U
URL template 38
users and groups
  assigning DBA authorization 155
  assigning SYSADM
    authorization 155
  repository objects 153
    selecting 154
  using 215

V
virtual data source 104
  administration 100, 101
  editing 100, 101
  preferences 49
  tables 103, 115
virtual data source editor 100, 101
  opening 100
  security 101
  structure 100
virtual data sources 99
Visual Designer
  preferences 50

W
web service repositories 129, 137