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C h a p t e r  1 .  Introduction  
 

Email Resource Adapter (Email RA) enables connectivity for integration across Emailing Systems (EIS 
which communicates via emails). 

 Email Resource Adapter supports integration through sending and receiving mails to/from 
different mail servers using email protocols like SMTP, IMAP and POP3. During inbound operational 
mode, the Email Resource Adapter can read mails from the mailbox convert the mail into a WebSphere 
Business Integration Business Object and send the business object across to the Application server. 
During outbound operational mode, the Email Resource Adapter will receive an appropriate business 
object from the application server, convert the same to an email and sends the email to the mail server. 

 In this release, the adapter can now be deployed on WebSphere Process Server, WebSphere 
Enterprise Server Bus and also can be run in non managed mode. The introduction of Data Exchange 
SPI (DESPI) (for more details see IBM WebSphere Adapter Foundation Classes 2.0.0 FS Section 6.8) 
enables adapter interoperability with other Business Integration environments like WebSphere Message 
Broker, WebSphere DataStage TX, WebSphere Information Integrator, Tivoli Data Interchange and 
WebSphere Partner Gateway.  

Note: Email Adapter is not released with WebSphere Application Server and hence will not support on 
WebSphere Application Server platform. The databinding and the JavaBean used are only with 
respective WebSphere Process Server environment. 

To gain practical knowledge in setting up and deploying the adapter, complete one or more of the 
tutorials. Everything you need to complete each tutorial is contained in the tutorial. If you have 
performed the prerequisite tasks, you can complete each tutorial in within an hour. 

 

Learning Objectives 
After completing a tutorial, you should be able to perform the following tasks: 

1. Create an adapter project in WebSphere Integration Developer. 
2. Discover services and associated business objects from the enterprise information system (EIS) 

and make them part of the adapter project. 
3. Create a deployable module that you install on WebSphere Process Server or WebSphere 

Enterprise Service Bus. 
4. Test the module and validate the results. 



 

 

Audience 
These tutorials are for integration developers who design, assemble, test, and deploy business integration 
solutions. 

Software prerequisites 
To use these tutorials, you must have the following applications installed: 

 

1. WebSphere Integration Developer version 7.0.0.0 
2. WebSphere Process Server version 7.0.0.0 
3. Lotus Domino Mail Server(6.5 or above version) 
4. Mail Client (any for example, Outlook Express any appropriate version) 

 



 

 

C h a p t e r  2 .  Preparing to run the tutorial 
 

Configuration prerequisites 
Before doing any tutorial testing, complete the following tasks: 

For running Inbound operations of the adapter, create three directories and name them accordingly as 
staging directory, archive folder, and FailedEvents folder. For the tutorials a folder called InProgress has 
been created under the “C:\Documents and Settings\Administrator\My Documents\InProgress” and 
this will be used as the staging directory. The other two directories archive and failedEvents folders are 
optional and are not used for our tutorials and is thereby left undefined 

Configuring the mail server:  The mail server to be used by the user for running the tutorials and the 
sample needs to be configured prior to running the sample. The mail server would be the Enterprise 
Integration System which the Email Resource Adapter polls. In Appendix A of the document, very 
detailed instructions have been provided for the installation and configuration of the IBM Domino mail 
server version 6.5. Clear steps have been provided for administering the server instance, including the 
creation of necessary user accounts. The users internal to IBM can use the Domino server instructions 
as-is. The external users can opt for any freeware or licensed mail servers, but will need to configure the 
users as specified in Appendix A. 

For the tutorials, it has been assumed that the mail server is installed on a remote system with IP address 
as 9.121.219.72 and thereby all references to the mail server will be as ‘9.121.219.72’, with ports for each 
protocol as SMTP 25, IMAP 143 and POP3 as 110. 

Note: The default ports are SMTP-25, IMAP-143, and POP3-110. If the mail server is installed locally 
then the host name would be localhost.  

The user can install or configure the mail server on any system, in which case, the Host property, which 
determines the IP address of the mail server and the ports, must be changed appropriately in the Email 
Resource Adapter Activation Specification properties.   

Alternatively you would need to set these on the Activation Specification custom properties from the 
WebSphere Process Server Administrative Console.  

If the Port number on which the mail server is listening differs from the default port number for 
the protocol, the corresponding port number value must be set on the Activation Specification 
custom properties from the WebSphere Process Server Administrative Console.  

Note: Detailed instructions over doing the same is given in Appendix in “Using the Project Interchange 
Samples shipped along with the adapter installation -> Changing the Email Connection details” 



 

 

1)  Configuring the mail Server for SSL: WebSphere Adapter for Email now supports SSL for IMAP, 
POP3, and SMTP. For making use of SSL Support, the mail server and WebSphere Process Server in 
which the Email Resource Adapter is deployed needs to be configured for SSL. Detailed steps are given 
in the Appendix in “Configuring Email adapter 7.0.0.0 and Domino 7.0 mail server for SSL” where 
there is a description about configuring Lotus Domino server for SSL and also about configuring 
WebSphere Process Server for the same. For the scenarios it has been assumed that the IP address for 
the mail server with SSL configuration is ‘9.121.219.72’. 

Note: For SSL enablement IMAP and POP3 uses different port numbers. For POP3 SSL and IMAP 
SSL the port numbers are 995 and 993 respectively. 

2) Configure the mail Client: The mail client is essential for creating the events on inbound. Also it is 
helpful in verifying that the right events have been placed for polling. The user can configure any mail 
client (popular one being Microsoft Outlook Express, and Lotus Notes mail clients) to access the mail 
account with the mail server that you configured in the previous step. 

During the configuration, make sure the client is configured with mail server, right protocol and port 
number, which were mentioned in the previous step.  

Extracting the sample files 
Replicas of the artifacts that you create when using the external service wizard are provided as sample 
files for your reference. Use these files to verify that the files you create with the external service wizard 
are correct. 

Go to the “<WID_installation>\ResourceAdapters\JDE_7.0.0.0\samples\referencefiles” folder and unzip Scenario1.zip, 
Scenario2.zip, Scenario3.zip, Scenario4.zip, Scenario5.zip, Scenario6.zip, Scenario7.zip or Scenario8.zip 
into a directory of your choice (you may want to create a new directory). 
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Note:  Detailed instructions over using the samples shipped are given is in Appendix section. 



 

 

C h a p t e r  3 .  Tutorial 1:  Email inbound with 
DTF without EmailBG 

 

This tutorial demonstrates how to use WebSphere Adapter for Email without using business graphs in 
data transformation mode for polling emails. In data transformation mode, the adapter transforms 
structured contents (e-mail body or attachments) to specific business objects using data handlers (For 
example, XML Data handler). 

         
    Note: With version 7.0.0.0 Email Adapter, business graphs are not mandatory. 

 

Scenario  
Consider an organization where the important medium of communication is E-mail. All the customer 
complaints are received through email and the business process wants to pick up the mails and store it 
in a database from it can be either accessed through a customer service portal or queried by a customer 
relationship officer for further processing of the complaint. 

 

 



 

 

 
Figure: Email inbound with DTF without EmailBG 

 

 Here, WebSphere Adapter for Email can play a key role in picking up the e-mail from the specified 
folder and processing it to the end point. The adapter picks up the emails that are ready to be processed 
from the mailbox and converts them into the business object and forwards it to the export component 
from where it reaches the consumer service. 
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Configuring the adapter for inbound processing  
Run the external service wizard to specify business objects, services, and configuration to be used in this 
tutorial.  

Creating the project 
 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking File -> New -> Module.  

3. Enter the Module name as EmailInboundDTFWithoutBG and click Finish.  

4.  Import the XSDs into the module created. Right-click the DataTypes under the module 
EmailInboundDTFWithoutBG and select Import. 

 
Figure: Import the datatypes into the module 

 

5. Select FileSystem from the General category and click Next. 

 



 

 

6. Browse and choose the sample business object Wbiaddress.xsd and Wbiphone.xsd in this case from 
the xsd folder. 

 

Figure: Import the XSDs 

7. The Wbiaddress.xsd and Wbiphone.xsd can be seen under the data types. 

 
Figure: Expand Data Types. 



 

 

8. Start the external service wizard by clicking File-> New -> External Service 
 

9. Expand Adapters and click the plus sign to expand and select E-mail. Select Advanced: 
Create an e-mail service using the complete wizard and click Next. 

 

   

Figure: Select the service type 

 

 

 

 

 

 

 



 

 

 

10. In the Select an Adapter window, you can either create a new project or select an existing project.  
          To create a new project, perform the following steps:  

a) Select IBM WebSphere Adapter for Email (IBM: 7.0.0.0) as shown in the following figure.   

 

Figure: Select IBM WebSphere Adapter for Email 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

11. Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
and click Next. 



 

 

 

 To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0.0) CWYEM_EMail, then select the 
connection information. 

c) Click Next. 

12. Select the processing direction as Inbound and click Next. 
 

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary: hostname, username, password, 
port, protocol, location of the staging directory, and optionally location of the Archive folder and Failed 
Events Folder. Provide this information in the wizard. 

 

 

Figure: Enter the connection information 

 



 

 

2. In Service properties, select Using security properties from the activation specification and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the Data format options list. 
 

 

Figure: Specify the service properties 

 

4. Click Next. 

Generating business object definitions and related artifacts 
         Follow these steps to generate the business object definitions. 

         1. In the Operation window, click Add. 

         2. Select the data type as Generic e-mail business object and click Next.  



 

 

 

Figure: Select the operation 

3. Click Select to create a new Data format type.   

 

Figure: Create a new data format type 

 

  4. Select EmailWrapperDataBinding and click Next. 



 

 

 
Figure: Select an existing data format transformation 

 

5. Click Add and then click on browse to select the Business object type. 

6. Browse and select the business object type as Wbiaddress. 



 

 

 

Figure: Select the business object type 

 

7. Click OK. 

       

 

 

 

 

 

 

 

 



 

 

 

   8. In the Add/Edit properties, select the Mime type as text/xml. 

 
Figure: Select the mime type 

 

 

 

 

 

 

 

 

 

 



 

 

   9. In the Data handler Configuration, select Use existing data format transformation from the 
list to configure the XML datahandler.  

 
Figure: Select the XML data handler 

 

   10. Select XML and Click Next. 

   11. Click Next again and then click Finish. 

   12. Repeat steps five to nine to select Wbiphone. 



 

 

13. Click Next. 

 

Figure: Specify the data binding properties 

14. Click Browse to select the module for which the external service has been run and click   
Finish.  



 

 

 

Figure: Select the module 

 

15. Click Next, and then click Finish. This completes setting up of the external service.  

16. Verify the results. 
 



 

 

 

Figure: Expand the created module 

 

17. Open the Assembly diagram for the module. Click Java Component from the palette, drag and drop 
the same into the assembly diagram.  



 

 

 

Figure: Open the assembly diagram for the module 

 

18. Rename the Java Component as EndPoint and wire the export to the Java Component. 

 

 

Figure: Rename the Java component 

 

19. Right-click the Java Component (Endpoint) created earlier and click Generate Implementation.  

20. Choose Default package. A java class file implementation is generated for the same. 



 

 

 

Figure: Review the Java class file implementation 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an Enterprise 
Integration System (EIS) import or export. Install this SCA module in WebSphere Integration 
Developer integration test client.  

 1. Add the module you created earlier to the server using the server panel in the WebSphere Integration 
Developer. Right-click the server, and then select Add and Remove Projects.  



 

 

 

Figure: Add the module 

 

2. Add the SCA module to the server. 

3. Click Finish. 
 

 

Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
 

1. Select any service you want, and click Test > Test Attach.    



 

 

2. Click Continue  to run the service. 

3. Go to <WID_installation>\ResourceAdapters\ Email_7.0.0.0_IF01\Samples location. Unzip 
EmailEventCreator.tar or EmailEventCreator.zip file. The utilities are extracted under folder 
EmailEventCreator.  

4. Create events using the createEvents_sample_nonpassthroughWithFileContent.bat file. 

available under the EmailEventCreator folder that was extracted. 

The example contents of the file are as shown below: 

java -cp .\;.\mail.jar;.\activation.jar EmailEventCreatorNew "9.121.219.72" 25 2 "tester@ibm" 
ejca@ibm ejca@ibm ejca@ibm "test subject" "<WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" 
"<WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiPhone.xml" "false"  

 

Note: Use the Files WbiAddress.xml and WbiPhone.xml in EmailEventCreator folder to test the 
scenario. 

 This will create two events from the user tester@ibm on the mail server with 9.121.219.72as the 
IP address, WbiAddress.xml as the content and WbiPhone.xml file as the mail attachment. The other 
attributes of the mail specified by the user will be incorporated on each mail event that is created. More 
information on creating the events and the EmailEventCreator is provided in the appendix section 
Creating Events. 

The mail is processed by the Email Resource Adapter and the business object is received via the 
Endpoint java component as shown in the following figure. Observe that Mail Content and Mail 
Attachment are MyAddress.xml and MyPhone.xml data types. 



 

 

 

 

Figure: Review the values for mail content and the mail attachment 

 

 

Clearing the sample content 
Return the data to its original state by removing the module created earlier from the WebSphere Process 
Server.  

1. Right-click the server and select Add and Remove Projects.  

2. Choose the module. 

3. Click on Remove, and then click Finish.  
 

Nothing is required to clean up after this tutorial. 
 

 

 

 



 

 

C h a p t e r  4 .  Tutorial 2:  Email inbound pass-
through with EmailBG 

 

This tutorial describes how to use WebSphere Adapter for Email with Business graphs to poll for 
emails. This scenario does not handle any data transformation. The content of each email is fetched into 
UnstructuredContent business object without performing data transformation. The content is filled into 
either AsText or AsBinary business objects accordingly. 

Scenario  
This scenario plays a role in a situation where the organization may not be able to predict the content of 
email that they might need to process. For example, there may be a customer who may have the 
privilege of sending email in any format. The customer can lodge a complaint with just the description 
of the problem and not mention his customer number or his identity. It would be the responsibility of 
the organization and the customer to He may not be compelled or asked to send an email in a particular 
structure. In order to process such emails, the adapter for Email can be configured in such a way that it 
can process any kind of email, let the content be text or binary. 



 

 

 
Figure: Email inbound pass-through with EmailBG 

 

The adapter does a pass through transformation of the content of the e-mail, that is it does not perform 
any data transformation of the content. The content is directly converted to a business object and 
forwarded to the export component from where it is directed to the end point. 

Configuring the adapter for inbound processing  
Run the external service wizard to specify business objects, services, and configuration to be used in this 
tutorial. 
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Creating the project 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking: File -> New -> Module. 

3. Enter the module name as EmailInboundPTWithBG and click Finish.  

4. Start the external service wizard by clicking: File-> New -> External Service. 

5. Select Adapters and click Next. 
6. In the Select an Adapter window, select you can either create a new project or select an 
existing project.  

7. To create a new project, perform the following steps:  

a) In the Select and Adapter window, select IBM WebSphere Adapter for Email (IBM: 
7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project    (CWYEM_EMail) 
or provide another name in the Connector project field. Select the server from the Target runtime list 
(for example, WebSphere Process Server v7.0.0.0), then click Next. 

8. To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information. 

c) Click Next. 

9. Select the processing direction as Inbound and click Next. 
 

Setting connection properties for the external service wizard 

 

1. To connect to Email server the following information is necessary: hostname, username, password, 
port and protocol, location of the staging directory and optionally location of the Archive folder and 
Failed Events Folder. Provide this information in the wizard. 

 



 

 

 

Figure: Enter the connection information 

 

 

2. In Service Properties, select Using security properties from the activation specification and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the Data format options list. 



 

 

 

Figure: Specify the service properties 

 

4. Click Next. 
 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 

1. In the Operations window, click Add. 

2. Select the data type as Generic e-mail business object with business graph and Click Next.  



 

 

 

Figure: Select the data type 

3. Click Select to create a new Data format type.   
 

 

Figure: Create a new data format type 

 

 



 

 

4. Select EmailWrapperDataBinding and click Next. 

 
Figure: Select an existing data format transformation 

 

5. Click Next. 



 

 

 

Figure: Select the module 

 

                   6. Click Finish twice. 

       7. Click Next, and click Finish. 

 

 
 

 

 

 

 

 

 

 



 

 

 

Figure: Expand the created module 

 

8. Open the Assembly diagram for the module. Click Java Component from the palette. Drag and drop 
the same into the assembly diagram.  

 

9. Name the Java Component as EndPoint and wire the export to the Java Component. 
 

 

Figure: Rename the Java component 

 

 



 

 

10. Right-click the Java Component (EndPoint) created earlier and click Generate Implementation. 
Choose Default package. A java class file implementation is generated for the same. 

 

Figure: Review the Java class file implementation 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server, and select Add and Remove Projects.  

2. Add the SCA module to the server. 

3. Click Finish. 
 

Testing the assembled adapter application   
1. Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
 

2. Select the service you want, and click Test --> Test Attach.    



 

 

3. Click Continue   to run the service. 

4. Go to the <WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples location. Unzip 
EmailEventCreator.tar or EmailEventCreator.zip. The utilities are extracted under folder 
EmailEventCreator. 

5. Create Events using the createEvents_sample_passthrough.bat file. 

The sample contents of the file are as shown here: 

java -cp .\;.\mail.jar;.\activation.jar EmailEventCreator "9.121.219.72" 25 2 "tester@ibm" 
emailjca@ibm emailpop3@ibm emailpop3@ibm "test subject" "Sample Content" 
"<WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" "true" 

 

Note: Use the files WbiAddress.xml and WbiPhone.xml which are there under 
EmailEventCreator folder test the scenario. 

 This will create two events from the user tester@ibm on the mail server with 9.121.219.72 as IP 
address with the content as “Sample Content” and with the mail attachment as MyAddress.xml. The 
other attributes of the mail specified by the user will be incorporated on each mail event that is created. 
More information on creating the events and the EmailEventCreator is provided in the appendix 
section, Creating Events. 



 

 

The mail is processed by the Email Resource adapter and the business object is received 
via the EndPoint java component as shown in the following figure. 

 
Figure: Review the values for mail content and the mail attachment 

  

 

Clearing the sample content 
Return the data to its original state by removing the module created earlier from the WebSphere Process 
Server.  

1. Right-click the server, and then select Add and Remove Projects.  

2. Choose the module. 

3. Click Remove and then click Finish.  
 

Nothing is required to clean up after this tutorial. 



 

 

C h a p t e r  5 .  Tutorial 3: Email outbound with 
DTF without EmailBG 

 

 This tutorial demonstrates how to use WebSphere Adapter for Email without using Business graphs in 
data transformation mode for sending emails. In data transformation mode, the adapter transforms 
configured business objects into structured contents (Email body or attachments) using data handlers 
(For example, XML Data handler). 

Note: With version 7.0.0.0 Email Adapter, Business Graphs are not mandatory. 

Scenario  
The following tutorial explains the configuration of Email adapter to send emails with a particular 
format to the recipients. 

Consider an educational institution where the management wants to send out a monthly report to all the 
parents over e-mail. The report would be in a standard format. In this situation, the adapter can be used 
to send the email to all the parents. 



 

 

 

   

Figure: Email outbound with DTF without EmailBG 

 

The report reaches the adapter in the form of a business object, out of which the adapter builds an e-
mail message. This e-mail is then forwarded to the mail server for distribution.  

 

Configuring the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and configuration to be used in this 
tutorial. 

Creating the project 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking: File -> New -> Module. 
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3.  Enter the Module name as EmailOutboundDTFWithoutBG and click Finish.  

4.  Import the XSDs into the module created. Right click the DataTypes under the module 
EmailOutboundDTFWithoutBG and select Import. 

 
Figure: Import  DataTypes 

 

5. Select FileSystem from the General category and click Next. 



 

 

 
Figure: Select File System 

6. Browse and choose the sample business object Wbiaddress.xsd and Wbiphone.xsd in this case from 
the xsd folder. 



 

 

 

Figure: Import the data types 

 

7. The Wbiaddress.xsd and Wbiphone.xsd can be seen under the data types. 

 
Figure: Expand Data Types 



 

 

8. Start the external service wizard by clicking File-> New -> External Service 
 

9. Expand Adapters, and click the plus sign(+) to expand E-mail. Select Advanced: 
Create an e-mail service using the complete wizard and click Next. 

 

 
Figure: Select the Service Type 

 

10. Start the external service wizard by clicking: File-> New -> External Service. Expand Adapters 
and select E-mail, and click Next.  

 11. In the Select an Adapter window, you can either create a new project or select an existing project.  

To create a new project, perform the following steps:  



 

 

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email (IBM: 7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. Select the server from the Target runtime list 
(for example, WebSphere Process Server v7.0.0.0), and then click Next. 

12. To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

13.  Select the processing direction as Outbound and click Next. 

Setting connection properties for the external service wizard 

1. To connect to Email server the following information is necessary hostname, username, password, 
port and protocol. Provide this information in the wizard. 

 

Figure: Enter the connection information 

 



 

 

2. In Service Properties, select Using security properties from the activation specification and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the Data format options list. 
 

 

Figure: Specify the service properties 

 

4. Click Next. 
 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 

 1. In the Operations window, click Add. 

 2. Select the data type as Generic e-mail business object and click Next.  



 

 

 

Figure: Select the data type 

 

3. Click Select, to create the Data format type.   

 

Figure: Create a new data format type 

 



 

 

4. In the Data Binding Configuration window, select EmailWrapperDataBinding and 
click Next. 

 

 

Figure: Select an existing data format transformation 

 

 

  5.  In the Data Transformation Properties window, Click Add. 

  6. Browse and select the Business object type as Wbiaddress and click OK.  



 

 

 

Figure: Select the business object type 

 

7. Enter the Mime type as text/xml. 

8. In the Data Handler Configuration, click Select to configure the XML datahandler. 



 

 

 
Figure: Select the mime type 

 

9. In the New Data Handler Configuration window, select XML and click Next. 

10. Click Next. 

11. Select Encoding as UTF-8 and click Next. 
12. Click Finish. 

13. In the Data Binding Properties window, click Add to add the Business Object Type.  

14. Browse and select the Business object type as Wbiphone. 

15. Choose the Mime type as text/xml. 

16. Browse and select the xml datahandler created in the previous step. 

17. Click Finish. 

18. In the Data Binding Properties window, click Finish. 

 



 

 

 

 
Figure: Specify the data binding properties 

 

19. Click Finish. 

       

         20.  Click Next and then click Finish to complete the external service wizard and verify 
the result. 

 



 

 

 

Figure: Expand the created module 

 

 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

 

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server and select Add and Remove Projects.  

2. Add the SCA module to the server. 



 

 

3. Click Finish. 
 

 

Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration 
test client.   
 

1. Select the service you want, and click Test > Test Module.    

2. Populate the values for the To, From, Subject, and the mail content as Wbiaddress type and mail 
attachment as Wbiphone type. Populate the values as required 

3. Click Continue  to execute the service. 

 

Figure: Review the values for mail content 

 

 



 

 

 

Figure: Review the values for mail attachment 

4. Check the output of the service, and check the data in the EIS to ensure it matches expected values.   

 

 

Figure: Check the output of the service 



 

 

 

5. The sample output from the test module is as shown here. 
 

 

Figure: Review the sample output 

  

Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server, and then select Add and Remove Projects.  

2. Choose the module. 

3. Click on Remove and then click Finish.  

Nothing is required to clean up after this tutorial. 
 

 



 

 

C h a p t e r  6 .  Tutorial 4: Email outbound 
pass-through with EmailBG 

This tutorial demonstrates how to use WebSphere Adapter for Email with business graphs to send 
emails. This scenario does not handle any data transformation. The content of UnstructuredContent 
business object is transformed into corresponding email contents and attachments without performing 
the data transformation. 

Scenario  
The following tutorial explains the configuration of Email adapter to send emails to any number of 
recipients with the mail content in any structure such as text or binary (such as rich text, PDF, or 
images).  
Consider an organization that provides tourism packages. For such an organization, it becomes a 
necessity to broadcast emails to its members with the new packages that they are providing. In 
this scenario, most of the times the person receiving the email would be very much interested in 
having a glance at the pictures of the places.  

Sending an email with binary content (say images, PDF etc) becomes inevitable in such 
situations. It is in this scenario that the current configuration of Email adapter plays a role. 

The mail content can be composed with binary content or text format and sent for a broadcast 
for a large group of members.  



 

 

 
  Figure: Email outbound pass-through with EmailBG 

 

 

When a request is received by the adapter, the adapter takes the information stored in the business 
object and creates an e-mail. This e-mail is then forwarded to the mail server for distribution. The 
adapter does not perform any transformation on the content of the e-mail since it is selected to go with 
a pass through kind of outbound processing. 

 

Configuring the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and configuration to be used in this 
tutorial. 

Creating the project 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking File -> New -> Module.  
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3. Enter the module name as EmailOutboundPTWithBG and click Finish.  

4. Start the external service wizard by clicking: File-> New -> External Service. 

5. Expand Adapters and select E-Mail then click Next.   

6. In the Select an Adapter window, you can either create a new project or select an existing 
project.  

To create a new project, perform the following steps:  

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

 d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
then click Next  

To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

7. Select the processing direction as Outbound and click Next.  

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary: hostname, username, 
password, port and protocol. Provide this information in the wizard. 

 



 

 

 

Figure: Enter the connection information 

2. In Service Properties, select Using security properties from the (activation specification) and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the list. 
 



 

 

 

Figure: Specify the service properties 

 

4. Click Next. 
 

Generating business object definitions and related artifacts 
 

Follow these steps to generate the business object definitions. 

1. In the Operations window, click Add. 

2. Select the data type as Generic e-mail business object with business graph and click Next.  



 

 

 

Figure: Select the data type 

3. Click Select to create the Data format type. 

 
Figure: Create a new data format type 

 

 

 



 

 

 

 

4. In the Data Binding Configuration window, select EmailWrapperDataBinding and click Next. 

 

Figure: Select an existing data format transformation 

 

 



 

 

5. Click the Next.   

 
Figure: Specify the data binding properties 

 

6. Click Finish twice. 

7. Click Next and then click Finish. 

8. Click Finish and verify the results. Observe the EmailBG Wrapper in the Data Types > Common 
Schemas 

 



 

 

 

Figure: Review the details for EmailBG wrapper 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

 

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server and then select Add and Remove Projects.  

2. Add the SCA module to the server. 

3. Click Finish. 
 



 

 

Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
1. Select the service you want, and click Test > Test Module.    

2. Populate the values for the To, From, Subject and the mail content as unstructured type and mail 
attachment as unstructured type. 

3. Populate the values as required. 

4. Click Continue   and run the service. 

 

Figure: Review the values for mail content 

 

 



 

 

 

Figure: Review the values for mail attachment 

 

5. Check the output of the service, and check the data in the EIS to ensure it matches 
expected values.   

 



 

 

 

Figure: Review the sample output 

 

6. The sample output from the attached test.xml file reads as shown in the preceding figure. 
  

Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server, and select Add and Remove Projects.  

2. Choose the module. 

3. Click on Remove, and then click Finish.  

Nothing is required to clean up after this tutorial. 
 

 



 

 

C h a p t e r  7 .  Tutorial 5:  Simple Email 
outbound 

 

This tutorial demonstrates how to use the WebSphere Adapter for Email for sending simple Hello 
World emails.  

Scenario  
The following tutorial explains the configuration of email adapter to send plain text emails to the 
recipients. 

Consider the business scenario where this particular behavior of Email adapter plays a role. 

  A Business process where a Customer relationship officer receives a new complaint from a 
customer through a customer services portal and wants to alert all the people who are supposed to take 
active participation in resolving the complaint lodged.  

Here, the E-mail adapter can be used to send an e-mail broadcasting the customer's complaint to a large 
group of e-mail addresses. Outbound processing begins with the adapter receiving a request in the form 
of a business object from a service. The adapter is triggered by an EmailOutboundInterfaceImport as 
depicted in the following figure.  

 



 

 

 
  Figure: Simple E-mail outbound 

 

When a request is received by the adapter, the adapter takes the information stored in the business 
object and creates an e-mail. This e-mail is then forwarded to the mail server for distribution.  
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Configuring the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and configuration to be 
used in this tutorial. 

Creating the project 
 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking File -> New -> Module. 

3. Enter the Module name as EmailOutboundSimple and click Finish.  

4. Start the external service wizard by clicking File-> New -> External Service. 

5. Expand Adapters and click the plus sign to expand E-Mail. Select Advanced: Create an e-mail 
server using the complete wizard and click Next. 



 

 

 

Figure: Select the service type 

  

6. In Select an Adapter window, you can either create a new project or select an existing project.  

7. To create a new project, perform the following steps:  

a) In the Select an Adapter window select IBM WebSphere Adapter for Email (IBM: 
7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
then click Next. 

8. To select an existing project, perform the following steps:  



 

 

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

9. Select the processing direction as Outbound and click Next. 

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary hostname, username, 
password, port and protocol. Provide this information in the wizard. 

 

 

Figure: Enter the connection information 

2. In Service Properties, select Using security properties from the (activation specification) and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the Data format options list. 
 



 

 

 

Figure: Specify the service properties 

 

4. In Service Properties, select Using security properties from the activation specification and 
provide the necessary credentials. 

5. Select the Data binding as Specify a databinding for each operation. 

6. Click Next. 
 

Generating business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Operations window, click Add. 

2. Select the data type as Simple e-mail.  

3. Select the Enable response on delivery check box and click Next. 



 

 

 

Figure: Select the enable response on delivery check box 

4. Click Finish and then click Next. 

 
Figure: Add the operation 



 

 

5. Click Finish and verify the results.  
 

 

Figure: Verify the results 

 

Deploying the module to the test environment 
The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

 

1. Add the module you created earlier to the server using the server panel in WebSphere 
Integration Developer. Right-click the server, and then select Add and Remove Projects.  

2. Add the SCA module to the server. 

3. Click Finish. 
 



 

 

Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
 

1. Select the service, and click Test > Test Module.    

2. Populate the values for the To, From, Subject and the mail content as required. 

3. Click Continue   and run the service. 
 

 

Figure: Enter the values to test the module 

 

    

 

 

 

 

 



 

 

4. The response business object is returned. 

 
Figure: Check the output of the service 

5. The fault business object is shown in the following figure. Set the Encoding to an invalid value say 
'abcd', and then click Continue. This results in a fault business object. 

 
Figure: Response Business Object 



 

 

 
Figure: Fault Business Object 

6. The missing data fault is shown here. Do not specify any value in the From field. 

 
Figure: Enter the values to test the module 



 

 

 

 

 
Figure: Fault Business Object 

 

Clearing the sample content 
Return the data to its original state. 

Remove the module created earlier from WebSphere Process Server. 

1. Right-click the server and then select Add and Remove Projects.   

2. Select the module. 

3. Click Remove and then click Finish 
 
Nothing is required to clean up after this tutorial. 



 

 

C h a p t e r  8 .  Tutorial 6:  Email inbound pass-
through with SSL support using 
Lotus Domino 

 

This tutorial demonstrates how to use WebSphere Adapter for Email to poll for emails over SSL. 

Scenario  
E-mails passing through the mail server are vulnerable to third party interference when SSL is not 
configured for use with the adapter. Using SSL prohibits data from being modified either intentionally 
or unintentionally during transport and protects data from being intercepted. It is effective because it 
uses several cryptographic processes public key cryptography for authentication with the mail server and 
secret key cryptography and digital signatures for privacy and data integrity. SSL allows the adapter to 
authenticate the identity of the mail server and, when necessary, for the mail server to authenticate the 
identity of the mail client. 

In a credit card system, information related to the credit card holder is confidential. It is very much 
necessary for organizations that provides the credit cards to safe guard and protect the sensitive 
information of its customers. Consider a situation where such an organization needs to update the 
address and contact details of the customer in the database. The customer would have sent a mail and in 
this scenario the adapter for e-mail can be configured to pick up mails from the mailbox over SSL, so 
that it is ensured that no data is modified during the process. 



 

 

 
Figure:  Email inbound pass-through with SSL support using Lotus 
Domino 

 

 Here, WebSphere Adapter for Email can play a key role in picking up the e-mail from the specified 

The adapter picks up the emails that are ready to be processed from the mailbox and converts them into 
the business object and forwards it to the export component from where the address is updated in the 
database. 
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Configuring the adapter for inbound processing  
Run the external service wizard to specify business objects, services, and configuration to be used in this 
tutorial. 

Creating the project 
 

Set up the Mail Server and WebSphere Process Server for SSL. (See Appendix for more details under 
sections ‘Configuring Email adapter 7.0.0.0 and Domino 7.0 mail server for SSL’ and ‘Configuring the 
WebSphere Process Server for Email adapter to support SSL’) 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by changing: File -> New -> Module. 

3. Enter the Module name as EmailInboundPTWithSSL and click Finish.  

4. Start the external service wizard by clicking: File-> New -> External Service. 

5. Expand adapters and select E-Mail and click Next. 

6. In Select an Adapter window, you can either create a new project or select an existing project.  
To create a new project, perform the following steps:  

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email (IBM: 
7.0.0.0).   

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
then click Next. 
To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection.  

c) Click Next. 

7. Select the processing direction as Inbound and click Next. 



 

 

Setting connection properties for the external service wizard 
1. To connect to Email server the following information is necessary: hostname, username, 
password, port, protocol and location of the staging directory and optionally location of the 
Archive folder and Failed Events Folder. Provide this information in the wizard. 

 

 

 

Figure1: Enter the connection information 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

2. Check Select the Enable transport security (SSL) check box under Additional properties. 

 

Figure: Select the Enable transport security (SSL) check box 

 

3. In Service Properties, select Using security properties from the activation specification and 
provide the necessary credentials. 

4. Select the Specify a data format for each operation from the Data format options list. 



 

 

 

Figure: Specify the service properties 

 

5. Click Next. 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 

1. In the Operations window and click Add. 

2. Select the data type as Generic e-mail business object. Click Next.  



 

 

 

Figure: Select the data type 

  3. Click Select to create a new Data format type.  

 

Figure: Create a new data format type 

 

4. Select the Data Binding type as EmailWrapperDataBinding and click Next. 
 



 

 

 

Figure2: Select an existing data format transformation 

 

5. Click Next. In the Data Bindings Properties window and click Finish. 

6. Click Finish twice and then click Next.  

7. Click Finish and verify the results.  



 

 

 

Figure: Verify the results 

 

8. Open the Assembly diagram for the module. Click the Java Component from the palette. 
Drag and drop the same into the assembly diagram.  

 

9. Name the Java Component as EndPoint and wire the export to the Java Component. 

 

Figure: Rename the Java component 

 

 

10. Right-click the Java Component(EndPoint) and click Generate Implementation. 

11. Select Default package. A java class file implementation is generated for the same. 



 

 

 

 

Figure: Review the Java class file implementation 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

 

1. Add the module you created earlier to the server using the server panel in WebSphere 
Integration Developer. Right-click the server and then select Add and Remove Projects.  

2. Add the SCA module to the server. 

3. Click Finish. 
 

 

 

 

 



 

 
0 

Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
 

1. Select the service you want, and click Test > Test Attach.    

2. Click Continue   to run the service. 

3. Go to the “<WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples” location. Unzip the 
EmailEventCreator.tar or EmailEventCreator.zip file. The utilities are extracted under folder 
EmailEventCreator. 

4. Create Events using the createEvents_sample_passthrough.bat file. 

The contents of the file are shown here: 

java -cp .\;.\mail.jar;.\activation.jar EmailEventCreator " 9.121.219.72" 25 1 "tester@ibm" ejca@ibm 
emailpop3@ibm emailpop3@ibm "test subject" "Sample Content" 
"<WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" "true" 

Note: Use the files WbiAddress.xml and WbiPhone.xml within EmailEventCreator folder to test the 
scenario. 

 This will create one event from the user tester@ibm on the mail server with 9.121.219.72 as IP 
address, with the content as “Sample Content” and with the mail attachment as that of the xml file 
MyAddress.xml. The other attributes of the mail specified by the user will be incorporated on each mail 
event that is created. More information on creating the events and the EmailEventCreator is provided in 
the appendix section, Creating Events. 

The mail is processed by the Email Resource adapter and the business object is received via the 
EndPoint java component as shown in the figure below. Observe the Mail Content as well as the Mail 
Attachment as Unstructured types. 
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Figure: Review the values for mail content and the mail attachment 

 

 

Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server and select Add and remove projects.  

2. Select the module. 

3. Click Remove and then click Finish.  

Nothing is required to clean up after this tutorial. 
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C h a p t e r  9 .  Tutorial 7:  Email Outbound 
user-defined type with DTF 

 

This tutorial demonstrates a new feature in version 7.0.0.0 of WebSphere Adapter for Email, which 
allow user to build user-defined wrappers. 

This tutorial demonstrates how to build user-defined wrappers and use it in the outbound. This feature 
can be used when you know the exact structure of email you want to send for all requests. 

Scenario  
The following tutorial explains the configuration of the Email adapter to send fixed structure emails. By 
selecting the user-defined data type in the external service wizard, you can define your own fixed 
structure wrapper business object. By doing this, you can use ordinary mapping tools to consume and 
work with your business objects without having to determine the business object type at runtime. 

This scenario plays a role in a situation where the finance department of any organization has to send its 
annual reports to the concerned and authorized people with consolidated report as mail content and all 
the monthly reports as attachments. All the monthly reports are to be sent in a particular order (in the 
order of months for example, report of month January should be followed by February and not by April 
or May) which gives clarity to the person viewing the reports. The configuration of adapter with user 
defined type helps in sending such emails to the recipients where the order of attachments matters. 
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  Figure: Email Outbound user-defined type with DTF 

 

When a request is received by the adapter, the adapter takes the information stored in the business 
object and creates an e-mail. This e-mail is then forwarded to the mail server for distribution.  

 

Configuring the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and configuration to be 
used in this tutorial. 

Creating the project 
 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking File -> New -> Module. 

Finance department 

 

Mail Server 

EmailOutboundInterfaceImport 

WebSphere Adapter for Email 

Report is sent to the adapter in the form of 
business objects in fixed structure

Adapter builds email out of the 
business objects and sends the 
email to the mail server for 
distribution. 
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3.  Enter the Module name as EmailOutboundFixedStructureDTF and click Finish.  

4.  Import the Customer xsd into the module created. Right-click the DataTypes under the module 
EmailOutboundFixedStructureDTF and select Import. 

 
Figure: Import the datatypes into the module 

 

5. Select FileSystem from the General category and click Next. 
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Figure: Select the option file system 

6. Browse and select the sample business object Wbiaddress.xsd and Wbiphone.xsd in this case from 
the xsd folder. 
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                              Figure: Import the XSDs 

7. The Wbiaddress.xsd and Wbiphone.xsd can be seen under the data types. 
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8. Start the external service wizard by selecting: File-> New -> External Service 

9. Expand Adapters, select E-Mail and then click Next. 
10. In the Select an Adapter window, you can either create a new project or select an existing 
project.  

11. To create a new project, perform the following steps:  

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email (IBM: 
7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
then click Next. 

12. To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

13. Select the processing direction as Outbound and click Next. 
 

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary: hostname, username, 
password, port and protocol. Provide this information in the wizard. 
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Figure: Enter the connection information 

 

2. In Service Properties, select Using security properties from the (activation specification) and 
provide the necessary credentials. 

3. Select the Specify a data format for each operation from the Data format options list. 
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Figure: Specify the service properties 

 

4. Click Next. 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 

1. In the Operations window, click Add.  

2. Select the data type as User defined email business object and Click Next.  
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Figure: Select the data type 

3. In the Add Operation window, click New to specify the Input Type. 

4. Specify the folder name (Optional) and click Next. 

 
Figure: Specify the Input Type 
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5. Specify the Business object name as AddressWrapper. 

 

 

Figure: Specify the business object properties 

 

 

6. Click Add. 

7.  Select Wbiaddress and click Finish. 
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Figure: Select the business object type 

8.  Repeat the steps six and seven to add Wbiphone. 

 
Figure: Specify the business object properties 
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9.  Click Finish. 

10.  Select the Data binding as EmailFixedStructureDataBinding. 

 
Figure: Select an existing data format transformation 

 

11.  Click Next.  
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Figure: Modify the data binding properties 

 

12. Edit each of the elements in the table. 

13.  Select the MimeType as text/xml. 
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Figure: Configure the data handler 

 

14.  In the DataHandlerConfiguration, click Select, to select the Data handler configuration 

15.  Select XML and click Next. 

16.  Repeat Steps 12 to 14 for Wbiphone. 

17.  Click Next. 
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Figure: Specify the data binding properties 

18. Click Next. 
19. Click Finish twice. 

      20. Click Next, and then click Finish. 
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Figure: Complete the new data transformation configuration 

21. Check the output of module and verify results 
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Figure: Check the output of the module 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

 

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server and then select Add and Remove Projects.  

2. Add the SCA module to the server. 

3. Click Finish. 
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Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer integration test 
client.   
 

1. Select the service you want, and click Test > Test Module.    

2. Populate the values for the To, From, Subject and the user-defined mail content and mail attachment. 

3. Click Continue   to run the service. 
 

 

 

Figure: Enter the values to test the module 

 

4. Check the output of the service, and check the data in the EIS to ensure it matches expected values.   
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Figure: Check the output of the service 

5. Check the sample output values as shown here. 

 

Figure: Review the sample output 

Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server, and then select Add and Remove Projects.  

2. Select the module. 

3. Click Remove and then click Finish.  

Nothing is required to clean up after this tutorial. 
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C h a p t e r  1 0 .   Tutorial 8:  Email inbound 
user-defined type with DTF  

 

This tutorial demonstrates a new feature in version 7.0.0.0 of WebSphere Adapter for Email, which 
allows the user to build user-defined wrappers. 

This tutorials demonstrates how to build user-defined wrappers and use it in inbound. This feature can 
be used when you know that all emails you receive are of the same structure. 

 

Scenario  
The following tutorial explains the configuration of the Email adapter to pick up fixed structure emails. 
By selecting the user-defined data type in the external service wizard, you can define your own fixed 
structure wrapper business object. By doing this, you can use ordinary mapping tools to consume and 
work with your business objects without having to determine the business object type at runtime. 

During inbound processing with user-defined type, the adapter will only process events symmetric to 
the User defined Email business objects that you define in the EmailFixedStructureDataBinding data 
binding. If the adapter receives an event that is not symmetric to the specified custom data type, it will 
not process the event. Instead, the adapter will throw an exception with the appropriate error message. 

This scenario plays a role where an organization, say a banking system uses e-mail as primary mode of 
communication with its customers. All the complaints lodged by the customers are over email. In this 
scenario, it would become very difficult for the banking system to process the complaints unless and 
until a particular structure is followed. The organization might now come up with a standard format to 
be followed by the customer to login a complaint. The structure can be something like the first 
attachment being the customer details, Customer ID, Name, Contact Number, Account Type and the 
second attachment being the Complaint. Any mail that does not confirm to this structure would not be 
considered and further processed. 
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Figure: Email inbound user-defined type with DTF 

 

All the complaints would be sent to customercare@bank.com from where the adapter would pick up 
mails for processing using this particular configuration. Fixed structure inbound configuration will read 
all the mails convert them to business objects and handle the info to any available external SCA 
component that can handle customer's compliant. 
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Configuring the adapter for inbound processing  
Run the external service wizard to specify business objects, services, and configuration to 
be used in this tutorial. 

Creating the project 
 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking: File -> New -> Module.  

3. Enter the module name as EmailInboundFixedStructureDTF and click Finish.  

4.  Import the Customer xsd into the module created. Right-click the DataTypes under the module 
EmailInboundFixedStructureDTF and select Import. 

 
Figure: Import the datatypes into the module 

5. Select FileSystem from the General category and click Next. 
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                      Figure: Select the option file system 

6. Browse and choose the sample business object Wbiaddress.xsd and Wbiphone.xsd in this case 
from the xsd folder. 
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                                                       Figure: Import the XSDs 

7. The Wbiaddress.xsd and Wbiphone.xsd can be seen under the data types. 

 
Figure: Expand Data Types 
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8. Start the external service wizard by clicking: File-> New -> External Service 

9. Expand Adapters and select Email, and then click Next. 

10. In the Select an Adapter window, you can either create a new project or select an existing project.  

11. To create a new project, perform the following steps:  

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email    (IBM: 7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
and then click Next. 

12. To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

13. Choose the processing direction as Inbound and click Next. 
 

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary: hostname, username, password, 
port, protocol, location of the staging directory and optionally location of the Archive folder and Failed 
Events Folder. Provide this information in the wizard. 
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Figure3: Enter the connection information 

 

2. Clear the Specify a Java Authentication and Authorization Services (JAAS) alias security 
credential. 

3. Select the Specify a data format for each operation from the Data format options list. 
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Figure: Specify the service properties 

 

 

4. Click Next. 
 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 
 

1. In the Operations window, click Add. 

2. Select the data type as User defined email business object and click Next.  
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Figure: Select the data type 

3. In the Add Operation window, click New, to create a new Input type.  

 
Figure: Create a new data format type 

 

4. Click Next. 

5. Type the Business object name as CustomEmail.  
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6. In Specify the Properties window, click Add to add an e-mail type.  

 
Figure: Add an e-mail type 

7. In the Add/Edit properties window, browse and select the malcontent as Wbiaddress and 
Wbiphone as attachment. 

8. Click Finish twice. 
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9. Select the DataBinding as EmailFixedStructureDataBinding and click Next. 
 

 

 

Figure: Select an existing data format transformation 
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10. Select the MimeType as text/xml. 

 

 

Figure: Configure the data handler 

 

11. In the Data handler configuration, click Select to select the DataHandlerConfiguration. 

12. Select XML and click Next. 
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Figure: Select the XML data handler 

13. Click Next and then click Finish. 

14. Repeat Steps 10 to 13 to add Wbiphone. 

15. Click Next. 
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Figure: Specify the data binding properties 

16. Click Finish. 

 

Figure: Complete the new data transformation configuration 
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17. Click Next, and then click Finish to complete the service and verify the results. 
 

 

Figure: Verify the results 

18. Open the Assembly diagram for the module. Click the Java Component from the palette. Drag and 
drop the same into the assembly diagram.  

19. Name the Java Component as EndPoint and wire the export to the Java Component. 
 

 

Figure: Rename the Java component 
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20. Right-click the Java Component (EndPoint) created earlier and click Generate Implementation. 

21. Select Default package. A java class file implementation is generated for the same. 

 
Figure: Review the Java class file implementation 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server and select Add and Remove Projects 

2. Add the SCA module to the server. 

3. Click Finish. 
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Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer 
integration test client.   
 

1. Select the service you want, and click Test > Test Attach.    

2. Click Continue    to run the service. 

3. Go to the “<WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples” location. Unzip the 
EmailEventCreator.tar or EmailEventCreator.zip file. The utilities are extracted under folder 
EmailEventCreator. 

4. Create Events using the createEvents_sample_passthrough.bat file.  

5. Modify the contents of the file as suits your scenario. The Example content could be as shown here:                      
java -cp .\;.\mail.jar;.\activation.jar EmailEventCreatorNew “9.121.219.72” 25 1 "tester@ibm" 
emailjca@ibm epop3@ibm ejca@ibm "test subject" " <WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" " 
<WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples\EmailEventCreator\WbiPhone.xml" 
"false" 

Note: Use the files WbiAddress.xml and WbiPhone.xml which are there under EmailEventCreator 
folder that was extracted to test the scenario. 

This will create one event from the user tester@ibm on the mail server at 9.121.219.72as IP address, 
with the content as “MyAddress.xml” and with the mail attachment as MyPhone.xml. The other 
attributes of the mail specified by the user will be incorporated on each mail event that is created.  

The mail is processed by the Email Resource adapter and the business object is received through the 
EndPoint java component is shown in the figure below. Observe the Mail Content as well as Mail 
Attachment appearing as the configured user-defined types. 
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Figure: Review the values for mail content and the mail attachment 

 

Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server and select Add and Remove Projects.  

2. Select the module. 

3. Click on Remove and then click Finish.  

Nothing is required to clean up after this tutorial. 
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C h a p t e r  1 1 .  Tutorial 9:  Email inbound 
with search criteria enabled 

Scenario  
Consider an organization where e-mail is the primary mode of communication. The current scenario 
plays a role where there arises a need to process e-mails that satisfy particular criteria.  

Consider a credit card system which resolves complaints lodged by the customers through e-mail. It 
would be very comfortable for the complaint processing system if there is a way to pick up e-mails that 
have a particular text in the subject or if it is from a particular user (say to address is 
abc@company.com). The Email adapter filters and processes only those e-mails that satisfy the search 
criteria mentioned. Only the e-mails with a specific value in the subject field will be processed. For 
example, if there is an application that updates the addresses in the database, Email adapter can be 
configured to pick up only those e-mails that have the search criteria with subject as ‘Address Update’ 
and process only those to the end point. 

mailto:abc@company.com�
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Figure: Email inbound with search criteria enabled 

 

Configuring the adapter for inbound processing  
Run the external service wizard to specify business objects, services, and configuration to 
be used in this tutorial. 

  MailBox 

 

Email InboundInterface

WebSphere adapter for Email 

            Database 

1. Polls the mail box which confirm to 
the structure mentioned in EMD and 
those which satisfy the search criteria 

2. Retrieves the e-
mail

3. Mails thus polled are 
converted to business objects. 
Stores the polled mail to 
database 

4. Polled e-
mail can be 
accessed  



 

 
1 

 

Creating the project 
 

1. Switch to the Business Integration perspective in WebSphere Integration Developer by clicking 
Window -> Open Perspective Business Integration.  

2. Create a new module by clicking: File -> New -> Module.  

3. Enter the Module name as EmailInboundWithSearchCriteria and click Finish.  

4.  Import the Customer xsd into the module created. Right-click DataTypes under the module 
EmailInboundWithSearchCriteria module and select Import. 

 
Figure: Import the Customer xsd into the module 

 

5. Select FileSystem from the General category and click Next. 
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Figure: Import the sample business objects  

 

6. Browse and choose the sample business object Wbiaddress.xsd and Wbiphone.xsd in this case 
from the xsd folder. 
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Figure: Select the sample business objects 

 

7. The Wbiaddress.xsd and Wbiphone.xsd can be seen under the data types. 

 
Figure: Review the business objects 
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8. Start the external service wizard by clicking: File-> New -> External Service 

9. Expand Adapters and select Email and then click Next. 

10. In the Select an Adapter window, you can either create a new project or select an existing project.  

11. To create a new project, perform the following steps:  

a) In the Select an Adapter window, select IBM WebSphere Adapter for Email (IBM: 
7.0.0.0). 

b) Click Next.  

c) In the Adapter Import window, either accept the default name for the project (CWYEM_EMail) or 
provide another name in the Connector project field. 

d) Select the server from the Target runtime list (for example, WebSphere Process Server v7.0.0.0), 
then click Next. 

12. To select an existing project, perform the following steps:  

a) Expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0).  

b) Select a project. For example, if you have an existing project named CWYEM_EMail, you can 
expand IBM WebSphere Adapter for Email (IBM: 7.0.0.0) CWYEM_EMail, then select the 
connection information.  

c) Click Next. 

13. Select the processing direction as Inbound and click Next. 
 

Setting connection properties for the external service wizard 
 

1. To connect to Email server the following information is necessary: hostname, username, password, 
port, protocol, location of the staging directory and optionally location of the Archive folder and Failed 
Events Folder. Provide this information in the wizard. 
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Figure: Enter the connection information 

2. In the Additional properties section of  the Advanced tab, specify the value for Match all search 
criteria as “from=from@ibm, to=ejca@ibm”. 

 
Figure: Enter the search criteria 
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Figure: Specify the service properties 

 

3. Click Next. 
 

Generating business object definitions and related artifacts 

Follow these steps to generate the business object definitions. 
 

1. In the Operations window, click Add. 

2. Select the data type as User defined email business object and click Next.  
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Figure: Select the data type 

3. In the Add Operation window, click New to create a new Input type.  

 
Figure: Create a new data format type 

 

4. Click Next. 

5. Type the Business object name as CustomEmail.  
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6. In properties, click Add to add an e-mail type.  

 
Figure: Add an e-mail type 

 

7. In the Add/Edit properties window, browse and select the malcontent as Wbiaddress and 
Wbiphone as attachment. 

8. Click Finish twice. 

9. Select the DataBinding as EmailFixedStructureDataBinding and click Next. 
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Figure: Select an existing data format transformation 

 

 

10. Select the MimeType as text/xml. 
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Figure: Configure a data handler 

 

11. In the Data handler configuration, click Select to select the DataHandlerConfiguration. 

12. Select XML and click Next. 
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Figure: Select the XML data handler 

 

 

13. Click Next, and then click Finish. 

14. Repeat Steps 9 to 12 to add Wbiphone. 

15. Click Next. 
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Figure: Specify the data binding properties 

16. Click Finish. 

 
Figure: Complete the new data transformation configuration 
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17. Click Next, and then click Finish to complete the service and verifying the results. 

 
Figure: Verify the results 

 

18. Open the Assembly diagram for the module. Click the Java Component from the palette. Drag and 
drop the same into the assembly diagram.  

19. Name the Java Component as EndPoint and wire the export to the Java Component. 
 

 

Figure: Rename the Java component 

20. Right-click the Java Component (EndPoint) created earlier and click Generate Implementation. 

21. Select Default package. A java class file implementation is generated for the same. 
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Figure: Review the Java class file implementation 

 

Deploying the module to the test environment 
 

The result of running the external service wizard is an SCA module that contains an EIS import or 
export. Install this SCA module in WebSphere Integration Developer integration test client.  

1. Add the module you created earlier to the server using the server panel in WebSphere Integration 
Developer. Right-click the server and select Add and Remove Projects.  

2. Add the SCA module to the server 

3. Click Finish. 
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Testing the assembled adapter application   
Test the assembled adapter application using the WebSphere Integration Developer 
integration test client.   
 

1. Select the service you want, and click Test > Test Attach.    

2. Click  Continue   to run the service. 

3. Go to the “<WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples” location. Unzip the 
EmailEventCreator.tar or EmailEventCreator.zip file.  The utilities are extracted under folder 
EmailEventCreator. 

4. Create Events using the createEvents_sample_passthrough.bat file.  

5. Modify the contents of the file as suits your scenario. The Example content could be as shown here:                      
java -cp .\;.\mail.jar;.\activation.jar EmailEventCreatorNew “9.121.219.72” 25 1 "tester@ibm" 
emailjca@ibm epop3@ibm ejca@ibm "test subject" " <WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" " 
<WID_installation>\ResourceAdapters\ Email_7.0.0.0\Samples\EmailEventCreator\WbiPhone.xml" 
"false" 

6. Modify the contents of the file as suits your scenario. The Example content could be as shown here:                      
java -cp .\;.\mail.jar;.\activation.jar EmailEventCreatorNew " 9.121.219.72" 25 1 "from@ibm" 
emailjca@ibm epop3@ibm ejca@ibm "test subject" " <WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiAddress.xml" 
"<WID_installation>\ResourceAdapters\ 
Email_7.0.0.0\Samples\EmailEventCreator\WbiPhone.xml" "false". 

 

Note: Use the files WbiAddress.xml and WbiPhone.xml which are there under EmailEventCreator 
folder that was extracted to test the scenario. 

 

This will create one event from the user tester@ibm and one event from the user from@ibm on the 
mail server at 9.121.219.72 as IP address, with the content as “MyAddress.xml” and with the mail 
attachment as MyPhone.xml. The other attributes of the mail specified by the user will be incorporated 
on each mail event that is created.  

The event whose sender value is from@ibm and to value is ejca@ibm is picked up for processing. 

The mail is processed by the Email Resource Adapter and the business object is received through the 
EndPoint java component as shown in the following figure. Observe that the Mail Content as well as 
Mail Attachment appearing as the configured user-defined types. 
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Clearing the sample content 
Return the data to its original state.   
Remove the module created earlier from the WebSphere Process Server.  

1. Right-click the server and select Add and Remove Projects 

2. Select the module. 

3. Click Remove and then click Finish.  

Nothing is required to clean up after this tutorial 
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C h a p t e r  1 2 .  Troubleshooting 
 

1) Symptom: Enabling of Tracing  

   

     Resolution: Open the server administrative console. Click Troubleshooting -> Logging and tracing -
> server1 -> change log Detail Levels. Under the components -> groups include *=info: 
com.ibm.j2ca.*=finest 

2) Symptom: Tracking successful deployment of a module. 

    Resolution: When you deploy the application you will find this as part of the trace messages: “The 
SCA Module <module name> started successfully. If this is not deployed properly then you may not 
find this message. 

 
Figure: Trace messages 

 

3) Symptom: Publish errors. If you get publish errors wherein you find exception 
in the System.err log of the server logs as: “ IBM WebSphere Adapter for Email 
not found something” as below:  
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Figure: Publish errors appearing as an exception 

 

Resolution: Add the Email adapter under the Dependencies for the Business Integration Module 

 

Figure: Add the adapter 
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Figure: Exception messages 

 

4) Symptoms: Exceptions which would be thrown if endpoint configuration is missed during inbound 
testing and details like that as shown here. 

 

 

Figure: Exception messages due to missing inbound configuration 
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Resolution: When the EndPoint is not configured as detailed under the “Adding the Endpoint” testing 
the assembled adapter configuration, you will find the above exception. Follow the instructions in the 
above section for details over configuring the same.  

5) Symptom: Firewall or some security software is enabled. 

Resolution: Select the Select when security software is running check box if you have firewall or 
some security software enabled. This is always checked by default. 

 

Figure: Select when security software is running check box 
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C h a p t e r  1 3 .  Appendix 

Mail Server Configuration 
 

The Mail server forms a significant part of the EIS Setup. The below document explains the installation 
or setup of one of the mail servers, which is recommend to the users. However, the users can configure 
and use any mail server that support the specific email protocols – IMAP/POP3 on inbound and SMTP 
on outbound – and configure them according to the instructions offered by the provider. 

 

Download the Domino Server version 7.0.2  
The Domino server version 7.0.2 can be downloaded from the Xtreme Leverage portal at this location –  

https://w3-104.ibm.com/software/xl/download/ticket.do?openform 

Download and extract the installer. Follow the steps provided here for its installation. 

Installing Domino Server 
 

1. Click the DominoServer.exe to start the installation of the server. 
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Figure: Start the server installation  

2. Accept the license and click Next.  

 
 

Figure: Accept the license 
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3. Select the installation location and click Next.  

 

Figure: Select the installation location 

4. Make sure that you select Domino Enterprise Server, and continue to click Next until 
the installation starts. 

 

Figure: Select the Domino Enterprise Server option 
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5. Click Finish to complete the installation. 

 

Figure: Complete the installation 

Configuring the Mail Server  
 

The steps to configure the mail server for the first time are given here.  

      1. Open the command prompt and From the Domino server directory (Example: 
C:\Lotus\Domino), and run the nserver command to start the server for the first time. 

2. Select the Start Domino Server as a regular application option, and then select the Don’t ask 
me again check box. Click OK. 

 
Figure: Select the start Domino server as a regular application option 
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3. No options need to be changed. Click Next.  

 

Figure: Accept the default settings 

4. Select the Setup the first server or a stand-alone server option, to set up a stand-alone server is 
being setup. 

 
                        Figure: Select the setup the first server or a stand-alone server option 
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5. Provide a server name and click Next. By default, the machine name is taken as the server name. 

 

Figure: Type the name of the server 

6. Note down server name and the typical username. Provide a certifier password (and note it down for 
your future reference). Click Next. 

 

Figure: Enter a certifier password 
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7. Specify the Domino domain name and click Next. 

 
Figure: Specify the Domino domain name 

8. Enter administrator name and password and. Select the option to save local copy of the ID file. 

 

Figure: Specify an Administrator name and password 
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9. Select the Internet Mail Clients and Directory Services check box. 

Note: This is an important step in the configuration. 

 

Figure: Select Internet mail clients and directory services 

10. Select Next on each window till you see the window shown in the following figure. Click Setup to 
set up the configuration. 
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Figure: Set up the configuration 

10. Repeat the preceding step two to start the server again. Check whether POP3, IMAP, and SMTP 
daemons have started and are active. 

 

Installing Domino Administrator and Designer 
  

 

The Domino administrator tool is used to create user accounts, to change server configuration and so 
on. 

To  nstall the Domino administrator, follow the steps given here  

1. Click DominoDesignerAdmin.exe to start installation of the server. 
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Figure: Start the server installation 

1. Accept the terms and conditions and click Next. 

 

 

Figure: Accept the terms and conditions 
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2. Provide the user name and organization and click Next. 

3. Browse to the correct installation path and click Next. 
 

 

Figure: Select the correct installation path 

 

4. Ensure that the Domino Designer and Administrator features are selected. 
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Figure: Select the Domino Designer and Domino Administrator features 

5. Clear Make Notes my default email program check box and click Install.  

 

Figure: Deselect the make Notes my default email program check box 
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6. Click Finish to complete the installation. 

 

Figure: Complete the installation 

Creating users using Domino Administrator 
 

1. Open the Domino administrator tool, by clicking Start -> Programs -> Lotus Application -> Lotus 
Domino Administrator. 

2. Provide the username and password for administrator. Make sure that you are using the administrator 
id that you created and saved on local as shown in the following example.   

C:\Lotus\Domino\data\admin.id 

3. Click File-> Open Server, and provide the mail server name you have installed. Wait till it connects 
to that server. Here, make sure that the server is up and running. 

Note: If File->Open Server option is not active then change the tabbed window to IBMIN Domain. 
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Figure: Select a server 

4. Once you have successfully connected you will get the following window. Observe that the mail sever 
name is displayed. Using this Lotus Administrator tool, you can monitor and manage the mail server. 

 

 



 

 
5 

 

Figure: The IBMIN Domain – Domino Administrator window 

 

 

Creating users  

 

1. To create users, select People option from the left panel that will display all the registered users. 
Presently, there is only one user that is, administrator.  There is a need to create at least two users for 
this project. 

2. On right hand side of the window, click Register to register new user.  
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Figure: Register a new user 

 

To create two users, ‘email jca’ and ‘email pop3’, use the following procedure.  

1. Specify user first name and last name.  

2. In the Short name field, specify ‘email jca’ (This is the id of the user). Here, the space between the 
letters also matters. 

3. In Mail System field, select IMAP for ‘email jca’ and POP for ‘email pop3’. 

4. Provide the password.  

Comment: Check if it should be 
POP3 
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Figure: Enter the basic details of the user 

5. Click Advanced on the left hand side. 

6. Click to open the Address tab to fill up email address for the user (email jca). 
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Figure: Enter the user’s address details 

7. Internet address is the email address, which will be used by others to send mail. Any mail sent to this 
address will be directed to the user’s mailbox. 

8 Click the check mark on the right hand side of the window. The user is queued in the Registration 
Queue.  

9. Select the user, and then click Register to register the user. 
 

Configuring Email adapter 7.0.0.0 and Domino 7.0 mail server 
for SSL 

 

The steps given here explain how to configure Domino 7.0 for SSL. 

 

Step 1 : Creating a server key ring file   
 

a. From the Notes client, open the Server Certificate Admin application on the server for which you 
want to enable SSL. 
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Figure: Open the Server Certificate Admin application 

b. Click the Create Key Ring option. 

 

Figure: Select the Create Key Ring option 
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c. Complete these fields: 

Field Action 

Key Ring File Name Enter the key ring file name. The default is KEYFILE.KYR. It is helpful to retain the extensio

 as .KYR to keep consistent key ring file names.  

Note: The server's key ring file name is displayed in any Internet Site  
documents that you have configured, or, if the Internet Site documents are not being used, on 

the Ports - Internet Ports tab of the server document.  If If you have specified a name other 

than the default, you need to edit the name where it is displayed – in the Internet Site documen
the Server document. 

Key Ring Password Enter the password for the key ring. 

Key Size Specify the key size Domino uses while creating the public and private key pairs. The larger the
stronger the encryption.  

 

Common name Enter the server's TCP/IP fully-qualified domain name -- for example, www.acme.com.  

Set up the server certificate so that the common name matches the host name since because  

some browsers check for this match before allowing a connection. 

Organization Enter the name of the organization -- for example, a company name, such as Acme. 

Organizational Unit (Optional) Enter the name of certifier division or department. 

City or Locality (Optional) Enter the organization city or locality. 

State or Province Enter the full name of the state or province in which the certifier organization resides. 
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Country Enter the two-character abbreviation of country in which organization resides 

 

d. Click the Create Key Ring option. 

e. Notes create Key Ring file (.kyr) and .sth files. 
 

 

Step 2 : Requesting an SSL server certificate in Domino  

From a third-party CA 

a. Make sure you have already completed step one. 

b. From the Notes client, open the Server Certificate Admin application on server for which you want 
to set up SSL. 

c. Click the Create Certificate Request option. 

 
Figure: Select the Create Certificate Request option 

 

  d. Complete these fields: 
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Field Enter 

Key Ring File Name The name of the server key ring file including the path to the file 

Log Certificate Request Select one: 

Yes (default) to log information in the Server Certificate Admin application 

No,  not to log information 

Method Select one: 

Paste into form on CA's site (recommended) 

e. Click the Create Certificate Request option.  

f. Enter the password for the server key ring file. 

This will create unsigned certificate. Copy the whole content from the last window and store it in some 
file using Notepad.  

Now, the steps for creating of unsigned certificate from Domino are completed. This unsigned 
certificate is called Certificate Signing Request (CSR) 
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Figure: Creating the certificate the request 

 

 

Step 3 Getting SSL certificate from a third party CA 

 

The following steps explain how to get signed SSL certificate from an unsigned CSR. 

a. Open a web browser and go to http://www.verisign.com  
 

http://www.verisign.com/�
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Figure: Fill in the form with appropriate details 

 

b. Browse and select the free SSL trial. 
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Continue 

 

Figure: Select the Free SSL Trial option 

c. Fill out the form as required and click Continue. 
 

 

Figure: Review the form details 
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d. Click Continue. 
 

 

Figure: Enter the contact details 

 

 

e. Fill out the information and click Continue. 
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Figure: Enter the certificate signing request details 

 

f. Use the following values: 

1) Select the Server Platform. 

2) Paste certificate signing request (CSR), obtained from your domino server:  
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3) Open the file in which you have stored CSR in Notepad and copy the contents into this form space. 

 

 

 

4) Click Continue. 

5) Challenge Phrase: <your password> 

6) Re-enter Challenge Phrase: <your password> 

7) Reminder Question: application 

8) Click Continue. 
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Figure: Accept the subscriber agreement 

 

 

g. Click Accept. 
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Figure: Review the information entered in the form 

Making third party CA as trusted root in Domino 
 

1. Open the following address in your browser: 

http://www.verisign.com/support/verisign-intermediate-ca/Trial_Secure_Server_Root/index.html 

This site provides CA trusted root certificate. 
 

http://www.verisign.com/support/verisign-intermediate-ca/Trial_Secure_Server_Root/index.html�
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Figure: Open the VeriSign page that provides the CA trusted root 
certificate 

 

2. Copy the certificate into the clipboard and follow the steps here to upload the CA certificate as 
trusted root into the domino. 

3. Copy the intermediate certificate to the clipboard.  

4. Open the Server Certificate Admin database and click the View & Edit Key Rings option. 
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Figure: Select the View & Edit Key Rings option 

5. Click Select Key Ring to Display and enter the server's key ring file.  

 
Figure: Enter the server's key ring file 
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6. Click the Create Key Rings & Certificates option in the Server Certificate Admin database.  

7. Click the Install Trusted Root Certificate into Key Ring option.  

 
    Figure: Select the Install Trusted Root Certificate into Key Ring option 

The steps describe here how to install the trusted root certificate into the key ring.  
 

1. Enter the server's key ring file name in the Key Ring Information section.  

2. In the Certificate Label field type the following text: VeriSign International Server CA - Class 3.  

3. Return to the Domino Server Certificate Admin document. Paste this text from VeriSign into the 
Certificate from Clipboard area.  

4. Click Merge Trusted Root Certificate into Key Ring. This adds the certificate to your key ring  

5. Copy Key Ring file and its associated .sth file to the domino directory. 

6. You can find .kyr (Key Ring) and .sth file from the notes or data and copy them to domino or data 
folder.  

7. Restart the domino server. 
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Upload the SSL certificate into the Domino Server 
 

a) Check your email for Verisign certificate that you applied for in the previous section.   

b) If the certificate is in the body of the email, copy and paste it into a text file (such as 
OriginalCert.txt) using the VI editor or Notepad. Do not use Microsoft Word or other word 
processing programs that may add extra characters. Confirm that there are no extra lines or spaces in the 
file. 

This is your actual SSL certificate and from now onwards you can use this file. 
 

 

Figure: Check the certificate 
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3) Start uploading the certificate to the Domino server. 

The following steps describe the process for uploading the SSL certificate to the Domino Server. 

1. In Notes, from the Administration panel, click System Databases and select Open Domino Server 
Certificate Administration (CERTSRV.NSF) on the local machine.  

2. Click the Install Certificate into Key Ring option.  

 
Figure: Select the install certificate into key ring option 

 

3. Enter the file name for the key ring that will store this certificate. You created this key ring file when 
you created the server certificate request.  

4. If you copied the contents of the certificate to the clipboard, select Clipboard in the Certificate 
Source field. Paste the clipboard contents into the next field.   
  
5. Click Merge Certificate into Key Ring.  

6. Enter the password for the server key ring file and click OK to approve the merger. This will add the 
SSL certificate as the KeyStore into the Domino server. This completes the configuration of Domino 
server. 

7. This will add the SSL certificate as the KeyStore into Domino server. This completes the 
configuration of Domino Server. 
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8. Copy the Key Ring file and its associated .sth file to the domino directory. 

9. You can find .kyr (Key Ring) and .sth file from the notes or the data folder. Copy these files to the 
domino or data folder. 

10. Restart the domino server. 

Configuring the WebSphere Process Server for SSL 
 

1. Start the WebSphere Process Server by selecting the created server and click Start. 

 

 

 

Figure: Start the WebSphere Process Server 

 

2. After the server is started, right-click the server, and select Run Administrative Console to open the 
administrative console. 

 

Figure: Run the administrative console 
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3. After the Administrative Console window comes up, expand Security and click SSL Certificate and 
key management. 

 

Figure: Select the SSL Certificate and key management option 

4. Under Related Items, click Key stores and certificates. 

 
 

 

Figure: Select the Key stores and certificates option 



 

 
8 

 

5. Click NodeDefaultTrustStore. 
 

 

Figure: Select the NodeDefaultTrustStore option 

 

6. In the Additional Properties, click Signer certificates. 
 

 

Figure: Select the Signer certificates option 
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7. Click Add to add the certificate. Enter the path of the text file where you have saved the SSL 
Certificate that was obtained while setting up the mail server for SSL. 

 

 

Figure: Add the certificate 

 

Figure: Check that the SSL certificate is displayed 
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8. Click Save to save the changes to the master. 
 

 

Figure: Save the changes to the master file 
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Using the project Interchange samples shipped along with the 
adapter installation 

1) Extracting the Samples: 

The samples have been shipped as Project Interchange Files (Zip archives) as discussed in Section 2.3 
under <wid_installlocation>/ResourceAdapters/ Email_7.0.0.0/Samples/referencefiles.  

Open the WebSphere Integration Developer and import the files using the Project Interchange as 
shown here.  

 
Figure: Import the samples 
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Figure: Select the samples to import 

2) Changing the Email Connection details(Inbound Case) 

 

a) Changing the connection details in the ActivationSpec properties of the assembly diagram of the 
Business Integration module. 

1. Open the Assembly diagram. Select the Generated Email Interface for example, 
EmailInboundDTFWithoutBG. 
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Figure: Select the Generated Email Interface 

3. Click Properties -> End-point configuration -> Activation Spec properties.  

4. Provide the connection details for host name, port, username, password, and other required details to 
suit your environment. 

 

 

Figure: Enter the connection details 
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b) Changing the connection details in the J2C Activation Spec properties in the WebSphere Process 
Server Administrative console after the Application has been deployed into the server. 

1. Start the administrative console. 

2. Click Applications -> Enterprise Applications -> <your installed Application, for example, 
EmailInboundDTFWithoutBG >.  

 

 

Figure: Enter the name of the enterprise application 

 

3. In Modules, click Manage Modules. 

4. Select the Email Rar. 

5. In the Additional Properties, click Resource Adapter. In the Additional Properties, click J2C 
Activation Specifications. 

6. Choose the Activation specification related to the deployed module. 

7. Select Additional Properties -> J2C activation specification custom properties. Specify and 
change the values to suit your environment 
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Figure: Change the settings as per your environment 

 

3. Changing the Email Connection details (Outbound Case) 

 

a) Changing the connection details in the ManagedConnectionFactory properties of the assembly 
diagram of the Business Integration module. 

1. Open the Assembly diagram. Select the Generated Email Interface for example, 
EmailOutboundDTFWithoutBG. 
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Figure: Select the generated email interface 

 

2. Click Properties -> End-point configuration -> Managed Connection Factory properties. 

 3. Provide the connection details for host name, port, username, password, and other required details to 
suit your environment. 

 

 

Figure: Enter the connection details 

 

 

b) Changing the connection details in the J2C Connection Factory properties in the WebSphere Process 
Server Administrative console after the Application has been deployed into the server. 

        1) Start the administrative console 
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        2) Click Applications -> Enterprise Applications -> <your installed Application for example, 
EmailOutboundDTFWithoutBG >  

 

 

Figure: Enter the name of the enterprise application 

 

3) In Modules, click Manage Modules  

4) Select the Email Rar (IBM WebSphere Adapter For Email)  

5) In the Additional properties, click Resource Adapter. 

6) In the Additional properties, click J2C connection factories. 

6) Select the connection properties specification related to the deployed module that is. 
EmailOutboundDTFWithoutBG.EmailOutboundDTFWithoutBG_CF. 

7) Click Additional Properties -> Custom properties. You can specify and change the values suiting 
to your environment. 
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Figure: Change the settings as per your environment 

4) Deploying the Samples into WebSphere Process Server 

a) Deploying the EAR directly into the WebSphere Process Server using Add & Remove projects. 

1. Right-click the server and click on Add and Remove projects. 

2. Select the EAR module generated and deploy into the WebSphere Process Server. 
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Figure: Select the EAR module 

 

 

 b) Exporting the EAR module and installing the same into the WebSphere Process Server using the 
Server Administrative console. 

1. In the Business Integration workspace, right-click and select Export. 

2. Select the EAR file. 
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Figure: Select the EAR file option 

 
 

3. Select the EAR Module say for example, EmailInboundDTFWithoutBGApp and export the EAR 
file to a temporary location in your file system. 
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  Figure: Select the EAR module 

4. Open the server administrative console upon server startup. 

5. In the administrative console click, Applications -> Enterprise Applications and click Install. 

6. Select the EAR file saved in the temporary location, and then select the default values and complete 
the installation. The deployed application shows up among the installed applications and a green arrow 
is shown and verifies that it is deployed successfully. 
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Figure: Select the default values and complete the installation 

 

 

 

Creating Events 
 

The events that will be created for the pass-through scenario testing will be different from the ones 
created for non-pass through scenario tests. The mail format would be the same, but the content or 
attachments would be different. 

 

EmailEventCreator 

 

This is a program that will be shipped to provide the users with a capability to create events on the mail 
server. 

The program would work both for pass-through mode and the non-pass-through mode. The batch file 
createEvents.bat provides a command-line interface to the EmailEventCreator. The user can edit the 
batch file and provide several parameters on the command-line. Based on the user-specified parameters, 
the events will be created. 

The command-line parameters that can be specified by the user are as shown here. 
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<host> <port> <number of events to be created> <from> <to> <cc> 
<bcc> <subject> <content> <path for event filename>  <boolean for 
passthru/nonpassthru> 

Where, 

Host - the IP address of the mail server 

Port - port number 

Number of events to be created – Total number of events required to be created for testing 

From - the mail id for the mail account from which mail is to be written 

To - the mail id for the mail account to which mail is to be written 

CC - the mail id for the mail account on cc of the mail 

BCC - the mail id for the mail account on bcc of the mail  

Subject – subject for the event mail 

Content – Sample pass-through text content for the mail 

Path for event file name – The path on the local folder where the event file attachment (for example, 
MyAddress.xm) has been placed. 

Boolean for pass-through or non-pass-through – true or false values indicating requirement of pass-
through scenario. True = pass-through. 

 

 

Procedure to create events with these artifacts  

 

Unzip the EmailEventCreator.zip to a <samples_temp> directory. 

Edit the createEvents.bat file to specify the appropriate parameters. Save and close the file. An example  
is shown here.  

 

Pass-through mode –  

java EmailEventCreator localhost 25 10 from@in.ibm.com to@in.ibm.com cc@in.ibm.com 
bcc@in.ibm.com TestEmail TestPassthruContent C:\EmailRA\Samples\MyPicture.jpg true  

 

 This will create 10 events from the user from@in.ibm.com on the localhost mail 
server with the content from the C:\EmailRA\Samples\MyPicture.jpg attached to 

mailto:venkatre@in.ibm.com�
mailto:to@in.ibm.com�
mailto:cc@in.ibm.com�
mailto:bcc@in.ibm.com�
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the mail. The other attributes of the mail specified by the user will be incorporated 
on each mail event that is created. 

Refer to the createEvents_sample_passthrough batch file (or shellscript) contents for illustration. 
 

Non-pass-through mode –  

java EmailEventCreator localhost 25 10  from@in.ibm.com to@in.ibm.com 
cc@in.ibm.com bcc@in.ibm.com TestEmail TestXMLContent 
C:\EmailRA\Samples\MyAddress.xml false  

 

 This will create 10 events from the user from@in.ibm.com on the localhost mail server with the 
content from the C:\EmailRA\Samples\MyAddress.xml attached to the mail. The other attributes of 
the mail specified by the user will be incorporated on each mail event that is created. 

 

Refer to the createEvents_sample_nonpassthrough batch file (or shellscript) contents for illustration. 
 

Non-pass-through mode with content other than text/plain–  

java EmailEventCreatorNew localhost 25 10 from@in.ibm.com to@in.ibm.com 
cc@in.ibm.com bcc@in.ibm.com TestEmail 
C:\EmailRA\Samples\FixedEventCreator\MyAddress.xml C:\EmailRA\Samples\MyPhone.xml true  

 

 This will create 10 events from the user from@in.ibm.com on the localhost mail server with the 
content from the C:\EmailRA\Samples\MyPicture.jpg attached to the mail and with the mail content as 
that of the xml file MyAddress.xml. The other attributes of the mail specified by the user will be 
incorporated on each mail event that is created. 

 

Refer to the createEvents_sample_nonpassthroughWithFileContent batch file (or shellscript) contents 
for illustration. 

 

1. Double-click to run the createEvents.bat file (or invoke through the command window). 
Instead, you can use the createEvents_sample_passthrough, 
createEvents_sample_nonpassthrough or 
createEvents_sample_nonpassthroughWithFileContent  script files. 

 

 

mailto:from@in.ibm.com�
mailto:to@in.ibm.com�
mailto:cc@in.ibm.com�
mailto:bcc@in.ibm.com�
mailto:venkatre@in.ibm.com�
mailto:to@in.ibm.com�
mailto:cc@in.ibm.com�
mailto:bcc@in.ibm.com�
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Use the mail client to verify that the events are created successfully, before the resource adapters is 
started. 
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Notices  
This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in other countries. 
Consult your local IBM representative for information on the products and services currently available 
in your area. Any reference to an IBM product, program, or service is not intended to state or imply that 
only that IBM product, program, or service may be used. Any functionally equivalent product, program, 
or service that does not infringe any IBM intellectual property right may be used instead. However, it is 
the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or 
service. 

IBM may have patents or pending patent applications covering subject matter described in this 
document. The furnishing of this document does not grant you any license to these patents. You can 
send license inquiries, in writing, to: 

IBM Director of Licensing 

IBM Corporation 

North Castle Drive 

Armonk, NY 10504-1785 

U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property 
Department in your country or send inquiries, in 

writing, to: 

IBM World Trade Asia Corporation Licensing 

2-31 Roppongi 3-chome, Minato-ku 

Tokyo 106-0032, Japan 
 

The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law:  

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION 
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-
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INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this 
statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. 

IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only and do not 
in any manner serve as an endorsement of those Web sites. 

The materials at those Web sites are not part of the materials for this IBM product and use of those 
Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you. 

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the 
exchange of information between independently created programs and other programs (including this 
one) and (ii) the mutual use of the information which has been exchanged, should contact: 

IBM Corporation Department  

2Z4A/SOM1 294 Route 100  

Somers, NY 10589-0100 U.S.A. 

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM 
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of 
those products. 

This information contains examples of data and reports used in daily business operations. To illustrate 
them as completely as possible, the examples include 

the names of individuals, companies, brands, and products. All of these names are fictitious and any 
similarity to the names and addresses used by an actual business enterprise is entirely coincidental. 

 

 

COPYRIGHT LICENSE: 

This information contains sample application programs in source language, which illustrate 
programming techniques on various operating platforms. You may copy, modify, and distribute these 
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sample programs in any form without payment to IBM, for the purposes of developing, using, 
marketing or distributing application programs conforming to the application programming interface for 
the operating platform for which the sample programs are written. These examples have not been 
thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, 
serviceability, or function of these programs. 

 

If you are viewing this information softcopy, the photographs and color illustrations may not appear. 
 
Programming interface information  

Programming interface information, if provided, is intended to help you create application software 
using this program. 

General-use programming interfaces allow you to write application software that obtain the services of 
this program's tools. 

However, this information may also contain diagnosis, modification, and tuning information. Diagnosis, 
modification and tuning information is provided 

to help you debug your application software. 

Warning: 

Do not use this diagnosis, modification, and tuning information as a programming interface because it is 
subject to change. 
 
 
Trademarks  

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business 
Machines Corporation in the United States, other countries, or both. These and other IBM trademarked 
terms are marked on their first occurrence in this information with the appropriate symbol (® or ™), 
indicating US registered or common law trademarks owned by IBM at the time this information was 
published. Such trademarks may also be registered or common law trademarks in other countries. A 
complete and current list of IBM trademarks is available on the Web at 
http://www.ibm.com/legal/copytrade.shtml 

 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both. 

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, 
or both. 

Java and all Java based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both.*  

http://www.ibm.com/legal/copytrade.shtml�


 

 
9 

UNIX is a registered trademark of The Open Group in the United States and other countries. 

Other company, product, or service names may be trademarks or service marks of others. 

This product includes software developed by the Eclipse Project (http://www.eclipse.org).  
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