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C h a p t e r  1 .  Introduction  
The Siebel Resource Adapter (RA) enables exchange of data with the Siebel EIS through two 
types of Siebel objects – Siebel Business Services and Siebel Business Objects. 

The SAP Resource Adapter creates integrated processes that include the exchange of 
information with an SAP server, without special coding.  

Learning Objectives 

After completing this tutorial, you should be able to perform the following tasks: 

• Create an adapter project in WebSphere Integration Developer (WID). 

• Create an integration sample using existing Siebel and SAP imports, invoked using a 
Plain-Old Java Object (POJO). 

• Create a deployable module that you install on WebSphere Process Server (WPS) or 
WebSphere Enterprise Service Bus (WESB). 

• Test the module and validate the results. 

Audience 

Integration developers who design, assemble, test, and deploy business integration 
solutions will find this tutorial useful.  

Software prerequisites 

To use this tutorial, you must install the following applications:  

• WebSphere Integration Developer version 7.0 

• WebSphere Process Server version 7.0 

• Siebel EIS 

• SAP EIS 
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C h a p t e r  2 .  Preparing to run through the 
tutorial 

 

Configuration prerequisites 

Before testing this tutorial, make sure you understand how to create an outbound interface 
for IBM WebSphere SAP Adapter 7.0 and IBM WebSphere Siebel Adapter 7.0.  
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C h a p t e r  3 .  Creating a synchronization 
application which automatically 
updates SAP records when the 
corresponding Siebel record is 
updated 

This tutorial demonstrates how to use WebSphere Process Server’s Relationship Server 
(static) to lookup linked customer IDs for automatically syncing SAP and Siebel records. 

Scenario 

This application uses a POJO to initially create records in both Siebel and SAP EISes, and 
map the created unique IDs to a logical ID using the Relationship Service. When an 
update is issued to a Siebel record (the unique ID is part of the request), the corresponding 
SAP ID is looked up using the Relationship Service and the update is completed. Similar 
strategy can be used for the Retrieve and Delete operations too. A generic interface has 
been designed to integrate both these applications. 

Configuring the adapter for outbound processing  

Run the New External Service wizard to specify business objects, services, and 
configuration to be used in this tutorial. 

Creating the project 

1. Switch to the WID Business Integration Perspective by choosing Window -> Open 
Perspective -> Business Integration.  

2. Create a new Module by choosing: File -> New -> Module. Enter the Module name 
as ‘Samplev1’and click Finish.  

3. Refer to the QSS for Siebel and SAP to create the corresponding Imports. 

4. For Siebel, use the Contact object using the Siebel Business Object Interface. 

5. For SAP, use  
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a. BAPI_CUSTOMER_CREATEFROMDAT1 to create a new customer 

b. BAPI_CUSTOMER_CHANGEFROMDATA to update a customer’s 
information 

c. BAPI_CUSTOMER_GETDETAIL to retrieve customer details 

  

6. The following diagram represents an assembly diagram for a module that was created.  

 

 

Creating a new Generic Interface 

7. Right-click Interfaces –> New -> Interface 
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8. Enter GenericInterface as the interface name. 

9. Click  to add three Request Response Operations which are: createRecords, 
updateRecords and retrieveRecords. 
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10. Use GenericBOBG as the Input and Output types for the three operations. 

 

Creating a POJO to implement the core interface 

1. Add a POJO to the Assembly diagram and wire it to the SAP and Siebel interfaces. 
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2. Right-click Human Task component -> Add -> Interface 
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3. Select and add the interface, GenericInterface and click OK.  

 

Implement the POJO  
1. Right-click the POJO component -> Generate Implementation. 

 

2. Add the code to the Component Implementation and also into your implementation. 
The following snippet of code is used to invoke the Relationship Service manually and 
generate a managed ID. The second line of code is used to link the SAP ID with the 
managed ID. 

try { 
int genId = relService.addParticipantString(relationshipName, siebelRole, siebelID); 

relService.addParticipantStringWithID(relationshipName,  sapCreateRole, genId, sapID); 

} catch (RelationshipServiceException e) { 
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e.printStackTrace(); 

} catch (RelationshipUserException e) { 

e.printStackTrace(); 

} 

   

return input1; 

} 

 

The following snippet of code is used to retrieve the corresponding SAP ID 
for a Siebel ID that is mapped using a managed ID. 
/* 

 * The SAP ID will be retrieved with the help of the Relationship Service 

 */ 

int[] ids; 

try { 

 ids = relService.retrieveInstanceIDsByString(relationshipName, siebelRole, siebelID); 

 if(ids.length > 0) { 

    List codes = relService.retrieveParticipants(relationshipName, sapCreateRole, ids[0]); 

    if(!codes.isEmpty()) { 

       sapID = ((DataObject) 
codes.get(0)).getDataObject("SapBapiCustomerCreatefromdata1").getString("NewCustomerNu
mber"); 

    } 

 } 

} catch (RelationshipServiceException e) { 

e.printStackTrace(); 

} catch (RelationshipUserException e) { 

 e.printStackTrace(); 

} catch (Exception e) { 

 e.printStackTrace(); 

} 

Deploying the module in the test environment 

1. When you run the New External Service wizard, the SCA module is displayed, with 
the Enterprise Integration System (EIS) Import or Export feature.  

2. Install the SCA module in the WID test client.  

3. Add the module that you created earlier to the server using the WID Server Panel. 

4. Right-click the server node and select Add and Remove Projects.  
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5.  Add the SCA module to the Configured projects pane. 

6. Click Finish. 
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Testing the Web application 

This section describes how to test the application, that you created using a web service.   

1. After the module is deployed, right-click on the Test Component to launch it. 

 

2.  Start with the create operation. Refer to the Execution traces for help with sample 
values. 
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3.  After executing the create operation, check for the Siebel ID. Execute the update 
operation on this Siebel ID. Do not specify the value for the SAP ID. The SAP ID will 
be mapped using the Relationship Service. 
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4.  The SAP System will also be updated but the SAP ID is mapped dynamically using 
the Relationship APIs.   
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Notices  
This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and services 
currently available in your area. Any reference to an IBM product, program, or service is not 
intended to state or imply that only that IBM product, program, or service may be used. Any 
functionally equivalent product, program, or service that does not infringe any IBM intellectual 
property right may be used instead. However, it is the user's responsibility to evaluate and 
verify the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter described in this 
document. The furnishing of this document does not grant you any license to these patents. 
You can send license inquiries, in writing, to: 

IBM Director of Licensing 

IBM Corporation 

North Castle Drive 

Armonk, NY 10504-1785 

U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual 
Property Department in your country or send inquiries, in writing, to: 

IBM World Trade Asia Corporation Licensing 

2-31 Roppongi 3-chome, Minato-ku 

Tokyo 106-0032, Japan 
 

The following paragraph does not apply to the United Kingdom or any other country where 
such provisions are inconsistent with local law:  

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS 
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
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PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied 
warranties in certain transactions, therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are 
periodically made to the information herein; these changes will be incorporated in new 
editions of the publication. 

IBM may make improvements and/or changes in the product(s) and/or the program(s) 
described in this publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only 
and do not in any manner serve as an endorsement of those Web sites. 

The materials at those Web sites are not part of the materials for this IBM product and use of 
those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate 
without incurring any obligation to you. 

Licensees of this program who wish to have information about it for the purpose of enabling: 
(i) the exchange of information between independently created programs and other programs 
(including this one) and (ii) the mutual use of the information which has been exchanged, 
should contact: 

IBM Corporation Department  

2Z4A/SOM1 294 Route 100  

Somers, NY 10589-0100 U.S.A. 

Information concerning non-IBM products was obtained from the suppliers of those products, 
their published announcements or other publicly available sources. IBM has not tested those 
products and cannot confirm the accuracy of performance, compatibility or any other claims 
related to non-IBM products. Questions on the capabilities of non-IBM products should be 
addressed to the suppliers of those products. 

This information contains examples of data and reports used in daily business operations. To 
illustrate them as completely as possible, the examples include the names of individuals, 
companies, brands, and products. All of these names are fictitious and any similarity to the 
names and addresses used by an actual business enterprise is entirely coincidental. 

 

COPYRIGHT LICENSE: 

This information contains sample application programs in source language, which illustrate 
programming techniques on various operating platforms. You may copy, modify, and 
distribute these sample programs in any form without payment to IBM, for the purposes of 
developing, using, marketing or distributing application programs conforming to the 
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application programming interface for the operating platform for which the sample programs 
are written. These examples have not been thoroughly tested under all conditions. IBM, 
therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. 

If you are viewing this information softcopy, the photographs and color illustrations may not 
appear. 
 
Programming interface information  

Programming interface information, if provided, is intended to help you create application 
software using this program. 

General-use programming interfaces allow you to write application software that obtains the 
services of this program's tools. 

However, this information may also contain diagnosis, modification, and tuning information. 
Diagnosis, modification and tuning information is provided to help you debug your 
application software. 

Warning: 

Do not use this diagnosis, modification, and tuning information as a programming interface 
because it is subject to change. 
 
 
Trademarks  

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International 
Business Machines Corporation in the United States, other countries, or both. These and other 
IBM trademarked terms are marked on their first occurrence in this information with the 
appropriate symbol (® or ™), indicating US registered or common law trademarks owned by 
IBM at the time this information was published. Such trademarks may also be registered or 
common law trademarks in other countries. A complete and current list of IBM trademarks is 
available on the Web at http://www.ibm.com/legal/copytrade.shtml 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both. 

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other 
countries, or both. 

Java and all Java based trademarks and logos are trademarks of Sun Microsystems, Inc. in the 
United States, other countries, or both.*  

UNIX is a registered trademark of The Open Group in the United States and other countries. 

Other company, product, or service names may be trademarks or service marks of others. 

This product includes software developed by the Eclipse Project (http://www.eclipse.org).  

http://www.ibm.com/legal/copytrade.shtml�
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