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Chapter 1. Introduction

To help you understand how to monitor operations in business applications using
WebSphere adapters, this sample provides a monitor model that is generated from
a Service Component Architecture (SCA) interface operation and mediation flow,
and is then completed in the Monitor development tooling. The sample showcases
an SCA entry event with payload coming from a source WebSphere adapter.

[Printable version of this tutorial|

For this sample, an inbound interface operation and mediation flow for a Java
Database Connectivity (JDBC) adapter is created in IBM® WebSphere® Integration
Developer v6.1. A monitor model is generated from this operation and mediation
flow. This monitor model is augmented to calculate metrics, and is then deployed.

The module used in this sample is the MonitorAdapter module. All project
interchange (PI) files are available in a .zip file called MonitorAdapter.zip. You can
import the MonitorAdapter.zip file into WebSphere Integration Developer and
review the module, the generated events, and the augmented monitor model. You
can then test the monitor model using db2 commands. This sample describes the
steps necessary to implement the solution, the PI file is not required unless you
want to skip the implementation of the solution (see Appendix A for instructions
on how to import the completed solution provided by the PI file).

This sample uses the WebSphere Integration Developer test environment to test the
adapter/mediation flow and the monitor model. Both the adapter / mediation
application and the monitor model application are deployed to the WebSphere
Business Monitor v6.1 Server for WebSphere Enterprise Service Bus test server. The
WebSphere Business Monitor test server could also be based on WebSphere Process
Server.

You must have the following software to run this sample:

* WebSphere Integration Developer v6.1—the runtime test environment for
WebSphere Enterprise Service Bus or WebSphere Process Server must be
installed.

* WebSphere Business Monitor v6.1—toolkit installation including the model
editing tooling and the Monitor server based on WebSphere Enterprise Service
Bus or WebSphere Process Server. This sample assumes the use of a Monitor
server on WebSphere Enterprise Service Bus.

* DB2 Enterprise Server Edition—This sample was tested using DB2 Enterprise
Server Edition 8.2.6.

This documentation has five sections:
e Introduction—this section.

* Overview—Explains the scenario used in this sample, the Data Model, Human
tasks and some installation tips.

* Build It Yourself—Step by step instructions to build the sample from scratch.

* Run the Sample— Run the downloaded artifacts, or the artifacts built in the
Build It Yourself section.

* Download the Sample—Explains how to install the downloaded prebuilt
solutions for this sample.
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Chapter 2. Overview

This sample explains the major steps required to build the MonitorAdapter
module, generate the monitor model, augment the monitor model, deploy the
monitor model, run test data through the adapter to be consumed by the monitor
model, and show monitoring results on a dashboard.

Here is a summary of the scenario used in this sample. When a new customer
record is added to a database table, a JDBC adapter becomes aware of it and sends
customer information to a mediation flow to process. In the monitor model, you
define metrics to be set from the data issued by the JDBC adapter, and key
performance indicators (KPIs) to be set using metric data. You then build a
monitor dashboard to display the metrics and KPIs calculated by the monitor
model processing.

¢ The MonitorAdapter module has two components: JDBCInboundInterface and
MediationFlow. After a customer record is added to the database table, the JDBC
inbound interface operation is activated to invoke the mediation flow with the
payload.

* Based on the SCA operation and mediation flow, a monitor model is generated.
In the Monitor Model Editor, you will add metrics to the generated monitor
model to monitor the data from the adapter and mediation flow.

* To see the resulting metrics and KPlIs, use the Instances view and the
Dimensional view in the dashboard.

In this lab, you will create a J2EE application using WebSphere Integration
Developer. In the application, the JDBC adapter acts as an event resource to fetch
data from a database and then send that data to the mediation flow which emits
CBEs containing the business data from the database.

Then you will create a monitor model and define the metrics.

After that you will deploy the application and monitor model to WebSphere
Business Monitor test environment server.

You will then use db2 commands to trigger the monitored application to submit
events.

Finally, you will configure dashboards in the WebSphere Integration Developer test
environment and view the monitored data in several different views.
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Chapter 3. Build it yourself

Build the sample, and then test it.

Prerequisite: Ensure that you have installed all the products listed in the Overview
section.

Start building the Adapter sample by creating the DB2 resources, the adapter, and
the mediation flow for your sample.

Create the DB2 artifacts for the sample

Before creating the module, you must created the DB2 artifacts for the adapter.

Create the DB2 artifacts that you will use for the sample by performing the
following steps:

1. Open the DB2 Control Center and right click on All Databases and select
Create Database » Standard.

2. Type ADAPTER for the database name and click Finish.

Wait for the database to be created the click No.

4. Open a DB2 command window and run the following commands:
db2 connect to ADAPTER user db2admin using <db2 password>

w

db2 -tvf c:\<path>\MonitorAdapter_db2.sql

db2 disconnect ADAPTER
The MonitorAdapter_db2.sql file contains the following information:

CREATE TABLE customer

(

pkey VARCHAR(10) NOT NULL PRIMARY KEY,
fname VARCHAR(20),

Tname VARCHAR(20),

ccode VARCHAR(10)

)s

CREATE TABLE WBIA JDBC_EventStore

(

event_id INTEGER NOT NULL GENERATED ALWAYS AS IDENTITY (START WITH 1, INCREMENT

xid VARCHAR(200) ,

object key VARCHAR(80) NOT NULL,

object name  VARCHAR(40) NOT NULL,

object function  VARCHAR(40) NOT NULL,

event _priority INTEGER  NOT NULL,

event_time TIMESTAMP default CURRENT TIMESTAMP NOT NULL,
event_status INTEGER ~ NOT NULL,

event_comment VARCHAR(100)

)s

CREATE TRIGGER event create
AFTER INSERT ON CUSTOMER REFERENCING NEW AS N



FOR EACH ROW MODE DB2SQL
INSERT INTO wbia_jdbc_eventstore (object key, object name, object function, event prior

Create a new Mediation module for the JDBC adapter

To skip the steps for creating this module, you can import the supplied project

interchange file (MonitorAdapter.zip) into WebSphere Integration Developer. Refer
to Downloading, then go to Test.

1. Start WebSphere Integration Developer and change the current perspective to

Business Integration.
a. Click Window » Open Perspective » Other.
b. Select Business Integration (default), and click OK.

2. Right-click in the Business Integration view, then click New » Mediation

Module.
4= Business Integration - IBM WebSphere Integration Developer 6.1 - C:documents',widb. 1 workspa 1ol =l
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3. Type MonitorAdapter for the name of the new mediation module and select
WebSphere ESB Server 6.1 as the target runtime.

4. Click Finish to create the new module.
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Add the JDBC adapter

Add a JDBC Adapter external service to the mediation module and deploy the

mediation module.

1. Right click MonitorAdapter and select New - External Service.
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Select Adapters and click Next.
Select IBM WebSphere Adapter for JDBC and click Next.
Select WebSphere ESB Server v6.1 for the Target runtime and click Next.

Click Add, locate and select the db2jcc.jar and db2jcc_licence_cu jar files in

the DB2 installation directory and click Open to add the JDBC driver jar files
and click Next.
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6. Select Inbound and click Next.

7. Select DB2 UDB » V8.2 from the database list and type ADAPTER for the
database, type the DB2 admin user name and password.

8. Click Next, then click Run Query to find the table lists. Select DB2ADMIN -
Tables > CUSTOMER and click > to add CUSTOMER to the Selected objects
list. Click Next.

9. Click Next.

10. In the Service Generation and Deployment Configuration window, enter the
following values:

a. For J2C Authentication Data Entry, type <NodeName>/JDBCAdapter/
inbound, where <NodeName> is the node name of the WebSphere
Application Server that will run the MonitorAdapter module. The node
name for the Monitor Server on WebSphere ESB defaults to
WBMonSrv_esb_Node.

b. Enter the password for the DB2 Admin User name.

c. Click Advanced and expand Advanced connection configuration and
type jdbc/DB2XA as the Datasource JNDI name. You will create this
datasource later.

4+ External Service [ x|

Service Generation and Deployment Configuration

Specify properties For generating the service and running it on the server, - Q ]
. =
-
User name: I dbZadmin
Passwaord: | Hhhha
<= Advanced |

l ¥ Event polling configuration ]

I b Event delivery configuration l

[+ Advanced connection configuration

Datasource JNDI name: | jdbc/DBZx%

Additional JDBC driver
connection properties |
[name:value;name: value]:

SOL query ko verify the connection: |

Query timeout {seconds): I

Return business object even when the =
stored procedure resulk set is emply: IFaIse J LI

(7 < Back INEXTI Einishy Cancel |

11. Click Next and then click Finish.

Create the mediation flow

Now create the mediation flow.

1. The Assembly Diagram editor is open. There are two elements:
JDBCInboundInterface, which was created when you added the adapter, and
MonitorAdapter, which was created when the module was initially created.
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2. Right-click MonitorAdapter and select Rename. Type MediationFlow and

press Enter.

3.

tool. In response to the prompt, click OK.

Change back to the Selection tool on the Palette and then right-click

MediationFlow and select Regenerate Implementation.
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5. Click OK at the prompt.
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6. In the Mediation Flow Editor window, click createDb2adminCustomerBG and
you see a source operation for createDb2adminCustomerBG.

7. In the flow, right-click and select Add > Stop .

8. Connect the out terminal of createDb2adminCustomerBG to the input
terminal of Stopl.
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Ele Edit Mavigate Search Project Data Run  Window Help
J i+ 5] & J =] - J s J Q- [ Hl. Business Mani..,
J Z - = e 2 J e =] F@Businesslnte..‘
& Admin Consale | 25 Manitorfidapter - Assembly Ciagram =&
e
~Dperation connections & 'ﬂ éf_’, =
Select a source operation, connect it bo one or more target operations, and define the mediation Aow,
(1) IWECInboundinterface
%2 createDb2adminCustomerBG
‘é“% updateDbZadminCustomerBG b
%2 delsteDbZadminCustomerBG LI

|¢§ ? ?;Ilette = 3 ’! # Mediation Flow I

= Fa:or\t\as 5, Input =i References K

[ Routing createDbZadming. .. (] Correlation Co., 52 3

|~ Transformation Stopl <nat specified >

L= Tracing ("I Transient Con... % %

|~ Error Handling  <notspecified>
¥ Fail [ZJshared Corkext == 5
[= Stop =nat specified >

—IE'$ Request: createDbZadmlnCustomerBGI

J0e I
9. Save the Mediation and then click MonitorAdapter:Assembly Diagram.

10. Click MediationFlow and in the Properties tab select Details. Go toInterfaces
> JDBCInboundInterface » createDb2adminCustomerBG and click the Event
Monitor tab. Select All for Monitor and select Full for Event Content.
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1.

Click the Global Event Setting tab. The default event format is WebSphere
Business Monitor 6.1 format.

12. Save the assembly diagram.

Generate a monitor model from the MonitorAdapter module

You will use the WebSphere Business Monitor tooling in WebSphere Integration
Developer to generate a starter monitor model from the MonitorAdapter module
and then you will use the Monitor Model Editor in WebSphere Integration
Developer to enhance the monitor model.

1.

Right-click MonitorAdapter and select Monitor Tools » Generate Monitor
Model.

Click New project.

For the name of the new business monitoring project, type MonitorAdapterBM.
Click Finish.

For the name of the monitor model name, type MonitorAdapterMM. Click Next.

Select JDBCInboundInterface.createDb2adminCustomerBG and click Emitted
Events.

Click Select All and then click Next. Click Next again.
Click Expand All to see the elements of the Monitor model. Click Finish.
kS

Preview the monitor model e

This preview shows the monitor model that: will be generated. You can go back and make changes, or click Finish to generate the monicor model,

= Bk Monitorsidapterth

= | MonitaradapterModule

: = WEISESSION_ID

E|LT'> JDECInboundInterface.createDbzadminCustomerBG
r,'? JDBCInboundInterface. createDbZ adminCustomerBGEMTRY
r,'? IDECInboundInterface. createDb2adminCustomerBGEXIT
r,'? IDBCInboundInterface. createDb2adminCustomerBEFAILURE

Collapse All |

7) < Back | [dexE = Einish Caneel

8. Click Yes to go to the Business Monitoring perspective.

9. For this sample, click No for the getting started information.
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Add trigger and metrics to the monitor model

12

Add a trigger and metrics to the model so that it can be tested later.

1.

Right-click MonitorAdapterModule and select New > Trigger.

4+ Business Monitoring - MonitorAdapterM™ - IBM WebSphere Integration Developer 6.1 - C:docun —|F 5[
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| |

For Name, type JDBCInbound Entry Trigger and then click OK.

On the right panel, click Add. Select

JDBCInboundInterface.createDb2adminCustomerBGEntry and then click OK.

Add the FName metric using the following steps:

a. Right-click MonitorAdapterModule and select New-> » Metric.

b. For the Name, type FName Metric. Click OK.

C. On the right panel, click Add under Metric Value Expressions.

d. Click in the space under Trigger. Click ... and select JDBCInbound Entry
Trigger. Then click OK.

e. Click in the space under Expression and press Ctrl+Spacebar to use the
content assist function. Go to
MonitorAdapterMMMonitorAdapterModule] DBCInboundInterface.createDb2adminCusto:
Db2adminCustomer:Db2adminCustomer.

f. Double click fname. The FName Metric is finished and will be assigned the
fname from the service data object received from the adapter.

Add the LName Metric with JDBCInbound Entry Trigger and expression using
the same
process.JDBCInboundInterface.createDb2adminCustomerBGENTRY. createDb2AdminCustomerInput:D

Add CCode Metric with JDBCInbound Entry Trigger and expression
JDBCInboundInterface.createDb2adminCustomerBGENTRY.createDb2AdminCustomerInput:Db2Admin
Select A value is required for this metric and type 'notspecified' for the

Default Value.

Add Is Gold Customer Metric. Set the type to Boolean with the trigger
JDBCInbound Entry Trigger and the following expression:

JDBC Adapter: Using WebSphere Business Monitor to monitor a database



8.

if (JDBCInboundInterface.createDb2adminCustomerBGENTRY/
createDb2adminCustomerBGInput/Db2adminCustomer eq 'Gold')thentrue()else
false()

Save the monitor model.

Add Dimension

Add a dimension to the monitor model.

1. Switch to the Dimensional panel by clicking Dimensional Model in the
bottom of MonitorAdapterMM view.
4+ Business Monitoring - MonitorAdapterMM - IBM WebSphere Integration Developer 6.1 - C:\ docume = Ellﬂ
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2. Right click MonitorAdapterModelCube in the Dimensions panel. Select New
-> Dimension and type CCode Dimension as the name. Click OK.
3. Right click CCode Dimension, select New » Dimension Level, type CCode
Dimension Level and select CCode Metric as the metric
4. Click OK.
5. Right click MonitorAdapterModule Cube, select New » Measureand type
FName Count Measure for the Name. Select Fname Metric as the Source Metric
6. Click OK.
7. Press Ctrl+S to save the monitor model.
8. Right-click MonitorAdapterMM.mm on the Project Explorer. Select Generate
Monitor J2EE projects.
9. Click OK and then Finish.
10. Go to the Business Integration view, you can see that several projects have

been generated.
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Configure the integrated test environment server

14

In this section you will configure the test environment server on which you will
test the adapter/mediation flow and the monitor model.

1. In the Servers view, right-click WebSphere Business Monitor Server v6.1 for
WebSphere ESB server and select Start.

2. Right-click on the started WebSphere Monitor Server for WebSphere ESB and
select Run administrative console.

3. Type in the user ID admin and password admin, and click Log In.
4. Create a J2C Authentication Alias.

a. In the left hand window, expand Security and click Secure administration,
application infrastructure. Expand Java Authentication and Authorization
Service in the right window.

Click J2C authentication data.

Click New. Type DB2 for Alias and your DB2 userid and password.
Click OK.

. Click Save to save the changes directly to the master configuration.

5. Repeat steps IE through [4e| for J2C authentication alias JDBCAdapter/inbound.
Scroll down to verify the new entries you added.

6. Create a JDBC Provider for DB2.
a. Expand Resources on the left hand window.
b. Expand JDBC. Click JDBC Providers.
C. Set the scope to Node=WBMonSrv_esb_Node.
d

Click New. For Database type, select DB2, for Provider type select, DB2
Universal JDBC Driver Provider, and for Implementation type, select XA
data source.

® ao0uoT

e. Click Next. Type the directory location for the indicated jar files.
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Previous | Mext

Cancel |
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J 0= Done

Click Next.

g. Click Finish.

h. Click Save to save the changes directly to the master configuration.
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7. Create a data source for the provider just created.
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Use thiz page to edit properties of a JDBC provider. The JDBC provider object encapsulates the
specific JDBC driver implemnentation class for access to the specific vendor database of your
environment.

General Properties
* Scope
[cellsiwBMangr_esb_cCellinodesiWBManSr_esb_Node |

Additional Properties

Data sources

Data sources
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b. Click Data sources.
c. Click New.

Chapter 3. Build it yourself
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d. Type jdbc/DB2XA for JNDI name. This matches the JNDI name you used
when configuring the JDBC adapter. Select WBMonSrv_esb_Node/DB2 as
the authentication alias and then click Next.

e. Type ADAPTER for Database name and localhost for Server name.
f. Click Next and then click Finish.

g. Click Save to save the changes directly to the master configuration.

8. Select the box under Select and click Test connection. Ensure that the test
connection is successful.
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9. Restart the WebSphere Business Monitor Server v6.1 on WebSphere ESB

server.
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Chapter 4. Deploy the Adapter/mediation application to the
test environment server

1.

Right-click on the Monitor server on WebSphere ESB and select Add and
Remove Projects.

-]
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Select MonitorAdapterApplication and click Add to add the application to
Configured projects.

Click Finish. The project is deployed to the server and started. Ensure there are
no error messages in the console.

To verify that the mediation module and adapter application works correctly,
open a DB2 command window and run the following commands:

db2 connect to ADAPTER user db2admin using <db2admin password>

db2 insert into customer values ('1', 'Yi', 'Che', 'Regular')

Note: If you see general errors in the console, try removing the
MonitorAdapterApp project from the server, then do Project > Clean » Clean
all projects, then add the project to the server and retry. If you see
UNAUTHENTICATED errors in the console. Follow the steps in
[user to Monitor Data Security root group” on page 18 and the retry to clean the
projects.

Right-click the WebSphere Business Monitor Server v6.1 on WebSphere ESB
server and select Common Base Event Browser.

From the left menu of the Common Base Event browser, click All Events. The
list should include the events related to the record that you just inserted.
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Add admin user to Monitor Data Security root group

If you receive UNAUTHENTICATED errors in the console when you have selected

the Clean All Projects option, you must add the admin user to the Monitor Data
Security root group.

1. Right-click on the Monitor server on WebSphere ESB and select Run

administrative console. Type in your user ID and password and then click Log
in.

2. Expand Security and select Monitor Data Security.
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Use this page to performn administrative functions for Business Monitor data
security, You can add a new resource group, seleck a resource group to delete,
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Resource Groups
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Start.

3. Click Root and then click Users.
4. Click OK and then click OK again.
5. Right-click on the Monitor server on WebSphere ESB and select Restart »

Chapter 4. Deploy the Adapter/mediation application to the test environment server
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Chapter 5. Deploy the monitor model application to the test

environment server

1. Right-click on the Monitor server on WebSphere ESB and select Add and

Remove Projects.

2. Select MonitorAdapterMMApp and click Add to add the application to

Configured projects.

4= Aadd and Remove Projects

Add and Remove Projects

Modify the projects that are configured on the server

@

| E—

Mowe projects to the right ko configure them on the server

Available projects;

Configured projects:

= =
|8 MonitoradapterMMapplics |H Monitoraddapterdpp

add > |

= Remave |

Add all ==

<< Remove Al |

l | H

(7 = Back ek = | Einish I Cancel

3. Click Finish. The project is deployed to the server and started. Ensure you see

no error messages in the console.
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Chapter 6. Process events to exercise the model

After deploying the monitor model, you can run some events to verify that the
monitor model works correctly.

1.

2.

Open a DB2 command window. Then run the following commands:
db2 connect to ADAPTER user db2admin using <db2admin password>

db2 insert into customer values ('3', 'Michael', 'Davis', 'Regular')
db2 insert into customer values ('4', 'Paul', 'Smith', 'Silver')

db2 insert into customer values ('5', 'Joe', 'Williams', 'Gold')

db2 insert into customer values ('6', 'Daniel', 'Johnson', 'Regular')
db2 insert into customer values ('7', 'Tim', 'Ross', 'Gold")

db2 disconnect ADAPTER
Wait briefly so that the monitor model can process the generated events.

View the calculated information on a Monitor dashboard in the test

environment

S S A

Right click on the Monitor Server on WebSphere ESB and select WebSphere
Business Monitor dashboard.

Type admin for the user ID and admin for the password and click Login.
Click Dashboards and click New.

Type MonitorAdapter for the name and then click OK.

Add and configure and Instance items.

a. Drag the 2nd palette icon (Instances) to Add to Dashboard.

b. Click Personalize and move some available items to the Selected window
and then click OK.

Add and configure Dimensions item.
a. Drag the 6th palette icon (Dimensions) to Add to Dashboard.
b. Click Personalize.

c. In Available dimensions, select Measures and move it to Column
dimensions.

d. In Available dimensions, select CCode Dimension and move it to Row
dimensions.

e. Confirm that the window looks like the following example.
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f. Click OK.
7. Double click All CCode Dimension.
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Chapter 7. Download the sample

Completed samples are available so that you can start at any stage of this tutorial.
This section shows you how to import the solutions. After you import the model,
you can proceed to the relevant section in the Build It Yourself section to continue
development.

You can download the following files.
+ [MonitorAdapter_db2.sq|
» [IDBCAdapter_PI.zip|

Use the following section to import the model using WebSphere® Integration
Developer.

Import the J2EE application solution into WebSphere Integration

Developer

A solution has been provided so that you do not have to build the J2EE application
from scratch. This section shows you how to import the application into
WebSphere Integration Developer and generate J2EE projects for deployment.

1. Start WebSphere Integration Developer and set up the environment.

a. Start WebSphere Integration Developer V 6.1, and when prompted, point to
a new workspace, such as C:\workspaces\MonitorAdapter.

b. Close the Welcome tab.
2. Select File » Import, then select Other » Project Interchange and click Next.

3. Click Browse. Locate and select the project interchange file named
MonitorAdapter.zip.

4. Click Select All and then click Finish. Wait for the projects to be built.
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4+ Import Project Interchange Contents L ﬂ

Import Projects fr="%

Import Projects from a zip file. [ |
a4

From zip file: I C:'devMonitor Adapter. zip j Browse... |

Project location root: IC: \Documents widé. 1'workspace \WID6 1gm_MonAdapt || Browse... |

= CWYBC_IDBC
=& ManitorAdapter
= MonitorAdaptergM
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~)

< Back [ext = | Finish I Cancel

5. In the Business Monitoring perspective, right-click the

MonitorAdapterMM.mm and select Monitor Tools » Generate Monitor J2EE
Projects.

6. Click Finish.
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