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Chapter 1. Introduction

This end-to-end tutorial introduces you to IBM® business process management (BPM) functionality by
showing you how to build and deploy a business process using IBM® WebSphere® Business Process
Management Version 6.2. No prior knowledge of the BPM products is required to complete the steps in
this tutorial.

Printable version of this tutorial

This tutorial focuses on the technical details that are related to building, running, and monitoring the
sample application. One Lotus® form is used throughout the process to convey information from one user
to the next. You will use WebSphere® Business Modeler to model the sample and WebSphere Integration
Developer to complete the development. You will use WebSphere Business Services Fabric to select the
best shipping service endpoint based on policies, WebSphere Process Server and WebSphere Business
Monitor Server to run the completed sample and WebSphere Business Monitor to monitor the business
process and view business performance using a dashboard. The dashboard is created in Business Space
powered by WebSphere, which provides an integrated visual environment.

In addition to this introduction, the tutorial has four major sections:

Overview
Explains the scenario used in this tutorial, the data model, and the human tasks that are
involved.

Build it yourself
Contains step-by-step instructions to build the sample from scratch.

Run the sample
Explains how to run the sample using either the artifacts that you download or the artifacts that
you created in the Build It Yourself section.

Download and import the sample
Explains how to install the downloaded pre-built solutions for this sample

Time required

This tutorial could take approximately four to five days to complete, depending on your familiarity with
the products.

Skill level

This tutorial-style sample is designed for new users. Step-by-step instructions are provided to guide you
through the process development life cycle, from the beginning to setting up a test runtime server, to
designing and developing a process, to finally monitoring the process. You are expected to have some
familiarity with the eclipse environment.

System requirements

The sample that is included with this tutorial runs on Microsoft® Windows® operating systems.

Prerequisite software

Before you build the sample, you must install the following products. For the tutorial steps, it is assumed
that the products are installed according to the instructions provided in the Installation Details section.
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Any deviation from the specific versions or instructions may result in differences from the tutorial steps
or screenshots. You are advised to follow the installation instructions exactly.
v WebSphere Business Modeler Advanced V6.2.0.1
v WebSphere Integration Developer V6.2.0.1
v WebSphere Business Monitor development toolkit V6.2.0.1
v WebSphere Business Services Fabric tool pack V6.2.0.1
v Lotus® Forms Designer V3.5
v Lotus Forms Viewer V3.5 Fix pack 1
v Lotus Forms Server V3.5

Note: Lotus® Forms Designer and Lotus Forms Viewer are included with WebSphere Business Modeler
and WebSphere Integration Developer. Lotus Forms Server is included with WebSphere Integration
Developer.

For more information about the products that are involved in this tutorial, refer to the product
documentation.

Installation Details

1. Install the WebSphere V6.2 products
There are two options for installing the required WebSphere products, choose the appropriate option
for your environment.
a. WebSphere Dynamic Process Edition (WDPE) Installation

Use this option if the machine you are installing on does not have any other products installed
with IBM Installation Manager. Check in your Start > Programs menu for IBM Installation
Manager. If you see this entry, skip this step and continue at step 1b: Individual Product
Installation
1) Extract the files of the WDPE V6.2 installer. This will create the following directory structure:

2) Download the files for each product and extract them into the appropriate subdirectory in
WDPEInst

3) Run installers/install_wdpe_win.exe and follow the instructions in the installer
Continue at Step 2: Update the WebSphere Products to V6.2.0.1

b. Individual Product Installation
Run this installation procedure only if you did not install the WebSphere Dynamic Process Edition
in step 1a.
1) Install WebSphere Integration Developer with the following features:
v Integrated development workbench (selected by default)
v The test environment without a profile. Be sure to uncheck the profile
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Note: IBM Installation Manager will install or upgrade with the first product that is installed
from the IBM WebSphere Dynamic Process Edition suite. In this sample, the IBM Installation
Manager will be installed when WebSphere Integration Developer is installed.

2) Install WebSphere Business Modeler Advanced V6.2
a) Install into the WebSphere Integration Developer package group

b) Use default installation features:

3) Install WebSphere Business Monitor Toolkit
a) Install into the WebSphere Integration Developer package group as you did for WebSphere

Business Modeler
b) Select features:
v Monitor Development Environment: Monitor Model Editor
v Monitor Development Environment: WebSphere Integration Developer support for

monitor model generation
v Monitor Test Environment: WebSphere Business Monitor profile on WebSphere Process

Server
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4) Install WebSphere Business Services Fabric tool pack V6.2 into WebSphere Integration
Developer with the Files Only and the Install Composition Studio features selected.

5) Augment the Monitor server profile with Fabric functionality.
a) In order to start the augmented monitor profile without exceptions the OSGi cache needs

to be flushed. Delete all folders starting with org.* in <WID62_Install>\pf\WBMonSrv_wps\
configuration.

b) Run the Profile Management Tool (PMT). This can be found at: <WID62_Install>\runtimes\
bi_v62\bin\ProfileManagement\pmt.bat .

c) Click Augment to augment the existing monitor profile. If the defaults were used this will
be named WBMonSrv_wps.

d) Select WebSphere Business Services Fabric as the augment to apply to the monitor profile.
e) Select Typical profile augmentation as the profile augmentation option.
f) Enter the user id and the password for the monitor profile created during the installation of

the WebSphere Business Monitor toolkit. The default username is admin and the default
password is also admin.

g) Review the summary and then click Augment
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h) Validate that the augment was successful by reviewing the log. The log is located at
<WID62_Install>\bi_v62\logs\mangeprofiles\WBMonServ_sps_augment.log. Near the end of
the log, there should be a message Profile augmentation succeeded.

2. Update the Websphere Products to V6.2.0.1
a. Use IBM Installation Manager to update the products to V6.2.0.1. All products are installed into

the WebSphere Integration Developer package, so this is the only package that needs to be
updated.

b. On the next screen, select Show All and select Version 6.2.0.1 for each product
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Note: Other versions may be recommended and highlighted, however the steps and screenshots
in this tutorial are for Version 6.2.0.1 and are not guaranteed to be the same in later versions.

Note: You may receive a message informing you that you need to update the IBM Installation
Manager. If this is your first time using the IBM Installation Manager to update an installed
package. Select yes.
Follow the prompts for the remainder of the update installation.

3. Create the FabricAdministrators group and add the admin user to that group

Note: Even though there is a user created by the installer that has WebSphere Process Server
administrative privileges, this user does not automatically have Administrator privileges to do
Governance in Business Space. To grant this user Administrator privileges, a group called
FabricAdministrators must be created and the admin user (or other users) must be added to the
group. In this sample, which uses the default VMM, this can be done in the WebSphere Process Server
administrative console. If you were using LDAP, Local OS, etc. you would create this group in the
appropriate system.
a. Start WebSphere Integration Developer with the default workspace
b. In the Servers view, right click the server WebSphere Business Monitor Server and select Start.

(This will take a few minutes)
c. When the Server status is Synchronized, right click the server again and select Administration >

Run administrative console

d. Log into the WebSphere Monitor Server admin console. Navigate to ″Users and Groups/Manage
Groups″. Create a new group with name FabricAdministrators.
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e. Add user ID admin to the FabricAdministrators group.

f. Close the Administrative console.
g. In the servers view, right click the WebSphere Business Monitor server and select stop.
h. After the server status changes to stopped, exit WebSphere Integration Developer.

4. Install Lotus Forms Designer V3.5 into WebSphere Integration Developer. This will also enable it in
WebSphere Business Modeler.
a. Create a directory called forms_designer in the same parent directory where you extracted the

Websphere Integration Developer installation files. This directory should now contain 3 directories:
disk1, disk2 and forms_designer.

b. Extract the Lotus Forms Designer V3.5 files in the new forms_designer directory.
c. Run the WebSphere Integration Developer launchpad and select the option to Install Lotus Forms

Designer
d. During the installation you will be prompted for a valid installation directory where an IBM

Software Development Platform package is installed. This is the WebSphere Integration Developer
directory. For example, if you installed using the WDPE installer, the default directory is
C:\ProgramFiles\IBM\WDPE\WID62. If you installed the WebSphere products individually, the
default directory is C:\ProgramFiles\IBM\WID62

Refer to Installing Lotus Forms software in the WebSphere Integration Developer product
documentation for full install information.

5. Install Lotus Forms Viewer V3.5 Fix pack 1 into WebSphere Integration Developer. This will also
enable it in WebSphere Business Modeler.
Because this is a fix pack, You must use a different install procedure, not the launchpad. To install
IBM Lotus Forms Viewer 3.5 fix pack 1 perform the following steps:
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a. In your Web browser, go to http://www.ibm.com/support/fixcentral.
b. Download IBM Lotus Forms Viewer 3.5 fix pack 1.
c. Double-click the downloaded file.
d. Follow the instructions in the installation wizard.
e. When prompted for the install location, enter the WebSphere Integration Developer installation

directory.
Refer to Installing Lotus Forms software in the WebSphere Business Modeler product documentation
for full install information.

6. Install Lotus Forms Sever into WebSphere Integration Developer.
Refer to Installing Lotus Forms software in the WebSphere Integration Developer product
documentation for full install information.
a. Create a directory called forms_server in the same parent directory where you extracted the

Websphere Integration Developer installation files. This directory should now contain 4 directories:
disk1, disk2, forms_designer and forms_designer.

b. Extract the Lotus Forms Designer V3.5 files in the new forms_designer directory.
c. Run the WebSphere Integration Developer launchpad and select the option to Install Lotus Forms

Server - API
d. When prompted for the install location, enter the WebSphere Integration Developer directory.
e. Install the SDK version of the server

f. Select the checkbox for deploy to WebSphere Process Server

g. For the location of the server, use <WID62_Install>\runtimes\bi_v62
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Chapter 2. Overview

Clips and Tacks is a fictional office supply company. In this business scenario, Clips and Tacks is
processing orders for office supplies and shipping them to customers.

The following sequence of events describes the Clips and Tacks business process for handling incoming
orders.
1. The business process is initiated when a customer submits an order.
2. A business rule evaluates the data from the order form and determines whether the order can be

automatically approved or if it needs human approval. When the total purchase price of the order is
$750.00 or less, the order is automatically approved. When the total purchase price of the order
exceeds $750.00, it is sent to a person for review.

3. For orders that are automatically approved, the customer account is checked to determine if it is in
good standing. If the customer account is in good standing, the order is sent for shipment; otherwise,
the order is sent to a person for review.

4. If the order is approved by reviewer, then it is sent for shipment; otherwise, the order is canceled and
a notification is sent to the customer.

5. The orders that are ready for shipment are given a packaging slip number and are sent to the
customer.

Clips and Tacks recently determined that it could save money by using external shipping carriers instead
of shipping all orders directly. Initially, Clips and Tacks decided to use Better Shipping for large domestic
orders (an order that is greater than $50), which charges a flat fee of $8 per order. For small or large
international orders, Clips and Tacks decided to use International Express™, which charges a flat fee of
$25. (Better Shipping and International Express are fictional shipping companies.) For small domestic
orders, Clips and Tacks decided to continue shipping directly, which costs $10 per order.

Change 1
A few months after this new shipping structure was implemented, Clips and Tacks decided to
outsource all domestic shipping to Better Shipping, even for small orders at the same flat fee of
$8 per order.

Change 2
After another few months, Clips and Tacks was offered a great deal for shipping in and around
North Carolina. LocalShippers charges a flat fee of $5 for small and large orders for customers
located in North Carolina, South Carolina, and Virginia. Clips and Tacks decided to change to the
following shipping structure:
v LocalShippers for orders in and around North Carolina, South Carolina, and Virginia at a flat

fee of $5 per order
v Better Shipping for all other domestic orders at a flat fee of $8 per order
v International Express for all international orders at a flat fee of $25 per order

Data model

There are two business objects (also known as business items) in this tutorial. A business object called
Order stores the following information for the business process:
v Customer information
v Items ordered
v Automatic approval field, which the business rule uses
v Current® status of the order, which is modified as the order progresses through the process
v The packing slip number, which is used to ship the order
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v The shipping charges, which are set after it is determined which shipping service is used

The Notification business object is used to send notification to a customer about a canceled order. It has
two fields: a text field and an e-mail field. There are two ways to generate business objects:
v By importing the complete object from an XSD file
v By manually creating the object through the authoring tools

To create the Order business object you will use the authoring tools, and to create the Notification
business object you will import Order.xsd.

Human tasks

There are three human tasks in this business process:
v A human task for entering data into the order entry form. This human task starts the business process.

It is not modeled in the process; it is the process-initiating action.
v A modeled human task that represents the employee activity of reviewing the order when the total

purchase amount is more than $750.00 or when the customer account is not in good standing.
v A modeled human task that represents the employee activity of shipping the order to the customer.

Lessons in this module
1. “Modeling the business process” on page 11

Use WebSphere Business Modeler to build a model that represents the Clips and Tacks business
process for handling incoming orders.

2. “Integration development” on page 55
Import the generated model into WebSphere Integration Developer to convert it into a runnable
business process that includes business rules, Java™ components, and a user interface.

3. “Identifying WebSphere Monitor Server on WebSphere Process Server ports” on page 70
Identify the WebSphere Monitor Server ports for use in later lessons.

4. “Creating a WebSphere Business Services Fabric project” on page 70
Create a project to act as a container for all the WebSphere Business Service Fabric artifacts created.

5. “Creating the Clips and Tacks Business Space” on page 76
Create a Business Space to enable an integrated and customized user experience allowing access to
business process information from a single user interface.

6. “Leveraging Business Services” on page 84
Use WebSphere Business Service Fabric policies and assertions to enable dynamic business processes.

7. “Monitoring the Order Handling business process” on page 109
Import the monitor model generated by WebSphere Business Modeler into WebSphere Business
Monitor Server V6.2 and add the missing elements to the monitor model.

8. “Testing the Order Handling business process” on page 128
Use the Business Space dashboard to run process instances.

9. “Creating a business dashboard in Business Space” on page 129
Create a business dashboard in Business Space to monitor the Order Handling process.
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Chapter 3. Build it yourself

As you complete this tutorial, check your work carefully. Consider working from a printed copy of the
documentation so that you can check off each step as you do it.

Before you begin, you must install all items listed in “Prerequisite software” on page 1.

The following artifacts are used in building the application. Refer to Chapter 5, “Download and import
samples,” on page 141 for download instructions and copy the files now to a convenient location on your
local machine.

Order.xsd
The XML schema to be used in WebSphere Business Modeler.

Order.xfdl
The Lotus® form used in this tutorial. It is imported in WebSphere Business Modeler.

ClipsAndTacksEndpoints.zip
Web service endpoints to be called by WebSphere Business Services Fabric. These are not really
Business Process Management artifacts, but rather external artifacts necessary to run the
application.

CancelOrderandSendNotificationImpl.java
The Java file used to generate notifications. It is the implementation for one of the components in
the WebSphere Integration Developer.

CreditRating.java
The Java file used to check the customer account status. It is the implementation for one of the
components in the WebSphere Integration Developer.

ContextExtractorImpl.java
A file used by the Dynamic Assembler component in Websphere Integration Developer to extract
data from the incoming request and pass it to Websphere Business Services Fabric.

ClipsAndTacks-Core_ontology.fca
Custom ontology (vocabulary) required for Websphere Business Services Fabric.

ClipsTacks_initial_scenario-owl.zip
WebSphere Business Services Fabric repository project.

DeclinedOrderEvent.xsd
An XML schema for the Declined Order event that is monitored in Websphere Business Monitor.

LateAverageOrderShippedEvent.xsd
An XML schema for the Order Fulfillment event that is monitored in Websphere Business
Monitor.

Modeling the business process
During the modeling phase, use WebSphere Business Modeler to build a model that represents the Clips
and Tacks business process for handling incoming orders.

To model the process, complete the following tasks:
1. Create the basic process by performing these steps:

a. “Creating the business process” on page 12.
b. “Importing the Order business item and related data types” on page 15.
c. “Building the model of the Order Handling process” on page 17.
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d. “Connecting the tasks and associating data” on page 21.
2. Replacing the generated form:

a. “Associating a form to the human tasks” on page 24.
b. “Replacing the generated form” on page 26.

3. Add details for the process to run by performing these steps:
a. “Creating the notification business item” on page 30.
b. “Implementing the decision branch conditions” on page 31.
c. “Setting the input criterion for the process” on page 35.
d. “Setting the input specification for the process” on page 35.
e. “Synchronizing forms and human tasks” on page 36.
f. “Implementing the business rule for automatic approval” on page 37.

4. Add details for process monitoring by performing these steps:
a. “Specifying monitoring criteria” on page 42.
b. “Creating a location dimension” on page 43.
c. “Creating the Percentage of Orders Shipped key performance indicator” on page 44.
d. “Creating the Average Process Duration key performance indicator” on page 46.
e. “Creating the Price per Order instance metric” on page 48.
f. “Creating the Order Price Total aggregate metric” on page 49.
g. “Creating the Order Price Average aggregate metric” on page 50.

5. Export the model by performing this step: “Exporting the model for further development” on page 52.

Creating the business process
In this lesson, you will create the business process.
1. Start WebSphere Business Modeler Advanced V6.2. The Workspace Launcher wizard opens.
2. Create a new workspace for this tutorial, such as C:\Documents and Settings\Administrator\IBM\

wbmodeler6.2\ClipsAndTacks. Do not select Use this as the default and do not ask again. Click OK.

3. On the Welcome window, click Close Product Welcome. The Start Process Modeling wizard opens.
4. Enter ClipsAndTacksF1 as the project name, leave Processes as the process catalog name, and enter

OrderHandling as the business process name. Select Design a process that can run and choose
WebSphere Business Services Fabric as the runtime target. Then click Next.
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5. Clear the Create business item check box and then click Next.

6. Select BPMN style and click Finish.
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The project and the business process are created. The Order Handling process opens.

7. Click the Apply 4-Pane Layout icon in the toolbar at the top of the window.

8. Optional: If the Technical Attributes view is not showing, you can display it by selecting Window →
Show View → Other, expanding Business Modeler Views, and selecting the Technical Attributes
view.
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Importing the Order business item and related data types
In this lesson, you will learn how to import the business items and identify and import related data
types.

The files needed for this tutorial are available in Chapter 5, “Download and import samples,” on page
141, such as the data definition file Order.xsd.
1. In the navigation tree, right-click ClipsAndTacksF1 then select Import.
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2. Select Type definition XML schema (.xsd), and then click Next.

3. Click Browse and select the directory containing the downloaded tutorial artifact files, then select
Order.xsd from the list of files. Click Next.
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4. Click Finish.

The Order business item is imported with three other business items (CustomerRecord, OrderItem, and
OrderProcessingData) that the Order business item requires. All of the business items are imported into a
catalog called ClipsAndTacks, which was also defined in the XSD file.

Building the model of the Order Handling process
In this lesson, you will build the model of the Order Handling process.
1. If the OrderHandling process is not open already, expand ClipsAndTacksF1 >Processes >

OrderHandling, and then double-click OrderHandling.
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Tip: The canvas is currently much larger than the area visible within the window. From the toolbar,

click the Resize Diagram icon and choose from the options to resize the process diagram. To

reduce the width of the canvas, use the Decrease Horizontal Space icon . To reduce the height of

the canvas, use the Decrease Vertical Space icon .
2. On the palette, click Business Rules Task and then click the canvas. Rename the local business rules

task to Check Order Handling Policy for Automatic Approval. You can resize the task to fully
display the text if you want.

Tip: You can also drag elements from the palette to the canvas.
Add new elements to the right of the previously added item. An image with all the elements in the
process is included in the “Connecting the tasks and associating data” on page 21 section.

3. On the palette, click Gateways to expand it. Click Simple Decision, and then click the canvas.
Rename the simple decision to Approve Without Review?

4. On the palette, click Task, and then click the canvas. Rename the task to Check Customer Account
Status. The generic task icon can be used to represent any call to an automated service.
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Note: You might experience errors during this part of the tutorial because you are in the Fabric
mode by default. If you do not want to experience those errors, change to the Basic mode.

5. Click Simple Decision, and then click the canvas to the right of the Check Customer Account
Status task. Rename the simple decision to Account in Good Standing?

6. On the palette, click Merge, and then click the canvas.

Tip: Place the merge elements on the canvas from left to right as you define them.
7. On the palette, click Human Task, and then click the canvas. Rename the human task to Review

Order.

8. Add a simple decision called Acceptable Credit Risk? to the right of the previous item, a merge
item to the canvas to the right of the Acceptable Credit Risk? simple decision, and a task called
Calculate Shipping Charges to the canvas to the right of the merge item.
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9. You can now indicate what type of task this represents. Select CalculateShippingCharges and select
the Implementation tab in the Technical Attributes view. Scroll down and select Dynamic Assembler
for the Implementation Type. This setting enables you to add dynamic behavior to the process.

10. Add a human task called Ship Order to Customer, a task called Update Order Database, and a task
called Cancel Order and Send Notification to the canvas. Note: Exact spelling and capitalization is
required for the Cancel Order and Send Notification task. In the integration section of this tutorial,
you will associate an implementation to this task. The implementation file is supplied for you and
the name must match.

11. Set the implementation types for the Check Customer Account Status, Update Order Database, and
Cancel Order and Send Notification tasks to Java.

12. Add a Terminate node by clicking the Terminate icon on the palette and then clicking the canvas.
(The Terminate icon is located under the Events group.)

13. Add a second Terminate node.
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Connecting the tasks and associating data
In this lesson, you will connect tasks, subprocesses, and other elements to model the flow of control and
data through the business process.

Connecting tasks is also called wiring the tasks. There are two parts to wiring the tasks: you must create
a wire to show that the output from one element becomes the input to another, and then you must
indicate what data is passed between those two elements.
1. Hover over the inner edge of the process diagram until you see an arrow.

2. Click and hold the left mouse button. Move the mouse with the connection to the Check Order
Handling Policy for Automatic Approval task. Release the left mouse button to form a connection.

3. Right-click the newly created connection and select Associate Data. Navigate to the ClipsAndTacksF1
project, select Order, and then click OK.
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Tip: An alternative method is to drag a business item from the project tree to a connection.

4. Wire the remainder of the process diagram by repeating steps 1 and 2 for all of the elements, but
review these tips before proceeding with wiring:

Important:

v All of the links must have the Order business item with the exception of the link from Cancel
Order and Send Notification to the Terminate node.

v If the Order icon is not automatically added to the link, add it using the Associate Data context
menu option before continuing with the wiring.

v Press Ctrl+Z or click Edit → Undo to reverse your last change instead of deleting recent work.
v If the Connections wiring tool is still enabled, select the white arrow icon at the top of the palette

to enable the regular mouse pointer before you try to right-click an item. Alternatively, pressing the
Esc key disables the connection tool.

v To prevent yourself from inadvertently creating extra input or output ports on the elements, click
the center of each element that you are connecting.

The following three images show the completed wired diagram. The first image shows the left half
and the second image shows the right half. The third image is the completed wired diagram.
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5. Right-click the canvas and select Auto-Layout left to right. Save your work by using one of these
combinations:
v Click File → Save

v Click File → Save All

v Press Ctrl+S.

Note: When you save your work errors appear on some elements. These errors are corrected during
the following lessons when you provide more details in your model.

Associating a form to the human tasks
In this lesson, you will associate an Order form with the two human tasks, Review Order and Ship
Order to Customer.

An Order form has been created and is available for download. Refer to Chapter 5, “Download and
import samples,” on page 141 to get the Order.xfdl Lotus® form. In this lesson you generate a
placeholder form within WebSphere Business Modeler. Later you will replace the placeholder form with
the one that you downloaded.
1. In the process that you just created, select the Review Order human task and, in the lower pane, click

the Attributes Review Order tab, and then click Forms.

2. Because you will use the same form for the input and output, leave the check box selected. Then click
New for the input form.

3. Enter Order for the name of the form and click Finish.
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4. Right-click the Ship Order to Customer human task, select Associate Form, and click Browse.
5. From the ClipsAndTacksF1 tree, select Order and click OK. Click OK on the Associate Form window.
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6. Save your work.

Replacing the generated form
In this lesson, you will replace the generated form with the provided order form to provide the
appropriate fields necessary to complete this tutorial.

Refer to Chapter 5, “Download and import samples,” on page 141 to get the Order.xfdl Lotus® form.
1. Switch to the Resource perspective, which contains the underlying implementation files. To see them,

click the Open Perspective icon and select Other.
2. Select Resource and click OK.
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3. Expand the ClipsAndTacksF1 tree to expose the Order.xfdl form.

4. Right-click the Order.xfdl entry and select Delete. Click OK.
5. From a file system explorer window, drag the Order.xfdl form to the Order folder in the Modeler

Project explorer.
6. To check that you have the correct form, right-click the Order.xfdl form and select Open With →

System Editor.
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7. Validate that the form was replaced.

28 IBM WebSphere Clips and Tacks: Getting started with the IBM BPM suite of products



8. Close the window that opens.
9. Associate the new order form with the Review Order and Ship Order to Customer human tasks.

Right-click each human task and select Associate Form. Click Browse and select Order. Click OK
and then click OK again.
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10. Save your work

Creating the notification business item
In this lesson, you will create a new business item called Notification.

The Cancel Order and Send Notification task does not use Order as an output business item. To send
notification to customers that their orders were canceled, you need to create a new business item.

To create the Notification business item, complete the following steps:
1. Switch to the Business Modeling perspective.
2. From the Project Tree, right-click Business items and click New → Business Item.
3. Name the new business item Notification and click Finish. The Notification business item appears.
4. Under Business item attributes, click Add, replace the new attribute name with e-mail, and select Text

for the type. Repeat this step to add the second attribute named text with the same type.

5. Save your changes and then close the Notification business item panel by clicking the X on its tab.
6. Right-click the wire between Cancel Order and Send Notification and the Terminate node and select

Associate Data. Select Notification from Business Items and click OK.
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Implementing the decision branch conditions
In this lesson, you will set the criteria, based on the input data, for which branch to take when decisions
are made in the business process.

The decision elements of the process currently have errors because there is no automated way to
determine which branch should be taken for a given order.

The branch options are listed in the following table.

Table 1. Summary of Decision Criteria

Decision Criteria

Approve without Review? The previous task set the value of the
OrderProcessingPreference - automaticApproval input
field. Check if this field is true or false. If this field is
true, then the order is automatically approved. If this
field is false then the order must be reviewed before it is
approved.

Account in Good Standing? Check whether the total price of the order is less than
the customer’s available credit.

Acceptable Credit Risk? In the previous task, the reviewer sets the value of the
OrderStatus field. Check this field for APPROVED.

1. In the process diagram, click the Approve Without Review? simple decision. In the Attributes view,
click the Attributes – Approve without Review? tab and then click the Output branches tab.

a. Click the Yes cell and change the probability field to 65. Similarly, change the No probability field
to 35. These probabilities are used during simulation.

b. Click the Yes cell again. Scroll down to the Expression field and click Edit (you can size the panes
in the 4-pane layout by selecting and dragging the borders). The Expression Builder wizard opens.

c. In Expression Builder, complete the following steps:
1) Click Add.
2) Under the Expression Composer, ensure Modeling artifact is selected as the first term. Expand

Processes → OrderHandling → Approve Without Review? → Input →
OrderProcessingPreference and select automaticApproval.

3) For Operator, select is equal to.
4) For the second term, select Boolean and set the Boolean value to true.
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5) Click Apply, and then click OK. You might need to scroll down to find the OK button.
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2. In the process diagram, click the Account in Good Standing? simple decision. In the Attributes view,
click the Output branches tab and change the Yes probability to 85 and the No probability to 15.
a. Select the Yes line, scroll down and click Edit under the Expression field.
b. In the Expression Builder, complete the following steps:

1) Click Add.
2) Ensure that Modeling artifact is selected as the first term. Under First term details, expand

Processes → OrderHandling → Account in Good Standing? → Input and select TotalPrice.
3) For the Operator, select is less than or equal to.
4) For the second term, select Modeling artifact and then expand Processes → OrderHandling →

Account in Good Standing → ? Input → Customer and select AvailableCredit.
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5) Click Apply, click OK, and then save your work.
3. Click the Acceptable Credit Risk? task. In the Attributes view, select the Output branches tab. Make

the following changes:
a. Change the Yes probability to 70 and the No probability to 30.
b. Select the Yes line, scroll down and click Edit under the Expression field.
c. In Expression Builder, complete the following steps:

1) Click Add.
2) Ensure Modeling artifact is selected as the first term. Under First term details expand

Processes → OrderHandling → Acceptable Credit Risk → Input and select OrderStatus.
3) For Operator, select is equal to.
4) For the second term, select Text and enter the value as APPROVED.
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5) Click Apply, click OK, and then save your work. You should have no more errors (red Xs) on
the decision elements of your process diagram.

Setting the input criterion for the process
In this lesson, you will set the input criterion for the process to ensure that the input parameter name
matches the name in the form.

Complete the following steps:
1. Click the canvas and then click the Attributes - OrderHandling tab and then the Inputs tab.
2. Select the Input row.
3. For the name, type Order.

4. Save your work.

Setting the input specification for the process
In this lesson, you will set the input specification for the process to ensure that the input and output
parameter names for the human tasks match the names in the form.
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Complete the following steps:
1. Click the Review Order human task icon, then click the Attributes – Review Order tab and then the

Inputs tab.
2. Select the Input row.
3. For the name, type Order and save your work.

4. Click the Review Order human task icon and the Attributes – Review Order tab again, but this time
select the Outputs tab.

5. Select the Output row.
6. For the name, type Order and save your work.
7. Repeat these steps for the Ship Order to Customer human task.

Note: Errors are expected for both human tasks. You will correct these errors in “Synchronizing forms
and human tasks.”

Synchronizing forms and human tasks
In this lesson, you will synchronize the Order form and the available human tasks to avoid XPath
problems when exporting the Project Interchange file to WebSphere Integration Developer.

Complete the following steps:
1. Right-click the Review Order human task and select Synchronize Forms.

2. Select Match the input form with the task inputs and make sure that the Update the form content
but not the layout entry is selected.

3. Click Synchronize.
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The errors are corrected.

Note: Because the two human tasks, Review Order and Ship Order to Customer, use the same form,
you do not need to repeat the previous steps for the Ship Order to Customer human task.

Implementing the business rule for automatic approval
In this lesson, you will set up a business rule to allow automatic approval of certain orders.

The business rules task uses the Order business item as the input and checks the TotalPrice variable. If
the total price is less than or equal to a specified fixed amount (in this case $750.00), then the rules task
sets the AutomaticApproval variable in the Order business item to true; otherwise, the variable is set to
false. The business rules component returns the modified Order business item as the output.

To implement the business rules task, you will first create a template and then create an if-then rule
instantiating the template.
1. In the process diagram, click the Check Order Handling Policy for Automatic Approval task and

then, in the Attributes view, click the Business Rules tab.
2. Click Add. The Define Business Rule wizard opens.
3. Enter AutoApprovalF1 as the name of the business rule.
4. Click the Rule Templates tab and then click Add Template.
5. Change the template name from Rule template:1 to AutoApproval Template by selecting the name

and typing over it.
6. Under Rule parameters, click Add.
7. Define the rule parameter by completing the following steps:

a. Change the parameter name to totalPriceMax by selecting it and typing over the generated
name.

b. Select Decimal (double-precision) as the type.
c. For the description, enter maximum purchase price for automatic approval.
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8. In the Rule Templates table, click the rule condition cell for AutoApproval Template and then click

the to open a Rule Condition wizard.
9. In the Expression Builder for the rule condition, complete the following steps:

a. Add a simple binary expression by clicking Add.
b. For the first term, select Modeling Artifact. Expand Check Order Handling Policy for

Automatic Approval → Input and select TotalPrice.
c. For the Operator, select is less than or equal to.
d. For the second term, select Modeling Artifact. Expand Check Order Handling Policy for

Automatic Approval and select totalPriceMax.
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e. Click Apply, and then click OK.

10. Click in the Rule action cell for AutoApproval Template and then click the .

The Specify Rule Action wizard opens.
11. Specify the rule action by completing the following steps:

a. Expand and select Check Order Handling Policy for Automatic Approval → Output →
OrderProcessingPreference → automaticApproval. Then select Value specification → Specific
value and True. Click OK.
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The following figure shows the completed business rule template.

You must now create an if-then instance of this rule template.
12. Click the If-Then Rules tab.
13. Click Add Rule.
14. Change the name of the new rule to AutoApprove Rule.
15. For Template name select AutoApproval Template.
16. After selecting the template, a pop-up will ask if you want to overwrite the rule conditions and

actions, click OK. This will fill in the rest of the fields.
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17. Under Rule parameter values, change the Value of totalPriceMax from 0.0 to 750.0 The following
image shows the completed business rule.

18. Close the Define Business Rule wizard by clicking OK.
19. In the Attributes view, select the Business Rules tab and scroll down to the Scheduling section. For

Default business rule, select AutomaticApprovalF1 from the list. Save your work.
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Specifying monitoring criteria
In this lesson, you will define the measurements you want to show to the executives.

IBM WebSphere Business Monitor retrieves business measures, the raw data from running business
process, and displays them in a business space. For this tutorial, the executives want to see the data by
country and city, which is known as dimensional analysis. First, you create a dimension. Then you create
several key performance indicators (KPIs), which are calculated values that are significant to running the
business. Two of these KPIs are Percentage of Orders Shipped and Average process Duration.

To specify what should be monitored, complete the following steps:
1. Click the canvas, and then click Business Measures tab and then the Monitored Values tab.
2. In the % Per Branch column, select the three check boxes (See the image in the next step.)
3. In the Processing Time column, Select the check box for each process element except the Calculate

Shipping Charges process element. Save your work.

4. Click the Business Performance Indicators tab, review the metrics that are created based on the
monitored value selections.
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Creating a location dimension
In this lesson, you will create the Location dimension to allow you to do dimensional analysis by country
and city.

You cannot specify a two-level dimension in IBM WebSphere Business Modeler, so you just create a single
level in WebSphere Business Modeler and then you complete the implementation in the WebSphere
Business Monitor development toolkit.
1. On the Business Performance Indicators tab, double-click the first aggregate metric in the list

(Average Acceptable Credit Risk? Yes Branch Percentage). This opens the Business Measures Details
window.

2. On the Business Measure Details window, in the Dimension Analysis section, select the check box
Specify the dimensions that will be available in the dashboards for analysis of this metric.

3. Click Add, and change the name of the dimension to Location.
4. Click OK.
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Creating the Percentage of Orders Shipped key performance indicator
In this lesson, you will set up the percentage of orders shipped as a key performance indicator (KPI).

One of the KPIs that we need to track is the percentage of orders shipped. By tracking this KPI you can
determine, automatically, if your business is being successful as defined by predetermined criteria.

Complete the following steps:
1. Click the Business Performance Indicators tab in the Business Measures view, and then click Add.

2. In Business Measure Details wizard, name the business measure Percentage of Orders Shipped.
3. For the Type, select KPI.
4. In the Description field, type Percentage of orders that are shipped.
5. Click the Dashboard Samples tab and preview the different KPI representations. You can select each

of the highlighted values, such as KPI Gauge or KPI Bar to see how the KPI is represented as a
gauge or bar graph. You can change the selection from KPI to one of the other values (instance
metric, aggregate metric, or unspecified) to see the various ways they are displayed on a dashboard.
When you are finished exploring the dashboards, ensure the Type field is selected as KPI before
proceeding.
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6. Click Business Measure Details tab. Select Specify a target type and value. Select the type as
Number and change the target value to 90.

7. Select Specify range details and Percentage of target value (target value = 100%).
8. Under Specify ranges, click Add and change the Range name to Shipped orders percentage too

low. Set the start value as 0 and the end value as 85. Perform the same actions for the following
ranges:

Range name Start value End value

Shipped orders percentage good 85 90

Shipped orders percentage great 90 100

Tip: In many tables that have an Add button, you can click Add or double-click in a row in the
table to add a row.
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9. Select Specify when to send an alert and the action to take as a result. Click Add. The Percentage
of Orders Shipped Alert is added. Change it to Percentage of Orders Shipped < 85%.

10. Select Specify a time period over which the business measure will be monitored. Select Rolling
and Last 30 days.

11. Click OK and save your work.

Creating the Average Process Duration key performance indicator
In this lesson, you will set up the average process duration as a KPI.

Another KPI to track is the average process duration. By tracking this KPI you can determine,
automatically, if your business is being successful as defined by predetermined criteria.

Complete the following steps:
1. Click Add to add a new business performance indicator.
2. In the Business Measure Details wizard, enter the name Average Process Duration and click KPI.
3. In the Description field, type Measure average time of business process duration.
4. Select Specify a target value and type.
5. In the Type field, select Duration .
6. Specify 3 in the Days field.
7. Select Specify range details and click Actual value.
8. Under Specify ranges, click Add. Change the range name to Duration is acceptable, the start value

to 1 Day and the end value to 3 days.
9. Click Add again. Change the range name to Duration is too long, the start value to 3 Days and the

end value to 5 days.
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10. Select Specify when to send an alert and the action to take as a result.
11. Click Add. An Average Process Duration Alert is added. Change it to Average Process Duration > 3

days.
12. Select Specify a time period over which the business measure will be monitored. Select Repeating,

and choose the period type as Yearly, the time zone as GMT-5, and the base period as Period in

progress.
13. Select Specify how to calculate this KPI. In the Instance metric to aggregate field, select

OrderHandling Processing Time. In the Aggregation function field, select Average
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14. Click OK and save your work.

Creating the Price per Order instance metric
In this lesson, you will create an instance metric for price per order.

The Price per Order metric is used as a source for aggregations that average the order prices and also
total the order prices.
1. Click Add to add a new instance metric.
2. Enter the name as Price per Order.
3. For the Type, select Instance metric.
4. In the Description field, type price per order.
5. Under Instance Metric Calculation Details, select Specify how to calculate this instance metric. In the

Template field, select Business Item Input. In the Process element field, select OrderHandling. For
the Attribute field, click on the Browse button. In the Business Item Attribute Selection window,
expand Order (Order) and select TotalPrice. Click OK. The selection displays as Order.TotalPrice
(Order).

6. Click OK and save your work.
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Creating the Order Price Total aggregate metric
In this lesson, you will create the order price total aggregate metric.

The order price total aggregate metric is another parameter necessary to measure the success of the
business.

Complete the following steps:
1. Click Add to add a new aggregate metric.
2. Enter the name as Order Price Total.
3. For the Type, select Aggregate metric.
4. In the Description field, type Total value of the orders.
5. Select Specify how to aggregate this measure across multiple runs of the process. In the Function

field, select Sum.
6. In the Aggregate Metric Calculation Details section, select Specify how to calculate this aggregate

metric . In the Instance metric to aggregate field, select Price per Order.

7. Select Specify the dimensions that will be available in the dashboards for analysis of this metric.
Keep the dimension as Location.
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8. Click OK and save your work.

Creating the Order Price Average aggregate metric
In this lesson, you will create the order price average aggregate metric.

The order price average is another parameter you use to measure the success of the business.

Complete the following steps:
1. Click Add to add a new Business Performance Indicator.
2. Enter the name as Order Price Average.
3. In the Type field, select Aggregate metric.
4. In the Description field, type Average value of orders.
5. Select Specify how to aggregate this measure across multiple runs of the process. In the Function

field, select Average.
6. In the Aggregate Metric Calculation Details section, select Specify how to calculate this aggregate

metric. In the Instance metric to aggregate field, select Price per Order.
7. In the Dimensions for Analysis section, select Specify the dimensions that will be available in the

dashboards for analysis of this metric. Keep the dimension as Location.
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8. Click OK and save your work.

The business performance indicators you added are listed in the business measures summary. The
business measures summary is located under the Business Performance Indicators tab.
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Exporting the model for further development
In this lesson, you will export the business process model from IBM WebSphere Business Modeler in a
format that you will import into WebSphere Integration Developer.

You have completed modeling the Clips and Tacks business process. Now you will export this model
from IBM WebSphere Business Modeler and import it into WebSphere Integration Developer for further
development. You will also use it in the WebSphere Business Monitor development toolkit.

Complete the following steps:
1. Select the Errors tab and ensure there are no errors in the model. If there are errors, then correct

them. You have four warnings in your model at this point, but they will be resolved during
integration development. If other warnings are displayed, they are acceptable.

2. Right-click ClipsAndTacksF1 on the project tree and select Export.

3. Select WebSphere Integration Developer and then click Next.
4. Select a target directory (for example, C:\ClipsAndTacks).
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5. Select Export entire project and related projects and click Next.
6. Select the Module export option.
7. Ensure Export using the standard project interchange format for other environments is selected.
8. Clear Append timestamp to project interchange name (so that it is easier to define the name in this

tutorial) and click Next.
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9. Select Export business measures as a monitor model or models.
10. Clear Append timestamp to project interchange name (to simplify the name in this tutorial) and

click Finish. The Export finished window is displayed, informing you that the export finished
warnings.

11. You can ignore the warning because you will be running the application on a server that has been
augmented with WebSphere Business Services Fabric. To view the warning, click Details; otherwise,
click OK.
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The project is placed in a ZIP file, ClipsAndTacksF1.zip, that can be imported into WebSphere Integration
Developer as a single file.

Integration development
During the integration development phase, use IBM WebSphere Integration Developer to develop a
business process and business rules, generate Java components, create a WebSphere Business Services
Fabric project, and create the user interface.

In the integration development phase, complete the following tasks:
1. “Importing model files into WebSphere Integration Developer”
2. “Setting up the Lotus Forms Server API workspace” on page 57
3. “Setting up the project to use the WebSphere Business Services Fabric runtime APIs” on page 58
4. “Importing web services endpoints into WebSphere Integration Developer” on page 59
5. “Defining business rules” on page 60
6. “Generating Java components” on page 62
7. “Adding a Dynamic Assembler extension” on page 65
8. “Creating the process invocation method” on page 67

Importing model files into WebSphere Integration Developer

In this lesson, you will import the exported file from IBM WebSphere Business Modeler into WebSphere
Integration Developer. You can use the ClipsAndTacksF1.zip file that you created with the previous tasks,
or you can use the ClipsAndTacksF1.zip provided with this tutorial. See the Chapter 5, “Download and
import samples,” on page 141 section for instructions on downloading the provided project interchange
file.

Complete the following steps:
1. Start WebSphere Integration Developer V6.2. The Workspace Launcher opens.

2. Create a new workspace for this tutorial, for example C:\Documents and Settings\Administrator\
IBM\wid6.2\ClipsAndTacks.

Note: Do not select Use this as the default and do not ask again so you will be prompted for a
workspace location each time you open the application.

3. Click OK. WebSphere Integration Developer opens. If the Welcome page is displayed, close it.
4. To import the PI file, select File > Import. The Import wizard opens.
5. Select Other > Project Interchange and click Next.
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6. From the Import Project Interchange Contents wizard, in the From zip file field, click Browse and
select the ClipsAndTacksF1.zip file of your choice (either the supplied file or the one you built in the
previous section).
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7. Select ClipsAndTacksF1 and click Finish.

Setting up the Lotus Forms Server API workspace
In this lesson, you will add two .jar files to enable the Lotus Forms Server API to compute some of the
values in the Order form automatically.

To add the two .jar files, complete the following steps.
1. In WebSphere Integration Developer, select Window → Preferences and expand the list of configurable

items by clicking the .
2. Select Java → BuildPath → Classpath Variables.

Note: If Java does not display as an option, switch to a Java perspective. Select Window →
Preferences and switch back to the Business Integration perspective.

3. Add two variables named FORMS_API and FORMS_API2 as shown in the following figure. These
variables point to the location of the .jar files, pe_api.jar and uwi_api.jar. The location of these files
depends on how Lotus Forms Server was installed. If Lotus Forms Server was installed into
WebSphere Integration Developer, these files are typically located at: <WID62_Install>\API\lib\java.
If not, these files are typically located at C:\Windows\PureEdge\76\java\classes.
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4. Click OK.

Note: The ClipsAndTacksF1 project has some errors at this stage of the tutorial. These errors will be
corrected as the tutorial progresses.

Setting up the project to use the WebSphere Business Services Fabric
runtime APIs
In this lesson, you will replace the WebSphere Process Server V6.2 runtime library with the WebSphere
Business Services Fabric V6.2 runtime library.

This project includes implementations and functionality that use several of the WebSphere Business
Services Fabric V6.2 runtime APIs. To use the WebSphere Business Services Fabric V6.2 runtime APIs, its
runtime library must replace the existing WebSphere Process Server V6.2 runtime library in the project’s
preferences.

Note: WebSphere Business Services Fabric V6.2 runs on WebSphere Process Server V6.2. The WebSphere
Process Server runtime library and all of its APIs are still available during development.

Complete the following steps:
1. Right-click ClipsAndTacksF1, and then select Properties.
2. Click Java Build Path and select the Libraries tab. Select WebSphere Process Server V6.2 and click

Remove. If WebSphere Business Services Fabric server V6.2 is already listed, click Cancel.
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3. Click Add Library, select Server Runtime, and then click Next.

4. Select WebSphere Business Services Fabric server V6.2 , and then click Finish and OK in the next
window.

Importing web services endpoints into WebSphere Integration
Developer

In this lesson, you will import information about previously created web services and their endpoints
into WebSphere Integration Developer. See the Chapter 5, “Download and import samples,” on page 141
section for instructions on downloading the necessary files.
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While working through the Clips and Tacks sample, you will use several web services that were
previously created. These web services could be hosted on any server, but for simplicity the services will
be hosted on the same test server where you are running the sample.

Complete the following steps:
1. Click File → Import to import the ClipsAndTacksEndpoints.zip.
2. On the Import page, click Other → Project Interchange and click Next.
3. On the Import Project Interchange Contents page, click Browse and select

ClipsAndTacksEndpoints.zip.

4. Select all the entries that are available and click Finish. WebSphere Integration Developer displays the
Business Integration perspective.

Before continuing, wait for Building Workspace to complete. The status is located in the bottom
right-hand corner of the workspace.

Defining business rules
In this lesson, you will convert the artifacts from WebSphere Business Modeler into an artifact that you
can deploy to the server.

Business rules must exist to specify criteria that allow the automated processes to run without further
human intervention. In WebSphere Business Modeler you defined the template and if-then rule for
autoApproval. However, the one implementation details that is still missing is to initialize the output
variable before running the if-then rule.
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Complete the following steps:
1. In the project tree, expand ClipsAndTacksF1 and select Integration Logic → Rule Logic →

processes/orderhandling.

2. Double-click AutoApprovalF1. If the Generated File Warning displays, click Yes. The business rule set
editor opens.

3. Click the Add Action Rule icon under Rules.
4. To copy the input variable to the output variable, click Action and select Output:Order. Then select =

and then Input:Order.

5. Right click on the new rule and select Move Rule Up

6. Save your work.

At this point, all of the errors are resolved. The following image shows the completed rule logic.
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Generating Java components
In this lesson, you will generate Java components to provide implementation code for the tasks created in
WebSphere® Business Modeler.

This section discusses how to provide the implementation code for the following Java components:
v CheckCustomerAccountStatus
v UpdateOrderDatabase
v CancelOrderandSendNotification
v CreditRating

Complete the following steps:
1. Double-click the assembly diagram.
2. Right-click in a blank area on the assembly diagram panel and select Automatic Layout. Save your

work.
3. Double-click CheckCustomerAccountStatus.
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The CheckCustomerAccountStatusImpl.java window opens.
4. Replace the contents of the following method:

public commonj.sdo.DataObject InputCriterion(commonj.sdo.DataObject Input) {
//TODO Needs to be implemented.
return null;
}

with the following content:
public DataObject InputCriterion(DataObject input) {

System.out.println(
"Check Customer Account Status Invoked");

// create CreditRating bean
com.clipstacks.credit.CreditRating creditRating =
new com.clipstacks.credit.CreditRating();

// call CreditRating bean to update the BO
DataObject orderOut = creditRating.calculateCreditRating(input);
return orderOut;
}

5. Save your work. Ignore the errors at this time because they will be fixed after you create the Java™

components in the next steps.
6. For UpdateOrderDatabase, replace the contents of the following method:

public commonj.sdo.DataObject InputCriterion(commonj.sdo.DataObject input) {
//TODO Needs to be implemented.
return null;
}

with the following content:
public DataObject InputCriterion(DataObject input) {

System.out.println("Update Order Database invoked");
return input;

}

7. For CancelOrderandSendNotification,
a. Select all of the text on the CancelOrderandSendNotificationImpl.java window and delete it.
b. Open the CancelOrderandSendNotificationImpl.java file, then copy and paste its contents into the

CancelOrderandSendNotificationImpl.java window.
8. Save your work and close the window.
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9. Create a Java package to implement calculation of customer credit rating by clicking File → New →
Other and then Java → Package. Click Next .

10. In the Source folder field, click Browse and select ClipsAndTacksF1 → gen/src. Click OK.
11. For the Java package name, enter com.clipstacks.credit and then click Finish.

12. Switch to the Physical Resources view by clicking the Physical Resources tab (located in the same
area as the Business Integration tab).

13. Expand ClipsAndTacksF1 → com → clipstacks → credit and copy the CreditRating.java file that you
downloaded following the directions in Chapter 5, “Download and import samples,” on page 141.
Then paste the file into the credit folder.

14. Switch back to the assembly diagram editor and save it.
15. Save any unsaved items. An open window with an asterisk (*) on the tab indicates that it is not

saved. You should not have errors now.
16. Rebuild all the projects by clicking Project → Clean, and then click OK.
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Adding a Dynamic Assembler extension
In this lesson, you will implement a Dynamic Assembler extension for the CalculateShippingCharges
component.

WebSphere Business Services Fabric uses a component called Dynamic Assembler (DA) to select the
appropriate endpoint based on assertions and policies.

An assertion is a concept in the WebSphere Business Services Fabric meta-model that is used to specify a
policy requirement and evaluate endpoints at run time. It is also used to describe the capabilities of an
endpoint. For example, Endpoint A supports service invocations for EXISTING customers and
accountSize = SMALL.

A policy defines the business requirements that have to be met when a consumer requests a service. A
policy is a set of assertions that represents requirements, constraints, or capabilities for a business service,
for example IF [customerType = PLATINUM] THEN [responseTime < 20ms]

The CalculateShippingCharges component is a DA. It needs extensions to extract context information
from the message body and insert it into its invocation context. DA extensions are implemented as Java
components

To implement a ContextExtractor extension for the CalculateShippingCharge DA, complete the following
steps:
1. Select the Java component type from the component group on the palette and drag it to the

assembly diagram.

2. Rename the component ContextExtractor
3. Select the ContextExtractor component and click the Add Interface icon to specify one or more

interfaces. A window opens.

4. To add the interface to the component, perform these steps:
a. Select the Show WSDL and Java radio button.
b. In the Filter by interface or qualifier field, enter ContextExtractor.
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c. In the Matching interfaces text box, select ContextExtractor.
d. Click OK.

The component is updated with the selected interface.
5. Click the reference wire for the CalculateShippingCharges component and drag it to the

ContextExtractor interface on the ContextExtractor component. When the Add Wire window opens,
click OK.

6. Double-click the ContextExtractor component to specify its implementation. Click Yes to implement
the component.
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7. Select New Package and type com.ibm.clipsandtacks.sample as the package name.
8. Click OK twice.

9. Select all of the text on the ContextExtractorImpl.java window and delete it.
10. Open the ContextExtractorImpl.java file, and then copy and paste its contents on the

ContextExtractorImpl.java window.
11. Save your work.

Creating the process invocation method
In this lesson, you will create a method to invoke the process. This lesson gives you a way to enter data
into the order form to start the automated process.

Complete the following steps:
1. In the Business Integration view, expand ClipsAndTacksF1 → Integration Logic → Processes →

processes/orderhandling and double-click OrderHandling. The process OrderHandling opens.
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Note: If the Generated File Warning opens, click Yes. The business process editor opens.

2. Select OrderHandling, and then select the Properties tab and Authorization.

3. Click the OrderHandling_OrderHandling link (click Yes if a warning window displays). The human
task editor opens.

4. In the OrderHandling_OrderHandling window, click on Lotus Forms (for use in Business Space and
a generated client) in the User Interface section. The Properties view will now show the Client type:
Lotus Forms (for use in Business Space and a generated client).
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5. Click browse. The Select a Lotus form window opens.
6. Expand ClipsAndTacksF1 > order and select Order.xfdl. Click OK.

7. In the human task editor, save your work. The following screen capture shows the completed task.
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8. Close the human task editor.
9. Save your work. You no longer have errors.

Identifying WebSphere Monitor Server on WebSphere Process Server
ports
In this lesson, you will identify the ports being used by WebSphere Monitor Server on WebSphere Process
Server.

Depending on the order of install and what else was previously installed on a user’s machine, the
WebSphere Monitor Server may not be using the default ports. So it is necessary to identify the ports to
use before running the sample.
1. Open the file AboutThisProfile.txt located at: <WebSphere Integration Developer 62 install

directory>\pf\WBMonitor Srv_wps\logs.
2. Check the entries for HTTP transport port and HTTPS transport port. Anywhere in this tutorial where

you see <Server_Port>, substitute the value found for the HTTP transport port. Anywhere in this
tutorial where you see <Secure_Server_Port>, substitute the value found for the HTTPS transport
port.

Creating a WebSphere Business Services Fabric project
In this lesson, you will create a WebSphere Business Services Fabric project to be the container of all the
WebSphere Service Fabric artifacts created (for example: endpoints, assertions, etc.).

To create a project, two main steps need to occur:
1. WebSphere Business Services Fabric is set up with the vocabulary and project interchange file.
2. WebSphere Integration Developer is set up with a Business Service project that has a name that is the

same as the name of the WebSphere Business Services Fabric project name.

The link between the two projects is established by using the same name in both projects.
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WebSphere Business Services Fabric runs on the server and has a browser based interface that will be
used in this sample to import the vocabulary and the project interchange file. The vocabulary and the
project interchange file contain the meta-data needed for the dynamic assembler (DA) implementation.
With version 6.2, similar artifacts would be developed using the Business Space Authoring space. The
Business Space Authoring space and the development of the artifacts are not covered in this sample.

Complete the following steps:
1. Click the Servers tab.
2. If the server is not already running, right-click the WebSphere Business Monitor Server V6.2 server

and select Start.
3. When the server has started, which takes several minutes, open a Web browser to

http://localhost:<Server_Port>/fabric/login.jsp and log in to WebSphere Business Services
Fabric as the administrator. For <Server_Port> use the value you identified in “Identifying
WebSphere Monitor Server on WebSphere Process Server ports” on page 70.

Note: For purposes of this tutorial, log in using admin for the user ID and for the password.

4. In the My Services section, expand the Governance Manager menu and select Import/Export.
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5. Click Browse and navigate to the directory where the ClipsAndTacks-Core_ontology.fca file is
located. Click Import File. This file contains the Clips and Tacks custom ontology or vocabulary (For
example, OrderSizeAssertion and its values SMALL and LARGE are defined in this file).

6. If the previous step was successful, click Browse again and navigate to the directory where the
ClipsTacks_initial_scenario-owl.zip file is located. This project interchange file contains the
definition of all of the WebSphere Business Services Fabric components that are needed to recreate
the Clips and Tacks scenario. Click Import File and watch for error messages.

7. Under Governance Manager, click Configure Projects to see the following entries:

8. Logout of WebSphere Business Services Fabric and return to WebSphere Integration Developer. Open
the Business Services perspective and click OK.

9. From the Business tab, right-click New and select Fabric Project.
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10. In Project name, type Clips&Tacks and click Next and then click Configure.

11. Enter the Business Services Repository information (the port might be different in your system. Use
the same port that you used to log in to the WebSphere Business Service Fabric page). Use admin for
the user ID and for the password. Click OK. The replication process starts momentarily. The entire
metadata repository is replicated to the Eclipse workspace and is referred to by Composition Studio
as a local working copy.
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Wait until the replication finishes (do not click Configure again).

12. When the replication is complete, click Next.
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13. In the Fabric Project field, select Clips&Tacks and click Finish.

The Clips and Tacks Fabric project is created.
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Creating the Clips and Tacks Business Space
During this phase, you will create a Business Space to enable an integrated and customized user
experience, allowing access of business process information from a single user interface.

During the creation of the Business Space, the project will be deployed and the business spaces needed to
interact with the deployed project will be created.

To create the Clips and Tacks business spaces, complete the following tasks:
1. “Deploying the Clips and Tacks Order Handling business process and endpoints”
2. “Setting up the Clips and Tacks business space” on page 78
3. “Setting up the Fabric business space” on page 83

Deploying the Clips and Tacks Order Handling business process and
endpoints
In this lesson, you will deploy the sample to the WebSphere® Process Server.

Complete the following steps:
1. Switch back to the Business Integration perspective.

a. Click the Servers tab.
b. Right-click WebSphere Business Monitor Server V6.2 on WebSphere Process Server.
c. Click Start (if it is not started already).
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It takes a few minutes for the server to start. When the server starts (the server status changes
from Stopped to Started).

2. Right-click the started server and select Add and Remove Projects.

3. Add all the projects that are available by selecting Add All and click Finish. It takes a few minutes
for the applications to be published to the server.
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Setting up the Clips and Tacks business space
In this lesson, you will set up a Clips and Tacks business space.

In order to effectively use the Clips and Tacks project you must first set up a Clips and Tacks business
space.
1. Set the WebSphere Integration Developer default browser and log into Business Space.

a. In WebSphere Integration Developer, click Window > Preferences > General > Web Browser. The
default browser might be Internal Web Browser, but it does not have all of the functions that you
need. Select Use external Web browser and Default system Web browser or another listed
browser other than the internal browser. Click Apply and then click OK.

Note: This allows Clips and Tacks to use the default browser for your system, rather than the
default browser built into Clips and Tacks.
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b. In WebSphere Integration Developer, in the Servers view, right-click WebSphere Business Monitor
Server V6.2 and select Launch → Business Space. If a Security Alert warning window opens, click
Yes.

c. When prompted, enter admin for the user ID and enter admin for the password (or enter the
current administrator ID and password if you changed them from the default values). A Business
Space Manager window opens.
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2. Click the Manage Business Spaces link in the top-right corner of the page. The Business Space
Manager page contains several default business spaces and their respective sample pages, such as the
Welcome space and the Getting Started page.

3. Click the Create new Business Space icon . Name the business space ClipsAndTacks, and then
click OK. You can create a Business Space from a template, such as one for monitoring or managing
human tasks, however in this sample we show you how to create Business Spaces from scratch using
the wizard. This is the resulting ClipsAndTacks business space. You can change the owner and theme
by clicking the corresponding Change buttons.

4. Click the Create new Page icon . Name the page C & T Tasks, select the second layout on the
second row, and click OK. This is the resulting C & T Tasks page within the business space.

80 IBM WebSphere Clips and Tacks: Getting started with the IBM BPM suite of products



5. Click the C & T Tasks link to open it. Click Add Widgets, which is located on the center of the page.
The widget palette opens on the right and the cursor is moved to a search field. Type Task
Information to filter the widget palette. Click the Task Information widget and drag the item to the
top right hand corner of the page.

6. Next you will add the Create Tasks, Available Tasks and Human Workflow Diagram widgets to
your page. Click the Add Widgets in the upper right hand corner to open the palette and add the
first two widgets to the left of your page so that they display underneath each other with the
Available Tasks widget on the bottom of the top left section of the page. Place the Human Workflow
Diagram widget in the bottom section of the page. Placing the Human Workflow Diagram widget is
easier if the Available Tasks and Task Information widgets are minimized.
a. Click Available Tasks to minimize it. The button is located in the top-right corner of the widget.

Repeat with the Task Information widget.

b. Resize the bottom edge of the Task Information widget to be side by side with the bottom edge of
the Available Task widget.
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7. Resize the widgets using the following suggestions:
a. Restore the Task Information widgets by clicking the Restore icon. Leave Available Tasks

minimized.
b. Resize the bottom edge of the Task Information widget to be side by side with the bottom edge of

the Available Task widget.
c. Resize the Create Tasks widget to half of its original width. Hover the mouse pointer over the

edge of the widget until the mouse pointer changes to a double arrow. Click and drag it to the left
to resize the widget.

d. Resize the Create Tasks widget so the bottom edge is as close as possible to the OrderHandling
entry in the Create Tasks widget.

e. Restore the Available Tasks widgets by clicking the Restore icon.
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The finished C & T Tasks page should look like this image.

Setting up the Fabric business space
In this lesson, you will set up a Fabric business space.

A Fabric business space contains all the pages used to interact with the Fabric Runtime. There are pages
to operate on tasks, and to deal with governance.

Complete the following steps:
1. If you are still logged in to the Business Space, click Manage Business Spaces to return to the

Business Space Manager. If not, log into Business Space as described in the Setting up the Clips and
Tacks Business Space topic.

2. Click the Create new Business Space icon .
3. Type ClipsAndTacks Fabric as the business space name.
4. Select From a template and Fabric Administration, and then click OK. The ClipsAndTacks Fabric

business space opens automatically.
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5. Select the Manage Business Spaces link in the right-hand corner of the page to go back to the main
page.

Leveraging Business Services
WebSphere Business Services Fabric delivers dynamic business processes based on Business Service
Policy. During this phase, WebSphere Business Services Fabric tool pack will be used to organize and use
business services to quickly adapt the process to changing business needs.

WebSphere Business Services Fabric uses customer context and message content, among other pieces of
information, to generate a merged business policy contract to provision the correct service. The service
providers available to Clips and Tacks are implemented as endpoints, which have capabilities, or
assertions. The assertions are stored in the WebSphere Business Services Fabric meta-model, which is
inside the business services repository.

At run-time, the Dynamic Assembler uses these endpoint assertions, the service consumer’s information,
and declarative business policies to select the best service provider endpoint that meets the requirements.

There are five dimensions along which assertions can be applied:
v Performance
v Reliability
v Interoperability
v Security
v Manageability

In this tutorial, only the interoperability assertions are applied.
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Understanding endpoints and business services policies

Most of the Clips and Tacks WebSphere Business Services Fabric artifacts are already created and were
retrieved from the repository in “Creating a WebSphere Business Services Fabric project” on page 70.
These artifacts needed to implement the initial scenario in which Clips and Tacks uses Better Shipping for
large domestic orders, International Express for all international orders, and internal shipping for
domestic and small orders.

To implement Change 1 (in which Clips and Tacks decides to outsource all domestic shipping to Better
Shipping, even for small orders at the same flat fee of $8 per order) and Change 2 (in which Clips and
Tacks decides to use LocalShippers for orders in and around North Carolina, South Carolina, and
Virginia, Better Shipping for all other domestic orders, and International Express for all international
orders), you need to create additional artifacts.

The initial scenario has the following endpoints and assertions.

Endpoint Assertion

Internal Shipping domestic, small orders

International Express international orders only

Better Shipping domestic, large orders

To make the process dynamic, complete the following tasks:
1. “Updating the web services endpoint URLs”
2. “Simulating the initial shipping policies” on page 86
3. “Testing the initial shipping policies” on page 89
4. “Updating the shipping policies for small orders” on page 93
5. “Using Governance to manage changes” on page 96
6. “Updating the shipping policies with Local Shipping Option” on page 100

Updating the web services endpoint URLs
In this lesson, you will update the web services endpoint URL.

So far, you have:
v Identified the ports used in your installation of WebSphere Monitor Server on WebSphere Process Sever

in the section “Identifying WebSphere Monitor Server on WebSphere Process Server ports” on page 70.
v Imported the Fabric artifacts (including the web services endpoints definition and metadata) into the

business repository in the section “Creating a WebSphere Business Services Fabric project” on page 70.
v Deployed three web services on to the WebSphere Monitor Server on WebSphere Process Sever in the

section “Deploying the Clips and Tacks Order Handling business process and endpoints” on page 76.

Now it is time to verify that the web services endpoint as defined in the business repository matches the
actual port used by your installation of WebSphere Monitor Server on WebSphere Process Server.

The three web services metadata that you need to verify and maybe update are BetterShippingEndpoint,
InternalShippingEndpoint, and InternationalShippingEndpoint. The three endpoints may need to have
their endpoint URL adjusted to use the appropriate WebSphere port.
1. Switch to the Business Services perspective in WebSphere Integration Developer. In the Business

Services Explorer, expand the Endpoint folder in the Clips&Tacks project.
2. Double-click on BetterShippingEndpoint to bring up the editor.
3. Click on the HTTP/SOAP 1.1 link in the Protocol section.
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4. Verify that the URL field is using the correct port. The initial value is 9443, but it must match
<Secure_Server_Port> on your system.

5. If the port listed here is not the correct port used by your system, update the URL field so that the
port is correct. Save the change and close the editor.

6. Repeat these steps for the two remaining web service endpoints, InternalShippingEndpoint and
InternationalShippingEndpoint.

7. Perform the remaining steps only if you made changes to the port numbers in the URLs. You need to
publish your local changes to the business services repository.
a. If you have not already setup a fabric business space, do so now by following the instructions in

“Setting up the Fabric business space” on page 83
b. Follow the steps as outlined in the section “Using Governance to manage changes” on page 96. On

the Governance page of the Clips And Tacks Fabric space, update your comments to be
appropriate for this change.

Simulating the initial shipping policies
In this lesson, you will simulate using the Clips and Tacks policy.

You will use the Business Services perspective of WebSphere Business Services Fabric in WebSphere
Integration Developer to simulate the initial shipping policies and their impact on the Order Handling
process. Simulation allows you to run and validate polices and assertions that are part of the initial
scenario. The initial scenario is pre-built for this sample and the Clips and Tacks policy is ready for
simulation.
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The following table represents the Clips and Tacks service-provider endpoint capabilities (assertions) and
the use cases for service consumers for the initial scenario. The top row depicts the available service
providers, and the left column represents the service consumer use cases. The X represents the
service-provider endpoint that is to be selected based on the context, content, and contract of the service
consumer’s request.

Table 2. Clips and Tacks service-provider endpoint capabilities and use cases

Internal
Shipping Better Shipping

International
Express

Order Size = SMALL and Order Type = DOMESTIC X

Order Size = LARGE and Order Type = DOMESTIC X

Order Type = INTERNATIONAL X

The business services policies for the initial Clips and Tacks scenario were created based on this table.

To start the policy usage simulation, complete the following steps:
1. Logout of Business Space if you have not done so and switch to WebSphere Integration Developer.
2. Select the Business Service perspective and the Business Service Explorer tab. Expand the Simulation

node and double-click Test Verify Shipper Selection.

3. Verify the Simulation values against the screen below and click Run.
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The Simulation Operations panel shows only green check marks and the InternalShippingEndpoint
is selected.

When the simulation confirms that the correct policy is being selected, it is time to try a runtime test.
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Testing the initial shipping policies
In this lesson, you will initiate an instance of the process in order to test the policies in run time.

To perform a runtime test using Business Space complete the following steps:
1. In WebSphere Integration Developer, Select the Business Integration perspective and in the Servers

view, right-click the WebSphere Business Monitor Server V6.2 server and select Launch → Business
Space.

2. When prompted, enter admin for the user ID and for the password (or the administrator ID and
password if you have changed it). A Business Space Manager window opens.

3. Click the C & T Tasks link to open the page.
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4. Create a new instance of the Clips and Tacks Order Handling process by selecting the
OrderHandling task in the Create Tasks widget. Click the icon on the right side.

5. The Clips and Tacks Order Form appears in the Task Information widget. Complete the top part of
the form using the following values:

Note: Scroll down the page to show the form and the entry fields to complete.

Table 3. Clips and Tacks Customer Information window

Field Value

Customer Number 1

Company Name IBM

Contact First Name John

Contact Last Name Doe

Rating 100

Available Credit $500.00

Order Number 101

Street Address 100 Main St.
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Table 3. Clips and Tacks Customer Information window (continued)

Field Value

Country USA

Postal Code 10004

E-mail jd@ibm.com

6. Complete the rest of the form. Make the Total Price greater than $750.00 to force the process to flow
to the Review Order task. As a result, the Order Size assertion is set to LARGE, which causes the
Better Shipping endpoint to be selected (make sure the Country field is set to USA and the Postal
Code field is set to 10004.

Note: Do not type underneath For Office Use Only.
7. Click Submit

.
8. The Order Handling process is waiting for the Review Order task to be Approved, as shown in the

Available Tasks widget.

Note: If the Review Order task is not displayed, select the down arrow icon and click Refresh.

9. Select Review Order and click the icon on the right side of the Available Tasks window. The Task
Information widget now displays the Review Order form.
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10. For Order Status, select APPROVED.
11. Scroll down to see the Human Workflow Diagram widget displaying the state of all the human

tasks in the process instance.

12. Scroll back up to the Task Information widget and click Submit. The process progresses to the Ship
Order to Customer tasks. The Available Tasks widget now lists the Ship Order to Customer task.

Note: If the Ship Order to Customer task is not in the Available Tasks widget, select Refresh.
13. Claim the Ship Order to Customer task by selecting Ship Order to Customer and clicking the icon

on the right side of the Available Tasks window.
14. The process now completes for this instance and you can review the completion information by:

a. The Task Information widget now displays the updated Ship Order to Customer form.
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b. The Human Workflow Diagram widget displays the state of all the human tasks in the process.
Hover the mouse over each task to see the state and the owner.

c. The Shipping Charge field shows the amount that the endpoint charges by using the Calculate
Shipping Charges Dynamic Assembler. In this case, the Better Shipping endpoint was selected,
given the values of the input data, and the fact that this particular carrier charges an $8 flat fee.

You can also see the selected endpoint in WebSphere Integration Developer in the console view.

Updating the shipping policies for small orders
In this lesson, you will implement a change in the shipping policies for small orders.

Clips and Tacks made a business decision to update the shipping policies for all domestic shipping
including small orders. You will implement Change 1 to the Clips and Tacks policy. The following table
represents the Clips and Tacks service-provider endpoint capabilities (assertions) and use cases for service
consumers for Change 1.

Chapter 3. Build it yourself 93



Table 4. Clips and Tacks service-provider endpoint capabilities and use cases for Change 1

Size and Type of Order Internal Shipping Better Shipping International Express

Order Size = SMALL and Order
Type = DOMESTIC

X

Order Size = Large and Order
Type = DOMESTIC

X

Order Type =
INTERNATIONAL

X

1. Switch back to the Business Services perspective in WebSphere Integration Developer. Remove the
InternalShipping endpoint by right-clicking InternalShippingEndpoint and selecting Delete.

2. Modify the BetterShipping endpoint.
a. Double-click BetterShippingEndpoint to open its editor. Select the Assertions tab and click Add,

which is in the upper-right corner of the Endpoint Capabilities table.

b. Expand the Interoperability folder, expand the Content Based Assertion folder, and then select
OrderSizeAssertion and click OK.
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c. In the window that opens, select SMALL for the order size, and then click OK.

You have created an instance of this assertion type and associated it with this endpoint. There is
now a row for this assertion in the table.

d. In the Capabilities table, clear the check box in the Required column for OrderSizeAssertion with
a value that equals LARGE. Save your work.

e. Verify that you have three rows in the Endpoint Capabilities assertions table and close the editor.
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3. Simulate Change 1 by following the steps as outlined in the section “Simulating the initial shipping
policies” on page 86, changing the values of the Test Verify Shipper selection page to the following
values:
v CountryAssertion = USA
v PostalCodeAssertion = 30324
v TotalPriceAssertion = 10
Then click Run. The Simulation Operations panel shows only green check marks and the
BetterShippingEndpoint is selected. After observing the simulation results close the simulation tab
without saving it.

Using Governance to manage changes
In this lesson, you will publish your local changes to the WebSphere Business Services Fabric business
services repository.

The business services repository is used by the Dynamic Assembler when an actual process runs in
production or when you run your runtime test. To publish your local changes, Governance is used to
submit your local change list to update the business services repository. A change list is a collection of
related metadata changes that an individual developer makes in the localized project.
1. Locate the Repository Changes view on the left of your WebSphere Integration Developer

workspace. Expand the Active Changes folder to see the list of 2 outstanding active changes.
2. Right-click Active Changes and click Submit Change Set.

3. On the first page of the Change Wizard keep the default Project and click Next.
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4. To move all of your development changes to the Selected Changes window, Click Add All > and
then click Finish.

5. In the Confirm Submit to Business Services Repository window, click Yes.
6. In the Change Submission Status window click OK. Notice that the Active Changes has gone to zero.

7. Log in to Business Space with the admin id and open up the Governance page of the Clips And
Tacks Fabric space.
a. To get to the Business Space, in the Business Integration perspective of WebSphere Integration

Developer, in the Servers view, right-click the WebSphere Business Monitor Server V6.2 server
and select Launch → Business Space. (If a Security window displays, select the option to continue
to the Web site or add this connection as an exception, depending on the browser being used).

b. When prompted, enter admin for the user ID and for the password (or the administrator ID and
password if you have changed it).

c. Navigate to the Governance page of the Clips and Tacks Fabric space.
8. On the Change Set widget, select the row corresponding to the Clips&Tacks change set with the

status column set to Pending. This change set is the list of changes that you submitted from
WebSphere Integration Developer.

9. Click Approve Change Set.
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10. For the comment, type Shipping Changes for Change 1 and click OK.
11. Click Publish Change Set.

12. Click OK. The Clips&Tacks row shows Published in the Status column.

13. Switch back to the WebSphere Integration Developer workspace and the Business Service
perspective, notice that there is now an entry in the Pending Change Sets folder under the
Repository Changes tab.
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14. At the root of the tree, right-click Clips&Tacks and select Update Project.

15. In the Update Project window, click Finish.
16. In the Project Update Results window, click OK.
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Performing these steps moved your changes to the run time business services repository. The WebSphere
Business Services Fabric server now has access to this metadata during run time. Additionally, you have
re-synchronized your local Composition Studio environment.

To complete Change 1, you need to run a runtime test. For the actual runtime test, follow steps as
outlined in the section “Testing the initial shipping policies” on page 89. Use the same input values
provided there for the form except for the Total Price, which you should set to 10, to show that the Better
Shipping endpoint now handles small orders as well.

Updating the shipping policies with Local Shipping Option
In this lesson, you will implement a change to the shipping policy for local orders.

Clips and Tacks made a business decision to update the shipping policies on how to handle shipping for
all local orders. You will implement Change 2 to the Clips and Tacks policy. The following table
represents the Clips and Tacks service-provider endpoint capabilities (assertions) and use cases for service
consumers for Change 2.

Table 5. Clips and Tacks service-provider endpoint capabilities and use cases for Change 2

Order Size and Type Internal Shipping Better Shipping
International
Express Local Shippers

Order Size = SMALL and Order
Type = DOMESTIC

X

Order Size = LARGE and Order
Type = DOMESTIC

X

Order Type = INTERNATIONAL X

Order Type = LOCAL X

To create the Local Shippers endpoint in your fabric project.
1. Switch back to the Business Services perspective in WebSphere Integration Developer. In the

Business Services Explorer, right-click Endpoint and select New → Endpoint.
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2. Enter the name LocalShippersEndpoint, change the address to HTTP and select Next.
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3. Enter the URL; https://localhost:<SECURE_SERVER_PORT>/LocalShippersEndpoint/services/
LocalShippersPort. Select Finish.

The LocalShippersEndpoint editor opens.
4. Select the Interfaces tab for this editor and click Add Existing, which is located in the upper-right

corner of the Associated Interfaces table.

Note: If the Add Existing is returns a blank list of interfaces, open up the advanced editor by
closing the editor that is currently open, right-clicking on the endpoint and selecting Open with
Advanced Editor. The advanced editor will open up with the option to select the supports service
through another window for Interface Selection.
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5. Select CalculateShippingCharges and click OK.

6. Select the Assertions tab for this editor and click Add, which is located in the upper-right corner of
the Endpoint Capabilities table.

7. Expand the Interoperability folder, expand the Content Based Assertion folder and then select
OrderSizeAssertion and click OK.
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8. In the window that opens, select SMALL for the order size field and click OK.

You have created an instance of this assertion type and associated it with this endpoint. There is now
a row for this assertion in the table.

9. Create an assertion for LARGE orders by repeating the previous steps for adding an assertion but
this time select LARGE for the order size and click OK.

10. Create an assertion for Local orders by repeating the previous steps for adding an assertion but this
time select the following:
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a. type is an OrderTypeAssertion in the same folder as the OrderSizeAssertion type.
b. select Required.
c. select LOCAL for the order type.

11. Verify that you have three rows in the Endpoint Capabilities assertion table, and close the editor.
Save your work.

Create the business service policy named NCLocalOrderType that will use the Local Shippers
endpoint.

12. Right-click Policy and select New → Policy.

13. For the name, type NCLocalOrderType. Then click Browse and select Interface(2) →
CalculateShippingCharges and click OK.
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14. Click Finish.
15. In the Policy editor, type 1 for the priority.

16. Select the Policy Expression tab for this editor. Inside the Expression panel and select Add →
Operator → AND.

17. Inside the Expression panel, right-click AND and select Add → Condition → Assertion.
18. In the window that opens, select postalCode for the content type and select is greater than or equal

in the Comparison field.
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19. Click Add Content and type 27006 for the postal code. Click OK twice.

20. Repeat the previous 3 steps to add a condition but this time select is less than or equal in the
Comparison field and 28698 for the postal code.

21. Verify that the content in your Policy Expression panel matches what is shown below.

22. Click Add in the Assertion table of the Policy Expression tab for this editor.
23. Expand the Interoperability folder, expand the Content Based Assertion folder, select

OrderTypeAssertion this time, and click OK.
24. In the window that opens, clear the Required check box, select Fill from Context, select LOCAL for

the order type, and click OK.
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25. Save your work.

26. Browse the Clips&Tacks fabric project. You can see that there are already two other local policies
defined:
v SCLocalOrderType is defined as any postal code between 29001 and 29449.
v VALocalOrderType is defined as any postal code between 20101 and 22942.

All of these policies set the OrderTypeAssertion to LOCAL and so will result in the fabric choosing
the LocalShippers Endpoint.

27. Simulate Change 2 by following the steps as outlined in the section “Simulating the initial shipping
policies” on page 86, changing the values of the Test Verify Shipper selection page to the following
values:
v CountryAssertion = USA
v PostalCodeAssertion = 27519
v TotalPriceAssertion = 100
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The Simulation Operations panel shows only green check marks and the LocalShippersEndpoint is
selected.

28. Publish your local changes to the business services repository by following the steps as outlined in
the section “Using Governance to manage changes” on page 96. On the Governance page of the
Clips And Tacks Fabric space, update your comments to be appropriate for Change 2.

To complete Change 2, you need to run a runtime test. For the actual runtime test, follow the steps as
outlined in the section “Testing the initial shipping policies” on page 89. Use the same input values
provided there for the form except for the Postal Code, which should be set to a value between 27006
and 28698 causing the Local Shipping endpoint to be selected. Run a second test with a Postal Code
outside the three local ranges, any code that does not begin with the digit 2 will work, to see which
shipping service is selected.

Monitoring the Order Handling business process
During the monitoring model development phase, you will use WebSphere Business Monitor Toolkit to
build a monitor model that represents the Clips and Tacks business process activity and events.

To monitor the process and create a monitor model, complete the following tasks:
1. “Verifying that the business process emits events”
2. “Importing and opening the monitor model” on page 110
3. “Synchronizing the monitor model with the application” on page 112
4. “Adding monitoring details” on page 113
5. “Creating situation events” on page 117
6. “Creating a dimension model” on page 119
7. “Generating executable artifacts for the monitor model and deploying to the server” on page 122
8. “Configuring WebSphere Business Monitor for business situation events” on page 123
9. “Setting up access to the OrderHandling monitor model” on page 126

Verifying that the business process emits events
In this lesson, you will verify that events are emitted for decisions and invocation actions in the process.

Before you create the monitor model, you must select the events that WebSphere Process Server
generates. WebSphere Business Monitor uses the generated events to monitor the process.

When you export the business model from WebSphere Business Modeler, decisions become BPEL links in
WebSphere Integration Developer and the events required for monitoring are already selected.

To verify that events are available for monitoring, complete the following steps.
1. In the Business Integration view, select ClipsAndTacksF1 → Integration Logic → Processes →

processes/orderhandling and then double-click OrderHandling to open the BPEL editor.
2. Click the white background of the process outside of the Generalized Flow (OrderHandlingFlow)

element, which is the large rectangle that contains elements such as a receive activity, human tasks,
and an invoke activity.

3. Click the Properties tab under the BPEL diagram, and then click the Event Monitor tab (if you have
to scroll down, scroll from the left side, not the right side). Verify that All is selected.
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4. Click inside the OrderHandling_Flow parallel activity element, and then verify that All on the Event
Monitor tab is selected.

The following screen capture shows the yellow flag icon on the OrderHandling process (right side of the
diagram), which indicates that events are selected to be emitted for all the components inside the
OrderHandling process.

Importing and opening the monitor model
In this lesson, you will import the business measures model from WebSphere Business Modeler to
monitor the business process.
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Note: Errors will result from the following actions, but these are corrected as you progress through the
steps.

Complete the following steps:
1. In the Business Integration view, click File → Import.
2. Expand Other, select Project Interchange, and click Next.
3. Browse to and select ClipsAndTacksF1_Monitor.zip.
4. Select ClipsAndTacksF1_Monitor and click Finish.

5. Verify that the ClipsAndTacksF1_Monitor project is added to the project tree on the left pane.

Note: The monitor model name can vary slightly from OrderHandling_Monitor.mm to
OrderHandling_Mon.mm.

6. Switch the Perspective to Business Monitoring Perspective by clicking the icon on the right corner and
selecting Business Monitoring.
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7. Close the Technology Quickstarts and the Help tabs.
8. In the project tree expand ClipsAndTacksF1_Monitor and double click the Orderhandling

Monitor.mm to open the monitor model.

Synchronizing the monitor model with the application
In this lesson, because you changed an interface, you will synchronize the monitor model, clean the
project, and build the workspace.

Complete the following steps:
1. Right-click OrderHandling Monitor.mm and select Synchronize with Application, and then click

OK.

2. Click Project → Clean. Then click OK to build the workspace. This will cleanly rebuild all the artifacts
included with the project.
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Adding monitoring details
In this lesson, you will add events, triggers, and KPIs to the monitor model.

Events are requests or responses sent from one component to another. A trigger is a mechanism that
detects an occurrence and can cause additional processing to occur in response. For example, you could
define a trigger that causes a metric to be updated, a counter to increment, or a stopwatch to halt each
time a task ends. Key performance indicators (KPIs) are quantifiable measurements of the improvement
or deterioration in the performance of an activity that is critical to the success of a business.
1. Click KPI Model tab and expand OrderHandling KC.
2. Click on the Average Process Duration Trigger 1. For Trigger condition, enter the expression

Average_Process_Duration ge dayTimeDuration(’P3DT1H’).
3. Click on the Percentage of Orders Shipped Trigger 1. For Trigger condition, enter the expression

Percentage_of_Orders_Shipped < 85.
4. Click Average process Duration (one of the KPIs) and examine how the KPI is calculated. How the

KPI gets its value is shown under KPI Value. The metric and the aggregate function are shown
under KPI Details. Everything is set up already.

5. Click Percentage of Orders Shipped. There is no metric available to calculate this KPI. You need to
create a KPI for the number of shipped orders and another KPI for the total number of orders. From
that you can calculate the percentage of orders shipped.

6. Create the Total Number of Orders KPI by right-clicking OrderHandling KC and selecting New →
KPI. For the name, enter as Total Number of Orders and click OK.
a. Under KPI Value select Base this KPI on a metric and an aggregation.
b. Under KPI Details, select OrderHandling as the monitoring context.
c. Select OrderHandling Instance ID as the metric.
d. Select Count as the aggregation function and leave everything else as it appears by default.
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7. Create the Shipped Orders KPI by right-clicking OrderHandling KC and selecting New → KPI. Enter
name as Shipped Orders and click OK.
a. Under KPI Value, select Base this KPI on a metric and an aggregation.
b. Under KPI Details, select OrderHandling as the monitoring context.
c. Select OrderHandling Instance ID as the metric.
d. Select Count as the aggregation function and leave everything else as it appears by default.

Note: This KPI should be counting only shipped orders. Under Data Filter you will need to filter
only the shipped orders. For that you need to create a new metric called Order Status. You will
create the Order Status metric in the next step and later complete the Data Filter for this KPI.

8. Create the Order Status metric.

114 IBM WebSphere Clips and Tacks: Getting started with the IBM BPM suite of products



a. Click the Monitor Details Model tab and right-click the OrderHandling monitor context. Select
New → Metric.

b. Enter Order Status as the name and leave String as the type. Click OK.
c. Select A value is required for this metric because a dimension uses this metric and it requires a

value for dimensional analysis.
d. For the default value, enter ’New’ with the single quotation marks. You need to create triggers to

set the value of the metric. See the next step to see how to create triggers. You select the triggers
later.

9. Create the Shipped Order and the Canceled Order triggers.
a. In Monitor Details Model tab, right-click the OrderHandling monitoring context and select New

→ Trigger.
b. Enter Shipped Order Trigger as the name and click OK.
c. Under Trigger Sources, click Add. Click Other source type and select OrderHandling → Ship

Order to Customer → Ship Order to CustomerExit. Click OK.

d. In Monitor Details Model tab, right-click the OrderHandling monitoring context and select New
→ Trigger.
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e. Enter Canceled Order Trigger as the name and click OK

f. Under Trigger Sources, click Add. Click Other source type and select OrderHandling → Cancel
Order and Send Notification → Cancel Order and Send NotificationExit. Click OK.

10. Complete the Order Status metric.
a. Click Order Status. Under Metric Value Expressions, click Add and then click Trigger Cell and

select Shipped Order Trigger.
b. Under Expression, enter ‘Shipped’ including the single quotation marks.
c. Repeat steps a and b to add Canceled Order Trigger as the trigger value and ‘Canceled’

including the single quotation marks for the expression.

11. Complete the Shipped Orders KPI.
a. Click the KPI Model tab and then click Shipped Orders.
b. Under Data Filter, click Add and select Order Status as the metric. Click OK.
c. Under values type ‘Shipped’ with the single quotation marks.

12. Complete the Percentage of Orders Shipped KPI
a. Click Percentage of Orders Shipped.
b. For KPI Value, select Write an expression to calculate this KPI based on existing KPIs.
c. For KPI Calculation, enter ( Shipped_Orders div Total_Number_of_Orders ) * 100. You can use

context assistant to complete the expression inside the parentheses.
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Creating situation events
In this lesson, you will create situation events to allow the outbound events to be visualized as alerts in
the Business Space.
1. Create the Shipped Percentage situation event.

a. Drag the DeclinedOrderEvent.xsd file to under Event Definitions.
b. Create the Shipped Percentage Event outbound event by clicking the KPI Model tab (for

OrderHandling Monitor.mm), right-clicking the OrderHandling KC, selecting New > Outbound
Event, and entering Shipped Percentage Event as the name.

c. Select Configure this event to be processed by WebSphere Business Monitor action services.
d. For the trigger, browse to Order Handling KC > Percentage of Orders Shipped Trigger 1 and

click OK and then click OK again.
e. In Event Type Details, in Event Parts, click Add and then click Select Type.
f. In the Select Event Part Data Type window, select Choose the data type from the XML schemas

accessible from this monitor project.
g. Select ClipsAndTacksF1_Monitor → DeclinedOrderEvent.xsd → doe:DeclinedOrderEvent, click

Next, then click Finish.

h. Change the path to cbe:CommonBaseEvent/doe:DeclinedOrderEventType, and click Finish.
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i. In the Outbound Event Content, expand Percentage of Orders Shipped Trigger1 > My Event Part.
For BusinessSituationName, enter ’Shipped Percentage Event’ for the expression, including the
single quotation marks.

2. Create Order processing Time situation event.
a. Drag the LateAverageOrderShippedEvent.xsd file to under Event Definitions.
b. Create the Order Fulfillment Event outbound event by clicking the KPI Model tab (for

OrderHandling Monitor.mm), right-clicking OrderHandling KC, selecting New → Outbound
Event, and entering Order Fulfillment Event for the name.

c. Select Configure this event to be processed by WebSphere Business Monitor action services.
d. For the trigger, browse to Order Handling KC → Average Process Duration Trigger 1 and click

OK and then click OK again.
e. In Event Type Details, in Event Parts, click Add and then click Select Type.
f. In the Select Event Part Data Type window, select Choose the data type from the XML schemas

accessible from this monitor project.
g. Select ClipsAndTacksF1_Monitor → LateAverageOrderShippedEvent.xsd → laose:

LateAverageOrderShippedEvent, then click Finish.
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h. Change the path to cbe:CommonBaseEvent/laose:LateAverageOrderShippedEventType and click
Finish.

i. In the Outbound Event Content, expand Average Process Duration Trigger1 → My Event Part. For
BusinessSituationName under Expression enter ’Order Fulfilment Event’ including the quotes.

j. For AverageOrderProcessingTime, set the expression to xs:string(Average_Process_Duration div
xs:dayTimeDuration(’P1D’)). This expression displays the average process duration in units of
days.

3. Click Ctrl-S to save your work.

Creating a dimension model
In this lesson, you will create a dimensional model to enable multidimensional analysis of collected data.

The Clips and Tacks dimensional model will be used for the organization of a dimensional analysis
widget to be included on the dashboard that will show the aggregation of orders (instances) by their
order status.
1. Click the Dimensional Model tab and expand OrderHandling → Orderhandling Cube.
2. Create a new dimension.

a. Right-click the Orderhandling Cube and select New → Dimension.
b. Enter Order Status as the name and click OK.
c. Right-click Order Status in the navigation, and then select New → Dimension Level.
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d. Enter Order Status as the name and click Browse to find the source metric. Select Order Status.
Click OK and then click OK again.

3. You want a multilevel dimension called Location that lets you drill down on the country and then the
city within the country. To enable the Location dimension, you need to create metrics for the country
and city, and then you can complete the Location dimension to refer to these metrics.
a. Create a metric called Country by clicking the Monitor Details Model tab, right-clicking the

OrderHandling monitoring context, and selecting New → Metric.
b. Enter Country as the name and leave the type as String, then click OK.
c. Select A value is required for this metric because a dimension uses this metric and requires a

value for dimensional analysis. For the default value, enter an empty string (two single quotation
marks).

d. In Metric Value Expressions, click Add. In the expression cell, use the content assistant to
navigate to the OrderHandling → OrderHandlingEXIT event then select Country in the order data
under Customer.

The resulting expression is OrderHandling2/OrderHandlingEXIT/Order/Customer/Country.
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e. Repeat the necessary steps to create a metric called City. The resulting expression is
OrderHandlingReceive/OrderHandlingReceiveEXIT/Order/Customer/City.

4. Update the Location dimension using the Country and City metrics:
a. Click Dimension Model tab. Navigate to the Order Handling Cube → Location. Notice that there

is a dimension level called Location underneath the Location dimension.
b. Right-click Location underneath the Location dimension and select Delete.

c. Right-click the Location dimension and select New → Dimension Level.
d. Enter Country as the name, and then click Browse to find the source metric and select

OrderHandling → Country. Click OK.
e. Right-click the Location dimension and select New → Dimension Level.
f. Enter City for the name, then click Browse to find the source metric and select OrderHandling >

City. Click OK. The resulting Location is shown in the following screen capture.
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g. Save your work.
5. Select Project > Clean, and then select Clean all projects. Click OK.

a. Warnings and informational messages might be present and can be ignored. Check for any errors
in the Problems view and resolve the errors before continuing.

Generating executable artifacts for the monitor model and deploying to
the server
In this lesson, you will use WebSphere Integration Developer to deploy the monitor model to the
WebSphere Business Monitor testing environment.
1. Generate the J2EE application from the monitor model.

a. In the Business Monitoring perspective project tree, expand ClipsAndTacksF1_Monitor > Monitor
Models > Order Handling, right-click OrderHandling_Mon.mm and select Generate Monitor
J2EE Projects and then click Finish.

A progress window shows the status of the operation and it closes when the operation is
complete. This takes a few minutes.

2. Deploy the generated projects.
a. Click the Servers tab and then right-click WebSphere Monitor Server v6.2 on WebSphere Process

Server and select Start to start the server. Starting the server might take a few minutes.
b. After the server starts, right-click WebSphere Monitor Server v6.2 on WebSphere Process Server

again and select Add and Remove Projects.
c. Click Add All to move ClipsAndTacksF1App, the Endpoints applications, and

OrderHandling_MonitorApplication from the list of available projects to the list of configured
projects and then click Finish. A progress message displays in the lower-right corner of the
window. Deploying and starting the applications might take a few minutes.

Note: At this time, you may be deploying just the WebSphere Business Monitor projects if the
Fabric and WebSphere Integration Developer projects are already deployed.
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d. Check the messages in the Console view for errors and correct them should they be present before
continuing.

Configuring WebSphere Business Monitor for business situation
events
In this lesson, you will configure WebSphere Business Monitor to create alerts by configuring Action
Services to send notifications when business situation events are received.

The situation events are defined in and sent by the monitor model as outbound events. The notifications
are visible as alerts in the Alert view on your dashboard.
1. Click Window → Preferences. Expand General and click Web Browser. Select Use external Web browser.

Click OK.
2. In the Servers view, right-click WebSphere Business Monitor Server v6.2 on WebSphere Process

Server and select Administration → Run administrative console. The administrative console opens in
a new window (if a Security page displays, select the option to continue to the website or add this
connection as an exception, depending on the browser being used). The administrative console
prompts you for a user ID and password. For the user ID, enter admin. For the password, enter admin.
Click Log in.

3. Add an alert template for when the percentage of shipped orders needs attention.
a. In the administrative console, select Applications → Monitor Services → Monitor Action Services →

Template Definitions → Notifications and click New.
b. For the template name, enter AlertShip, and then enter any description.
c. Select Dashboard Alert. This indicates an alert is sent to the business dashboard’s alert view.
d. Select User id.
e. In the To field, enter admin. This user ID is the user logged into the business dashboard that

receives the alert. You must log into the business dashboard with this user ID.
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f. In the Subject field, enter Percentage of shipped orders. This is the title of the alert in the
dashboard.

g. In the Body field, enter Percentage of shipped orders is less than 85.

h. Click OK.

4. Add an alert template for when order processing time needs attention.
a. In the administrative console, select Applications → Monitor Services → Monitor Action Services →

Template Definitions → Notifications and click New.
b. For the template name, enter AlertTime, and then enter any description.
c. Select Dashboard Alert. This indicates an alert is sent to the business dashboard’s alert view.
d. Select User ID.
e. For the To field, enter admin. This user ID is the user logged into the business dashboard that

receives the alert. You must log into the business dashboard with this user ID.
f. For the Subject field, enter Order processing time.
g. For the Body field, enter The average order processing time is %AverageOrderprocessingTime%

days.
h. Click OK.

5. Add the binding from the situation event to the action type of the alert template for shipped
percentage situations:
a. In the administrative console, select Applications → Monitor Services → Monitor Action Services →

Installed Situation Event Bindings and click New.
b. Enter the situation event name you defined in the model. You named the business situation

Shipped Percentage Event. The name must match the value in the BusinessSituationName field in
the outbound event. You might want to copy the name from the monitor model (without the
quotation marks).
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c. Enter any description and then click Apply.
d. In the table under Preferences, click Add.
e. Enter a binding name, for example Shipped Percentage Event, and then select the template

AlertShip.
f. Click OK. Notice you now have one action defined for this situation event. If you had other action

templates defined, then you could add more actions to this event and you could send a notification
for this situation event to multiple destinations using e-mail, alerts, and Web services.

g. Click Ok.
6. Add the binding from the situation event to the action type of the alert template for action processing

time situations.
a. In the administrative console, select Applications → Monitor Services → Monitor Action Services →

Installed Situation Event Bindings and click New.
b. Enter the situation event name that you defined in the model. You named the business situation

Order Fulfillment Event. The name must match the value in the BusinessSituationName field in
the outbound event. You might want to copy the name from the monitor model (without the
quotation marks).

c. Enter any description and then click Apply.
d. In the table under Preferences, click Add.
e. Enter a binding name such as Order Fulfillment Event, select the template AlertTime, and then

click OK.
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f. Click OK.
g. In the administrative console, select Applications → Monitor Services → Monitor Action Services →

Installed Situation Event Bindings. You see the two bindings you created.

Setting up access to the OrderHandling monitor model
In this lesson, you will configure the Data Security Services in WebSphere® Business Monitor to permit
the administrative user access to the OrderHandling_ClipsAndTacksF1 monitor model.

Access is automatically granted when the WebSphere Business Monitor development toolkit is installed.
However, because the WebSphere Process Server profile was augmented with the development toolkit
profile in this tutorial, you need to manually set up access to this resource. You will grant the
administrative user access to the deployed monitor models, OrderHandling_ClipsAndTacksF1 and
GlobalHTMM.
1. If you are not still logged in, login to the administrative console of WebSphere Business Monitor

Server V6.2 on WebSphere Process Server. For the user ID, enter admin. For the password, enter
admin.

2. In the administrative console, select Security → Monitor Data Security and click the root entry in the
Resource Groups table.
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3. In the Roles section, select Business-Manager, and then click Users.

4. Click Search. When the Available panel is populated, select the entry with uid=admin and then click
the right arrow to move uid=admin to the Selected panel. Click OK and then click OK again.
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5. Repeat steps 3 and 4 for each of the next three available roles: Personal-KPI-Administrator,
Public-KPI-Administrator, and KPI-Administrator. Then click OK.

Testing the Order Handling business process
The order handling process has been modeled, developed, optimized with points of agility, and is
configured to emit events for monitoring. The order handling monitor model has been developed to
handle those emitted events for display in the Business Space. The Order Handling projects (executables)
have been deployed to the WebSphere Process Server and WebSphere Business Monitor. Now you will
test this code to observe the corresponding output and behavior.

Run the process multiple times so there is enough data to display in the Business Space widgets. Create a
process instance for each of the following orders. For the non-specified values, any value is acceptable as
long as it does not repeat values for value-unique fields, such as the shipping number.

To run the process instances, do the steps that were used during the runtime testing in the section
“Testing the initial shipping policies” on page 89.

You can create more scenarios than are listed here.
v Scenario 1: Process tasks run; approve without review; account in good standing; ship the order

1. Form data to start this instance of the process.
a. Rating: 800
b. Available Credit: 800
c. Total Price: 200

2. Ship task
a. Packing Slip Number: Any unique value

v Scenario 2: Process tasks run; approve without review; account not in good standing; approve the
order; ship the order
1. Form data to start this instance of the process.

a. Rating: 800
b. Available Credit: 100
c. Total Price: 300

2. Review task
a. Order Status: APPROVED

3. Ship task
a. Packing Slip Number: Any unique value

v Scenario 3: Process tasks run; approve without review; account not in good standing; decline the order
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1. Form data to start this instance of the process.
a. Rating: 800
b. Available Credit: 100
c. Total Price: 400

2. Review task
a. Order Status: REJECTED

v Scenario 4: Process tasks run; do not approve without review; approve the order, ship the order
1. Form data to start this instance of the process.

a. Rating: 10
b. Available Credit: 100
c. Total Price: 900

2. Review task
a. Order Status: APPROVED

3. Ship task
a. Packing Slip Number: Any value

v Scenario 5: Process tasks run; do not approve without review; decline the order
1. Form data to start this instance of the process.

a. Rating: 10
b. Available Credit: 100
c. Total Price: 800

2. Review task
a. Order Status: REJECTED

v Scenario 6: Repeat Scenario 5
Repeating the declined order scenario is necessary to see an alert in the Alerts view of the business
space dashboard. The monitor model is configured to raise an alert when the number of shipped
orders is less than 85 percent of the total number of orders. You will see this alert when you complete
the steps in the “Creating a business dashboard in Business Space” section.

Creating a business dashboard in Business Space
In this lesson, you will create a business dashboard to monitor the Order Handling process using
Business Space powered by WebSphere.
1. If not already logged in, log in to Business Space as userID admin.
2. Add a page named C & T Instances to the previously created ClipsAndTacks business space.

a. Navigate to the Business Space Manager.
b. Select the ClipsAndTacks business space.

c. Click the Create new page icon , name the page C & T Instances, and click OK.
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The ClipsAndTacks business space is updated with the C & T Instances page.
3. Add an instance widget to the C & T Instances page:

a. Click the C & T Instances link to open the page. Click Add Widgets, which is in the center of the
page, and type Instances. Drag the Instances item to the page.

You could also click Add Widgets from the right corner of the page.

b. Click the down arrow icon on the right side of the Instances toolbar and select Configure.

c. In Select the monitoring context to personalize, expand OrderHandling (Across all Versions) and
select OrderHandling. In Select the columns to display, select City, Country, Order Status, and

Price per order. Use the right arrow to move to these items into the Selected column.
Then click Set as default.
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d. Click OK. The resulting Instances view is shown in the following screen capture.

4. Create a new page, add the KPI and Alerts widgets, and then configure the page:
a. Click the New Page tab.
b. Enter C & T KPI and Alerts as the page name, and then click OK.
c. Click Add Widgets and enter KPIs. Drag the KPIs item to the page.
d. Select Configure. Select the Average Process Duration and Percentage of Orders Shipped KPIs

that you want to display on the widget.

e. Click the Layout tab. Select Half Gauge as the display type. Click OK.
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The KPI view opens.

5. Add the Alerts widget to the C & T KPI and Alerts page:
a. Click Add Widgets and enter Alerts. Drag the Alerts item to the page, underneath the KPIs

widget.
There are two alerts defined in the model: one for shipped percentage and one for order
processing time. The latter alert is based on a processing time greater than three days, so it is
difficult to test here, unless you use the KPI Manager widget to reduce the target. The former
alert can be tested easily by ensuring the number of shipped orders is less than 85 percent of the
number of total orders.

Note: WebSphere Business Monitor may ship with a default BAM showcase model. The alert view
may display alerts from this showcase model.

b. Click the alert to see details.

6. Create a new page to add the Human Tasks widget and Dimensions view:
a. Click the New Page tab .
b. Enter C & T Human Tasks and Dimensions as the page name and click OK.
c. Click Add Widgets and enter Human Tasks. Drag the Human Tasks item to the page.
d. Select Configure.

e. Select Creation Time, Owner, and Status and use the right arrow to move them to the
Selected column.
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f. Click OK. The Human Tasks view displays.

7. Add the Dimension widget to C & T Human Tasks and Dimensions page:
a. Click the Add Widgets and enter Dimensions. Drag the Dimensions item to the page, underneath

the Human Tasks widget.
b. Click Configure.
c. In the Monitoring Model field, select Global HT MM (All Versions).
d. Add Task Name Dimension to the Row dimensions box.
e. Add Task Owner Dimension to the Column dimensions box.
f. Add Measures Dimension to the Page dimensions box.

g. Click OK. The Dimensions view displays the instances count based on the task name and task
owner.
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h. You can double-click All Task Name Dimension and select All Task Owner Dimension to drill
down for more detailed data.

8. Add a dynamic KPI to the business space:
a. Click the C & T KPI and Alerts link to open the page.
b. Click Add Widgets and enter KPI Manager. Drag the KPI Manager item to the page, underneath

the Alerts widget.
c. For the model, select OrderHandling.

d. Click Actions and select the New Expression KPI.
e. For the name of the KPI, enter Declined Orders.
f. For the model associated with the KPI, select OrderHandling.
g. For the type of access, select Shared so that other users can see the new KPI.
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9. Create the expression for the new Declined Orders KPI:
a. Select the Definition tab.
b. Use the KPI drop-down list to select Total Number of Orders and click Insert.
c. Use the Operator drop-down list to select the minus symbol (-) and click Insert.
d. Use the KPI drop-own list again to select Shipped Orders and click Insert.

e. Click Apply.
f. Select the Range tab.
g. For Range definition, select Numerical.
h. Add two rows by clicking Add row and entering the following values:
v In the first row, enter low declined orders for the range name, 0 for the start value, 2 for the

end value, green for the color, and the check mark in the green square for the icon.
v In the second row, enter high declined orders for the range name, 2 for the start value, 5 for

the end value, red for the color, and the down arrow in the red circle for the icon.

Click OK.
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i. Click Configure on the KPIs widget.
j. Expand OrderHandling and select Declined Orders and then click OK. The newly created KPI is

added to the KPIs widget.
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Chapter 4. Running the sample

You can run the sample from the provided artifacts if you did not build the sample from the tutorial.
1. Import the provided project interchange file. There are two options for completing this step, choose

the method that best suits you.
a. Start WebSphere Integration Developer V6.2 and create a new workspace for this sample, for

example C:\Documents and Settings\Administrator\IBM\wid6.2\ClipsAndTacks. Do not select
Use this as the default and do not ask again because it is easier to come back to this window if
it is not selected. Click OK.

b. If you accessed this documentation through the Samples and Tutorials Gallery, return to the
gallery now and use the button to import the complete application, then continue on to step 2.

c. If you accessed this document through a web browser, follow the steps in Chapter 5, “Download
and import samples,” on page 141

2. Follow the steps described in “Setting up the Lotus Forms Server API workspace” on page 57.
3. Follow the steps described in “Identifying WebSphere Monitor Server on WebSphere Process Server

ports” on page 70
4. Follow the steps in “Creating a WebSphere Business Services Fabric project” on page 70.
5. Follow the steps described in “Updating the web services endpoint URLs” on page 85, and be sure

to complete the governance step at the end.
6. Deploy the monitor model J2EE projects. Follow the steps described in the “Generating executable

artifacts for the monitor model and deploying to the server” on page 122. Note that when generating
the J2EE artifacts, you will have to overwrite existing artifacts so be sure to select the checkbox.

7. Follow the steps in “Configuring WebSphere Business Monitor for business situation events” on page
123.

8. Follow the steps in “Setting up access to the OrderHandling monitor model” on page 126.
9. Import the provided clipsandtacks.data file into Business Space powered by WebSphere.

a. In WebSphere Integration Developer, click Windows → Preferences → General → Web Browser.
The default browser might be Internal Web Browser, but this one does not have all of the
functions that you require. Select Default system Web browser or another listed browser other
than the internal browser and select Use external Web browser. Click OK.
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b. In WebSphere Integration Developer, in the Servers view, right-click the WebSphere Business
Monitor Server V6.2 server and select Launch → Business Space. (If a Security page displays,
select the option to continue to the Web site or add this connection as an exception, depending
on the browser being used.)

c. When prompted, enter admin for the user ID and enter admin for the password (or the
administrator ID and password if you have changed it). A Business Space Manager window
opens.
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10. Click Manage Business Spaces. The new page contains two default business spaces: Solution
Management and Welcome (which has a few sample pages).

11. Import the provided clipsandtacks.data file.

a. Click the Import Business Space icon . Click Browse and navigate to the directory where
the clipsandtacks.data file is located.

b. Click OK.
12. To run the sample, complete the following steps:

a. Follow the steps described in “Testing the initial shipping policies” on page 89.
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b. Follow the steps described in “Testing the Order Handling business process” on page 128 and
select the C & T Instances and Diagrams, C & T KPI and Alerts and C & T Human Tasks and
Dimensions pages to monitor the deployed process.

13. View the business dashboard.
v On the C & T Instances page you can see a record of each test you ran.
v On the C & T KPI and Alerts page you can see gauges representing the average process duration

and the percentage of orders shipped, as well as an alert for the percentage of orders shipped
below the threshold of 85%.

v On the C & T Human Tasks and Dimensions page you can see each human task with its current
status and in the dimensions widget a graphical representation of the tasks that you can drill
down to view additional details.
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Chapter 5. Download and import samples

This section provides links to artifact files needed to complete the tutorial and build the sample
application, and also guidance on the three different starting points.

This sample uses the WebSphere Business Process Management Products in the following order
1. WebSphere Business Modeler
2. WebSphere Integration Developer
3. WebSphere Business Services Fabric
4. WebSphere Business Monitor
5. Business Space Powered by WebSphere

There are three paths through the tutorial. The required files and the starting points in the documentation
are as follows:
1. Start in WebSphere Business Modeler

a. Download the file Download/BIY_StartInModeler.zip. This contains the following artifact files:

Order.xsd
The XML schema to be used in WebSphere Business Modeler.

Order.xfdl
The Lotus® form used in this tutorial. It is imported in WebSphere Business Modeler.

ClipsAndTacksEndpoints.zip
Web service endpoints to be called by WebSphere Business Services Fabric. These are not
really Business Process Management artifacts, but rather external artifacts necessary to run
the application.

CancelOrderandSendNotificationImpl.java
The Java file used to generate notifications. It is the implementation for one of the
components in the WebSphere Integration Developer.

CreditRating.java
The Java file used to check the customer account status. It is the implementation for one of
the components in the WebSphere Integration Developer.

ContextExtractorImpl.java
A file used by the Dynamic Assembler component in Websphere Integration Developer to
extract data from the incoming request and pass it to Websphere Business Services Fabric.

ClipsAndTacks-Core_ontology.fca
Custom ontology (vocabulary) required for Websphere Business Services Fabric.

ClipsTacks_initial_scenario-owl.zip
WebSphere Business Services Fabric repository project.

DeclinedOrderEvent.xsd
An XML schema for the Declined Order event that is monitored in Websphere Business
Monitor.

LateAverageOrderShippedEvent.xsd
An XML schema for the Order Fulfillment event that is monitored in Websphere Business
Monitor.

ClipsAndTacksF1.mar
The completed process model in WebSphere Business Modeler.
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b. Extract the files into a convenient local directory.
c. Proceed to Chapter 3, “Build it yourself,” on page 11 of the documentation.

2. Start in WebSphere Integration Developer
a. Download the file Download/BIY_StartInWID.zip. This contains the following artifact files:

ClipsAndTacksF1.mar
The completed process model in WebSphere Business Modeler.

ClipsAndTacksF1.zip
The modeler model formatted for import into WebSphere Integration Developer.

ClipsAndTacksEndpoints.zip
Web service endpoints to be called by WebSphere Business Services Fabric. These are not
really Business Process Management artifacts, but rather external artifacts necessary to run
the application.

CancelOrderandSendNotificationImpl.java
The Java file used to generate notifications. It is the implementation for one of the
components in the WebSphere Integration Developer.

CreditRating.java
The Java file used to check the customer account status. It is the implementation for one of
the components in the WebSphere Integration Developer.

ContextExtractorImpl.java
A file used by the Dynamic Assembler component in Websphere Integration Developer to
extract data from the incoming request and pass it to Websphere Business Services Fabric.

ClipsAndTacks-Core_ontology.fca
Custom ontology (vocabulary) required for Websphere Business Services Fabric.

ClipsTacks_initial_scenario-owl.zip
WebSphere Business Services Fabric repository project.

DeclinedOrderEvent.xsd
An XML schema for the Declined Order event that is monitored in Websphere Business
Monitor.

LateAverageOrderShippedEvent.xsd
An XML schema for the Order Fulfillment event that is monitored in Websphere Business
Monitor.

ClipsAndTacksF1_Completed.zip
The completed process model and monitor projects, to be imported into WebSphere
Integration Developer

b. Extract the files into a convenient local directory.
c. Proceed to “Integration development” on page 55 of the Build It Yourself documentation.

3. Start with the complete WebSphere Integration Developer process, modeler model, and business space
a. Download the file RunTheSample.zip. This contains the following artifact files:

ClipsAndTacksF1_Completed.zip
The completed process model and monitor projects, to be imported into WebSphere
Integration Developer

ClipsAndTacksF1_Monitor.zip
The monitor model to be imported into WebSphere Integration Developer for further
development
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ClipsAndTacksEndpoints.zip
Web service endpoints to be called by WebSphere Business Services Fabric. These are not
really Business Process Management artifacts, but rather external artifacts necessary to run
the application.

ClipsAndTacks-Core_ontology.fca
Custom ontology (vocabulary) required for Websphere Business Services Fabric.

ClipsTacks_initial_scenario-owl.zip
WebSphere Business Services Fabric repository project.

clipsandtacks.data
A pre-built business space for the ClipsAndTacks scenario

b. Extract the files into a convenient local directory.
c. Complete the steps in “Importing the completed model into WebSphere Integration Developer”
d. Proceed to Chapter 4, “Running the sample,” on page 137 of the documentation.

There are three additional files available for individual download as follows:

ClipsAndTacks.pdf
The documentation for running the sample in a book format that you can print

ClipsAndTacksF1.mar
The completed process model to be imported into WebSphere Business Modeler

Use the instructions in “Importing the completed process model into WebSphere Business
Modeler” to import the model into WebSphere Business Modeler.

ClipsAndTacksF1_Completed.zip
The completed process model and monitor projects, to be imported into WebSphere Integration
Developer

Use the instructions in “Importing the completed model into WebSphere Integration Developer”
to import the model into WebSphere Business Modeler.

Importing the completed process model into WebSphere Business
Modeler
The completed process model is in the ClipsAndTacksF1.mar file.

To import the ClipsAndTacksF1.mar file, complete the following steps:
1. Start WebSphere Business Modeler with a new workspace.
2. Right-click the white background of the Project Tree panel and select Import.
3. Select WebSphere Business Modeler project (.mar, .zip) and click Next.
4. Click Browse and select the directory where the ClipsAndTacksF1.mar is saved.
5. Select ClipsAndTacksF1.mar and click Finish.

Importing the completed model into WebSphere Integration Developer
The completed process model, monitor model, and WebSphere Business Services Fabric endpoints for
importing into WebSphere Integration Developer are included in the ClipsAndTacksF1Completed.zip file.

To import the ClipsAndTacksF1Completed.zip file, complete the following steps:
1. Start WebSphere Integration Developer with a new workspace.
2. Click File → Import → Other → Project Interchange and click Next.
3. For From zip file, click Browse and select the directory where the ClipsAndTacksF1Completed.zip is

saved.
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4. To import everything, click Select All and then Finish.
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