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C h a p t e r  1 .  Introduction  
WebSphere Adapter for JDBC 7.5.0.0 enables the bidirectional 
connectivity for integration to any database application. The exchange 
of data for such applications happens at the database level. Updates to 
the database may need to be applied to another Enterprise Information 
System (EIS) and changes in an EIS may need to be applied to a 
database. The JDBC resource adapter can integrate with any database, 
as long as there is a JDBC driver that supports the JDBC 2.0 or higher 
specification, available for the database. Examples of such databases 
include Oracle, Microsoft SQLServer, DB2, Sybase, and Informix. 
 

Learning objectives 
After completing the tutorial, you should be able to perform the 
following tasks: 

• Create an adapter project in IBM Integration Designer. 

• Discover services and associated business objects from the 
enterprise information system (EIS) and make them part of the 
adapter project. 

• Create a deployable module that you install on IBM Process 
Server or WebSphere Enterprise Service Bus. 

• Test the module and validate the results. 

 

Audience 

These tutorials are for integration developers who design, assemble, test, and 
deploy business integration solutions. 

 

Software prerequisites 

To use these tutorials, you must have the following applications installed: 

• IBM Integration Designer version 7.5.0.0 

• IBM Process Server version 7.5.0.0 

• WebSphere Adapter for JDBC version 7.5.0.0 

• JDBC Driver for Oracle 

• JDBC Driver for DB2 

• JDBC Driver for SQLServer 



 

C h a p t e r  2 .  Tutorial 1: Creating a record 
using parent child business 
objects with a CreateSP 
operation associated with the 
child business objects 
(Oracle) 

This tutorial demonstrates how to create records in a table in a parent 
child relationship for WebSphere Adapter for JDBC 7.5.0.0. The 
scenario also demonstrates the use of a stored procedure attached to 
a business object. A stored procedure is associated with the child 
business object using the CreateSP verb ASI. The adapter calls the 
stored procedure to create the record in the child table instead of 
generating the insert SQL statement. 

About this task 
In this scenario, an application SCA component raises a create 
Customer business object request to the JDBC Outbound Interface. 
The JDBC adapter generates SQL statements to insert corresponding 
Customer and CustAdd records into the database. Finally, the JDBC 
adapter generates response according to the input business object and 
the execution results of the SQL statements. The following figure 
represents this scenario. 
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Prepare to run through the tutorial 

Extract the sample files 

Replicas of the artifacts that you create when using the external service wizard 
are provided as sample files for your reference. Use these files to verify if the 
files you create using the external service wizard are correct. 

Download the sample zip file and extract it into a directory of your choice (you 
may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedure 

• Create an authentication alias 

• Create a data source 

Create tables and stored procedure 

You must create the following tables and stored procedures in the Oracle 
database before starting the scenario.  
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CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 
 
CREATE TABLE CUSTADD  ( 
    ADDRID VARCHAR2(10) NOT NULL PRIMARY KEY,  
    CUSTID VARCHAR2(10) ,  
    CITY VARCHAR2(20) ,  
    ZIPCODE VARCHAR2(10) ) ; 
 
CREATE or REPLACE PROCEDURE CREATEADDRESS  
(addr_id IN varchar2, cust_id IN varchar2, city IN 
 varchar2, zipcode IN varchar2) 
 AS 
 BEGIN 
  INSERT into CUSTADD (ADDRID, CUSTID, CITY, ZIPCODE) 
 values             
            (addr_id, cust_id, city, zipcode); 
 END; 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 
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3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 

 

4. Log on to the administrative console.  
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5. Click Security  Global security. 
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6. On the right, click J2C Authentication Data under Java 
Authentication and Authorization Service. 
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A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 
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8. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the data source.  
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Create the data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source will be used later when 
generating the artifacts for the module.  

Note: This tutorial will use Oracle as the database and the Oracle thin 
driver, ojdbc6.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right, click ORACLE_JDBC_DRIVER_PATH and specify the 
path of the ojdbc6.jar file in the Value field. Click OK. 
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3. Click Save to save the changes. 

 

The variable has been added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 

 

5. Click New in the JDBC providers window. 
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6. In the Create new JDBC provider page, select an Oracle database 
with a connection pool data source for the Oracle JDBC driver. Click 
Next. 
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7. In the Enter database classpath information page, enter the following 
value in the Class path field: 
$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

8. Click Next. 
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9. Click Finish.  

 

10. Click Save to save the changes. 
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The JDBC provider is added and appears in the list. 

 

11. Click the Oracle JDBC provider you just created. Under Additional 
Properties, click Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias list. Click Next. 

 

The Summary of the values entered for the data source will be shown.  

15. Click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the check box corresponding to the data source you created 
in the previous step and click Test connection. 
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The connection should succeed as shown in the following figure. If you 
experience problems while testing the connection, refer to the 
“Troubleshooting” section. 

 

Note: The data source is created which will be used by the adapter to 
connect to the database. 
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Configure the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and 
configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> External 
Service. 

3. In the Available Types area, select Adapters > JDBC and then click 
Next. 

 
4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and click 

Next. 
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5. In the Connector project field enter CWYBC_JDBC, and in the Target 

runtime environment field, select the appropriate runtime. Click Next. 
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6. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file and 
click Next. 

 
7. Select Outbound and click Next.   
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Set connection properties for the external service wizard 
To connect to the Oracle database: 

1. Expand the Oracle node from Database system connection 
information then select 10. 

2. Enter System ID, Host name, Port number, User name and 
Password fields, and then click Next.   
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Select the business objects to be used with the adapter  
Follow these steps to select the Customer and CustAdd business objects: 

1. In the Find Objects in Enterprise System window, click Edit Query. 
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2. In the Specify the Query Properties window, select the Prompt for 

additional configuration settings when adding business objects 
check box and click OK.   
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3. Click Run Query.  

4. Expand the QAD (for this tutorial only) node, select Tables and expand 
it. 

28 



 

 

5. Select the CUSTOMER table and click . In the Specify the Configuration 
Properties for ‘CUSTOMER’ window, click OK.   
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6. Select the CUSTADD table and click . 

7. In the Specify the Configuration Properties for ‘CUSTADD’ window, 
select CUSTOMER (SAMPLE) from the Choose parent table list, 
and then select PKEY for CUSTID in the Build a foreign key area. 
Select the Parent object owns child object(cascade delete) check box. 
Click Add. 
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8. Select CreateSP and click OK. 
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9. Select QAD for schema name. 

 
10. Select CREATEADDRESS form the stored procedure name list.   
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11. Select stored procedure parameter for each column.  

ADDR_ID: addrid 

CUST_ID: custid 

CITY: city 

ZIPCODE: zipcode 

12. Click OK. 
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13. In the Find Objects in Enterprise System window, click Next.  
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Generating business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default values 
for all fields and click Next. 
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2. In the Specify the Service Generation and Deployment window, perform 

the following steps: 

a) Select Other for security options under Deployment 
Properties.  

b) Clear the Join the global transaction check box.  

c) Select Specify predefined connection pool DataSource 
from the Database connection information list. 

d) Enter OracleDS in the Connection pool DataSource JNDI 
Name field, and click Next. 
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3. Click New in the Specify the Location Properties window.  
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4. In the Select a Business Integration Project Type window, select Module 

and click Next. 

38 



 

 
5. In the Create a Module window, type TestCreateSPOracle in the 

Module Name field and click Finish. 
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6. Click Finish to complete service creation. 
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7. Expand the created Business Integration Project and verify whether the 

artifacts are generated correctly. 
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Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System import. You must install 
this SCA module in the IBM Integration Designer integration test client. 
To do this, you must add the SCA module you created earlier to the server 
using the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove…. 
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The Add and Remove… window lists the available projects in the IBM 
Integration Designer workspace. 

43 



 

 
4. Select your project (TestCreateSPOracleApp) and click Add to 

configure the project on the server. Click Finish. 
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Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration Designer 
integration test client.   

1. Select the TestCreateSPOracle module, right-click, and select Test > 
Test Module. The Test Client window is displayed. 
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2. Select createQadCustomerBG from the Operation list. 

46 



 

 
3. Enter Create for the verb and specify values for pkey, lname, fname 

and ccode as shown in the figure. 
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4. Right-click custaddobj and select Add Elements.  
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5. Enter 1 and click OK. 

 
6. Enter values for custaddobj[0] as shown in the figure below. 
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7. To execute the service, click . 

8. In the Select a Deployment Location window, select the server, and click 
Finish. 
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9. Check the data in the EIS to ensure that it is populated correctly.  

Clear the sample content 
After you have tested the application, clear the sample content to return 
the data to its original state. 
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C h a p t e r  3 .  Tutorial 2: Creating a record using 
parent-child business objects with a 
CreateSP associated with the child business 
object (SQL Server) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
populates the Customer and Address information into the database 
where the CUSTOMER and ADDRESS tables have a parent-child 
relationship.  A stored procedure is used to populate the Address 
(child) information. 

About this task 

In this scenario, an application SCA component raises a create 
Customer business object request to the JDBC Outbound Interface. 
The JDBC adapter generates SQL statements to insert corresponding 
CUSTOMER and ADDRESS records into database. Finally, the JDBC 
adapter generates response according to the input business object and 
the execution results of the SQL statements. The following figure 
represents this scenario: 

 

Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedure 
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• Create an authentication alias 

• Create a data source 

Create tables and stored procedure 

You must create the following tables and stored procedure in the MS 
SQLServer database before starting the scenario. 

a. Script for creating CUSTOMER and ADDRESS tables 

   CREATE TABLE CUSTOMER  ( 
      PKEY VARCHAR(10) NOT NULL PRIMARY KEY,  
      FNAME VARCHAR(20) ,  
      LNAME VARCHAR(20) ,  
      CCODE VARCHAR(10) ) ; 
 
   CREATE TABLE ADDRESS  ( 
      ADDRID VARCHAR(10) NOT NULL PRIMARY KEY,  
      CUSTID VARCHAR(10) ,  
      CITY VARCHAR(20) ,  
     ZIPCODE VARCHAR(10) ) ; 
 

b. Script for create CREATEADDRESS procedure 

CREATE PROCEDURE CREATEADDRESS  
(@addr_id varchar(10), @cust_id varchar(10), @city 
varchar(10), @zipcode varchar(10)) 
AS 
begin 
INSERT into ADDRESS (ADDRID, CUSTID, CITY, ZIPCODE) 
values             
             (@addr_id, @cust_id, @city, @zipcode);  
end; 
 

Create an authentication alias 

The authentication alias needs to be set because the data source that 
is used to generate artifacts will use the username and password set in 
the authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  
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5. Click Security  Global security. 

 

6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  
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7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 

 

 

8. Click Save to save the changes.  
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You have created an authentication alias that will be used to configure 
the data source. 

 

Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source is used later when 
generating the artifacts for the module.  

Note: This tutorial uses SQL Server as the database and the SQL 
Server JDBC driver sqljdbc.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right, select MICROSOFT_JDBC_DRIVER_PATH and 
specify the path of the sqljdbc.jar file in the Value field. Click OK. 
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3. Click Save to save the changes. 

 

The variable is added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 
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5. Click New in the JDBC providers window. 
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6. In the Create new JDBC provider page, select an SQL Server 
database with a connection pool data source for the SQL Server JDBC 
driver. Click Next. 
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7. In the Enter database classpath information page, enter the following 
value in the Class path field: 
$(MICROSOFT_JDBC_DRIVER_PATH)/sqljdbc.jar, where 
$(MICROSOFT_JDBC_DRIVER_PATH) is library path for the run time. 

8. Click Next.  
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9. In the Summary page, click Finish.  

 

10. Click Save to save the changes. 
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The JDBC provider is added and appears in the list. 

 

11. Select the SQL Server JDBC provider you created. Under Additional 
Properties, click Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Enter appropriate values in the Database name, Port number, and 
Server name fields. Click Next. 

68 



 

 

14. Select the authentication alias you just created from the 
Component-managed authentication alias list and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  

69 



 

 

16. Click Save to save the changes. 

 

17. Select the check box corresponding to the data source you created in 
the previous step and click Test connection. 
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The connection should succeed shown in the following figure. If you 
experience problems while testing the connection, refer to the 
“Troubleshooting” section. 
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Note: The data source is created which will be used by the adapter to 
connect to the database.  

Configure the adapter for outbound processing  

Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and then 
click Next. 

 

4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC, and in the 
Target runtime environment field, select the appropriate runtime. 
Click Next. 
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6. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 

 

7. Select Outbound and click Next. 
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Set connection properties for the external service wizard 
 To connect to the SQL Server: 

1. Expand the SQL Server node in the Database system connection 
information area and select 2005. 

2. Enter Database, Host name, Port number, User name and 
Password fields, and click Next. 

 

Select the business objects and services to be used with the adapter  
1. Find Objects in Enterprise System window, click Edit Query. 
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2. In the Specify the Query Properties window, select the Prompt for 
additional configuration settings when adding business 
objects check box and click OK. 

 

3. Click Run Query. 
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4. Expand the dbo (for this tutorial only) node, select Tables and 
expand it. 

 

5. Select the CUSTOMER table and click . In the Specify the 
Configuration Properties for ‘CUSTOMER’ window click OK.    
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6. Select the ADDRESS table and click   

7. In the Specify the Configuration Properties for ‘ADDRESS’ window, 
select CUSTOMER (dbo) from the Choose parent table list, and 
then select PKEY for CUSTID in the Build a foreign key area. Select 
the Parent object owns child object(cascade delete) check box. 
Click Add. 
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8. Select CreateSP and click OK. 

 

9. Select dbo for the schema name. 
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10. Select CREATEADDRESS;1 from stored procedure name list. 
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11. Select stored procedure parameter for each column. 

@addr_id: addrid 

@cust_id: custid 

@city: city 

@zipcode: zipcode 

12. Click OK. 
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13. In the Find Objects in Enterprise System window, click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values for all fields and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Other for security options under Deployment 
Properties.  

b) Clear the Join the global transaction check box.  

c) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

d) Enter SQLServerDS in the Connection pool 
DataSource JNDI Name field, and click Next. 
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3. Click New in the Specify the Location Properties window.  
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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5. In the Create a Module window, type TestCreateSPSQLServer in 
the Module Name field and click Finish. 
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6. Click Finish to complete service creation. 
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7. Expand the created Business Integration Project and verify whether 
the artifacts are generated correctly. 

 

Deploy the module to the test environment 

The result of running the external service wizard is a Service 
Component Architecture (SCA) module that contains an Enterprise 
Information System import. You must install this SCA module in the 
IBM Integration Designer integration test client. To do this, you must 
add the SCA module you created earlier to the server using the 
Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

The Add and Remove Projects window lists the available projects in the 
IBM Integration Designer workspace. 
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4. Select your project (TestCreateSPSQLServerApp) and click Add to 
configure the project on the server. Click Finish. 
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Test the assembled adapter application   

Test the assembled adapter application using the IBM Integration 
Designer integration test client.  
 

1. Select the TestCreateSPSQLServer module, right-click and select 
Test > Test Module. The Test Client window is displayed. 
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2. Select createDboCustomerBG from the Operation list. 
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3. Enter Create for the verb and specify values for pkey, lname, 
fname and ccode as shown in the figure. 

 

4. Right-click addressobj and select Add Elements. 
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5. Enter 1 and click OK. 

 

6. Enter the values for addressobj[0] as shown in the figure below. 

 

7. To execute the service click . 

95 



 

8. In the Deployment Location window, select the server, and click 
Finish. 

 

The result of the test execution will be displayed once completed. 

 Clear the sample content 

After a record created with the IBM Integration Designer environment, 
it can be remove using a Delete operation.  

96 



 

C h a p t e r  4 .  Tutorial 3: Creating and executing stored 
procedure business objects with complex 
data types (Oracle) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
creates business object for stored procedure and executes the stored 
procedure using the Execute operation. This tutorial also demonstrates 
the support for Array and Struct data types.  

About this task 

In this scenario, an application SCA component raises an execute 
request to the JDBC Outbound Interface. Then JDBC adapter 
constructs the complex SQL types according to the input business 
object and generates execute SQL statement to call the corresponding 
stored procedure. The stored procedure executes its internal business 
logic and generates output. Finally, the JDBC adapter generates a 
response according to the execution status and output of the stored 
procedure. The following figure represents this scenario: 
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Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create types, tables and stored procedure 

• Create an authentication alias 

• Create a data source 

Create types, tables and stored procedure 

You must create the following tables, objects and stored procedures in 
the Oracle database before starting the scenario.  

a. Script for creating the reference type 

 CREATE OR REPLACE TYPE ARRAYTYPE AS   
 VARRAY(10) OF    VARCHAR2(50); 
  / 

This script creates a reference type of Array that holds up to 10 records 
of type VARCHAR2. It is used as an input type in our stored procedure.  

   
 CREATE OR REPLACE TYPE STRUCTTYPE AS OBJECT ( 
  EMPID VARCHAR2(10), 
  NAME VARCHAR2(20), 
  TITLE VARCHAR2(10) 
   ); 
 / 

This script creates a reference type of Struct that has three columns. It 
is used as an output type in our stored procedure.  

Note: To create reference types, enter a forward slash (/) at the end 
and then press the Return key. 

b. Script for creating tables 

Create two tables that will be used in the stored procedure.  
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  CREATE TABLE TABLE_ARRAY ( 
    ID VARCHAR2(10),  
    INFO ARRAYTYPE ); 
 
  CREATE TABLE TABLE_STRUCT ( 
    ID VARCHAR2(10) ,  
    INFO STRUCTTYPE ) ; 

Insert a record into TABLE_STRUCT by executing the following SQL 
statement:  

INSERT INTO TABLE_STRUCT VALUES ('100', 
STRUCTTYPE('10', 'xyz', 'SE')); 

c. Script for creating the stored procedure 

The stored procedure takes an Array type as an input parameter and 
returns a Struct type as an output parameter. 

CREATE OR REPLACE PROCEDURE SAMPLE_ARRAY_STRUCT ( 
pkey IN VARCHAR, arr IN ARRAYTYPE, strt OUT STRUCTTYPE 
) 
IS BEGIN 
INSERT INTO TABLE_ARRAY VALUES (pkey, arr); 
SELECT INFO INTO strt FROM TABLE_STRUCT WHERE ID = 
pkey; 
END SAMPLE_ARRAY_STRUCT; 
/ 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

9. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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10. In the Servers view, right-click the server that you want to start and 
select Start. 

 

 

11. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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12. Log on to the administrative console.  

 

13. Click Security  Global security. 
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14. On the right, click J2C Authentication Data under Java 
Authentication and Authorization Service. 
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A list of existing aliases is displayed.  

 

15. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 
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16. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the data source.  
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Create the data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source will be used later when 
generating the artifacts for the module.  

Note: This tutorial will use Oracle as the database and the Oracle thin 
driver, ojdbc6.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

18. In the administrative console, select Environment  WebSphere 
Variables. 
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19. On the right, click ORACLE_JDBC_DRIVER_PATH and specify the 
path of the ojdbc6.jar file in the Value field. Click OK. 
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20. Click Save to save the changes. 

 

The variable has been added and appears in the list.  
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21. Select Resources  JDBC -> JDBC Providers. 

 

22. Click New in the JDBC providers window. 
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23. In the Create new JDBC provider page, select an Oracle database 
with a connection pool data source for the Oracle JDBC driver. Click 
Next. 
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24. In the Enter database classpath information page, enter the following 
value in the Class path field: 
$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

25. Click Next. 
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26. Click Finish.  

 

27. Click Save to save the changes. 
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The JDBC provider is added and appears in the list. 

 

28. Click the Oracle JDBC provider you just created. Under Additional 
Properties, click Data sources. Click New. 
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29. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

30. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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31. Select the authentication alias you just created from the 
Component-managed authentication alias list. Click Next. 

 

The Summary of the values entered for the data source will be shown.  

32. Click Finish.  
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33. Click Save to save the changes. 

 

34.  Select the check box corresponding to the data source you created 
in the previous step and click Test connection. 
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The connection should succeed as shown in the following figure. If you 
experience problems while testing the connection, refer to the 
“Troubleshooting” section. 

 

Note: The data source is created which will be used by the adapter to 
connect to the database. 

Configure the adapter for outbound processing  
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Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and then 
click Next. 

 

4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC, and in the 
Target runtime environment field, select appropriate runtime. 
Click Next. 
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6. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 

 

7. Select Outbound and click Next.   

119 



 

 

Set connection properties for the external service wizard 
To connect to the Oracle database: 

1. Expand the Oracle node from Database system connection 
information then select 10. 

2. Enter System ID, Host name, Port number, User name and 
Password fields, and then click Next.   
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Select the business objects to be used with the adapter  
Follow these steps to select the SAMPLE_ARRAY_STRUCT business 
object: 

1. In the Object Discovery and Selection screen, click Edit Query. 
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2. In the Specify the Query Properties window, select the Prompt for 
additional configuration settings when adding business 
objects check box and click OK.   

122 



 

 

3. Click Run Query.  

4. Expand the SAMPLE (for this tutorial only) node and select Stored 
Procedures and expand it. 

5. Select SAMPLE_ARRAY_STRUCT from stored procedures and click 

.   
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6. In the Specify the Configuration Properties for 
‘SAMPLE_ARRAY_STRUCT’ window, accept the default value for the 
Maximum number of result sets returned field and check 
whether the data types of parameters are correct. 
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7. Enter sample values for the stored procedure input types, click 
Validate to verify if the stored procedure executes successfully. 
Check the Result to verify the result of validation and click OK.  
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8. Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values for the all fields and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Other for security options under Deployment 
Properties.  

b) Clear the Join the global transaction check box.  

c) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

d) Enter OracleDS in the Connection pool DataSource 
JNDI Name field, and click Next. 
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3. Click New in the Specify the Location Properties window.  
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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5. In the Create a Module window, type TestStructArray in the 
Module Name field and click Finish. 

 

6. Click Finish to complete service creation.  
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7. Expand the created Business Integration Project and verify whether 
the artifacts are generated correctly. 
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Deploy the module to the test environment 

After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System import. You must 
install this SCA module in the IBM Integration Designer integration test 
client. To do this, you must add the SCA module you created earlier to 
the server using the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects. 
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The Add and Remove Projects window lists the available projects in the 
IBM Integration Designer workspace. 

 

4. Select your project (TestStructArrayApp) and click Add to 
configure the project on the server. Click Finish. 
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Test the assembled adapter application   

Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

1. Select the TestStructArray module, right-click, and select Test > 
Test Module. The Test Client window is displayed. 
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There is only one supported operation for business objects created for stored 
procedures. The executeSampleSample_Array_StructBG operation is 
selected by default. 
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2. Right-click arr and click Add Elements.  
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3. In the Add Element window enter 2, to create two child objects and 
click OK. 

 

4. Populate data for the input pkey and the two array child attributes as 
shown in the figure.  
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5. Unset the value for the strt attribute, which is an output type by 
right-clicking on strt and select Set To Unset.  
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6. Execute the service by click . 

7. In the Select Deployment location window, select the server, and 
click Finish. 

 

8. Check the output of the service, and check the data in the Enterprise 
Information System to ensure it matches expected values.  
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Clear the sample content 

After you have tested the application, clear the sample content to 
return the data to its original state. 
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C h a p t e r  5 .  Tutorial 4: Sending Data to Enterprise 
Information System using BatchSQL 
(Oracle) 

This tutorial demonstrates how to create batch SQL business object to execute 
multiple SQL statements using WebSphere Adapter for JDBC 7.5.0.0.  

About this task 

In this scenario, an application SCA component raises a batch SQL execution 
request to the JDBC Outbound Interface. The JDBC adapter executes a batch 
SQL to complete the following database operations: 

• Insert a record into CUSTOMER table 

• Delete a record from CUSTOMER table  

• Update a record in CUSTINFO table 

Finally, the JDBC adapter returns the execution result to a SDO and sends a 
response to the SCA component. The following figure represents the scenario: 
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Prepare to run through the tutorial 

Extract the sample files 

Replicas of the artifacts that you create when using the external service wizard 
are provided as sample files for your reference. Use these files to verify that 
the files you create with the external service wizard are correct. 

Download the sample zip file and extract it into a directory of your choice (you 
may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and records 

• Create an authentication alias 

• Create a data source 

Create tables and records 

You must create the following tables in the Oracle database before 
starting the scenario.  

a. Script for creating the tables 

CREATE TABLE CUSTINFO ( 
 CCODE VARCHAR2(10) NOT NULL PRIMARY KEY,  
 CDATA VARCHAR2(20)); 
 
CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 
 

b. Script for inserting records into tables 

Insert a record in Customer table.  

INSERT INTO CUSTOMER (pkey,ccode,fname,lname) 
values('Test', 'ANITA','MEHTA','IBM'); 

Insert a record in CUSTINFO table.  

INSERT INTO CUSTINFO (ccode, cdata) values('Test1', 
'ABC');  

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  
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Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  
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5. Click Security  Global security. 

 

6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  
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7. Click New to create a new authentication entry. Type the alias 
name, and username and password to connect to the database. Click 
OK. 
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8. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the data source.  
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Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source is used later when 
generating the artifacts for the module.  

Note: This tutorial uses Oracle as the database and the Oracle thin 
driver, ojdbc6.jar. 

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right page, select ORACLE_JDBC_DRIVER_PATH and 
specify the path of the ojdbc6.jar file in the Value field. Click OK. 

151 



 

 

3. Click Save to save the changes. 

 

The variable has been added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 

 

5. Click New in the JDBC providers window. 
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6. Select an Oracle database with a connection pool data source for the 
Oracle JDBC driver. Click Next. 
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7. In the Enter database classpath information page, enter the following 
value for the Class path field: 

$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

8. Click Next. 
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9. In the Summary page, click Finish. 

 

10. Click Save. 
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The JDBC provider is added and appears in the list. 

 

11. Select the Oracle JDBC provider you just created. Under Additional 
Properties, click Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias field and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the data source you just created and click Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database. 

 

Configure the adapter for outbound processing  
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Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer 7.5 by selecting Window -> Open Perspective -> 
Business Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 

 

4. Select IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC. 

6. In the Target runtime environment field, select the appropriate 
runtime and click Next. 
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7. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Outbound and click Next.   

 

Set connection properties for the external service wizard 
To connect to the Oracle database:  

1. Expand the Oracle node in the Database system connection 
information area and select 10. 

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and then click Next.   
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Select the business objects and services to be used with the adapter  
Follow these steps to select the data for outbound Processing: 

1. In the Object Discovery and Selection screen, click Edit Query.  
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2. In the Specify the Query Properties window, select the Create batch 
SQL business object... check box and accept the default value for 
the Number of batch SQL business objects to be created field. 
Click OK. 
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3. In the Find Objects in Enterprise System window, click Run Query.  

4. Expand the Batch SQL Statements node. 
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5. Select Batch SQL Statement1 and click . 

6. In the Specify the Configuration Properties for Batch SQL window, 
specify the following details:  

a) In the Batch SQL business object name field, enter 
TestBatchSQL. 

b) In the SQL Statements field, enter the following query: 
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Insert into customer values(?,?,?,?);update 
custinfo set cdata=? Where ccode=?;delete from 
customer where pkey=? 

 

7. Select the Generate Parameters check box. Parameter fields 
corresponding to each ‘?’ in the SQL Statements will be generated as 
shown in the figure below: 
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8. Select the parameter type and enter the sample value for each 
parameter in all the statements. 
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9. Click Validate. The validation result is displayed. Click OK. 
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10. The Batch SQL Statement1 will be listed in the Selected Objects. 
Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values for the all fields and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Other for security options under Deployment 
Properties.  

b) Clear the Join the global transaction check box.  

c) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

d) Enter OracleDS in the Connection pool DataSource 
JNDI Name field, and click Next. 
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3. In the Specify the Location Properties window, click New. 
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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5. In the Create a Module window, type JDBCBatchSQLTest in the 
Module Name field and click Finish. 
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6. Click Finish to complete service creation. 

7. Verify the results. 

 

Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) import. You 
must install this SCA module in the IBM Integration Designer 
integration test client.   

To do this, you must add the SCA module you created earlier to the 
server using the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects. 
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4. Add the SCA module to the server. 

181 



 

 

5. Click Finish. 

Test the assembled adapter application  
Test the assembled adapter application using the IBM Integration 
Designer integration test client.    

1. Select the JDBCBatchSQLTest module, right-click, and select Test 
> Test Module. 
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2. Populate data for parameters as shown in the figure below. 

 

3. To execute the service, click Continue . 

4. In the Select a Deployment location window, select the server and 
click Finish. 
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5. Check the output of the service, and check the data in the Enterprise 
Information System to ensure it matches the expected values.   

 

Clear the sample content 
After you have tested the application, clear the sample content to 
return the data to its original state.  
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C h a p t e r  6 .  Tutorial 5: Receiving events from the 
Enterprise Information System (Oracle) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
polls the inbound events from the database table. 

About this task 

In this scenario, a legacy application makes a change to the 
CUSTOMER table in a single operation. Here we will insert an event 
record into the event table (WBIA_EVENT_TABLE). The JDBC adapter 
will poll the events from the database periodically. If a new event 
found, it will fetch the event and corresponding business objects from 
database. Finally, the JDBC adapter will convert the event to a SDO 
and send it to the destination SCA component. 

The following figure represents the whole scenario: 
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Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedures 

• Create an authentication alias 

• Create a data source 

Create tables and stored procedures 

You must create the following tables and stored procedures in the 
Oracle database before starting the scenario.  
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a. Script for creating the tables 

CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 
 
CREATE SEQUENCE EVENT_SEQ INCREMENT BY 1 START WITH 
1 MINVALUE 1 CACHE 20 ; 
 
CREATE TABLE WBIA_JDBC_EVENTSTORE 
( 
 EVENT_ID INTEGER NOT NULL  PRIMARY KEY, 
 XID    VARCHAR2(200), 
 OBJECT_KEY   VARCHAR2(80)  NOT NULL, 
 OBJECT_NAME  VARCHAR2(40)  NOT NULL, 
 OBJECT_FUNCTION  VARCHAR2(40)  NOT NULL, 
 EVENT_PRIORITY      INTEGER   NOT NULL, 
 EVENT_TIME   TIMESTAMP,   
 EVENT_STATUS  INTEGER   NOT NULL, 

EVENT_TIMEOUT TIMESTAMP, 
CONNECTOR_ID            VARCHAR2(40), 

 EVENT_COMMENT  VARCHAR2(100) 
); 
 

b. Script for creating triggers for Inbound  
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CREATE OR REPLACE TRIGGER EVENT_CREATE AFTER INSERT 
ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name,object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:N.pkey, 
'SampleCustomerBG', 'Create', 1, 0); 
END; 
/ 
 
CREATE OR REPLACE TRIGGER EVENT_DELETE AFTER DELETE 
ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name,object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:O.pkey, 
'SampleCustomerBG', 'Delete', 1, 0); 
END; 
/ 
 
CREATE OR REPLACE TRIGGER EVENT_UPDATE AFTER UPDATE 
OF PKEY,  CCODE,  FNAME, LNAME ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name, object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:N.pkey, 
'SampleCustomerBG', 'Update', 1, 0); 
  END; 
/ 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  

 

5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  
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7. Click New to create a new authentication entry. Type the alias 
name, and username and password to connect to the database. Click 
OK. 
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8. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the data source.  
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Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source is used later when 
generating the artifacts for the module.  

Note: This tutorial uses Oracle as the database and the Oracle thin 
driver, ojdbc6.jar. 

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right page, select ORACLE_JDBC_DRIVER_PATH and 
specify the path of the ojdbc6.jar file in the Value field. Click OK. 
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3. Click Save to save the changes. 

 

The variable has been added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 

 

5. Click New in the JDBC providers window. 
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6. Select an Oracle database with a connection pool data source for the 
Oracle JDBC driver. Click Next. 
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7. In the Enter database classpath information page, enter the 
following value for the Class path field: 

$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

8. Click Next. 
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9. In the Summary page, click Finish. 

 

10. Click Save. 
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The JDBC provider is added and appears in the list. 

 

11. Select the Oracle JDBC provider you just created. Under Additional 
Properties, click Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the 
authentication alias. Click Next. 

 

13. Provide the appropriate URL value and select a data store helper 
class name from the Data store helper class name list as shown in 
the following figure. Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias field and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the data source you just created and click Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database. 

 

Configure the adapter for inbound processing  
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Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 

 

4. Select IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC. 

6. In the Target runtime environment field, select the appropriate 
runtime and click Next. 
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7. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Inbound and click Next. 

 

Set connection properties for the external service wizard 
To connect to the Oracle database:  

1. Expand the Oracle node in the Database system connection 
information area and then select 10. 

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   

212 



 

 

Select the business objects and services to be used with the adapter  
Follow these steps to select the data for Inbound processing: 

1. In the Find Objects in Enterprise System window, click Run Query.  

213 



 

 

2. Expand the SAMPLE (for this tutorial only) node, select Tables and 
expand it. 
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3. Select the CUSTOMER table and click .   

4. Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Using security properties from the activation 
specification as the section option.  

b) Select Specify predefined DataSource from the 
Database connection information list.  

c) Click Advanced.  
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d) In the Even Configuration area, enter the values for the 
Event Order By, Event Table Name fields and click 
Next.  
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3. In the Specify the location Properties window, click New. 
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 

 

5. In the Create a Module window, type JDBCInboundTest in the 
Module Name field and click Finish. 
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6. Click Finish to complete service creation. 

7. Verify the results. 

 

Set up the components to be part of the Inbound environment 
Add the components and set transaction specific properties for them so 
that they are part of the inbound environment.  
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1. In the Business Integration view, double click JDBCInboundTest > 
Assembly Diagram to open the Assembly Diagram. 

 

2. From the Palette, select the Java component and drop it on the 
assembly diagram. 
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A component named Component1 is created in the Assembly 
diagram.  
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3. Wire JDBCInboundInterface to Component1 by dragging the 
mouse pointer from the rear end of JDBCInboundInterface to the 
front end of Component1. 

 

Note: Before the preceding window, i.e., before wiring you will see the 
following window. Click OK. 
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4. Generate the implementation for Java component. Right-click the 
component, and select Generate Implementation to complete the 
service creation.  
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5. Highlight the default package and select OK. 

The Java Editor displays the Component1Impl.java file. 

 

6. Scroll down and locate the createSampleCustomer(DataObject 
createSampleCustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 

 

7. Scroll down and locate the updateSampleCustomer(DataObject 
updateSampleCustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 
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8. Scroll down and locate the deleteSampleCustomer(DataObject 
deleteSampleCustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 

 

9. Select File -> Save to save your changes.   

10. Close and save the Assembly Diagram. Wait for the workspace to 
complete building. 
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Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) export. You 
must install this SCA module in the IBM Integration Designer 
integration test client. To do this, you must add the SCA module you 
created earlier to the server using the Servers view in IBM Integration 
Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

4. Add the SCA module to the server. 

5. Click Finish. 
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Test the assembled adapter application  
Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

  

1. In the Business Integration view right-click on the JDBCInboundTest 
module, and select Test > Attach.  
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2. To execute the service, click . 

3. Insert a record into the Customer table:  

INSERT INTO CUSTOMER (pkey,ccode,fname,lname) 
values('Test', 'ANITA','MEHTA','IBM'); 

4. Check the output of the service: 
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5. Update an existing record in the Customer table: 

UPDATE CUSTOMER SET fname='ABC', lname='XYZ', 
ccode='' WHERE pkey='Test'; 

6. Check the output of the service: 
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Clear the sample content 
After you have tested the application, clear the sample content to 
return the data to its original state.  
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C h a p t e r  7 .  Tutorial 6: Executing a business object 
created from a stored procedure (DB2) 

This scenario demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
interacts with database stored procedure business object. 

About this task 

In this scenario, a SCA component invokes the ‘Execute’ operation of JDBC 
adapter Outbound Interface. The adapter invokes a stored procedure defined 
in the target database, and returns the execution result to the SCA 
component. 

The following figure represents this scenario: 

 

Prepare to run through the tutorial 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedure 

• Create an authentication alias 

Create tables and stored procedure 

You must create the following tables and stored procedure in the DB2 
database before starting the scenario. 

a. Script for creating the Customer and Address tables 
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CREATE TABLE CUSTOMER  ( 
    "PKEY" VARCHAR(10) NOT NULL PRIMARY KEY,  
    "FNAME" VARCHAR(20) ,  
    "LNAME" VARCHAR(20) ,  
    "CCODE" VARCHAR(10) ) ; 
 
CREATE TABLE ADDRESS  ( 
    "ADDRID" VARCHAR(10) NOT NULL PRIMARY KEY,  
    "CUSTID" VARCHAR(10) ,  
    "CITY" VARCHAR(20) ,  
    "ZIPCODE" VARCHAR(10) ) ; 

b. Scripts for inserting records to the two tables 

INSERT INTO CUSTOMER VALUES ('100', 'fname1', 
'lname1', 'IBM'); 
INSERT INTO CUSTOMER VALUES ('300', 'abc', 'xyz', 
'IBM'); 
INSERT INTO ADDRESS VALUES ('100', '100', 'cxxx', 
'xxxx'); 
INSERT INTO ADDRESS VALUES ('120', '100', 'city1', 
'zipcode1'); 

c. Scripts for creating the stored procedure 

The stored procedure can be created using the DB2 Development 
Center or IBM Integration Designer. 

CREATE PROCEDURE CustAddrSP (  ) 
 SPECIFIC CustAddrSP 
 DYNAMIC RESULT SETS 1 
--------------------------------------------------
---------------------- 
-- SQL Stored Procedure  
--------------------------------------------------
---------------------- 
P1: BEGIN 
 -- Declare cursor 
 DECLARE cursor1 CURSOR WITH RETURN FOR 
  SELECT CUSTOMER.FNAME, CUSTOMER.LNAME, 
ADDRESS.CITY, ADDRESS.ZIPCODE 
    FROM ADDRESS JOIN CUSTOMER ON ADDRESS.CUSTID 
= CUSTOMER.PKEY 
    ORDER BY ADDRESS.ZIPCODE ASC; 
 
 -- Cursor left open for client application 
 OPEN cursor1; 
END P1 

Create an authentication alias 

The authentication alias needs to be set because the adapter uses the 
username and password set in the authentication alias to connect to 
the database. This authentication alias will be used later when 
generating the artifacts for the module. 

Here are the steps to set the authentication alias in IBM Process Server 
administration console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 

237 



 

 

4. Log on to the administrative console.  
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5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed. 

 

7. Click New to create a new authentication entry. Type the alias name, 
and a username and password that can connect to the database. 
Click OK. 
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8. Click Save to save the changes. 

 

Note: You have created an authentication alias that will be used when 
you configure the adapter properties. Re-start the server for the 
changes to take effect. 

Configure the adapter for outbound processing  

1. Switch to the Business Integration perspective in IBM Integration 
Designer. 

2. Select File->New->Module to create a module project. 
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3. Specify the module name as Tutorial6, and click Finish. 

 

4. Expand Tutorial6 and select displayed. Right-click and select 
New->External Service. 
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5. Select JDBC, and click Next.  

 

6. Select IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0).  Click 
Next. 
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7. In the Target Runtime environment field, select the appropriate 
runtime and click Next. 

 

8. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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9. Select Outbound and click Next. 
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Set connection properties for the external service wizard  
To connect to the database: 

1. Expand the DB2 node in the Database system connection 
information area and select appropriate version, 

2. Enter values in the Database, Host name, Port number, User name 
and Password fields, and click Next. 
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Select the business objects and services to be used with the adapter 
1. In the Find Object in the Enterprise System window, click Run 

Query. 

2. Select DB2ADMIN->Stored Procedures->CUSTADDRSP, and 

click . 
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3. In the The maximum number of ResultSets returned from the 
stored procedure field, enter 1. Click Validate. After successful 
validation, click OK. 
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4. Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values for the all fields and click Next. 

 

2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) In the J2C authentication data entry field, enter  
Alias_DB2.  

b) disable the Join the global transaction check box.  

c) Select Specify local database connection information 
from the Database connection information list and 
click Next. 
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3. In the Specify the Location Properties window, click Finish to 
complete the service creation. 
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4. Verify the results.  
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Deploy the module to the test environment 

The result of running the external service wizard is an SCA module that 
contains an Enterprise Information System import. Install this SCA 
module in the IBM Integration Designer integration test client. To do 
this, you must add the SCA module you created earlier to the server 
using the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

4. In the Add and Remove Projects window, select the module created 
earlier and click Add. The project moves to the Configured Projects 
list from the Available Projects list. 
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5. Click Finish. This deploys the project on the server. For 
troubleshooting issues while adding the project, see the 
Troubleshooting section. The Console tab in the lower-right pane 
displays a log while the module is being added to the server. 
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Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration 
Designer integration test client:  

1. From the Business Integration view, right click on Tutorial6 and select 
Test > Test Module. 

2. Leave all fields in the test client as default. 

 

 

3. Execute the service by click .  

4. In the Select Deployment Location window as shown below, select 
the server, and click Finish.  
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5. If the deployment and execution of the test module is successful, the 
result set should return the expected records that reflect the 
conditions stipulated in the stored procedure. 
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C h a p t e r  8 .  Tutorial 7: Sending data to the DB2 
database within XA Transaction (outbound 
processing)  

This scenario demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
participates in a global transaction using XA a data source for DB2 
database. 

About this task 

In this scenario, we will create a Java component and a JDBC adapter 
import component. The Java component invokes JDBC adapter to 
make changes to the database. Both the java component and JDBC 
adapter will participate in the same global transaction. 

The following figure represents this scenario: 
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Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct.  

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create a table 

• Create an authentication alias 

• Create a data source 

Create a table 

You must create the following table in the DB2 database before starting the 
scenario. 

Script for creating the CUSTOMER table 

 CREATE TABLE CUSTOMER  ( 
    "PKEY" INTEGER NOT NULL PRIMARY KEY,  
    "FNAME" VARCHAR(20) ,  
    "LNAME" VARCHAR(20) ,  
    "CCODE" VARCHAR(10) ) ; 

Create an authentication alias 

The authentication alias needs to be set because the adapter uses the 
username and password set in the authentication alias to connect to 
the database. This authentication alias will be used later when 
generating the artifacts for the module.  

Here are the steps to set the authentication alias in IBM Process Server 
administration console. 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start, and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console by entering the username and 
password (if required).  
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5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias name 
and a username and password that can connect to the database, as 
shown in the figure. Click OK. 
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8. Click Save to save the changes. 

 

Create a data source 

1. In administrative console, select Resources->JDBC->JDBC 
Providers. 
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2. On the right, select Node=nlNode01 from the drop-down list, and 
click New. 
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3. Select the following values for the Database type, Provider type, 
and Implementation type fields. Click Next. 

Field Value 
Database type DB2 
Provider type DB2 Universal JDBC Driver Provider 
Implementation type XA data source 
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4. Enter the absolute path of the JDBC drivers (db2jcc.jar, 
db2jcc_license_cu.jar, db2jcc_license_cisuz.jar) directory. 
Click Next. 

268 



 

 

5. Click Finish. 

 

6. Click the JDBC Provider that you just created. 
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7. Click Data sources, under Additional Properties. 

 

8. Click New. 
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9. Enter jdbc/DB2XADS for JNDI name. 

10. Under Component-managed authentication alias and XA 
recovery authentication alias, select the name of the 
authentication alias you previously created from the drop-down list.  
Click Next. 

 

11. Enter the values below for Database name and Server name.  
Click Next. 
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12. Click Finish. 

 

13. In the Messages area, click Save.  This will save changes made to 
the local configuration onto the master configuration. 
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14. Select the check box next to the Data source you just created. Click 
Test Connection. 

 

The connection test should succeed as indicated by the message shown 
in the figure below. For troubleshooting issues while testing the 
connection, see the Troubleshooting section. 
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15. Close the Administrative Console tab. 

Configure the adapter for outbound processing  
Run the external service wizard to specify business objects, services, and 
configuration details. 

1. Switch to the Business Integration perspective in IBM Integration Designer. 

2. Select File->New->Module to create a Module project. 

 

3. Specify the module name as JDBCXADB2, and click Finish. 
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4. Right-click JDBCXADB2, select New->External Service. 

 

5. Select JDBC, and click Next. 
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6. Select IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0).  Click Next. 

 

7. In the Target Runtime environment field, select the appropriate runtime 
and click Next. 
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8. Click Add to add the JDBC driver jar to the class path, and click Next. 
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9. Select Outbound and click Next. 
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Set connection properties for the external service wizard 

To connect to the database:  

1. Expand the DB2 node in the Database system connection information 
area and select appropriate version, 

2. Enter values in the Database, Host name, Port number, User name and 
Password fields, and click Next. 
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Select the business objects and services to be used with the adapter 
1. Click Run Query to list the tables, stored procedures, views, and 

synonyms for each schema in the database. 

2. Select DB2ADMIN->Tables-> CUSTOMER and click the > (Add). 
The CUSTOMER table is added to the Selected objects list. 

280 



 

 

3. Click Next. 
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Generate business object definitions and related artifacts 
1. In the Specify Composite Properties window, accept the default settings and 

click Next. 
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2. Select the security credential type as Other. Specify the XA DataSource 
JNDI name property as jdbc/DB2XADS. Click Next. 
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3. Click Finish. 

284 



 

 

Verify the results shown below. 
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Set up the components to be part of the XA environment 
1. In the Business Integration tab, under JDBCXADB2 double-click 

Assembly Diagram to open it. 

2. In the Palette, expand Components and drag Untyped Component to 
Assembly Diagram editor, and name it as Component1.        
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3. Wire Component1 to JDBCOutboundInterface. In the Add Wire message 
window, click OK.  

 

4. Right-click Component1 and select Add > Interface. 
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5. In the Add Interface window, click New. 
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6. Enter CustomerInterface in the Name field. Click Finish.  
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7. Click  to add a new operation for CustomerInterface interface. 
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8. Rename the operation name to invoke. Click Type for Inputs parameter, 
and select New. 
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9. In the New Business Object window, enter Source in the Name field.  
Click Next. 

 

10. From the list of Available business objects, select the 
Db2adminCustomer to add all of the Customer business objects's 
attributes to the Source business object. Click Finish. 
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11. In the Business Object editor, click  to add three new fields for Source 
business object.  

 

12. Then rename these three new fields as operation, objectName and 
namespace.  
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13. Select File->Save All to save all the changes. 

14. Right click on Component1 in the Assembly Diagram and select Generate 
implementation... -> Java. 

 

15. In the Generate Implementation window, select default package and 
click OK. 

16. In the text editor of Component1Impl.java file, add the following imports.  
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17. Add the following implementation for invoke() method. 

public String invoke(DataObject input1) throws 
BusinessObjectDefinitionNotFoundException { 
   
  String objName = 
input1.getString("objectName"); 
  String namespace = 
input1.getString("namespace"); 
  DataObject customerBO = 
SDOFactory.createDataObject(namespace, objName); 
  DataObject customerBG = 
customerBO.getContainer(); 
 
  customerBO.setString("pkey", 
input1.getString("pkey")); 
  customerBO.setString("fname", 
input1.getString("fname")); 
  customerBO.setString("lname", 
input1.getString("lname")); 
  customerBO.setString("ccode", 
input1.getString("ccode")); 
  
  String op = input1.getString("operation"); 
  
  String operation = 
op.toLowerCase()+customerBG.getType().getName(); 
   
 locateService_JDBCOutboundInterfacePartner().in
voke(operation, customerBG); 
   
  return "Success"; 
 } 

18. Select File > Save All to save all the changes.  

295 



 

 

Deploy the module to the test environment 
The result of running the external service wizard is an SCA module that 
contains an Enterprise Information System import. Install this SCA 
module in IBM Integration Designer integration test client. To do this, 
you must add the SCA module you created earlier to the server using 
the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

2. In the Servers tab in the lower-right pane of the IBM Integration 
Designer screen, right-click the server, and select Start. 
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3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

4. In the Add and Remove Projects window, select the module created 
earlier and click Add. The project is added to the Configured 
Projects list from the Available Projects list. 

 

5. Click Finish. This deploys the project on the server. For 
troubleshooting issues while adding the project, see the 
Troubleshooting section. The Console tab in the lower-right pane 
displays a log while the module is being added to the server. 
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Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration 
Designer integration test client:  

1. From the Business Integration view, right click on JDBCXADB2 and 
select Test > Test Module. 

 

2. From the Component list, select Component1. Specify the parameters 
as shown in the figure below.  
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Note: Set the operation value to Create; set the objectName value 
to Db2adminCustomerBG; set the namespace value to 
http://www.ibm.com/xmlns/prod/websphere/j2ca/jdbc/db
2admincustomerbg. 

3. Click   to continue. 

 

4. In the Select Deployment Location window, select your server, and click 
Finish. 
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5. Once the service is executed successfully, the customer record will be 
created in the target database. To verify the result, connect to the 
database and run the following SQL query:   

SELECT * FROM CUSTOMER WHERE pkey = '300';  

Clear the sample content 
Return the data to its original state by deleting the Customer record 
you created in the CUSTOMER table by connecting to the database and 
running the SQL query:   

DELETE FROM CUSTOMER WHERE pkey = '300';  
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C h a p t e r  9 .  Tutorial 8: Sending data to the Oracle 
database with XA transaction (outbound 
processing) 

This scenario demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
participates in a global transaction using a XA data source for Oracle 
database. 

About this task 

In this scenario, we will create a Java component and a JDBC adapter 
import component. The Java component invokes JDBC adapter to 
make changes to the database. Both, the java component and JDBC 
adapter will participate in the same global transaction. 

The following figure illustrates the scenario: 
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Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct.  

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create a table 

• Create an authentication alias 

• Create a data source 

Create a table 

You must create the following table in the Oracle database before starting the 
scenario. 

Script for creating the CUSTOMER table: 

 CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  
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5. Click Security  Global security 

 

6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  
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7. Click New to create a new authentication entry. Type the alias name 
and a username and password that can connect to the database, as 
shown in the figure. Click OK. 
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8. Click Save to save the changes. 

 

We have created an authentication alias that will be used to configure 
the data source.  
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Create a data source 

1. Click Resources > JDBC > JDBC Providers. 
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2. On the right, select Node=nlNode01 from the drop-down list. 
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3. Click New in the JDBC providers window. 

 

4. Specify the for the Database type, Provider type, and 
Implementation type fields as shown in the figure below.  Click 
Next. 

 

5. Enter the absolute path of the JDBC driver (ojdbc6.jar) directory. 
Click Next. 
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6. Click Finish. 

 

7. Click the JDBC Provider that you just created. 
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8. Click Data sources, under Additional Properties. 

 

9. Click New. 
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10. Enter jdbc/OracleXADS for JNDI name. 

11. Under Component-managed authentication alias and XA 
recovery authentication alias, select the name of the 
authentication alias you previously created from the drop-down list.  
Click Next. 
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12. Enter the URL to connect to the database in the URL field.  Click 
Next. 

 

13. Click Finish. 

 

14. In the Messages area, click on Save link.  This will save changes 
made to the local configuration onto the master configuration. 
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15. Select the check box next to the Data source you just created.  Click 
Test Connection. 

 

16. The connection test should succeed as indicated by the message 
shown in the figure below. For troubleshooting issues while testing 
the connection, see the Troubleshooting section. 
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17. Close the Administration Console tab. 

Configure the adapter for outbound processing  
Run the external service wizard to specify business objects, services, 
and configuration details. 

Set connection properties for the external service wizard 
1. Switch to the Business Integration perspective in IBM Integration 

Designer. 

2. Select File->New->Module to create a Module project. 

 

3. Specify the module name as JDBCXAOracle, click Finish. 
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4. Right-click JDBCXAOracle->Assembly Diagram, select 
New->External Service. 

 

5. Select JDBC, and click Next. 
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6. Select IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0).  Click 
Next. 

 

7. In the Target Runtime environment field, select the appropriate 
runtime and click Next.  
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8. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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9. Click the Outbound radio button.  Click Next. 
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10. Expand the Oracle node in the Database system connection 
information area and then select 10. 

11. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   
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12. Click Run Query to list the tables, stored procedures, views, and 
synonyms for each schema in the database. 
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13. Expand the schema name in which you created the CUSTOMER table.  
Select Tables > CUSTOMER and click the > (Add). The CUSTOMER 
table is added to the Selected objects list.  
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14. Click Next. 

325 



 

 

15. In the Specify Composite Properties window, click Next. 
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16. In Specify the Service Generation and Deployment Properties 
area, select Other. In the XA DataSource JNDI name field enter 
jdbc/OracleXADS. Click Next. 
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17.  In Specify the Location Properties window, click Finish. 
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18. Verify the results shown below. 
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Set up the components to be part of the XA environment 
1. In the Business Integration tab, under JDBCXAOracle double-click 

Assembly Diagram to open it. 

2. In the Palette, expand Components and drag Untyped 
Component to Assembly Diagram editor, and name it as 
Component1.        
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3. Wire Component1 to JDBCOutboundInterface. In the Add Wire 
window,  click OK.  

 

4. Right-click Component1 and select Add > Interface. 

 

5. In the Add Interface window, click New. 
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6. Enter CustomerInterface in the Name field. Click Finish.  
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7. Click  to add a new operation for CustomerInterface interface. 

 

8. Rename the operation name to invoke. Select "Type" for the Inputs 
parameter, and select New. 

 

9. In the Create a Business Object window, enter Source in the Name 
field.  Click Next. 
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10. From the list of Available business objects, select 
SampleCustomer to add all Customer business objects's attributes 
to the Source business object. Click Finish. 

 

11. In the Business Object editor, click  to add three new fields for 
Source business object.  
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12. Rename the three new fields as operation, objectName and 
namespace.  

 

13. Select File->Save All to save all the changes. 

14. Right click Component1 in the Assembly Diagram and select 
Generate implementation -> Java. 
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15. In the Generate Implementation window, select default package 
and click OK. 

16. Open the Component1Impl.java file in the editor and add the imports 
as shown in the figure below.  

 

17. Add the following implementation for invoke() method. 
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public String invoke(DataObject input1) throws 
BusinessObjectDefinitionNotFoundException { 
   
  String objName = 
input1.getString("objectName"); 
  String namespace = 
input1.getString("namespace"); 
  DataObject customerBO = 
SDOFactory.createDataObject(namespace, objName); 
  DataObject customerBG = 
customerBO.getContainer(); 
 
  customerBO.setString("pkey", 
input1.getString("pkey")); 
  customerBO.setString("fname", 
input1.getString("fname")); 
  customerBO.setString("lname", 
input1.getString("lname")); 
  customerBO.setString("ccode", 
input1.getString("ccode")); 
  
  String op = input1.getString("operation"); 
  
  String operation = 
op.toLowerCase()+customerBG.getType().getName(); 
   
 locateService_JDBCOutboundInterfacePartner().in
voke(operation, customerBG); 
   
  return "Success"; 
 } 

18. Select File > Save All to save all the changes. 
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Deploy the module to the test environment 
The result of running the external service wizard is an SCA module that 
contains an Enterprise Information System import. Install this SCA 
module in IBM Integration Designer integration test client. To do this, 
you must add the SCA module you created earlier to the server using 
the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 
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2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

4. Add JDBCXAOracleApp into the Configured projects panel. Click 
Finish. 

 

5. Click Finish. This deploys the project on the server. For 
troubleshooting issues while adding the project, see the 
Troubleshooting section. The Console tab in the lower-right pane 
displays a log while the module is being added to the server. 
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Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration 
Designer integration test client:  

1. From the Business Integration view, right click JDBCXAOracle and 
select Test > Test Module. 

 

2. From the Component list, select Component1.  Specify the 
parameters as shown below. 
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Note: Set the operation value to Create; set the objectName value 
to SampleCustomerBG; set the namespace value to 
http://www.ibm.com/xmlns/prod/websphere/j2ca/jdbc/Sa
mplecustomerbg. 

3. Click   to continue. 

 

4. In the Select Deployment Location window, select the server, and 
click Finish. 
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6. After the service is executed successfully, the customer record will be 
created in the target database. To verify the result, connect to the 
database and run the following SQL query:   

SELECT * FROM CUSTOMER WHERE pkey = '300';  

Clear the sample content 
Return the data to its original state by deleting the Customer record 
you created in the CUSTOMER table by connecting to the database and 
running the SQL query:   

DELETE FROM CUSTOMER WHERE pkey = '300';   

342 



 

C h a p t e r  1 0 .  Tutorial 9: Receiving events from the 
Oracle database using data source with 
prepared statement cache (inbound 
processing) 

This tutorial demonstrates how the WebSphere Adapter for JDBC 
7.5.0.0 receives events from the Oracle database using a data source 
with a prepared statement cache. WebSphere JDBC adapter interact 
with database by polling database event from an event table. 

About this task 

In this scenario, a legacy application makes a change to the 
CUSTOMER table in a single operation. Here we will insert an event 
record into the event table (WBIA_EVENT_TABLE). The JDBC adapter 
will poll the events from the database periodically. If a new event is 
found, it will fetch the event and corresponding business objects from 
database. Finally, the JDBC adapter will convert the event to a SDO 
and send it to the destination SCA component.  

The following figure shows the whole scenario: 

 

Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 
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Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedures 

• Create an authentication alias 

• Create a data source 

Create tables and stored procedures 

You must create the following tables and stored procedures in the Oracle 
database before starting the scenario. 

a. Script for creating the tables 

CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20),  
    LNAME VARCHAR(20) ,  
    CCODE VARCHAR2(10) ) ; 

 

CREATE SEQUENCE EVENT_SEQ INCREMENT BY 1 START WITH 
1 MINVALUE 1 CACHE 20 ; 

 

CREATE TABLE wbia_jdbc_eventstore 
( 
 event_id     NUMBER(20) PRIMARY KEY, 
 xid   VARCHAR2(200), 
 object_key    VARCHAR2(80) NOT NULL, 
 object_name  VARCHAR2(40) NOT NULL, 
 object_function  VARCHAR2(40) NOT NULL, 
 event_priority     NUMBER(5) NOT NULL, 
 event_time   DATE DEFAULT SYSDATE NOT NULL,
    
 event_status   NUMBER(5) NOT NULL, 
 event_timeout TIMESTAMP, 
 connector_ID            VARCHAR2(40), 
 event_comment VARCHAR2(100) 
); 

b. Script for creating triggers for Inbound  
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CREATE OR REPLACE TRIGGER EVENT_CREATE AFTER INSERT 
ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name,object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:N.pkey, 
'SampleCustomerBG', 'Create', 1, 0); 
END; 
/ 
 
CREATE OR REPLACE TRIGGER EVENT_DELETE AFTER DELETE 
ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name,object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:O.pkey, 
'SampleCustomerBG', 'Delete', 1, 0); 
END; 
/ 
 
CREATE OR REPLACE TRIGGER EVENT_UPDATE AFTER UPDATE 
OF PKEY,  CCODE,  FNAME, LNAME ON CUSTOMER  
REFERENCING OLD AS O NEW AS N  
FOR EACH ROW  
BEGIN 
INSERT INTO wbia_jdbc_eventstore (event_id, 
object_key, object_name, object_function, 
event_priority, event_status) 
VALUES (event_seq.nextval,:N.pkey, 
'SampleCustomerBG', 'Update', 1, 0); 
  END; 
/ 

c. Script for inserting data into the CUSTOMER table  

CREATE OR REPLACE PROCEDURE INSERTCUSTRECORDS AS 
BEGIN 
  FOR cntr in 1..100 LOOP 
INSERT INTO CUSTOMER (pkey,ccode,fname,lname) 
values(to_char(cntr), 'ANITA','MEHTA','IBM'); 
 End Loop;        
END; 

Note:  After running this procedure, verify whether the records are 
inserted correctly into the WBIA_JDBC_EVENTSTORE table. 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  
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1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  
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5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 

 

A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias 
name, and username and password to connect to the database. Click 
OK. 
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8. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the data source.  
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Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source is used later when 
generating the artifacts for the module.  

Note: This tutorial uses Oracle as the database and the Oracle thin 
driver, ojdbc6.jar. 

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right page, select ORACLE_JDBC_DRIVER_PATH and 
specify the path of the ojdbc6.jar file in the Value field. Click OK. 
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3. Click Save to save the changes. 

 

The variable has been added and appears in the list.  

 

4. Select Resources  JDBC -> JDBC Providers. 
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5. Click New in the JDBC providers window. 
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6. Select an Oracle database with a connection pool data source for the 
Oracle JDBC driver. Click Next. 
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7. In the Enter database classpath information page, enter the following 
value for the Class path field: 

$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

8. Click Next. 

356 



 

 

9. In the Summary page, click Finish. 

 

10. Click Save. 

357 



 

 

The JDBC provider is added and appears in the list. 

 

11. Select the Oracle JDBC provider you just created. Under Additional 
Properties, click Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias field and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the data source you just created and click Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database. 

Configure data source statement cache 
1. Click the data source you just created. 
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2. On the right, under Additional Properties click WebSphere 
Application Server data source properties. 

 

3. In the Statement cache size field, enter the value 20. Click OK. 

 

4. In the Messages area, click Save. 

 

5. Select the data source you just created and click Test Connection. 
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The connection test should succeed as indicated by the message 
shown in the figure below. For troubleshooting issues while testing the 
connection, see the Troubleshooting section. 

 

6. Close the Admin Console tab. 

Configure the adapter for inbound processing  
Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 
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4. Select IBM WebSphere Adapter for JDBC and click Next. 

 

5. In the Connector project field, enter CWYBC_JDBC. 

366 



 

6. In the Target runtime environment field, select appropriate 
runtime and click Next. 
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7. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Inbound and click Next. 

 

Set connection properties for the external service wizard 
To connect to the Oracle database:  

1. Expand the Oracle node in the Database system connection 
information area, and then select 10. 

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   
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Select the business objects and services to be used with the adapter  
Follow these steps to select the data for Inbound Processing: 

1. In the Find Objects in Enterprise System window, click Run Query.  
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2. Expand the SAMPLE (for this tutorial only) node, select Tables and 
expand it. 

371 



 

 

3. Select the CUSTOMER table and click .   

4. Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Using security properties from the managed 
connection factory. 

b) Select Specify predefined DataSource from the 
Database connection information list and input the 
preconfigured JNDI name of oracle data source in 
DataSource JNDI name. 

c) Click Advanced.  
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d) In the Even Configuration area, enter the values for the 
Event Order By, Event Table Name fields and click 
Next. 
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3. In the Specify the location Properties window, click New. 
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 

 

5. In the Create a Module window, type JDBCInboundTest in the 
Module Name field and click Finish. 
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6. Click Finish to complete service creation. 

7. Verify the results. 

 

 

Set up the components to be part of the inbound environment 
Add the components and set transaction specific properties for them so 
that they are part of the inbound environment.  
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1. Open the Assembly Diagram. It shows the JDBCInboundInterface 
that was generated when the artifacts were created. 

 

 

2. From the Palette, select the Java component and drop it on the 
assembly diagram. 
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A component named Component1 is created in the Assembly 
diagram.  
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3. Wire JDBCInboundInterface to Component1 by dragging the 
mouse pointer from the rear end of JDBCInboundInterface to the 
front end of Component1. 

 

Note: Before the preceding window, i.e., before wiring you will see the 
following window. Click OK. 

 

The Assembly diagram now looks like the figure below. 
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4. Generate the implementation for Java component. Right-click the 
component, and select Generate Implementation to complete 
service creation.  

 

 

5. Highlight the default package and select OK. 

The Java Editor displays the Component1Impl.java file. 
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6. Scroll down and locate the createSample1Customer(DataObject 
createSample1CustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 

 

7. Scroll down and locate the updateSample1Customer(DataObject 
updateSample1CustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 
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8. Scroll down and locate the deleteSample1Customer(DataObject 
deleteSample1CustomerBGInput) method that needs to be 
implemented. Write the code into the method so the complete 
method looks as follows: 

 

9. Select File -> Save to save your changes.   

10. Close and save the Assembly Diagram. Wait for the workspace to 
complete building. 
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Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) export. You 
must install this SCA module in the IBM Integration Designer 
integration test client.  To do this, you must add the SCA module you 
created earlier to the server using the Servers view in IBM Integration 
Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 

2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

 

4. Add the SCA module to the server. 
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5. Click Finish. 

Test the assembled adapter application  
Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

  

1. In the Business Integration view right-click on the JDBCInboundTest 
module, and select Test > Attach.  
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2. To execute the service, click . 

3. Execute the INSERTCUSTRECORDS stored procedure to insert 
records into the Customer table:  

BEGIN 
INSERTCUSTRECORDS(); 

END; 

4. Check the output of the service: 
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Clear the sample content 
Nothing is required to clean up after this tutorial. 
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C h a p t e r  1 1 .  Tutorial 10: Generate wrapper 
business objects (Oracle)  

Wrapper business object is a top-level business object in business 
object hierarchy and it used to relate unrelated child business objects. 
Wrapper object needs a minimum of two table business objects to 
wrap them together.  

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
generates wrapper business objects and creates record in tables using 
wrapper business objects. 

About this task 

In this scenario, an application SCA component raises a retrieve test 
request to the JDBC Outbound Interface. The JDBC adapter executes a 
SQL query to select all specific records back. Finally, the JDBC adapter 
converts the test result to a SDO and gives a response to the SCA 
component. The following figure represents this scenario: 

 

Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 
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Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create a table 

• Create an authentication alias 

• Create a data source 

Create a table 

You must create the following table in the Oracle database before starting the 
scenario. 

CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 
 
Insert a record into the table you just created. 
 
insert into customer values ('1000', 'testFname', 
'testLname', 'testCcode') 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Window > Show View > Servers. 
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2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  

 

5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication Data. 

 

A list of existing aliases is displayed.  
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7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 

 

You have created an authentication alias that will be used to configure 
the adapter properties.  
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Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source will be used in generating 
the artifacts for the module.  

Note: This tutorial will use Oracle as the database and the Oracle thin 
driver, ojdbc6.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
variables 

 

2. On the right, click ORACLE_JDBC_DRIVER_PATH and specify the 
path of the ojdbc6.jar file in the Value field. Click OK. 
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The variable is added and appears in the list.  

 

3. Select  Resources  JDBC -> JDBC Providers. 

 

397 



 

 

4. Click New in the JDBC providers window. 

 

5. Click New. Select the Oracle database with a connection pool data 
source for the Oracle JDBC driver. Click Next. 
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6. In the Enter database classpath information page, enter the following 
value for the Class path field: 

$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time. 
Because you have added the ojdbc6.jar file to this path, you must 
specify that path here.  

7. Click Next. 
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8. Click Finish. 

 

9. Under Additional Properties, select Data sources. Click New. 
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10. Type any value in the JNDI name field, and select the authentication 
alias “OracleDS” that you created earlier from the 
Component-managed authentication alias and XA recovery 
authentication alias list. Click Next. 

 

11. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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12. In the Setup security aliases window, configure the aliases. 

 

13.  In the Summary page, review the values entered for the data source 
and click Finish. 
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14.  Click Save to save the changes.  

 

15. Select the data source you just created and click Test connection. 

403 



 

 

The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database.  

Configure the adapter for outbound processing  

Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 
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4. Select IBM WebSphere Adapter for JDBC and click Next. 

 

5. In the Connector project field enter CWYBC_JDBC. 
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6. In the Target runtime environment field, select the appropriate 
runtime and click Next. 

 

7. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Outbound and click Next.   
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Set connection properties for the external service wizard 
To connect to the Oracle database:  

1. Expand the Oracle node in the Database system connection 
information area and select 10.  

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   
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Select the business objects and services to be used with the adapter  
Follow these steps to select the Customer and Address business 
object: 

1. In the Find Objects in Enterprise System window, click Run Query. 
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2. In the Discovered objects pane, select the SAMPLE (for this tutorial 
only) node, expand it and then select the Tables node and expand it. 

3. Select the CUSTOMER and CUSTADD tables and click  . 
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Note: Remember Wrapper business objects needs minimum two table 
objects. 

4. Click Next. The Specify Composite Properties window is displayed. 

5. In the Wrapper object names area, click Add. 
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6. In the Add Value window, specify the name for the wrapper. Enter 
Wrapper1 and click OK. 

 

Wrapper1 is added into the Wrapper object names area.  

7. In the Table, View or nickname child business objects for the 
selected wrapper object area, click Add to add child table business 
objects for the wrapper. 
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8. In the Add Value window, select CUSTADD and CUSTOMER tables and 
click OK. 

 

Both CUSTADD and CUSTOMER tables are added into child business 
objects for the selected wrapper object.  
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9. In the Service functions for the selected wrapper object area, 
click Add to add service functions to the wrapper. 

 

10. In the Add Value window, select the Create and click OK.   
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The selected service operation is added into the Service functions 
for the selected wrapper object area.  

11. Accept the default values for the other fields and click Next.  

Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Other for security options under Deployment 
Properties. Clear the Join the global transaction check 
box.  

b) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

c) Enter OracleDS in the Connection pool DataSource 
JNDI Name field, and click Next. 
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2. Click New in the Specify the Location Properties window.  

416 



 

 

3. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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4. In the Create a Module window, type TestWrapper in the Module 
Name field and click Finish. 
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5. In the Specify the Location Properties window, accept the default 
values for all fields and click Finish.  
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6. Open the Project Explorer and verify business objects are created 
correctly.  
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Deploy the module to the test environment 

After running the external service wizard, you will have an SCA module 
that contains an EIS import. You must install this SCA module in the 
IBM Integration Designer integration test client. To do this, you must 
add the SCA module you created earlier to the server using the 
Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 
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2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.    

. 

 

The Add and Remove Projects window lists the available projects in the 
IBM Integration Designer workspace. 
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4. Select your project (TestWrapperApp) and click Add to configure 
the project on the server and click Finish. 
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Test the assembled adapter application   

Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

1. Select the TestWrapper module, right-click, and select Test > Test 
Module. The Test Client window is displayed. 
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2. Select createWrapper1 from the Operation list and set "Create" as 
verb. Right-click custaddobj and select Add Elements. 
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3. Enter 1 and click OK. 

 

4. Enter the input values for custaddobj[0] as shown in the below figure.  

 

5. Now, right-click over customerobj and select Add Elements and 
enter 1 and click OK. 
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6. Enter the input values for customerobj[0] as shown in the below 
figure. 

 

7. To execute the service, click Continue .  

8. In the Select Deployment location window, select the server and click 
Finish. 
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9. Check the output of the service, and check the data in the enterprise 
information system (EIS) to ensure it matches the expected values.   
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Clear the sample content 

Return the data to its original state.   
Nothing is required to clean up after this tutorial. 
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C h a p t e r  1 2 .  Tutorial 11: Creating business 
objects for stored procedure and executing stored 
procedure with Execute operation (SQL Server) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
creates business object for stored procedure and execute the stored 
procedure with execute operation. It also demonstrates the support for 
result sets returned by stored procedure.  

About this task 

In this scenario, an application SCA component raises an execute 
request to the JDBC Outbound Interface. The JDBC adapter generates 
an execute SQL statement to call the corresponding stored procedure. 
The stored procedure executes its internal business logic and 
generates output. Finally, JDBC adapter generates response according 
to the execution status and the output of the stored procedure. The 
following figure represents this scenario: 
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Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables and stored procedure 

• Create an authentication alias 

• Create a data source 

Create tables and stored procedure 

You must create the following tables and stored procedure in the SQL 
Server database before starting the scenario.  

a. Script for creating the reference types 

Execute the below scripts to create CUSTOMER and ADDRESS tables. 

CREATE TABLE CUSTOMER ( 
    PKEY VARCHAR(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR(20) ,  
    LNAME VARCHAR(20) ,  
    CCODE VARCHAR(10) ) ; 

 

CREATE TABLE ADDRESS  ( 
    ADDRID VARCHAR(10) NOT NULL PRIMARY KEY,  
    CUSTID VARCHAR(10) ,  
    CITY VARCHAR(20) ,  
    ZIPCODE VARCHAR (10) ); 
 

Execute the below scripts to enter the following records in the customer table. 

 
INSERT INTO CUSTOMER VALUES ('100', 'fname1', 
'lname1', 'IBM'); 
     INSERT INTO CUSTOMER VALUES ('200', 'fname2', 
'lname2', 'IBM'); 

Execute the below scripts to enter the following records in the address 
table 
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INSERT INTO ADDRESS VALUES ('100', '100', 'test1', 
'12345'); 
INSERT INTO ADDRESS VALUES ('200', '200', 'test2', 
'12346'); 

b. Script for creating the stored procedure 

The stored procedure can be created using the SQL Server Client.  

Create a stored procedure that has one input string and one output 
string parameter, and returns two result sets. Stored Procedures in 
SQL Server Database always have return value. 

CREATE PROCEDURE PROCEDURE1 @var0 varchar(10), 
@var1 varchar(10) OUT 
AS 
      SELECT PKEY,LNAME,FNAME,CCODE FROM CUSTOMER; 
 SELECT ADDRID,CUSTID,CITY,ZIPCODE FROM ADDRESS; 
 Set @var1= @var0; 
 Return (@var1) 
GO 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 
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3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 

 

4. Log on to the administrative console.  

433 



 

 

5. Click Security  Global security. 
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6. Under Java Authentication and Authorization Service, click J2C 
authentication data. 
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A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 

 

8. Click Save to save the changes.  
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You have created an authentication alias that will be used to configure 
the data source. 

 

Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source is used later when 
generating the artifacts for the module.  

Note: This tutorial uses SQL Server as the database and the SQL 
Server JDBC driver sqljdbc.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
Variables. 

437 



 

 

2. On the right, select MICROSOFT_JDBC_DRIVER_PATH and 
specify the path of the sqljdbc.jar file in the Value field. Click OK. 
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3. Click Save to save the changes. 

 

The variable is added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 
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5. Click New in the JDBC providers window. 
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6. Select SQL Server database with a connection pool data source for 
the SQL Server JDBC driver. Click Next. 
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7. In the Enter database classpath information page, enter the following 
value for the Class path field: 
$(MICROSOFT_JDBC_DRIVER_PATH)/sqljdbc.jar, where 
$(MICROSOFT_JDBC_DRIVER_PATH) is library path for the run time. 

8. Click Next.  
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9. In the Summary page, click Finish.  

 

10. Click Save to save the changes. 
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The JDBC provider is added and appears in the list. 

 

11. Select the SQL Server JDBC provider you created. Under Additional 
Properties, click Data sources. Click New. 

445 



 

 

12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Provide the appropriate Database name, Port number, Server 
name value. Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias field and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the check box for the newly created data source and click 
Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 
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Note: The data source is created which will be used by the adapter to 
connect to the database.  

Configure the adapter for outbound processing  

Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and then 
click Next. 

 

4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC, and in the 
Target runtime environment field, select the appropriate runtime. 
Click Next. 
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6. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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7. Select Outbound and click Next. 

 

Set connection properties for the external service wizard 
 To connect to the SQL Server: 
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1. Expand the SQL Server node in the Database system connection 
information area and select 2005. 

2. Enter Database, Host name, Port number, User name and 
Password fields, and click Next. 

 

Select the business objects and services to be used with the adapter  
1. In the Find Objects in Enterprise System window, click Run Query. 
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2. Expand the dbo (for this tutorial only) node and select Stored 
Procedures and expand it. 

3. Select PROCEDURE1;1 and click .  
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4. Change the maximum number of resultsets to 2 and select String as 
data type for @RETURN_VALUE, @var0 and @var1. 
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5. Enter sample values for the stored procedure input types, which are 
@var0 and @var1 and click Validate to verify if the stored 
procedure executes successfully. Verify the result from the validation  
and click OK.  
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6. Make sure procedure1 is added to the selected objects list and click 
Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default values for 
all fields and click Next. 
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2. In the Specify the Service Generation and Deployment Properties window, 
select Other for security options under Deployment Properties.  

a) Clear the Join the global transaction check box.  

b) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

c) Enter SQLServerDS in the Connection pool 
DataSource JNDI Name field, and click Next. 
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3. Click New in the Specify the Location Properties window. 
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4. In the Select a Business Integration Project Type window, select Module 
and click Next. 
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5. In the Create a Module window, type TestExecuteSPSQLServer in the 
Module Name field and click Finish. 
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6. Accept the default values and click Finish.  
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7. Expand the created Business Integration Project and verify whether the 
artifacts are generated correctly. 
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Deploy the module to the test environment 

After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) import. You 
must install this SCA module in the IBM Integration Designer 
integration test client.  To do this, you must add the SCA module you 
created earlier to the server using the Servers view in IBM Integration 
Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 

2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.   

The Add and Remove Projects window lists the available projects in the 
IBM Integration Designer workspace. 

  

4. Select your project (TestExecuteSPSQLServerApp) and click Add  
to configure the project on the server. 
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5. Click Finish. 

Test the assembled adapter application   

Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

1. Select the TestExecuteSPSQLServer Module, right-click it, and 
select Test > Test Module. The Test Client window is displayed. 
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2. Select executeDboProcedure1U591BG operation.  
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3. Enter value for the input type var0.  

4. Unset the value for the output type var1 and return_value. 
Right-click u64return_value, and select Set To > Unset.  

 

An unset field is indicated by a ‘X’ mark. 
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5. To execute the service, click . 

6. In the Select Deployment location window, select the server, and 
click Finish. 

 

7. Check the output of the service, and check the data in the Enterprise 
Information System to ensure it matches the expected values.   
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Clear the sample content 

Return the data to its original state.   

Nothing is required to clean up after this tutorial. 
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C h a p t e r  1 3 .  Tutorial 12: Retrieve business 
object from database using user defined query 
(DB2) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
populates customer information into an application’s database using 
user defined query where CUSTOMER and ADDRESS tables have a 
parent-child relationship. 

About this task 

In this scenario, an application SCA component raises a retrieveAll test 
request to the JDBC Outbound Interface. The JDBC adapter executes a 
SQL query to select all specific records back. Finally, JDBC adapter 
convert the test result to a SDO and give a response to the SCA 
component. The following figure represents this scenario: 

 

Prerequisites to run the scenario 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables 

• Create an authentication alias 
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Create tables  

You must create the following tables in the DB2 database before 
starting the scenario. 

Script for creating the CUSTOMER and ADDRESS tables  

CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR(10) NOT NULL,  
    FNAME VARCHAR(20) ,  
    LNAME VARCHAR(20) ,  
    CCODE VARCHAR(10) , 
                      PRIMARY KEY(PKEY)); 

 

CREATE TABLE ADDRESS  ( 
    ADDRID VARCHAR(10) NOT NULL,  
    CUSTID VARCHAR(10) ,  
    CITY VARCHAR(20) ,  
    ZIPCODE VARCHAR(10), 
                      PRIMARY KEY(ADDRID) ) ; 

Create an authentication alias 

The authentication alias needs to be set because the adapter uses the 
username and password to connect to the database. This 
authentication alias will be used later when generating the artifacts for 
the module.  

Here are the steps to set the authentication alias in IBM Process Server 
administration console. 

1. In IBM Integration Designer, switch to the Servers view by selecting 
Window > Show View > Servers. 

 

473 



 

2. In the Servers view, right-click the server that you want to start and select 
Start. 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 

  

4. Log on to the administrative console. 
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5. In the administrative console, click Security -> Global security. 

6.  Under Java Authentication and Authorization Service, click 
J2C authentication Data.  

 

A list of existing aliases is displayed.  
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7. Uncheck Prefix new alias names with the node name of the 
cell(for compatibility with earlier releases). And click Apply 
button.

 
 

8. Click New to create a new authentication entry. Type the alias name, 
username and password to connect to the database. Click OK. 

 

9. Click Save to save the changes. 

 

You have created an authentication alias that will be used to configure 
the adapter properties. Restart the server for the changes to take 
effect. 

Configure the adapter for outbound processing  

Run the external service wizard to specify business objects, services, 
and configuration details. 

The wizard will guide you to do the following steps: 
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• Setting connection properties for the enterprise service discovery 
wizard  

• Selecting the business objects and services to be used with the 
adapter 

• Generating business object definitions and related artifacts 

Follow these instructions to launch the Enterprise Service Discovery 
(ESD) wizard. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration (default). 

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 

 

 

4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field enter CWYBC_JDBC. 

6. In the Target runtime environment field, select appropriate 
runtime and click Next. 

 

7. In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Outbound and click Next. 
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Set connection properties for the external service wizard 
To connect to the preferred database:   

1. Select the appropriate database server in the Database system 
connection information area.  

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   
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Database connection is established to retrieve the database schema. 

Select the business objects and services to be used with the adapter  
1. In the Find Objects in Enterprise System window, click Edit Query. 
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2. In the Specify the Query Properties window, select Create a query 
business object to build user-defined select statements check 
box and enter the number of query business objects you want to 
create. Click OK.   
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3. Click Run Query. 
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4. Span Expand the Query Statements node, select the Select Statement 1 

and click . The window to configure the query object is displayed. 
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5. In the Name of the business object field, type a name for the business 
object. The name can contain spaces and national language characters. 

6. In the Select statement field, type the SELECT statement you want to run. 
Indicate each parameter with a question mark (?). 

7. Click Validate. The Result area displays the result of the validation. Click 
OK. 

8. Click Next. 

Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, click the Advanced 
button, collapse the RetrieveAll configuration properties, accept 
the default values for all fields in this group and click Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps; 

a) Select Using an existing JAAS alias for security options 
under Deployment Properties. 

b) Enter the authentication alias that you created in previews 
section into the J2C Authentication data entry field.  

c) Clear the Join the global transaction check box.  

d) Select Specify local database connection information 
from the Database connection information list, and 
click Next. 
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3. Click New in the Specify the Location Properties window. 
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4. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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5. In the Create a Module window, type BOCustAddrDB2 in the 
Module Name field, and click Finish. 
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6. Accept the default values and click Finish.  
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Expand the created Business Integration Project and verify whether 
the artifacts are generated correctly. 
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Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System import. You must 
install this SCA module in the IBM Integration Designer integration test 
client. To do this, you must add the SCA module you created earlier to 
the server using the Servers view in IBM Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 

2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects.  

4. Add the BOCustAddrDB2App module to the server. 

 

5. Click Finish..  

Test the assembled adapter application   

Test the assembled adapter application using the IBM Integration 
Designer integration test client by following these steps:  
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1. Based on the SCA module file, sca.module, double-click to display it 
as an assembly diagram and right-click anywhere within the diagram 
to bring up the context menu for creating a test module, select Test 
Module. 

 

2. A test client is created with input fields. 

 

493 



 

A test client page is automatically created and displayed and it is ready 
to accept values before the test execution. The first invocation is 
created by default. Subsequent invocation can be created by clicking 

Invoke . 

3. Determine the type of operation. The verb prefix indicates the type of 
operation. For example, one of the operation names for selection, 
retrieveallTestQuery1BG, is a named combination of the verb 
prefix (retrieveall), business object name (TestQuery1BG), and an 
abbreviation for Business Graph (BG). 

4. Based on the type of operation, double-click the field under Value 
column for the corresponding field under Name column to enter an 
appropriate value. Simply, unset all existing Value fields of the 
relevant business object. 

 

5. To run the test client, click Continue   on the top of the page. The result 
of the test execution is displayed. 
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Clear the sample content 
After a record has been created with the IBM Integration Designer 
environment, it can be removed with the Delete operation, determine 
the key field that uniquely represent the record just created and enter 
its value. 
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C h a p t e r  1 4 .  Tutorial 13: Checking for the 
existence of a business object (Oracle) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
checks for the existence of a business object. 

About this task 

In this scenario, an application SCA component raises an existence test 
request to the JDBC Outbound Interface. The JDBC adapter executes a 
SQL query to determine whether specific records exist or not. Finally, 
JDBC adapter convert the test result to a SDO and give a response to 
the SCA component. The following figure represents this scenario: 

 

Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create a table 

• Create an authentication alias 

• Create a data source 
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Create a table 

You must create the following table in the Oracle database before 
starting the scenario. 

CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  

    CCODE VARCHAR2(10) ) ; 
 
Insert a record into the table you just created. 

insert into customer values ('1000', 'testFname', 
'testLname', 'testCcode') 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Window > Show View > Servers. 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 
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3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 

 

4. Log on to the administrative console.  

498 



 

 

5. Click Security  Global security. 

 

6. Under Java Authentication and Authorization Service, click J2C 
authentication Data. 
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A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 
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You have created an authentication alias that will be used to configure 
the adapter properties.  

 

Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. This data source will be used in generating 
the artifacts for the module.  

Note: This tutorial will use Oracle as the database and the Oracle thin 
driver, ojdbc6.jar.  

Here are the steps to create the data source in the IBM Process Server 
administrative console. 

1. In the administrative console, select Environment  WebSphere 
variables 
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2. On the right, click ORACLE_JDBC_DRIVER_PATH and specify the 
path of the ojdbc6.jar file in the Value field. Click OK. 

 

The variable is added and appears in the list.  

 

3. Select Resources  JDBC -> JDBC Providers. 
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4. Click New in the JDBC providers window. 

 

 

5. Click New. Select the Oracle database with a connection pool data 
source for the Oracle JDBC driver. Click Next. 
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6. In the Enter database classpath information page, enter the following 
value for the Class path field: 

$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time. 
Because you have added the ojdbc6.jar file to this path, you must 
specify that path here.  

7. Click Next. 
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8. Click Finish. 

 

9. Under Additional Properties, select Data sources. Click New. 
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10. Type any value in the JNDI name field, and select the authentication 
alias “OracleDS” that you created earlier from the 
Component-managed authentication alias and XA recovery 
authentication alias list. Click Next. 

 

11. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure.  Click Next. 
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12. In the Setup security aliases window, configure the aliases. 

 

13. In the Summary page, review the values entered for the data source 
and click Finish. 
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14.  Click Save to save the changes.  

 

15. Select the data source you just created and click Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database.  

Configure the adapter for outbound processing  
Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next.  
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4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 

 

5. In the Connector project field enter CWYBC_JDBC. 

6. In the Target runtime environment field, select appropriate 
runtime and click Next. 
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7.  In the JDBC driver JAR files field, click Add to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Outbound and click Next. 

 

Set connection properties for the external service wizard 
To connect to the Oracle database:  

1. Expand Oracle from Database system connection information then 
select 10. 

2. Enter values in the System ID, Host name, User name and Password 
fields, and click Next. 
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Select the business objects to be used with the adapter  

1. In the Find Objects in Enterprise System window, click Run Query. 
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2. In the Discovered objects pane, select the JABDULLA (for this tutorial 
only) node and expand it. Expand Tables, select the CUSTOMER 

table and click . Click Next. 

 

 

Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, accept the default 
values for the Maximum records for RetrieveAll operation and 
Business object namespace fields. Leave the Generate business 
graph for each business object fields check box selected and click 
Next. 
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2. In the Specify the Service Generation and Deployment Properties 
window, perform the following steps: 

a) Select Other for security options under Deployment 
properties.  

b) Clear the Join the global transaction check box.  

c) Select Specify predefined connection pool 
DataSource from the Database connection 
information list.  

d) Enter OracleDS in the Connection pool DataSource 
JNDI Name field, and click Next. 
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3. Click New in the Specify the Location Properties window.  

 

4. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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5. In the Create a Module window, type TestExists in the Module 
Name field and click Finish. 

 

6. In the Specify the Location Properties window, click Finish to finish 
the service creation.  
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7. Open the Project Explorer and verify that the business objects are 
created correctly. 
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Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) import. You 
must install this SCA module in the IBM Integration Designer 
integration test client to deploy it. To do this, you must add the SCA 
module you created earlier to the server using the Servers view in IBM 
Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 

2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects. 
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The Add and Remove Projects window lists the available projects in the 
IBM Integration Designer workspace.  
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4. In the Add and Remove Projects window, select your project 
(TestExistsApp) and click Add to configure the project on the server. 
Click Finish. 

 

Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

1. Select the TestExists module, right-click, and select Test > Test 
Module. The Test Client window is displayed. 
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2. Select existsJabdullaCustomerBG from the Operation list. 
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3. Right-click verb, select Set To > Unset. Enter 1000 for pkey, and 
unset lname, fname and ccode. 

 

4. To execute the service, click Continue . 

5. In the Select Deployment location window, select the server and click 
Finish. 
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6. Check the return value to ensure it matches expected values.  
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C h a p t e r  1 5 .  Tutorial 14: Generate Wrapper business 
objects for Inbound (Oracle) 

This tutorial demonstrates how WebSphere Adapter for JDBC 7.5.0.0 
retrieves customer information from an application’s database. A 
wrapper business object is used to retrieve records from multiple 
tables with one event entry.  

About this task 

This scenario illustrates the ability of WebSphere JDBC adapter to 
interact with database by polling database event from an event table. 
In this scenario, a legacy application makes some change of the 
CUSTOMER table and the GOODS table in a single operation. Then, 
insert an event entry record into the event table 
(WBIA_EVENT_TABLE). Then, the event will be polled by JDBC adapter 
and send it to one SCA component. JDBC adapter screen all the 
database operation details, event quality assuring details and provide 
a simple event interface for the application component. The following 
figure shows the whole scenario: 
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This case has three steps: 

1. The legacy application will make the changes and then generate an 
event record. For simplify reason, we will insert records using SQL 
statement directly.  

2. JDBC adapter will poll the event from database periodically. Thus, it 
will find the new events and fetch the event and corresponding 
business objects from database.  

3. At last, JDBC adapter will convert the event to a SDO and send it to 
the destination SCA component. 

Prepare to run through the tutorial 

Extract the sample files 
Replicas of the artifacts that you create when using the external 
service wizard are provided as sample files for your reference. Use 
these files to verify if the files you create using the external service 
wizard are correct. 

Download the sample zip file and extract it into a directory of your 
choice (you may want to create a new directory). 

Configuration prerequisites 

Before configuring the adapter, you must complete the following tasks: 

• Create tables 

• Create an authentication alias 

• Create a data source 

Create tables  

You must create the following tables in the Oracle database before 
starting the scenario. 
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CREATE TABLE CUSTOMER  ( 
    PKEY VARCHAR2(10) NOT NULL PRIMARY KEY,  
    FNAME VARCHAR2(20) ,  
    LNAME VARCHAR2(20) ,  
    CCODE VARCHAR2(10) ) ; 
       
       
CREATE TABLE CUSTADD  ( 
    ADDRID VARCHAR2(10) NOT NULL PRIMARY KEY,  
    CUSTID VARCHAR2(10) ,  
    CITY VARCHAR2(20) ,  
    ZIPCODE VARCHAR2(10) ) ; 

 
 

CREATE TABLE WBIA_JDBC_EVENTSTORE 
( 
 EVENT_ID INTEGER NOT NULL  PRIMARY KEY, 
 XID    VARCHAR2(200), 
 OBJECT_KEY   VARCHAR2(80)  NOT NULL, 
 OBJECT_NAME  VARCHAR2(40)  NOT NULL, 
 OBJECT_FUNCTION  VARCHAR2(40)  NOT NULL, 
 EVENT_PRIORITY      INTEGER   NOT NULL, 
 EVENT_TIME   TIMESTAMP,   
 EVENT_STATUS  INTEGER   NOT NULL, 
 EVENT_COMMENT  VARCHAR2(100) 

    ); 
 
Insert records into the tables we just created. 
 

INSERT INTO CUSTOMER (PKEY, FNAME, LNAME, CCODE) 
VALUES ('C1', 'JONE', 'TIGER', '1'); 
INSERT INTO CUSTOMER (PKEY, FNAME, LNAME, CCODE) 
VALUES ('C2', 'ROTH', 'GREEN', '1'); 
INSERT INTO CUSTADD (ADDRID, CUSTID, CITY, ZIPCODE) 
VALUES ('A1', 'C1', 'BEIJING', '100000'); 
INSERT INTO CUSTADD (ADDRID, CUSTID, CITY, ZIPCODE) 
VALUES ('A2', 'C2', 'SHANGHAI', '200000'); 

Create an authentication alias 

The authentication alias needs to be set because the data source 
created in the next section uses the username and password set in the 
authentication alias to connect to the database.  

Follow these steps to set the authentication alias in the IBM Process 
Server administrative console.  

1. In IBM Integration Designer, switch to the Servers view by selecting 
Windows > Show View > Servers. 

528 



 

 

2. In the Servers view, right-click the server that you want to start and 
select Start. 

 

 

3. After the server is started, right-click the server, and select 
Administration > Run administrative console. 
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4. Log on to the administrative console.  

 

5. Click Security  Global security. 
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6. On the right, click J2C Authentication Data under Java 
Authentication and Authorization Service. 
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A list of existing aliases is displayed.  

 

7. Click New to create a new authentication entry. Type the alias name, 
and username and password to connect to the database. Click OK. 

 

8. Click Save to save the changes. 
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You have created an authentication alias that will be used to configure 
the data source.  

 

Create a data source 

Create a data source in IBM Process Server, which the adapter will use 
to connect to the database. Here are the steps to create the data 
source in the IBM Process Server administrative console. This data 
source will be used later when generating the artifacts for the module.  

Note: This tutorial will use Oracle as the database and the Oracle thin 
driver, ojdbc6.jar.  

1. In the administrative console, select Environment  WebSphere 
Variables. 
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2. On the right, select ORACLE_JDBC_DRIVER_PATH and specify the 
path of the ojdbc6.jar file in the Value field. Click OK. 

534 



 

 

3. Click Save to save the changes. 

 

The variable is added and appears in the list.  
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4. Select Resources  JDBC -> JDBC Providers. 

 

5. Click New in the JDBC providers window. 
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6. Select Oracle database with a connection pool data source for the 
Oracle JDBC driver. Click Next. 
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7. In the Enter database classpath information page, enter the 
following value for the Class path field: 
$(ORACLE_JDBC_DRIVER_PATH)/ojdbc6.jar, where 
$(ORACLE_JDBC_DRIVER_PATH) is library path for the run time.  

8. Click Next. 
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9. In the Summary page, click Finish.  

 

10. Click Save to save the changes. 
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The JDBC provider is added and appears in the list. 

 

11. Select the Oracle JDBC provider you created. Under Additional 
Properties, select Data sources. Click New. 
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12. Type any value in the JNDI name field, and select the authentication 
alias. Click Next. 

 

13. Provide the appropriate URL value and select a data store helper class 
name from the Data store helper class name list as shown in the 
following figure. Click Next. 
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14. Select the authentication alias you just created from the 
Component-managed authentication alias field and click Next. 

 

15. In the Summary page, review the values entered for the data source 
and click Finish.  
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16. Click Save to save the changes. 

 

17.  Select the newly created data source and click Test connection. 
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The connection should succeed as indicated by the message shown in 
the following figure. If you experience problems with the test 
connection, refer to the “Troubleshooting” section. 

 

The data source is created and it will be used by the adapter to connect 
to the database. 

 

Configure the adapter for inbound processing  
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Run the external service wizard to specify business objects, services, 
and configuration details. 

1. Switch to the Business Integration Perspective in IBM Integration 
Designer by selecting Window -> Open Perspective Business 
Integration.  

2. Start the external service wizard by selecting File-> New –> 
External Service. 

3. In the Available Types area, select Adapters > JDBC and click 
Next. 

 

4. Select the IBM WebSphere Adapter for JDBC (IBM: 7.5.0.0) and 
click Next. 
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5. In the Connector project field, enter CWYBC_JDBC. 

6. In the Target runtime environment field, select the appropriate 
runtime and click Next. 
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7. In the JDBC driver JAR files field, click Add, to add the JDBC driver 
class to connect to the database. Browse to select the driver JAR file 
and click Next. 
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8. Select Inbound and click Next. 

 

Set connection properties for the external service wizard 
To connect to the Oracle database: 

1. Expand the Oracle node in the Database system connection 
information area and select 10. 

2. Enter values in the System ID, Host name, Port number, User 
name and Password fields, and click Next.   
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Select the business objects to be used with the adapter  

1. In the Find Objects in Enterprise System window, click Run Query. 
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2. In the Discovered objects pane, expand the SAMPLE (for this tutorial 
only) node, select Tables and expand it. 

3. Select the CUSTOMER and CUSTADD tables and click .  

4. Click Next. 
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Generate business object definitions and related artifacts 
Follow these steps to generate the business object definitions. 

1. In the Specify Composite Properties window, click Add and enter the 
name for the new wrapper business object. Click OK. 

551 



 

 

2. In the Table, view, synonym, or nickname child objects for the 
selected wrapper area, click Add to add CUSTOMER and CUSTADD 
table business objects for the wrapper. 
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3. In the Service functions for selected wrapper object area, click 
Add to add functions for the wrapper. 
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4. Accept the default for the other fields, and click Next. 
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5. In the Specify the Service Generation and Deployment Properties 
window, select the security credential as Other. Select Specify 
predefined DataSource form the Database connection 
information list. 
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6. In the DataSource JNDI name field, enter the JNDI name of the 
data source, which you created in the previous section. Click Next.  
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7. Click New in the Specify the Location Properties window.  

 

8. In the Select a Business Integration Project Type window, select 
Module and click Next. 
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9. In the Create a Module window, type TestWrapperInbound in the 
Module Name field, click Finish. 
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10. In the Specify the Location Properties window, click Finish to finish 
the wizard.  
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11. Expand the created Business Integration Project and verify whether 
the artifacts are generated correctly. 

 

Set up the components to be part of the inbound environment 
Next, we add and set up components that to be part of the inbound 
environment. 

1. In the Assembly Diagram, in the Palette, expand Components and 
click Java component.  
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2. Click anywhere in the TestWrapperInbound -Assembly Diagram 
window (white part) to create the Java component, Component1. 

 

3. To wire JDBCInboundInterface to Component1 hover the cursor 
over the right end of JDBCInboundInterface until a yellow wire 
appears. 
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4. Click on the yellow wire and drag it to the left end of Component1. 
When the Add Wire pop-up window displays click OK. 

 

5. Click File > Save from the toolbar to save changes made. 

6. Right-click on Component1 in the Assembly Diagram and select 
Generate implementation. 
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7. In the Generate Implementation window, select default package 
and click OK. 
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8. The Java Editor will open showing the Component1Impl.java file. 
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9. Scroll down and locate the createwrapperBG method. 

10. Replace the entire method so that it looks like the one shown below: 
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 public void createwrapperBG( 
   DataObject wrapper = 
createwrapperBGInput.getDataObject("wrapper"); 
  
 System.out.println("-----------------------------"); 
   System.out.println("Wrapper was created."); 
   DataObject customer = (DataObject) 
wrapper.getList("customerobj").get(0); 
   DataObject addr = (DataObject) 
wrapper.getList("custaddobj").get(0); 
   System.out.println("CUSTOMER info as below:"); 
   System.out.println("PKEY is: "+ 
    customer.getString("pkey")); 
   System.out.println("FNAME is: "+ 
    customer.getString("fname")); 
   System.out.println("LNAME is: "+ 
    customer.getString("lname")); 
   System.out.println("CCODE is: "+ 
    customer.getString("ccode")); 
   System.out.println(); 
   System.out.println("CUSTADD info as below:"); 
   System.out.println("ADDRID is: "+ 
     addr.getString("addrid")); 
   System.out.println("CUSTID is: "+ 
     addr.getString("custid")); 
   System.out.println("CITY is: "+ 
     addr.getString("city")); 
   System.out.println("ZIPCODE is: "+ 
     addr.getString("zipcode")); 
  
 System.out.println("-----------------------------"); 
   System.out.println(); 
 } 

11. Scroll down and locate the deletewrapperBG method. 

12. Replace the entire method so that it looks like the one shown below: 

public void deletewrapperBG( 
DataObject deletewrapperBGInput) {  
  DataObject wrapper = 
deletewrapperBGInput.getDataObject("wrapper"); 
  System.out.println("-----------------------------"); 
  System.out.println("Wrapper was deleted."); 
  System.out.println("PKEY of customer is: "+ 
   wrapper.getString("wrapcustomerpkey")); 
  System.out.println("ADDRID custadd is: "+ 
   wrapper.getString("wrapcustaddaddrid")); 
  System.out.println("-----------------------------"); 
  System.out.println(); 
 } 

13. Scroll down and locate the updatewrapperBG method. 

14. Replace the entire method so that it looks like the one shown below: 
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public void updatewrapperBG( 
DataObject updatewrapperBGInput) {  
  DataObject wrapper = 
updatewrapperBGInput.getDataObject("wrapper"); 
  System.out.println("-----------------------------"); 
  System.out.println("Wrapper was updated."); 
  DataObject customer = (DataObject) 
wrapper.getList("customerobj").get(0); 
  DataObject addr = (DataObject) 
wrapper.getList("custaddobj").get(0); 
  System.out.println("CUSTOMER info as below:"); 
  System.out.println("PKEY is: "+  
   customer.getString("pkey")); 
  System.out.println("FNAME is: "+ 
   customer.getString("fname")); 
  System.out.println("LNAME is: "+ 
   customer.getString("lname")); 
  System.out.println("CCODE is: "+ 
   customer.getString("ccode")); 
  System.out.println(); 
  System.out.println("CUSTADD info as below:"); 
  System.out.println("ADDRID is: "+ 
    addr.getString("addrid")); 
  System.out.println("CUSTID is: "+ 
    addr.getString("custid")); 
  System.out.println("CITY is: "+ 
    addr.getString("city")); 
  System.out.println("ZIPCODE is: "+ 
    addr.getString("zipcode")); 
  System.out.println("-----------------------------"); 
  System.out.println(); 
 } 

15. Click on File > Save from the toolbar to save the changes made. 

Deploy the module to the test environment 
After running the external service wizard, you will have an SCA module 
that contains an Enterprise Information System (EIS) export. You 
must install this SCA module in the IBM Integration Designer 
integration test client to deploy it. To do this, you must add the SCA 
module you created earlier to the server using the Servers view in IBM 
Integration Designer.  

Steps for adding the SCA module to the server: 

1. In IBM Integration Designer, switch to the Servers view by selecting 
from the toolbar Window > Show View > Servers. 

2. In the Servers tab in the lower-right pane right click the server, and 
select Start. 

3. After the server is started, right-click the server, and select Add and 
Remove projects. 
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A window is displayed that shows the available projects on the IBM Integration 
Designer workspace.  
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4. In the Add and Remove Projects window, select your project 
(TestWrapperInbound) and click Add to configure the project on the 
server. Click Finish. 

570 



 

 

 

Test the assembled adapter application   
Test the assembled adapter application using the IBM Integration 
Designer integration test client.   

  

1. In the Business Integration view right-click on the 
TestInboundWrapper module, and select Test > Attach.  
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2. To execute the service, click . 

3. Execute below SQL scripts to generate events:  

INSERT INTO WBIA_JDBC_EVENTSTORE  
 (EVENT_ID,OBJECT_KEY,OBJECT_NAME,OBJECT_FUNCTIO
N,EVENT_PRIORITY,EVENT_TIME,EVENT_STATUS) VALUES  
 (1,'A1;C1','WrapperBG','Create',1, 
SYSTIMESTAMP,0); 
INSERT INTO WBIA_JDBC_EVENTSTORE  
 (EVENT_ID,OBJECT_KEY,OBJECT_NAME,OBJECT_FUNCTIO
N,EVENT_PRIORITY,EVENT_TIME,EVENT_STATUS) VALUES  
 (2,'A2;C2','WrapperBG','Update',1, 
SYSTIMESTAMP,0); 
INSERT INTO WBIA_JDBC_EVENTSTORE  
 (EVENT_ID,OBJECT_KEY,OBJECT_NAME,OBJECT_FUNCTIO
N,EVENT_PRIORITY,EVENT_TIME,EVENT_STATUS) VALUES  
 (3,'A3;C3','WrapperBG','Delete',1, 
SYSTIMESTAMP,0); 

Note: in a real environment, a trigger or another application, which can 
access the database, may insert the event record. 

4. Check the output of the service: 
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C h a p t e r  1 6 .  Troubleshooting 
1. Symptom: Error while attempting to connect to Oracle database 

with Enterprise Metadata Discovery tool. 

Resolution: 

Verify whether the connection parameters have been entered 
correctly. 

2. Symptom: There are no tables listed in the tree view the 
Discovered objects area. 

Resolution: 

Verify whether the tables are added to the Supported database 
object types property in the Query Properties window. 

3. Symptom: A ClassNotFoundException exception is generated from 
the external service wizard or at runtime: 

Cause: This is usually caused by configuration issues with the Oracle 
JDBC driver path. 

Resolution:  

Verify that the WebSphere variable such as 
ORACLE_JDBC_DRIVER_PATH is the path contains the JDBC DB driver. 

Verify that the oracle driver jar is exactly the jar required. 

4. Symptom: A primary key does not exist exception is generated from 
the external service wizard or at runtime. 

Cause: The table does not have a primary key defined. Hence, the 
PrimaryKey ASI on the business object is not set to true. 

Resolution:  

Define a primary key in the table. 

Set a PrimaryKey column on the business object. 

5. Symptom: A record already exists exception is generated at 
runtime. 

Cause: A record with the primary key already exists in the database.  

Resolution:  

Insert a record with a primary key that does not exist in the database. 

6. Symptom: Test failed with following Exception message: 
javax.resource.ResourceException: LoginException getting Subject, 
and with following Exception trace.  
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Caused by: 
javax.security.auth.login.LoginException: 
Incorrect authDataEntry and alias is: <AliasName> 
 at 
com.ibm.ws.security.auth.j2c.WSDefaultPrincipalMap
ping.getMappedSubject(WSDefaultPrincipalMapping.ja
va:505) 
 at 
com.ibm.ejs.j2c.PrivExAction.run(PrivExAction.java
:145) 
 ... 53 more 

Cause: This is usually caused by configuration issues such as incorrect 
J2C Authentication Data Entry value entered in the Service Generation 
and Deployment Configuration window. 

Resolution: 

Verify that the authentication alias is a full authentication alias which 
could be exactly found in the JAAS - J2C authentication data view 
under administrative console. 
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C h a p t e r  1 7 .  Notices 
This information was developed for products and services offered in 
the U.S.A. 

IBM may not offer the products, services, or features discussed in this 
document in other countries. Consult your local IBM representative for 
information on the products and services currently available in your 
area. Any reference to an IBM product, program, or service is not 
intended to state or imply that only that IBM product, program, or 
service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may 
be used instead. However, it is the user's responsibility to evaluate and 
verify the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject 
matter described in this document. The furnishing of this document 
does not grant you any license to these patents. You can send license 
inquiries, in writing, to: 

IBM Director of Licensing 

IBM Corporation 

North Castle Drive 

Armonk, NY 10504-1785 

U.S.A. 

For license inquiries regarding double-byte (DBCS) information, 
contact the IBM Intellectual Property Department in your country or 
send inquiries, in 

writing, to: 

IBM World Trade Asia Corporation Licensing 

2-31 Roppongi 3-chome, Minato-ku 

Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom 
or any other country where such provisions are inconsistent 
with local law:  

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical 
errors. Changes are periodically made to the information herein; these 
changes will be incorporated in new editions of the publication. 

IBM may make improvements and/or changes in the product(s) and/or 
the program(s) described in this publication at any time without notice. 
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Any references in this information to non-IBM Web sites are provided 
for convenience only and do not in any manner serve as an 
endorsement of those Web sites. 

The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way 
it believes appropriate without incurring any obligation to you. 

Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between 
independently created programs and other programs (including this 
one) and (ii) the mutual use of the information which has been 
exchanged, should contact: 

IBM Corporation Department  

2Z4A/SOM1 294 Route 100  

Somers, NY 10589-0100 U.S.A. 

Information concerning non-IBM products was obtained from the 
suppliers of those products, their published announcements or other 
publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any 
other claims related to non-IBM products. Questions on the capabilities 
of non-IBM products should be addressed to the suppliers of those 
products. 

This information contains examples of data and reports used in daily 
business operations. To illustrate them as completely as possible, the 
examples include 

the names of individuals, companies, brands, and products. All of 
these names are fictitious and any similarity to the names and 
addresses used by an actual business enterprise is entirely 
coincidental. 

COPYRIGHT LICENSE: 

This information contains sample application programs in source 
language, which illustrate programming techniques on various 
operating platforms. You may copy, modify, and distribute these 
sample programs in any form without payment to IBM, for the 
purposes of developing, using, marketing or distributing application 
programs conforming to the application programming interface for the 
operating platform for which the sample programs are written. These 
examples have not been thoroughly tested under all conditions. IBM, 
therefore, cannot guarantee or imply reliability, serviceability, or 
function of these programs. 

If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 

Programming interface information 

Programming interface information, if provided, is intended to help you 
create application software using this program. 

General-use programming interfaces allow you to write application 
software that obtain the services of this program's tools. 
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However, this information may also contain diagnosis, modification, 
and tuning information. Diagnosis, modification and tuning 
information is provided to help you debug your application software. 

Warning: 

Do not use this diagnosis, modification, and tuning information as a 
programming interface because it is subject to change. 
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Trademarks  

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corporation in the United States, other countries, or 
both. These and other IBM trademarked terms are marked on their first occurrence in 
this information with the appropriate symbol (® or ™), indicating US registered or 
common law trademarks owned by IBM at the time this information was published. Such 
trademarks may also be registered or common law trademarks in other countries. A 
complete and current list of IBM trademarks is available on the Web at 
http://www.ibm.com/legal/copytrade.shtml 

Linux is a registered trademark of Linus Torvalds in the United States, other countries, 
or both. 

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, 
other countries, or both. 

Java and all Java based trademarks and logos are trademarks of Sun Microsystems, 
Inc. in the United States, other countries, or both. 

UNIX is a registered trademark of The Open Group in the United States and other 
countries. 

Other company, product, or service names may be trademarks or service marks of 
others. 

This product includes software developed by the Eclipse Project 
(http://www.eclipse.org). 
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